TJ引擎制作版本流程

简介：
 特戒引擎兼容GOM引擎命令与数据格式，可直接将GOM引擎的数据导出直接做成手游版本

特戒引擎会提供：资源编辑器、GM编辑器这两个工具来制作版本

同时特戒引擎会提供一个完整的版本作为示例（QQ群:726565751）
第一步：复制版本文件
 1.版本只保留Mir200和Mud2这两个文件夹（注意区分大小写）

2.删除Mir200里面的所有exe.dll文件，以及其他无用文件（包括插件、日志文件夹、第三方文件等）

 3.删除Mir200里的MAP文件夹

 4.删除Mud2-DB下的文件，将导出的DB数据放入这个文件夹（下文有导出DB数据的方法）

 5.将示例版本中的Tejieconfig文件夹复制到Mir200文件夹下

做好以上五步即可使用资源编辑器进行游戏内内容编辑了！！！

第二步：DB数据库表编辑（导DB库）
 将GOM引擎的Magic.DB Monster.DB Stditems.DB 导出成CSV格式

 将导出的CSV放到Mud2/DB文件夹下

第三步：Tejieconfig文件夹（特戒引擎专有配置）
 将示例版本Mir200下的Tejieconfig文件夹复制到自己版本对应目录下

 （Tejieconfig文件夹下有Tejieconfig.txt配置文件，该配置中配置特戒独有功能）

第四步：使用资源编辑器编辑资源
 1.地图列表中编辑地图资源

 2.NPC列表中编辑NPC资源

 3.怪物列表中编辑怪物资源

 4.物品列表中编辑：道具、装备资源

 5.我要编辑NPC中编辑NPC坐标

 6.我要编辑安全区中编辑安全区

 7.我要编辑传送点中编辑地图传送点

 8.MAPMOVE命令、MONGENEX命令坐标编辑

 9.我要编辑怪物中编辑刷怪坐标（可不编辑系统会自动找合法坐标）

将资源编辑完成后，即可使用GM编辑工具进行开服了

第五步：使用GM编辑工具开服与进入游戏
 GM编辑工具账号由特戒引擎提供，一个账号对应一台服务器

 将GM编辑工具下的config.txt配置下的basePath=路径修改为自己本地的路径

 使用账号密码登陆GM编辑工具后，点击重载数据，重载成功后点击重启，重启成功即可进入游戏了。

 游戏安装包下载地址请联系特戒引擎官方，电脑端可使用雷电模拟器安装游戏

 成功安装游戏后，进入游戏版本号输入自己的GM编辑器账号即可登录自己的服


官方主页

资源编辑器使用使用说明

第一步：路径配置
 将TeJieEditor\TeJieEditor_Data\StreamingAssets文件夹下的TeJieEditorConfig.txt中的路径修改为本地版本的路径

修改成功后启动TejieEditor.exe即可进行编辑了

注意：在编辑时不要打开DB表和脚本文件，因为在编辑的时候会对这些文件进行读写

地图资源的编辑：
 在编辑器中选择地图列表；编辑器会拉取MapInfo.txt 中配置的所有场景，并可以直接在编辑中修改对应地图使用的美术资源

更改地图美术资源：
 操作方法：资源编辑左侧地图列表中选地图，然后在右侧的地图资源库中使用地图资源即可。

地图内容编辑：
 在左侧列表中选择地图后，点击“显示场景地图”即可进入针对这张地图的内容编辑
 进入地图内容编辑模式后，在编辑器中会显示出对应的场景，可直接在场景中加载：怪物、NPC、传送点、安全区
 在界面中点击要编辑的内容，会将配置的内容显示加载的内容显示在场景中，左键进行拖动改变坐标，右键可进行编辑；编辑完成后点击保存即可

NPC资源的编辑：
 在编辑器中选择NPC列表；编辑器会拉取MerChant.txt 中配置的所有NPC，并可以直接在编辑中修改NPC使用的美术资源

更改NPC美术资源：
 操作方法：资源编辑左侧NPC列表中选NPC，然后在右侧的NPC资源库中使用NPC资源即可。

怪物资源的编辑：
 在编辑器中选择怪物列表；编辑器会拉取Monster.csv 中配置的所有怪物，并可以直接在编辑中修改怪物使用的美术资源

更改怪物美术资源：
 操作方法：资源编辑左侧怪物列表中选怪物，然后在右侧的怪物资源库中使用即可。

装备、道具资源的编辑：
 在编辑器中选择物品；编辑器会拉取StdItems.csv 中配置的所有装备和道具，并可以直接在编辑中修改道具装备的图标和外显模型

更改道具、装备图标和外显基础操作方式：
 操作方法：资源编辑左侧物品列表中选物品，然后在右侧的图标资源库中使用即可。

道具类型筛选功能：
 在道具列表上方可通过类型对装备单独进行编辑，选择类型后列表中将只会显示出对应类型的装备

资源库类型筛选功能：
 编辑器右上角两个按钮可对资源库中的资源进行分类显示，选择后资源库中只会显示对应类型的资源

拥有外显的装备编辑：
 衣服、武器、斗笠、时装武器、时装衣服拥有外显
 在列表中选择这些类型的装备后，资源库会自动跳转至对应的资源库，在资源库中选择后图标和外显会同时进行修改

特戒引擎特有功能：翅膀编辑：
 衣服、时装衣服、65军鼓、53宝石、48盾牌、29天使、30照明物、28马牌这些类型的道具可配置翅膀外显
 这些类型的装备在列表中显示会显示出一个+号，点击+号即可给对应的装备配置翅膀外显
 装备翅膀外显数据会存储在StdItems.csv 中的Value20列

mapmove命令编辑：
 选择mapmove命令编辑后编辑器会把脚本中所有用到mapmove命令传送的地图显示出来
 点击列表中的地图，即可进入mapmove坐标编辑模式，左键拖动坐标球即可改变位置
 编辑完成后点击保存即可

mongenex命令编辑：
 选择mongenex命令编辑后编辑器会把脚本中所有用到mongenex命令刷怪的地图显示出来
 点击列表中的地图，即可进入mongenex坐标编辑模式，左键拖动怪物即可改变位置，右键点击可以修改刷怪范围和刷怪数量
 编辑完成后点击保存即可

我要编辑NPC：
 选择我要编辑NPC后编辑器会把所有拥有NPC的地图显示出来
 点击列表中的地图，即可进入NPC坐标编辑模式，左键拖动NPC即可改变位置
 编辑完成后点击保存即可

我要编辑传送点：
 选择我要编辑传送点后编辑器会把所有拥有传送点的地图显示出来
 点击列表中的地图，即可进入传送坐标编辑模式，左键拖动NPC即可改变位置，右键点击传送点可对传送点进行删除
 编辑完成后点击保存即可

我要编辑传送点：
 选择我要编辑传送点后编辑器会把所有拥有传送点的地图显示出来
 点击列表中的地图，即可进入传送坐标编辑模式，左键拖动NPC即可改变位置，右键点击传送点可对传送点进行删除
 编辑完成后点击保存即可

我要编辑安全区：
 选择我要编辑安全区后编辑器会把所有拥有安全区的地图显示出来
 点击列表中的地图，即可进入安全区编辑模式，左键拖动安全区即可改变位置，右键点击安全区可对安全区的范围进行修改
 编辑完成后点击保存即可

可调用UI资源与可调用特效资源：
 可调用UI资源资源库中的图片可供脚本调用，可调用特效资源库中的资源可供脚本调用


官方主页

GM编辑器使用使用说明

1.路径配置
 GM编辑器目录下的config.txt中的路径修改为本地版本的路径

修改成功后启动TejiePlatform.exe即可进行编辑了

重载数据：
 重载数据可以将本地的脚本文件与DB文件加载到服务器，加载后即可生效

 首次做版本需要首先加载数据后在启动服务器

重启：
 重启按钮可将服务器开启和重新启动

 服务器没开启时点击可将服务器启动，服务器开启中点击可将服务器重新启动

关服与清库：
 关服：将服务器关闭；清库：将服务器数据清除

 清库的时候需要先关闭服务器才能进行操作

GM编辑器中的其他功能：
 GM编辑中集合了GOM引擎M2的配置功能

 操作与GOM引擎相同


TJ引擎tejieconfig配置说明-20221108有更新

TJ引擎tejieconfig配置文件配置说明

简介：

1.tejieconfig配置为特戒引擎独有且必要的文件，没有这个文件服务器启动不起来

 2.该配置的文件路径为：Mir200\Tejieconfig

 3.在这个配置中配置了特戒引擎独有的功能

tejieconfi g详细介绍：

;特戒通用配置
[tjconfig]
;宝石镶嵌显示的标题名称
gemtittle=[宝石镶嵌]
;镶嵌宝石后是显示宝石名称还是显示具体的属性0显示具体属性，1显示宝石名称，2显示宝石自定义的描述（描述配置在tejieconfig：[gemTips]）
showgem=0
;角色的初始攻速：startSpeed=初始物攻速度,初始法攻速度
startSpeed=30,30
;角色的初始攻速是否显示在属性界面中（默认为显示，不配置也为显示；0为不显示，1为显示）：
startSpeedShow=0
;OK框中的文字按钮是否放大（0放大，1不放大）
okBtnSize=1
;是否开启装备对比功能（0不开启，1开启）默认为不开启状态
equipcomparison=0
;是否开启自动生成传送点特效(0不开启，1开启）默认为不开启
teleportEffect=1
;是否开启自动复活功能(0不开启，1开启）默认为不开启
AutomaticResurrection=1
;自动复活所需要的货币类型（支持定义好的7种货币,默认为元宝（GAMEGOLD、GOLDCOUNT、CREDITPOINT、GAMEPOINT、GAMEDIAMOND、GAMEGIRD、GAMEGLORY））
AutomaticResurrectionType=GOLDCOUNT
;自动复活所需货币数量(默认为1000)
AutomaticResurrectionSpeed=8000
;哪些地图不允许使用自动复活，配置格式为（场景编号,场景编号,场景编号）
AllowAutoResurrection=3,0122,0133
;通过KILLMONBURSTRATE增加的爆率是否显示到属性界面中（默认为显示，0为不显示，1为显示）
KILLMONBURSTRATESHOW=1
;通过CHANGESPEED增加的攻速是否显示到属性界面中（默认为显示，0为不显示，1为显示）
CHANGESPEEDSHOW=1
;发送世界消息是否需要千里传音（0不需要，1需要；默认是需要）
worldnewsneed=0
;战斗力算法和装备对比是否开启三职业模式，开启后（战士将不计算道术和魔法攻击，法师将不计算物理和道术攻击，道士将不计算物理和魔法攻击）（0不开启，1开启）默认是不开启状态
threecareermodels=0
;角色死亡是否弹出默认的复活界面（0不弹出，1弹出）默认是弹出
resurrection=1
;多少级允许在世界频道发言（默认等级为20级，不配置的话是20级允许发言）
shoutinglevel=40
;切换至后台后多久掉线配置（单位毫秒，默认为立即掉线）
offlineTime=5000
;世界频道发言时间间隔（单位秒）；默认时间为20秒
SpeakingTime=30
;召唤的人形宠移动速度是读取表中的移动速度还是与主角移动速度相同（0.与主角移动速度相同，1.读取表中的移动速度。（默认为与主角速度相同））：
HumanForPetSpeed=1
;是否显示怪物等级(0不开启，1开启;默认为不开启状态）
showMonLevel=0
;任务页签是否显示 0-不显示 1-显示 默认0是不显示
taskview=0
;是否显示外显时装（0不显示，1显示）默认为显示
FashionShow=1
;复活CD 单位-秒，不写默认是60（复活效果CD时间）
reliveCd=120
;是否开启新加的时装时装装备位（新加了四个） 1-开启 0-不开启 默认是0，不开启。
openfashion20=0
openfashion21=0
openfashion22=0
openfashion23=0
;是否开启新加的装备页的装备位（新加了两个） 1-开启 0-不开启 默认是0，不开启。
openequip24=0
openequip25=0
;物品使用间隔： 单位毫秒， 不写默认是500毫秒
useitemcd=1000
;吃药时间间隔： 单位毫秒， 不写默认是500毫秒
eatMedicineTimeInterval=1000
;是否开启排行榜功能（0为不开启，1为开启）不配置默认为开启
OPENRANKINGLIST=1
;是否开启自动穿戴功能（开启后获得好的装备会弹出自动穿戴界面）(=1时开启，默认为不开启)
openautomaticwear=1
;是否开启交易，默认为开放（1开放，0不开放）
ifopentransaction=1
;是否显示自动挂机按钮，默认为显示（0不显示，1显示）
ShowAutomatic=0
;物理伤害减少百分比属性最大生效值（如果不配置则按照面板属性计算）
PhyDamageReduction=50
;魔法伤害减少百分比属性最大生效值（如果不配置则按照面板属性计算）
MagDamageReduction=50
;血条上方是否显示出具体血量值（默认为不显示，0不显示，1显示）
BloodVolumeNum=1
;目标头像上显示的血量是百分比值还是具体值（默认为百分比值，0百分比，1具体值）
BloodVolume=1
;角色默认移动速度 (支持浮点型)
initOriMoveSpeed=3.3
;双龙斩技能CD（单位秒，不配置则走默认的CD）
Skill40CD=10
;飓风破技能CD（单位秒，不配置则走默认的CD）
Skill52CD=10
;嗜血术技能CD（单位秒，不配置则走默认的CD）
Skill57CD=10
;是否开启背包扩容模式（默认为不开启，0不开启，1开启）
BagExpansion=1
;暴击伤害系数， 默认是1.5倍, 不配置也是1.5倍
critDamageRate=2.3
;野蛮冲撞和擒龙手优先判断转生等级在tejieconfig中增加一个开关 0-优先转生等级 1-优先等级 ， 默认为0
renewLevelOrOnlyLevel=1
;补丁资源名称，逗号分隔
patch=shiwu,wy,fugu,anniu
;是否使用新自定义的OK框（开启后使用新的基于像素算法的OK框）(=1时开启，默认为不开启)
isUseCustomOKPanel=0
;是否启用新的伤害减免计算方式(默认为不开启，{=1时的公式：伤害*（伤害加成 + 100） /100 - 防御 *伤害减免 } ；{=2时的公式：[攻击力-目标防御*(100-忽视防御)%]*(100+攻击伤害-目标伤害减免)%)}
isUseNewDamageAntiRate=2
;技能抵抗百分比最大生效值（如果不配置则按照实际生效属性计算）
SkillResistance=50
;是否显示小地图随机传送功能（0不开启，1开启）
maptransButton=0
;是否显示小地图回城传送功能（0不开启，1开启）
goMapButton=0
;战斗力排行榜是否显示战力数值（默认1，1显示，0不显示）
RankingListFightPower=1
;开启后自动召唤技能不判断是否有拾取宝宝，只判断战宠，无战宠时自动召唤，默认0不开启，1开启
AutoRecallMob=0
; 忽视防御百分比最大生效值（如果不配置则按照实际生效属性计算）
ignoredefense=50
;脱战回复血量设置（数值代表百分比，如BloodReturnVelocity=10代表每秒回血10%，默认为10%，0为不回复）
BloodReturnVelocity=10
;是否开启时装柜 0不开启，使用现有时装功能； 1开启 默认为0
openwardrobe=0
;changemodeex是否对玩家也隐身(默认为0，不隐身 ；1隐身)
invisibeltoplayers=0
;自动穿戴倒计时（不设置默认为10）单位（秒）
automaticweartime=10
;背包内高属性装备是否显示提升箭头（默认0，全部显示；1，全部不显示；2，不满足穿戴条件的不显示）
showliftarrow=0
;针对使用tips的文本写法，如：<使用新的OK框文字大小|文字大小/SCOLOR=250>\(默认0，放大的字体；1，普通字体大小)
tipsUseCustomOKPanel=0
;传送戒指功能使用间隔（秒）
MoveTimeCD=0
;是否显示尸体（默认0或空：显示 1：不显示）
corpseShow=1
;是否使用monster表内Attack_Spd字段， （1使用，0不使用）
useMonsterAttackSpeed=0
;探测功能使用间隔（秒）,不写默认为0
SearchingTimeCD=0
;OK框的默认底框配置，不配置时使用现在的默认底框
;defaultOkPanel=资源名称
;经验显示位置设置（屏幕中心点坐标为0,0）：
;expDisplayPosition=x,y
;PC端经验显示位置设置（屏幕中心点坐标为0,0）：
;pcexpDisplayPosition=x,y
;使用时装自定义时装位置（默认为0，不使用自定义位置；1为使用）
;openFashionfidle=0
;上/下马间隔时间配置（单位：秒，不配置无限制）
; UpHorseCD=0
;受击下马几率（百分比，不配置为100%）
;DownHorseRate=100
;穿戴增加技能伤害百分比的装备后，刺杀近身、隔位相同的伤害计算：不写或0为默认伤害计算(如增加50%伤害，近身伤害为1.5.隔位伤害为1.5*1.5)；1为近身、隔位相同伤害（0防御时）
;openSergum_12_AttackRate=1
;召唤的宝宝是否也开启MonSpAbilList.txt的属性扩展， 0-不开启 1-开启， 默认不开启
;opensummonspab=0
;自定义采集被攻击打断：（0或不配置，默认不打断，1打断）
;progressBarType=1
;技能强化威力倍数计算方式（0或不填写，技能威力提升以上一级为基础；1，以初始伤害为基础乘以威力倍数）
;以1-5级每级设置200为例，5级的伤害：0或空时伤害1*2*2*2*2*2=16倍； 1时，伤害为2倍
NewLevelMagicPowerRate=1
;显示或关闭物品来源信息（0关闭，1显示）
;dropinfo=0
;玩家持续攻击时(处于战斗状态20秒)，右上方的自定义按钮收起（0默认，1持续攻击收起）
;autopackupcustombutton=0
;角色界面上主角动作, 1为举手 2为不举手动作
;roleMode=1
;是否显示背包内可用道具绿点提示：0-不显示 1-显示
;viewgreenpoint=1
;配置该命令后，施毒术是否阻止怪物回血。（0不回血，1回血）
;poisonRecover=1
;穿戴装备方式（0= 旧1=新）使用新的方式，模型装备（武器、衣服、头盔、斗笠、盾牌）不再使用装备格子，而是直接穿到身上，需要同时设置rolemode=1
;isNewWearingMode=1
;tejieconfig配置使用套装组功能（0不使用；1使用）
;isnewsuit=1
;mongen.txt 怪物视野是否生效 0-不生效 1-生效 默认是0
;isNewMonsterEye=1
;采集时间,采集尸体消失时间
;butchTime=1000,3000
;是否浮动提示人物属性增加（1显示，0隐藏，默认隐藏）
;attributeAddFloat=1
;是否启用魔法攻击范围限制 0-关闭（默认） 1-开启
;usemagicattackrange=0
;.挂机寻怪模式配置：新模式下，先寻路到随机点，寻路过程中遇到可攻击目标时，会攻击目标
;autoPlayGameMode=1 （0或不写，当前挂机寻怪模式；1：新模式）
;闭关安全区光柱,1为关闭,0或缺省为正常显示
;clsSafeAreaBeam=1
;隐藏被攻击自动反击,1为隐藏,0或缺省为正常显示
;hideAutoHitBack =1
;是否允许麻痹、冰冻、蛛网可以同时触发随机，buff效果优先级按照麻痹>冰冻>蛛网进行覆盖顶替(0不允许，1允许，默认不允许)
;limitRandom =0

;是否支持同一件装备可根据职业配置属性（默认为0，不支持；1为支持，分职业属性读\Mir200\equipDiffJob.txt）
equipDiffJob =1
;是否开启技能熟练度升级(0或空-不使用熟练度升级模式；1，使用技能熟练度升级技能)
useskillproficient =1

;不同职业角色PVP时造成伤害是否为计算值的80%(0-计算值的80%，1-计算值的100%，默认0)

;PvpDamageMode=1

;伤害飘字新模式：有护身效果时，MP值抵消受到的伤害值时，伤害飘字为白色，飘字值为掉蓝量；MP值为0时伤害飘字恢复正常(0不使用，1使用，默认值0)
;shieldNew=1

;是否通过脚本控制人物死亡掉落（0不控制，1控制，默认值0）=1时，通过命令doDrop控制人物死亡掉落
;canCtrlDrop=1

;开启服务端外挂加速检测
;inspectmovespeed=1

;使用新的攻速计算方式 （0或空-默认计算方式，1-使用新的攻速计算方式,新攻速计算方式攻速上限为1000，旧攻速为120；221108更新后,，新上传的版本不再生效，旧版本和测试服不受影响 ）
isNewSpeed=1

;技能升级后增加伤害上下限是否读表（magic表：defpower、defmaxpower列，不支持：小火球、治疗术、群体治疗术、冰风暴、火焰墙，数值范围：0-21E）
upSkillHurtByCsv=0

;怪物移动间隔配置：
;单次行走距离参数(米，默认值：1)
;stopdis=1
;单次停顿时间参数(毫秒，默认1000)
;stoptime=1000

;隔位刺杀无视防御的最小间隔距离
;cishajuli=1

;是否开启面巾装备位
;openequip26=1

;自动拾取一定范围内物品（支持小数，只自动拾取在拾取列表内的物品）：pickupRange
;pickupRange=1

;默认关闭按钮配置(图片资源名称,x偏移,y偏移)
;clsBtn=GuanBi,-60,0

< P>

< P>

< P>

;-------------------------------------------------------------------
;背包界面显示的货币，对应GOM引擎的货币代码
;货币名称 货币数量代码 位置（1 2 3 4 5 6 --6个位置，不配置则按照顺序显示）
[bagCurrency]
金币 <$GOLDCOUNT> 3
元宝 <$GAMEGOLD> 4
充值点 <$GAMEGIRD> 5
降妖币 <$GAMEDIAMOND> 6

;-------------------------------------------------------------------
;商城界面显示的货币（最多支持显示3种货币，支持7种货币类型）
[mallCurrency]
<$GOLDCOUNT>
<$GAMEGOLD>
<$GAMEGIRD>
;---------------------------------------------------------------------------------------------------------------------------------------------------------------
;主角状态界面中显示的货币类型
;货币名称 货币数量代码
[roleCurrency]
PK点数 <$PKPOINT>
声望点数 <$CREDITPOINT>
金币数量 <$GOLDCOUNT>
游戏币数 <$GAMEGOLD>
游戏点数 <$GAMEPOINT>
金刚石 <$GAMEDIAMOND>
灵符 <$GAMEGIRD>
荣誉值 <$GAMEGLORY>

;-------------------------------------------------------------------
;摆摊可交易的货币类型配置（最多支持两种货币，不配置则默认是金币和元宝）
;货币名称 货币数量代码
[setStallCurrency]
金币 <$GOLDCOUNT>
元宝 <$GAMEGOLD>
;充值点 <$GAMEGIRD>
;降妖币 <$GAMEDIAMOND>

;-------------------------------------------------------------------
;交易可交易的货币类型配置（最多支持两种货币，不配置则默认是金币和元宝）
;货币名称 货币数量代码
[tradeCurrency]
金币 <$GOLDCOUNT>
元宝 <$GAMEGOLD>
;充值点 <$GAMEGIRD>
;降妖币 <$GAMEDIAMOND>

;---------------------------------------------------------------------------------------------------------------------------------------------------------------
;充值配置
;充值金额 金刚石数量 元宝数量 充值积分数量 背景图片 荣誉值数量 声望值数量 灵符数量 界面描述 标记ID
;充值金额 GAMEDIAMOND GAMEGOLD GAMEPOINT 背景图片 GAMEGLORY CREDITPOINT GAMEGIRD 界面描述 标记ID（命令调用ID）
[charge]<BR>9060000000yuanbao_2009<9元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=1795><1000W/SCOLOR=243><元宝/SCOLOR=90designtimesp=1796><9/SCOLOR=243><充值点/SCOLOR= 90designtimesp=1797>1
180180000000yuanbao_30018<18元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=1799><1800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=1800><18/SCOLOR=243><充值点/SCOLOR=90designtimesp=1801>2<BR>380380000000yuanbao_40038<38元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=1803><3800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=1804><38/SCOLOR=243><充值点/SCOLOR=90designtimesp=1805>3<BR>680680000000yuanbao_50068<68元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=1807><6800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=1808><68/SCOLOR=243><充值点/SCOLOR=90designtimesp=1809>4<BR>48804880000000yuanbao_500488<488元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=1811><48800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=1812><488/SCOLOR=243><充值点/SCOLOR=90designtimesp=1813>5<BR>10801080000000yuanbao_500108<108元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=1815><10800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=1816><108/SCOLOR=243><充值点/SCOLOR=90designtimesp=1817>6<BR>21802180000000yuanbao_500218<218元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=1819><21800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=1820><218/SCOLOR=243><充值点/SCOLOR=90designtimesp=1821>7<BR>35803580000000yuanbao_500358<358元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=1823><35800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=1824><358//SCOLOR=243><充值点/SCOLOR=90 designtimesp=1825> 8

;--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
;可创建职业配置，0战士，1法师，2道士
[CreateOccupation]
0
;1
;2

;可创建男女，0男，1女
[CreateGender]
0
;1

;-----------------------------------------------------------------------------------------------------------------------------------------
;1是否使用系统默认的战斗力（如果用系统默认的填1，不用的话写0；写0时可在脚本里给 n$FIGHTPOWER 传值来自定义战斗力）
;2（隐藏主界面战斗力显示写0，显示的话写1）
[FIGHTPOWER]
1 0
2 1

;------------------------------------------------------------------------------------------------------------------------------------------------------------
;宝石在备注中的文字描述
;格式：道具名称 描述文字
[gemTips]
攻击宝石 <超级牛逼的BUFF/FCOLOR= 243designtimesp=1851><拥有则天下无敌/FCOLOR=255 designtimesp=1852>
;------------------------------------------------------------------------------------------------------------------------------------------------------------
;放到这个节点下的道具不受改名影响，使用改名命令ChangeItemName改名后显示的名字仍然为道具表中的名字
[itemname]
道具名字
道具名字
道具名字
;------------------------------------------------------------------------------------------------------------------------------------------------------------
;放到这个节点下的道具，只按照数据库中的名字显示DZitemDescList中配置的置顶信息
[DZitemDescList2]
道具名字
道具名字
道具名字
;---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
;开放装备位配置，0盔甲，1武器，2勋章，3项链，4头盔，5右手镯，6左手镯，7右戒指，8左戒指，9护身符，10腰带，11鞋子，12宝石，13斗笠，14军鼓，15马牌，16盾牌，19生肖
;开放位置 位置坐标（30，30） 背景图片名称
[EquipmenField]
0 288.6,150 Beibao_yifu
1 -289.3,150 Beibao_WQ
2 288.6,268 Beibao_sunzang
3 -289.3,268 Beibao_XL
4 288.6,384 Beibao_toukui
5 288.6,32 Beibao_shouzuo
6 -289.3,32 Beibao_shouzuo
7 288.6,-84 Beibao_jiezi
8 -289.3,-82 Beibao_jiezi
9 288.6,-314 Beibao_baoshi
10 -6,-314 Beibao_yaodai
11 124,-314 Beibao_xiezi
12 -289.3,-314 Beibao_hushenhu
13 -289.3,384 Beibao_DLDJK
14 288.6,-198 Beibao_ShenQi_2
15 -289.3,-198 Beibao_ShenQi_1
16 -134,-314 Beibao_Dun
17 288.6,150 Beibao_yifu
18 -289.3,150 Beibao_WQ
20 -289.3,384 beibao_daojukuang001
21 288.6,384 beibao_daojukuang001
22 -289.3,-314 beibao_daojukuang001
23 -289.3,-82 daojukuang001
26 90,20 Beibao_mianjin

[EquipmenFieldPC]
0 175,49 Beibao_yifu
1 -175,49 Beibao_WQ
2 175,103 Beibao_sunzang
3 -175,103 Beibao_XL
4 175,157 Beibao_toukui
5 175,-5 Beibao_shouzuo
6 -175,-5 Beibao_shouzuo
7 175,-59 Beibao_jiezi
8 -175,-59 Beibao_jiezi
9 175,-167 Beibao_baoshi
10 0,-166 Beibao_yaodai
11 66,-167 Beibao_xiezi
12 -175,-167 Beibao_hushenhu
13 -175,157 Beibao_DLDJK
14 175,-113 Beibao_ShenQi_2
15 -175,-113 Beibao_ShenQi_1
16 -66,-167 Beibao_Dun
17 -200,88.8 attr_btn_shengxiao
18 -175,49 beibao_daojukuang001
20 -175,157 beibao_daojukuang001
21 170,157 beibao_daojukuang001
22 -175,-167 beibao_daojukuang001
23 170,-167 beibao_daojukuang001
24 -66,-113 beibao_daojukuang001
25 66,-113 beibao_daojukuang001
26 100,-167 Beibao_mianjin

;----------------------------------------
;道具位置（0-11） 位置坐标（X,Y） 背景图片名称 背景字名称
;------------------------生肖位置配置

;[GODBLESSITEMFIELD]
;0 -385 195 beibao_daojukuang001 shengxiao_text_zi
;1 -385 26 beibao_daojukuang001 shengxiao_text_zi
;2 -256 200 beibao_daojukuang001 shengxiao_text_yin
;3 -256 30 beibao_daojukuang001 shengxiao_text_yin
;4 -125 240 beibao_daojukuang001 shengxiao_text_yin
;5 -125 80 beibao_daojukuang001 shengxiao_text_yin
;6 10 243 beibao_daojukuang001 shengxiao_text_chou
;7 10 86 beibao_daojukuang001 shengxiao_text_chou
;8 130 161 beibao_daojukuang001 shengxiao_text_wu
;9 130 0 beibao_daojukuang001 shengxiao_text_wu
;10 -195 -128 beibao_daojukuang001 shengxiao_text_shen
;11 -89 -128 beibao_daojukuang001 shengxiao_text_shen

;[GODBLESSITEMFIELDpc]
;0 -90 114 beibao_daojukuang001 shengxiao_text_zi
;1 2 136 changtikuang_yiji shengxiao_text_chou
;2 92 114 beibao_daojukuang001 shengxiao_text_yin
;3 -131 42 beibao_daojukuang001 shengxiao_text_mao
;4 2 42 changtikuang_yiji shengxiao_text_chen
;5 138 42 changtikuang_yiji shengxiao_text_si
;6 -131 -50 beibao_daojukuang001 shengxiao_text_wu
;7 2 -50 changtikuang_yiji shengxiao_text_wei
;8 138 -50 changtikuang_yiji shengxiao_text_shen
;9 -90 -114 beibao_daojukuang001 shengxiao_text_you
;10 2 -140 changtikuang_yiji shengxiao_text_xu
;11 92 -114 beibao_daojukuang001 changtikuang_yiji shengxiao_text_hai

;---------------------------------------------------------------------------------------------------------------------
;配置商城界面中分页的显示文字
;最多支持5个分页，修改这里的文字即可改变商城界面分页上的文字；没有东西的分页会自动隐藏
[Shoptab]
1 杂货
2 补给
3 转生
4 好友
5 限量

;------------------------------------------------------------------------------------------------------------
;配置查看其他角色可看到的角色界面的分页
[Viewotheruser]
1 装备
2 状态
;3 属性
4 称号
;5 技能

;-------------------------------------------------------------------------------------------------------------------------------------------------------------------
;配置设置中保护数据
;类型(1.自动吃药；2.自动传送) 道具名称 道具名称 道具名称 道具名称 道具名称 （不配置则没有）
;3.自动使用技能 技能名称 技能名称（尽量配置回血类技能）
[ProtectSet]
1 强效金创药 强效魔法药 强效太阳水 疗伤药 万年雪霜 大补丸 血灵芝 茯苓丹
2 回城石 随机传送石
;3 治愈术

;-----------------------------------------------------------------------------------------------------------------------------------------------------------------------
;配置设置-挂机里自动拾取的装备类型（配置好类型后，使用GM编辑工具在：查看-列表信息2-内挂捡取 中将对应道具设置成对应的类型，挂机时即可自动捡对应的装备）
;编号 类型 颜色值
[PickingType]
1 01-05阶 255
2 06-10阶 215
3 11-15阶 254
4 16-20阶 241
5 21-25阶 185
6 26-30阶 186
7 31-35阶 209
8 特殊装备 249
9 法器类 249
10 面具类 249
11 圣印类 249
12 战旗类 249
13 神器类 249
14 盾牌类 249
15 勋章类 249

;---------------------------------------------------------------------------------
;自动拾取道具 最多支持配置7种类型 （配置后将自动拾取对应颜色的道具）
;编号 显示文字 颜色值
[pickitem]
1 货币 251
2 材料 191 249 9 245
3 技能 254
4 杂物 241
5 高级 186
6 特殊 245

;---------------------------------------------------------------------------------
;创建行会消耗
;格式：
[createguild]
<$GOLD> 1000000
;<$gameGlory>
;<$gameDiamond>
;<$goldCount>
;<$gamePoint>
;<$gameGold>
;<$gameGird>
;<$creditPoint>
;<$b_gameGlory>
;<$b_gameDiamond>
;<$b_goldCount>
;<$b_gamePoint>
;<$b_gameGold>
;<$b_gameGird>
;<$b_creditPoint>
;<$Item> 沃玛号角 1
<$Show> 100W金币

;------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
;签到配置，如果开放签到功能则在这里进行每天可领取的道具
;天数 道具名称 道具数量

[Sign]
1 屠魔碎片 3

;---------------------------------------------------------------------------------------------------------------------------------------------------------------
;配置道具掉落在地上对应道具上播放的特效（光柱）
;道具名称 特效名称
[ItemBeam]
命运之书 ShanGuang

;---------------------------------------------------------------------------------------------------------------------------------------------------------------
;道具的爆率衰减 当前道具爆率=开服小时掉落系数*全服衰减系数*个人衰减系数

;道具名 开服小时 开服小时掉落系数 全服第N件开始衰减 全服衰减系数 个人第N件开始衰减 个人衰减系数
[DropItems]
治愈术 3|12|16 1.5|1|0.8 5|8|14 1.5|1|0.8 5|8|14 1.5|1|0.8

;道具名称 掉落间隔(分钟) 生效对象（0：个人 1：本服）
[Dropinterval]
治愈术 120 1

;配置全屏吸怪技能参数
[FullScreenCatcher]
;技能CD(秒) 范围 数量 是否受等级影响（0无视等级，1为现有规则，默认1）
8 8 8 0

;--------------------------------------------------------------------------------------------------------------------------------------------------------------

;拍卖行交易货币设置,不配置默认为金币
[setAuctionHouseCurrency]

名称 对应货币 最低上架价格
金币 <$GOLDCOUNT> 1
元宝 <$GAMEGOLD> 1
充值点 <$GAMEGIRD> 1

;拍卖行标签配置
[setAuctionHouseTag]
装备_武器#5,6|衣服#10,11|头盔#15
书籍_卷轴#3
材料_药水#0|食物#1

;设置拍卖行vip等级和手续费率，可上架物品数量(不设置默认为等级0 手续费10 可上架物品数量1)
[auctionvip]
;拍卖行vip等级（0-99） 手续费（百分比） 可上架物品数量 上架时间（分钟）
0 10 1 60
1 9 2 90

;--------------------------------------------------------------------------------------------------------------------------------------------------------------

;自定义属性名，“< >”的内容为自定义属性名的内容，可以使用空格来调整排版

[RoleAttributeName]

;默认属性名 自定义属性名

防御 < 物 防 >

魔御 < 魔 防 >

攻击 <力 量>

魔法 <智 力>

道术 <精 神>

;--------------------------------------------------------------------------------------------------------------------------------------------------------------

;自定义货币图标
[CurrencyIcon]
;货币 图标id
<$GAMEGLORY> CurrencyIcon1
<$GAMEDIAMOND> CurrencyIcon2
<$GOLDCOUNT> CurrencyIcon3
<$GAMEPOINT> CurrencyIcon4
<$GAMEGOLD> CurrencyIcon5
<$GAMEGIRD> CurrencyIcon6
<$CREDITPOINT> CurrencyIcon7


TJ引擎更新记录-2023.1.10

TJ引擎更新记录

2023.1.10更新内容

【新功能】

触发器

1.使用物品触发[@StdModeFuncX]支持checkitem检测的数量大于1
2.攻击/被击触发,增加被攻击者/攻击者执行指定脚本命令：currrTargetName（详情请搜索“攻击触发”）

装备

stdmode=124-127的装备位，支持need字段人物等级、转生等级、属性穿戴限制

【修复bug】

1.修复背包特效残留问题
2.修复货币减法命令“正减数”经乘法赋值且超上限时,会变成负数的问题
3.修复某些情况下会多开itembox，造成变量出错的问题

【优化内容】

1.优化游戏外挂加速检测机制
2.优化拾取宠物拾取检测频率
3.优化货币加、减、等于命令的计算

【GM编辑工具】

增加脚本编辑功能：
（1）命令变色显示
（2）内容编辑
（3）脚本查找
（4）脚本跳转（鼠标右键）
（5）脚本内容查找（Ctrl+F）
（6）脚本内容批量替换（Ctrl+R）


TJ引擎更新记录

2022.12.27更新内容

【新功能】

命令

1.新增对话框命令：itemBoxRes 定义itemBox显示资源
2.套装属性克隆相关命令
（1）指定ok框中物品的套装编号：<$BOXITEM[X].suitID>
（2）获取指定物品的套装ID：getSuitID 装备位(-1为OK框) 套装ID变量
（3）克隆指定道具的套装属性：cloneSuitId 装备位(-1为OK框) 套装编号(-1为删除克隆套装及描述信息) 克隆的套装道具名称 套装描述(缺省则使用克隆装备的套装描述)
（4）获取指定套装的克隆信息：getCloneSuitInfo 装备位(-1为OK框) 克隆的套装ID(没有克隆返回空) 克隆的道具名称变量(没有克隆返回空)

通用触发器

触发器 | 触发事件 | 返回值n0
[@stdModeFunc] | 点击任意stdModeFuncX触发 | 返回点击id
[@buttonClick] | 点击任意buttonClickX触发 | 返回点击id
[@takeOn] | 点击任意takeOnX触发 | 返回点击id
[@takeOff] | 点击任意takeOffX触发 | 返回点击id
[@task] | 点击任意taskX触发 | 返回点击id
[@itemBagButtonClick] | 点击任意itemBagButtonClickX触发 | 返回点击id
[@storageOpenFail] | 点击任意storageOpenFail触发 | 返回点击id
[@bagOpenFail] | 点击任意bagOpenFailX触发 | 返回点击id
[@groupItemff] | 点击任意groupItemOffX触发 | 返回点击id
[@groupItemOn] | 点击任意groupItemOnX触发 | 返回点击id
[@magSelfFunc] | 点击任意magSelfFuncX触发 | 返回点击id
[@canInputItemList] | 点击任意canInputItemListX触发 | 返回点击id
[@canPutoffItemList] | 点击任意canPutoffItemListX触发 | 返回点击id

【修复bug】

1.修复某些情况下，人物属性点会出现数值越界的问题
2.修复宠物打死怪后不会跟随人物一起回城的问题
3.修复行会界面：成员、日志分页第一次打开会没有数据的问题

【优化内容】

PC端聊天栏调整，只能发送装备信息

2022.12.6更新内容

< P >

【新功能】

变量

支持时间戳变量<$timestamp>支持在机器人脚本RobotManage.txt内使用

命令

1.RANGEHARM、RANGEHARMEX 特效持续时间参数支持使用小数
2.playefffect、mapeffect 资源名称参数支持使用变量
3.mapeffect时间、坐标参数支持使用小数
4.对话框播放指定玩家模型 <player:x:y:玩家昵称:缩放系数>
5.addUiDlg命令扩展,支持主界面添加自定义对话框
6.openBigDialogBox 参数扩展

触发器

通过邮件获得的道具，支持触发[@giveitemex]

跨服功能

1.后台管理工具-运营管理-跨服服务器管理添加跨服服务器
2.跨服地图设置
3.检测是否是本服玩家 isInServer
4.玩家角色是否在跨服地图：isOnCrossServerMap
5.跨服攻城
6.支持通区跨服设置：【gm平台】后台管理工具-->运营管理-->游戏版本列表-->通区跨服设置|通区跨服

【修复BUG】

1.修复背包物品特效会有残留的问题
2.修复itemlist物品显示不全的问题
3.修复战斗过程中，会错误提示技能释放超出攻击距离的问题
4.修复充值变量：<$RECHARGE[X].FREQUENCY>、<$RECHARGE[X].NUMBER> 数值在服务器重启后才会更新的问题
5.修复宝宝在一些情况下不跟随玩家的问题
6.修复stdmode=20时，AC2的属性错误的问题
7.修复召唤拾取精灵后，宝宝战斗按钮消失的问题
8.修复制作服宝宝攻击不显示掉血量的问题

【优化内容】

1.优化humanDropItem命令的性能
2.优化道具合成与分解配方的服务器请求流程
3.优化攻城提示：在开服天数大于等于M2内设置的申请攻城天数后（!setup.txt内StartCastleWarDays），再发送系统的攻城消息

2022.11.14更新内容

【新功能】

触发器

1.qf新增拾取物品进背包前触发[@prepickupitem]
2.[@pgdropitem]、[@PrePickUpItem]支持改道具颜色命令：ChangeItemNameColor

【修复BUG】

1.修复PC端时装界面的衣服拖动后，外观会消失的问题
2.修复可叠加物品进背包后，需要刷新背包才会显示叠加数量的问题
3.修复宝宝攻击不显示伤害数字的问题
4.修复在PC端添加自定义内容（adduidlg）时，会出现多个错误内容的问题
5.修复自定义技能图标，普通攻击技能图标换不掉的问题
6.修复getDropStr获取不到值的问题

2022.11.8更新内容

【新功能】

人物状态

新增瘫痪、防瘫痪状态

命令

changemodeex增加瘫痪（139）、防瘫痪（141）效果

配置

tejieconfig新增对话框默认关闭按钮配置
;默认关闭按钮配置(图片资源名称,x偏移,y偏移)
;clsBtn=GuanBi,-60,0

【修复bug】

1.修复火墙持续期间，使用其他技能，造成的伤害时返回的技能ID错误的问题
2.修复playeffect多次播放时，不消失的问题
3.修复adduidlg在角色界面无法添加自定义内容的问题
4.修复主界面主角模型翅膀不动的问题

【注意】

22.11.09后，新上传的版本全部使用新攻速模式，tejieconfig内配置不再生效，旧版本和测试服不受影响
新上传版本需替换屏蔽字，否则无法上传，旧版本不受影响

2022.11.1更新内容

【新功能】

命令

1.改变用户模式命令changemodeex：新增定身(137)、防定身(138)参数
2.怪物掉落物品时触发[@pgdropitem]支持对物品设定指定光柱,名称,字符串
3.ImgButton支持是否描边参数

触发器

1.[@slaveattack]、[@SlaveMagicAttack]支持checkcurrtargetrace检测
2.[@giveitemex]新增物品名称返回值变量：s1
3.技能触发支持多级脚本：m.humanhp

功能

宝石打孔镶嵌增加支持孔位置：5-9（原有0-4）

【修复bug】

1.修复宠物血量超上限，无法召唤的问题
2.修复setskillpower伤害加成结果数值不对的问题
3.修复新穿戴模式下，脱下装备，装备格子也会消失的问题
4.修复新装备位（60-83）触发[@takeon]、[@takeoff]时，位置变量（<$CurItemPos>）错误的问题
5.修复背包里有神佑首饰盒装备，会一直绿色提升箭头的问题
6.修复开启神秘人后，召唤的宝宝无法使用命令（ChangeSlaveNameColor）改变名字颜色的问题
7.修复input提醒文本字号没有使用参数8设置的字号的问题
8.修复切换地图后，使用命令修改的宝宝名字颜色又变回去的问题

【优化内容】

1.优化任务栏自定义内容加载
2.优化对话框延时刷新问题
3.优化邮件界面删除按钮

2022.10.18更新内容

【新功能】

命令

1.新增判断是否是PC端的命令：isPc
2.支持给绑定物品命令（givestateitem）触发QF内[@giveitemex]
3.TakeBagItem增加参数：回收物品的颜色值(0-255，空或*回收所有颜色)

触发器

新增通用穿戴/脱下触发器：[@takeon] [@takeoff] 及相关变量

【修复bug】

1.修复img命令增加旋转参数，在有图片宽高参数时无效的问题
2.修复宝宝在使用自定义技能时，除和平、全体模式外，会对己方宝宝造成伤害的问题
3.修正setskillpower说明书错误描述
4.修复getfloat获得的结果小于1时，整数位错误的问题
5.修复PGExtractString分割字符串不生效的问题
6.修复某些情况下，玩家打开对话框后移动一段距离，对话框仍不关闭的问题
7.修复开启神秘人后，召唤的宝宝名字会显示数字的问题

【优化内容】

1.调整道具右下角添加文本在OK框内显示的字号大小
2.优化宝宝跟随逻辑
3.调整摇杆区域

【资源编辑器】

修复部分模型使用后，列表没有显示截图的问题

2022.9.27更新内容

【新功能】

触发器

魔法攻击触发器[@MagSelfFuncX]、[@MagTagFuncX]、[@MagTagFuncExX]、[@MagMonFuncX]支持获取目标名字变量<$CURRRTARGETNAME>,调整血量命令：m.HumanHp

命令

1.img命令增加图片旋转参数
格式: <Img:图片名称:X横向坐标:Y纵向坐标:是否灰化（0不灰化，-1灰化）:缩放倍数,旋转角度（0-360）:宽度:高度 /@Label>
2.playmodel增加旋转参数
格式:<playmodel:模型编号:X横向坐标:Y纵向坐标:UI缩放比例,Y轴旋转角度（可缺省，0-360）,平面旋转角度（可缺省，0-360）:模型缩放比例:男女:武器:斗笠:翅膀:特效>
3.设置自动拾取范围：setPickupRange 拾取范围（需在挂机拾取列表中）
4.重置宝宝属性的命令resetSlaveAbility
5.give命令获取的物品，支持修改物品自定义属性及自定义文本

【修复bug】

修复OK框内字体描边模糊的问题

【优化内容】

调整手机端聊天框消息的行间距

【GM编辑工具(M2)】

使用GM工具修改!setup.txt的内容时，如果!setup.txt内没有对应字段会自动添加

2022.9.20更新内容

【新功能】

命令

文本命令text增加文字是否描边参数

功能

生肖、首饰盒、时装、新装备支持限时功能

【修复bug】

1.修复pc端itemshowex查看道具tips会不显示的问题
2.修复挂机时自动走位会来回走动的问题
3.修复图标右下角文本在未配置的道具上也会显示的问题
4.修复部分音效不播放的问题

【优化内容】

优化拾取规则：主角行走时的触发检测

【资源编辑器】

替换地图资源：D501、D502、D503

2022.9.8更新内容

【新功能】

配置

tejieconfig配置自动拾取一定范围内物品（支持小数，只自动拾取在拾取列表内的物品）：pickupRange
pickupRange=1

【修复bug】

1.修复查看其它玩家装备时，不显示套装物品的问题
2.修复道士在一些情况下可以召唤多个宝宝的问题
3.修复法师诱惑的宝宝不动的问题
4.修复镖车不跟随的问题
5.修复SCENEVIBRATION屏幕会黑屏闪烁的问题

【优化内容】

1.优化怪物攻击、被击、死亡音效
2.优化对话框内字体描边
3.stditems表overlop配置错误时，制作装备增加错误提示
4.优化拾取规则：主角行走时触发拾取，站在物品上拾取，不受拾取列表的影响

【GM编辑工具(M2)】

增加脚本字符串查找功能：工具-字符串查找

2022.8.23更新内容

【新功能】

配置

增加强攻剑法触发几率和伤害倍率的配置

装备

增加新装备位：面巾

【修复bug】

1.修复测试服转正式服，领取充值奖励的问题
2.修复物品放入OK框,背包会出错的问题
3.修复物品tips不显示icon、持久等信息的问题
4.修复切割命令会对拾取精灵造成伤害的问题

【优化内容】

1.替换强攻剑法音效
2.调整主界面UI位置（HP、MP、聊天框）
3.替换怪物受击音效
4.优化宝宝休息、战斗状态
5.优化怪物的被击状态显示

【GM编辑工具】

增加强攻剑法配置：选项-功能设置-战士技能

【平台管理工具】

修复已解除禁言的玩家，在后台仍然显示禁言的问题

【资源编辑器】

1.新增武侠风格武器模型
2.新增武侠风格衣服模型
3.新增怪物模型

2022.8.9更新内容

【新功能】

触发器

[@GiveItemEX]触发器对装备类道具返回唯一id，存入变量s0

配置

1.tejieconfig新增怪物移动间隔配置：
;单次行走距离参数(默认值：1)
;stopdis=1
;单次停顿时间参数(毫秒，默认1000)
;stoptime=1000
2.新增自定义假人名字库配置，假人登陆优先随机使用文本内的名字:DummyNameListTJ.txt
文本路径：..\Mir200\Envir\DummyNameListTJ.txt
3.新增tejieconfig配置：隔位刺杀无视防御的最小间隔距离
cishajuli=1
4.新增在道具图标右下角添加自定义文本的配置文件：equipStage.txt
文件路径：..\Mir200\Envir\equipStage.txt

【优化内容】

1.调整怪物初始移动速度，优化怪物不同速度下，跑步动作的播放速率
2.优化攻击加速后，技能特效播放的表现
3.优化技能攻击的表现
4.隔位刺杀在近身时，也会触发攻杀
5.调整怪物攻击音效
6.更换登陆界面背景音乐

【GM编辑工具(M2)】

屏蔽字替换增加替换流程说明链接

2022.8.2更新内容

【新功能】

命令

1.新增放大装备位武器或翅膀外显命令：zoom 装备位置 放大倍率
2.新增放大SetPlayerModel命令设置的武器或翅膀外显命令：zoomEx 放大类型 放大倍率

【修复bug】

1.修复某些情况下，setPlayerModel取消武器外观时，翅膀装扮也会取消的问题
2.修复开启脚本控制死亡掉落时，死亡邮件的击杀者显示错误的问题
3.修复tbl_save存表，某些情况下无法删除的问题
4.修复因护身效果，主角被击时不播放被击动作的问题
5.修复AddHumNewValue修改人物体力魔力时，未生效的问题

【优化内容】

1.更换部分美术资源
2.优化掉落物名字显示层级
3.调整近战技能攻击位置
4.调整怪物攻击位置
5.优化怪物打击点
6.优化拍卖行界面显示

【后台管理工具】

修复服务器费用充值流水明细显示时间都是0点的问题

2022.7.26更新内容

【新功能】

配置

新增tejieconfig配置项,技能升级后增加伤害上下限值是否读表（magic表：defpower、defmaxpower列，不支持：小火球、治疗术、群体治疗术、冰风暴、火焰墙）
;技能升级后增加伤害上下限是否读表（数值范围：0-21E）
upSkillHurtByCsv=0

【修复bug】

1.修复保护设置-自动传送：生命值低于设定值时，没有使用传送的问题
2.修复手机端状态界面，人物的等级固定为90的问题
3.修复开启刀刀刺杀，当角色没有刺杀技能时，普攻无法释放的问题
4.修复AddHPPer命令攻击者看不到切割的数字的问题
5.修复拾取精灵卡顿问题

【优化内容】

1.货币增减命令类，【例如：B_GOLDCOUNT (+ - =) 值】， 提升货币修改值的参数设置上限
2.更换隔位刺杀、神之开天的技能特效
3.背包已满时，角色会继续拾取金币
4.playusermodel,部分装备未配置模型（如头盔未配置模型），可以正常显示其他模型了
5.优化伤害飘字
6.优化人物血条显示层级，不会被地上的掉落物名字遮挡

【资源编辑器】

增加大神盒子称号（tejiehezidashen）、补丁（tjds）

【GM编辑工具(M2)】

1.增加是否检验屏蔽字的开关
2.优化编辑器多开时的错误提示

【运营平台】

运营管理-全局变量一览-变量类型(文本文件)：支持下载指定文本文件

2022.7.18更新内容

【新功能】

1.隔位刺杀修订为开关技能，点击技能图标，开启或关闭隔位刺杀
2.DelTextList 参数2 兼容大写英文字母
3.金币<$GOLDCOUNT>增加掉落地面显示，并支持自动拾取
平台工具菜单>选项>怪物设置>基本参数
已有选项“金币直接入背包”未勾选时则挂机时自动拾取金币

【修复bug】

1.修复浮动提示人物属性增加开启(attributeAddFloat=1)时，部分属性显示错误的问题
2.修复没有行会的玩家，iscastleguild会被判断为皇城成员的问题
3.修复背包引导命令失效的问题
4.修复纵横剑术特效错误的问题
5.修复聊天框发送物品信息，背包显示错误的问题
6.修复tejieconfig配置原地复活需要的货币，人物当前货币不足时仍然可以原地复活的问题
7.修复PC端物品回收在某些情况下，不显示勾选物品的问题
8.修复法师挂机时，魔法值不足，会出现一直使用雷电术的问题

【优化内容】

1.优化技能表现（调整技能伤害延迟、特效播放时间、攻击距离、范围）
2.通过物品名称获取指定字段值的命令，取物品字段值取equipDiffJob.txt中值时，需要满足特戒配置equipDiffJob=1
3.优化头顶血量显示单位
4.优化伤害显示数字字体
5.镶嵌宝石后，属性面板会即时刷新
6.优化怪物模型通过MonGen.txt的【模型大小】放大后，在游戏场景里模型脚下的红圈大小

【资源编辑器】

1.新增人物环身特效-可调用特效资源内查看
2.新增武器模型*6
3.新增人物模型*6

2022.7.11更新内容

【新功能】

配置

1.tejieconfig创建行会配置项扩展：支持其他系统货币
<$gameGlory>
<$gameDiamond>
<$goldCount>
<$gamePoint>
<$gameGold>
<$gameGird>
<$creditPoint>
<$b_gameGlory>
<$b_gameDiamond>
<$b_goldCount>
<$b_gamePoint>
<$b_gameGold>
<$b_gameGird>
<$b_creditPoint>

功能

1.setClientBuff支持文本单行多颜色设定
2.聚灵珠支持消耗绑定货币开启
anicount新增类型设定(2-5)
0 使用元宝(<$gameGold>)提取
1 使用金币(<$goldCount>)提取
2 使用绑定元宝(<$b_gameGold>)提取
3 使用绑定元宝(<$b_goldCount>)提取
4 优先使用<$b_gameGold>，不足时使用<$gameGold>
5 优先使用<$b_goldCount>，不足时使用<$goldCount>
3.MerChant.txt 支持npc变色设定

命令

1.获取指定地图、指定怪物的复活时间：getReviveTime
2.changeItemShape 支持翅膀 斗笠 头盔 面巾

OK框

自定义对话框中设置一个文字输入框：input

触发器

新增全局触发器：合服触发[@serverMerge]，触发器所在文件RobotManage.txt

【修复bug】

1.修复角色属性界面的属性“增加攻击伤害”显示错误问题
2.修复Hcall命令某些情况下会报错的问题
3.修复传送符-道具使用次数不刷新的问题
4.修复部分怪物挂点错误的问题
5.修复诱惑之光召唤的宝宝等级刷新及传送后名字重置成白色的问题
6.修复mapinfo中配置了noDrug的地图上使用药品，提示信息多了一条的问题
7.修复PC端自定义技能图标补丁资源不显示的问题
8.修复身上装备持久为0图标变红，使用修复神水后，身上装备图标未刷新的问题
9.修复旋风斩技能释放卡顿的问题

【优化内容】

1.优化综合频道聊天信息刷新
2.优化GroupItemSkillPowerList.txt支持在文件中添加;注释
3.优化自定义技能图标：下毒术、群体下毒术需配置2个技能图标
4.自动喝药保护：支持tejieconfig.txt内配置的药品道具都可以配置
5.优化称号会挡住摆摊的店名
6.setAttachIco添加了物品角标后,摆摊、交易、快捷装备，也显示物品角标
7.调整左上角buff图标位置
8.优化itemGrid规则

【GM编辑器(M2)】

优化脚本异常提示信息显示内容

2022.6.30更新内容

【新功能】

命令

1.设置指定技能的修改系数和附加伤害 setSkillPower / pgSetSkillPower
2.获取SetSkillPower设置的值 getSkillPower
3.自定义排行榜相关命令：saveRankData、 getRank、 rankView、 playUserModel、 viewPlayer
4.自定义主界面右下角功能按钮
5.获取pgExtractString命令拆分后的指定顺序字符串: getListValue
6.设置角色外显模型：setPlayerModel 、 loginSetPlayerModel
7.检测指定itemBox中有无物品：chkItemBoxNull
8.脚本设置checkBox选中状态：setCheckBox
9.改变角色当前模式changeModeEx增加新模式
10.新版押镖（角色跟随镖车移动）相关命令：autoEscort 、 fellowSlave 、 stopFellowSlave 、 checkEscort 、 checkBiao
11.主界面左侧边栏添加/删除自定义对话框内容：addDlg 、 delDlg
12.直接击杀玩家周边一定范围内的指定怪物：nearKillMon
13.装备改造相关命令：setModule 、 putinBox 、 getEquipList 、 getEquipListFirst等
14.装备属性转移相关命令（搜索装备属性转移）
15.道具筛选框组件相关命令（搜索道具筛选框）
16.屏幕中间位置添加/删除自定义按钮：addMainCenterBtn delMainCenterBtn
17.自定义装备属性changeCustomItemValue增加属性下限设定
18.装备回收针对不同货币类型,设置回收时获得货币的倍率：setRecMoneyRate
19.装备额外属性相关命令（搜索装备额外属性）
20.任务领取与刷新支持显示选中框：pickuptask
21.获取当前服务器的全部行会列表：getGuildList
22.拍卖行系统上架/下架指定物品：sysAuctionUp sysAuctionDown
23.获取指定排行文件的排行对象列表：getRankList
24.设置指定技能的攻击距离：setSkillAttDist
25.脚本循环模式：loop
26.装备tips指定位置加入文本：addItemTips
27.装备图标附加小图标：setAttachIco
28.脚本控制角色死亡掉落：doDrop
29.扩展给角色发送邮件命令：sendEmails
30.主界面指定按钮附近生成/删除气泡对话框：addBtnBubble delBtnBubble
31.根据约定的ID向对应UI添加自定义内容：addUiDlg 、 delUiDlg
32.打开指定id的系统界面 opensysui
33.主界面添加或删除一个消息提示按钮:setMsgBtn
34.设置是否外显时装命令(假人使用)：setShowFashion
35.修改物品的附加属性：tjChgItemValue
36.支持换行与多字色的自定义tips：addItemTipsEx
37.给指定装备添加扩展属性：setItemExValue
38.获取指定装备扩展属性：getItemExValue
39.游戏加载时文字信息展示：loadingTxt
40.获取指定角色的模型信息：playUser
41.查看玩家信息面板：viewPlayerEx

变量

1.增加自定义行会变量：guild2 服务器重启不清除
2.t变量支持扩展写法：t$扩展写法

对话框

1.设置风琴列表样式：accordionList
2.对话框自定义tab按钮、itemList和itemGrid
3.设置子对话框(二级对话框)
4.设置多排图标单元组列表iconGrid

功能

1.道具合成与分解
2.神佑首饰盒相关功能
3.采集玩法
4.新增OK框装备位*24：在自定义OK框中调用，属性同其他装备位一致，穿戴会增加人物属性
5.自定义技能图标

配置

1.Tejieconfig新增配置
[tjconfig]
;不同职业角色PVP时造成伤害是否为计算值的80%(0-计算值的80%，1-计算值的100%，默认0)
PvpDamageMode=1
2.;伤害飘字新模式：有护身效果时，MP值抵消受到的伤害值时，伤害飘字为白色，飘字值为掉蓝量；MP值为0时伤害飘字恢复正常(0不使用，1使用，默认值0)
shieldNew=1
3.;是否通过脚本控制人物死亡掉落（0不控制，1控制，默认值0）=1时，通过命令doDrop控制人物死亡掉落
canCtrlDrop=1
4.;开启服务端外挂加速检测
inspectmovespeed=1
5.;使用新的攻速计算方式 （0或空-默认计算方式，1-使用新的攻速计算方式,新攻速计算方式攻速上限为1000，旧攻速为120）
isNewSpeed=1

【修复bug】

1.修复自动回收会回收背包中比身上穿戴的装备属性更高(带绿色提升箭头)的装备的问题
2.修复邮件满了之后，收不到拍卖行邮件的问题
3.修复playModel、playModelEx: 配置了斗笠,没有显示的问题
4.修复快速回收后，无法双击使用背包道具，需要重新打开背包才能使用的问题
5.修复pgReadConfigFileItem 读取<$dress>类系统变量，变量中有大写字母时，读取失败的问题

【优化内容】

1.stAutoPlayGame增加挂机范围和是否寻路参数
2.calcVar 增加变量类型标识，支持字符串加减
3.openNpcShowEx 支持假人使用
4.changeSpeed 支持假人使用
5.autoTakeOffItem 、 takeOffItem 、 takeEx 、 autoTakeOnItem 、 takeOnItem 支持新装备位
6.更换手机端及PC端的血条蓝条
7.自动穿戴或使用弹出框，展示的物品图标优先显示动态图标
8.拍卖邮件不记入邮件上限数
9.优化登录界面动效

【运营后台】

1.运营后台支持查询账号被封原因查询-->可以查询被系统判定封号的原因

【GM编辑工具(M2)】

1.物品列表支持输入查找 鼠标悬停在限制物品列表，或物品列表上时，出现提示“Ctrl+F物品查找”
2.tejieplatform 重载数据时,增加配置文件校验

【资源编辑器】

更换部分地图：F003、jiguan3、Z001、hsp3、sx_0607_55、sxb_0607_83、tj_1122_04、tj_1122_07、tj_1122_08

2022.6.23更新内容

【新功能】

1.支持checkEquipNum、getEquipNum、takeW、takeEquip命令对生肖装备生效
2.支持takeOffItem命令对生肖装备生效
3.新增获取当前角色所在服务器id：<$server>
4.新增QF内触发器：收到私聊消息,且未打开一对一聊天框时触发 [@prvtMsg]
5.新增QF内触发器：人物杀死怪物时获得经验触发 [@GetExp],获得经验变量<$GetExp>
6.对话框增加关闭按钮及触发器： clsBtn

【修复bug】

1.修复宝石镶嵌tips字号变大的问题
2.修复NPC商店物品颜色错误的问题

【优化内容】

1.获得道具时，如果背包超重，提示“超过背包超重”
2.弹出菜单命令popMenu显示优化
3.优化登录界面、创建角色界面
4.物品来源：物品获得时间使用24小时制
5.游戏设置自动释放技能与mapinfo参数规则优化： 地图参数NOTALLOWUSEMAGIC禁用技能优先级高于游戏设置自动技能
6.假人全体攻击模式AI优化

【资源编辑器】

调整了一些道具ICON

2022.6.1更新内容

【新功能】

命令

新增获取登陆渠道号命令：getChannel
GetDBItemFieldValue、PGGetDBItemFieldValue支持获取equipDiffJob.txt内配置的属性值
新增打开行会界面命令：openGuild
新增保护设置命令(玩家未勾选时生效)： setProtect 可以设置自动喝药、自动传送的百分比及道具
新增改变全体怪物默认回血速度命令(对全体怪物实时生效)：setMonHot

配置

tejieconfig支持初始魔法攻速设置（兼容旧版）：startSpeed=初始物攻速度,初始法攻速度
例如：startSpeed=100,200

【修复bug】

1.修复技能通过熟练度升至顶级后，使用命令增加技能等级，又显示经验的问题
2.修复开启装备对比功能后，套装组不显示对比的问题
3.修复部分模型显示错误的问题

【优化内容】

1.优化神之开天技能特效
2.优化部分模型的特效

【资源编辑器】

1.调整了一些道具ICON
2.调整了一些怪物的模型

2022.5.11更新内容

【新功能】

命令

1.ChangeSlaveAbility参数一增加属性13：抗反伤值,每次受伤反伤伤害反弹都会减少对应参数值
2.新增读取指定txt到指定变量命令：readTxt
3.新增检查数据库中文件是否存在命令：fileExist
4.新增清除指定文件命令：clearFile
5.新增挂机时不将玩家角色作为目标命令：targetNoPlayer
6.新增是否是模拟器登陆的检测命令：isSimulator （最低客户端版本: 2.2.2）
7.新增QM内跨天执行触发器 [@dayChanged] 在线玩家跨天时,会触发此模块；不在线玩家第二天登录时会触发此模块
8.新增在小地图上显示NPC标记的命令：setNpcStat
9.新增设置角色外显模型命令： setPlayerModel

功能

1.同一件装备不同职业穿戴增加的属性值不同，装备可根据职业配置属性： equipDiffJob
2.支持技能熟练度升级

【修复bug】

1.修复一次性获得大量物品，触发[@inbag]时，会导致断线重连的问题
2.修复聊天栏系统信息没有颜色的问题

【GM编辑工具】

增加rmb类屏蔽字

2022.4.28更新内容

【新功能】

命令

神秘人命令SetMySteriousMan新增参数3：是否隐藏玩家血量 参数4：设置宠物外显模型ID（缺省显示原模型）
新增受击触发时，免疫本次伤害命令：SuckDamage
新增命令：清除指定目录下全部文件 clearPath
changeModeEx增加新模式

配置

GM编辑器工具（M2）支持下毒术技能配置-下线中毒消失

【修复bug】

1.修复sendcentermsg在跳转地图后，@块不执行的问题
2.修复qf触发器[@inbag]，在一次性获得大量叠加物品时，会出现断线重连的问题

【优化内容】

1.优化合服后列表的排序：按照从新到旧的顺序排序
2.命令THROWITEM制作的物品增加获得物品来源：系统制造
3.服务器列表显示优化
4.优化副本掉线处理

【GM管理后台】

服务器列表展示兼容两种模式：1-合并 2-不合并
操作说明：运营平台-后台管理工具-运营管理-游戏版本列表-修改服务器列表（修改模式后，需要等待2分钟左右）

2022.4.21更新内容

【新功能】

命令

1.checkItemDura参数支持变量
2.playmodel增加模型旋转角度参数
3.createNpc增加传递参数
4.changemodeex增加新模式
5.changehumability新增属性万分比修改

配置

;是否允许麻痹、冰冻、蛛网可以同时触发随机，buff效果优先级按照麻痹>冰冻>蛛网进行覆盖顶替(0不允许，1允许，默认不允许)
limitRandom=0

【修复bug】

1.修复HumanForPetSpeed=0时未生效的问题
2.修复地图参数NOTALLOWUSEMAGIC，设置禁止使用技能后，仍然会播放技能动作和特效的问题
3.修复角色小退重新上线后，技能CD会重置的问题
4.修复getFloat小数位设定为0还有小数的问题

【优化内容】

1.宝箱物品支持分组，同组内物品按照权重选出一种物品放入宝箱

2022.4.14更新内容

【新功能】

命令

1.addHpPerEx支持m.addHpPerEx
2.MAPEFFECT新增缩放倍数参数
3.新增检测指定地图范围内，玩家所属行会数量：checkRangeGuildCount
4.新增获取指定地图范围内，玩家所属行会数量及行会名称：getRangeGuildCount
5.delNameList、delIpList 文件路径支持变量

配置

技能快捷键、技能配置界面，图标位置增加文本配置（\Mir200\Envir\skillAbbr.txt）

【修复bug】

1.修复textex文本命令，居中对齐时，下划线没有对齐的问题
2.修复自定义技能获取技能ID错误的问题
3.修复PC端messagebox按钮资源错误问题
4.修复怪物反伤的伤害没有伤害来源的问题
5.修复MAKEPOSION生效的目标错误的问题
6.修复宠物切割命令bDelMonHpEx，参数8=0时对主人也有伤害的问题
7.修复realive百分比回血复活异常的问题
8.修复手机端保护设置-自动元宝复活-勾选框不显示的问题
9.修复changeItemNameColor修改身上穿戴的装备名字的颜色，没有即时刷新的问题
10.修复tejieconfig配置RankingListFightPower=0时界面显示问题

【优化内容】

1.优化怪物归属计算方式，计算切割造成的伤害
2.getUserItemName参数二兼容直接填写变量名的写法
例如：
getUserItemName 0 0
兼容写法：getUserItemName 0 s0

2022.3.31更新内容

【新功能】

命令

1.控制角色打出的道具均为绑定命令：bindingState 支持对怪物死亡掉落直接飞入背包的物品生效
2.脚本命令的文件路径参数支持变量
3.openNpcShowEx、killMobAppoint 命令支持假人执行
4.takeoffitem增加一段时间后可再次穿戴参数

功能

新增查看假人装备信息功能

【修复bug】

1.修复addGuildMember无法将其他玩家加入行会的问题
2.修复人物小退命令logout无法返回角色选择界面的问题
3.修复假人在怪物中毒后，还会一直释放下毒术的问题
4.修复假人跑步有时会出现动作过快的问题

【优化内容】

1.优化排行榜上的假人清理问题
2.怪物掉落归属支持对假人生效

【资源编辑器】

新增怪物模型*8

【GM编辑工具】

增加清理日志按钮

2022.3.24更新内容

【新功能】

命令

1.对话框文本命令：textex增加对齐方式设置
2.T变量、A变量支持Inc与Dec
3.新增命令monsterDrop，执行后不在地图上显示怪物，直接击杀怪物，掉落物飞入执行者背包
4.新增在屏幕中心播放特效命令：playScrEff
5.支持getNpcPos命令，可以获取通过命令(createnpc 、createmapnpc)创建出来的npc的坐标

配置

tejieconfig增加隐藏被攻击自动反击配置
;隐藏被攻击自动反击,1为隐藏,0或缺省为正常显示
;hideAutoHitBack=1

触发器

1.QF内增加背包增加物品触发器：[@inbag]
;背包中增加物品
;s0道具名称 n0道具数量
2.QF内增加背包减少物品触发器：[@outbag]
;背包中增加物品
;s0道具名称 n0道具数量

【资源编辑器】

新增地图*6
tj_0308_4
tj_0308_5
tj_0308_6
tj_0308_7
tj_0308_8
tj_0308_9

【GM编辑器】

查看-列表信息二-物品规则：支持物品下线必爆设置

2022.3.17更新内容

【新功能】

配置

tejieconf新增配置,可关闭安全区光柱显示
;关闭安全区光柱,1为关闭,0或缺省为正常显示
;clsSafeAreaBeam=1

命令

1.在地图上放物品命令：THROWITEM增加物品存在时间参数
2.新增decex：支持对程序变量（如U变量、D变量）操作，例如：decex u<$str(n$变量值)> 123
3.任务栏文本支持下划线，以/u开始，/u结束，中间的文本显示下划线
例如：PICKUPTASK 1 1001 特戒引擎 </u使用特戒引擎/u/FCOLOR=250>[<$STR(U502)>/10]
4.新增获得指定行会人数命令：getGuildScale
5.新增获得指定行会会长名称命令：getGuildMaster
6.新增获取指定行会总战力命令：getGuildPower

脚本变量

最高等级人物信息 <$HIGHLEVELINFO>
最高PK点数人物信息 <$HIGHPKINFO>
最高攻击力人物信息 <$HIGHDCINFO>
最高魔法力人物信息 <$HIGHMCINFO>
最高道术人物信息 <$HIGHSCINFO>

【修复bug】

修复设置了“丢弃消失”规则的物品，在手机端点击“丢弃”按钮丢弃时，没有丢弃消失提示的问题

【优化内容】

1.通过命令GiveStateItem获取的物品增加物品来源显示
2.创建角色界面增加“+”显示
3.delRole命令删除角色后，返回的服务器选择界面
4.账号选择列表内增加从列表内删除账号功能

2022.3.10更新内容

【新功能】

变量

新增宝宝当前攻击造成的伤害变量<$slaveAttackPower>

数据表

道具表stditems.csv，支持need=10时，需要制定职业及指定等级以上才可以穿戴，needlevel填写数值：职业(0-战士，1-法师，2-道士) + 65536*等级限制

【修复bug】

1.修复自定义怪物使用群体治疗术时，会对着攻击目标释放的问题
2.修复PC端角色界面-技能页显示错误数值的问题
3.修复增加会员时间命令ADDNAMEDATETIMELIST，添加的内容需要重启服务器才能检测到的问题

【优化内容】

1.优化PC端角色界面-称号属性查看时的回弹
2.增加宝箱开出的装备的物品来源显示
3.addGreenPoint支持PC端
4.优化一对多的套装组，套装生效时，装备tips的显示
5.优化新的挂机模式：寻路过程中遇到可攻击目标时，也会攻击

【资源编辑器】

新增地图*3
tj_0308_1
tj_0308_2
tj_0308_3

2022.3.3更新内容

【新功能】

命令

1.设置装备绑定状态：SetItemState新增项目7-禁止拍卖
2.自动同意入会申请命令：autoAdmApp 0 （默认0-关闭；1-开启）
3.地图刷怪时间调整命令：changeMonRenew 支持在Robot脚本内调用

【修复bug】

1.修复拥有多个宝宝时，在某些情况下，宝宝的群攻技能会对其他宝宝造成伤害的问题
2.修复新版PC客户端，聊天框字体颜色解析错误的问题
3.修复穿戴坐骑装备后，在某些情况下，小退重登不显示上马按钮的问题
4.修复groupMove，在目标地图有安全区时，只在安全区内传送的问题
5.修复groupMapMove的触发字段不生效的问题
6.修复防御术、魔御术只对自己生效的问题
7.修复分身独自攻击的怪物有时会出现无法杀死的问题

【优化内容】

1.宝箱增加跳过动画和连续开启功能
2.穿戴护身时，怪物反伤会先执行护身功能
3.回收获得界面增加特效
4.新挂机模式下，在寻路过程中，遇到可攻击目标时会优先攻击目标
5.在错误的使用了转译符号(如颜色)，导致物品报错，出现账号无法正常游戏的情况时，现在增加了容错，转译符错误将跳过转译
6.更换技能图标
7.替换部分技能特效

【资源编辑器】

新增地图*2：
tj_0210_01
tj_0210_02

新增怪物*5：
760
768
769
770
771

【GM管理后台】

GM操作-角色信息查询：增加邮件列表及删除邮件功能

2022.2.24更新内容

新功能:

命令

1.LINKPICKUPITEM支持在[@dropItemX]、[@takeOffX]、[@scatterBagItems]中关联物品，修改道具属性
2.挂机支持视野内自动采集尸体功能，单玩家生效，下线不保存
;autoCorpseCollection 0 (0-关闭，默认；1-开启)
3.新增开始挂机命令：stAutoPlayGame，执行可以触发qf内的[@stAutoPlayGame] ，使用stopAutoPlayGame可以停止挂机

触发器

1.qf内新增爆出背包物品触发： [@scatterBagItems]
2.qf内新增爆出身上物品触发： [@dropUseItems]

脚本变量

1.仅在以下触发器内生效
(1)爆出背包物品触发： [@scatterBagItems] (2)爆出身上物品触发： [@dropUseItems]
掉落包裹物品名称 <$SCATTERITEMNAME>
物品原拥有者名称 <$SCATTERITEMOWNERNAME>
物品所在地图中文名称 <$SCATTERITEMMAPNAME>
物品所在地图代码名称 <$SCATTERITEMMAPDESC>
物品所在地图坐标X <$SCATTERITEMX>
物品所在地图坐标Y <$SCATTERITEMY>

修复bug：

1.修复PC端部分装备格子自定义位置不生效的问题
2.修复滚动条消息sendmovemsg发送给个人时，滚动次数参数不生效的问题
3.修复在一些情况下人物会一直播放跑步动作的问题
4.修复裂神符不分裂的问题
5.修复法、道分身攻速与比自身不同的问题
6.修复技能魔御术有锁定目标时，使用时提示超出距离限制

优化内容：

1.优化手机端快捷栏操作，可以拖拽物品
2.隐藏主界面按钮命令clsMainUI执行命令时,屏蔽点地行走及NPC点击

资源编辑器：

支持24、25号装备位配置坐骑和翅膀

GM编辑器：

屏蔽字替换支持更改文件名

2022.2.17更新内容

新功能

命令：

1.离线挂机命令OFFLINEPLAY新增挂机角色是否显示在线参数
2.新增怪物尸体采集开关命令、怪物尸体清理命令

配置：

1.新增挂机寻怪模式配置：新模式下，先寻路到随机点，再寻找视野内的怪
;tejieconfig配置：
;autoPlayGameMode=1 （0或不写，当前挂机寻怪模式；1：新模式）
2.商城支持消耗绑定货币，支持优先消耗绑定货币设置
3.支持M2内死亡必爆设置
4.新增可采集尸体出现几率的配置文件：\Mir200\Envir\目录内增加配置文件：butchProfile.txt
;butchID（关联monster表内的butch编号） 出现几率百分比（0-100）
5.区服选择界面支持自定义Icon和Logo设置（GM管理后台配置：运营管理-游戏版本公告/介绍-版本Icon）注意：需要下载新版客户端才有

修复bug

1.修复套装不取下直接替换，不触发[@groupItemOff的问题]
2.修复某些情况下，背包页切换会失效的问题
3.修复PC端可叠加物品过万时，显示不全的问题
4.修复PC端商城购买限购物品，点击Max后显示的货币数值不对的问题

优化内容

1.优化召唤技能召唤出2个宝宝，初始站位会重叠的情况
2.扩大任务栏@块触发的点击区域

资源编辑器

1.新增可调用UI资源*25
2.新增头盔模型*6

GM编辑工具

1.商铺交易货币支持绑定货币，支持优先消耗绑定货币设定
2.支持M死亡必爆设置（查看-列表信息二-物品规则）

2022.1.26更新内容

新功能：

1.playCutHurt支持宠物攻击触发
2.新增道具添加/删除绿点提示命令addGreenPoint/delGreenPoint
addGreenPoint 道具名称
delGreenPoint 道具名称
3.自定义采集SHOWPROGRESSBARDLG时间、内容参数支持变量
4.绑定货币支持自定义图标
5.背包引导bagButtonInterfaceArrow支持背包道具格引导

修复bug：

1.修复自定义怪使用冰咆哮,配置的攻击威力读取DC属性,但仍然读取MC属性的问题
2.修复设置界面的自动元宝复活勾选后，tejieconfig内配置的不允许使用自动复活不生效的问题
3.修复系统回收功能背包最后一个格子的装备不回收的问题
4.修复SetItemState命令设置装备非绑定状态,显示文字错误的问题
5.修复手机端：设置界面取消勾选隐藏摇杆、固定摇杆位置不生效的问题
6.修复npcopenshowex自动寻路捡物品时会抖的问题
7.修复changeModeEx冰冻效果，怪物会一直被冰冻的问题
8.修复穿戴护身的情况下，伤害结果显示错误的问题
9.修复道士的宝宝在命令攻击后经常出现停在原地不动的问题
10.修复<$weekday>在机器人脚本内不生效的问题
11.修复掉落组掉落的问题

优化内容：

1.自定义采集SHOWPROGRESSBARDLG时间、内容参数支持变量
2.clsMainUI执行命令时,同时屏蔽PC版的打开背包快捷键

资源编辑器：

1.新增盾牌模型*7
2.新增头盔模型*13

2022.1.13更新内容

新功能：

1.新增文本命令：textex 单一文本支持多颜色设定
2.游戏设置增加“自动走位”开关项
3.M2-选项-功能设置-技能魔法-技能参数：支持魔法攻击范围限制 tejieconfig.txt增加开关： usemagicattackrange=0 0-关闭（默认） 1-开启
4.新增万分比控制血量命令：addHpPerEx 运算符(+-=) 血量万分比
5.bagItemIntoBox命令:放入道具支持数量参数
6.背包引导新增关闭按钮位置的引导
7.购买商铺物品时触发@BuyShopItem增加返回值:货币类型

修复bug：

1.修复手机端：tejieconfig配置不显示排行榜，还会显示的问题
2.修复一些情况下护身效果激活后被攻击仍然掉血的问题
3.修复回收功能对生肖及道具类装备无法回收的问题
4.修复手机端聊天-综合频道无法切换的问题
5.修复CLEARITEMMAP命令，清除指定区域所有掉落物品无效的问题
6.修复部分资源在PC端不显示的问题
7.修复自动寻路npc（opennpcshowex）角色会来回跑的问题

优化内容：

1.优化组队界面角色特效显示
2.GiveStateItem命令设置丢弃消失的物品，丢弃时会弹出确认框

资源编辑器：

1.新增tubiaotexiao1180 - tubiaotexiao1185
2.新增title273 - title440
3.新增可调用UI资源*8

2022.1.6更新内容

新功能：

1.新增addHpPer改变血量百分比支持小数
2.新增OK框内播放粒子特效命令：PlayParticleEffect
3.设置界面-战斗设置-道士辅助新增技能间隔接普攻、治疗术治愈自己选择
4.法师火焰墙加入群体技能释放列表
5.takeEquip增加回收数量参数
6.道具描述ItemDescList.txt 支持变量，例如：回城石=\-\146/返回主城/254/(双击使用)\254/今日使用次数:<$str(N111)>/<$str(N100)>
7.主界面右侧新增人物属性值增长的绿字提示，脚本触发的属性增加，需要提示的要在脚本中进行标记：具体搜索“人物属性值增长绿字提示”
;tejieconfig配置：
;是否浮动提示人物属性增加（1显示，0隐藏，默认隐藏）
attributeAddFloat=1
8.changeModeEx 24 新增扣蓝百分比参数
9.设置界面-战斗设置-其他：新增自动走位

修复bug：

1.修复套装有2个触发套装激活和失效对应不上的问题
2.修复PC端使用ese关闭OK框，物品没有返回背包的问题
3.修复分身会攻击同国家怪物的问题
4.修复组队界面角色模型特效缺失的问题
5.修复<$BOXITEM[0].MAKEINDEX>的问题

优化内容：

1.playModel命令(拖动可旋转)展示模型不加倾斜角度，playModelEx命令(拖动不旋转)展示模型保留倾斜角度
2.优化序列帧动态图标在对话框内的剪裁处理
3.宝箱界面美术资源替换
4.属性点分配界面美术资源替换
5.支持多级脚本<$CURRRTARGETNAME>.movex2写法

资源编辑器：

1.新增衣服模型*6
2.新增武器模型*5

2021.12.23更新内容

新功能：

1.itemshowex支持静态图道具
2.新增取消所有行会攻城命令：CancelAttackSabukAll （对应AddAttackSabukAll）
3.新增脚本变量：<$weekday> 获取当日周几，变量值 1-7 对应周一至周日
4.回收功能引导箭头：recycleItemArrow
5.支持师徒功能
6.新增尸体采集功能
7.怪物掉落文件#child支持掉落物数量配置

修复bug：

1.修复套装触发异常的问题
2.修复gamepoint等货币命令在默写情况下赋值“=”“-”时会出错的问题
3.修复假人可能会出现刀刀烈火的问题
4.小地图点寻路有时会闪退的问题

优化内容：

1.新版回收界面，点击奖励界面外任意位置，立刻关闭奖励界面
2.优化组队界面展示

资源编辑器：

1.新增盾牌模型*7
2.新增衣服模型*6
3.新增可调用UI

2021.12.16更新内容

新功能：

1.useBonusPoint新增攻击力、魔法、道术上下限属性
2.新增itemshowex：显示装备动态图标（仅支持有动态图标的道具）
3.新增地图刷怪时间调整命令：changeMonRenew （仅针对mongen.txt内刷怪间隔）

修复bug：

1.修复背包内双击使用物品时，快捷栏不播放物品使用间隔的问题
2.修复一些情况下，在M2内自定义技能无法保存的问题

优化内容：

1.排行榜美术资源替换
2.登陆和角色界面增加了一些特效
3.行会美术资源替换
4.拍卖行美术资源替换

资源编辑器：

1.新增地图*5
2.删除地图*4
3.更换部分icon资源

2021.12.9更新内容

新功能：

1.新增物品回收功能，可以通过GM编辑工具（M2）进行配置
2.新增命令：显示指定进度的进度条
3.支持NPC商店：买卖、修理、武器升级功能
4.新增命令：checkGuildName 检查指定字符串是否已创建过行会名称
5.新增命令：disband 解散行会
6.新增新的模型装备穿戴方式：使用新的方式，模型装备（武器、衣服、头盔、斗笠、盾牌）不再使用装备格子，而是直接穿到身上
Tejieconfig配置：
;穿戴装备方式（0=旧 1=新）
;isNewWearingMode=1
7.新增套装组功能：将不同套装通过套装组号关联，穿戴同组装备都可以触发套装效果 tejieconfig配置：isnewsuit=1
8.九宫格类对话框增加长宽设定支持：panelsize
9.mongen.txt参数17新加状态，支持掉落物跟随动画
10.主界面右上角自定义按钮加红点提示：增加红点：redpointAddBtn 删除红点：delRedpointAddBtn
11.对话框指定按钮加红点提示：增加红点：redPointDlg 删除红点：delRedPointDlg
12.新增NPC商店引导箭头：npcShopArrow
13.对话框新增复选框命令checkbox
14.新增提升按钮功能：popMenu
15.新增拉取充值接口功能：pullPay
16.新增实时刷新time文本:<time:x坐标:y坐标:时间变量:颜色:是否显示年月日(0不显示，1显示)>
17.新增playModelEx，支持粒子特效播放

修复BUG：

1.修复修改密码没有响应的问题
2.修复分身术多次装备属性的问题
3.修复噬血术吸血不生效的问题
4.修复mongen.txt怪物视野参数的问题：tejieconfig配置 isNewMonsterEye=1
5.修复怪物墓碑不显示的问题
6.修复tejieconfig内配置生肖按钮（位置编号：19）不能自定义图标和坐标的问题
需要开启配置，开始后时装位置17、18坐标也需要一起调整
;角色时装格子,是否支持配置
openFashionfidle=1
7.修复PC端查看装备显示错误tips的问题
8.修复addTextList及addTextListEx最后一次写入数据未能保存

优化内容：

1.游戏设置_基本设置_低画质设置不再控制是否显示怪物名字
2.对话框设定了panelSize，不要再进行区域裁剪
3.自定义装备底框支持使用补丁图片
4.交易邀请、组队邀请弹框资源替换（移动端）
5.组队界面美术资源更换（移动端）
6.交易界面美术资源替换（移动端）
7.关闭生肖界面时,如背包处于打开状态,不会同时关闭背包
8.邮件删除操作优化，手动删除一封后，如果列表下方还有邮件，会自动选中下一封
9.好友界面美术资源更换 （移动端）
10.聊天，角色，邮件界面上的小细节优化
11.绑定手机时, 确认信息修改
12.摆摊界面美术资源替换（移动端）
13.游戏设置界面美术资源替换（移动端）
14.执行NPC寻路前判定下是否有可拾取物，拾取后再寻路（不包括跨图寻路传送）
15.优化网络幻境差的判断机制
16.角色清理：没有充值且1个月未登录的角色会被删除

资源编辑器：

1.新增武器模型*10
2.新增衣服模型*2

GM编辑工具（M2）：

1.新增：查看-列表信息二-回收列表 配置物品回收列表
2.新增：查看-列表信息二-套装系统 配置套装组

2021.11.25更新内容

新功能：

1.支持排行榜变量：排名X的角色名称<$RANKINGPOWER[X].NAME>、排名X的角色战力<$RANKINGPOWER[X].POWER>
2.SetMySteriousMan增加角色名称根据职业显示为“无名武士”“无名法师”“无名道士”参数设置
3.新增获取怪物数量命令：getRangeMonCount
4.新增设定指定道具的掉落系数命令
（1）设置个人指定道具掉落系数：humanDropItem
（2）设置个人指定道具掉落系数：globalDropItem
5.新增脚本变量：主角当前的移动速度<$speed>
6.新增打开背包命令：openHumBag
7.新增脚本变量：职业：<$job> (0：战士；1：法师；2：道士) <$gender> (0:男；1：女)
8.新增隐藏主界面按钮命令：clsMainUI 需要和#say搭配使用才生效
9.新增手机卡顿模式切换提示
10.新增死亡警告红色边框效果
11.新增背包内可用道具绿点提示(需要配置，说明书内搜索：背包内可用道具绿点提示)
;是否显示背包内可用道具绿点提示：0-不显示 1-显示
;viewgreenpoint=1
12.战斗设置新增自动使用先天罡气技能开关
13.保护设置新增自动使用技能设置,可使用的技能在tejieconfig配置
;tejieconfig配置：
;[ProtectSet]
;1 小还丹 大还丹 鬼药 强身壮体丹
;2 回城石 随机石 第二大陆传送石
;3 施毒术 魔法盾 野蛮冲撞
14.新增怪物头顶特殊伤害飘字命令：playCutHurt
15.新增绑定货币 (说明书内搜索：绑定货币)
16.新增怪物墓碑功能 (说明书内搜索：怪物墓碑)
17.新增主动弹出自动使用框命令：openUseWindow
18.新增重置指定日常任务ID的状态命令：clearTask
19.新增自定义进度条
20.创建镜像地图，增加镜像永久存在设置
21.怪物掉落文件支持掉落物品数量配置
;怪物名称.txt
;1/10 掉落物名称 数量
22.新增创建行会时触发@块[@crtGuild]
23.新增以字符形式返回指定小数位的除法结果命令：getFloat
24.tejieconfig新增配置：
;配置该命令后，施毒术是否阻止怪物回血。（0回血，1不回血）
;poisonRecover=1
25.支持怪物身上播放特效：M.PlayEffect 资源名称 时间

修复bug：

1.修复手机端任务描述显示不全的问题
2.修复原地复活不触发qf内[@Revival]的问题
3.修复点击OK键后触发字段[@UpgradeDlgItem]会调用其他脚本的@块的问题
4.修复PC端置顶消息和聊天消息重叠的问题
5.修复道具表装备配置较大数值，显示会出错的问题
6.修复强化技能威力倍数读取错误的问题
7.修复使用text编辑文本位置，OK框大小不会自适应的问题
8.修复大刀卫士不攻击怪物的问题
9.修复称号描述、装备描述的切割数字内容不显示的问题
10.修复纵横剑术获取技能ID：<$CURRRUSEMAGICID>错误的问题
11.修复领取邮件内绑定物品的会变成未绑定的问题

优化内容：

1.优化挂机寻怪规则
2.游戏内按钮统一更换为大按钮
3.优化多条跑马灯消息SENDMOVEMSGEX的初始位置
4.优化登陆流程
5.更换邮件界面UI
6.更换生肖界面UI
7.更换地图界面UI
8.优化手机绑定流程
9.优化创建角色流程，当服务器不能创建角色且没有角色时创建弹出通用提示框
10.当有左上角OK框打开时自动隐藏任务栏
11.更换聊天界面UI
12.优化自定义货币图标等比缩放
13.更换登陆界面UI

GM编辑工具（M2）：

1.选项-客户端设置-内挂控制：游戏内设置界面初始化设置
2.查看-列表信息二-商铺列表：可配置根据开服天数、人物等级、人物转生等级显示商品

2021.11.11更新内容

新功能：

1.增加宝宝战斗状态
2.设置界面增加同屏人数设定
3.商城增加每日限购、永久限购配置（M2-查看-列表信息二-商铺列表）
4.tejieconfig配置增加：角色界面上主角动作
roleMode=1 1为举手 2为不举手动作
5.新增自动寻路打开指定NPC面板命令:
6.新增优先打指定打怪命令,支持多个怪物一起:killMobAppoint
7.新增怪物掉落展示:怪物掉落文件增加[display]
8.拍卖行增加vip等级、手续费显示
9.tejieconfig配置拍卖行：增加上架时间配置（[auctionvip]新增一列）、最低上架价格配置([setAuctionHouseCurrency]新增一列)
10.q-function新增：物理攻击暴击触发[@critAttack]、 魔法攻击暴击触发[@critMagicAttack]
11.装备数量相关命令：
（1）checkEquipNum 检测指定装备的数量：包含装备位与背包
（2）getEquipNum 获取指定装备的数量,包含装备位与背包
(3) takeEquip 系统回收指定装备,包含装备位与背包
12.ReleaseSkill增加释放的技能等级参数（默认为1级）
13.怪物属性扩展：增加反伤绝对值，且反伤怪物名字后加上[反伤]文字
14.changemodeex：增加护身吸收百分比（模式序号：24），抗反伤（模式序号：25）
15.新增检测聚灵珠满经验命令：checkExpBead
16.新增改变物品外观命令：changeitemshape
17.新增屏幕震动命令：SCENEVIBRATION
18.新增小地图备注显示
19.新增角色属性界面自定义属性名（tejieconfig内配置）
20.新增自定义货币图标（tejieconfig内配置）
21.新增怪物金币掉落：配置表中增加掉落配置 例如： 1/1 金币 2000 M2工具：选项-怪物设置-基本参数：可以设置金币堆
22.新增OK框内即时刷新倒计时timeTips（有单位转换，可转为时分秒）：<timeTips:x:y:参数1{scolor=159}/@触发>
23.新增OK框内即时刷新倒计时countDown（无单位转换，单位为秒）：<countDown:x:y:参数1{scolor=159}/@触发>
24.新增跑马灯消息：SENDMOVEMSGEX命令
25.新增强化等级（星星）套装属性（仅支持1-9星）
26.新增怨念buff
27.新增麻痹几率衰减

修复bug：

1.修复获取当前组队人数变量：<$groupmembercount> 获取数值错误的问题
2.修复主界面技能快捷键充值后，没有底板的问题
3.修复OK框内容超出框外的问题
4.修复穿戴称号套装属性不生效及属性增加不对的问题
5.修复部分范围切割命令没有判断攻击模式的问题
6.修复初始化假人性别和职业错误的问题
7.修复账号被顶后，再登陆会提示超时的问题
8.修复暴击伤害数值被怪物模型遮挡的问题
9.修复当前攻击力倍数剩余时间：<$powerratetime> 一段时间后会变成负值
10.修复espchangedamage参数二设置的伤害错误的问题
11.修复宝石镶嵌道具，使用补丁内的图标时，会显示错误的问题
12.修复OK框中变色后面的@块 无法触发的问题

优化内容：

1.物品来源隐藏怪物名字后的数字
2.服务器选择界面美术资源更换
3.手机端打开:商城/充值/地图/设置/排行榜/行会/创建行会/邮件界面时隐藏主界面
4.当没有资源更新时去除检查版本的进度条
5.断线重连小界面更换
6.手机版商城界面更换并增加限购功能
7.充值界面资源更换
8.高中低画质默认勾选项优化
9.邮件提示增加动效
10.手机号登陆界面点击确定后自动勾选同意协议并发送验证码
11.死亡复活界面、输入礼包码界面，加载进度条界面，快捷装备界面资源更换美术效果优化
12.更换创建角色界面
13.优化邮件领取及保存

GM工具（M2）：

1.选项-参数设置-游戏选项：增加测试服/正式服环境，切换选项，方便测试充值返利等功能
2.商城增加每日限购、永久限购配置（M2-查看-列表信息二-商铺列表）
3.选项-怪物设置-基本参数：可以设置金币堆大小

GM管理后台：

gm后台按照子渠道查询：调整字段顺序、新增统计字段

2021.10.28更新内容

新功能：

1.新增获取合服次数命令getJoinCount：取合服次数的最大值
2.新增检测合服次数命令checkJoinCount
3.tejieconfig新增tips物品来源显示开关
;显示或关闭物品来源信息（0关闭，1显示）
dropinfo=0
4.新增使用货币触发qf内@块,返回货币消耗值
5.支持地图参数
（1）NEEDSET_ON(001)
（2）NEEDSET_OFF(001)
（3）CHECKQUEST(Q001)
6.tejieconfig新增移动端持续战斗时，右上方自定义按钮组自动收起
;玩家持续攻击时(处于战斗状态20秒)，右上方的自定义按钮收起（0默认，1持续攻击收起）
autopackupcustombutton=0
7.永久增加人物元素属性命令：AddHumNewValue
8.MAKEPOSION、ChangeModeEx：参数二（状态时长）设置为0时，可以解除状态（不包括复活）
9.changeItemAddValue 对物品的属性修改，即使是没有定义的属性位置，也会记录下来，可以通过getItemAddValue命令来查询数值

修复bug：

1.修复M2设置火墙换地图消失没生效的问题
2.修复怪物不攻击假人的问题
3.修复首次登陆在脚本中弹出界面，界面不显示的问题
4.修复拆解物品OpenItemBoxEx不生效的问题
5.修复宝宝到达主人身边后，还会一直播放移动动作
6.修复自定义ok框，底板外的按钮不响应的问题
7.修复itemshow、itemshownum按钮无响应及显示错误的问题

优化内容：

1.sendemails物品增加物品来源为系统制造
2.内挂保护数值上限调整至99
3.文字按钮的点击区域整体放大
4.优化文字按钮点击效果
5.更换游戏启动的特戒引擎LOGO
6.更换通用OK框、提示框美术资源
7.手机端更换背包界面UI
8.手机端更换主界面UI
9.手机端更换新字体
10.手机端更换角色界面UI
11.手机端摇杆区域调整
12.手机端更换仓库UI

资源编辑器：

新增npc*10

GM管理后台：

1.运营管理-服务器管理增加合服次数显示
2.后台管理工具查询角色信息，增加生命值/魔法值显示
3.增加“全局变量一览”页面
4.增加合区以后初始化某个全局变量（仅支持G变量和A变量）

M2编辑工具：

!setup.txt内的数值超过设置范围时，提示具体的数值范围

2021.10.21更新内容

新功能：

1.命令ChangeHumAbility ：参数二的操作符 “-”，支持减去自身数值，最多减少到0
2.messageBox增加左对齐/右对齐/居中的参数
3.装备tips加入道具产出信息
4.新增技能强化威力倍数计算方式：M2-功能设置-技能参数-强化技能威力倍数 强化后的技能威力直接读取设置的威力倍数，比如：150 为基础伤害的1.5倍
需要在tejieconfig配置：NewLevelMagicPowerRate=1
5.增加新的伤害减免计算方式：[攻击力-目标防御*(100-忽视防御)%]*(100+攻击伤害-目标伤害减免)%
tejieconfig配置isUseNewDamageAntiRate=2
6.扩展强化等级/星星数量：至255级
7.更换随机名字库
8.购买商铺物品触发，增加返回总价（M1）
9.text命令增加字体大小参数
10.增加是否已经召唤拾取精灵的命令 checkSqjlStat
11.增加沙城相关命令：强制修改沙城归属、强制开启/停止攻城（无视M2设定）
12.mov同步GOM，支持以引号("")内的字符串，作为一个参数
例如：mov s$举例 " 一个 栗子 "
sendmsg 6 <$str(s$举例)>
输出结果为： 一个 栗子
13.新增获取当天充值总额的命令getDayRecharge、及脚本变量<$DayRecharge>
14.新增使用货币时，触发qf内@块
[@COST_GAMEGLORY]
[@COST_GAMEDIAMOND]
[@COST_GOLDCOUNT]
[@COST_GAMEPOINT]
[@COST_GAMEGOLD]
[@COST_GAMEGIRD]
[@COST_CREDITPOINT]
15.新增获取boxitem堆叠数量的命令： getBoxItemNum 参数一：boxitem序号 参数二：返回值
16.新增获取指定npc坐标命令：getNpcPos 参数1:地图名称 参数2:NPC名称 参数3：返回值1（X坐标） 参数4：返回值2（Y坐标）

修复bug：

1.修复movemontopos移动一次后，再次移动不生效的问题
2.修复RUNONWEEK未生效的问题
3.修复gotolabelex未生效的问题
4.修复M变量切换地图没清空的问题
5.修复changemodeex防冰冻对makeposion不生效的问题
6.修复人物称号文字重叠的问题
7.修复人物死亡后不复活，小退重登仍会触发[@revival]的问题
8.修复毒素武器中毒目标错误的问题
9.修复毒素武器施毒的那一次攻击没有伤害的问题
10.修复<$maxmac>获取的数值错误的问题
11.修复元素伤害反弹不生效的问题
12.修复mapeffect有部分特效播放不出来的问题
13.修复makeposion红绿毒不生效的问题
14.修复m.MAKEPOSION 12 对怪物的冰冻效果展示为麻痹效果的问题
15.修复限时时装时间到了不消失的问题
16.修复<$CURRRUSEMAGICID> 获取的魔法ID错误的问题
17.修复限时时装，穿戴后不即时刷新剩余时间的问题
18.修复限时时装，穿戴后每次小退就扣除一分钟的问题
19.修复拍卖行超时物品重新上架，货币错误的问题
20.修复OpenUpgradeDialog宝石升级界面资源丢失的问题
21.修复两个国家怪物互相攻击杀死后，没有掉落的问题
22.修复Z001地图会走到地图外的问题
23.修复人物称号偏左的问题

优化内容：

1.去除pc端messagebox自带“提示”字符
2.itemshow命令，增加显示物品自动特效及底框
3.命令PGSetMySteriousMan，显示“神秘人”即时刷新
4.text命令按钮文字下划线位置向下移动，以避免文字与下划线重叠
5.text命令解析时，对变量中的":"，不解析为分隔符
6.优化角色界面中的模型层级
7.优化角色界面中的主角动作
8.优化血量显示
9.增加适龄提示：适合18岁以上使用
10.创建角色界面当角色数量小于等于2时不显示翻页箭头
11.版本列表中只有一个游戏的在服务器进入界面不显示版本列表
12.主角名称/血量/NPC名称/怪物名称血量/宠物名称血量文字大小和字体调整和聊天框/走马灯字体调整
13.更换月灵的技能特效为灵魂火符
14.角色/怪物/宠物头顶血量数字显示规则修改
15.手机端角色背包界面记忆功能，手动打开背包和角色拖动位置后，下次打开在记忆的位置出现
16.主界上主角左侧飘字，屏幕左下角飘字，系统提示消息飘字的字体和效果修改

资源编辑器：

1.新增地图*2
2.新增装备模型*13
3.优化选择物品_模型时,显示与模型对应的图标id
4.资源编辑器返回选中对象使用的资源id
5.NPC名称移至模型前方
6.增加资源名称复制按钮

2021.9.26更新内容

修复BUG：

1.修复套装穿戴齐后，部分装备tips显示错误的问题
2.修复拾取精灵会出现血量数值的问题
3.修复同一个对话框内有多个物品框时，触发UNALLOWITEMINTOBOX时会将物品框的物品都放回背包的问题
4.修复jiguan1地图道具掉落位置过不去的问题
5.修复复活戒指在玩家复活后，持久没有及时刷新的问题
6.修复使用技能纵横剑术，施法者自己看不到技能特效的问题
7.修复挂机自动寻怪时，会出现一直徘徊的问题
8.修复冰咆哮冰冻效果为麻痹的问题
9.修复冰镰术、冰霜群雨设置冰冻效果不生效的问题
10.修复宠物被施毒后，会瞬间满血的问题
11.修复获取全身总强化数：<$upgradecount> 获取的数值错误的问题
12.修复自定义宝宝设定不攻击人物后，技能还会对玩家造成伤害的问题

优化内容：

1.拍卖行物品超时后，可以直接重新上架
2.更换人物血条
3.ok框内在使用2D资源时，资源不可以旋转
4.优化部分装备图标

资源编辑器：

1.新增地图*21
2.新增剑甲翅膀套装*3
3.新增基础装备*1

2021.9.16更新内容

新功能：

1.tejieconfig增加配置
自定义采集被攻击打断：（0或不配置，默认不打断，1打断）
progressBarType=1
2.RangeHarm、RangeHarmEx新增参数，是否考虑护身效果
3.新增qf内[@GiveItemEX],给任意物品触发
4.新增打开网站命令：OpenWebsite PgOpenWebsite
5.CheckHumInRange参数支持变量

修复BUG：

1.修复镖车主人距离过远，镖车被攻击不显示掉血的问题
2.修复itemshow展示物品，在某些情况下会出现2个道具tip的问题
3.修复套装配置HP、MP上限在角色信息界面显示错误的问题
4.修复种怪脚本缩小怪物后，掉血数字也会缩小的问题
5.修复tejieconfig配置自动拾取道具[pickitem],只配置一个时不显示的问题
6.修复怪物被冰冻后，还会继续攻击的问题
7.修复宝宝被攻击后，状态栏显示的血量没有更新的问题
8.修复某些情况下，读条回城后会一直滑步的问题
9.修复移动端打开技能界面时，使用技能书会出现技能显示错误的问题
10.修复某些情况下，背包箭头引导需要二次打开才显示的问题
11.修复死亡邮件内收到的怪物信息会显示怪物名字的序号的问题
12.修复配置默认ok框后，会多出一圈边框的问题
13.修复指向性技能的光标有时会不显示的问题
14.修复镶嵌宝石后，装备tip会出现大片空白的问题

优化内容：

1.多级脚本：支持<$CURRRTARGETNAME>.GOTO写法
2.优化倚天辟地伤害计算方式
3.读取配置项ReadConfigFileItem，在配置项不存在时，返回值为空
4.排行榜仅保留查看按钮

资源编辑器：

1.新增套装*3
2.新增基础装备*2
3.坐骑模型转移到物品配置内，可以快速配置

GM编辑器：

1.增加倚天辟地技能CD、攻击力倍数、攻击范围设置（选项-功能设置-通用技能-倚天辟地）
2.KM支持账号和手机号两种登陆方式

GM管理后台：

1.修改IOS打包过程中的文字显示
2.修复按照游戏版本查询，新增付费账号数错误的问题
3.定时任务按照时间排序

2021.9.9更新内容

新功能：

1.新增自定义怪物（M2-选项-怪物设置-自定义怪物）设置技能，当使用条件hp百分比设置为-1时，则忽略HP条件
2.新增Gm命令：Backstep 功能：后退一步
3.新增打开背包触发QFunction[@OpenHumBag]
4.账号登录界面添加重置密码
5.新增脚本召唤的宠物，继承MonSpAbilList.txt的属性扩展(tejieconfig配置)
;脚本召唤的宠物是否开启MonSpAbilList.txt的属性扩展， 0-不开启 1-开启， 默认不开启
;opensummonspab=0

修复BUG：

1.修复收取邮件内通过命令givestateitem给的绑定物品会变成不绑定的问题
2.修复<$DROPITEMNAME>不生效的问题
3.修复爆出物品时，没有配置触发@块的物品也会触发@块的问题
4.修复宝宝会主动攻击弓箭守卫和同国家怪物的问题
5.修复登陆时设置弹窗，层级高于loading界面的问题
6.修复CHECKSOCKETABLEITEM检测出的宝石，与实际镶嵌宝石不一致的问题
7.修复拍卖行道具特效在一些情况下显示错误的问题
8.修复拍卖行在筛选不同分类物品后，会加速物品计时速度的问题
9.修复在穿戴增加技能伤害百分比的装备后，对于0防御的目标，隔位刺杀造成的伤害会高于近身刺杀的问题（为不影响线上版本，使用新的计算方式需要在tejieconfig配置）
;穿戴增加技能伤害百分比的装备后，刺杀近身、隔位相同的伤害计算：不写或0为默认伤害计算(如增加50%伤害，近身伤害为1.5.隔位伤害为1.5*1.5)；1为近身、隔位相同伤害（0防御时）
;openSergum_12_AttackRate=1
10.修复野蛮冲撞释放后冲撞方向与角色朝向不同的问题
11.修复CHANGEITEMADDVALUE修改身上物品增加的属性没有即时刷新的问题
12.修复坐骑的上下马、受技能影响的问题
13.修复引导箭头在使用自定义输入按钮（@@Inputstring）时，不触发的问题
14.修复创建角色时，点击选择会导致模型消失的问题
15.修复在进入连续创建的镜像副本后，回城会导致npc不显示的问题
16.修复并支持部分多级脚本
17.修复PGAddHpPer零血不死的问题
18.修复脚本修改宠物血量，宠物中毒后，血量上限会错误的问题

优化内容：

1.优化qm内触发[@login]时，加载一些功能需要delaygoto的才能触发的问题
2.优化pc端手机登录，输入验证码后还需要点击一下界面才能跳转的问题
3.优化掉落表使用#call时，大小写的识别

GM编辑工具：

登陆GM编辑工具（M2）时，输入未注册的手机号，不会再发送验证码

资源编辑器：

1.修复点击物品会反复刷新列表的问题
2.新增基础装备模型*2

GM管理后台：

修复部分区服合完区后启动不起来的问题

2021.8.30更新内容

新功能：

1.拾取触发[@PickUpItemX][@PickUpItemEX]、给物品触发[@GiveItemX]，支持打孔镶嵌
2.坐骑可以挂在任意装备上：stditems表内Value19配置坐骑模型ID
3.用户注册-登录流程调整、增加适龄提示
4.实名认证增加1小时试玩：试玩期间不可充值；试玩结束需实名，否则不可进入游戏

修复BUG：

1.修复PC端背包自定义按钮响应区域过大，导致按钮响应错位的问题
2.修复移动端彻地钉技能特效显示错误的问题
3.修复屏蔽好友邀请未生效的问题
4.修复宝箱anicount值为100时，还会转动宝箱的问题
5.修复屏蔽陌生人私聊后，好友无法成功发送消息的问题
6.修复某些情况下玩家PK打人不掉血的问题
7.修复国家脚本刷巡逻怪部分参数不生效的问题
8.修复某些情况下会卡引导箭头的问题
9.修复自定义装备底框，装备界面使用指定图片不生效的问题
10.修复三头兽被击后在一些情况下一直播放受击动作的问题

优化内容：

1.兼容命令参数中使用Tab代替空格做分割
2.优化部分UI细节
3.优化部分序列帧特效，降低内存占用
4.优化模型影子支持alpha通道

资源编辑器：

1.修改部分怪物模型
2.修改部分图标资源
3.替换部分图标资源
4.补丁：ui、shj2、sqdsj、fugu更新
5.jdws92增加部分区域半透
6.新增坐骑*9
7.装备模型：20144、20145、20146、20147增加特效
8.修复装备标签读取不出来的问题
9.增加坐骑icon（物品-马牌分类）
10.新增衣服模型*2
11.新增套装模型*3

运营后台：

K2运营后台增加账号状态配置：正常/异常

2021.8.18更新内容

新功能：

1.tejieconfig内支持时装位置和生肖位置自定义（不配置则为默认位置）
;使用时装自定义时装位置（默认为0，不使用自定义位置；1为使用）
openFashionfidle=0
2.新增邮件一键删除
3.文本命令text支持负数坐标
4.新增用户协议和隐私协议
5.新增实名认证
6.text命令增加行间距参数
7.新增OKPanelPlayEffectEx：当前OK框调用特效
8.新增坐骑功能
9.checkMapSameMonCount、checkLoginCount参数支持变量

修复BUG：

1.修复PC端被禁锢后，仍然可以使用快捷键小退的bug
2.修复禁止原地复活的提示文本错误的问题
3.修复give命令获取货币时，显示错误的问题
4.修复十步一杀对超出范围的目标释放，仍然会产生伤害的问题
5.修复私聊内容换行后重叠的问题
6.修复被攻击时触发[@struck]不触发一些命令的问题（涉及的命令较多，本次修复了部分未支持的脚本）
7.修复使用命令addhpper某些情况下会造成怪物0血不死的问题
8.修复扣除货币的显示错误的问题
9.修复物品放入OK框后，点击快速装备仍然可以穿到人物身上的问题
10.修复senddelaymsg命令：%s显示错误的问题
11.修复手机端双击技能图标可能会变小的问题

优化内容：

1.优化查看排行榜会导致卡顿的问题
2.优化2D怪内存占用
3.优化buff时间的显示方式
4.优化部分PC端UI细节
5.优化传送戒指功能：（1）增加传送确认、（2）无效的坐标不传送

资源编辑器：

1.更新shj补丁
2.更新shj2补丁
3.新增zbgz补丁
4.新增mapui补丁
5.新增sqdsj补丁
6.新增一批基础装备模型
7.新增一批高级装备模型
8.新增时装套装模型*3
9.新增斗笠*3

运营后台：

1.修复角色信息查询区服错误的问题
2.修复删除的服务器的角色查不出来的问题
3.修复后台时间长了没操作后刷新页面就会白屏的问题
4.修复按渠道组统计数据无法显示的问题
5.申请提现结构调整，精确到6位小数
6.K2运营后台：游戏版本列表中增加自定义登陆渠道号
7.有充值的游戏版本不允许删除
8.K2运营后台：对账中心-申请提现中增加：提现规则文字描述

2021.8.5更新内容

新功能：

1.命令ANSIREPLACETEXT参数支持变量
2.命令killcallmob 参数支持变量
3.扩展NPC脚本点击触发带参数
4.新增脚本命令:关联give物品LinkGiveItem、give命令触发QF内[@GiveItemX]
5.新增系统调用的创建、删除npc命令（用于在robotmanage内调用）：CreateMapNPC DelMapNpc
6.mapinfo支持地图名字中含有中括号
7.拍卖行功能

修复BUG：

1.修复宝石镶嵌增加元素属性没效果的问题
2.修复手机端发送坐标时，显示多余符号的问题
3.修复聊天频道发消息会出现不一样的颜色的问题
4.修复使用UNALLOWITEMINTOBOX命令物品仍然可以放进OK框的问题
5.修复手机端聊天框信息显示不全的问题
6.修复PC端聊天框符号会显示错误的问题
7.修复怪物归属不刷新的问题
8.修复随机传送石等物品，在快捷栏使用剩1次时，无法继续使用的问题
9.修复服务器列表拉不出来显示是空的问题

优化内容：

1.优化隐身的效果
2.优化地图、道具、npc配置了错误资源时，会给一个默认的资源

资源编辑器：

1.新增标签功能
2.更新补丁

GM编辑器：

1.查看-列表信息二：增加物品是否可以拍卖选项
2.修改技能列表内的技能名称

2021.7.28更新内容

新功能：

1.tejieconfig内增加经验显示位置设置（屏幕中心点坐标为0,0）：
expDisplayPosition=x,y
2.新增任务引导箭头命令
通过任务ID引导：MissonGuideArrow 任务ID 提示文字内容
3.新增国战相关命令
4.更换登陆BGM
5.支持一个文本中可以存多个自定义变量

修复BUG：

1.修复2D怪被麻痹后还会播放被击动作的问题
2.修复ADDNAMELIST命令，保存后服务器重启，丢失数据的bug
3.修复自定义变量出现空值时，导致所有玩家无法保存变量值的bug
4.修复服版本一直报错导致服务器卡顿、网络异常或服务器维护的问题

优化内容：

1.优化多开提示文字内容
2.更换PC端属性点UI
3.优化修改密码完成后的界面跳转
4.优化资源边玩边下时会导致游戏卡顿
5.优化服务器列表
6.PC端，2.1.2版本不再游戏目录下输出日志

资源编辑器：

1.新增剑甲套装*3
2.新增图标特效*65
3.更新sg补丁、新增shj2补丁

GM后台：

1.增加显示/收起所有从服列表

2021.7.20更新内容

新功能：

1.新增玩家的镖车如果在跟随范围内，可以跟玩家一起通过传送点传送
2.兼容esp插件命令
（1）杀死怪物时，触发QF脚本 检测人物数据后决定是否爆出物品
（2）动态调整特殊状态：ChangeSP
（3）怪物鞭尸命令ESPMonItems
（4）全屏吸怪命令MoveMonsters
（5）切割命令DelMonHp、DelMonHpEx
3.兼容pg插件命令
（1）qf内增加宝宝攻击触发
（2）怪物掉落物品时触发 [@PGDropItem]
（3）嘲讽范围内的怪物：PGDoTaunt 、 PGDoTauntEx
（4）脚本变量
4.monster表支持添加模型缩放倍数字段：Scale （百分比倍数，如100为1倍大小，120为1.2倍）
5.新增时间戳变量<$timestamp>
6.mongenex命令：
支持参数9：国家ID(属于哪个国家的怪物，没有可以为空)
支持参数10：同一个国家玩家是否可以攻击怪物功能(0不可以,1可以)
新增参数16：是否可以攻击同国家的玩家(0或空不可以,1可以)
新增参数17：不同国家怪物是否可以互相攻击(0或空不可以,1可以)
7.新增查看人形怪装备功能
8.探测功能
道具类型为戒指、项链、手镯、头盔，shape=121时，装备具有探测功能
支持套装属性的探测功能
使用方法：@searching 对象名称 或者 @探测 对象名称
9.tejieconfig内增加配置
;探测功能使用间隔（秒）,不写默认为0
SearchingTimeCD=0
10.增加释放技能命令：
角色释放技能：ReleaseSkill
宝宝释放技能：slaveReleaseSkil
11.新增角色静止命令：
角色静止：stopAction
宝宝静止：slaveStopAction
12.人形怪支持模型缩放
13.SENDMOVEMSG增加置顶显示参数
SENDMOVEMSG 信息类型代码(0全局发送，1发送给个人) 字体颜色(0-255) 背景颜色(0-255) Y坐标 滚动次数 信息内容 是否置顶（0，否；1，置顶层级）
14.文本编辑命令<text:文字内容:X:Y:列宽>，增加列宽设置，超过设置的列宽，文本自动换行
15.tejieconfig增加配置：
;OK框的默认底框配置，不配置时使用现在的默认底框
defaultOkPanel=资源名称

修复BUG：

1.修复邮件领取附件后，没有刷新可领取物品状态
2.修复部分地图会卡住怪物的问题
3.修复人形怪无法寻路到一些地图的角落的问题
4.修复切换版本时，不刷新版本名称的问题
5.修复PC端文字备注偏移过远的问题
6.修复PC端tip文字在特定位置会一直闪的问题
7.修复随机生成的名字会和屏蔽字冲突的问题
8.修复某些情况下，messagebox按钮不执行@块的问题

优化内容：

1.更换PC端生肖界面UI
2.更换PC端行会日志界面UI
3.更换PC端摆摊界面UI
4.更换PC端邮件UI
5.更换PC端交易界面UI
6.更换PC端设置界面UI
7.PC端增加聊天窗口
8.宝箱领取优化

资源编辑器：

1.新增可调用特效资源*2
2.新增三国风格npc*22
3.新增斗笠*18
4.新增3D怪*11
5.修复编辑物品图标时会返回顶部的问题
6.因未关闭DB表导致卡进度时，增加提示

GM管理后台：

1.查询角色信息时，增加角色逻辑变量的显示
2.查询充值金额时，显示的单位改为（元）

2021.7.8更新内容

新功能：

1.新增脚本变量：好友数<$FriendsCount>
2.img新增设置宽度、高度参数
<Img:图片名称:X横向坐标:Y纵向坐标:是否灰化（0不灰化，-1灰化）:缩放倍数:宽度:高度/@Label>
3.支持monster表attack_spd字段:攻击CD时长（单位：毫秒），需要在tejieconfig内配置开启
;是否使用monster表内Attack_Spd字段， （1使用，0不使用）
useMonsterAttackSpeed=0
4.新增任务类型：支线任务，未完成任务不会次日刷新
PICKUPTASK 参数1 参数2 参数3 参数4
参数1-任务类型（1主线2日常3支线） 参数2-任务编号（自定义） 参数3-任务名称 参数4-任务目标（支持变量支持颜色）
5.新增设置：隐藏不拾取物品
6.RECALLMOB增加一个参数：是否无敌
RECALLMOB 怪物名称 宝宝等级(最高为 7) 叛变时间(分钟) 是否自动变色（0、1）固定颜色（1-7） 缩放倍数（不填写默认为1）属性倍率 是否无敌（默认0正常，1无敌模式）
7.兼容esp插件命令
（1）宝宝用百分比切割命令BDelMonHp，BDelMonHpEx
（2）解毒命令ESPDETOXIFCATION
（3）循环脚本运行次数ESPLoopGoto
（4）判断一个时间段的剩余时间StrComp
（5）脚本变量
（6）调整攻击伤害倍数：ESPChangeDamage
（7）范围伤害命令ESPRangeHarm
（8）获取背包指定物品的数量 ESPGetItemsNumber
（9）被攻击后回调HookStruck、HookMagicStruck
（10）根据物品Idx获取物品数据库字段参数值：PGGetDBIdxItemFieldValue
（11）根据物品名获取物品数据库字段参数值：PGGetDBItemFieldValue
8.兼容PG插件命令
（1）获取背包内指定道具的数量命令：PGGetItemsNumber
（2）获取指定人物的指定变量值信息：PGGetHumVar
（3）脚本开关神秘人PGSetMySteriousMan
（4）脚本整理背包PGQueryBag
（5）取随机值：PGRandomEx
（6）血量控制检测：PGCheckHpPer、PGCheckMpPer、PGAddHpPer、PGAddMpPer
（7）全屏吸怪PGMoveMonsters
（8）分割数字到变量：PGSplitNumber
（9）分割字符串：PGExtractString

修复BUG：

1.修复装备tip有时不显示的问题
2.修复tejieconfig内okBtnSize设置不生效的问题
3.修复pc端走马灯消息在改变分辨率时位置错误的问题
4.修复PC端多个好友私聊时消息看不到的问题

优化内容：

1.引擎LOGO 健康游戏公告 创角界面更换
2.调整任务追踪界面位置
3.快捷栏的道具拖回背包时将快捷栏的道具取消，拖出屏幕执行丢弃
4.删除道具不存在的提示
5.优化查看其它玩家信息ui

资源编辑器：

1.新增补丁资源预览功能
2.更新sg，shj补丁

2021.7.1更新内容

新功能：

1.新增手机端主界面增加固定商城按钮
2.支持行会相关命令
(1)行会建设相关
(2)调整行会人数上限
(3)添加行会成员
(4)删除行会成员
(5)检查当前场景中的人物是否属于一个行会
(6)检测人物是否加入行会
(7)检测行会可容纳的成员数量
(8)检测行会是否在列表中
3.新增mongen.txt怪物归属配置
4.PC端新增快捷键
(1)挂机/停止挂机:ctrl+alt+x
(2)打开/关闭大地图：M
5.设置-基础设置界面新增“显示快捷装备”设置
6.包裹物品放入OK框命令BAGITEMINTOBOX参数支持变量
7.RecallMob增加模型大小缩放参数
RECALLMOB 怪物名称 宝宝等级(最高为 7) 叛变时间(分钟) 是否自动变色（0、1）固定颜色（1-7） 缩放倍数（不填写默认为1）
8.Q-function增加宝宝攻击触发@块
9.增加获取宝宝坐标的变量：<$S.X> X坐标 <$S.Y> Y坐标 （仅支持单只宝宝）
10.messagebox扩展：现在可以设置4个@块
11.OPENUPGRADEDLG增加坐标参数
OPENUPGRADEDLG 显示的名称 X坐标 Y坐标

修复BUG：

1.修复PC端OK框中道具TIPS显示的时候会闪一下
2.修复手机端ok框资源丢失的问题
3.修复魔御技能图标显示错误的问题
4.修复pc端聊天框显示位置问题
5.修复手机端聊天框消息显示不全的问题
6.修复npc商店资源丢失的问题

优化内容：

1.优化PC端装备道具TIPS的字体
2.优化PC端技能界面中技能描述
3.技能在冷却时显示cd中提示

资源编辑器：

1.新增npc*8
2.新增shj补丁
3.新增sg补丁
4.新增7只2D小宠
5.新增3只3D宠物（备注：宠物没有攻击、死亡动作，仅支持做拾取精灵）
6.套装*1

2021.6.24更新内容

新功能：

1.新增合服后有多于2个角色时，按照转生等级、角色等级排序
2.新增命令CheckStoneCount，检测玩家身上装备已镶嵌的某宝石的总数
3.OKPanelPlayEffect命令增加缩放倍数参数（参数5）

修复BUG：

1.修复快速穿脱装备可能会卡住的问题
2.修复某些情况下，装备信息tips会显示错误的问题
3.修复世界频道发言等级与设置不符的问题

优化内容：

1.优化客户端掉血数字显示重叠问题
2.优化PC端字体显示
3.优化部分光柱资源过大的问题

资源编辑器：

1.新增套装模型*6
2.新增npc*4
3.新增2D怪物*41
4.新增部分地图
5.新增补丁：shj

2021.6.17更新内容

新功能：

1.最高攻速上限由69提升至120
2.tejieconfig增加是否显示怪物尸体配置：corpseShow=0 （默认0或空：显示 1：不显示）
3.新增命令：ReadConfigFileItem 读取配置项； WriteConfigFileItem 写配置项
4.新增命令：PGDelMonHpEx 范围内百分比切割(加强)
5.新增PC版多开限制：最多开3个客户端

修复BUG：

1.修复动态图标在生肖位没有动态效果的问题
2.修复小地图坐标显示不全的问题
3.修复按钮设置颜色时，无法进行引导的问题
4.修复mongenex命令召唤人形怪加载不到配置的问题
5.修复pc端生肖界面，1号位置重装时出现显示错误

优化内容：

1.优化客户端飘血效果
2.优化pc端ok框适配
3.优化部分界面文本显示不全

GM编辑器：

增加怪物尸体清理时间功能：选项-游戏参数-时间控制

资源编辑器：

1.新增2D怪物
2.新增光柱
3.新增地图排序

2021.6.10更新内容

新功能：

1.PC端物品快捷键调整
2.新增检测幸运值命令：checkluckypoint，checkluckypointex
;数值为幸运值，幸运值 > 数值时为1 否则为0
checkluckypoint 数值
;检测人物的幸运值是否符合条件
checkluckypointex 控制符(>，<，=) 数值

修复BUG：

1.修复OPENUPGRADEDLG界面资源丢失及销毁不生效的问题
2.修复进行装备对比时，不显示“当前装备”的问题
3.修复takew命令不回收生肖栏物品的问题

优化内容：

1.优化PC版UI
2.优化移动端任务栏显示

资源编辑器：

1.新增地图资源
2.新增动态装备资源，可通过资源编辑器->物品

2021.6.3更新内容

新功能：

1.更换pc版ui
2.OK框内播放特效命令（tejieconfig需要配置使用新的OK框才生效）：OKPanelPlayEffect
3.新增【跨服货币】：<$CrossServerGold>，<$CrossServerPoint>，<$CrossServerDiamond>
4.新增删除当前角色命令：delrole
5.背包自定义按钮增加PC端配置命令：PCSETITEMBAGBUTTONINFO
6.tejieconfig新增全屏吸怪技能参数设置

修复BUG：

1.修复移动端itemshow触发问题
2.修复组队申请同意后，倒计时不消失的问题
3.修复PC端装备特效显示错误的问题
4.修复take数量为0时，扣除道具数量错误的问题
5.修复openMerchantBigDLG被背包按钮调用时，微调坐标不生效的问题

优化内容：

1.优化怪物选中区域
2.优化messagebox信息显示

资源编辑器：

1.新增npc
2.新增2D怪物*16
3.新增拾取精灵模型：狗、驴、鹰
4.新增3套剑甲模型
5.新增动态装备icon资源
6.新增可调用特效

2021.5.20更新内容

新功能：

tejieconfig内传送戒指功能增加CD时间设置（单位：秒），不填写默认为0
;传送戒指功能使用间隔（秒）
MoveTimeCD=8

修复BUG：

修复魔法攻击触发[@attack]的问题

优化内容：

优化鼠标悬停逻辑

资源编辑器：

1.新增2D怪物
2.新增部分NPC
3.新增地图

GM管理后台：

GM后台管理工具增加U、T变量查询功能

2021.5.13更新内容

新功能：

1.createnpc命令增加npc存在时间参数
2.stditems表增加FrameAnimation列，支持穿戴在装备栏的装备使用动态图标（现有动态icon资源：animatedicon_001 ~ animatedicon_005）

修复BUG：

1.修复gamegold命令“=”为增加货币的错误
2.修复自定义按钮1没有底框的问题
3.修复Boss_ChiYanYaoWang技能特效不销毁导致卡顿的问题

优化内容：

1.PC版UI优化
2.优化怪物选中区域
3.优化鼠标悬停tips的显示问题
4.优化属性界面排版：魔御和攻击位置调换

资源编辑器：

1.新增5件复古衣服
2.新增2套套装（武器+衣服+翅膀）
3.新增可调用特效资源

GM后台管理工具：

查询角色信息时，增加生肖装备信息的显示

2021.5.7更新内容

新功能：

1.新增PGchangeSP命令
2.tejieconfig增加配置
;背包内高属性装备是否显示提升箭头（默认0，全部显示；1，全部不显示；2，不满足穿戴条件的不显示）
showliftarrow=0
3.tejieconfig增加配置
;针对使用tips的文本写法，如：<使用新的OK框文字大小|文字大小/SCOLOR=250>\(默认0，放大的字体；1，普通字体大小)
tipsUseCustomOKPanel=0
4.新版PC端UI
5.新增技能 幽灵盾：Effect配置 14 全屏吸怪：Effect配置 301

修复BUG：

1.修复镜像副本倒计时显示错误问题
2.修复sendtipsmsg命令消息显示层级问题
3.修复地图参数NOPOSITIONMOVE导致小地图无法寻路的问题
4.修复senddelaymsg的%s解析错误

优化内容：

1.设置界面增加画质设置：目前仅针对人物模型特效进行处理
2.优化怪物模型：Boss_ChiYanYaoWang Boss_BingChuanJuShou Boss_YanMo hama Boss_SanTouShou
3.优化怪物：Boss_ChiYanYaoWang攻击效果

资源编辑器：

1.更新编辑器UI
2.增加可调用动态UI资源

2021.4.22更新内容

新功能：

1.tejieconfig新增自动穿戴倒计时配置
;自动穿戴倒计时（不设置默认为10）单位（秒）
automaticweartime=10
2.新增脚本开关复活：PGSetRevival、麻痹：PGSetParalysis、护身；PGSetMagicShield 命令
3.新增伤害加成命令 物理：PGSetDamageAdd 魔法道术：PGSetMagicDamageAdd
4.新增神秘人脚本命令：SetMySteriousMan
5.新增调整角色速度命令：ChangeSpeedex
6.新增tips提示消息命令：sendtipsmsg
7.新增背包自定义按钮的引导：BAGBUTTONINTERFACEARROW
8.新增假人读取玩家数据并穿戴装备的命令：LoadPlayConfig
9.背包自定义按钮命令SETITEMBAGBUTTONINFO 增加按钮宽、高设置参数
10.支持麻痹(ParalysisItemList.txt)复活(RevivalItemList.txt)护身(MagicShieldItemList.txt)配置文件

修复BUG：

1.修复时装柜更换外显时装时，翅膀残留的问题
2.修复引导箭头在一些情况下不消失的问题

优化内容：

1.优化SENDDELAYMSG、RecallMob、AddButton参数支持变量
2.优化时装柜未激活时装不显示属性的问题
3.优化未激活装备特效框显示问题
4.优化商城界面UI
5.优化充值界面UI

资源编辑器：
1.新增剑仙套装
2.新增一些称号
3.新增补丁

GM编辑器：

优化文本内容重载数据

2021.4.15更新内容

新功能：

1.拾取精灵增加是否显示精灵名称参数
RECALLJINFLING 名称 移动速度 捡取范围 捡取时间 捡取距离 跟随距离 持续时间 模型大小（0.1为0.1倍，2为2倍，1为正常大小） 是否显示精灵名称（0不显示；1显示；默认为1显示）
2.tejieconfig内配置生肖界面：可以自定义调整装备框位置及数量(详见配置说明)
3.爆率文件支持#call调用（#call调用的@格式，必须和爆率文件的格式一样）
4.changemodeex增加复活 参数1:23 参数2：复活血量百分比
5.新增地图参数 NOPOSITIONMOVE 配置后地图内具有传送功能的物品不能传送
6.tejieconfig内增加配置：invisibeltoplayers=1 changemodeex命令是否对玩家也隐身(默认为0，不隐身 ；1隐身)
7.ChangeHumAbility增加一个真实伤害的属性：30
8.商城交易货币新增支持声望、灵符、荣誉值
9.新增角色状态：蛛网、冰冻、定身、禁锢（详见人物状态说明）
10.新增怪物简装显示：开启后模型显示为稻草人模型，在设置内开启
11.增加一组喝药设置

修复BUG：

1.修复祝福油增加幸运错误的问题
2.修复时装武器强化错误的问题
3.修复命令CreateNPC的一些问题
4.修复拾取精灵血量显示问题

优化内容：

1.优化SendCenterMsg长消息的显示
2.优化OK框和背包重叠的显示

资源编辑器：

新增3件武器，2件衣服 1件翅膀

2021.4.9更新内容

新功能：

1.新增脚本变量
<$ServerName> 服务器名字
<$PKPOWER> 当前攻击造成的伤害
<$ATTACKMONSTER_MAXHP> 当前锁定怪物总血量
<$GODBLESSITEM1>~ <$GODBLESSITEM12> 生肖盒道具名称（对应1-12个位置）
2.新增设置对话框中文字坐标命令<text:文字内容:X:Y/@触发>
3.新增修改宝宝属性的命令ChangeSlaveAbility
4.新增道具类型stdmode=29 装备位置：2
5.新增特殊道具：传送符
DB配置：name= 传送符 stdmode =25 shape=6 消耗品 每次使用消耗耐久1000
6.imgbutton按钮文字颜色设置
7.新增时装柜功能

修复BUG：

1.修复生肖装备强化不加属性的问题
2.修复rangeharm的伤害问题

优化内容：

1.优化普攻不受伤害抵抗影响的问题
2.优化createnpc、delnpc命令支持变量
3.优化RECALLJINFLING支持变量

资源编辑器：
1.新增3套武器衣服翅膀套装
2.新增复古布衣女

GM编辑器:

编辑器热更功能

2021.4.2更新内容

新功能：

1.tejieconfig配置，新增忽视防御百分比最大生效值
;忽视防御百分比最大生效值（如果不配置则按照实际生效属性计算）
ignoredefense=50
2.人物特效增加一个播放组命令playEffectRole
3.;脱战回复血量设置（数值代表百分比，如BloodReturnVelocity=10代表每秒回血10%，默认为10%，0为不回复）
BloodReturnVelocity=10
4.支持脚本变量：当前攻击力倍数<$POWERRATE> 当前攻击力倍数剩余时间<$POWERRATETIME>
5.tejieconfig配置，新增物品掉落间隔控制：同一个道具配置了两种生效对象时，以本服的掉落间隔为准
[Dropinterval]
;道具名称 掉落间隔(分钟) 生效对象（0：个人 1：本服）
治愈术 120 1
6.M2支持套装的传送设置

修复BUG：

1.修复发送消息时多层变量的解析问题
2.修复文本中间空格会失效的问题
3.修复[@Attack][@MagicAttack]触发错误的问题
4.修复img命令缩放后底板没有变化及点击后恢复原大小的问题
5.修复scolor解析错误的问题
6.修复切换新老UI时会显示错误的问题

优化内容：

1.GetCustomItemText、GetCustomItemTextColor装备位置为-1时，获取OK框内物品信息
2.优化自动拾取显示排序

资源编辑器：

1.优化补丁显示排序
2.优化选取逻辑
3.增加道具分类
4.增加了两组魂环特效
5.增加一些光柱

2021.3.25更新内容

新功能：

1.Img命令增加图片缩放参数
<Img:图片名称:X横向坐标:Y纵向坐标：是否灰化（0不灰化，-1灰化）：缩放倍数（可不填写，不填写为1正常大小）/@Label>
2.tejieconfig配置增加开关AutoRecallMob，开启后自动召唤技能不判断是否有拾取宝宝，只判断战宠，无战宠时自动召唤，默认0不开启，1开启
AutoRecallMob=0
3.新增玩家使用称号触发的命令[@TitleChanged_XX]、取消使用称号时触发的命令[@Untitled_XX] XX代表物品DB中的Shape
4.传送戒指功能：道具shape=112时，穿戴物品可以使用点击小地图位置或NPC传送 或者使用传送命令:@move X坐标 Y坐标
5.新增宝箱功能（详搜宝箱说明）

修复BUG：

1.修复文本变量的解析问题
2.修复召唤兽状态显示

优化内容：

1.优化PlayModel命令模型加载方式
2.自动喝药列表支持滑动
3.小地图增加目的地坐标显示

资源编辑器：

1.优化雷霆服装特效
2.新增烈焰、光芒衣服
3.新增天界武器、衣服
4.资源编辑器热更功能

GM编辑器：

新增宝箱的配置功能（M2-列表信息二-宝箱列表）

2021.3.18更新内容

新功能：

1.新增tejieconfig内可配置战力排行榜是否显示战斗力数值
;战斗力排行榜是否显示战力数值（默认1，1显示，0不显示）
RankingListFightPower=1
2.新增切割命令：PGDelMonHp 参数1 参数2 参数3 参数4
参数1 百分比或切割值
参数2 0：当前HP的百分比，1：以参数1的值切割，2：最大的HP的百分比
参数3 0：不判断嘲讽 1：嘲讽过的怪才切割
参数4 0：默认切割 ，1：切割角色 ，2：切割英雄 ，3：切割怪物
3.聊天框掉落消息可以单独屏蔽

修复BUG：

1.修复称号会被NPC遮挡的问题
2.修复爆裂火焰特效

优化内容：

1.优化OK框材料使用后会直接放回背包的问题
2.AddButton命令和DelButton命令增加的按钮即时刷新
3.优化OK框放入装备和叠加物品的显示
4.优化自动拾取物品的逻辑

资源编辑器：

1.新增4个光柱特效
2.新增5衣服，1武器，1翅膀模型资源
3.新增补丁资源：ui（可在物品内查看）
4.增加地图大小显示
5.优化编辑器性能

2021.3.11更新内容

新功能：

1.脚本命令：GetDBItemFieldValue 获取物品指定字段值
格式：GetDBItemFieldValue 物品名称/IDX 字段名 变量
2.脚本命令：CALLBACKJINGLING 收回RECALLJINFLING召唤出的拾取精灵
格式：CALLBACKJINGLING 精灵名称
3.增加了播放动态图的命令 (需要在tejieconfig内开启使用新的自定义OK框)
格式：<playflash:资源名称：坐标X：坐标Y：放大比例>

修复BUG：

1.修复IOS平台2D怪物图集错误问题
2.修复堆叠物品数量过多，导致物品错误的问题
3.修复穿戴加等级的装备后，等级显示不正确的问题
4.修复背包界面的货币显示会出现白图的问题
5.修复tejieconfig配置CHANGESPEEDSHOW=0时，仍然显示增加的攻速的问题
6.修复特殊情况下，放入OK框的物品会消失的问题

优化内容：

1.更换创建角色UI界面
2.使用CLEARMAPMON清怪后，不会留下怪物尸体
3.优化不同攻击模式下的目标切换逻辑
4.优化小地图显示
5.优化say命令的弹出逻辑

2021.3.4更新内容

新功能：

1.脚本命令-playmodel-新增参数 (需要在tejieconfig内开启使用新的自定义OK框)
playmodel:模型编号:X横向坐标:Y纵向坐标:UI缩放比例:模型缩放比例:男女:武器ID:斗笠ID:翅膀ID:特效ID
男女：男 = 0 ； 女 = 1
武器ID、斗笠ID、翅膀ID、特效ID：不填写默认为0

2.支持命令PlayEffect 在模型上播放特效
格式：PlayEffect 资源名称 时间
时间：为 -1 时持续存在，大于0时按时间销毁，计时单位为毫秒

3.新增命令获取自定义装备文字内容命令 GetCustomItemText
格式：GetCustomItemText 装备位置 变量

4.获取装备自定义装备文字内容的颜色 GetCustomItemTextColor
格式：GetCustomItemTextColor 装备位置 变量(0~255)

5.新增技能抵抗百分比最大生效值（tejieconfig内配置）最大生效值不影响面板显示
;技能抵抗百分比最大生效值（如果不配置则按照实际生效属性计算）
SkillResistance = 50

6.新增背包内自定义按钮功能 命令SETITEMBAGBUTTONINFO
格式：SETITEMBAGBUTTONINFO 按钮编号 （1-5） 是否可见（0不可见，1可见） 坐标X 坐标Y 提示信息（按钮上文字）
点击对应按钮可触发Qfunction-0 中对应的@块
@itemBagButtonClickX (X为按钮编号)

7.新增获取背包内指定道具的数量命令：PGGetItemsNumber
格式： PGGetItemsNumber 参数1 参数2
参数1 ：道具名称 参数2 ：数量变量

修复BUG：

1.修复邮件会漏发的问题
2.修复playdice无法跳转标签页的问题
3.修复OK框物品在某种情况下会消失的问题
4.修复会卡在下载补丁界面的问题
5.修复OK框道具残留问题
6.修复关闭OK框物品没有回到背包的问题
7.修复带颜色值的按钮解析出错的问题

优化内容：

1.优化模型斗笠位置
2.优化ok框显示叠加道具数量
3.优化减伤系数算法，使一些版本在减伤达到100%时，不会出现打不掉血的情况
在tejieconfig内配置是否启用新的算法
;是否启用新的伤害减免计算方式(=1时开启，默认为不开启)
isUseNewDamageAntiRate=1
4.优化生肖界面UI
5.优化地图界面布局
6.优化自定义怪物技能：附加伤害增加默认值

GM后台管理工具：

增加通过绑定手机号查询角色信息的功能

2021.2.26更新内容

新功能：

1.增加装备爆率衰减功能
在tejieconfig中增加DropItems节点（用来控制单个道具的爆率衰减）
道具名 开服小时 开服小时掉落系数 全服第N件开始衰减 全服衰减系数 个人第N件开始衰减 个人衰减系数
治愈术 3|12|16 1.5|1|0.8 5|8|14 1.5|1|0.8 5|8|14 1.5|1|0.8
当前道具爆率=开服小时掉落系数*全服衰减系数*个人衰减系数
2.新增命令RandomEx 格式：Randomex 参数1 参数2 参数1为子，参数2为母，母是随机范围，当随机值小于或等于子值，就执行脚本
3.新增命令SENDMAILS 格式：SENDEMAILS 邮件标题 内容 奖励物品,数量|奖励物品，数量
4.MAPEFFECT、ADDMAPGATE命令参数支持变量
5.新增命令CONTINUPISDROP （怪物死亡时触发多一次掉落） 格式：CONTINUPISDROP 怪物名字

修复BUG：

1.修复宝宝设置休息状态后，玩家无法抢走仇恨的问题
2.修复随时传送石传送区域错误的问题
3.修复部分地图传送进去不能走路的问题
4.修复相同金额的不同档充值记录错误的问题
5.修复命令CHANGECUSTOMITEMPROGRESSBAR参数显示错误问题
6.修复充值界面tips条点击后直接弹出充值界面的问题
7.修复部分NPC模型点击不到的问题

8.修复角色改名导致的捐献排行失效问题

9.修复因缺少补丁导致无法进入游戏的问题

10.修复模型遮挡文字按钮的问题

优化内容：

1.优化角色名字被翅膀遮挡
2.优化私聊等级限制
3.优化整理仓库时，物品可以自动堆叠
4.更换UI界面

5.优化弹窗开关逻辑

6.优化自定义怪物技能：附加伤害增加默认值

7.优化脚本命令imgbutton解析方式

资源编辑器：

1.新增雷霆系列时装（男、女）
2.新增复古布衣（男）、凤天（男）、重盔甲（男）
3.新增40个仙剑风格NPC，3个人形NPC
4.新增一批道具ICON

GM编辑工具：

增加了数据库报错的相关提示：
1.ERROR Skill表没有这个技能sId ->引擎不支持的技能
2.ERROR 添加到非法坐标 ->NPC或传送阵位置设置错误（如设置在阻挡区）
3.ERROR 超级无限地图中对象数量= XXXX->配置了一个错误的地图 或配置传送地图错误

2021.1.28更新内容

新功能：
 1.怪物类型为128的怪物作为宝宝时为镖车的特殊功能实现
 2.实现了：$DLGITEM.NAME、$DLGITEM.STDMODE、DLGITEM.DURA、$DLGITEM.DURAMAX这几个变量
 3.增加了在聊天框中插入道具发送出去的功能
 4.引擎3.0增加自定义补丁功能，需要在tejieconfig中配置对应版本需要调用的补丁
 5.引擎3.0开放基于像素算法的OK框，需要在tejieconfig中进行配置开启。（推荐以后新的制作版本都开启这个功能，涉及到OK框中插入图片的都会基于像素来计算）

修复BUG：
 1.人形怪在大地图上显示的是白色方框的问题
 2.选择未解锁的背包，然后打开OK框，OK框是空的信息没有加载进来的问题
 3.摊位图片没有加载出来的问题
 4.人形怪在打人追击过程中会卡住原地走的问题
 6.自定义怪物无法使用到宝宝身上的问题

优化内容：
 1.优化了开天斩和逐日剑法的攻击算法
 2.优化自动拾取宝宝的灵敏度

GM编辑工具：
 1.自定义怪物技能附加攻击伤害中增加了默认值
 2.增加了数据库报错的相关提示

资源编辑器：
 1.增加了：anniu、fugu、shiwu、wy四个补丁包，可配置进行使用这四个补丁包里的图片
 2.增加了数据库报错的相关提示
 3.增加了130只原始怪物，注意：引擎3.0的客户端可用
 4.增加了一批新的顶戴花领图片

2021.1.21更新内容

新功能：
 1.排行榜中增加了行会排行榜功能
 2.在配置tejieconfig中的[Sign]时，增加配置道具数量的参数（格式：天数 道具名称 道具数量），并将数量显示在界面上
 3.checkrangemoncountex支持了变量
 4.野蛮冲撞和擒龙手优先判断转生等级在tejieconfig中增加一个开关，不配置默认为判断转生等级（详细见tejieconfig配置
 5.自定义技能中增加是否调用关联技能实际效果开关，不调用实际效果则只会播放动作特效无实际效果
 6.摆摊增加摊位显示功能
 7.增加大刀护卫、弓箭手、练功师NPC功能

修复BUG：
 1.RECALLMOB命令召唤宝宝会受技能影响删除的问题
 2.处于交易状态下保护不生效的问题
 3.设置中群体施毒术开启后战士、法师不生效的问题

优化内容：
 1.掉落提示消息的开关修改为：查看信息列表二-掉落提示来控制，现在是：内挂捡取-极品提示中控制的

2021.1.14更新内容

新功能：
 1.暴击伤害系数配置到了tejieconfig中，可自由配置暴击伤害的倍率（详细见tejieconfig)
 2.Img命令增加了一个参数，控制图片是否灰化，示例：Img:tushazhiwang:180:200:-1/@Label>，最后一个参数0为不灰化，-1为灰化
 3.ItemShow命令增加了一个参数，控制图片是否灰化，示例：ItemShow:218:1:180:80:1:1>，最后一个参数0为不灰化，1为灰化
 4.CHECK和SET命令支持了变量
5.ItemShow:D:F:X:Y:Z> 命令 参数Z是否显示物品框底图做个扩展，0不显示，1显示基础的，2显示pinjie_1,3显示 pinjie_2 ,4显示pinjie_3,5显示pinjie_4；大于5显示基础
6.游戏中增加了玩家自己解除绑定手机号功能
7.GM后台增加功能可通过后台开放沙巴克的开启
8.实现了命令：setbodycolor
9.实现了新命令：新的命令RANGEHARM、RANGEHARMEX

修复BUG：
 1.脚本命令TakeBagItem参数： 聚灵珠经验 （ 配置为1时不生效）的问题
 2.脚本释放 心灵召唤 技能 QF里技能触发不触发的问题
 3.GM编辑器中-功能设置-宝宝升级 中的 宝宝判断控制没有生效的问题
 4.@run 触发现在使用技能也触发了，且移动时触发的特别快的问题
 5.MOV命令几种格式用法做了兼容
 6.套装属性配置到称号（Stdmode： 70）上没有效果的问题
 7.修复学习新技能八键位显示错误问题
 8.道具类型(Stdmode) 为70(称号) 的道具 itemshow不显示魔御防御的问题

优化内容：
 1.更换了一批UI界面的美术资源
 2.优化了防外挂机制，攻击加速的防御优化
 3.地图资源没找到时，地图右上角显示的超级无限地图修改为显示正确的地图名称，不再显示超级无限地图
 4.通过changehumability 增加的属性不需要受角色百分比属性加成影响，比如加了50000血就是加50000血（特别注意，会导致某些版本战斗力下降）
 5.野蛮冲撞，撞人是否可撞动优先判断转生等级，擒龙手抓人是否可抓动优先判断转生等级

资源编辑器：
 1.增加了5只怪物资源

2021.1.7更新内容

新功能：
 1.角色头顶血量显示，当血量超过亿后，显示格式为：9999E9999W3002
 2.基础OK框底图更换，更换了新的美术资源
 3.增加了设置技能界面，在技能界面打开
 4.使用BINDINGSTATE命令打出的绑定道具允许丢弃，丢弃消失
 5.GETCALLMOB 使宠物叛变，叛变后怪物走正常的掉落
 6.实现了命令：SetItemBind 和 CheckItemBind
 7.OpenItemBoxEX 命令支持了OK框的所有命令
 8.诱惑之光、抗拒火环、气功波推开的中立怪（如：鸡、鹿），中立怪将不会主动攻击玩家
 9.增加一个新的命令：ItemShownum:341:0:0:0:1:数量> 带背包数量检测的itemshow
 10.增加技能键位设置功能，增加主界面八键位模式
 11.增加了一个新的命令：ImgButton:图片名称:X横坐标:Y纵坐标:按钮文字/@Label:按钮文字X:按钮文字Y>
 12. ChangeModeEx 命令中的时间参数支持了浮点值
 13. 背包扩容-增加四页背包功能，详细配置见：TJ引擎常见问题解答中的：背包扩容

修复BUG：
 1.摆摊界面和背包界面有叠加的问题
 2.自动战斗中的特效显示没有做适配的问题
 3.交易窗口-交易锁定后，道具或装备仍然可以进行拖动，导致出现交易窗口上的道具显示消失的问题
 4.角色界面上的分页---属性界面的文字和时装界面的文字写反了--按钮文字都错乱了的问题
 5.PLAYDICE 3 这个命令调取的筛子动画没有了的问题
 6.绑定的装备/道具TIPS显示错误的问题
 7.行会招募信息在聊天界面中显示是空的问题
 8.装备上有诅咒属性，但是属性界面中没有显示出来的问题
 9.道具表中叠加道具的重量计算现的相关问题
 10.GETMAPGATE 命令取出的数据不对的问题
 11.THROWITEM 命令参数中范围参数不好用的问题
 12.通用引导箭头会被OK框裁切的问题
 13.玩家交易时会出现玩家不存在的问题
 14.假人带魔血石不回血的问题
 15.国家存储导致判出国家无效的问题

优化内容G：
 1.主界面上角色按钮和背包按钮优化，当角色界面和背包界面打开的情况下再次点击是关闭对应界面
 2.当丢弃丢弃摧毁的道具时给了一个通用的二级确认弹窗
 3.优化了通用OK框美术资源
 4.优化行会名称同版本不同服不能相同的问题

资源编辑器：
 1.地图列表、NPC列表、怪物列表、物品列表增加按钮：一键筛选出没有配置的列表
 2.资源编辑器涉及到地图编辑的时候显示出不可行走区域
 3.新增80张地图，现在除大土城和大比奇这两张地图，电脑版所有原版地图都有了
 4.新增一套关羽时装

2020.12.24更新内容

新功能：
 1.擒龙手技能成功抓取目标后需要增加1秒的麻痹
 2.顶戴花铃的显示位置规则进行下修改，以前是会自动向上显示，修改为每个位置只显示对应位置的顶戴花铃，如果一个位置有多个则显示最后一个
 3.自动战斗状态在主界面显示出了自动战斗特效
 4.tejieconfig中增加一个配置控制初始的角色移动速度，详细见tejieconfig配置
 5.地图上的传送门，需要显示在地图界面NPC列表中
 6.<$KILLMONEXPRATE> 变量实现
 7.双龙斩，飓风破，嗜血术技能在tejieconfig中增加CD时间配置（详细见tejieconfig配置）
 8.脚本里给道具如果背包满了现在是直接丢到了地上，修改为通过邮件发给角色
 9.隐身技能释放后角色释放技能不取消隐身效果

修复BUG：
 1.怪物名字有特殊符号显示不出顶戴花翎的问题
 2.SkillWaitTimes51 字段是控制群体施毒术的CD，现在对施毒术也起作用的问题
 3.怪物顶戴花翎会出现一个黑框的问题
 4.顶戴花铃，每次点击一下角色顶戴花铃的位置就会往下移的问题
 5.设置-保护里放入药品后显示的数量不对的问题
 6.GETRANDOMLINETEXT 命令 路径中有变量不支持的问题
 7.绑定装备TIPS显示错误问题
 8.野蛮冲撞技能在GM编辑器中开启了使目标麻痹，这个数据没有存上的问题
 9.OK框拼接其他脚本导致@块无法执行的问题
 10. OpenItemBoxEx打开的界面坏掉的问题
 11. 精神力战法和神圣战甲术无效果的问题
 12. 诱惑之光技能GM后台配置诱惑数量无效的问题
 13. ChangeModeEx 增加麻痹 使用魔法攻击无效的问题
 14. 切换版本号，主界面上的按钮会带到下一个版本的问题
 15. 道士技能召唤神兽召唤出的宝宝不显示宝宝名字
 16. 修复几张地图怪物会刷到阻挡区里的问题
 17. SendCenterMsg命令相关倒计时问题
 18. 怪物表中配置的MP值对宝宝不生效的问题
 19. 使用抗拒火环技能推开人物，人物释放技能出现错误提示

优化内容G：
 1.自定义怪物施放技能配置了远程技能则按照远程技能的攻击距离进行计算
 2.主界面左上角战力显示图片进行了放大
 3.登陆假人时优先登陆已创建的假人，不再继续创建新的假人了
 4.优化了寻路算，解决部分地图寻路卡住的问题
 5.ELSEACT写到ACT前面解析错误问题

资源编辑器：
 1.新增了一套圣诞时装
 2.新增了一批动态称号
 3.新增了一批电脑版原版地图

2020.12.17更新内容

新功能：
 1.CHECKSKILL命令支持了变量
 2.设置-挂机-战斗-道士辅助中增加 自动群体施毒术（默认是关闭的）
 3.tejieconfig中增加一个配置：是否在血条上方显示出血量值（详细见tejieconfig配置）
 4.tejieconfig中增加一个配置控制目标头像显示血量的具体值还是百分比值（详细见tejieconfig配置）
 5.增加怪物自定义技能功能，在选项-怪物-自定义怪物中设置
 6.SetIcon命令最后增加了一个参数来调整偏移，SetIcon 位置(0-9) 图片名称 是否只有自己看见（0=所有人都可以看见 1=仅仅自己可以看见） 微调上下偏移（正值往上，负值向下）
 7.实现了命令：CHECKSLAVENAME

修复BUG：
 1.<$STR(G<$STR(N$首杀奖励_全局变量_名额定位)>)>这种格式的解析问题
 2.OK框里的ICON特效偏移问题
 3.CHANGEMODEEX命令设定了吸血几率不好用的问题
 4.tejieconfig中[mallCurrency]节点配置不生效的问题
 5.沙皇宫使用野蛮冲撞有时候会冲到阻挡区里的问题
 6.CHECKNAMELIST 路径中有变量的话 取不出值的问题
 7.解决安卓手机微信充值闪退问题

资源编辑器：
 1.资源编辑中增加了：可调用动态图片，增加了一批动态顶戴花铃资源
 2.增加了10把新的武器
 3.增加时装：孙悟空（衣服和背饰是分开的）
 4.又增加了一批电脑版地图资源

2020.12.10更新内容

新功能：
 1.实现了命令：GETCALLMOB
 2.更新了游戏主界面-改成了血球模式的主界面
 3.tejieconfig 中增加一个配置控制是否显示自动挂机按钮(详细配置见tejieconfig配置)
 4.tejieconfig中增加两个配置来控制 物理伤害减少 和 魔法伤害减少 属性的最大值
 5.宝宝叛变立即死亡
 6.实现了命令：GOTOLABEL

优化内容：
 1.优化传送地图取坐标的精度
 2.首次加载完NPC后，再次传送不用重新加载了
 3.增加了自动拾取的范围，以适应远程职业
 4.当复活效果触发时和复活效果CD结束时给个通用的消息提示
 5.设置-战斗中增加了自动召唤圣兽和自动召唤月灵
 6.优化了刷怪脚本，兼容有一行错误导致不刷怪的情况
 7.与npc对话弹出的OK框，当离开NPC一定距离后自动关闭

修复BUG：
 1.机器人脚本中写变量+重启会自动+1的问题
 2.报名参加沙巴克提示活动未开放的问题
 3.修复装备名字中有特殊符号回收不了的问题
 4.怪物中毒0血不死亡的问题
 5.修复开天斩技能伤害系数无效的问题
 6.修复沙巴克称号有时候显示异常的问题
 7.毒素武器会将绿毒覆盖的问题，现在修改为了叠加
 8.修正了角色死亡后文字称号显示异常的问题
 9.changeHumAbility 1 - 500 不生效的问题
 10.使用次数限制的物品，所有需要触发到QF里的，双击扣次数会扣两次的问题
 11.冰雪归来版本 生肖套装的效果10件触发、11件触发、12件触发，现在只有12件触发了的问题
 12.快捷装备装备的时候，会出现道具不存在的问题
 13.野蛮冲撞会冲到阻挡区外的问题
 14.有固定消息的装备tips显示错误的问题

资源编辑器：
 1.资源编辑增加了取消装备翅膀的操作
 2.增加了200张地图资源，资源名与电脑版一致
 3.增加了5把新的武器

2020.12.3更新内容

新功能：
 1.道具TIPS中显示出了道具的图标
 2.增加了一个命令控制角色不管丢弃什么东西都消失，命令格式：DISCARDLOSTSTATE 参数1；命令说明：参数1（0为不开启，1为开启）处于开启这个状态下的角色不管丢弃什么道具都会消失（默认为不开启状态）
 3.摆摊可出售的货币扩展至了4种，在tejieconfig中配置即可
 4.增加一个命令：禁止聊天和解除禁止聊天；FORBIDDENWORDS 参数1和RELIEVEFORBIDDENWORDS（详细说明见-TJ引擎专有命令）
 5.增加一个命令：可控制角色打出的道具都为绑定道具；BINDINGSTATE 参数1（详细说明见-TJ引擎专有命令）
 6.tejieconfig中增加一项配置来控制这个版本是否开启交易（详细说明见-tejieconfig配置）
 7.实现了命令：ChangeSlavePowerRate
 8.支持了国家相关的命令

 9.实现了命令：ChangeSlavePowerRate
 10.回收命令支持了变量-导致GM023回收不了装备的问题
 11.设置-保护中增加了新功能，当有复活效果时可以不执行保护
 12.实现了<$SUCKDAMAGE>变量与<$SUCKDAMAGEPOINT>变量

优化内容：
 1.召唤出的宝宝 如果怪物表中名字最后有数字则客户端显示时不要把数字显示出来
 2.邮件增加了删除功能

 3.优化了宝宝的移动，减少宝宝被卡住的情况
 4.资源编辑器编辑安全区支持了浮点值
 5.优化了NPC的名字位置
 6.优化了角色名字与称号之间会出现空行的问题
 7.GM编辑器中道具备注可直接在编辑器中进行编辑了
 7.优化了假人走路滑步的问题

修复BUG：
 1.changeslaveabil 命令没有支持变量，现在支持了
 2.renewlevel 命令没有支持变量，现在支持了
 3.changeslaveabil 命令没有支持变量，现在支持了
 4.changeslaveattackhumpowerrate 命令没有支持变量，现在支持了
 5.佩戴隐身装备怪物不反击的问题
 6.去除了系统每天自动开放沙巴克，现在沙巴克的开启都需要命令开启或者报名开启

 7.修复部分版本读取ICON图片资源报错的问题
 8.道具表中配置装备特殊效果161不生效的问题修正了

 9.QF脚本--[@PickUpitemEx]中 CHECKNEWITEMVALUE 命令和 CHECKITEMADDVALUE 命令 不生效的问题
 10.群体施毒技能给怪上毒后，隔位刺杀打怪，怪物不还手，只有近身才还手的问题
 11.#ACT、#ELSESAY这样写逻辑不执行的问题

2020.11.26更新内容

新功能：
 1.TakeBagItem 命令支持了叠加物品的回收
 2.绑定的道具死亡后不允许爆出
 3.死亡邮件内容里显示出死亡的地图
 4.角色属性界面中增加了属性：增加怪物爆率
 5.增加邮件红点和行会红点
 6.增加新功能：当获得比自己身上穿戴的装备好时的装备时弹出自动穿戴小界面；在tejieconfig中增加配置：openautomaticwear=1
 7.增加新的功能顶戴花铃，具体使用方法请看顶戴花铃的使用说明

优化内容：
 1.地图界面右侧支持了换行
 2.道具使用失败的提示从弹窗提示修改为飘字提示

修复BUG：
 1.死亡邮件有时候会出现没有找到指定邮件的问题
 2.角色死亡邮件，当角色被神兽杀死时邮件里没有显示出被谁击杀，被神兽击杀应该显示出角色名称的问题
 3.道具表中配置的增加目标爆率应该只对杀人生效，KILLMONBURSTRATE增加的爆率应该只对杀怪生效
 4.tejieconfig中[setStallCurrency] 设置了摆摊可交易货币不好用的问题
 5.GETRANDOMLINETEXT 命令 取不出来第一行的值的问题
 6.CHECKSOCKETABLEITEM 命令获取的宝石IDX没有+1的问题
 7.playmodel 命令会挡住按钮的问题
 8.法师没有默认雷电术为挂机单体技能的问题
 9.CHECKNEWITEMVALUE 命令 判断元素属性 只需要判断使用命令增加的属性 模板表中的元素属性不参与计算
 10.宝石类道具装备对比箭头错误的问题
 11.假人执行不了AUTOGOTOXY 命令的问题
 12.ADDGUILDMEMBER和ADDGUILD命令 假人无效的问题
 13.角色转职后导致强化技能等级丢失的问题

资源编辑器：
 1.增加了一批新的怪物、新的地图和新的时装

安卓打包固定版本号工具：
 1.开放了固定版本号工具：可自定义游戏名称、图标、开始游戏底图、LOADING图

2020.11.19更新内容

新功能：
 1.usebonuspoint 支持了参数中使用变量
 2.实现了OPENUPGRADEDLG命令，解决点击无效问题
 3.GAMEGIRD - <$str(s$para2)> 对数字进行兼容 只要是纯数字就可以执行
 4.增加功能：套装技能伤害增加百分功能和防御百分比功能
 5.怪物表中Race列为51/52时怪物为非主动攻击怪，受到攻击才会反击；cooleye 反隐身怪的反隐身距离100为反隐身
 6.召唤出捡物精灵后角色通过复活效果复活后捡物宠物会死掉，这个应该不会死掉才对（现在不会死了）
 7.增加一个新的命令将道具放入主界面快捷栏；命令：PUTINSHORTCUT 参数1 参数2 说明：参数1：道具名称 参数2：快捷栏位置ID（1-4）(
 8.玩家死亡会自动收到一封邮件，说明死亡原因、死亡时间、掉落物品（1-4）
 9.GM运营后台增加版本推荐功能，在版本列表中进行设置
 10.支持了2DNPC、2D光柱
 11.在游戏运营后台每个服务器处增加一个标识，增加系统变量<$SERVERBURST> 可调用到这个变量，可在脚本中使用这个变量来控制对应服务器的一些定制功能（重点）

优化内容：
 1.GM编辑工具兼容一些会出现报错的格式
 2.addtextlistex ..\testkist.txt <$USERNANE> 0 写入文本指定行，会覆盖原有的行。。正常应该是原有的行往下移动
 3. 摆摊出售道具或装备，他人点击查看无Tips装备或道具显示信息内容的问题
 4. 用户交易，A与B交易窗口显示无法查看对方放置装备的Tips信息内容的问题
 5. 属性点功能增加了一键加点

修复BUG：
 1.从仓库取出叠加物品会消失的问题
 2.自动拾取有时候会卡住不拾取的问题
 3.MOV N$LSJG <$str(s$para2)> 无法赋值的问题
 4.角色删除了但是在排行榜中还能看到这个角色
 5.人形怪在特殊情况下不打人的问题
 6.一个OK框中有多个可放置道具框时特殊情况会出现复制道具的问题

资源编辑器：
 1.资源编辑器，编辑NPC名字一样无法编辑的问题
 2.增加了一批新的NPC资源

2020.10.29更新内容

新功能：
 1.增加生肖装备死亡掉落功能，在游戏参数、人物死亡、首饰盒中进行设置
 2.增加一个命令，删除自己的捡物宝宝 命令为：CLEARRECALLJINFLING
 3.UserCmds.txt 脚本功能实现
 4.takeonitem 和 takeoffitem 命令支持了生肖装备
5.tejieconfig中增加配置是否开启排行榜功能；OPENRANKINGLIST=1 （0为不开启，1为开启）
6.道具表中给装备增加的元素属性与脚本中增加的元素属性拆分开存储
7.仓库存取可叠加道具增加了选择数量功能
8.CHECKDRILLHOLECOUNT 命令支持了生肖装备
 9.tejieconfig中增加了一个配置，控制自动复活的CD时间（AutomaticResurrection=500）单位秒

优化内容：
 1.脚本中将角色等级降低到1级以下时按照1级计算，角色最低等级为1级
 2.自动反击：当前目标为其他可被攻击角色时，这时候再受到其他角色攻击不需要切换目标

修复BUG：
 1.GM运营后台通过绑定的手机号查询查询不到对方的充值信息且无法对角色进行操作的问题
 2.等级超过100万级血量会变成负数的问题
 3.setstringblank 增加长度还是对不齐的问题
 4.<$BOXITEM[X].PROGRESSBAR1.POSITION> 当前自定义OK框中的物品 第一个进度条的当前进度值 这个命令的默认值错误 默认值应该为0
5.changehumnewvalue 命令 减属性 减了10 实际给扣除了20
6.<$BOXITEM[X].PROGRESSBAR1.OPEN> 当前自定义OK框中的物品 第一个进度条是否开启 0没有开启 1开启 这个命令默认值错误 默认应该是0 没有开启现在是-1

2020.10.23更新内容

新功能：
 1.增加一个清除分身的命令 CLEARRecallSelf 删除自己的分身
 2.电脑版本运行的时候在桌面生成快捷方式
 3.自动挂机三职业做成了统一的技能释放列表，三职业自动挂机技能都可释放
 4.称号去除了道具表中stdom类型的限制，任何类型的都可作为称号使用
 5.SetNewItemValue 命令支持了拾取触发
 6.升级增加属性算法引擎默认算法和自定义等级算法功能（SETUP！中UseLevelAbilitys 字段控制采用哪种模式 =0 使用引擎默认 =1使用自定义）
 7.RECALLJINFLING 名称 移动速度 捡取范围 捡取时间 捡取距离 跟随距离 持续时间 模型大小（0.1为0.1倍，2为2倍，1为正常大小） （这个命令最后增加一个参数）
 8.tejieconfig中增加两个配置控制装备TIPS名字显示规则与装备TIPS上置顶消息的显示（详细见tejieconfig）
 9.增加玩家战斗力常量：<$powervalue>
 10.增加配置吃药时间间隔 单位：毫秒（tejieconfig中增加配置使用CD时间，单位毫秒，不写的话使用默认CD时间）详细见tejieconfig
 11.支持了变量后加变量的脚本格式：MOVT<$str(s$t11)> <$str(s$值)>

GM编辑器：
 1.修复部分报错问题

优化内容：
 1.角色和假人传送地图（使用随机、回城）角色朝向的方向设置为随机方向
 2.拾取道具-通过拾取按钮拾取道具不需要受是否勾选自动拾取影响直接可拾取
 3.打敌对目标现在的掉血上限是21E，现在去除了这个限制
 4.tejieconfig中的[gemtips]没有支持文字颜色，现在支持了
 5.充值配置中配置了相同金额然后就不好用了，现在支持了
 6.自定义技能触发脚本优化，自定义的技能同样触发QF里的技能触发@块
 7.从仓库中取出道具不在判断背包负重，超过负重也可取出

修复BUG：
 1.changehumnewvalue 命令的参数没有支持变量，现在支持了
 2.人形怪佩戴复活戒指复活后会受到MP值影响达到受伤害上限的问题
 3.叠加的道具使用后会出现一个获得道具提示消息的问题
 4.SHOWPROGRESSBARDLG 时间(秒) 触发字段 提示信息 有动作是否中断(0不中断,1中断) 中断触发字段 这个命令不好用了的问题
 5.CHECKCUSTOMITEMPROGRESSBARPERCENT命令应该是检测进度条百分比现在检测的是具体的值的问题
 6.CheckSuckDamage 这个命令没有支持变量的问题

2020.10.16更新内容

新功能：
 1.[@Revival]实现
 2.扩展参数：REALIVE 参数1 参数2（参数1：复活血量；参数2：复活方式（1百分比血量，0具体血量值））
 3.OK框上的按钮点击增加一个统一的0.3秒CD时间，点击太快提示：“你点击的太快了”
 4.怪物表中MP值是所受伤害上限，不受脚本中减血影响

GM开服网站：
 1.游客账号绑定手机号之后可通过手机账号对角色进行修改/封号

GM编辑器：
 1.修复TIPS后台报错问题

资源编辑器：
 1.新增六张新地图

优化内容：
 1.装备TIPS当有文字超出tips界面时点击关闭不了tips
 2.取消了自定义输入框中字符长度限制
 3.客户端设置中增加了是否显示光柱开关
 4.好友聊天卡顿-优化

修复BUG：
 1.仓库卡顿问题
 2.CHANGEHUMABILITY 11 = 500 65535 用定时器执行时间每次都不固定血量和战斗力来回跳的问题
 3.hour和MIN 命令检测无效的问题
 4.65类型的道具使用数据库代码添加了复活效果没有生效的问题
 5.摆摊掉线后重新上线摆摊的道具消失的问题
 6.RecallSelf 命令不好用的问题
 7.设置自动保护，血量掉到指定百分比以下只会吃一个药，然后每受到一次伤害吃一个（应该是吃到指定百分比以上）
 8.称号数量多的时候会导致称号显示不出来的问题
 9.怪物多次中毒怪物会回满血的问题
 10.<$HITSPD>攻速变量不生效的问题
 11.倚天劈地技能没有走CD时间
 12.GIVE命令 GIVE <$BOXITEM[1].GNAME3> 1 给不了东西的问题
 13.装备上附带攻速重新上线后不生效的问题

2020.8.27更新内容

新功能：
 1.在tejieconfig中增加了配置控制任务栏的显示
 2. 主界面中增加了一个快捷栏使用位置
 3. 战斗设置中增加了：自动逐日剑法、自动分身
 4. 开放自动拾取宝宝功能，命令为：RECALLJINFLING 名称 移动速度 捡取范围 捡取时间 捡取距离 跟随距离 持续时间
 5. tejieconfig增加配置是否显示外显时装 命令格式：FashionShow=1 显示 =0不显示 默认显示
 6. 当道具stdmode=31 支持可以改名 命令格式 ChangeItemNameEx -1 名字
 7. 套装触发 [@GroupItemOn]

GM后台：
 1.GM后台查看角色信息界面可直接修改货币
 2.后台增加，账号信息查询加一个删除角色原因（测试删除，gm删除，玩家自己删除）
3.账号信息查询界面针对每个角色增加了角色信息查询按钮
3.角色信息查询中显示出了角色的详细属性

修复BUG：
 1.OK框中的道具，如果有其他界面打开导致道具消失的问题
 2.玩家和NPC重叠 点不了NPC的问题
3.PC端好友聊天输入栏和发送按钮位置偏下
4.@goto太多卡顿的问题
5.改变人物当前模式：ChangeModeEx 20 65535 100 8 吸血不是百分比的问题
6.有ICON特效的装备放入仓库后仓库中就没有特效了
7.好友聊天里的消息没有按照正常顺序排序
8.GiveStateItem 命令给绑定道具导致其他道具绑定的问题

2020.8.21更新内容

新功能：
 1.增加自定义任务功能（在TJ引擎任务里见详细使用方法）
 2. ChangeItemNameEx改变道具名字 命令格式：ChangeItemNameEx -1 名字
 3. 电脑版本增加技能快捷键功能
 4. DZItemDescList 脚本 显示在顶部
 5. 增加自定义技能功能
GM后台：
 1.后台增加了功能清理排行榜数据
 2.后台查询增加了模糊查询角色
3.可通过绑定的手机号查询用户信息
优化：
 1.挂机时如果对方防毒自动施放的时候就把毒给去掉
新资源：
 1.增加了一批新的斗笠资源
 2.增加了两个翅膀资源

修复BUG：
 1.行会/队伍申请】行会/队伍申请列表显示的职业与实际不符
 2.人形怪配置复活戒指，不复活，（人形怪跟玩家是一样的，配置的属性需要支持）

2020.8.12更新内容（注意：本次更新内容8.13日才会更新至正式服）

新功能：
 1.GM后台：增加等级限制，多少级以下是不允许接收邮件

修复BUG：
 1.站在安全区外面放技能打安全区的玩家和离线挂机的玩家掉血
 2.OPENMERCHANTBIGDLG一直显示关闭按钮，不能通过参数5控制是否显示的问题
 3.称号不显示重量
 4.修复神水修复装备显示问题
 5.物品规则，上线消失和禁止个人商店出售不好用

2020.8.10-8.11更新内容（注意：本次更新内容8.13日才会更新至正式服）

新功能：
 1.monster表中race字段为112时 只攻击红名玩家
 2.增加一个配置：是否开启人形宝宝的攻速和移动速度跟主人一样(详细见tejieconfig)
 3.CheckItemAddValueEx 检测装备的附加属性总和(武器的诅咒不在计算范围之内)
 4.checkjob warrior 检测角色职业，支持变量
 5.增加配置：控制是否显示出怪物等级，获取的怪物表的Lvl字段(详细见tejieconfig)
 6.怪物表中Race列为51/52时怪物为非主动攻击怪，受到攻击才会反击
 7.RECALLMOB脚本召唤宝宝 增加宝宝大小，属性倍率两个参数
 8.怪物表中race字段功能实现 为82 毒液攻击（怪打人 人中毒） 为107 全屏攻击+麻痹+中毒
9.自定义技能功能（在GM编辑器工具中：查看信息列表二-自定义技能中配置）

修复BUG：
 1.摆摊】背包里的空白格子也可以拖动到摊位上
 2.玩家改名字之后，老的角色名还在排行榜上，需要清除掉
 3.将好友添加到黑名单，再移出黑名单，界面报错
 4.怪物血量配置超过21亿 打的时候直接从21亿血开始掉
 5.重复查看玩家信息 ，出现重影
 6.线上出现版本来回切换快捷按钮显示上一个版本的快捷按钮了
 7.同一个套装显示的tips不一样
 8.道具表need为 70 沙城城主才可以戴上 功能好用，tips没显示出来

2020.8.6正式服更新：

更新说明：7.27-8.5号在测试服更新的内容到正式服务
 1.正式服用户会强制将客户端版本升级至1.3.0
 2.电脑版在正式服正式上线

2020.8.3-8.5更新内容（注意：本次更新内容8.6日才会更新至正式服（引擎底层做了比较大的升级））

新功能：
 1.增加CHECKDAYRECHARGE命令，格式 CHECKDAYRECHARGE 检测符（><=） 金额(充值的RMB金额) （检测当天充值金额）
 2.增加CHECKLOGINCOUNT命令，格式 CHECKLOGINCOUNT 检测符（><=） 次数 （检测当天登陆次数）
 3.设置-战斗中增加功能被其他玩家攻击，自动反击攻击玩家，默认为开启
 4.gm工具增加配置禁止清理怪物列表，保存的脚本为 NoClearMonList.txt 作用：用于脚本命令clearmapmon 加入此列表的怪物，在使用此命令不会被清除掉
 5.增加法师技能诱惑之光
 6.tejieconfig中增加控制世界频道发言时间间隔；（详细配件见tejieconfig配置）

优化：
 1.背包货币显示出了货币小图标

修复BUG：
 1.装备穿戴需要转生等级，转生等级不够也能穿上的问题
 2.召唤的宝宝打自己的问题
 3.召等级太高就变成负数了的问题
 4.<$USERID> 人物登录帐号 获取的账号不对的问题

2020.7.31更新内容（注意：本次更新内容8.6日才会更新至正式服（引擎底层做了比较大的升级））

新功能：
 1.电脑版增加右键移动功能
 2.电脑版接通了电脑版的充值
3.电脑版默认隐藏摇杆开启，默认视野范围为最大

优化：
1.优化彻地钉、龙影剑法、爆裂火焰特效效果

修复BUG：
1.自动生成的传送阵特效方向错误问题

2020.7.27-7.30更新内容（注意：本次更新内容8.6日才会更新至正式服（引擎底层做了比较大的升级））注意：本次更新引擎升级至1.3.0，服务器做了迁移GM测试服清档，需要使用1.3.0的客户端包才能登陆

新功能：
 1.增加检测战斗力命令，CHECKPOWER 检测符（><=） 数值
 2.增加命令：ACCOUNTBINDINGMOBILEPHONE 说明：登录的账号是否已经绑定手机 已经绑定返回真
3.增加命令：OPENTHEMOBILEPHONEBINDINGINTERFACE 说明：打开手机绑定界面
4.tejieconfig中增加配置，可控制初始给的攻速是否显示在属性界面中
 5.增加技能：火球术、大火球、纵横剑术、雷霆剑法、彻地钉、气功波、无极真气、双龙斩、隐身术、群体隐身术、群体治疗术、冰镰术、爆裂火焰
 6.开放电脑版客户端
 7.优化NPC模型，增加了一批新的NPC模型
 8.增加了6只基础怪物
 9.增加每天累计在线时间命令：<$DAYLOGINLONG> 每天24：00清0，单位分
 10.增加检查人物每天累计在线时长命令：CHECKDAYLOGINLONG (> < =) 支持变量操作的时间（单位分钟）
 11.【战士自动攻击配置】在战斗设置中增加设置，可开启和关闭自动攻击（默认是开启的）
12.初始攻速不显示在面板上在tejieconfig 中增加了配置是否显示
14.取消道具拾取，跟装备拾取合并到一起，都在FilterItemList.txt配置
15.MONGENEX 再增加四个参数，视野范围、属性倍率、模型大小，怪物爆率（当前怪物的所有道具的爆率）
16.刷怪脚本，再增加一个参数，怪物爆率（控制该怪物掉所有装备的爆率）
17.增加一个获取当前OK框中物品的某个属性存放在数据库中的值
18.禁止取下物品 添加的物品存放在DisableTakeOffList脚本中

优化：
1.资源编辑器中显示出了模型的编号
2.资源编辑器增加了拖拽滑动条
3.优化了NPC资源，将质量不好的NPC替换掉了（可在资源编辑器中查看）
4.优化战斗打击感，提升打击感效果
5.优化主角界面主角的动作
6.优化部分技能特效的美术表现效果
7.看其他角色施放护体神盾还会播放动作（护体神盾是被动技能不需要播放动作）
8.挂机拾取详细信息的装备显示颜色获取道具表中的颜色
9.快捷按钮优化：底图变成自适应，描述问题多长底图多大，，，描述文字加一个描边
10.gm工具配置套装 点击修改，左边会刷新，改成点击修改不需要刷新左边

修复BUG：
1.消息提示：解析怪物名字后面带数字的，数字不要解析出来 例如：感染的僵尸1 感染的僵尸2 感染的僵尸3 123不要显示出来
2.查看其它玩家可以给其他玩家穿装备的问题
3.安全区范围内，改成人打人不掉血，人打怪掉血，怪打人掉血
4.查看其他玩家的生肖，显示的是自己装备的
5.Tejieconfig 里带の符号的装备没解析出来

2020.7.24针对正式服问题进行修复

修复BUG：
1.人形怪攻击问题
2.从充值界面点击到绑定手机号界面无法获取验证码问题
3.Z002地图阻挡区错误问题
4.装备对比戒指手镯有时候不出对比的问题、生肖装备对比错误的问题
5.#define写法支持没有#include就生效的问题
6.装备附加技能挂机技能列表错误问题
7.增加新的打点信息，将从打开游戏到进入游戏的比例显示到GM后台
8.称号穿戴问题

2020.7.22更新内容（注意：7.20号-7.22号更新的内容7.23号会同步到正式服。客户端版本升级至1.2.0）

新功能：
 1.增加新技能：狮子吼、寒冰掌
 2.GM运营后台增加查看账号密码功能和解除手机号绑定功能（23号同步正式服后可用）
 3.增大了NPC名字颜色的字号
 4.GM编辑工具增加禁止取消装备配置
 5.资源编辑器：增加怪物、NPC批量选择，批量修改坐标功能

修复BUG：
1.优化游戏整体性能，解决卡顿、掉帧、发热、耗电量问题
2.优化OK框中文字的清晰度问题（只有新下载的客户端才有效果，热更的不生效）
3.【离线挂机】在安全区里的离线挂机角色还会被杀死的问题
4.【人形宠物、假人】人形宠和假人的移动速度、攻击速度、AI问题
5.I0S留海屏 在登陆界面没有适配的问题
6.有自定义货币配置的的版本回收消息错误的问题
7.次服务器重启捐献排行里的数据会被清空的问题

2020.7.21更新内容

新功能：
 1.自动拾取获取装备修改（拾取脚本只要配置了，道具表里有的都显示）
 2.【刷怪脚本】刷怪脚本增加几个参数控制怪物的视野范围、属性倍率、模型大小
3.增加一个获取星星的命令（getitemStarNum 参数1 参数2 ，参数1 -1代表在OK框中，0-12穿在身上的装备，参数2 获取的星星数量赋值给参数2）
 4.快捷按钮描述文字加一个小阴影,加粗

修复BUG：
1.自动挂机优化，自动挂机时单机空白地面就直接跑过去
2.随机传送优化

2020.7.20更新内容

新功能：
 1.buff 文字备注，支持换行
 2.支持超大属性数值，装备备注上支持18位数值
3.没有绑定手机号的玩家，充值的时候增加一个提示请绑定手机号
 4.快捷按钮文字改成可配置文字 命令格式：addbutton shangcheng_bth 1 1 颜色值|文字
 5.优化创建角色流程，创建新角色会自动进入游戏
 6.支持了#Include与#INCLUDE写法

修复BUG：
1.GETITEMADDVALUE命令获取不到值的问题
2.装备捡起来有星级，在NPC 装备加星 精炼之后星星就没了的问题
3.元素属性重洗之后会把原有的属性清理掉的问题
4.修复护体神盾特效同步问题

2020.7.17更新内容（注意：17日会推送正式服）

新功能：
 1.字符串切割支持正则表达式符号
 2.开放自动拾取详细设置功能
3.游戏整体性能优化
 4.战斗操作手感优化
 5.增加新技能：护体神盾

2020.7.15更新内容（注意：16日上午会把最近一周的更新推到正式服，本周增加的新命令新功能即可在正式服使用）

新功能：
 1.增加技能：气功波
 2.增加设置毒素武器功能，\Envir\UserData\PoisonWeapon.txt
3.增加新功能：宝石升级，使用命令OpenUpgradeDialog打开界面
 4.SendCenterMsg命令发送的消息显示到了屏幕上
 5.tejieconfig中增加配置可控制切到后台后多久掉线
 6.资源编辑器增加编辑器多边形安全区功能
 7.优化战斗，增加被击特效；优化远程技能的攻击距离
 8.增加了一些道具图标特效，可在资源编辑器中查看使用
 9.镶嵌宝石功能增加了可配置自定义文字描述功能，可在tejieconfig中进行配置

修复BUG：
1.装备对比箭头错乱问题
2.分身术不打怪了，人形宠物也不打怪的问题
3.当stdmode为70时，value1-value9代表属性：tips需要显示出来，属性需要加到身上

2020.7.14更新内容

新功能：
 1.增加技能：擒龙手
 2.GM编辑工具：增加装备耐久度为0是否消失的配置
3.GM编辑工具：道士技能中增加召唤骷髅
 4.tejieconfig中增加了可配置多少级可以说话
 5.增加一键注册快速游戏功能
 6.增加账号绑定手机号功能
 7.【安全区形状】可自定义安全区形状支持圆形和多边形（可在StartPoint中自行配置也可在资源编辑器中可视化编辑）
 ; 编辑圆形，第一个参数为圆心X，第二个参数为圆心Y，第三个参数为类型，第四个参数为半径
 ; 编辑多边形，对一个参数为中心点X，第二个参数为中心点Y 第三个参数为类型，以后的参数为顶点坐标：坐标X 坐标Y 坐标X 坐标Y 坐标X 坐标Y 坐标X 坐标Y 坐标X 坐标y 坐标X 坐标Y
 8.挂机设置中增加详细设置，玩家可针对具体的道具进行设置拾取
 9.tejieconfig中增加了可配置哪些地图不允许自动复活
 10.充值界面中的说明文字支持<文字|文字说明格式 designtimesp=17586>
 11.GM运营后台，角色信息查询增加账号和状态

修复BUG：
1.HCALL <$CURRRTARGEINAME> @法克飞飞 这个命令错误问题
2.勋章，武器类装备配置特殊效果不生效的问题
3.:96:1:-3/@1阶回收>；IMG命令支持变量
4.点击有OK框的NPC，再直接点击其他NPC，再点击装备，还显示放入按钮 的问题
5.MOV S$装备所在位置0<$STR(N$装备所在位置)> 解析错误的问题
6.装备属性超过999亿无法显示的问题，现在支持超大无限数值

2020.7.13更新内容

新功能：
 1.增加技能：冰霜群雨
 2.GetUseritemName 获取装备名字实现
3.怪物速度优化，写1太慢，写2太快（怪物表speed列支持浮点值）
 4.增加<$PASSWORD>命令 注册账号时用户输入的密码
 5.<$TEAM0>..<$TEAMX>用于显示组队成员实现,<$TEAM0>代表队长,成员从<$TEAM1>开始
 6.DeleteItemDuraZero实现
 7.交易和摆摊增加7种货币，可在tejieconfig配置

修复BUG：
1.stdmode是23的戒指加不上攻击问题
2.文件名大小写问题导致服务器启动失败问题
3.攻速超过一定值变成负值了，之后自动挂机不会打怪了的问题

2020.7.11更新内容

新功能：
 1.增加新的命令可在OK框中显示对应的3D模型 格式： <PlayModel:资源名:X横向坐标:Y纵向坐标：缩放比例>
 2.背包界面和主角界面和通用OK框界面可拖动位置
 3.【默认装备ICON特效配置】EffectItemList 中可配置道具的ICON特效 该装备会默认有对应的特效(这个配置的第二个字段为特效名，特效名可在资源编辑器中查看)

修复BUG：
1.dnf版本备注错误 dnf盟重传送员
2.BOXITEM[X].HMC这个命令值取出来的值不对
3.{[%name]|146:0:1}{在地图|255:26:1}{%Map|210:0:1}{中掉落物品} []这个解析问题有时候多一个有时候少一个
4.ChangeModeEx 11 10 3 命令不好用
5.dnf版本,战斗力NPC 战斗力显示的不对的问题

2020.7.10更新内容

新功能：
 1.增加新技能：十步一杀
 2.【自定义游戏视角】在设置-基本-显示里增加 地图缩放配置玩家可自定义调整视野高度
 3.增加两个变量 $RECHARGE[1].NUMBER：检测充值金额 $RECHARGE[1].FREQUENCY：检测充值次数
 4.资源编辑器增加：配置怪物增加可以删除怪物，修改怪物数量
 5.资源编辑器修改：获取地图NPC功能
 6.资源编辑器修改：增加查看可调用UI资源和可调用特效资源
 7.面板的攻击速度：装备面板上显示的都加，脚本增加的的不显示（在tejieconfig中增加配置是否显示命令加的攻速）

修复BUG：
1.KILLER和 MONKILLER命令（神秘人的问题）
2.脚本扣血，扣到0也不死的问题
3.dnf版本 ok框取装备替换，取下，拖拽会出现图标消失，错乱情况
4.当stdmode=26 CHANGEITEMADDVALUE改变属性附加 2位置代表的是DC2
5.脚本检测/设置人物或怪物血量 AddhpPer +/-/= AddmpPer +/-/= CheckHpPer >//


wy_商业网关说明

----------------------------------------------------------自定义按钮--------------------------------------------------------

格式：命令 参数1 参数2 参数3
说明：参数1：图片名称（图片名称可在资源编辑器中的可调用UI资源查看） 参数2为：按钮点击后的脚本触发序号，触发QF里面的[@ButtonClickX]X即为触发序号 参数3为按钮位置（1-10）

命令：ADDBUTTON

例子
#IF
#ACT
ADDBUTTON wujiang_bth 1 1 颜色值|按钮上文字

参数说明：

参数1为图片名称（图片名称可在资源编辑器中的可调用UI资源查看）
参数2为按钮点击后的脚本触发序号，触发QF里面的[@ButtonClickX]X即为触发序号
参数3为按钮位置（1-15）
参数4为按钮上显示的文字，可以不写（1-15）

其他说明：

按钮序号只能为1-10，因为最多就添加10个自定义按钮

格式：命令 参数1 参数2

命令：DELBUTTON

例子
#IF
#ACT
DELBUTTON 1

说明：参数1为按钮序号(1-10) 参数2(0或空的时删除自己的，1时删除全服用户的)

---------------------------------------------------------------BUFF---------------------------------------------------------------------------------

说明：在客户端增加BUFF图标显示
格式; setclientbuff 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8（可以没有）
参数1： WILL文件序列号（这个参数咱们不用）
参数2：BUFF序号
参数3：图片名称（图片名称可在资源编辑器中的可调用UI资源中查看，也可直接调用装备的内显资源）
参数4：倒计时间（-1时不限时是按钮模式，大于0时是倒计时时间）--按钮模式点击触发：[@closeclientbuffx]
参数5：文字备注（点开显示的文字内容）
参数6：微调X坐标（不需要）
参数7：微调Y坐标（不需要）
参数8：附加特性（不需要）

closeclientbuff
说明：删除BUFF图标
格式：closeclientbuff 序号

------------------------------------------------------------首饰盒(奇门)(十二生肖)----------------------------------------------------------------------
SetSndaItemBox 参数1(任意字符,不能为空) 参数2(任意字符,不能为空) 参数3(开启或关闭用户首饰盒。开启=8888,关闭=1234) 参数4(任意字符,不能为空) 参数5(任意字符,不能为空) 参数6(任意字符,不能为空) 参数7(任意字符,不能为空) 参数8(任意字符,不能为空) 参数9(要和参数3完全保持一致 开启或关闭用户首饰盒。开启=6666,关闭=5678) 参数10(任意字符,不能为空)

开启首饰盒：
QFunction-0.txt 加入如下脚本
[@OpenSndaItemBox]
#act
;如果那个首饰盒按钮是灰色的，点击那个按钮就会触发这个，然后使用命令SetSndaItemBox开启后，按钮就会变彩色，然后点击按钮就可以打开首饰盒子
SetSndaItemBox 1 2 8888 4 5 6 7 8 6666 9 10
SENDMSG 6 首饰盒开启成功

关闭首饰盒：
[@main]
#act
SetSndaItemBox 1 2 1234 4 5 6 7 8 5678 9 10
SENDMSG 6 已关闭

首饰盒12个装备,StdMode值 100~111

首饰盒装备的修理，在NPC文件头增加以下代码
(@buy @sell @repair @s_repair)
%100
+100
+101
+102
+103
+104
+105
+106
+107
+108
+109
+110
+111

首饰盒支持CheckItemW TakeW AutoTakeOnItem AutoTakeOffItem这4个脚本命令

AutoTakeOnItem 装备名称 装备位置(30~41 是首饰盒的位置代码)
AutoTakeOffItem 装备位置(30~41 是首饰盒的位置代码)

[@TakeOnX]
首饰盒穿装备触发 X值=30~41

[@TakeOffX]
首饰盒脱装备触发 X值=30~41

首饰盒装备，人物死亡掉落设置在(M2-选项-参数设置-人物死亡-首饰盒)
首饰盒装备是否掉持久设置(M2-选项-功能设置-其他控制(1))

--------------------------------------------------------------镶嵌宝石--------------------------------------------------------------------

在数据库增加宝石的DB,宝石DB如下：

GOM引擎原版是这样的：
宝石的Shape值(0~4)显示出5个不同颜色的镶嵌宝石。在必备补丁NewopUI.PAK的301~305
宝石的Shape值如果设置为255，镶嵌后会显示宝石DB的Looks的。也就是DnItems里面的素材
TJ引擎对这一部分进行了修改：
1.tejieconfig中可进行配置在装备备注中是显示宝石的详细属性还是显示宝石的名称还是显示自定义的文字说明
2.示例如下：

;镶嵌宝石后是显示宝石名称还是显示具体的属性0显示具体属性，1显示宝石名称,2显示宝石自定义的描述（描述配置在tejieconfig：[gemTips]）
showgem=0
;宝石在备注中的文字描述
;格式：道具名称 描述文字
[gemTips]
攻击宝石 <超级牛逼的BUFF/FCOLOR=243><拥有则天下无敌/FCOLOR=255>

宝石DB库的字段Reserved=0时 Ac2 Mac2 DC2 MC2 SC2 HP MP字段的值是增加的对应的7个基本属性的值
宝石DB库的字段Reserved>0时 Ac2 Mac2 DC2 MC2 SC2 HP MP字段的值除以100，为各属性的倍数，例如Ac2设置为110，人物的防御为200。 人物实际防御=110/100*200=220

Value1~Value11 是增加的元素属性。

其他字段没有特别要求。

打孔脚本命令
DRILLHOLE 参数1(任意字符,不能为空) 参数2(任意字符,不能为空) 参数3(装备位置(0~16时身上装备,-1时为OK框里的物品)) 参数4(任意字符,不能为空) 参数5(任意字符,不能为空) 参数6(孔位置(0~4)) 参数7(任意字符,不能为空) 参数8(状态(1=打开 0关闭)) 参数9(任意字符,不能为空) 参数10(任意字符,不能为空)

镶嵌宝石脚本命令,先要打孔后才能镶嵌成功
SOCKETABLEITEM 参数1(任意字符,不能为空) 参数2(任意字符,不能为空) 参数3(任意字符,不能为空) 参数4(任意字符,不能为空) 参数5(装备位置(0~16时身上装备,-1时为OK框里的物品)) 参数6(宝石位置(0~4)) 参数7(任意字符,不能为空) 参数8(任意字符,不能为空) 参数9(宝石DB库的IDX序号加1(如果设置0就是删除宝石)) 参数10(任意字符,不能为空)

检测玩家身上指定装备是否已经打孔
CHECKDRILLHOLE 装备位置(0~16时身上装备,-1时为OK框里的物品) 孔位置(0~4)

检测玩家身上指定装备是否已经镶嵌宝石
CHECKSOCKETABLEITEM 装备位置(0~16时身上装备,-1时为OK框里的物品) 宝石位置(0~4) 变量(如果已经镶嵌宝石，该宝石的IDX值会保存到该变量) 变量2(如果已经镶嵌宝石，该宝石的名称会保存到该变量)

检测玩家身上指定装备已经打孔的数量
CHECKDRILLHOLECOUNT 装备位置(0~16时身上装备,-1时为OK框里的物品) 检测符(<,>,=) 数量

检测玩家身上指定装备已经镶嵌宝石的数量
CHECKSOCKETABLEITEMCOUNT 装备位置(0~16时身上装备,-1时为OK框里的物品) 检测符(<,>,=) 数量

其他注意：
StdMode=19 20 21 23 24 5 6
这几种是没有防御和魔防的，最好不要镶嵌防御和魔防。 如果你镶嵌魔防和防御，那出现的属性是幸运、敏捷、准确等等这些属性

[@例子]
#IF
CHECKSOCKETABLEITEM 0 0 N1 S1
#act
SENDMSG 6 衣服第一个位置镶嵌了宝石。宝石名称：<$STR(S1)>,宝石IDX字段：<$STR(N1)>
#elseact
SENDMSG 6 衣服第一个位置没有镶嵌宝石

[@镶嵌衣服的第一个宝石，宝石IDX为831]
#ACT
;先要打孔
DRILLHOLE * * 0 * * 0 * 1 * *
;然后镶嵌
SOCKETABLEITEM * * * * 0 0 * * 832 *

-----------------------------------------------------------极品属性转移（暂不支持）------------------------------------------------------
============================================================================================
<$MOVE.SOURCE.NAME> ;正在移动的原始物品名称
<$MOVE.DEST.NAME>;正在移动的目标物品名称

脚本命令：打开极品属性转移窗口
;OpenMoveItemValueDlg 参数1(20130801) 参数2(20130802) 参数3(所需货币类型(0=元宝,1=金币,2=泡点)) 参数4(20130804) 参数5(所需货币值) 参数6(20130806) 参数7(20130807) 参数8(20130808) 参数9(20130809) 参数10(20130810)

脚本命令：关闭极品属性转移窗口
;CloseMoveItemValueDlg

[@main]
#IF
#ACT
OpenMoveItemValueDlg 20130801 20130802 0 20130804 100 20130806 20130807 20130808 20130809 20130810
;打开属性转移窗口，转移装备极品属性需要(请咨询客服了解价格)宝

;点击转移按钮会触发QF脚本中以下字段
[@StartMoveItemValue]
#IF
CHECKTEXTLIST ..QuestDiary物品名称.txt <$MOVE.SOURCE.NAME>
#ACT
MoveItemValueFail
;MoveItemValueFail 禁止转移命令
SENDMSG 6 该物品禁止转移
break

#IF
CHECKTEXTLIST ..QuestDiary物品名称.txt <$MOVE.DEST.NAME>
#ACT
MoveItemValueFail
;MoveItemValueFail 禁止转移命令
SENDMSG 6 该物品禁止转移
break

#IF
#ACT
MoveItemValueOK
;MoveItemValueOK 开始转移属性命令，会自动扣除所需的费用，如果费用不够转移失败

------------------------------------------------------------可视化仓库--------------------------------------------------------------------

可视化仓库总共4个仓库，除了默认的一个仓库外，其他3个仓库，需要脚本命令开通

;仓库二未开启时，从该仓库取物品或存物品会失败，并且触发QF脚本字段

;命令SETSTORAGEOPEN设置仓库开启或关闭状态

;SETSTORAGEOPEN 参数1(20130801) 参数2(20130802) 参数3(20130803) 参数4(20130804) 参数5(仓库序号(2,3)) 参数6(20130806) 参数7(20130807) 参数8(20130808) 参数9(开启或关闭(1,0)) 参数10(20130810)

[@StorageOpenFail2]
#IF
#ACT
MESSAGEBOX 仓库二无法打开,单击确认后开启 @开启仓库二 @取消

[@开启仓库二]
#IF
CHECKGAMEGOLD > 100
#ACT
GAMEGOLD - 100
SETSTORAGEOPEN 20130801 20130802 20130803 20130804 2 20130806 20130807 20130808 1 20130810
;开启仓库二命令
MESSAGEBOX 仓库二已解锁
#ELSEACT
MESSAGEBOX 元宝不够

;仓库三未开启时，从该仓库取物品或存物品会失败，并且触发QF脚本字段
[@StorageOpenFail3]
#IF
#ACT
MESSAGEBOX 仓库三无法打开,单击确认后开启 @开启仓库三 @取消

[@开启仓库三]
#IF
CHECKGAMEGOLD > 100
#ACT
GAMEGOLD - 100
SETSTORAGEOPEN 20130801 20130802 20130803 20130804 3 20130806 20130807 20130808 1 20130810
;开启仓库三命令
MESSAGEBOX 仓库三已解锁
#ELSEACT
MESSAGEBOX 元宝不够

------------------------------------------------------------------------宝宝不攻击人物--------------------------------------------------------------
ChangeSlaveAttackHumPowerRate 宝宝名称 攻击人物威力倍率(0不攻击人物,当前值除以100为实际倍数)
调整版本攻击人物的威力倍率

[@main]
#if
CHECKSLAVENAME 神兽
#act
ChangeSlaveAttackHumPowerRate 神兽 0
sendmsg 6 神兽不攻击人物
#elseact
sendmsg 6 请先把神兽召唤出来

-----------------------------------------------------------------------时装---------------------------------------------------------------------------
[Setup]
;在!Setup.txt字段下加入
;时装物品显示前缀文字信息
FashionPreFix=[时装]

时装衣服DB设置：StdMode段66为男衣服，67为女衣服,其他字段和普通衣服一样。位置代码：17。
时装武器DB设置：StdMode段68、69为武器,其他字段和普通武器一样。位置代码：18。
时装衣服属性和衣服一样。时装武器属性也是和普通的武器属性一样设置。
佩戴时装衣服和时装武器可以触发：[@TakeOn17]和[@TakeOff18]
相关常量<$SDRESS> <$SWEAPON> <$G_SDRESS> <$G_SWEAPON>

-------------------------------------------------------------------------人物杀怪暴率倍数----------------------------------------------------------------
脚本命令 KILLMONBURSTRATE 20140220 20140221 参数1 20140223 20140224 20140225 20140226 参数2 20140227 20140228
参数说明：
参数1 //倍率，实际倍率除以100;
参数2 //时长
例如：
#ACT
KILLMONBURSTRATE 20140220 20140221 200 20140223 20140224 20140225 20140226 600 20140227 20140228
SENDMSG 7 杀怪爆率翻倍，时长：600秒!

<$KILLMONBURSTRATE> 返回人物杀怪暴率倍数;

<$KILLMONBURSTRATETIME> 返回人物杀怪暴率倍数剩余时间;

-----------------------------------------------------------------------------备注功能---------------------------------------------------------------------
备注功能;
在Envir目录下创建个DZItemDescList.txt文本文件

文件格式，例：
;装备名称 备注颜色 备注信息
木剑=251/史诗
铁剑=253/极品


颜色值列表

0 | 1 | 2 | 3 | 4 | 5
6 | 7 | 8 | 9 | 10 | 11
12 | 13 | 14 | 15 | 16 | 17
18 | 19 | 20 | 21 | 22 | 23
24 | 25 | 26 | 27 | 28 | 29
30 | 31 | 33 | 34 | 35 | 36
37 | 38 | 39 | 40 | 41 | 42
43 | 44 | 45 | 46 | 47 | 48
49 | 50 | 51 | 52 | 53 | 54
55 | 56 | 57 | 58 | 59 | 60
61 | 62 | 63 | 64 | 65 | 66
67 | 68 | 69 | 70 | 71 | 72
73 | 74 | 75 | 76 | 77 | 78
79 | 80 | 81 | 82 | 83 | 84
85 | 86 | 87 | 88 | 89 | 90
91 | 92 | 93 | 94 | 95 | 96
97 | 98 | 99 | 100 | 101 | 102
103 | 104 | 105 | 106 | 107 | 108
109 | 110 | 111 | 112 | 113 | 114
115 | 116 | 117 | 118 | 119 | 120
121 | 122 | 123 | 124 | 125 | 126
127 | 128 | 129 | 130 | 131 | 132
133 | 134 | 135 | 136 | 137 | 138
139 | 140 | 141 | 142 | 143 | 144
145 | 146 | 147 | 148 | 149 | 150
151 | 152 | 153 | 154 | 155 | 156
157 | 158 | 159 | 160 | 161 | 162
163 | 164 | 165 | 166 | 167 | 168
169 | 170 | 171 | 172 | 173 | 174
175 | 176 | 177 | 178 | 179 | 180
181 | 182 | 183 | 184 | 185 | 186
187 | 188 | 189 | 190 | 191 | 192
193 | 194 | 195 | 196 | 197 | 198
199 | 200 | 201 | 202 | 203 | 204
205 | 206 | 207 | 208 | 209 | 210
211 | 212 | 213 | 214 | 215 | 216
217 | 218 | 219 | 220 | 221 | 222
223 | 224 | 225 | 226 | 227 | 228
229 | 230 | 231 | 232 | 233 | 234
235 | 236 | 237 | 238 | 239 | 240
241 | 242 | 243 | 244 | 245 | 246
247 | 248 | 249 | 250 | 251 | 252
253 | 254 | 255 |  |  |


自定义发光,宝宝属性叠加,按钮触发

===============================================================

右下角按钮触发 QF脚本

[@ButtonCustomClick]

该按钮默认没有素材，需要自己设置，默认隐藏的需要开启可见。

右下角那个按钮，需要在自定义UI编辑里面，在右边的框子找到该按钮，按钮名称 DButtonCustom。然后在左边的框，基本属性-是否可见-True

===============================================================

宝宝属性叠加至人物
ChangeHumNewValue
参数一:宝宝名称
参数二:类型(0叠加到攻击,1叠加到防御
参数三:叠加百分比（0-100）
参数四:叠加人物的道术(0)或魔法

人物的属性叠加至宝宝
ChangeSlaveAbil 稻草人 0 50 2

===============================================================

装备投保功能
QF脚本触发：

[@DropUseItems0]
#IF
#ACT
MOV M1 0

#IF
Equal <$INSURANCECURRENCY> 0
#ACT
MOV M1 1
MOV S1 <$INSURANCEGOLD>
INC S1 元宝

#IF
Equal <$INSURANCECURRENCY> 1
#ACT
MOV M1 1
MOV S1 <$INSURANCEGOLD>
INC S1 金币

#IF
Equal <$INSURANCECURRENCY> 2
#ACT
MOV M1 1
MOV S1 <$INSURANCEGOLD>
INC S1 泡点

#IF
Equal M1 1
#ACT
ThrowItem <$MAP> <$X> <$Y> 10 <$STR(S1)> 1|60 0 1
SENDMSG 6 衣服有保险，没有掉，掉落<$STR(S1)>。剩余投保次数(<$INSURANCECOUNT>)保金类型(<$INSURANCECURRENCY>)投保金额(<$INSURANCEGOLD>)
;#ELSEACT
;SENDMSG 6 未知投保类型

需要在物品DB StdItems.DB 里增加2个字段 InsuranceGold 和 InsuranceCurrency 这两个字段填写后针对的单个物品，多个物品需要继续设置

数据库字段名

字段详解
InsuranceGold
设置投保金额
字段值
投保金额 设置大于0时 登陆器才会显示该装备是否已经投保

InsuranceCurrency
设置保金类型
字段值:保金类型 0元宝 1金币 2泡点 3金刚石 4灵符

===============================================================

功能:人物放大
命令：SHOWPHANTOM
例子
SHOWPHANTOM 1 2 3 4 5 255 7 8 65535 10

SHOWPHANTOM 任意 任意 任意 任意 任意 透明度(0-255) 任意 任意 时间(秒) 任意
显示一个放大的虚影

==================================================================

1，首先在数据库里设置Anicount字段=190 (发光)，武器还支持部分特殊武器，如：138（吸血），241（倚天辟地）也会有发光效果.

友情提示：不管衣服、武器发光都需要修改Anicount为发光字段、如武器吸血可置138也会有发光

2，手动编写发光配置文件，放在客户端data目录下

武器发光配置文件Sky_WeaponEffect.txt
;编号|外观文件名|起始帧|内观文件|起始帧|结束帧|X|Y|武器名
73|HumEffect2.wzl|13200|stateitem.wzl|2850|2865|0|0|0|七品之剑

友情提示：编号是指装备DB的Shape字段值

衣服发光配置文件SKY_HumEffect.txt
;衣服外观编号|文件名|起始帧|内观文件|起始帧|结束帧|是否偏移|偏移X|偏移Y|备注87|HumEffect2.wzl|7200|stateitem.wzl|2541|2541|0|85|75|九品龙甲

除了自定义以外还支持装备发光AniCount=246至254

数据库设置装备发光的教程：衣服、武器发光详细说明

Anicount装备特效数据算法
设置：查看->列表信息二->物品特效 copyright dedecms

衣服翅膀下列没写出的请按算法自行进行换算，DB库衣服表Anicount除凤天(50)、天外飞仙(42)外其余请自行修改为0
算法：Anicount大于20：开始图片=(AniCount值 - 21) * 600 资源文件：HumEffect2.wil
AniCount小于等于20：开始图片=(AniCount值 - 1) * 600 资源文件：HumEffect.wil

原程序内定：(无坐标则为0)

主宰神甲：
内观特效：
资源文件：stateitem.wil
男：开始图片：2425 播放数量：1
女：开始图片：2426 播放数量：1

神甲：
内观特效：
资源文件：stateitem.wil
男：开始图片：2541 播放数量：1
女：开始图片：2543 播放数量：1

天外飞仙：
内观特效：
资源文件：stateitem.wil
开始图片：2600 播放数量：20

金牛道剑：
内观特效：
资源文件：stateitem.wil
开始图片：1403 播放数量：1
外观特效：
资源文件：HumEffect2.wil
开始图片：0

倚天：
内观特效：
资源文件：stateitem.wil
开始图片：1890 播放数量：10
外观特效：
资源文件：HumEffect2.wil
开始图片：1200

主宰神剑：
内观特效：
资源文件：stateitem.wil
开始图片：2427 播放数量：1
外观特效：
资源文件：HumEffect2.wil
开始图片：6000 内容来自dedecms

神剑：
内观特效：
资源文件：stateitem.wil
开始图片：2530 播放数量：8
外观特效：
资源文件：HumEffect2.wil
开始图片：8400

宝扇：
内观特效：
资源文件：stateitem.wil
开始图片：2550 播放数量：10
外观特效：
资源文件：HumEffect2.wil
开始图片：9600

魔杖：
内观特效：
资源文件：stateitem.wil
开始图片：2560 播放数量：10
外观特效：
资源文件：HumEffect2.wil
开始图片：10800

金牛头盔：
内观特效：
资源文件：Prguse.wil X坐标：77 Y坐标：-11
开始图片：620 播放数量：11

虎威头盔：
内观特效：
资源文件：ui1.wil X坐标：69 Y坐标：-16
开始图片：220 播放数量：32

主宰头盔：
内观特效：
资源文件：StateEffect.wil X坐标：72 Y坐标：-14
开始图片：580 播放数量：10 dedecms.com

金牛首饰：
内观特效：
资源文件：Prguse.wil X坐标：-10 Y坐标：-10
开始图片：640 播放数量：9
包裹特效：
资源文件：Prguse.wil X坐标：10 Y坐标：10
开始图片：640 播放数量：9

虎威首饰：
内观特效：
资源文件：ui1.wil X坐标：-8 Y坐标：-8 播放数量：32
手镯：开始图片：100
戒指：开始图片：140
项链：开始图片：180
靴子：开始图片：260
腰带：开始图片：300
勋章：开始图片：340

主宰首饰：
内观特效：
资源文件：StateEffect.wil X坐标：-4 Y坐标：-4 播放数量：10
戒指：开始图片：530
手镯：开始图片：540
项链：开始图片：550
靴子：开始图片：560
腰带：开始图片：570
勋章：开始图片：590

火龙印1：
内观特效：
资源文件：stateitem.wil X坐标：-8 Y坐标：-14
开始图片：2630 播放数量：15

火龙印2：
内观特效：
资源文件：stateitem.wil X坐标：-10 Y坐标：-14
开始图片：2650 播放数量：15
倚天战甲(男)：
外观特效：
资源文件：HumEffect2.wil
开始图片：2400

倚天战甲(女)：
外观特效：
资源文件：HumEffect2.wil
开始图片：3000

辉煌类衣服(男)：
外观特效：
资源文件：HumEffect2.wil
开始图片：3600

辉煌类衣服(女)：
外观特效：
资源文件：HumEffect2.wil
开始图片：4200

主宰神甲(男)：
外观特效：
资源文件：HumEffect2.wil
开始图片：4800

主宰神甲(女)：
外观特效：
资源文件：HumEffect2.wil
开始图片：5400

神甲(男)：
外观特效：
资源文件：HumEffect2.wil
开始图片：7200

神甲(女)：
外观特效：
资源文件：HumEffect2.wil
开始图片：7800

HumEffect2.wil 属于 翅膀 和武器的发光效果补丁文件
HumEffect2.wil 内素材代码除600加1等于DB Anicount值，例如素材内1200，DB写3
HumEffect2.wil 内只有一个素材，也就是只有600张图，第一个代码是00000
DB Anicount值写的是101，因为只有这一个没法算，简单看的话应该是除600加101
每个HumEffect2.wil文件中有20种效果图，如果用到的效果是在HumEffect2.wil中。那么按照第一张图片除以600加1以后再加上20就是Anicount的值

武器发光代码计算方法
humeffect2.wil //anicount值从240开始计算
如果用到的效果是在HumEffect2.wil中
HumEffect2中的效果设置AniCount=240.
注:HumEffect2中是武器发光的效果.那么按照第一张图片除以600加1以后再加上20就是Anicount的值

第二个文件HumEffect2.wil中有些复杂，因为里面保护的有衣服的翅膀样式和武器的特效动作，使用前必须把衣服和武器分类对应清楚，第二个文件HumEffect2.wil的样式代码从20开始，也就是HumEffect2.wil文件中的第一个外观代码是20，第二个样式外观代码为21以此类推，这些操作都是通过盛大客户端的源文件进行的测试，请大家使用客户端data里面的源文件去测试，因为有的补丁可能会比较乱，希望这篇文章可以帮助到大家，谢谢各位的阅读。


一、使用#Include
类似配置文件，用于设置常量
经常需要使用到的变量和常量可以考虑使用#Include
在..\Envir\Defines 建立一个文本文件
例如(支持txt ini)

全局常量.txt
定义的配置.ini

文本内容如下：
#DeFine $玩家衣服$ <$Dress>
#DeFine $玩家武器$ <$Weapon>
#DeFine $盟重地图ID$ N3
#DeFine $会员数量$ <$Global(会员数量)>
#DeFine $传送标签$ <【盟重】[url=]/@[/url]传送盟重>

或者

#Define 按钮位置(确定按钮X坐标) 500
#Define 按钮位置(确定按钮Y坐标) 300

;======================================

在NPC脚本[@Main]前添加

例如:
#Include 全局常量.txt
#INCLUDE 定义的配置.ini

[@Main]
#If
#Say
你佩戴的衣服为：$玩家衣服$ \
你佩戴的武器为：$玩家武器$ \
  \
当前会员数量：$会员数量$
  \
当前盟重地图ID：$盟重地图ID$
  \
$传送标签$
#Act
Var Integer Global 会员数量

[@传送盟重]
#If
#Act
MapMove $盟重地图ID$

;======================================
注明：要先定义全局变量<$Global(会员数量)> 否则脚本会报错
;======================================

二、使用#DeFine
不经常需要使用到的变量和常量可以考虑使用##DeFine

在NPC脚本[@Main]前添加
#DeFine $玩家衣服$ <$Dress>
#DeFine $玩家武器$ <$Weapon>
#DeFine $盟重地图ID$ N3

#DeFine $会员数量$ <$Global(会员数量)>

#DeFine $传送标签$ <【盟重】[url=]/@[/url]传送盟重>
[@Main]
#If
#Say
你佩戴的衣服为：$玩家衣服$ \
你佩戴的武器为：$玩家武器$ \
  \
当前会员数量：$会员数量$
  \
当前盟重地图ID：$盟重地图ID$
  \
$传送标签$
#Act
Var Integer Global 会员数量

[@传送盟重]
#If
#Act
MapMove $盟重地图ID$

;======================================
注明：要先定义全局变量<$Global(会员数量)> 否则脚本会报错
;======================================

例

在脚本中使用时

[@main]
#INCLUDE 定义的配置.ini
#if
#act
MOV S1 按钮位置(确定按钮X坐标)
MOV S2 按钮位置(确定按钮Y坐标)
sendmsg 5 按钮X坐标为：<$STR(S1)>,按钮Y坐标为：<$STR(S2)>

如果是#call 中调用
[@测试]
#INCLUDE 定义的配置.ini
{

脚本内容

.

.

.

.

}


TJ引擎充值配置与命令

1.充值配置
 特戒引擎充值需要首先在tejieconfig文件中进行配置：

---------------------------------------------------------------------------------------------------------------------------------------------------------------
;充值配置
;充值金额 金刚石<$GAMEDIAMOND>数量 元宝<$GAMEGOLD>数量游戏点数<$GAMEPOINT>数量背景图片 荣誉<$GAMEGLORY>数量声望<$CREDITPOINT>数量灵符<$GAMEGIRD>数量 界面描述 标记ID（命令调用ID）
[charge]< br>9 060000000yuanbao_2009<9元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=19814><1000W/SCOLOR=243><元宝/SCOLOR=90designtimesp=19815><9/SCOLOR=243><充值点/SCOLOR=90 designtimesp=19816> 1< br>18 0180000000yuanbao_30018<18元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=19818><1800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=19819><18/SCOLOR=243><充值点/SCOLOR=90 designtimesp=19820> 2< br>38 0380000000yuanbao_40038<38元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=19822><3800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=19823><38/SCOLOR=243><充值点/SCOLOR=90 designtimesp=19824> 3< br>68 0680000000yuanbao_50068<68元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=19826><6800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=19827><68/SCOLOR=243><充值点/SCOLOR=90 designtimesp=19828> 4< br>488 04880000000yuanbao_500488<488元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=19830><48800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=19831><488/SCOLOR=243><充值点/SCOLOR=90 designtimesp=19832> 5< br>108 01080000000yuanbao_500108<108元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=19834><10800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=19835><108/SCOLOR=243><充值点/SCOLOR=90 designtimesp=19836> 6< br>218 02180000000yuanbao_500218<218元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=19838><21800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=19839><218/SCOLOR=243><充值点/SCOLOR=90 designtimesp=19840> 7< br>358 03580000000yuanbao_500358<358元充值/SCOLOR=243>|<送/SCOLOR=90designtimesp=19842><35800W/SCOLOR=243><元宝/SCOLOR=90designtimesp=19843><358//SCOLOR=243><充值点/SCOLOR=90 designtimesp=19844> 8

充值相关命令：
功能: 检查当前是否为测试服，如果是测试服则为真
格式: checktestsever

[@main]
#IF
checktestsever
#SAY
当前服务器是测试服
#ELSESAY
当前服务器是正式服

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 系统变量：测试服充值总金额
格式: <$TESTRECHARGE>

[@main]
#IF
#SAY
你在测试服的充值金额为：<$TESTRECHARGE>

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 改变测试区充值金额
格式: GAMETETESTRECHARGE 操作符（+、-，=） 数值
说明: 正式服领取充值返还后需要使用这个命令把测试服的充值金额减掉

[@main]
#IF
#ACT
GAMETETESTRECHARGE - <$TESTRECHARGE>

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 系统变量：对应档充值的总次数和对应档充值的总金额
格式: <$RECHARGE[X].FREQUENCY>
说明：X为在tejieconfig中配置的标记ID；对应标记的充值次数

格式：<$RECHARGE[X].NUMBER>
说明：X为在tejieconfig中配置的标记ID；对应标记的充值总金额

[@main]
#IF
#SAY
你在测试服充值9元档的充值金额为：<$RECHARGE[1].NUMBER>
你在测试服充值9元档的次数为：<$RECHARGE[1].FREQUENCY>

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 打开充值界面命令
格式: OPENCHARGE
说明: 这个命令可以打开充值界面

[@main]
#IF
#ACT
OPENCHARGE

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 充值返还脚本实例：

[@main]
#IF
#ACT
mul N$返还元宝 <$TESTRECHARGE> 4800
mul N$返还充值点 <$TESTRECHARGE> 12
mul N$返还逆兲币 <$TESTRECHARGE> 24
#SAY
<测试区元宝领取：/scolor=253>\ \
<可以在我这里领取测试区充值对应的元宝；充值点和逆兲币/scolor=255>\
<测试服充值，到对应的正式服百分百返还加送百分之二十！/scolor=224>\ \
<您在测试区充值金额为：/scolor=253><[/scolor=243><$TESTRECHARGE><]元/scolor=243>\ \
<可领取：/scolor=253><[/scolor=243><$STR(N$返还元宝)><]元宝/scolor=243> <[/scolor=243><$STR(N$返还充值点)><]充值点/scolor=243> <[/scolor=243><$STR(N$返还逆兲币)><]逆兲币/scolor=243>\ \
<领取充值返还/@领取元宝>
[@领取元宝]
#IF
checktestsever
#act
MESSAGEBOX 只有在正式服才能领取充值返还！
break
#IF
large <$TESTRECHARGE> 1
Check [9999] 0
#act
;给与元宝
GAMEGOLD + <$STR(N$返还元宝)>
;给逆天币
GAMEGIRD + <$STR(N$返还逆兲币)>
;给充值点
GAMEDIAMOND + <$STR(N$返还充值点)>
;加上正式区的充值额度
GAMEPOINT + <$TESTRECHARGE>
;减去充值额度 （这个值一定要在加上之前在减）
GAMETETESTRECHARGE - <$TESTRECHARGE>
MESSAGEBOX 您的成功领取了测试区充值返还！！！
SET [9999] 1
mov <$TESTRECHARGE> 0
#ELSEACT
MESSAGEBOX 您已经领取过测试区充值返还了！！！

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
注意：如果充值档给的充值货币不同或者有多充多送的这种充值结构，在充值返还脚本的计算结果需要使用<$RECHARGE[X].NUMBER>来根据具体每一档的充值额度进行计算返还

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
一个每一档充值比例都不同的列子：
[@main]
#IF
#ACT
;先在tejieconfig中给每一档充值打上标记
mov N$总返还RMB点数量 0
mov N$总返还消费点数量 0
mul N$第一档返还RMB点数量 <$RECHARGE[1].FREQUENCY> 12
mul N$第一档返还消费点数量 <$RECHARGE[1].FREQUENCY> 12
mul N$第二档返还RMB点数量 <$RECHARGE[2].FREQUENCY> 36
mul N$第二档返还消费点数量 <$RECHARGE[2].FREQUENCY> 36
mul N$第三档返还RMB点数量 <$RECHARGE[3].FREQUENCY> 72
mul N$第三档返还消费点数量 <$RECHARGE[3].FREQUENCY> 72
mul N$第四档返还RMB点数量 <$RECHARGE[4].FREQUENCY> 132
mul N$第四档返还消费点数量 <$RECHARGE[4].FREQUENCY> 132
mul N$第五档返还RMB点数量 <$RECHARGE[5].FREQUENCY> 276
mul N$第五档返还消费点数量 <$RECHARGE[5].FREQUENCY> 276
mul N$第六档返还RMB点数量 <$RECHARGE[6].FREQUENCY> 420
mul N$第六档返还消费点数量 <$RECHARGE[6].FREQUENCY> 420
mul N$第七档返还RMB点数量 <$RECHARGE[7].FREQUENCY> 720
mul N$第七档返还消费点数量 <$RECHARGE[7].FREQUENCY> 720
mul N$第八档返还RMB点数量 <$RECHARGE[8].FREQUENCY> 1560
mul N$第八档返还消费点数量 <$RECHARGE[8].FREQUENCY> 1560
inc N$总返还RMB点数量 N$第一档返还RMB点数量
inc N$总返还RMB点数量 N$第二档返还RMB点数量
inc N$总返还RMB点数量 N$第三档返还RMB点数量
inc N$总返还RMB点数量 N$第四档返还RMB点数量
inc N$总返还RMB点数量 N$第五档返还RMB点数量
inc N$总返还RMB点数量 N$第六档返还RMB点数量
inc N$总返还RMB点数量 N$第七档返还RMB点数量
inc N$总返还RMB点数量 N$第八档返还RMB点数量
inc N$总返还消费点数量 N$第一档返还消费点数量
inc N$总返还消费点数量 N$第二档返还消费点数量
inc N$总返还消费点数量 N$第三档返还消费点数量
inc N$总返还消费点数量 N$第四档返还消费点数量
inc N$总返还消费点数量 N$第五档返还消费点数量
inc N$总返还消费点数量 N$第六档返还消费点数量
inc N$总返还消费点数量 N$第七档返还消费点数量
inc N$总返还消费点数量 N$第八档返还消费点数量
#SAY
<测试区元宝领取：/scolor=253>\ \
<可以在我这里领取测试区充值对应的RMB点和消费点/scolor=255>\
<测试服充值，到对应的正式服百分百返还加送百分之二十！/scolor=224>\ \
<您在测试区充值金额为：/scolor=253><[/scolor=243><$TESTRECHARGE><]元/scolor=243>\ \
<可领取：/scolor=253><[/scolor=243><$STR(N$总返还RMB点数量)><]RMB点/scolor=243> <[/scolor=243><$STR(N$总返还消费点数量)><]消费点/scolor=243> \ \
<领取充值返还/@领取元宝>
[@领取元宝]
#IF
checktestsever
#act
MESSAGEBOX 只有在正式服才能领取充值返还！
break
#IF
large <$TESTRECHARGE> 1
Check [9999] 0
#act
;给RMB点
GAMEGOLD + <$STR(N$总返还RMB点数量)>
;给消费点
GAMEGIRD + <$STR(N$总返还消费点数量)>
;加上正式区的充值额度（GM自定义的充值额度货币）
GAMEPOINT + <$TESTRECHARGE>
;减去充值额度 （这个值一定要在加上之前在减）
GAMETETESTRECHARGE - <$TESTRECHARGE>
MESSAGEBOX 您的成功领取了测试区充值返还！！！
SET [9999] 1
mov <$TESTRECHARGE> 0
#ELSEACT
MESSAGEBOX 您已经领取过测试区充值返还了！！！

充值成功触发
 充值成功会进入QFunction-0中的[@recharge]@块，可以用来做全服消息提醒等功能

---------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 检测当前笔充值的RMB额度
格式: checkchargelimit 参数1 参数2
说明: 参数1为检测符号><= 参数2为当前次充值充值的人民币金额

[@recharge]
#IF
checkchargelimit = 9 #ACT
SENDMSG 0 <$USERNAME>成功充值了9元


TJ引擎战斗力功能介绍

简介：
 1.TJ引擎提供内置的战斗力系统，可通过tejieconfig中的配置进行开启和关闭
 2.GM也可使用自己脚本中的战斗力来替代TJ引擎默认的战斗力，也是在tejieconfig中配置

配置说明：
;1是否使用系统默认的战斗力（如果用系统默认的填1，不用的话写0；写0时可在脚本里给 n$FIGHTPOWER 传值来自定义战斗力）
;2（隐藏主界面战斗力显示写0，显示的话写1）
[FIGHTPOWER]
1 0
2 1


TJ引擎对GOM引擎一些命令的修改

TJ引擎对GOM引擎一些命令的修改和特戒引擎独有命令

ADDBUTTON命令：
功能: 创建自定义按钮
格式: ADDBUTTON 参数1 参数2 参数3 参数4
说明: 参数1为图片资源名称（可在资源编辑器中查看可调用图片） 参数2为按钮点击后脚本触发序号，触发QF里面的[@ButtonClickX]X即为触发序号 参数3为按钮位置（1-10） 参数4为按钮上的文字（支持：文字颜色|文字 ）

[@main]
#IF
#ACT
ADDBUTTON chongzhi_bth 1 1
;在1位置增加充值按钮，点击触发[@ButtonClick1]

SETITEMEFFECT命令：

功能: 设置装备发光特效
格式: SETITEMEFFECT 参数1 参数2
说明: 参数1为位置(-1时是OK框中的装备, 0-16时是穿在身上的装备) 参数2为特效名称(0为清除特效)（特效名称可在资源编辑器中的可调用特效资源查看）

[@main]
#IF
#ACT
SETITEMEFFECT 0 iconGuangXiao_lv

MAPEFFECT命令：

功能: 在地面播放特效
格式: MAPEFFECT 参数1 参数2 参数3 参数4 参数5
说明: 参数1为地图编号 参数2为X坐标 参数3为Y坐标 参数4为特效资源名（特效名称可在资源编辑器中的可调用特效资源查看） 参数5为持续时间（-1为永久） 参数6为缩放倍数

[@main]
#IF
#ACT
MAPEFFECT 3 100 100 GuangZhu_Zi -1 1
;在地图3的100、100处创建GuangZhu_Zi这个特效

PLAYEFFECT命令：

功能: 在主角模型上播放指定特效
格式: PLAYEFFECT 参数1 参数2
说明: 参数1为特效资源名（特效名称可在资源编辑器中的可调用特效资源查看） 参数2为播放时长（单位毫秒-1为循环播放）

[@main]
#IF
#ACT
PLAYEFFECT GuangZhu_Zi -1

Img、ImgEx、PlayImg命令：

功能: 在OK框中播放图片
格式: <Img:图片名称:X横向坐标:Y纵向坐标:是否灰化（0不灰化，-1灰化）:缩放倍数,旋转角度（可缺省，0-360）:宽度:高度/@Label>格式: <ImgEx:图片名称:X横向坐标:Y纵向坐标/@Label>
格式: <PlayImg:图片名称:X横向坐标:Y纵向坐标/@Label>
说明: 图片资源名称（可在资源编辑器中查看可调用图片）

OPENSHOPPINGMALL命令：

功能: 打开商城界面
格式: OPENSHOPPINGMALL
说明: 打开商城界面

[@main]
#IF
#ACT
OPENSHOPPINGMALL

OPENSIGNIN命令：

功能: 打开签到界面
格式: OPENSIGNIN
说明: 打开签到界面，签到每日签到可领取的道具在：tejieconfig中的[Sign]，需要配置31天的道具

[@main]
#IF
#ACT
OPENSIGNIN

OPENCHARGE命令：

功能: 打开充值界面
格式: OPENCHARGE
说明: 打开充值界面

[@main]
#IF
#ACT
OPENCHARGE

openui命令：

功能: 打开界面命令
格式: openui 参数1
说明: 参数1为1 （打开可视化仓库）

[@main]
#IF
#ACT
openui 1

OPENMERCHANTBIGDLG命令：

功能: 打开NPC大对话框
格式: OPENMERCHANTBIGDLG 参数1 参数2 参数3 参数4 参数5 参数6 参数7
说明:参数1为图片名称（图片名称可在资源编辑器可调用UI资源中查看）参数2为显示位置(0=左上角,1=右上角,2=左下角,3=右下角,4=居中) 参数3为微调坐标X 参数4为微调坐标Y 参数5为是否显示关闭按钮(2,3为关闭，其他为不关闭) 参数6为关闭按钮坐标X 参数7为关闭按钮坐标Y

[@main]
#IF
#ACT
OPENMERCHANTBIGDLG daokkuang 4 0 0 0 0 0

ItemShownum命令：

功能: 带道具数量检测的itemshow命令
格式: ItemShownum:341:0:0:0:1:数量>
说明: 数量可检测对应道具在背包中拥有的数量是否足够，如果足够则图片显示为亮，不够则显示为灰色

ItemShow命令：

功能: 调用装备信息，将装备图标显示在界面上
格式:
说明: 参数D：物品ID
说明: 参数F：数量（如果为0就不显示数量）
说明: 参数X：微调坐标X
说明: 参数Y：微调坐标Y
说明: 参数B：是否显示背景图片，（0不显示，1显示通用底框，2显示绿色底框，3显示蓝色底框，4显示紫色底框，5显示橙色底框，6红色底框）
说明: 参数E：是否灰化（0不灰化，1灰化）

ImgButton命令：

功能: 自定义图片按钮
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
imgButton | 图片名称,是否描边 | X偏移 | Y偏移 | 按钮文字 | 跳转

参数1追加附件参数:是否描边

1为描边

0为不描边

缺省为描边

[@main]
#say

<imgButton:0000378,0:500:50:按钮1/@test>
<imgButton:0000378,1:380:50:按钮2/@test>
<imgButton:0000378:260:120:按钮文字3/@test>

[@test]
#act
messageBox hello


官方主页

TJ引擎地面物品光柱特效设置说明

简介：
 物品地面光柱在Tejieconfig.txt中进行配置

在[ItemBeam]节点下进行配置，格式为：道具名称 光柱特效名称

特戒引擎提供光柱资源，可在资源编辑中查看提供的光柱资源
示例：
;---------------------------------------------------------------------------------------------------------------------------------------------------------------
;配置道具掉落在地上对应道具上播放的特效（光柱）
;道具名称 特效名称
[ItemBeam]
命运之书 ShanGuang
护身符 ShanGuang
战神油 ShanGuang
回城卷 ShanGuang
祝福油 ShanGuang
求婚戒指 ShanGuang
太阳水 ShanGuang
祖玛头像 ShanGuang
修复油 ShanGuang
疗伤药 ShanGuang
神水 ShanGuang
万年雪霜 ShanGuang
神秘药水 ShanGuang
地牢逃脱卷包 ShanGuang
随机传送卷包 ShanGuang


官方主页

TJ引擎专有命令

简介：
 特戒引擎自己实现的命令和修改的GOM引擎的命令会统一在这里进行说明

排行榜相关命令：
功能: 检测当前在等级排行榜中的排名
格式: CHECKRANKINGLEVEL 检测符（><=） 数值
说明: 未进入排行的角色排名为9999

[@main]
#IF
CHECKRANKINGLEVEL = 1
#SAY
你当前在等级排行榜中的排名是：第1名
#ELSESAY
你当前在等级排行榜中的排名不是：第1名

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 检测当前在战力排行榜中的排名
格式: CHECKRANKINGPOWER 检测符（><=） 数值
说明: 未进入排行的角色排名为9999

[@main]
#IF
CHECKRANKINGPOWER = 1
#SAY
你当前在战力排行榜中的排名是：第1名
#ELSESAY
你当前在战力排行榜中的排名不是：第1名

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 系统变量：当前等级排行榜排名和当前战力排行榜排名
格式: <$RANKINGLEVEL>
说明：当前等级排行榜排名

格式：<$RANKINGPOWER>
说明：当前战力排行榜排名

[@main]
#IF
#SAY
你在等级排行榜中的排名为：<$RANKINGLEVEL>
你在战力排行榜中的排名为：<$RANKINGPOWER>

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 系统变量：战力排行榜中对应X排名的角色名称和战力排行榜中对应X排名的战力值
格式: <$RANKINGPOWER[X].NAME>
说明：X为排名，返回战力排行榜中对应X排名的角色名称

格式：<$RANKINGPOWER[X].POWER>
说明：X为排名，返回战力排行榜中对应X排名的战力战力之间

[@main]
#IF
#SAY
战力排行榜中第一名的角色为：<$RANKINGPOWER[1].NAME>
战力排行榜中第一名的角色战力为：<$RANKINGPOWER[X].POWER>


TJ引擎在OK框中显示3D模型

TJ引擎专有命令

简介：

该命令可以在OK框中显示出角色、怪物、NPC、武器的3D模型

PlayModel命令：

功能: 在OK框中显示出3D模型
格式:< playmodel:模型编号:X横向坐标:Y纵向坐标:UI缩放比例,Y轴旋转角度（可缺省，0-360）,平面旋转角度（可缺省，0-360）:模型缩放比例:男女:武器:斗笠:翅膀:特效>
说明:模型编号可在资源编辑中查看(缩放比例1为正常大小)

男 = 0 女 = 1
[@main]
#IF
#SAY
<PlayModel:2001:0:0:1:1:0:1001:0:0:0>


百分比控制血量

功能：

脚本检测/设置人物或怪物血量

AddhpPer +/-/=
AddmpPer +/-/=

CheckHpPer >/</=
CheckMpPer >/</=

参数详解：

参数1:血量百分比

例：

QFunction-0.txt 攻击怪物触发

[@攻击怪物触发]
#IF
CHECKHITMONNAME 白野猪
#act
m.AddHPPer - 10
sendmsg 6 白野猪血量减少10%

[@main]
<检查血量百分比30%/@检查血量百分比30%> <检查蓝量百分比30%/@检查蓝量百分比30%> \
<增加血量10%/@增加血量10%> <增加蓝量10%/@增加蓝量10%> \
<减少血量10%/@减少血量10%> <减少蓝量10%/@减少蓝量10%> \
<设置血量10%/@设置血量10%> <设置蓝量10%/@设置蓝量10%> \

[@设置血量10%]
#act
AddhpPer = 10

[@设置蓝量10%]
#act
AddmpPer = 10

[@减少血量10%]
#act
AddhpPer - 10

[@减少蓝量10%]
#act
AddmpPer - 10

[@检查血量百分比30%]
#if
CheckHpPer > 30
#act
sendmsg 6 你的血量在30%以上..
#elseact
sendmsg 6 你的血量低于30%..

[@检查蓝量百分比30%]
#if
CheckMpPer > 30
#act
sendmsg 6 你的蓝量在30%以上..
#elseact
sendmsg 6 你的蓝量低于30%..

[@增加血量10%]
#act
AddhpPer + 10

[@增加蓝量10%]
#act
AddmpPer + 10


官方主页

TJ引擎新增装备位置

简介：
 TJ引擎在装备界面新增了2个装备位置，在时装界面新增了4个装备位置

1.tejieconfig中配置是否开启新的装备位置：
说明: 配置方法
;是否开启哪一个位置的时装 1-开启 0-不开启 默认是0，不开启。
openfashion20=1
openfashion21=0
openfashion22=1
openfashion23=1
;是否开启哪一个位置的装备 1-开启 0-不开启 默认是0，不开启。
openequip24=1
openequip25=1
如果开放装备页上的装备位置还需要在[EquipmenField]中配置：
24 -134,-198 beibao_daojukuang001
25 124,-198 beibao_daojukuang001

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 装备界面上新增的2个装备位：
Stdmode: 113和114
装备位ID: 24和25
对应的常量：<$GUASHI1>、<$G_GUASHI1>和<$GUASHI2>、<$G_GUASHI2>
支持现有所有对装备进行操作的命令

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
功能: 时装界面上新增的4个装备位：
Stdmode: 120、121、122、123
装备位ID: 20、21、22、23
对应的常量：<$FASHION1>、<$G_FASHION1>和<$FASHION2>、<$G_FASHION2>和<$FASHION3>、<$G_FASHION3>和<$FASHION4>、<$G_FASHION4>
支持现有所有对时装进行操作的命令
穿戴触发：[@TakeOn121]、[@TakeOff121]、[@TakeOn122]、[@TakeOff122]、[@TakeOn123]、[@TakeOff123]、[@TakeOn124]、[@TakeOff124]


字符串分割命令功能

功能：

分割指定字符串内容到储存到变量中

命令：

EXTRACTSTRING 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8 参数9 参数10

参数详解：

参数1：字符串分割符
参数2：要被分割的完整字符串
参数3：用于接收分割后的第一个字符串，如S1
参数4：用于接收分割后的第一个字符串，如S2
参数5：用于接收分割后的第一个字符串，如S3
参数6：用于接收分割后的第一个字符串，如S4
参数7：用于接收分割后的第一个字符串，如S5
参数8：用于接收分割后的第一个字符串，如S6
参数9：用于接收分割后的第一个字符串，如S7
参数10：用于接收分割后的第一个字符串，如S8

脚本例子：

#act
mov S0 战神盔甲(男):裁决之杖:绿色项链:黑铁头盔:骑士手镯:骑士手镯:力量戒指:力量戒指
EXTRACTSTRING : <$STR(S0)> s1 s2 s3 s4 s5 s6 s7 s8
sendmsg 6 分割结果:<$STR(S1)> <$STR(S2)> <$STR(S3)> <$STR(S4)> <$STR(S5)> <$STR(S6)> <$STR(S7)> <$STR(S8)>

执行结果：
<$STR(S1)> = 战神盔甲(男)
<$STR(S2)> = 裁决之杖
<$STR(S3)> = 绿色项链
<$STR(S4)> = 黑铁头盔
<$STR(S5)> = 骑士手镯
<$STR(S6)> = 骑士手镯
<$STR(S7)> = 力量戒指
<$STR(S8)> = 力量戒指


绝对路径说明

功能：

引擎自带的所有字符串操作命令都带有绝对路径操作，我们插件就不再出命令了，本章教你引擎自带的命令如何使用绝对路径

例子：

功能：
从文件中随机取文本。

格式：
GETRANDOMLINETEXT 文件 字符串变量

;==========================================
;示例脚本
[@Main]
#If
#Act
GETRANDOMLINETEXT ..\QuestDiary\装备列表.txt <$STR(S0)>
#Say
取回的文本是： <$STR(S0)>
;==========================================

详解：

GETRANDOMLINETEXT ..\QuestDiary\装备列表.txt <$STR(S0)>

上面这条命令可分为三部分

1：GETRANDOMLINETEXT
2：..\QuestDiary\装备列表.txt
3：<$STR(S0)>

我们要修改的是第2部分，路径：..\QuestDiary\装备列表.txt

..\在windows系统中代表的是上一层目录的意思，那么第二部分换算过来，路径就是：【D:\MirServer\Mir200\Envir】 + 【\QuestDiary\Envir\装备列表.txt】

那么1个【..\】 = 【D:\MirServer\Mir200\Envir】路径， 2个【..\..\】 = 【D:\MirServer\Mir200】路径

3个【..\..\..\】 = 【D:\MirServer】路径，4个【..\..\..\..\】 = 【D:\】路径

通过上面理解了..\的功能后，现在我们把需求变更，随机从D:\共享数据\装备列表.txt中获取数据

先到D盘建立共享数据文件夹，再将装备列表.txt放进去

写法：

[@Main]
#If
#Act
GETRANDOMLINETEXT ..\..\..\..\共享数据\数据文件1.txt <$STR(S0)>
#Say
取回的文本是： <$STR(S0)>

【4个..\】=D盘 那么本条命令执行的结果就是 D:\共享数据\装备列表.txt 了

这样，D盘下所有分区，就可以共享 D:\共享数据\装备列表.txt 的数据了

此方法支持引擎所有文件文本操作的功能命令。

注意：

此功能仅限于相同盘符，无法跨盘符操作文件。


GM命令制造物品带物品来源

功能：

GM命令制造出物品，指定物品来源，制造物品命令在插件中可修改

命令(在游戏聊天框中输入，注意每个参数中间只能有1个空格)：

@MakeEx 参数1 参数2 参数3 参数4 参数5 参数6

参数详解：

参数1:装备名称
参数2:来源类型 2=自定义来源 4=杀怪掉落
参数3:地图名
参数4:怪物名/来源名
参数5:角色名称(省略或使用%s时获取当前人物名)
参数6:来源时间(省略或使用%s时获取当前时间)

例：

制造怪物来源的物品(指定所有参数):
@MakeEx 裁决之杖 4 死亡棺材 暗之触龙神 龙在天下 2010-01-01 00:00:01

制造怪物来源的物品(部分参数自动获取):
@MakeEx 裁决之杖 4 死亡棺材 暗之触龙神 %s %s

制造自定义来源的物品(指定所有参数):
@MakeEx 裁决之杖 2 盟重省 土城酷跑活动 龙在天下 2010-01-01 00:00:01

制造自定义来源的物品(部分参数自动获取):
@MakeEx 裁决之杖 2 盟重省 土城酷跑活动 %s %s


装备位置

标签:|装备位置|装备位|装备栏|装备格|道具栏|道具格

装备
道具类别 | StdMode | 装备位 | 装备位道具名称变量 | 装备位道具名称改名变量 | 装备位道具强化值
衣服(男) | 10 | 0 | <$dress> | <$g_dress> | <$upgradeCount0>
衣服(女) | 11
武器(单手) | 5 | 1 | <$weapon> | <$g_weapon> | <$upgradeCount1>
武器(双手) | 6
勋章 、照明 | 30 | 2 | <$righthand> | <$g_righthand> | <$upgradeCount2>
项链 | 19 | 3 | <$NECKLACE> | <$g_necklace> | <$upgradeCount3>
头盔 | 15 | 4 | <$helmet> | <$g_helmet> | <$upgradeCount4>
左手镯 | 24 | 5 | <$armring_l> | <$g_armring_l> | <$upgradeCount5>
右手镯 | 26 | 6 | <$armring_r> | <$g_armring_r> | <$upgradeCount6>
左戒指 | 22 | 7 | <$ring_l> | <$g_ring_l> | <$upgradeCount7>
右戒指 | 23 | 8 | <$ring_r> | <$g_ring_r> | <$upgradeCount8>
护身符-兵法 | 25 | 9 | <$bujuk> | <$g_bujuk> | <$upgradeCount9>
腰带 | 64 | 10 | <$belt> | <$g_belt> | <$upgradeCount10>
鞋子 | 62 | 11 | <$boots> | <$g_boots> | <$upgradeCount11>
宝石-神石 | 63 | 12 | <$charm> | <$g_charm> | <$upgradeCount12>
斗笠 | 16 | 13 | <$hat> | <$g_hat> | <$upgradeCount13>
军鼓 | 65 | 14 | <$drum> | <$g_drum> | <$upgradeCount14>
马牌 | 28 | 15 | <$horse> | <$g_horse> | <$upgradeCount15>
盾牌 | 48 | 16 | <$shield> | <$g_shield> | <$upgradeCount16>
挂饰1 | 113 | 24 | <$guashi1> | <$g_guashi1> | <$upgradeCount24>
挂饰2 | 114 | 25 | <$guashi2> | <$g_guashi2> | <$upgradeCount25>
面巾 | 50 | 26 | <$ftower> | <$g_ftower> | <$upgradeCount26>

?

时装
道具类别 | StdMode | 装备位 | 装备位道具名称变量 | 装备位道具名称改名变量 | 装备位道具强化值
时装衣服(男) | 66 | 17 | <$sdress> | <$g_sdress> | <$upgradeCount17>
时装衣服(女) | 67
时装武器(单手) | 68 | 18 | <$sweapon> | <$g_sweapon> | <$upgradeCount18>
时装武器(双手) | 69
时装装备1 | 120 | 20 | <$fashion1> | <$g_fashion1> | <$upgradeCount20>
时装装备2 | 121 | 21 | <$fashion2> | <$g_fashion2> | <$upgradeCount21>
时装装备3 | 122 | 22 | <$fashion3> | <$g_fashion3> | <$upgradeCount22>
时装装备4 | 123 | 23 | <$fashion4> | <$g_fashion4> | <$upgradeCount23>

?

首饰盒(生肖盒)
道具类别 | StdMode | 装备位 | 装备位道具名称变量 | 装备位道具名称变量 | 装备位道具名称改名变量 | 装备位道具强化值
首饰盒位置1 | 100 | 30 | <$godBlessItem1> | <$pgSndaItemBox1> | <$pgG_SndaItemBox1> | <$upgradeCount100>
首饰盒位置2 | 101 | 31 | <$godBlessItem2> | <$pgSndaItemBox2> | <$pgG_SndaItemBox2> | <$upgradeCount101>
首饰盒位置3 | 102 | 32 | <$godBlessItem3> | <$pgSndaItemBox3> | <$pgG_SndaItemBox3> | <$upgradeCount102>
首饰盒位置4 | 103 | 33 | <$godBlessItem4> | <$pgSndaItemBox4> | <$pgG_SndaItemBox4> | <$upgradeCount103>
首饰盒位置5 | 104 | 34 | <$godBlessItem5> | <$pgSndaItemBox5> | <$pgG_SndaItemBox5> | <$upgradeCount104>
首饰盒位置6 | 105 | 35 | <$godBlessItem6> | <$pgSndaItemBox6> | <$pgG_SndaItemBox6> | <$upgradeCount105>
首饰盒位置7 | 106 | 36 | <$godBlessItem7> | <$pgSndaItemBox7> | <$pgG_SndaItemBox7> | <$upgradeCount106>
首饰盒位置8 | 107 | 37 | <$godBlessItem8> | <$pgSndaItemBox8> | <$pgG_SndaItemBox8> | <$upgradeCount107>
首饰盒位置9 | 108 | 38 | <$godBlessItem9> | <$pgSndaItemBox9> | <$pgG_SndaItemBox9> | <$upgradeCount108>
首饰盒位置10 | 109 | 39 | <$godBlessItem10> | <$pgSndaItemBox10> | <$pgG_SndaItemBox10> | <$upgradeCount109>
首饰盒位置11 | 110 | 40 | <$godBlessItem11> | <$pgSndaItemBox11> | <$pgG_SndaItemBox11> | <$upgradeCount110>
首饰盒位置12 | 111 | 41 | <$godBlessItem12> | <$pgSndaItemBox12> | <$pgG_SndaItemBox12> | <$upgradeCount111>

?

首饰盒(神佑盒)
道具类别 | StdMode | 装备位 | 装备位道具名称变量 | 装备位道具名称改名变量 | 装备位道具强化值
首饰盒位置1 | 72 | 51 | <$jewelryItem1> | <$g_jewelryItem1> | <$upgradeCount51>
首饰盒位置2 | 73 | 52 | <$jewelryItem2> | <$g_jewelryItem2> | <$upgradeCount52>
首饰盒位置3 | 74 | 53 | <$jewelryItem3> | <$g_jewelryItem3> | <$upgradeCount53>
首饰盒位置4 | 75 | 54 | <$jewelryItem4> | <$g_jewelryItem4> | <$upgradeCount54>
首饰盒位置5 | 76 | 55 | <$jewelryItem5> | <$g_jewelryItem5> | <$upgradeCount55>
首饰盒位置6 | 77 | 56 | <$jewelryItem6> | <$g_jewelryItem6> | <$upgradeCount56>

?

ok框用装备
道具类别 | StdMode | 装备位 | 装备位道具名称变量 | 装备位道具名称改名变量 | 装备位道具强化值
ok框用装备1 | 124 | 60 | <$equipField60> | <$g_equipField60> | <$upgradeCount60>
ok框用装备2 | 125 | 61 | <$equipField61> | <$g_equipField61> | <$upgradeCount61>
ok框用装备3 | 126 | 62 | <$equipField62> | <$g_equipField62> | <$upgradeCount62>
ok框用装备4 | 127 | 63 | <$equipField63> | <$g_equipField63> | <$upgradeCount63>
ok框用装备5 | 128 | 64 | <$equipField64> | <$g_equipField64> | <$upgradeCount64>
ok框用装备6 | 129 | 65 | <$equipField65> | <$g_equipField65> | <$upgradeCount65>
ok框用装备7 | 130 | 66 | <$equipField66> | <$g_equipField66> | <$upgradeCount66>
ok框用装备8 | 131 | 67 | <$equipField67> | <$g_equipField67> | <$upgradeCount67>
ok框用装备9 | 132 | 68 | <$equipField68> | <$g_equipField68> | <$upgradeCount68>
ok框用装备10 | 133 | 69 | <$equipField69> | <$g_equipField69> | <$upgradeCount69>
ok框用装备11 | 134 | 70 | <$equipField70> | <$g_equipField70> | <$upgradeCount70>
ok框用装备12 | 135 | 71 | <$equipField71> | <$g_equipField71> | <$upgradeCount71>
ok框用装备13 | 136 | 72 | <$equipField72> | <$g_equipField72> | <$upgradeCount72>
ok框用装备14 | 137 | 73 | <$equipField73> | <$g_equipField73> | <$upgradeCount73>
ok框用装备15 | 138 | 74 | <$equipField74> | <$g_equipField74> | <$upgradeCount74>
ok框用装备16 | 139 | 75 | <$equipField75> | <$g_equipField75> | <$upgradeCount75>
ok框用装备17 | 140 | 76 | <$equipField76> | <$g_equipField76> | <$upgradeCount76>
ok框用装备18 | 141 | 77 | <$equipField77> | <$g_equipField77> | <$upgradeCount77>
ok框用装备19 | 142 | 78 | <$equipField78> | <$g_equipField78> | <$upgradeCount78>
ok框用装备20 | 143 | 79 | <$equipField79> | <$g_equipField79> | <$upgradeCount79>
ok框用装备21 | 144 | 80 | <$equipField80> | <$g_equipField80> | <$upgradeCount80>
ok框用装备22 | 145 | 81 | <$equipField81> | <$g_equipField81> | <$upgradeCount81>
ok框用装备23 | 146 | 82 | <$equipField82> | <$g_equipField82> | <$upgradeCount82>
ok框用装备24 | 147 | 83 | <$equipField83> | <$g_equipField83> | <$upgradeCount83>

?

支持配置翅膀模型的装备位id
装备位id | 说明
0 | 衣服
2 | 勋章 、照明
12 | 宝石-神石
14 | 军鼓
15 | 马牌
16 | 盾牌
24 | 挂饰1
25 | 挂饰2


官方主页

TJ引擎


TJ引擎使用GM编辑器启动服务器服务器启动不起来

GM编辑器启动服务器启动不起来的解决方法

常见的服务器启动不起来的原因
 1.DB数据表表导出错误，先检查下DB表导出的.CSV是否有数据

 2.setup文件中缺少字段，一些老的版本中会缺少一些数据（解决方法-联系qq群726565751）

 3.启动不起来联系：QQ群726565751


官方主页

TJ引擎怪物移动速度和主角移动速度的调整

1.怪物移动速度
 1.TJ引擎使用了自己的移动速度算法，涉及到移动速度的地方都需要进行修改

 2.调整方式：Monster.csv中的SPEED列，支持浮点值（具体速度建议在0.5-3之间，可根据版本不同自行进行调整（默认的主角移动速度为3））
 3.不允许移动的怪物这一列写0

2.主角移动速度
 1.TJ引擎默认的主角移动速度为3

 2.可使用changespeed命令对主角移动速度进行修改


官方主页

TJ引擎为什么有些技能没有？

TJ引擎目前支持的技能：（没有支持的技能是无法使用的）
 治愈术
 基本剑法
 施毒术
 攻杀剑法
 抗拒火环
 极光电影
 雷电术
 刺杀剑术
 灵魂火符
 神圣战甲术
 召唤骷髅
 火墙
 半月弯刀
 烈火剑法
 野蛮冲撞
 召唤神兽
 魔法盾
 冰咆哮
 群体雷电术
 群体施毒术
 飓风破
 召唤月灵
 逐日剑法
 噬血术
 流星火雨
 开天斩
 分身术
 召唤圣兽
 十步一杀
 裂神符
 死亡之眼
 冰霜群雨


官方主页

TJ引擎GM命令说明

如何使用GM命令？
 1.GM测试服在聊天框中输入 /tm 发送后进入GM模式，可使用GM命令

 2.也可在GM编辑器中：查看-查看信息列表一-管理员列表；将角色添加到管理员列表中，该角色即进入GM模式

 3.GM命令的使用方法：在聊天框中输入GM命令点击发送即可

TJ引擎提供的常用GM命令：
 制造道具：item 道具名称 数量

 加经验：exp 数值

 改变等级：level 等级

 传送地图：gomap 地图编号

 召唤怪物：mob 怪物名称

 增加货币：货币代码 数量

 增加属性：addatt 属性代码（6攻击，11血） 数值


官方主页

TJ引擎如何设置自动拾取

1.自动拾取在tejieconfig中配置
 1.道具类物品的自动拾取：在[PickingType]中配置对应的道具颜色即可，自动拾取时会自动拾取配置了对应颜色（items表中Color）

 2.装备类道具需要先在[pickitem]中定义类型，定义类型后在GM编辑工具查看信息列表二中的内挂捡取分页中将装备放入对应的类型即可


TJ引擎刷怪脚本中控制怪物大小、视野、属性倍率

TJ引擎在刷怪脚本中做了一些字段的扩展

说明：
 1.MonGen中扩展了四个字段，可控制怪物视野范围、属性倍率、模型大小 、怪物爆率

 字段解释：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~0 255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1) 怪物视野（不写为默认视野，支持浮点值） 属性倍率（不写则为1，支持浮点值） 模型大小（默认为1，支持浮点值1.1就是1.1倍） 怪物爆率（100为1倍）

TJ引擎对MONGENEX命令的扩展

说明：

1.MONGENEX中扩展了四个字段，可控制怪物视野范围、属性倍率、模型大小 、怪物爆率

 字段解释：地图文件名称 X Y 怪物名称 范围 数量 是否内功怪物(0否,1是) 名称颜色(0~255) 国家ID (属于哪个国家的怪物，没有可以为空) 同一个国家玩家是否可攻击怪怪物(0不可以,1可以) 最后2个参数是国家怪物设置，如果没有可以留空 怪物视野（不写为默认视野，支持浮点值） 属性倍率（不写则为1，支持浮点值） 模型大小（默认为1，支持浮点值1.1就是1.1倍） 怪物爆率（100为1倍）


官方主页

TJ引擎人形怪设置

TJ引擎支持GOM引擎人形怪的设置，只是需要在Monster中将对应的怪物设置成人形怪
 Monster.csv中Appr列写1999为男主角模型2000为女主角模型
 配置后，会读取MonUseItems下的配置，该怪会拥有配置的装备和技能（这里就跟GOM引擎一样了）


TJ引擎特有功能-新手引导相关命令

新手引导相关命令

主界面快捷键部分UI资源名称（定位引导箭头）：

角色：main_role

背包：lt_beibao_bth

技能：jinengxinxi_01

行会：hanghuixinxi_01

商店：shangdiananniu

在NPC名字上方出现指引箭头并出现文字提示：

功能: 在NPC名字上方出现指引箭头并出现文字提示
格式: NPCGUIDEARROW NPC名称 提示文字内容
说明: 可在指定NPC头顶上出现指引箭头并出现提示文字

[@PlayLevelUp]
#IF
CHECKLEVELEX = 60
#ACT
NPCGUIDEARROW 【初级地图】 先在初级地图打一身初级装备\然后就可以去后面的地图进行挑战了！

功能: 删除NPC头顶上的指引箭头与文字
格式: DELETENPCGUIDEARROW NPC名称
说明: 可删除指定NPC头顶上出现的指引箭头

[@main]
#if
#ACT
DELETENPCGUIDEARROW 【初级地图】

在OK框中的指定文字按钮上出现指引箭头并出现文字提示：
功能: 在OK框中的指定文字按钮上出现指引箭头并出现文字提示
格式: INTERFACEARROW 按钮名称 位置（1上，2下，3左，4右） 提示文字
说明: 此命令需要使用在NPC脚本中，按钮名称为NPC脚本中定义的文字按钮

[@main]
#IF
#ACT
#SAY
<>\ <> 　　　　　 <霸梦诀,独家第③季寻仙篇./AUTOCOLOR=253>\
<━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━/AUTOCOLOR=249>\
<※等级修炼※/SCOLOR=250>：<免费泡点地图每秒388W经验，打BOSS升级超级快。>\
<※游戏玩法※/SCOLOR=250>：<本服转生和封神相当重要，赠送强悍属性，封神章>\
<更是杀人打宝的装逼利器！必须搞起！>\
<※装备介绍※/SCOLOR=250>：<任何装备都没有合成，不管是面巾还是盾牌，护符，>\
<武器，都没有合成，全部靠怪爆出。>\
<※重要提示※/SCOLOR=250>：<介绍再多不如自己摸索，首杀BOSS奖励元宝充值装备>\
<超级丰富，名额有限先到先得>\
<开启/@1> \
<每秒可获得388W经验,150级以上无法获得经验！/SCOLOR=69> <边打怪边升级/SCOLOR=224> \
#IF
#ACT
INTERFACEARROW 开启/@1 4 点击按钮开启之旅吧！

在主界面上弹出指引箭头指向主界面固定按钮并出现文字说明：
功能: 在主界面上弹出指引箭头指向主界面固定按钮并出现文字说明
格式: MAININTERFACEARROW 按钮名称 位置（1上，2下，3左，4右） 提示文字
说明: 按钮名称为使用的资源图片的名称

[@PlayLevelUp]
#IF
CHECKLEVELEX = 84
#ACT
MAININTERFACEARROW main_recycle 2 多余的装备可以通过在线回收回收掉\可以获得大量元宝/逆兲币/充值点！


官方主页

TJ引擎扩展了获取OK框中获取装备属性总属性值的全局变量：

TJ引擎扩展了获取OK框中获取装备属性总属性值的全局变量：
<$BOXITEM[X].HPATTRIBUTE> 当前自定义OK框中的物品HP字段附加的属性总值
<$BOXITEM[X].MPATTRIBUTE> 当前自定义OK框中的物品MP字段附加的属性总值
<$BOXITEM[X].LACATTRIBUTE> 当前自定义OK框中的物品的防御下限字段附加的属性总值
<$BOXITEM[X].HACATTRIBUTE> 当前自定义OK框中的物品的防御上限字段附加的属性总值
<$BOXITEM[X].LMACATTRIBUTE> 当前自定义OK框中的物品的魔防下限字段附加的属性总值
<$BOXITEM[X].HMACATTRIBUTE> 当前自定义OK框中的物品的魔防上限字段附加的属性总值
<$BOXITEM[X].LDCATTRIBUTE> 当前自定义OK框中的物品的攻击下限字段附加的属性总值
<$BOXITEM[X].HDCATTRIBUTE> 当前自定义OK框中的物品的攻击上限字段附加的属性总值
<$BOXITEM[X].LMCATTRIBUTE> 当前自定义OK框中的物品的魔法下限字段附加的属性总值
<$BOXITEM[X].HMCATTRIBUTE> 当前自定义OK框中的物品的魔法上限字段附加的属性总值
<$BOXITEM[X].LSCATTRIBUTE> 当前自定义OK框中的物品的道术下限字段附加的属性总值
<$BOXITEM[X].HSCATTRIBUTE> 当前自定义OK框中的物品的道术上限字段附加的属性总值


TJ引擎自定义任务功能（重点）

自定义任务相关命令

接取或完成任务触发：
功能: 接取或者完成某个任务时触发
格式: [@PICKUPTASK任务编号]
说明: 写在QFunction-0脚本中，当接取对应任务时触发

格式: [@FINISHTHETASK任务编号]
说明: 写在QFunction-0脚本中，当完成对应任务时触发

接取和完成任务命令：
功能: 接任务命令和完成任务命令
格式: PICKUPTASK 参数1 参数2 参数3 参数4
说明:参数1-任务类型（1主线2日常3支线） 参数2-任务编号（自定义） 参数3-任务名称 参数4-任务目标（支持变量支持颜色）

格式: FINISHTHETASK 任务编号
说明:完成指定编号的任务

点击主界面上快捷任务栏中的任务触发：
功能: 点击主界面任务栏中的任务触发到对应的@块
格式: [@TASK任务编号]
说明:写在QFunction-0脚本中

任务状态检测命令：
功能: 检测是否接取过某个任务：
格式: CHECKPICKUPTASK 任务编号
说明:检测对应编号的任务是否接取过，如果接取过则检测通过

功能: 检测是否在任务进行中：
格式: CHECKTASKINPROGRESS 任务编号
说明:检测对应编号的任务是否在进行中，如果在进行中则检测通过

功能: 检测是否完成了某个任务：
格式: CHECKFINISHTHETASK 任务编号
说明:检测对应编号的任务是否已经完成，如果已完成则检测通过

将任务状态同步至界面中：
功能: 当任务进度发生变化时，这时候需要这个命令来同步界面显示状态：
格式: SYNCHRONIZATIONTASKSTATUS 参数1 参数2 参数3
说明:参数1-任务编号 参数2-任务名称 参数3-任务目标


TJ引擎安卓打包工具使用说明（重点）

TJ引擎更新记录

2021.1.7更新内容
 新功能：
 1.角色头顶血量显示，当血量超过亿后，显示格式为：9999E9999W3002
 2.基础OK框底图更换，更换了新的美术资源
 3.增加了设置技能界面，在技能界面打开
 4.使用BINDINGSTATE命令打出的绑定道具允许丢弃，丢弃消失
 5.GETCALLMOB 使宠物叛变，叛变后怪物走正常的掉落
 6.实现了命令：SetItemBind 和 CheckItemBind
 7.OpenItemBoxEX 命令支持了OK框的所有命令
 8.诱惑之光、抗拒火环、气功波推开的中立怪（如：鸡、鹿），中立怪将不会主动攻击玩家
 9.增加一个新的命令： 带背包数量检测的itemshow
 10.增加技能键位设置功能，增加主界面八键位模式
 11.增加了一个新的命令：
 12. ChangeModeEx 命令中的时间参数支持了浮点值
 13. 增加了背包四页模式，可配置开启四页背包空间-详细配置见

 修复BUG：
 1.摆摊界面和背包界面有叠加的问题
 2.自动战斗中的特效显示没有做适配的问题
 3.交易窗口-交易锁定后，道具或装备仍然可以进行拖动，导致出现交易窗口上的道具显示消失的问题
 4.角色界面上的分页---属性界面的文字和时装界面的文字写反了--按钮文字都错乱了的问题
 5.PLAYDICE 3 这个命令调取的筛子动画没有了的问题
 6.绑定的装备/道具TIPS显示错误的问题
 7.行会招募信息在聊天界面中显示是空的问题
 8.装备上有诅咒属性，但是属性界面中没有显示出来的问题
 9.道具表中叠加道具的重量计算现的相关问题
 10.GETMAPGATE 命令取出的数据不对的问题
 11.THROWITEM 命令参数中范围参数不好用的问题
 12.通用引导箭头会被OK框裁切的问题

 优化内容G：
 1.主界面上角色按钮和背包按钮优化，当角色界面和背包界面打开的情况下再次点击是关闭对应界面
 2.当丢弃丢弃摧毁的道具时给了一个通用的二级确认弹窗

 资源编辑器：
 1.地图列表、NPC列表、怪物列表、物品列表增加按钮：一键筛选出没有配置的列表
 2.资源编辑器涉及到地图编辑的时候显示出不可行走区域
2020.12.24更新内容
 新功能：
 1.擒龙手技能成功抓取目标后需要增加1秒的麻痹
 2.顶戴花铃的显示位置规则进行下修改，以前是会自动向上显示，修改为每个位置只显示对应位置的顶戴花铃，如果一个位置有多个则显示最后一个
 3.自动战斗状态在主界面显示出了自动战斗特效
 4.tejieconfig中增加一个配置控制初始的角色移动速度，详细见tejieconfig配置
 5.地图上的传送门，需要显示在地图界面NPC列表中
 6.<$KILLMONEXPRATE> 变量实现
 7.双龙斩，飓风破，嗜血术技能在tejieconfig中增加CD时间配置（详细见tejieconfig配置）
 8.脚本里给道具如果背包满了现在是直接丢到了地上，修改为通过邮件发给角色
 9.隐身技能释放后角色释放技能不取消隐身效果

 修复BUG：
 1.怪物名字有特殊符号显示不出顶戴花翎的问题
 2.SkillWaitTimes51 字段是控制群体施毒术的CD，现在对施毒术也起作用的问题
 3.怪物顶戴花翎会出现一个黑框的问题
 4.顶戴花铃，每次点击一下角色顶戴花铃的位置就会往下移的问题
 5.设置-保护里放入药品后显示的数量不对的问题
 6.GETRANDOMLINETEXT 命令 路径中有变量不支持的问题
 7.绑定装备TIPS显示错误问题
 8.野蛮冲撞技能在GM编辑器中开启了使目标麻痹，这个数据没有存上的问题
 9.OK框拼接其他脚本导致@块无法执行的问题
 10. OpenItemBoxEx打开的界面坏掉的问题
 11. 精神力战法和神圣战甲术无效果的问题
 12. 诱惑之光技能GM后台配置诱惑数量无效的问题
 13. ChangeModeEx 增加麻痹 使用魔法攻击无效的问题
 14. 切换版本号，主界面上的按钮会带到下一个版本的问题
 15. 道士技能召唤神兽召唤出的宝宝不显示宝宝名字
 16. 修复几张地图怪物会刷到阻挡区里的问题
 17. SendCenterMsg命令相关倒计时问题
 18. 怪物表中配置的MP值对宝宝不生效的问题
 19. 使用抗拒火环技能推开人物，人物释放技能出现错误提示

 优化内容G：
 1.自定义怪物施放技能配置了远程技能则按照远程技能的攻击距离进行计算
 2.主界面左上角战力显示图片进行了放大
 3.登陆假人时优先登陆已创建的假人，不再继续创建新的假人了
 4.优化了寻路算，解决部分地图寻路卡住的问题
 5.ELSEACT写到ACT前面解析错误问题

 资源编辑器：
 1.新增了一套圣诞时装
 2.新增了一批动态称号
 3.新增了一批电脑版原版地图

2020.12.17更新内容
 新功能：
 1.CHECKSKILL命令支持了变量
 2.设置-挂机-战斗-道士辅助中增加 自动群体施毒术（默认是关闭的）
 3.tejieconfig中增加一个配置：是否在血条上方显示出血量值（详细见tejieconfig配置）
 4.tejieconfig中增加一个配置控制目标头像显示血量的具体值还是百分比值（详细见tejieconfig配置）
 5.增加怪物自定义技能功能，在选项-怪物-自定义怪物中设置
 6.SetIcon命令最后增加了一个参数来调整偏移，SetIcon 位置(0-9) 图片名称 是否只有自己看见（0=所有人都可以看见 1=仅仅自己可以看见） 微调上下偏移（正值往上，负值向下）
 7.实现了命令：CHECKSLAVENAME

 修复BUG：
 1.<$STR(G<$STR(N$首杀奖励_全局变量_名额定位)>)>这种格式的解析问题
 2.OK框里的ICON特效偏移问题
 3.CHANGEMODEEX命令设定了吸血几率不好用的问题
 4.tejieconfig中[mallCurrency]节点配置不生效的问题
 5.沙皇宫使用野蛮冲撞有时候会冲到阻挡区里的问题
 6.CHECKNAMELIST 路径中有变量的话 取不出值的问题
 7.解决安卓手机微信充值闪退问题

 资源编辑器：
 1.资源编辑中增加了：可调用动态图片，增加了一批动态顶戴花铃资源
 2.增加了10把新的武器
 3.增加时装：孙悟空（衣服和背饰是分开的）
 4.又增加了一批电脑版地图资源

2020.12.10更新内容
 新功能：
 1.实现了命令：GETCALLMOB
 2.更新了游戏主界面-改成了血球模式的主界面
 3.tejieconfig 中增加一个配置控制是否显示自动挂机按钮(详细配置见tejieconfig配置)
 4.tejieconfig中增加两个配置来控制 物理伤害减少 和 魔法伤害减少 属性的最大值
 5.宝宝叛变立即死亡
 6.实现了命令：GOTOLABEL

 优化内容：
 1.优化传送地图取坐标的精度
 2.首次加载完NPC后，再次传送不用重新加载了
 3.增加了自动拾取的范围，以适应远程职业
 4.当复活效果触发时和复活效果CD结束时给个通用的消息提示
 5.设置-战斗中增加了自动召唤圣兽和自动召唤月灵
 6.优化了刷怪脚本，兼容有一行错误导致不刷怪的情况
 7.与npc对话弹出的OK框，当离开NPC一定距离后自动关闭

 修复BUG：
 1.机器人脚本中写变量+重启会自动+1的问题
 2.报名参加沙巴克提示活动未开放的问题
 3.修复装备名字中有特殊符号回收不了的问题
 4.怪物中毒0血不死亡的问题
 5.修复开天斩技能伤害系数无效的问题
 6.修复沙巴克称号有时候显示异常的问题
 7.毒素武器会将绿毒覆盖的问题，现在修改为了叠加
 8.修正了角色死亡后文字称号显示异常的问题
 9.changeHumAbility 1 - 500 不生效的问题
 10.使用次数限制的物品，所有需要触发到QF里的，双击扣次数会扣两次的问题
 11.冰雪归来版本 生肖套装的效果10件触发、11件触发、12件触发，现在只有12件触发了的问题
 12.快捷装备装备的时候，会出现道具不存在的问题
 13.野蛮冲撞会冲到阻挡区外的问题
 14.有固定消息的装备tips显示错误的问题

 资源编辑器：
 1.资源编辑增加了取消装备翅膀的操作
 2.增加了200张地图资源，资源名与电脑版一致
 3.增加了5把新的武器

2020.12.3更新内容
 新功能：
 1.道具TIPS中显示出了道具的图标
 2.增加了一个命令控制角色不管丢弃什么东西都消失，命令格式：DISCARDLOSTSTATE 参数1；命令说明：参数1（0为不开启，1为开启）处于开启这个状态下的角色不管丢弃什么道具都会消失（默认为不开启状态）
 3.摆摊可出售的货币扩展至了4种，在tejieconfig中配置即可
 4.增加一个命令：禁止聊天和解除禁止聊天；FORBIDDENWORDS 参数1和RELIEVEFORBIDDENWORDS（详细说明见-TJ引擎专有命令）
 5.增加一个命令：可控制角色打出的道具都为绑定道具；BINDINGSTATE 参数1（详细说明见-TJ引擎专有命令）
 6.tejieconfig中增加一项配置来控制这个版本是否开启交易（详细说明见-tejieconfig配置）
 7.实现了命令：ChangeSlavePowerRate
 8.支持了国家相关的命令

 9.实现了命令：ChangeSlavePowerRate
 10.回收命令支持了变量-导致GM023回收不了装备的问题
 11.设置-保护中增加了新功能，当有复活效果时可以不执行保护
 12.实现了<$SUCKDAMAGE>变量与<$SUCKDAMAGEPOINT>变量

 优化内容：
 1.召唤出的宝宝 如果怪物表中名字最后有数字则客户端显示时不要把数字显示出来
 2.邮件增加了删除功能

 3.优化了宝宝的移动，减少宝宝被卡住的情况
 4.资源编辑器编辑安全区支持了浮点值
 5.优化了NPC的名字位置
 6.优化了角色名字与称号之间会出现空行的问题
 7.GM编辑器中道具备注可直接在编辑器中进行编辑了
 7.优化了假人走路滑步的问题

 修复BUG：
 1.changeslaveabil 命令没有支持变量，现在支持了
 2.renewlevel 命令没有支持变量，现在支持了
 3.changeslaveabil 命令没有支持变量，现在支持了
 4.changeslaveattackhumpowerrate 命令没有支持变量，现在支持了
 5.佩戴隐身装备怪物不反击的问题
 6.去除了系统每天自动开放沙巴克，现在沙巴克的开启都需要命令开启或者报名开启

 7.修复部分版本读取ICON图片资源报错的问题
 8.道具表中配置装备特殊效果161不生效的问题修正了

 9.QF脚本--[@PickUpitemEx]中 CHECKNEWITEMVALUE 命令和 CHECKITEMADDVALUE 命令 不生效的问题
 10.群体施毒技能给怪上毒后，隔位刺杀打怪，怪物不还手，只有近身才还手的问题
 11.#ACT、#ELSESAY这样写逻辑不执行的问题

2020.11.26更新内容
 新功能：
 1.TakeBagItem 命令支持了叠加物品的回收
 2.绑定的道具死亡后不允许爆出
 3.死亡邮件内容里显示出死亡的地图
 4.角色属性界面中增加了属性：增加怪物爆率
 5.增加邮件红点和行会红点
 6.增加新功能：当获得比自己身上穿戴的装备好时的装备时弹出自动穿戴小界面；在tejieconfig中增加配置：openautomaticwear=1
 7.增加新的功能顶戴花铃，具体使用方法请看顶戴花铃的使用说明

 优化内容：
 1.地图界面右侧支持了换行
 2.道具使用失败的提示从弹窗提示修改为飘字提示

 修复BUG：
 1.死亡邮件有时候会出现没有找到指定邮件的问题
 2.角色死亡邮件，当角色被神兽杀死时邮件里没有显示出被谁击杀，被神兽击杀应该显示出角色名称的问题
 3.道具表中配置的增加目标爆率应该只对杀人生效，KILLMONBURSTRATE增加的爆率应该只对杀怪生效
 4.tejieconfig中[setStallCurrency] 设置了摆摊可交易货币不好用的问题
 5.GETRANDOMLINETEXT 命令 取不出来第一行的值的问题
 6.CHECKSOCKETABLEITEM 命令获取的宝石IDX没有+1的问题
 7.playmodel 命令会挡住按钮的问题
 8.法师没有默认雷电术为挂机单体技能的问题
 9.CHECKNEWITEMVALUE 命令 判断元素属性 只需要判断使用命令增加的属性 模板表中的元素属性不参与计算
 10.宝石类道具装备对比箭头错误的问题
 11.假人执行不了AUTOGOTOXY 命令的问题
 12.ADDGUILDMEMBER和ADDGUILD命令 假人无效的问题
 13.角色转职后导致强化技能等级丢失的问题

 资源编辑器：
 1.增加了一批新的怪物、新的地图和新的时装

 安卓打包固定版本号工具：
 1.开放了固定版本号工具：可自定义游戏名称、图标、开始游戏底图、LOADING图

2020.11.19更新内容
 新功能：
 1.usebonuspoint 支持了参数中使用变量
 2.实现了OPENUPGRADEDLG命令，解决点击无效问题
 3.GAMEGIRD - <$str(s$para2)> 对数字进行兼容 只要是纯数字就可以执行
 4.增加功能：套装技能伤害增加百分功能和防御百分比功能
 5.怪物表中Race列为51/52时怪物为非主动攻击怪，受到攻击才会反击；cooleye 反隐身怪的反隐身距离100为反隐身
 6.召唤出捡物精灵后角色通过复活效果复活后捡物宠物会死掉，这个应该不会死掉才对（现在不会死了）
 7.增加一个新的命令将道具放入主界面快捷栏；命令：PUTINSHORTCUT 参数1 参数2 说明：参数1：道具名称 参数2：快捷栏位置ID（1-4）(
 8.玩家死亡会自动收到一封邮件，说明死亡原因、死亡时间、掉落物品（1-4）
 9.GM运营后台增加版本推荐功能，在版本列表中进行设置
 10.支持了2DNPC、2D光柱
 11.在游戏运营后台每个服务器处增加一个标识，增加系统变量<$SERVERBURST> 可调用到这个变量，可在脚本中使用这个变量来控制对应服务器的一些定制功能（重点）

 优化内容：
 1.GM编辑工具兼容一些会出现报错的格式
 2.addtextlistex ..\testkist.txt <$USERNANE> 0 写入文本指定行，会覆盖原有的行。。正常应该是原有的行往下移动
 3. 摆摊出售道具或装备，他人点击查看无Tips装备或道具显示信息内容的问题
 4. 用户交易，A与B交易窗口显示无法查看对方放置装备的Tips信息内容的问题
 5. 属性点功能增加了一键加点

 修复BUG：
 1.从仓库取出叠加物品会消失的问题
 2.自动拾取有时候会卡住不拾取的问题
 3.MOV N$LSJG <$str(s$para2)> 无法赋值的问题
 4.角色删除了但是在排行榜中还能看到这个角色
 5.人形怪在特殊情况下不打人的问题
 6.一个OK框中有多个可放置道具框时特殊情况会出现复制道具的问题

 资源编辑器：
 1.资源编辑器，编辑NPC名字一样无法编辑的问题
 2.增加了一批新的NPC资源

2020.10.29更新内容
 新功能：
 1.增加生肖装备死亡掉落功能，在游戏参数、人物死亡、首饰盒中进行设置
 2.增加一个命令，删除自己的捡物宝宝 命令为：CLEARRECALLJINFLING
 3.UserCmds.txt 脚本功能实现
 4.takeonitem 和 takeoffitem 命令支持了生肖装备
5.tejieconfig中增加配置是否开启排行榜功能；OPENRANKINGLIST=1 （0为不开启，1为开启）
6.道具表中给装备增加的元素属性与脚本中增加的元素属性拆分开存储
7.仓库存取可叠加道具增加了选择数量功能
8.CHECKDRILLHOLECOUNT 命令支持了生肖装备
 9.tejieconfig中增加了一个配置，控制自动复活的CD时间（AutomaticResurrection=500）单位秒

 优化内容：
 1.脚本中将角色等级降低到1级以下时按照1级计算，角色最低等级为1级
 2.自动反击：当前目标为其他可被攻击角色时，这时候再受到其他角色攻击不需要切换目标

 修复BUG：
 1.GM运营后台通过绑定的手机号查询查询不到对方的充值信息且无法对角色进行操作的问题
 2.等级超过100万级血量会变成负数的问题
 3.setstringblank 增加长度还是对不齐的问题
 4.<$BOXITEM[X].PROGRESSBAR1.POSITION> 当前自定义OK框中的物品 第一个进度条的当前进度值 这个命令的默认值错误 默认值应该为0
5.changehumnewvalue 命令 减属性 减了10 实际给扣除了20
6.<$BOXITEM[X].PROGRESSBAR1.OPEN> 当前自定义OK框中的物品 第一个进度条是否开启 0没有开启 1开启 这个命令默认值错误 默认应该是0 没有开启现在是-1

2020.10.23更新内容
 新功能：
 1.增加一个清除分身的命令 CLEARRecallSelf 删除自己的分身
 2.电脑版本运行的时候在桌面生成快捷方式
 3.自动挂机三职业做成了统一的技能释放列表，三职业自动挂机技能都可释放
 4.称号去除了道具表中stdom类型的限制，任何类型的都可作为称号使用
 5.SetNewItemValue 命令支持了拾取触发
 6.升级增加属性算法引擎默认算法和自定义等级算法功能（SETUP！中UseLevelAbilitys 字段控制采用哪种模式 =0 使用引擎默认 =1使用自定义）
 7.RECALLJINFLING 名称 移动速度 捡取范围 捡取时间 捡取距离 跟随距离 持续时间 模型大小（0.1为0.1倍，2为2倍，1为正常大小） （这个命令最后增加一个参数）
 8.tejieconfig中增加两个配置控制装备TIPS名字显示规则与装备TIPS上置顶消息的显示（详细见tejieconfig）
 9.增加玩家战斗力常量：<$powervalue>
 10.增加配置吃药时间间隔 单位：毫秒（tejieconfig中增加配置使用CD时间，单位毫秒，不写的话使用默认CD时间）详细见tejieconfig
 11.支持了变量后加变量的脚本格式：MOVT<$str(s$t11)> <$str(s$值)>

 GM编辑器：
 1.修复部分报错问题

 优化内容：
 1.角色和假人传送地图（使用随机、回城）角色朝向的方向设置为随机方向
 2.拾取道具-通过拾取按钮拾取道具不需要受是否勾选自动拾取影响直接可拾取
 3.打敌对目标现在的掉血上限是21E，现在去除了这个限制
 4.tejieconfig中的[gemtips]没有支持文字颜色，现在支持了
 5.充值配置中配置了相同金额然后就不好用了，现在支持了
 6.自定义技能触发脚本优化，自定义的技能同样触发QF里的技能触发@块
 7.从仓库中取出道具不在判断背包负重，超过负重也可取出

 修复BUG：
 1.changehumnewvalue 命令的参数没有支持变量，现在支持了
 2.人形怪佩戴复活戒指复活后会受到MP值影响达到受伤害上限的问题
 3.叠加的道具使用后会出现一个获得道具提示消息的问题
 4.SHOWPROGRESSBARDLG 时间(秒) 触发字段 提示信息 有动作是否中断(0不中断,1中断) 中断触发字段 这个命令不好用了的问题
 5.CHECKCUSTOMITEMPROGRESSBARPERCENT命令应该是检测进度条百分比现在检测的是具体的值的问题
 6.CheckSuckDamage 这个命令没有支持变量的问题

2020.10.16更新内容
 新功能：
 1.[@Revival]实现
 2.扩展参数：REALIVE 参数1 参数2（参数1：复活血量；参数2：复活方式（1百分比血量，0具体血量值））
 3.OK框上的按钮点击增加一个统一的0.3秒CD时间，点击太快提示：“你点击的太快了”
 4.怪物表中MP值是所受伤害上限，不受脚本中减血影响

 GM开服网站：
 1.游客账号绑定手机号之后可通过手机账号对角色进行修改/封号

 GM编辑器：
 1.修复TIPS后台报错问题

 资源编辑器：
 1.新增六张新地图

 优化内容：
 1.装备TIPS当有文字超出tips界面时点击关闭不了tips
 2.取消了自定义输入框中字符长度限制
 3.客户端设置中增加了是否显示光柱开关
 4.好友聊天卡顿-优化

 修复BUG：
 1.仓库卡顿问题
 2.CHANGEHUMABILITY 11 = 500 65535 用定时器执行时间每次都不固定血量和战斗力来回跳的问题
 3.hour和MIN 命令检测无效的问题
 4.65类型的道具使用数据库代码添加了复活效果没有生效的问题
 5.摆摊掉线后重新上线摆摊的道具消失的问题
 6.RecallSelf 命令不好用的问题
 7.设置自动保护，血量掉到指定百分比以下只会吃一个药，然后每受到一次伤害吃一个（应该是吃到指定百分比以上）
 8.称号数量多的时候会导致称号显示不出来的问题
 9.怪物多次中毒怪物会回满血的问题
 10.<$HITSPD>攻速变量不生效的问题
 11.倚天劈地技能没有走CD时间
 12.GIVE命令 GIVE <$BOXITEM[1].GNAME3> 1 给不了东西的问题
 13.装备上附带攻速重新上线后不生效的问题

2020.8.27更新内容
 新功能：
 1.在tejieconfig中增加了配置控制任务栏的显示
 2. 主界面中增加了一个快捷栏使用位置
 3. 战斗设置中增加了：自动逐日剑法、自动分身
 4. 开放自动拾取宝宝功能，命令为：RECALLJINFLING 名称 移动速度 捡取范围 捡取时间 捡取距离 跟随距离 持续时间
 5. tejieconfig增加配置是否显示外显时装 命令格式：FashionShow=1 显示 =0不显示 默认显示
 6. 当道具stdmode=31 支持可以改名 命令格式 ChangeItemNameEx -1 名字
 7. 套装触发 [@GroupItemOn]

 GM后台：
 1.GM后台查看角色信息界面可直接修改货币
 2.后台增加，账号信息查询加一个删除角色原因（测试删除，gm删除，玩家自己删除）
3.账号信息查询界面针对每个角色增加了角色信息查询按钮
3.角色信息查询中显示出了角色的详细属性

修复BUG：
 1.OK框中的道具，如果有其他界面打开导致道具消失的问题
 2.玩家和NPC重叠 点不了NPC的问题
3.PC端好友聊天输入栏和发送按钮位置偏下
4.@goto太多卡顿的问题
5.改变人物当前模式：ChangeModeEx 20 65535 100 8 吸血不是百分比的问题
6.有ICON特效的装备放入仓库后仓库中就没有特效了
7.好友聊天里的消息没有按照正常顺序排序
8.GiveStateItem 命令给绑定道具导致其他道具绑定的问题

2020.8.21更新内容
 新功能：
 1.增加自定义任务功能（在TJ引擎任务里见详细使用方法）
 2. ChangeItemNameEx改变道具名字 命令格式：ChangeItemNameEx -1 名字
 3. 电脑版本增加技能快捷键功能
 4. DZItemDescList 脚本 显示在顶部
 5. 增加自定义技能功能
 GM后台：
 1.后台增加了功能清理排行榜数据
 2.后台查询增加了模糊查询角色
3.可通过绑定的手机号查询用户信息
优化：
 1.挂机时如果对方防毒自动施放的时候就把毒给去掉
 新资源：
 1.增加了一批新的斗笠资源
 2.增加了两个翅膀资源

 修复BUG：
 1.行会/队伍申请】行会/队伍申请列表显示的职业与实际不符
 2.人形怪配置复活戒指，不复活，（人形怪跟玩家是一样的，配置的属性需要支持）

2020.8.12更新内容（注意：本次更新内容8.13日才会更新至正式服）
 新功能：
 1.GM后台：增加等级限制，多少级以下是不允许接收邮件

 修复BUG：
 1.站在安全区外面放技能打安全区的玩家和离线挂机的玩家掉血
 2.OPENMERCHANTBIGDLG一直显示关闭按钮，不能通过参数5控制是否显示的问题
 3.称号不显示重量
 4.修复神水修复装备显示问题
 5.物品规则，上线消失和禁止个人商店出售不好用

2020.8.10-8.11更新内容（注意：本次更新内容8.13日才会更新至正式服）
 新功能：
 1.monster表中race字段为112时 只攻击红名玩家
 2.增加一个配置：是否开启人形宝宝的攻速和移动速度跟主人一样(详细见tejieconfig)
 3.CheckItemAddValueEx 检测装备的附加属性总和(武器的诅咒不在计算范围之内)
 4.checkjob warrior 检测角色职业，支持变量
 5.增加配置：控制是否显示出怪物等级，获取的怪物表的Lvl字段(详细见tejieconfig)
 6.怪物表中Race列为51/52时怪物为非主动攻击怪，受到攻击才会反击
 7.RECALLMOB脚本召唤宝宝 增加宝宝大小，属性倍率两个参数
 8.怪物表中race字段功能实现 为82 毒液攻击（怪打人 人中毒） 为107 全屏攻击+麻痹+中毒
9.自定义技能功能（在GM编辑器工具中：查看信息列表二-自定义技能中配置）

修复BUG：
 1.摆摊】背包里的空白格子也可以拖动到摊位上
 2.玩家改名字之后，老的角色名还在排行榜上，需要清除掉
 3.将好友添加到黑名单，再移出黑名单，界面报错
 4.怪物血量配置超过21亿 打的时候直接从21亿血开始掉
 5.重复查看玩家信息 ，出现重影
 6.线上出现版本来回切换快捷按钮显示上一个版本的快捷按钮了
 7.同一个套装显示的tips不一样
 8.道具表need为 70 沙城城主才可以戴上 功能好用，tips没显示出来

2020.8.6正式服更新：
 更新说明：7.27-8.5号在测试服更新的内容到正式服务
 1.正式服用户会强制将客户端版本升级至1.3.0
 2.电脑版在正式服正式上线

2020.8.3-8.5更新内容（注意：本次更新内容8.6日才会更新至正式服（引擎底层做了比较大的升级））
 新功能：
 1.增加CHECKDAYRECHARGE命令，格式 CHECKDAYRECHARGE 检测符（><=） 金额(充值的RMB金额) （检测当天充值金额）
 2.增加CHECKLOGINCOUNT命令，格式 CHECKLOGINCOUNT 检测符（><=） 次数 （检测当天登陆次数）
 3.设置-战斗中增加功能被其他玩家攻击，自动反击攻击玩家，默认为开启
 4.gm工具增加配置禁止清理怪物列表，保存的脚本为 NoClearMonList.txt 作用：用于脚本命令clearmapmon 加入此列表的怪物，在使用此命令不会被清除掉
 5.增加法师技能诱惑之光
 6.tejieconfig中增加控制世界频道发言时间间隔；（详细配件见tejieconfig配置）

 优化：
 1.背包货币显示出了货币小图标

 修复BUG：
 1.装备穿戴需要转生等级，转生等级不够也能穿上的问题
 2.召唤的宝宝打自己的问题
 3.召等级太高就变成负数了的问题
 4.<$USERID> 人物登录帐号 获取的账号不对的问题

2020.7.31更新内容（注意：本次更新内容8.6日才会更新至正式服（引擎底层做了比较大的升级））
 新功能：
 1.电脑版增加右键移动功能
 2.电脑版接通了电脑版的充值
3.电脑版默认隐藏摇杆开启，默认视野范围为最大

优化：
1.优化彻地钉、龙影剑法、爆裂火焰特效效果

 修复BUG：
1.自动生成的传送阵特效方向错误问题

2020.7.27-7.30更新内容（注意：本次更新内容8.6日才会更新至正式服（引擎底层做了比较大的升级））注意：本次更新引擎升级至1.3.0，服务器做了迁移GM测试服清档，需要使用1.3.0的客户端包才能登陆
 新功能：
 1.增加检测战斗力命令，CHECKPOWER 检测符（><=） 数值
 2.增加命令：ACCOUNTBINDINGMOBILEPHONE 说明：登录的账号是否已经绑定手机 已经绑定返回真
3.增加命令：OPENTHEMOBILEPHONEBINDINGINTERFACE 说明：打开手机绑定界面
4.tejieconfig中增加配置，可控制初始给的攻速是否显示在属性界面中
 5.增加技能：火球术、大火球、纵横剑术、雷霆剑法、彻地钉、气功波、无极真气、双龙斩、隐身术、群体隐身术、群体治疗术、冰镰术、爆裂火焰
 6.开放电脑版客户端
 7.优化NPC模型，增加了一批新的NPC模型
 8.增加了6只基础怪物
 9.增加每天累计在线时间命令：<$DAYLOGINLONG> 每天24：00清0，单位分
 10.增加检查人物每天累计在线时长命令：CHECKDAYLOGINLONG (> < =) 支持变量操作的时间（单位分钟）
 11.【战士自动攻击配置】在战斗设置中增加设置，可开启和关闭自动攻击（默认是开启的）
12.初始攻速不显示在面板上在tejieconfig 中增加了配置是否显示
14.取消道具拾取，跟装备拾取合并到一起，都在FilterItemList.txt配置
15.MONGENEX 再增加四个参数，视野范围、属性倍率、模型大小，怪物爆率（当前怪物的所有道具的爆率）
16.刷怪脚本，再增加一个参数，怪物爆率（控制该怪物掉所有装备的爆率）
17.增加一个获取当前OK框中物品的某个属性存放在数据库中的值
18.禁止取下物品 添加的物品存放在DisableTakeOffList脚本中

优化：
1.资源编辑器中显示出了模型的编号
2.资源编辑器增加了拖拽滑动条
3.优化了NPC资源，将质量不好的NPC替换掉了（可在资源编辑器中查看）
4.优化战斗打击感，提升打击感效果
5.优化主角界面主角的动作
6.优化部分技能特效的美术表现效果
7.看其他角色施放护体神盾还会播放动作（护体神盾是被动技能不需要播放动作）
8.挂机拾取详细信息的装备显示颜色获取道具表中的颜色
9.快捷按钮优化：底图变成自适应，描述问题多长底图多大，，，描述文字加一个描边
10.gm工具配置套装 点击修改，左边会刷新，改成点击修改不需要刷新左边

 修复BUG：
1.消息提示：解析怪物名字后面带数字的，数字不要解析出来 例如：感染的僵尸1 感染的僵尸2 感染的僵尸3 123不要显示出来
2.查看其它玩家可以给其他玩家穿装备的问题
3.安全区范围内，改成人打人不掉血，人打怪掉血，怪打人掉血
4.查看其他玩家的生肖，显示的是自己装备的
5.Tejieconfig 里带の符号的装备没解析出来

2020.7.24针对正式服问题进行修复

 修复BUG：
1.人形怪攻击问题
2.从充值界面点击到绑定手机号界面无法获取验证码问题
3.Z002地图阻挡区错误问题
4.装备对比戒指手镯有时候不出对比的问题、生肖装备对比错误的问题
5.#define写法支持没有#include就生效的问题
6.装备附加技能挂机技能列表错误问题
7.增加新的打点信息，将从打开游戏到进入游戏的比例显示到GM后台
8.称号穿戴问题

2020.7.22更新内容（注意：7.20号-7.22号更新的内容7.23号会同步到正式服。客户端版本升级至1.2.0）
 新功能：
 1.增加新技能：狮子吼、寒冰掌
 2.GM运营后台增加查看账号密码功能和解除手机号绑定功能（23号同步正式服后可用）
 3.增大了NPC名字颜色的字号
 4.GM编辑工具增加禁止取消装备配置
 5.资源编辑器：增加怪物、NPC批量选择，批量修改坐标功能

 修复BUG：
1.优化游戏整体性能，解决卡顿、掉帧、发热、耗电量问题
2.优化OK框中文字的清晰度问题（只有新下载的客户端才有效果，热更的不生效）
3.【离线挂机】在安全区里的离线挂机角色还会被杀死的问题
4.【人形宠物、假人】人形宠和假人的移动速度、攻击速度、AI问题
5.I0S留海屏 在登陆界面没有适配的问题
6.有自定义货币配置的的版本回收消息错误的问题
7.次服务器重启捐献排行里的数据会被清空的问题

2020.7.21更新内容
 新功能：
 1.自动拾取获取装备修改（拾取脚本只要配置了，道具表里有的都显示）
 2.【刷怪脚本】刷怪脚本增加几个参数控制怪物的视野范围、属性倍率、模型大小
3.增加一个获取星星的命令（getitemStarNum 参数1 参数2 ，参数1 -1代表在OK框中，0-12穿在身上的装备，参数2 获取的星星数量赋值给参数2）
 4.快捷按钮描述文字加一个小阴影,加粗

修复BUG：
1.自动挂机优化，自动挂机时单机空白地面就直接跑过去
2.随机传送优化

2020.7.20更新内容
 新功能：
 1.buff 文字备注，支持换行
 2.支持超大属性数值，装备备注上支持18位数值
3.没有绑定手机号的玩家，充值的时候增加一个提示请绑定手机号
 4.快捷按钮文字改成可配置文字 命令格式：addbutton shangcheng_bth 1 1 颜色值|文字
 5.优化创建角色流程，创建新角色会自动进入游戏
 6.支持了#Include与#INCLUDE写法

 修复BUG：
1.GETITEMADDVALUE命令获取不到值的问题
2.装备捡起来有星级，在NPC 装备加星 精炼之后星星就没了的问题
3.元素属性重洗之后会把原有的属性清理掉的问题
4.修复护体神盾特效同步问题

2020.7.17更新内容（注意：17日会推送正式服）
 新功能：
 1.字符串切割支持正则表达式符号
 2.开放自动拾取详细设置功能
3.游戏整体性能优化
 4.战斗操作手感优化
 5.增加新技能：护体神盾

2020.7.15更新内容（注意：16日上午会把最近一周的更新推到正式服，本周增加的新命令新功能即可在正式服使用）
 新功能：
 1.增加技能：气功波
 2.增加设置毒素武器功能，\Envir\UserData\PoisonWeapon.txt
3.增加新功能：宝石升级，使用命令OpenUpgradeDialog打开界面
 4.SendCenterMsg命令发送的消息显示到了屏幕上
 5.tejieconfig中增加配置可控制切到后台后多久掉线
 6.资源编辑器增加编辑器多边形安全区功能
 7.优化战斗，增加被击特效；优化远程技能的攻击距离
 8.增加了一些道具图标特效，可在资源编辑器中查看使用
 9.镶嵌宝石功能增加了可配置自定义文字描述功能，可在tejieconfig中进行配置

 修复BUG：
1.装备对比箭头错乱问题
2.分身术不打怪了，人形宠物也不打怪的问题
3.当stdmode为70时，value1-value9代表属性：tips需要显示出来，属性需要加到身上

2020.7.14更新内容
 新功能：
 1.增加技能：擒龙手
 2.GM编辑工具：增加装备耐久度为0是否消失的配置
3.GM编辑工具：道士技能中增加召唤骷髅
 4.tejieconfig中增加了可配置多少级可以说话
 5.增加一键注册快速游戏功能
 6.增加账号绑定手机号功能
 7.【安全区形状】可自定义安全区形状支持圆形和多边形（可在StartPoint中自行配置也可在资源编辑器中可视化编辑）
 ; 编辑圆形，第一个参数为圆心X，第二个参数为圆心Y，第三个参数为类型，第四个参数为半径
 ; 编辑多边形，对一个参数为中心点X，第二个参数为中心点Y 第三个参数为类型，以后的参数为顶点坐标：坐标X 坐标Y 坐标X 坐标Y 坐标X 坐标Y 坐标X 坐标Y 坐标X 坐标y 坐标X 坐标Y
 8.挂机设置中增加详细设置，玩家可针对具体的道具进行设置拾取
 9.tejieconfig中增加了可配置哪些地图不允许自动复活
 10.充值界面中的说明文字支持<文字|文字说明格式 designtimesp=10736>
 11.GM运营后台，角色信息查询增加账号和状态

 修复BUG：
1.HCALL <$CURRRTARGEINAME> @法克飞飞 这个命令错误问题
2.勋章，武器类装备配置特殊效果不生效的问题
3.:96:1:-3/@1阶回收>；IMG命令支持变量
4.点击有OK框的NPC，再直接点击其他NPC，再点击装备，还显示放入按钮 的问题
5.MOV S$装备所在位置0<$STR(N$装备所在位置)> 解析错误的问题
6.装备属性超过999亿无法显示的问题，现在支持超大无限数值

2020.7.13更新内容
 新功能：
 1.增加技能：冰霜群雨
 2.GetUseritemName 获取装备名字实现
3.怪物速度优化，写1太慢，写2太快（怪物表speed列支持浮点值）
 4.增加<$PASSWORD>命令 注册账号时用户输入的密码
 5.<$TEAM0>..<$TEAMX>用于显示组队成员实现,<$TEAM0>代表队长,成员从<$TEAM1>开始
 6.DeleteItemDuraZero实现
 7.交易和摆摊增加7种货币，可在tejieconfig配置

 修复BUG：
1.stdmode是23的戒指加不上攻击问题
2.文件名大小写问题导致服务器启动失败问题
3.攻速超过一定值变成负值了，之后自动挂机不会打怪了的问题

2020.7.11更新内容
 新功能：
 1.增加新的命令可在OK框中显示对应的3D模型 格式： <PlayModel:资源名:X横向坐标:Y纵向坐标：缩放比例>
 2.背包界面和主角界面和通用OK框界面可拖动位置
 3.【默认装备ICON特效配置】EffectItemList 中可配置道具的ICON特效 该装备会默认有对应的特效(这个配置的第二个字段为特效名，特效名可在资源编辑器中查看)

 修复BUG：
1.dnf版本备注错误 dnf盟重传送员
2.BOXITEM[X].HMC这个命令值取出来的值不对
3.{[%name]|146:0:1}{在地图|255:26:1}{%Map|210:0:1}{中掉落物品} []这个解析问题有时候多一个有时候少一个
4.ChangeModeEx 11 10 3 命令不好用
5.dnf版本,战斗力NPC 战斗力显示的不对的问题

2020.7.10更新内容
 新功能：
 1.增加新技能：十步一杀
 2.【自定义游戏视角】在设置-基本-显示里增加 地图缩放配置玩家可自定义调整视野高度
 3.增加两个变量 $RECHARGE[1].NUMBER：检测充值金额 $RECHARGE[1].FREQUENCY：检测充值次数
 4.资源编辑器增加：配置怪物增加可以删除怪物，修改怪物数量
 5.资源编辑器修改：获取地图NPC功能
 6.资源编辑器修改：增加查看可调用UI资源和可调用特效资源
 7.面板的攻击速度：装备面板上显示的都加，脚本增加的的不显示（在tejieconfig中增加配置是否显示命令加的攻速）

 修复BUG：
1.KILLER和 MONKILLER命令（神秘人的问题）
2.脚本扣血，扣到0也不死的问题
3.dnf版本 ok框取装备替换，取下，拖拽会出现图标消失，错乱情况
4.当stdmode=26 CHANGEITEMADDVALUE改变属性附加 2位置代表的是DC2
5.脚本检测/设置人物或怪物血量 AddhpPer +/-/= AddmpPer +/-/= CheckHpPer >//


官方主页

TJ引擎专有命令

禁止聊天和解除禁止聊天命令：
功能: 使角色禁言
格式: FORBIDDENWORDS 参数1
说明: 使角色禁言，世界聊天、私聊、行会聊天都不允许，输入聊天发送后提示参数1写的文字信息

格式: RELIEVEFORBIDDENWORDS
说明: 解除角色的禁言

控制角色丢弃道具消失的命令：
格式: DISCARDLOSTSTATE 参数1
说明: 参数1（0为不开启，1为开启）处于开启这个状态下的角色不管丢弃什么道具都会消失（默认为不开启状态）

功能: 控制角色打出的道具均为绑定
格式: BINDINGSTATE 参数1
说明: 参数1（0为不开启，1为开启）处于开启这个状态下的角色打怪掉落的所有道具均为绑定状态（默认为不开启状态）


如何设置武器为吸血武器

功能：
可将武器设置成吸血武器；

用法：
在物品数据库中，将武器Anicount字段设为：138，
吸血量为武器的重量（如重量为10，即每刀吸血10点）


官方主页

背包扩容配置

tejiconfig中配置是否开启扩容：
功能: 配置是否开启背包扩容模式
格式: BagExpansion=1
说明: 是否开启背包扩容模式（默认为不开启，0不开启，1开启）

开启背包分页命令：
功能: 可使用此命令开启背包分页
格式:SETBAGOPEN 参数1 参数2
说明:参数1：背包页数 参数2：0关闭 1开启

点击背包分页按钮触发：
功能: 点击背包中分页按钮触发QF中的对应@块（与仓库的开分页功能相同）
格式: @BagOpenFail2 @BagOpenFail3 @BagOpenFail4
说明:分别是第二分页/第三分页/第四分页

免费开启脚本：
[@BagOpenFail2]
#IF
#ACT
SETBAGOPEN 2 1
sendmsg 0 背包二已解锁

[@BagOpenFail3]
#IF
#ACT
SETBAGOPEN 3 1
sendmsg 0 背包三已解锁

[@BagOpenFail4]
#IF
#ACT
SETBAGOPEN 4 1
sendmsg 0 背包四已解锁

付费开启脚本：
[@BagOpenFail2]
#IF
#ACT
MESSAGEBOX 背包二无法打开,单击确认后开启(需500元宝) @开启背包二 @取消

[@开启背包二]
#if
CHECKGAMEGOLD > 499
#ACT
GAMEGOLD - 500
SETBAGOPEN 2 1
;开启背包二命令
MESSAGEBOX 背包二已解锁
#ELSEACT
MESSAGEBOX 元宝不够

背包三未开启时，从该背包取物品或存物品会失败，并且触发QF脚本字段
[@BagOpenFail3]
#IF
#ACT
MESSAGEBOX 背包三无法打开,单击确认后开启(需5000元宝) @开启背包三 @取消

[@开启背包三]
#IF
CHECKGAMEGOLD > 4999
#ACT
GAMEGOLD - 5000
SETBAGOPEN 3 1
SETBAGOPEN 3 1
;开启仓库三命令
MESSAGEBOX 背包三已解锁
#ELSEACT
MESSAGEBOX 元宝不够

[@BagOpenFail4]
#IF
#ACT
MESSAGEBOX 背包四无法打开,单击确认后开启(需50000元宝) @开启背包四 @取消

[@开启背包四]
#IF
CHECKGAMEGOLD > 49999
#ACT
GAMEGOLD - 50000
SETBAGOPEN 4 1
;开启仓库四命令
MESSAGEBOX 背包四已解锁
#ELSEACT
MESSAGEBOX 元宝不够


为什么不能自动解包

客户端自动解包配置，药品数据库的Anicount=打包物品的Shape，这样才可以自动解包
例如：
强效金创药 Anicount=100 超级金创药 Shape=100
疗伤药 Anicount=115 疗伤药包 Shape=115
回城卷 Anicount=108 回城卷包 Shape=108

支持2次打包
例如：
可以把“疗伤药包”再次打包
疗伤药包 Anicount=120 超级疗伤药包 Shape=120

使用启动器有个捆绑DB转换一下就正常了

新的解包配置文件 Envir\UnbindList.txt 格式，兼容旧格式，升级新M2如果不需要修改解包数量的，可以不修改Envir\UnbindList.txt：

;物品DB字段Anicount的值 物品名称 解包数量 物品类型(0其他,1加红,2加蓝,3加红蓝,4卷轴)

100 强效金创药 6 1
101 强效魔法药 6 2
119 强效太阳水 6 3
120 万年雪霜 6 3
102 金创药(小量) 6 1
103 魔法药(小量) 6 2
104 金创药(中量) 6 1
105 魔法药(中量) 6 2
106 地牢逃脱卷 6 4
107 随机传送卷 6 4
108 回城卷 6 4
109 行会回城卷 6 4


为什么登陆黑屏，M2提示全局会话验证失败？

一般情况是M2和账号服务器之间连接出了问题

如果IP端口都检测过设置正确，并且都成功连接成功的情况下，还是出现这个问题

可能是你的服务器名称有空格或括号等等特殊字符，或者名称太长


为什么地面物品不显示名称，不自动捡取？

M2-查看-列表信息二-内挂捡取


为什么个人商店创建失败？

如果使用了你知道的所有方法都不能搞定。

请先关闭服务端，然后使用启动器的里的清除数据，清除个人商店的数据，一般都会正常。


为什么看不见衣服翅膀和武器特效

1. M2里设置错误

2. 客户端没有相应的补丁

3. 内挂开启了隐藏衣服和武器特效的选项


为什么内挂乱吃包裹物品的问题[!]

启动器有个捆绑DB转换一下就正常了


为什么商铺购买不了元宝

商铺中的金币、元宝、声望、经验等等。

如果数据库中的物品名称以金币、元宝、声望、经验等等开头的，购买时不是给用户一个物品

而是根据物品的Need字段值直接给用户加点数。

例：

元宝100 这个物品，用户购买时，会根据这个物品的Need字段值直接给用户加元宝

如果想要给用户一个物品，可以把物品名称改成 100元宝


为什么所有的衣服外观都只显示重盔甲？

登录器配置器-内挂默认设置 衣服简装显示不要勾选 然后在配置登录器。或者在M2-选项客户端设置-内挂控制-玩家简装显示不要勾选，这样直接去掉这个功能

登录器呼出内挂-所有玩家简装显示 不要勾选


为什么提示file not found？

file not found => D:\MirServer\Mir200\Envir\Market_Def\.\QuestDiary\打宝数据\刷怪.txt

如果路径正确，文件存在。最大的可能QuestDiary前面只有1个点，要改成这样 ..\QuestDiary\打宝数据\刷怪.txt


为什么提示禁止点击该NPC触发字段？

为什么提示禁止点击该NPC触发字段，如下图？

下面以一个死亡触发为例，不仅仅是死亡触发，引擎的所有触发都不允许玩家点击NPC触发，
例如：物品触发[@StdModeFunc]，套装触发[@GroupItemOn] [@GroupItemOff]，魔法触发[@MagTagFunc]，穿脱装备触发[@TakeOn] [@TakeOff]等等，就不一一举例了。

[@PlayDie]
<下一页/@下一页>

[@下一页]
<返回/@PlayDie>

;<返回/@PlayDie> 新引擎这里“@PlayDie”是引擎内部触发字段，禁止用户通过NPC点击来触发这个字段
;不仅仅“@PlayDie”不允许“@PlayDie1、 @PlayDie2、 @PlayDie死亡”等等都不允许，只有前面的字符和“@PlayDie”一样的后面不管增加什么字符都将不允许
;如果非要使用玩家点击NPC触发的，可以把上面的脚本改成如下,使用goto转一下

[@PlayDie]
<下一页/@下一页>

[@下一页]
<返回/@返回>

[@返回]
#ACT
goto @PlayDie

---------------------------------------------------------------------------------------------------

还有其他一些触发，也属于这类的，比如：

DelayCall 5000 @再次复活
SendCenterMsg 180 251 还剩余%d发放新手奖励. 0 30 @GiveNewHumanItem

“@再次复活”和“@GiveNewHumanItem”就会变成引擎内部触发，也是不允许用使用NPC点击来触发的
还有一些其他脚本命令带字段触发的，就不一一举例了。


为什么微端不更新

微端更新是按需更新，例如登录器需要读取Hum.wzl里的第10张图片，如果登录器没有读取到，就会从微端更新这个图片，Hum.wzl里的其他图片不管有没有，登录器不需要读取就不会更新

1. 微端更新密码和登录器配置时的密码不一致

2. 微端除了支持Map目录的地图文件和Wav目录声音文件，Data目录的素材支持wzl和Pak这两种格式的素材更新,如果你使用的是wil需要转换成这2种格式才能正常更新

3. IP或者端口设置错误


为什么我的NPC不能买、卖、修理物品？

NPC脚本的第一行加上指定的操作，就可以正常了。

;=================================
(@buy @sell)
%100
+5
+6
[@main]
欢迎光临！！！
<买/@buy>\
<卖/@sell>\ \
<关闭/@exit>
;================================

功能标志说明：
;买物品
@buy
;卖物品
@sell
;炼药
@makedrug
;存仓库
@storage
;取仓库
@getback
;升级武器
@upgradenow
;取回升级武器
@getbackupgnow
;修理
@repair
;特殊修理
@s_repair
;发祝福语
@@sendmsg


为什么我的沙城墙没血条

第一步.首先检查M2启动有没报错，如有检查怪物数据库(Monster.DB)有没设置城墙类型怪物名称，如没只需将城墙名称与怪物数据库相对应即可解决，错误信息如下：
[错误信息] 城堡初始化城门失败，检查怪物数据库里有没城门的设置: MainDoor，

第二步.检查怪物数据库内城墙名称的血量，不能超过5000，


为什么我原来数据库里的武器加速，现在乱了？

由于数据库格式有些改变，原数据库里组合数据字段会有所变化，大家按以下规则改一下数据就行了。

武器5,6
(AC2) 准确
(MAC2) 1-10 为攻击速度减 11或以上为攻击速加，点数为 x - 10 = 1


为什么无法切换攻击模式，@开始提问无效？

最大的可能是命令被过滤了

M2-查看-列表信息二-消息过滤

就在这个里面过滤了，如果不知道哪个，就全部清空掉


为什么武器升级提示缺少材料

武器升级需要矿石和金币，

矿石错误，可以看Mir200\!Setup.txt里面 BlackStone=黑铁矿石 看看名称是否和你的包裹里的矿石名称一样，如果不一样请修改

M2-功能设置-升级武器，可以查看需要多少金币，如果金币足够，那就是矿石错了


为什么物品不能重叠

物品重叠功能不能使用在拥有持久、属性、品质、纯度等物品上。 StdMode等于 0, 2, 3, 40, 41, 42

物品重叠功能，StdItem.DB 中OverLap=1或2 表示可以重叠 0不叠加
OverLap=1 重量=重叠数量*单物品重量/10
OverLap=2 重量=重叠数量*单物品重量

DuraMax必须大于1


为什么有的客户端登录后地图是黑的黑屏,界面不显示？

如果使用了pak 并且pak的密码都设置正确，还是黑屏，并且在没有使用微端的情况下，可以看下面的图


为什么装备元素属性不显示

M2-选项-物品装备-新增属性 勾选“启用新增属性”，勾选后登录器才能显示元素属性


Magic详解

magicdb:是你所修炼的法术和各种技能.
序号 字段 说明

(1)MagID 技能序号
(2)MagName 技能名字
(3)EffectType 使用技能时角色的动作效果
(4)Effect 技能产生的动画效果
(5)Spell 每次使用技能使用的魔法值
(6)Power 技能的伤害值下限
(7)MaxPower 技能的伤害值上限
(8)DefSpell 每次技能升级后增加使用的魔法值
(9)DefPower 每次技能升级后增加的伤害值下限
(10)DefMaxPower 每次技能升级后增加的伤害值上限
(11)job 可以学习技能的职业（0-战士，1-法师，2-道士）
(12)NeedL1 技能升到1级 需要玩家达到的人物等级（默认数据到15级别）
(13)L1Train 技能升到1级 需要的熟练度（默认数据到15级别）
(14)Delay 使用完当前技能后再次使用其他任意技能之间的延时（单位：毫秒）
(15)descr 简单备注
(16)MaxTrainLv 可以修炼的最高等级


Monster详解

monsterdb: 是关于怪物的攻击,经验,还有等级方面的东西
怪物CoolEye 调到100 ，再用隐身戒指也没用了

(1)sid 怪物代号
(2)name 怪物名称
(3)race 行动模式及死亡时的效果代码
race代码---81 对象进入范围自动攻击
82 2x2范围内毒液攻击-弱
90 贴身麻痹石化攻击-弱
92 遇到攻击对象在范围外时会瞬移
93 边攻击边躲避
95 对象进入攻击范围内会从地下爬出来
100 召唤的骷髅
101 进入范围会从石像状态激活
102 在攻击的同时召唤mir200\!setup.txt文件里的zuma1~4里特定的怪
103 自身不移动，通过释放mir200\!setup.txt文件里的bee特定的怪来攻击对象
105 麻痹石化攻击-强
106 麻痹石化攻击-弱
107 全屏攻击+麻痹+中毒
113 召唤的神兽-小
114 召唤的神兽-大
115 自身不移动，通过地刺来攻击对象
116 自身不移动，通过释放mir200\!setup.txt文件里的spider特定的怪来攻击对象
117 自身没有攻击力，通过自暴来攻击对象
(4)racelmg 攻击模式代码
racelmg代码---15 抛斧头
16 贴身喷毒
21 电火花
22 喷针
40 击电
45 射箭
52 高空喷毒效果
53 低空喷毒效果
49 丢火球 祖玛教主攻击动作
33 大范围喷毒 触龙神攻击动作
触龙神外形编号 140 攻击动作编号 33
祖玛教主外形编号 63 攻击动作编号 49
火焰沃玛外形编号 31 攻击动作编号 20
沃玛教主外形编号 34 攻击动作编号 21
(5)appr 怪物外观形象代码
(6)lvl 怪物等级
(7)undead 是否属不死系 0-否，1-是[不死系不可招，死系可召]
(8)cooleye 是否主动攻击(反隐形范围,并和等级有关)
(9)exp 怪物的经验值
(10)hp 怪物生命
(11)mp 怪物魔法
(12)ac 怪物防御力
(13)ac2 防御力上限
(14)mac 魔法防御力
(15)dc 物理攻击力
(16)dcmax 最大物理攻击力
(17)mc 魔法攻击力
(18)sc 道士精神力
(19)speed 速度
(20)hit 攻击命中率
(21)walk-spd 行走速度间隔
(22)walkstep 行走步伐
(23)walkwait 行走等待时间
(24)attacr-spd 攻击速度间 （攻击速度间隔的时间，不会小于服务器技能表的CD时间）


Stditem详解

stditemdb：物品属性修改
1.选中最底下的那个装备名，然后点图中所示1的位置那个+号，这样就会在你所选中的装备前面插入一列横向表单，点了+号后，在右边就会出现一个“对号”标记的按钮，按一下这个“对号”就表示确定插入这一横列。
(1)idx属性表示数据库的序列号(记住序号不要重复)
(2)name属性表示：
物件的名称
(3)stdmode装备属性：
10-男衣
11-女衣
5-单手
6-双手
30-蜡烛类
22-毒药，符类
42-制作原料
=======================================================
(4)shape这个属性(衣服显示穿上得样子,首饰代表其特殊功能)
“5”表示“灵魂战衣”的样子。
“4”表示“魔法长袍”的样子。
“3”表示“重盔甲”的样子。
19~21 ：项链
为19时，ac2和mac2代表魔法躲避和幸运
为20时，ac2为准确，mac2为敏捷
为21时，ac2为体力恢复，mac2为魔法恢复
24~26 ：手镯
为24时，ac2代表准确，mac2代表敏捷
为26时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
22~23 ：戒指
为22时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
为23时，ac代表攻击速度+ ， mac代表中毒躲避+ ， mac2代表中毒恢复+
shape值：
记忆头盔125
记忆戒指122
记忆手镯124 天地合一
记忆项链123
魔血戒指133 虹魔戒指136
魔血项链134 mp转hp 虹魔手镯137 吸hp
魔血手镯135 虹魔项链138
神秘戒指130 祈祷戒指128
神秘腰带131 随机属性 祈祷手镯126
神秘头盔132 祈祷头盔129
隐身戒指111 传送戒指112
麻痹戒指113 复活戒指114
火焰戒指115 治愈戒指116
幸运戒指117 护身戒指118
负载戒指119
技巧项链120
探测项链121
恢复hp/mp113
对于武器来说： 当shape值和reserved值分别为 30 和 12 时，武器一旦拿上就不能取下，只到死后消失 (血剑)
当仅reserved值为 8 时，武器拿上可以取下，但是一旦战斗死亡，就会消失
=====================================================================================
(5)weight属性是物件重量.

(6)looks属性(显示衣服物品栏里样子和在装备栏里的样子)
"重盔甲(男)"or"战神盔甲(男)"or"钢盔甲(男)" 62
"魔法长袍(男)"or"恶魔长袍(男)"or"圣龙魔袍(男)" 63
"灵魂战衣(男)"or"幽灵战衣(男)"or"泰坦战衣(男)" 64
"重盔甲(女)"or"战神盔甲(女)"or"钢盔甲(女)" 82
"魔法长袍(女)"or"恶魔长袍(女)"or"圣龙魔袍(女)" 83
"灵魂战衣(女)"or"幽灵战衣(女)"or"泰坦战衣(女)" 84
(7)duramax物件持久的属性：这里的变量中"1000"表示1个持久度,那么"40000"就表示40个持久度了!
(8)衣服和武器的属性:
"ac" 防御力下限
"ac2" 防御力上限
"mac" 魔防下限
"mac2" 魔防上限
"dc" 物理攻击力下限
"dc2" 物理攻击力上限 超过了255带在身上攻击是会减成0
"mc" 魔法攻击力下限
"mc2" 魔法攻击力上限
"sc" 道术下限
"sc2" 道术上限
"needlevel" 需要等级
"price" 价格
(9)物品是首饰时：
"ac2" 表示准确
"mac2" 表示敏捷
"ac" 表示防御下限
"ac2" 表示防御上限
"mac" 表示魔御下限
"mac2" 表示魔御上限
药剂的属性：
强效金疮药：hp +90
数据库体现：
ac 90
强效太阳水：hp +50 mp +80
数据库体现：
ac 50
mac 80
这样看来，这里的
ac 表示 hp前值（注 hp：200/300，200为前值，300为后值。）
mac 表示 mp前值
特殊的:
一些不常见的特殊药剂：
生命强化水：生命力暂时提升120秒（120秒内hp后值+50）
数据库体现：
ac 50
mac2 120
魔法强化水：魔法力暂时提升120秒（120秒内mp后值+50）
mac 50
mac2 120
那么这里的
ac 表示hp后值
mac 表示mp后值
mac2 表示时间了
大家知道 苹果 是每项属性都暂时增加240秒，他的ac2中是2，那么应该和武器一样，ac2表示准确了！
(10)stock 是否为库存品
(11)need表示限制种类：
0 为等级限制
1 为攻击限制
2 为魔法限制
3 为道术限制
10 为职业及等级限制

(12)needlevel表示了(need)限制的具体数量.

need=10时，needlevel填写数值：职业(0-战士，1-法师，2-道士) + 65536*等级限制

另外上面的 stock处网上有说不是库存的意思是是否容易暴出后物品比较极品的意思,大家可以自己测试

字段Color 物品在地面颜色的显示设置
字段OverLap 物品叠加功能

60:在DB库增加新装备新怪的方法和技巧:
4F在DB库增加新装备新怪的方法和技巧
大家一定玩腻了盛大所定的那些装备了把，一定也想在自己的4F里增加一些独创的装备把。
告诉大家一个技巧多利用COPY而让创建的装备100%成功，又不会出错！
具体操作：
比如我想要一件[狂神布衣（男）]
用DB Commander Shortcut打开StdItems.DB后首先找到原来的布衣（男）的数据单击成兰色后，选择DB Commander Shortcut上面的EDIT出现下拉菜单，点里面的COPY RECORD后下拉菜单消失。再点EDIT这时出现的下拉菜单里面原来是灰色不能选择的2个选项成了可选项，选择PASTE RECORD APPEND后他会自动在库的最下面拷贝了一份布衣的资料。IDX是物品编号改成上面物品的编号的后一位就可。NAME是名称呀改成[狂神布衣（男）]因为是COPY布衣（男）同样都是男用衣服所以装备属性和外观属性等都不用修改，现在要修改的只是：
DURAMAX：这是持久，注意这里的1000=游戏中的1点持久，如要40的持久那么就是40000。
AC和AC2就不用我多说了把是 防御和防御上限。
MAC和MAC2是魔防和魔防上限。
DC和DC2是攻击和攻击上限。
MC和MC2是魔法力和魔法力上限。
SC和SC2是道术和道术上限。
这里就自己看着改吧，都改成225的话呵呵。。。。。自己试试。
注意最高只能改到225！！！！！！！！！！！


特殊物品设置[!]

物品名称(Name) | StdMode | Shape | Anicount | Source | 说明
气血石 | 7 | 1 | 0 | 0 | 自动增加HP,增加数量为 持久*10
幻魔石 | 7 | 2 | 0 | 0 | 自动增加MP,增加数量为 持久*10
魔血石 | 7 | 3 | 0 | 0 | 自动增加HP和MP,增加数量为 持久*10
例如： 气血石(小);7;1;1;0;0;0;991;4000;1;0;0;0;0;0;0;0;0;0;0;0;5000;5;
气血石(中);7;1;2;0;0;0;992;9000;1;0;0;0;0;0;0;0;0;0;0;0;5000;5;
气血石(大);7;1;3;0;0;0;993;20000;1;0;0;0;0;0;0;0;0;0;0;0;5000;5;
幻魔石(小);7;2;1;0;0;0;995;6000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
幻魔石(中);7;2;2;0;0;0;996;14000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
幻魔石(大);7;2;3;0;0;0;997;32000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
魔血石(小);7;3;3;0;0;0;1028;10000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
魔血石(中);7;3;3;0;0;0;1027;15000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
魔血石(大);7;3;3;0;0;0;1026;20000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;

物品名称(Name) | StdMode | Shape | Anicount | Source | 说明
随机传送石 | 2 | 2 | 0 | 0 | 随机在当前地图上移动，使用次数为 持久/1000
修复神水 | 2 | 9 | 0 | 0 | 修复身上所穿装备持久，修复点数为 持久/100
千里传音 | 7 | 0 | 1 | 0 | 可以使用 @传 向全服喊话，使用次数为 持久/1000
火龙之心 | 25 | 9 | 0 | 0 | 英雄配带，合击物品.
召唤强化卷 | 2 | 1 | 0 | 0 | 装自己的宝宝升级为七级宝宝(适用于道士)，使用次数为 持久/1000
斗笠 | 16 | 0 | 0 | 0 | 配带后可以隐藏人物名称，支持双头盔配带，并支持人物属性增加 Shap 0~7
聚灵珠 49 0 0时使用元宝提取经验,=1时使用金币提取经验.

0提取经验时触发@GetExp

1提取经验时不触发@GetExp

 说明:聚灵珠在人物背包中杀怪时获得经验时自动聚集经验,当经验聚满时双击可获得经验.
人物英雄在线时也可获得经验.

设置:1.物品数据库中聚灵珠StdMode=49.
2.获取当前经验的倍数Shape/100
3.DuraMax表示聚灵珠可聚集的最大经验值,1点表示1W经验值,例如DuraMax设置20那么实际
可聚集20W经验.DuraMax设置100那么最大可聚集100W经验值.
4.AniCount=0时使用元宝提取经验,=1时使用金币提取经验.

0 使用元宝(<$gameGold>)提取

1 使用金币(<$goldCount>)提取

2 使用绑定元宝(<$b_gameGold>)提取

3 使用绑定元宝(<$b_goldCount>)提取

4 优先使用<$b_gameGold>，不足时使用<$gameGold>

5 优先使用<$b_goldCount>，不足时使用<$goldCount>

5.Reserved表示聚灵珠最多可使用的天数,当超过使用天数后不再聚集经验,没有聚集经验时不计算天数,值为0时不限制天数
6.Need=提取经验时所需的元宝数量或者金币数量.
7.AC等于0时表示不限制人物等级,大于0时人物等级超过AC设定的等级时无法使用.
8.使用GM命令@Make制造聚灵珠时第三个参数代表聚灵珠的经验,第四个参数代表最多可使用的天数.例如:@Make 聚灵珠 1 10 365 ;10表示10W经验.365表示可以使用365天
如果第四个参数为空时，默认使用DB数据库里Reserved设置的天数
传送符 | 25 | 6 | 0 | 0 | 类似于传送戒指，使用一次减100点持久
自定义记次物品 | 2 | 1 | X | 0 | 自定义物品，使用次数为 持久/1000 ，使用成功后调用 QFunction-0脚本中的 [@StdModeFuncX] 其中X为Anicount
例如： 随机传送石;2;2;1;0;0;0;1025;50000;0;0;0;0;0;0;0;0;0;0;0;0;50000;1;255;0;99;
修复神水;2;9;1;9;0;0;120;10000;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;
千里传音(小);7;0;1;1;0;0;1000;5000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
千里传音(大);7;0;1;1;0;0;1000;10000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
传音筒;7;0;1;2;0;0;1000;5000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
超级传音筒;7;0;1;2;0;0;1000;10000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
火龙之心;25;9;1;0;0;0;1148;30000;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;
召唤强化卷;2;1;1;7;0;0;998;5000;0;0;0;0;0;0;0;0;0;0;0;0;6000;5;
斗笠;16;0;2;0;0;0;1188;30000;0;0;0;0;0;0;0;0;0;0;0;7;20000;5;
回城石;2;3;1;30;0;0;1024;60000;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;255;0;99;
聚灵珠(小);49;100;1;0;0;0;820;25;0;0;0;0;0;0;0;0;0;0;5;0;25000;5;255;0;0;0;
聚灵珠(大);49;100;1;0;0;0;820;50;0;0;0;0;0;0;0;0;0;0;10;0;50000;5;255;0;0;0;
计时物品 限时物品带到身上开始计时,到期后必须在身上时才会自动消失.(每分钟检测一次)
物品Need=101时限时物品,NeedLevel=时间(分钟)
配合死亡之眼技能使用 | 蓝色药粉(大量);25;3;3;0;0;0;257;15000;0;0;0;0;0;0;0;0;0;0;0;1;15000;50;255;0;0;;


物品代码表

物品代码(Stdmode) | 物品类型 | 相关说明
0 | 药品 |
1 | 食物 |
2 |  |
3 | 卷类 |
4 | 技能书 |
5 | 武器 |
6 | 武器 |
7 | 技能书 |
8 |  |
9 |  |
10 | 衣服(男) |
11 | 衣服(女) |
15 | 头盔 |
16 | 斗笠 |
19 | 项链 |
20 | 项链 |
21 | 项链 |
22 | 戒指 |
23 | 戒指 |
24 | 手镯 |
25 | 符、毒药 |
26 | 手镯 |
28 | 马牌 | 位置代码=15 变量<$HORSE> Anicount=0 不能骑马 大于0时比如1,2,3等等可以使用“Ctrl + J”骑马 马的素材调用L-Horse
29 | 天使 | 物品数据库字段Shape设置天使的类型，1 -10 代表不同的天使。51-100 为不同的同的马， 可以使用“Ctrl + J”骑马 马的素材调用L-Horse
30 | 照明物 | 物品数据内Source字段为1时不随时间掉持久，为0随时间掉持久 51-100 为不同的同的马， 可以使用“Ctrl + J”骑马 马的素材调用L-Horse
31 | 捆装物品 |
48 | 盾牌 | 位置代码=16 变量<$SHIELD>
49 | 聚灵珠 |
53 | 宝石 | 有气血石功能 Anicount=1,2,3 分别对应三种石头
62 | 鞋子 |
63 | 宝石 |
64 | 腰带 |
65 | 军鼓 |

物品特殊属性设置:
 武器 蜡烛 类型物品 使用物品数据库字段
AniCount 首饰 类型物品 使用物品数据库字段 Shape

属性代码 | 属性功能 | 功能介绍
111 | 隐身 | 人物进入隐身状态，普通怪物看不到人物，破隐身的怪物可以看到人物
112 | 传送 | 人物可以使用命令在传送到指定座标上(@UserMove)
113 | 麻痹 | 人物物理攻击时可以将对方麻痹
114 | 复活 | 人物具备复活功能，人物在死亡时起作用，生效一次掉一个持久
115 | 火焰 |
116 | 治愈 |
117,170 | 不掉物品 | 人物死亡时不会掉任何物品，包括背包里的及身上戴的
118 | 护身 | 人物在被攻击时，先降MP，MP为0时才降HP
119 | 超负载 | 人物可以戴上超过自己负重的物品
120 | 技巧 | 人物在练技能时，得到双倍的练习点
121 | 探测 | 可以查找指定人物当前位置
122 | 记忆戒指 |
124 | 记忆手镯 |
125 | 记忆头盔 |
126 | 祈祷手镯 |
127 | 祈祷项链 |
128 | 祈祷戒指 |
129 | 祈祷头盔 |
130 | 神秘戒指 |
131 | 神秘腰带 |
132 | 神秘头盔 |
133 | 魔血戒指 |
134 | 魔血手镯 |
135 | 魔血项链 |
136 | 虹魔戒指 |
137 | 虹魔戒指 |
138 | 虹魔项链 |
139 | 防麻 | 防麻痹功能，可以使被攻击方的麻痹功能失效(不防怪物麻痹）
140 | 无敌(未完全) |
141 | 经验 | 杀怪所得经验为指定倍数(倍数为持久除以 10000)，如果物品持久太小，所得经验将比正常还低
142 | 力量 | 人物攻击力倍数(倍数为持久除以 10000)，如果物品持久太小，所得攻击力将比正常还低
182 | 经验 | 杀怪所得经验为指定倍数(倍数为持久除以 10000)，不受物品持久太小影响
183 | 力量 | 人物攻击力倍数(倍数为持久除以 10000)，不受物品持久太小影响
143 | 防护身 |
144 | 防复活 |
145 | 行会召唤 |
150 | 麻痹护身 |
151 | 麻痹火球 |
152 | 麻痹防御 |
153 | 麻痹负载 |
154 | 护身火焰 |
155 | 护身防御 |
156 | 护身负载 |
157 | 传送麻痹 |
158 | 传送护身 |
159 | 传送探测 |
160 | 传送复活 |
161 | 复活麻痹 |
162 | 护身复活 |
171 | 不掉背包物品 |
172 | 不掉身上装备 |
189 | 麻痹 | 人物魔法技能攻击时可以将对方麻痹


物品极口属性详解

物品极品属性详解

重要注意事项，请在使用本功能前务必详细阅读，否则将有可能带来严重后果
当所需要升级的项链、手镯、戒指、在DB数据库中因 SHAPE 值的不同，而升级
出来得到的结果也不同，所以使用者请按照以下属性变化列表进行详细设置！
其中涉及的体力恢复、魔法恢复、毒物躲避、中毒恢复、如升级成功“1”点属性，则表示为 10%

项链属性：
当SHAPE值为19时：属性位置“0”升级出来表现为“魔法躲避”、属性位置“1”升级出来属性表现为“幸运”
当SHAPE值为20时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当SHAPE值为21时：属性位置“0”升级出来表现为“体力恢复”、属性位置“1”升级出来属性表现为“魔法恢复”

手镯属性：
当SHAPE值为24时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当SHAPE值为26时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”

戒指属性：
当SHAPE值为22时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”
当SHAPE值为23时：属性位置“0”升级出来表现为“毒物躲避”、属性位置“1”升级出来属性表现为“中毒恢复”

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久


物品所需条件设置

使用物品所需条件设置:

物品数据库字段:（字段包括二个参数的需要用字段计算器算出具体数字）

Need | NeedLevel
0 | 需要指定等级以上才可以戴上
1 | 需要指定攻击力以上才可以戴上
10 | 需要指定职业及指定等级以上才可以戴上
11 | 需要指定职业及指定攻击力以上才可以戴上
12 | 需要指定职业及指定魔法力以上才可以戴上
13 | 需要指定职业及指定道术以上才可以戴上
2 | 需要指定魔法力以上才可以戴上
3 | 需要指定道术以上才可以戴上
4 | 需要指定转生等级以上才可以戴上
40 | 需要指定转生等级及指定等级以上才可以戴上
41 | 需要指定转生等级及指定攻击力以上才可以戴上
42 | 需要指定转生等级及指定魔法力以上才可以戴上
43 | 需要指定转生等级及指定道术以上才可以戴上
44 | 需要指定转生等级及指定声望点以上才可以戴上
5 | 需要指定声望点以上才可以戴上
6 | 加入了行会的人才可以戴上
60 | 行会掌门才可以戴上
7 | 沙城成员才可以戴上
70 | 沙城城主才可以戴上
8 | 会员才可以戴上
81 | 指定类型会员，及大于或等于指定会员等级，字段设置
82 | 指定或大于类型会员，及大于或等于指定会员等级 字段设置


达到多少人在线不允许离线挂机脚本[!]

[@离线挂机]
{
#IF
checklevelex < 35
#act
MessageBox 等级35级以上才能使用离线挂机功能!
break

#if
ISONMAP 0
#act
goto @HumanCount0
break

#if
ISONMAP 3
#act
goto @HumanCount3
break

#if
ISONMAP 5
#act
goto @HumanCount5
break

#elseact
MessageBox 此地图无法使用离线挂机功能!
break

[@HumanCount0]
#IF
checkhum 0 300
#act
MessageBox 此地图挂机人数已满，请选择其他地图挂机!
break
#elseact
goto @开始离线挂机

[@HumanCount3]
#IF
checkhum 3 300
#act
MessageBox 此地图挂机人数已满，请选择其他地图挂机!
break
#elseact
goto @开始离线挂机

[@HumanCount5]
#IF
checkhum 5 300
#act
MessageBox 此地图挂机人数已满，请选择其他地图挂机!
break
#elseact
goto @开始离线挂机

[@开始离线挂机]
目前您只需要花费30万金币即可享受挂机涨经验,泡点的服务\
点击下面的挂机功能后即可回家睡觉了,人物自动挂在安全区泡\
经验.能量及泡红名,还可设置自动回复信息,给好友留言！ \
<注意:>在游戏中输入指令[@挂机].同样可以享受挂机服务!\
原则上本区不发展挂机，不希望活死人现象，开区一定成形后\
将逐渐销减离线挂机成分，努力做到让大家聊天有个伴，PK有对象！\
<我要挂机/@@offlinemsg>　<--点击后输入留言给好友留言.>\ \
<关闭/@exit>

[@@offlinemsg]
#if
checkgold 300000
#act
take 金币 300000
OFFLINE 60 2000 ;60 2000 说说60秒钟可以获得2000经验
#elseACT
MessageBox 对不起您的金币不够30万，无法启用离线挂机功能!
break

}


动态地图连接[!]

增加动态地图连接命令
ADDMAPGATE 连接名称(为了区别其他连接) 地图号 X(小于0时随机坐标) Y(小于0时随机坐标) 范围 到达地图号 到达地图坐标X(小于0时随机坐标) 到达地图坐标Y(小于0时随机坐标) 有效时间秒(时间到了自动删除该连接,该参数为空时不限时间)

删除动态地图连接命令
DELMAPGATE 连接名称 地图号

获取动态地图连接坐标
GETMAPGATE 连接名称 地图号 变量1(保存X坐标) 变量2(保存Y坐标) 变量3(保存到达地图号) 变量4(保存到达地X坐标) 变量5((保存到达地Y坐标))

[@AddMapGate]
#ACT
AddMapGate 连接 3 335 330 1 0 335 268 30
GetMapGate 连接 3 <$STR(G10)> <$STR(G11)> <$STR(S$10)> <$STR(G12)> <$STR(G13)>
SENDMSG 6 增加地图新连接30秒后删除:[<$STR(G10)>:<$STR(G11)>]到达地图:<$STR(S$10)>到达坐标[<$STR(G12)>:<$STR(G13)>]

[@DelMapGate]
#ACT
DelMapGate 连接 3


发送聊天框固顶信息

SENDTOPCHATBOARDMSG 发送模式(0发送给所有人,1发送给自己) 字体颜色 背景颜色 时间(秒) 信息 是否显示人物名称(0显示，1不显示)

[@Main]
SENDTOPCHATBOARDMSG 0 149 235 30 %s:聊天框固顶信息


会员系统详解

会员系统主要用来对一些加盟玩家的特殊控制。可以用IP地址，登录帐号，角色名，之类的为标志控制。

相关脚本命令

设置会员类型：SETMEMBERTYPE
设置会员等级： SETMEMBERLEVEL

检查会员类型：CHECKMEMBERTYPE
检查会员等级：CHECKMEMBERLEVEL

相关脚本会员物品

物品使用条件：8、81、82

增加会员时间 文件名称 天 时 分
[@main]
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 2 3
#ACT
SENDMSG 6 增加30天2小时3分 255 253

检测会员剩余时间 文件名称 过期是否删除(0不删除 1删除) 变量1(到期时间 字符变量) 变量2(剩余天数 数字变量) 变量3(剩余小时 数字变量) 变量4(剩余分钟 数字变量)
[@main]
#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 S$1 N$1 N$2 N$3
#ACT
SENDMSG 6 你的会员到期时间是<$STR(S1)>【剩余天数=<$STR(N$1)>】【剩余小时=<$STR(N$2)>】【剩余分钟=<$STR(N$3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253

删除会员还是使用原来的老命令DELNAMEDATELIST

[@main]
<输入需要充值的人物名称/@@InputString1>\ \ \
<关闭/@EXIT>\

[@InputString1]
#IF
S$1.CHECKONLINE
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 2 3
SENDMSG 6 <$STR(S$1)>充值成功，增加30天2小时3分！ 255 253
#ELSEACT
SENDMSG 6 <$STR(S$1)>不在线！ 255 253


机器人脚本

功能：
系统机器人，可以定时做一些指定操作
相关配置目录:
\Envir\Robot_def\

相关文件:
\Envir\Robot.txt 机器人配置文件
\Envir\Robot_def\RobotManage.txt 机器人运行脚本文件

机器人配置文件格式:
;Robot.txt
;机器人名称 脚本名称
系统控制 AutoRunRobot

脚本格式:
;AutoRunRobot.txt
#AutoRun NPC SEC 10 @SendRedMsg
SEC：按秒运行
MIN：按分运行
HOUR：按小时运行
DAY：按天运行
RUNONWEEK：按星期几及时间运行
#AutoRun NPC RUNONWEEK 5:15:55 @SendRedMsg
星期五15点55分运行

实例：
Robot.txt内容：该文件在\Envir\下
;==========================
Test Test
;==========================

Test.txt内容：（每8秒钟运行脚本一次）该文件在\Envir\Robot_def\下
;==========================
#AutoRun NPC SEC 8 @DHB
;==========================

RobotManage.txt内容（内容即普通脚本内容）该文件在\Envir\Robot_def\下
;==========================
[@DHB]
#if
#act
SENDMSG 0 双头金刚怪物攻城了......
MISSION 3 330 330
PARAM1 360
PARAM2 340
PARAM3 10
PARAM4 1
MOBPLACE 双头金刚
;==========================


假人登录脚本实例

[@Login]
#IF
;检测是否是假人
ISDUMMY
#ACT
;从配置文件列表中随机获取一个配置文件
GETRANDOMLINETEXT ..\QuestDiary\智能陪练\假人配置文件列表.txt <$STR(S$10)>

SETDUMMYCONFIGFILENAME <$STR(S$10)>

LOADDUMMYCONFIGFILE

MOVR D0 6
ChangeAttatckMode <$STR(D0)>

;从配置文件列表中随机获取一个配置文件,给英雄使用
GETRANDOMLINETEXT ..\QuestDiary\智能陪练\假人英雄配置文件列表.txt <$STR(S$11)>

;从假人列表或假人英雄列表中获取一个没有登录过的名称
GETDUMMYNAME <$STR(S$1)> 1 1

;格式 SETDUMMYHERONAME 英雄名称
SETDUMMYHERONAME <$STR(S$1)>

RECALLHERO

DUMMYSTART

[@HeroLogin]
#IF
;检测是否是假人英雄
H.ISDUMMY
#ACT
;<$STR(S$11)> 是主人登录随机获取的一个配置文件
H.SETDUMMYCONFIGFILENAME <$STR(S$11)>

H.LOADDUMMYCONFIGFILE


脚本控制怪物攻城

功能：
实现由脚本控制怪物攻城。

格式：
格式:

MISSION 地图 x1|x2|x3...xn y1|y2|y3...yn (x和y的数量要一致）
PARAM1 刷新怪物座标X
PARAM2 刷新怪物座标Y
PARAM3 数量
PARAM4 范围
PARAM5 国家编号
PARAM6 是否攻击本国玩家(0,1)
PARAM7 不同国家怪物是否PK(0,1)
PARAM8 怪物名字颜色
PARAM9 是否允许本国玩家攻击(0,1)
MobPlace 怪物名称 目标名称(为空表示可攻击所有可攻击的对象，指定名字表示只攻击指定名称的可攻击对象)

;=======================================
[@MobMission]
#if
#act
MISSION 3 125|96|119|152 90|71|52|69
PARAM1 125
PARAM2 95
PARAM3 1
PARAM4 1
PARAM5 1
PARAM6 0
PARAM7 0
PARAM8 250
PARAM9 0
MobPlace 半兽勇士
;=======================================


离线挂机[!]

OFFLINEPLAY 参数1 参数2 参数3

参数1：离线时长范围

参数2：每分钟获取的经验

参数3：挂机角色在行会列表及好友界面是否显示在线（0或空，不显示在线；1：显示在线）

OFFLINEPLAY 离线时长范围 0-35000

(@@offlinemsg)
[@main]
欢迎使用我提供的挂机功能，使用此功能可以让你不必开电脑，\
就可以进行泡点。\
点击开始挂机后，可输入一段留言信息给你的朋友。\
<开始挂机/@@offlinemsg>
[@@offlinemsg]
#if
ISDUPMODE
#say
请找一个空位置，不能与别人站在一起。\ \
<返回/@main>
#act
break

#if
INSAFEZONE
#elseact
break
#elsesay
请在安全区找一个位置站好，不能会被人杀的。\ \
<返回/@main>

#IF
checklevelex > 0
#act
OFFLINEPLAY 100 ;这100是说100分钟被踢下线！ 第一种离线命令

OFFLINEPLAY 12 5000 ;说明1分钟可以获得5000经验。可以获得12分钟时间


人物登录脚本

功能：
即在人物进入游戏时自动执行的脚本，通过此脚本可对人物进行大量的功能控制。

格式：
在目录 Envir\MapQuest_def\ 中建立文件名为QManage.txt的脚本，按以下格式编写脚本：

========================================================================
;脚本例子
[@Login]
#IF
IsAdmin
#ACT
CHANGEMODE 2 1
CHANGEMODE 3 1
SENDMSG 5 %s，欢迎进入游戏，当前模式为GM管理模式。========================================================================
注：如该脚本更改后，不须重启M2使其生效，可用@ReloadManage命令重新加载该脚本。


人物转生[!]

功能：
人物转生控制

格式：
 RENEWLEVEL 转次数 转后等级 分配点数
转次数 代表一次转多少级(数值范围为 1 - 255)
转后等级 代表转生后人物的等级，0为不改变人物当前等级。
分配点数 代表转生后可以得到的点数，此点数可能按比例换成人物属性点(数值范围 1 - 20000)。

;==========================================
;将人物转生一次，后等级设为 28级，分配100点属性
[@RenewLevel]
#IF
#ACT
RENEWLEVEL 1 28 100
#SAY
转生成功。
;==========================================
功能：
 检测转生等级

格式：
 控制符(=,>,<)
;==========================================
[@ViewRenLevel]
#IF
checkrenewlevel = 0
#act
break
#say
你还没转生！！！\ \
〖<返回/@ReNewLevel>〗 〖<关闭/@exit>〗
#IF
checkrenewlevel = 1
#act
break
#say
你的转生等级为第一重转生！！！\ \
〖<返回/@ReNewLevel>〗 〖<关闭/@exit>〗
;==========================================

功能：
清除人物转生数据(即人物转生后恢复到未转生状态)

格式：
;==========================================
[@ClearRenewLevel]
#IF
#ACT
RestRenewLevel
;==========================================

功能：
设置及更改转生人物显示的名称

格式：
配置文件：String.ini

以下为相关配置内容：
;==========================================
WarrReNewName=%chrname\*<圣>*
WizardReNewName=%chrname\*<神>*
TaosReNewName=%chrname\*<尊>*

WarrReNewName 　武士转生后名称显示
WizardReNewName 法师转生后名称显示
TaosReNewName 　道士转生后名称显示


任务脚本

pickupTask

接取指定任务

标签:命令定义|pickupTask

格式

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
pickupTask | 任务类型 | 任务id | 任务名称 | 任务目标 | 是否显示高亮引导
说明:

  • 参数1: 任务类型
    • 1：主线
    • 2：日常
    • 3：支线
  • 参数2: 任务id
  • 参数3: 任务名称文本
    • 支持文本颜色
      <任务目标文本/fcolor=颜色编码id>
  • 参数4: 任务目标文本
    • 支持文本颜色
      <任务目标文本/fcolor=颜色编码id>
    • 支持文本下划线
      </u任务目标文本/u>
  • 参数5: 任务是否显示高亮引导框
    • 0 不显示
    • 1 显示
    • 缺省 不显示

synchronizationTaskStatus

同步界面显示状态，展示任务进度变化

标签:命令定义|synchronizationTaskStatus

格式

命令名 | 参数1 | 参数2 | 参数3 | 参数4
synchronizationTaskStatus | 任务id | 任务名称 | 任务目标 | 是否显示高亮引导
说明:

  • 参数1: 任务id
  • 参数2: 任务名称文本
    • 支持文本颜色
      <任务目标文本/fcolor=颜色编码id>
  • 参数3: 任务目标文本
    • 支持文本颜色
      <任务目标文本/fcolor=颜色编码id>
    • 支持文本下划线
      </u任务目标文本/u>
  • 参数4: 任务是否显示高亮引导框
    • 0 不显示
    • 1 显示
    • 缺省 不显示

特戒引擎脚本示例：

[@main]
#say
<接任务/@接任务>\ \
<刷新任务/@刷新任务>

[@接任务]
#act
mov u502 0
pickupTask 2 1002 世外桃源的挑战 </u击杀[恶魔领主·伏地魔]/u/fcolor=250>[<$str(u502)>/10]

[@刷新任务]
#act
mov u502 2
synchronizationTaskStatus 1002 世外桃源的挑战 </u击杀[恶魔领主·伏地魔]/u/fcolor=250>[<$str(u502)>/10]

接取或完成任务触发：

--------------------------------------------------------------------------------
功能: 接取或者完成某个任务时触发
格式: [@PICKUPTASK任务编号]
说明: 写在QFunction-0脚本中，当接取对应任务时触发

格式: [@FINISHTHETASK任务编号]
说明: 写在QFunction-0脚本中，当完成对应任务时触发

接取和完成任务命令：

--------------------------------------------------------------------------------
功能: 接任务命令和完成任务命令
格式: PICKUPTASK 参数1 参数2 参数3 参数4
说明:参数1-任务类型（1主线2日常3支线） 参数2-任务编号（自定义） 参数3-任务名称 参数4-任务目标（支持变量支持颜色）

格式: FINISHTHETASK 任务编号
说明:完成指定编号的任务

点击主界面上快捷任务栏中的任务触发：

--------------------------------------------------------------------------------
功能: 点击主界面任务栏中的任务触发到对应的@块
格式: [@TASK任务编号]
说明:写在QFunction-0脚本中

任务状态检测命令：

--------------------------------------------------------------------------------
功能: 检测是否接取过某个任务：
格式: CHECKPICKUPTASK 任务编号
说明:检测对应编号的任务是否接取过，如果接取过则检测通过

功能: 检测是否在任务进行中：
格式: CHECKTASKINPROGRESS 任务编号
说明:检测对应编号的任务是否在进行中，如果在进行中则检测通过

功能: 检测是否完成了某个任务：
格式: CHECKFINISHTHETASK 任务编号
说明:检测对应编号的任务是否已经完成，如果已完成则检测通过

将任务状态同步至界面中：

--------------------------------------------------------------------------------
功能: 当任务进度发生变化时，这时候需要这个命令来同步界面显示状态：
格式: SYNCHRONIZATIONTASKSTATUS 参数1 参数2 参数3
说明:参数1-任务编号 参数2-任务名称 参数3-任务目标

;QMission-0.txt 此脚为任务脚本放在Market_Def目录，人物每次登录时都会执行[@Login]

首先到M2-工具-任务NPC配置-增加任务NPC页面。例如：增加“主线任务”他对应的脚本字段就是[@主线任务]

[@Login]

[@主线任务]
归来任务\
<归来任务/@生存的诀窍>\
主线任务\
<生存的诀窍/@生存的诀窍>\

[@支线任务]
支线任务\
<等级2 寻找炼金师/@寻找炼金师>\
<等级3 王师弟子/@王师弟子>\
<等级4 新手大礼包/@新手大礼包>\
<等级5 进入庄园/@进入庄园>\
<等级5 天关寻宝/@天关寻宝>\

[@日常活动]
日常活动\
<玛法巡游（每日一次）/@玛法巡游>\
<地下夺宝/@地下夺宝>\
<除魔任务（每日一轮）/@除魔任务>\
<历练任务（每日一次）/@历练任务>\
<每日巡游任务/@每日巡游任务>\
<生存战（每日13：50，16：50开放）/@生存战>\
<每日探索任务（每日一次）/@每日探索任务>\
<闯关夺宝（每日18：30-19：00）/@闯关夺宝>\

[@生存的诀窍]
半兽人的贪婪和凶残打破了我们宁静的生活。\
战火蔓延到玛法大陆的每个角落。\
我们渴望驱除侵入者，我们期待重建家园。\
勇士，在这生死存亡的危机时刻，我们要团结\
在一起。为了帮助你成长，快去找你旁边\
的任务使者<比奇(333.262)/@比奇任务使者>或<边界村(287.614)/@边界村任务使者>或\
<银杏山谷(647.623)/@银杏山谷任务使者>吧！\

[@寻找炼金师]
在比奇（325，262），盟重（326，330），苍月岛\
庄园（65，72）处可以找到炼金师，在炼金师处使\
元宝可以获得大量经验、金刚石和组队卷轴。\
金刚石是锻造高级武器的必备物品。\
组队卷轴是去地下宫殿解救天工神剪的必须道具。\
<任务/FCOLOR=249>：到炼金师处查询元宝锻造的规则\
<完成任务NPC/FCOLOR=249>：比奇、盟重、苍月岛、庄园的炼金师\

[@王师弟子]
恭喜你已经达到了<$LEVEL>级，你可以到比奇（327，260）\
盟重（331，328）金牌尊者处领取一份王师弟子奖\
<任务/FCOLOR=249>：在武馆教头处了解“师傅如何收徒”\
<完成任务NPC/FCOLOR=249>：比奇、盟重的武馆教头\

[@新手大礼包]
比奇的书店老板（325，250）是个热心肠的人。\
尤其是对待新人的帮助。\
<任务/FCOLOR=249>：查看“5元宝换取新手大礼包”\
<完成任务NPC/FCOLOR=249>：比奇书店老板\

[@玛法巡游]
你每天可以在<盟重活动使者(339,335)/FCOLOR=249>处\
领取玛法巡游任务。\
只要在玛法大陆巡查两个小时后，\
就可以带<比奇国王/FCOLOR=249>那里领取大量的经验回馈。\
每日22点后，不可以接受巡查任务。\

[@地下夺宝]
你每天可以在<宫殿长廊送宝人偶(108，96)/FCOLOR=249>处\
参加地下夺宝活动。\ \

活动时间为：\
10：30-11：00\
13：30-14：00\
15：30-16：00\
20：30-21：00\
23：00-23：30\ \

活动细则：\
以上活动时间段内,通过<盟重镇魔首将(322,342)/FCOLOR=249>处\
携带地下组队卷轴选择单人或组队进入地下宫殿后\
点击送宝人偶，进入夺宝地图，\
活动时间结束前的5分钟宝物会出现在夺宝地图中，\
宝物出现后2分钟即可获得。\ \

有几率爆出以下宝物：\
<40级重装等高级装备/FCOLOR=249>\
<白金积分，热血积分/FCOLOR=249>\
<全系列藏宝图/FCOLOR=249>\
<47级新技能书，道士驯兽术/FCOLOR=249>\

[@除魔任务]
你每天可以在<盟重活动使者(339,335)/FCOLOR=249>处\
领取每日除魔任务。\
在一轮除魔任务（完成5次任务）中。\
每次完成任务后的奖励会越来越好。\
每天只能完成一轮的除魔任务。\ \

任务包括：\
前往石墓杀死<10只红野猪/FCOLOR=249>\
前往骨魔洞杀死<20只骷髅长枪兵/FCOLOR=249>\
前往霸者大厅杀死<3只白野猪/FCOLOR=249>\
前往兽人古墓杀死<15只骷髅/FCOLOR=249>\
前往赤月峡谷杀死<10只月魔蜘蛛/FCOLOR=249>\
前往比奇杀死<15只鸡/FCOLOR=249>\
前往毒蛇山谷杀死<5只虎蛇/FCOLOR=249>\
前往比奇杀死<8只食人花/FCOLOR=249>\
前往雷炎洞穴杀死<2只金杖蜘蛛/FCOLOR=249>\
前往死亡棺材杀死<2只邪恶钳虫/FCOLOR=249>\
前往魔龙西郊杀死<3只魔龙刀兵/FCOLOR=249>\ \

如果你觉得领取的任务太难，\
也可花费<50000金币/FCOLOR=249>在<盟重活动使者(339，335)/FCOLOR=249>处\
重新领取任务。\

[@历练任务]
你每天可以在盟重活动使者（339，335）处\
领取每日历练任务。\
按照指示前往各地找到恶魔看守人，支付一定的金币\
杀死指定的怪物即可完成历练任务领取奖励。\
每天只能只能完成一次历练任务。\ \

任务包括：\
25-29级：前往香石墓穴，杀四10只恶魔野猪\
香石墓穴恶魔看守人(37,30)，(84,47)\
任务奖励：500000经验\ \

30-34级：前往沃玛寺庙三层，杀死<10只恶魔沃玛/FCOLOR=249>\
沃玛寺庙恶魔看守人(46,46),(62,62)\
任务奖励：600000经验\ \

35-39级：前往地牢一层东，杀死<10只恶魔蜈蚣/FCOLOR=249>\
地牢一层恶魔看守人(75,108),(161,52)\
任务奖励：800000经验\ \

40-44级：前往石墓七层，杀死<10只恶魔楔蛾/FCOLOR=249>\
石墓恶魔看守人(30,72),(62,42)\
任务奖励：1000000经验\ \

45-49级：前往祖玛七层大厅，杀死<10只恶魔祖玛/FCOLOR=249>\
祖玛神殿恶魔看守人(11,13)\
任务奖励：1200000经验\ \

50-54级：前往牛魔寺庙大厅，杀死<10只恶魔牛魔/FCOLOR=249>\
牛魔寺庙恶魔看守人(15,16),(67,67)\
任务奖励：1200000经验\ \

55-59级：前往魔龙岭，杀死<10只恶魔魔龙/FCOLOR=249>\
魔龙岭恶魔看守人(213,117),(84,353)\
任务奖励：1500000经验\ \

60-70级：前往地下长廊，杀死<10只地下长廊恶魔/FCOLOR=249>\
地下长廊恶魔看守人(160,172)\
任务奖励：1500000经验\ \

支线任务：

[@接任务]

#IF
#ACT
PICKUPTASK 1 1001 打怪 打10只怪
PICKUPTASK 2 2001 在线领奖 领取在线30分奖励
PICKUPTASK 2 2002 在线领奖 领取在线90分奖励
PICKUPTASK 3 3001 打怪任务 打2只怪
PICKUPTASK 3 3002 打怪任务2 打3只怪
[@同步任务]
#IF
CHECKPICKUPTASK 3001
CHECKPICKUPTASK 3002
CHECKTASKINPROGRESS 3001
CHECKTASKINPROGRESS 3002
#ACT
SYNCHRONIZATIONTASKSTATUS 3001 打怪任务 打2只怪
SYNCHRONIZATIONTASKSTATUS 3002 打怪任务2 打3只怪
[@完成任务]
#if
CHECKTASKINPROGRESS 3001
CHECKTASKINPROGRESS 3002
not CHECKFINISHTHETASK 3001
not CHECKFINISHTHETASK 3002
#ACT
FINISHTHETASK 3001
FINISHTHETASK 3002


跳转，延迟

DELAYGOTO 时间(毫秒) 触发字段 换地图是否删除此延时(0或为空时=不删除 1=删除)

DELAYGOTO 20 @火龙珠 表示20毫秒

实例：
----------------------------------------------------------------------------

[@main]
<延迟跳转/@DelayGoto> <清除延迟/@ClearDelayGoto>\ \
<返回/@main>

[@DelayGoto]
#if
#act
DELAYGOTO 3000 @DelayLabel
#say
<清除延迟/@ClearDelayGoto>

[@DelayLabel]
#say
延迟跳转测试成功！\ \
<返回/@next>

[@ClearDelayGoto]
#if
#act
CLEARDELAYGOTO
#say
延迟跳转已清除.\ \
<返回/@next>

------------------------------------------------------------------------;


新转职业变性脚本

最新转职业脚本变性(含英雄转职和清理合击技能)

[@变性转职]
{
欢迎你光临：<$SERVERNAME>\ \
你是否对自己的英雄职业不满意？是的，我想<变更英雄职业/@变更英雄职业>\ \
你是否对现在的职业已经厌烦？ 是的，我想<变更职业/@职业变更>\ \
你是否想尝试做异性的滋味？ 是的，我想<变更性别/@性别变更>\ \
                                           <版权所有/@1>:D3dm2引擎\

[@性别变更]
#IF
gender man
#SAY
是不是做猛男没什么意思呀，想不想尝尝做淑女的滋味呀！！！\ \
『<尝尝/@towoman>』\ \
〖<返回/@main>〗 〖<关闭/@exit>〗
#ELSESAY
是不是做淑女挺累的，想不想尝尝做猛男的滋味呀！！！\ \
『<尝尝/@toman>』\ \
〖<返回/@main>〗 〖<关闭/@exit>〗

[@toman]
#IF
CHECKGAMEGOLD > 19
#ACT
GAMEGOLD - 20
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \
<返回/@main>
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足20颗。

[@towoman]
#IF
CHECKGAMEGOLD > 19
#ACT
GAMEGOLD - 20
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \
〖<返回/@main>〗 〖<关闭/@exit>〗
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足20颗。

[@职业变更]
#IF
CHECKJOB warrior
#SAY
是不是战士不好玩呀，换换别的职业试试吧！\ \
『<玩玩法师/@法师>』\
『<玩玩道士/@道士>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
CHECKJOB wizard
#SAY
是不是法师不好玩呀，换换别的职业试试吧！\ \
『<玩玩战士/@战士>』\
『<玩玩道士/@道士>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
CHECKJOB taoist
#SAY
是不是道士不好玩呀，换换别的职业试试吧！\ \
『<玩玩战士/@战士>』\
『<玩玩法师/@法师>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break

[@战士]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
CLEARSKILL
CHANGEJOB warrior
ADDSKILL 基本剑术
ADDSKILL 攻杀剑术
ADDSKILL 刺杀剑术
ADDSKILL 半月弯刀
ADDSKILL 野蛮冲撞
ADDSKILL 烈火剑法
ADDSKILL 狮子吼
SKILLLEVEL 基本剑术 + 3
SKILLLEVEL 攻杀剑术 + 3
SKILLLEVEL 刺杀剑术 + 3
SKILLLEVEL 半月弯刀 + 3
SKILLLEVEL 野蛮冲撞 + 3
SKILLLEVEL 烈火剑法 + 3
SKILLLEVEL 狮子吼 + 3
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@法师]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
CLEARSKILL
CHANGEJOB WIZARD
ADDSKILL 火球术
ADDSKILL 大火球
ADDSKILL 抗拒火环
ADDSKILL 地狱火
ADDSKILL 雷电术
ADDSKILL 疾光电影
ADDSKILL 诱惑之光
ADDSKILL 瞬息移动
ADDSKILL 火墙
ADDSKILL 爆裂火焰
ADDSKILL 地狱雷光
ADDSKILL 魔法盾
ADDSKILL 圣言术
ADDSKILL 冰咆哮
ADDSKILL 寒冰掌
ADDSKILL 灭天火
SKILLLEVEL 火球术 + 3
SKILLLEVEL 大火球 + 3
SKILLLEVEL 抗拒火环 + 3
SKILLLEVEL 地狱火 + 3
SKILLLEVEL 雷电术 + 3
SKILLLEVEL 疾光电影 + 3
SKILLLEVEL 诱惑之光 + 3
SKILLLEVEL 瞬息移动 + 3
SKILLLEVEL 火墙 + 3
SKILLLEVEL 爆裂火焰 + 3
SKILLLEVEL 地狱雷光 + 3
SKILLLEVEL 魔法盾 + 3
SKILLLEVEL 圣言术 + 3
SKILLLEVEL 冰咆哮 + 3
SKILLLEVEL 寒冰掌 + 3
SKILLLEVEL 灭天火 + 3
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@道士]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
CLEARSKILL
CHANGEJOB taoist
ADDSKILL 治愈术
ADDSKILL 精神力战法
ADDSKILL 施毒术
ADDSKILL 灵魂火符
ADDSKILL 幽灵盾
ADDSKILL 神圣战甲术
ADDSKILL 困魔咒
ADDSKILL 召唤骷髅
ADDSKILL 隐身术
ADDSKILL 集体隐身术
ADDSKILL 心灵启示
ADDSKILL 群体治疗术
ADDSKILL 召唤神兽
ADDSKILL 气功波
ADDSKILL 无极真气
SKILLLEVEL 治愈术 + 3
SKILLLEVEL 精神力战法 + 3
SKILLLEVEL 施毒术 + 3
SKILLLEVEL 灵魂火符 + 3
SKILLLEVEL 幽灵盾 + 3
SKILLLEVEL 神圣战甲术 + 3
SKILLLEVEL 困魔咒 + 3
SKILLLEVEL 召唤骷髅 + 3
SKILLLEVEL 隐身术 + 3
SKILLLEVEL 集体隐身术 + 3
SKILLLEVEL 心灵启示 + 3
SKILLLEVEL 群体治疗术 + 3
SKILLLEVEL 召唤神兽 + 3
SKILLLEVEL 气功波 + 3
SKILLLEVEL 无极真气 + 3
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@变更英雄职业]
想把你的英雄变更为其它职业的英雄？\
只要你交纳50颗元宝，我即可将你的英雄成功转职。\
但是合击技能将会被删除，只给予新职业的部分技能、\
是否同意将英雄转职呢？\

<我同意将英雄转职业/@同意英雄转职>\

[@同意英雄转职]
#IF
HAVEHERO
#ELSEACT
MESSAGEBOX 对不起，您没有英雄！
BREAK

#IF
H.CHECKONLINE
#ELSEACT
MESSAGEBOX 对不起，您的英雄不在线！
BREAK

#IF
CHECKGAMEGOLD > 49
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

#IF
H.CHECKJOB warrior
#SAY
是不是战士英雄不好玩呀，换换别的英雄试试吧！\ \
『<玩玩法师英雄/@法师英雄>』\
『<玩玩道士英雄/@道士英雄>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
H.CHECKJOB wizard
#SAY
是不是法师英雄不好玩呀，换换别的英雄试试吧！\ \
『<玩玩战士英雄/@战士英雄>』\
『<玩玩道士英雄/@道士英雄>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
H.CHECKJOB taoist
#SAY
是不是道士英雄不好玩呀，换换别的英雄试试吧！\ \
『<玩玩战士英雄/@战士英雄>』\
『<玩玩法师英雄/@法师英雄>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break

[@战士英雄]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
H.CLEARSKILL
H.CHANGEJOB warrior
H.ADDSKILL 英雄基本剑术 1
H.ADDSKILL 英雄攻杀剑术 1
H.ADDSKILL 英雄刺杀剑术 1
H.ADDSKILL 英雄半月弯刀 1
H.ADDSKILL 英雄野蛮冲撞 1
H.ADDSKILL 英雄烈火剑法 1
H.ADDSKILL 英雄狮子吼 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功将英雄转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@法师英雄]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
H.CLEARSKILL
H.CHANGEJOB WIZARD
H.ADDSKILL 英雄火球术 1
H.ADDSKILL 英雄大火球 1
H.ADDSKILL 英雄抗拒火环 1
H.ADDSKILL 英雄地狱火 1
H.ADDSKILL 英雄疾光电影 1
H.ADDSKILL 英雄雷电术 1
H.ADDSKILL 英雄诱惑之光 1
H.ADDSKILL 英雄瞬息移动 1
H.ADDSKILL 英雄火墙 1
H.ADDSKILL 英雄爆裂火焰 1
H.ADDSKILL 英雄地狱雷光 1
H.ADDSKILL 英雄魔法盾 1
H.ADDSKILL 英雄圣言术 1
H.ADDSKILL 英雄冰咆哮 1
H.ADDSKILL 英雄灭天火 1
H.ADDSKILL 英雄寒冰掌 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功将英雄转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@道士英雄]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
H.CLEARSKILL
H.CHANGEJOB taoist
H.ADDSKILL 英雄神圣战术 1
H.ADDSKILL 英雄群疗术 1
H.ADDSKILL 英雄集体隐身 1
H.ADDSKILL 英雄精神战法 1
H.ADDSKILL 英雄施毒术 1
H.ADDSKILL 英雄召唤骷髅 1
H.ADDSKILL 英雄召唤神兽 1
H.ADDSKILL 英雄灵魂火符 1
H.ADDSKILL 英雄隐身术 1
H.ADDSKILL 英雄幽灵盾 1
H.ADDSKILL 英雄治愈术 1
H.ADDSKILL 英雄困魔咒 1
H.ADDSKILL 英雄心灵启示 1
H.ADDSKILL 英雄气功波 1
H.ADDSKILL 英雄无极真气 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功将英雄转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK
}

QFunction-0.txt里的配置脚本

[@HeroLogon]
#if
$HERO.CHECKNAMELIST ..\QuestDiary\数据文件\英雄名单.txt
#act
$HERO.DELSKILL 破魂斩
$HERO.DELSKILL 劈星斩
$HERO.DELSKILL 雷霆一击
$HERO.DELSKILL 噬魂沼泽
$HERO.DELSKILL 末日审判
$HERO.DELSKILL 火龙气焰
$HERO.delnamelist ..\QuestDiary\数据文件\英雄名单.txt
#IF
$HERO.ISNEWHUMAN
$HERO.gender man
CHECKHEROJOB WIZARD
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 恶魔长袍(男) 1
$HERO.give 骨玉权杖 1
$HERO.TakeOnitem 骨玉权杖 1
$HERO.TakeOnitem 恶魔长袍(男) 0
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender WOMAN
CHECKHEROJOB WIZARD
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 恶魔长袍(女) 1
$HERO.give 骨玉权杖 1
$HERO.TakeOnitem 骨玉权杖 1
$HERO.TakeOnitem 恶魔长袍(女) 0
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender man
CHECKHEROJOB WARRIOR
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 战神盔甲(男) 1
$HERO.give 裁决之杖 1
$HERO.TakeOnitem 战神盔甲(男) 0
$HERO.TakeOnitem 裁决之杖 1
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender WOMAN
CHECKHEROJOB WARRIOR
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 战神盔甲(女) 1
$HERO.give 裁决之杖 1
$HERO.TakeOnitem 战神盔甲(女) 0
$HERO.TakeOnitem 裁决之杖 1
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender man
CHECKHEROJOB TAOIST
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 幽灵战衣(男) 1
$HERO.give 龙纹剑 1
$HERO.TakeOnitem 幽灵战衣(男) 0
$HERO.TakeOnitem 龙纹剑 1
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
$HERO.ISNEWHUMAN
$HERO.gender WOMAN
CHECKHEROJOB TAOIST
#ACT
CHANGEHEROLEVEL = 35
$HERO.ADDSKILL 英雄先天元力
$HERO.ADDSKILL 英雄酒气护体
$HERO.give 幽灵战衣(女) 1
$HERO.give 龙纹剑 1
$HERO.TakeOnitem 幽灵战衣(女) 0
$HERO.TakeOnitem 龙纹剑 1
$HERO.give 超级金创药 4
$HERO.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break


转职业变性脚本

[@SexJob]
请选择转换项目....\ \
『<转换性别/@ChangSex>』\
『<转换职业/@ChangJob>』\ \
〖<返回/@Main>〗 〖<关闭/@exit>〗

[@ChangSex]
如何你想换性别，这里提供转性别服务\
『<换性别/@ChangGender>』\ \
〖<返回/@MemberSexJob>〗 〖<关闭/@exit>〗

[@ChangGender]
#IF
gender man
#SAY
是不是做猛男没什么意思呀，想不想尝尝做淑女的滋味呀！！！\ \
『<尝尝/@towoman>』\ \
〖<返回/@ChangSex>〗 〖<关闭/@exit>〗
#ELSESAY
是不是做淑女挺累的，想不想尝尝做猛男的滋味呀！！！\ \
『<尝尝/@toman>』\ \
〖<返回/@ChangSex>〗 〖<关闭/@exit>〗
[@toman]
#IF
;CHECKLEVEL 50
#ACT
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \
<返回/@MemberSexJob>
#ELSESAY
你未到50级不能转性别！！！
[@towoman]
#IF
;CHECKLEVEL 50
#ACT
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \
〖<返回/@MemberSexJob>〗 〖<关闭/@exit>〗
#ELSESAY
你未到50级不能转性别！！！
;=========================================================================
[@changjob]
如何你想换一换职业，这里提供转职业服务，\
<注:>会员才能具有转职业的功能！！！\ \
『<换职业/@Chang>』\ \
〖<返回/@main>〗

[@Chang]
#IF
checkjob warrior
#SAY
是不是做武士不好玩呀，换换别的试试吧！\ \
『<玩玩法师/@ToWizard>』\
『<玩玩道士/@Totaos>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
checkjob wizard
#SAY
是不是做魔法师不好玩呀，换换别的试试吧！\ \
『<玩玩武士/@Towarr>』\
『<玩玩道士/@Totaos>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
checkjob taoist
#SAY
是不是做道士不好玩呀，换换别的试试吧！\ \
『<玩玩武士/@Towarr>』\
『<玩玩法师/@ToWizard>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
[@Towarr]
#if
#ACT
CHANGEJOB Warrior
#SAY
呵呵，你已经变成一位武士了。\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#elsesay
你不是会员！！！\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
[@ToWizard]
#if
#ACT
CHANGEJOB Wizard
#SAY
呵呵，你已经变成一位魔法师了。\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#elsesay
你不是会员！！！\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
[@Totaos]
#if
#ACT
CHANGEJOB Taoist
#SAY
呵呵，你已经变成一位道士了。\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗


祝福语脚本

[@@SendMsg]
#if
checkgold 10000
#act
take 金币 10000
SETSENDMSGFLAG
#elsesay
穷鬼，一边站着。\ \
<返回/@main>

注：只能在普通NPC上发祝福语，国王系NPC将不能使用


元宝转帐

(@@dealgold)
[@main]
<进行元宝转帐/@dealgamegold>\
<关闭/@exit>

[@dealgamegold]
#IF
#ACT
STARTTAKEGOLD

[@startdealgold]
#IF
#SAY
<$DEALGOLDPLAY>与你交易，请<输入转帐/@@dealgold>数量\
<返回/@main>

[@dealgoldpost]
对不起,需要交易的人没站好位置！\
<返回/@main>

[@dealgoldFail]
对不起，你的元宝数量没有这么多！\
<返回/@exit>

[@dealgoldInputFail]
非法操作，交易失败！

[@dealgoldPlayError]
转帐失败！


烟花脚本实例[!]

数据库设置

一心一意;2;1;1;79;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
心心相印;2;1;1;80;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
飞火流星;2;1;1;81;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
浪漫星雨;2;1;1;82;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
绮梦幻想;2;1;1;83;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
如梦似雾;2;1;1;84;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
长空火舞;2;1;1;85;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
庆典蛋糕;2;1;1;86;0;0;1001;5000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;

SHOWEFFECT 类型(79~86)

这个范例支持持久就是次数10次。不想支持次数把类型2修改为31即可。

QFunction-0 下增加如下：

[@StdModeFunc79]
#IF
#ACT
Gmexecute showeffect 79
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc80]
#IF
#ACT
Gmexecute showeffect 80
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc81]
#IF
#ACT
Gmexecute showeffect 81
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc82]
#IF
#ACT
Gmexecute showeffect 82
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc83]
#IF
#ACT
Gmexecute showeffect 83
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc84]
#IF
#ACT
Gmexecute showeffect 84
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc85]
#IF
#ACT
Gmexecute showeffect 85
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc86]
#IF
#ACT
Gmexecute showeffect 86
SENDMSG 0 <$USERNAME>在:%m%x:%y处放庆典蛋糕了!大家快去看拉


挑战功能

说明:没有等级限制,只在双方面对面,即可挑战,挑战时间5分钟,在挑战时间内没有分出胜负的,直接随机传送.
     增加地图参数 FIGHT4 (挑战地图),此参数禁止召唤英雄,死亡不掉落物品,不增加PK值.
     M2\查看\列表信息 中可设置禁止挑战的物品.
     挑战时双方都不可以使用英雄,所有药品
     挑战胜,所有之前押的物品归胜方所有

相关脚本命令:
功能:移动到挑战地图
格式:CHALLENGMAPMOVE 地图名 X Y

功能:没有挑战地图可移动,则退回抵押的物品
格式:GETCHALLENGEBAKITEM

//----------------------------------------------------------------------
QFunction-0.txt 文件

[@Challenge]
#IF
CHECKMAPHUMANCOUNT EM029A = 0
#ACT
CHALLENGMAPMOVE EM029A 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029B = 0
#ACT
CHALLENGMAPMOVE EM029B 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029C = 0
#ACT
CHALLENGMAPMOVE EM029C 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029D = 0
#ACT
CHALLENGMAPMOVE EM029D 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029E = 0
#ACT
CHALLENGMAPMOVE EM029E 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029F = 0
#ACT
CHALLENGMAPMOVE EM029F 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029G = 0
#ACT
BREAK
CHALLENGMAPMOVE EM029G 14 15
#IF
CHECKMAPHUMANCOUNT EM029H = 0
#ACT
CHALLENGMAPMOVE EM029H 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029I = 0
#ACT
CHALLENGMAPMOVE EM029I 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029J = 0
#ACT
CHALLENGMAPMOVE EM029J 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029K = 0
#ACT
CHALLENGMAPMOVE EM029K 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029L = 0
#ACT
CHALLENGMAPMOVE EM029L 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029M = 0
#ACT
CHALLENGMAPMOVE EM029M 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029N = 0
#ACT
CHALLENGMAPMOVE EM029N 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029O = 0
#ACT
CHALLENGMAPMOVE EM029O 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029P = 0
#ACT
CHALLENGMAPMOVE EM029P 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029Q = 0
#ACT
CHALLENGMAPMOVE EM029Q 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029R = 0
#ACT
CHALLENGMAPMOVE EM029R 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029S = 0
#ACT
CHALLENGMAPMOVE EM029S 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029T = 0
#ACT
CHALLENGMAPMOVE EM029T 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029U = 0
#ACT
CHALLENGMAPMOVE EM029U 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029V = 0
#ACT
CHALLENGMAPMOVE EM029V 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029W = 0
#ACT
CHALLENGMAPMOVE EM029W 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029X = 0
#ACT
CHALLENGMAPMOVE EM029X 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029Y = 0
#ACT
CHALLENGMAPMOVE EM029Y 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029Z = 0
#ACT
CHALLENGMAPMOVE EM029Z 14 15
BREAK
#IF
#ACT
goto @Challenge_Fail

[@Challenge_Fail]
#IF
#ACT
GETCHALLENGEBAKITEM
#SAY
当前地图人数已经满员!请稍后再试,谢谢!\

;挑战胜利者执行..
[@Challenge_Win]
#IF
#ACT
SendMsg 5 挑战胜利..
-------------------------------------------------------------------------------
MapInfo.txt文件

[EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029A|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029B|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029C|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029D|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029E|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029F|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029G|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029H|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029I|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG


魔王岭脚本

天下第一脚本

修改MerChant.txt 配置文件

NPC名称支持变量显示(只能使用全局变量A和T两种字符串类型，其它类型无效，请参照天下第一设置)

直接给变量写值NPC就会自动更名

例如：

天下第一战士 3 321 340 A14 0 35 0 0 0
天下第一战士 3 324 340 A15 0 36 0 0 0
天下第一法师 3 327 340 A16 0 37 0 0 0
天下第一法师 3 330 340 A17 0 38 0 0 0
天下第一道士 3 333 340 A18 0 39 0 0 0
天下第一道士 3 336 340 A19 0 40 0 0 0

脚本

[@main]
#if
#act
MOV A14 <$USERALLNAME>\天下第一战士


收徒脚本--暂不支持

收徒脚本

[@main]

#ACT
#SAY
<><我想拜师/@master>\
<><离开/@exit>\

[@master]
#ACT
#SAY
<>想拜师呀，你要拜的师傅来了没有？\
<>输入师傅的名字，开始拜师。\
<><输入师傅名字/@@InputStringMaster>\
<><我再想想/@exit>\
<><返回/@main>\

[@InputStringMaster]
#if
checkMasterName
#act
goto @agree
#elseact
MESSAGEBOX 　\\角色名不存在，请检查输入！

[@agree]
#if
checkismaster;
#say
TA已经是别人的师傅了！！！\ \
<返回/@main>
#act
break

#if
checkmaster;
#say
你都已经拜了别人为师，怎么还拜师！！！ \ \
<返回/@main>
#act
break

#if
checkposemaster;
#say
你找了个什么人做师傅，怎么现在还是别人的徒弟？\ \
<返回/@main>
#act
break
#if
CHECKPOSEDIR 2 3 <str($smastername)> <$username>
#say
师傅怎么没在你身边啊，都站得离我近一点。\
<返回/@main>
#act
break

#if
checklevel 160
#say
你都超过160级了还要找师傅？\ \
<返回/@main>
#act
break

#if
checkposelevel <$STR(smastername)> > 100 ;
#elsesay
你找个什么师傅呀，等级还不到200级？\ \
<返回/@main>
#elseact
break

#if
#act
master

[@StartGetMaster]
#say
拜师仪式正式开始。\ \
你是否确认拜师？\ \
<确认/@RequestMaster>

[@StartMaster]
#say
拜师仪式正式开始。\ \
对方已经向你提出拜师请求。\ \

[@RequestMaster]
#if
#act
master requestmaster

[@WateMaster]
#say
你已向对方请求拜师，请耐心等待对方的答复。

[@RevMaster]
#say
对方想拜你为师，你是否想收此人为徒？ \ \
<同意/@ResposeMaster> \ \
<不同意/@ResposeMasterFail>

[@ResposeMaster]
#if
#act
master responsemaster ok

[@ResposeMasterFail]
#if
#act
master responsemaster fail

[@EndMaster]
#say
拜师成功，你们俩已经是师徒关系了。\ \
<关闭/@exit>

[@EndMasterFail]
#say
拜师失败，拜师请求被拒。\ \
<关闭/@exit>


沙城主公告

将下面的放到沙皇宫的NPC脚本里就行了

(@@sendmsg)
[@main]
沙巴克当前归<$OWNERGUILD>所有，由<$LORD>统治管理。\
现在金库中所存的金币数量为:<$CASTLEGOLD>，今天的收入为: <$TODAYINCOME>\ \

『<修改城名/@@castlename>』 『<城主公告/@@sendMsg>』\\
『<取回资金/@@withdrawal>』 『<存入资金/@@receipts>』\
『<控制城门/@treatdoor>』 『<修理城门和城墙/@repaircastle>』\
『<雇用弓箭手/@hirearchers>』\ \
〖<取消/@exit>〗\
[@@sendMsg]
#if
checkcastlegold ? 100000
#act
takecastlegold 100000
SETSENDMSGFLAG
#elsesay
城内资金不足，不要乱用钱。\ \
『<返回/@main>』

[@treatdoor]
城门当前状态为:『<$CASTLEDOORSTATE>』\ \
『<关城门/@closemaindoor>』\
『<开城门/@openmaindoor>』\ \
〖<返回/@main>〗\

[@openmaindoor]
城门已经打开。\ \
〖<返回/@treatdoor>〗\

[@closemaindoor]
城门已经关闭。\ \
〖<返回/@treatdoor>〗\

;--------------------------------------------------
;荐府 包访

[@repaircastle]
请选择要修理的位置？\ \
『<修理城门/@repairdoor>』\
『<修理城墙/@repairwalls>』\ \
〖<返回/@main>』\

[@repairdoor]
修理城门所需费用为:『<$REPAIRDOORGOLD>』金币。\ \
『<修理城门/@repairdoornow>』\
『<返回/@repaircastle>』\

[@repairwalls]
修理城墙所需费用为:『<$REPAIRWALLGOLD>』金币。\ \
『<修理城墙/@repairwallnow1>』\
『<修理城墙/@repairwallnow2>』\
『<修理城墙/@repairwallnow3>』\ \
〖<返回/@repaircastle>』\

[@hirearchers]
雇用弓箭手可保护城堡的安全，并维护城堡的治安。\
每个弓箭手的雇用费用为『<$ARCHERFEE>』金币。\
请选择要雇用弓箭手放置位置: \ \
『<城墙左弓箭手三/@hirearchernow1>』, 『<城墙左弓箭手二/@hirearchernow2>』, 『<城墙左弓箭手一/@hirearchernow3>』\
『<城墙右弓箭手一/@hirearchernow4>』, 『<城墙右弓箭手二/@hirearchernow5>』, 『<城墙右弓箭手三/@hirearchernow6>』\
『<城门左弓箭手/@hirearchernow9>』, 『<城门左弓箭手/@hirearchernow10>』, 『<城门右弓箭手/@hirearchernow11>』, 『<城门右弓箭手/@hirearchernow12>』\
『<皇宫左弓箭手/@hirearchernow7>』, 『<皇宫右弓箭手/@hirearchernow8>』\
『<返回/@main>』\


人物颜色发型

[@HumFace]
请选择美容项目....\ \
『<名称颜色/@changcolor>』\
『<换 发 型/@ChangHair>』\ \
〖<返回/@main>〗

[@ChangColor]
是不是觉得自己名称的颜色太单调了，换换试试！\ \
『<复原/@Color255>』\
『<蓝色/@Color0>』 『<绿色/@Color1>』 『<黄色/@Color2>』 『<橙色/@Color3>』\
『<土黄/@Color4>』 『<红色/@Color5>』 『<淡兰/@Color6>』 『<淡绿/@Color7>』\ \
〖<返回/@MemberFace>〗 〖<关闭/@exit>〗

[@Color255]
#ACT
CHANGENAMECOLOR 255
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color0]
#ACT
CHANGENAMECOLOR 252
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color1]
#ACT
CHANGENAMECOLOR 217
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color2]
#ACT
CHANGENAMECOLOR 251
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color3]
#ACT
CHANGENAMECOLOR 253
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗

[@Color4]
#ACT
CHANGENAMECOLOR 125
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗

[@Color5]
#ACT
CHANGENAMECOLOR 249
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗
[@Color6]
#ACT
CHANGENAMECOLOR 254
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗
[@Color7]
#ACT
CHANGENAMECOLOR 250
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗
[@ChangHair]
#IF
gender man
#ACT
goto @ChangHairMan
#ELSEACT
goto @ChangHairWoman
[@ChangHairMan]
想不想来个光头呀，酷呆了！！！\ \
『<光头/@hairman0>』\
『<长头发/@hairman1>』\ \
〖<返回/@MemberFace>〗 〖<关闭/@exit>〗
[@hairman0]
#ACT
HAIRSTYLE 0
#SAY
呵呵，光头是不是很酷呀！！！ \ \
〖<返回/@ChangHairMan>〗
[@hairman1]
#ACT
HAIRSTYLE 1
#SAY
呵呵，你的发型已经改变了... \ \
〖<返回/@ChangHairMan>〗

[@ChangHairWoman]
『<短发型/@hairWoman0>』\
『<长发型/@hairWoman1>』\ \
〖<返回/@MemberFace>〗 〖<关闭/@exit>〗
[@hairWoman0]
#ACT
HAIRSTYLE 0
#SAY
呵呵，你的发型已经改变了... \ \
〖<返回/@ChangHairWoman>〗 〖<关闭/@Exit>〗
[@hairWoman1]
#ACT
HAIRSTYLE 1
#SAY
呵呵，你的发型已经改变了... \ \
〖<返回/@ChangHairWoman>〗 〖<关闭/@Exit>〗


酒神弟子完整脚本[!]

以下为酒神弟子完整脚本:
[@Main]
我是玛法酒神的嫡传大弟子,也是这家酒馆的老板.\
这次回来正式受了师父的托付,将玛法的古老武学内功,在玛法大陆\
传播开来.当你学习内功并通过修炼,使内功等级逐渐升高后,你的\
战斗力会获得极大的提升.怎么样?有没有兴趣来学习内功?\
<我要学习内功/@学习内功> <兑换玛法珍酿>\
<内功是什么?/@内功说明> <兑换精元丹>\

[@学习内功]
哦?有心思学习这心法了?\
算你有眼光,学习了内功,实力大增,到时候莫说,\
击败肆虐玛法的邪恶生物,就是翻越过雪山,\
找到回家之路也不是不可能.\
那你是想自己学习还是你的英雄学习呢?\
请注意,只有你自己学会内功后,我才会教你的英雄内功.\
<我自己学习/@自己学习> <让我的英雄学吧/@英雄学习>\
<不,我是想将玛法内功心法还给你>\
<返回/@EXit>

[@自己学习]
#if
CHECKREADSKILLNG
#ACT
MESSAGEBOX 你还想再学习?
#ELSEACT
goto @自己学习1

[@自己学习1]
#IF
;检查所需物品
checkitem 玛法内功心法 1
#ACT
take 玛法内功心法 1
READSKILLNG
#ELSEACT
MESSAGEBOX 没有玛法内功心法,你还想学习?

[@英雄学习]
#if
H.CHECKREADSKILLNG
#ACT
MESSAGEBOX 英雄还想再学习?
#ELSEACT
goto @英雄学习1

[@英雄学习1]
#IF
;检查所需物品
H.checkitem 玛法内功心法 1
#ACT
H.take 玛法内功心法 1
H.READSKILLNG
#ELSEACT
MESSAGEBOX 没有玛法内功心法,你还想学习?

[@ReadNGOK]
你学会内功!

[@ReadNGHeroOK]
你的英雄学会内功!

[@ReadNGFail]
你的已经学会内功了呀!

[@ReadNGHeroFail]
你尚未招出你的英雄,或者你的英雄已经学会内功了呀!

[@内功说明]
三龙卫的神威早已铭记在了每个玛法人的心头,他们当年所使用的\
绚丽招式多已经流传于当今的玛法大陆,在不久前几种三龙卫的几乎\
失传的绝技也从藏经阁出世,再度扬威江湖.不过人们所不知道的是\
昔年三龙卫之所以能够扬威玛法,不仅仅靠他们精妙的招式,更是\
因为他们雄厚的内功.随着三龙卫的失踪,这些内功的秘密,也随之\
失传.但只有一种人,他们中间还依旧流传着三龙卫内功的秘密,\
他们,便是三龙卫的后裔!\\

<莫非你就是三龙卫的后裔?/@三龙卫的后裔>

[@三龙卫的后裔]
不,不,我当然不是那些英雄的后裔,我的师父才是!我师父的名号\
相信你一定听过,他就是玛法大陆上酒的传播者,三十年前的第一\
勇士玛法酒神.当年师父正是凭借着他内外双修的高深功力,\
在玛法大陆上横行无阻.这些年来,师父他一直在遵循着他的祖先\
三龙卫的遗志,试图翻越雪山,寻找回家的路.然而,自然之力并非\
人力可敌,师父花了三十年,也不过探索了大雪山一隅,\
为此,他决定从他这代开始,打破三龙卫家族的族规.\ \

<三龙卫的禁密武学从此可以外传了?/@禁密武学外传>

[@禁密武学外传]
不错,师父他相信人定胜天,只要敢于打破常规,必可以找出一条\
回家的道路.因此,师父派我,他的嫡传大弟子,来到盟重酒馆\
这个人来人往的地方,寻找有缘人,将内功的奥妙传播开来.\
一个人找不到回家的路,但相信一万人百万人,一定可以在绵延的\
雪山中,寻找到一条路,通向我们玛法文化的根源!\ \

<我相信我们会找到回家的路的> <返回>


结婚脚本

[@main]
<我想结婚/@marry>\
<我想离婚/@unmarry>\ \
<离开/@exit>

[@marry]
求婚者必须是男性且拥有求婚戒指，\
你准备好求婚了吗？\ \
<准备好了/@agree>\
<下次再来/@exit>\ \ \
<返回/@main>

[@agree]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>
#if
checkposemarry
#say
对方已经结过婚了，是不是想犯重婚罪呀！！！\ \
<返回/@main>
#act
break

#if
gender man
#elsesay
只有男的向女的求婚，还没见过大姑娘向小伙子求婚的。\ \
<返回/@main>
#elseact
break

#if
checkposegender 男
#say
你变态呀！！！想搞同性恋！！！ \ \
<返回/@main>
#act
break

#if
checkposedir 2
#elsesay
你们二个面对面站好呀，不要乱动。\ \
<返回/@main>
#elseact
break

#if
checklevel 40
#elsesay
结婚要求你的等级必须40级或以上，小伙子努力练好级再来找我。\ \
<返回/@main>
#elseact
break
#if
checkposelevel > 34
#elsesay
你的对象还没成年，等她长大点再来吧！小伙子不要心急嘛！\ \
<返回/@main>
#elseact
break
#if
checkitemw 求婚戒指 1
#elsesay
你没求婚戒指，弄到求婚戒指再来找我吧！！！\ \
<返回/@main>
#elseact
break

#if
#act
takew 求婚戒指 1
marry

[@StartMarry]
#if
checkmarry
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>
#act
break

#if
gender man
#act
break
#say
婚礼现在正式开始。\ \
你愿意娶对方为妻，并照顾她一生一世吗？\ \
<我愿意/@RequestMarry>

#if
gender
#act
break
#say
婚礼现在正式开始。\ \
请耐心等待你心爱的人向你求婚\ \

[@RequestMarry]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#act
marry requestmarry
[@WateMarry]
你已向对方求婚，请耐心等待对方的答复。

[@RevMarry]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#say
对方向你求婚，你是否答应嫁给他？ \ \
<我愿意/@ResposeMarry> \
<我不愿意/@ResposeMarryFail>
[@ResposeMarry]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#act
marry responsemarry ok

[@ResposeMarryFail]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#act
marry responsemarry fail
[@EndMarry]
你们二个已经成为了一对全法夫妻了。\ \
<关闭/@exit>
[@EndMarryFail]
结婚失败！\ \
<关闭/@exit>
[@MarryDirErr]
对方没站好位置

[@MarryCheckDir]
请站好位置\\

[@HumanTypeErr]
你变态呀，既然选择一个非人类作为结婚对象。

[@MarrySexErr]
你变态呀，既然同性恋。

;==========================================
离婚开始
[@unmarry]
#if
checkmarry
#act
unmarry
#elsesay
你都没结婚离什么婚？？\ \
<返回/@main>

;=======================================================
;双方离婚时没面对面站好显示的信息
[@UnMarryCheckDir]
要离婚是吧？离婚是二个人的事，必须二个人对面对站好位置，\
如果人来不了你只能选择强行离婚姻了。\ \
<我要强行离婚/@fUnMarry>\
<返回/@main>
;=======================================================
;对面位置不是人物时显示的信息
[@UnMarryTypeErr]
你对面站了个什么东西，怎么不太象人来的。\ \
<返回/@main>

;=======================================================
;开始离婚程序后，双方显示的信息
[@StartUnMarry]
#if
gender man
#act
BREAK
#say
是否确定真的要与你共事多年的妻子离婚吗？\ \
<确定/@RequestUnMarry>

#if
gender
#say
你的老公现在向我请求离婚，是不是愿意协议离婚？ \ \
<确定/@RequestUnMarry>
#act
break

;=======================================================
;发出离婚请求
[@RequestUnMarry]
#if
checkmarry
#act
unmarry requestunmarry
;=======================================================
;回应离婚请求
[@ResposeUnMarry]
#if
checkmarry
#act
unmarry responseunmarry

;===============================================
;请求离婚后显示的信息
[@WateUnMarry]
你已向对方发出离婚请求，请耐心等待对方的答复。

;===============================================
;请求离婚后对方显示的信息
[@RevUnMarry]
对方向你离婚请求，你是否答应离婚？ \ \
<我愿意/@RequestUnMarry>
<返回/@main>

;===============================================
;没结过婚的人点离婚后出的提示信息
[@ExeMarryFail]
你都没结过婚，跑来做什么？ \ \
[返回/@main]

;==============================================
;强行离婚
[@fUnMarry]
#if
checkitem 金条 1
checkmarry
#act
take 金条 1
unmarry requestunmarry force
#elsesay
要收一根金条的手续费，你没有金条，\
我不能让你离婚。\
<确定/@exit>
;==============================================
;离婚完成后的提示信息
[@UnMarryEnd]
呵呵，你已经脱离苦海了！！！ \ \
<退出/@exit>
[@asktime]
你调查结婚时间的请求已发出，\
请稍后。\
<确定/@exit>


LineNotice.txt彩色滚动公告[!]

例：
[253,0]自定义字体颜色公告！
<252,255>窗口顶部滚动公告！

格式1：[253,0]聊天框公告 0为背景色 253前景色
格式2：<252,255> 窗口顶部滚动公告,255为背景色 252前景色


记忆石设置方法[!]

功能演示：

物品分类号:31
SHAPE 值:1
AN字段是触发.这个根据自己版本设置.我们以设置为99为例子
QFunction-0.txt脚本下面

[@StdModeFunc99]
一： <记录当前坐标/@TAGMAPINFO1> <移动到/@PMOVE1> -> <$TAGMAPNAME1> <$TAGX1> <$TAGY1>\
二： <记录当前坐标/@TAGMAPINFO2> <移动到/@PMOVE2> -> <$TAGMAPNAME2> <$TAGX2> <$TAGY2>\
三： <记录当前坐标/@TAGMAPINFO3> <移动到/@PMOVE3> -> <$TAGMAPNAME3> <$TAGX3> <$TAGY3>\
四： <记录当前坐标/@TAGMAPINFO4> <移动到/@PMOVE4> -> <$TAGMAPNAME4> <$TAGX4> <$TAGY4>\
五： <记录当前坐标/@TAGMAPINFO5> <移动到/@PMOVE5> -> <$TAGMAPNAME5> <$TAGX5> <$TAGY5>\
六： <记录当前坐标/@TAGMAPINFO6> <移动到/@PMOVE6> -> <$TAGMAPNAME6> <$TAGX6> <$TAGY6>\ \
<成功传送后才会消失一点.安全无毒.放心使用>\
[@PMOVE1]
#ACT
TAGMAPMOVE 1
[@PMOVE2]
#ACT
TAGMAPMOVE 2
[@PMOVE3]
#ACT
TAGMAPMOVE 3
[@PMOVE4]
#ACT
TAGMAPMOVE 4
[@PMOVE5]
#ACT
TAGMAPMOVE 5
[@PMOVE6]
#ACT
TAGMAPMOVE 6
[@TAGMAPINFO1]
#ACT
TAGMAPINFO 1
GOTO @StdModeFunc99
[@TAGMAPINFO2]
#ACT
TAGMAPINFO 2
GOTO @StdModeFunc99
[@TAGMAPINFO3]
#ACT
TAGMAPINFO 3
GOTO @StdModeFunc99
[@TAGMAPINFO4]
#ACT
TAGMAPINFO 4
GOTO @StdModeFunc99
[@TAGMAPINFO5]
#ACT
TAGMAPINFO 5
GOTO @StdModeFunc99
[@TAGMAPINFO6]
#ACT
TAGMAPINFO 6
GOTO @StdModeFunc99


按地图列表移动

功能：
先设定每一张地图停留的地间，再把地图列表添加一下，人物会
从第一张地图开始一张一张移动到最后一张

例子：

[@Test]
#IF
#ACT
batchDelay 1 ;(暂停时间)
addbatch B102 ;步进地图名1
addbatch B103 ;步进地图名2
addbatch B104 ;步进地图名3
addbatch B105 ;步进地图名4
addbatch B106 ;步进地图名5
addbatch B107 ;步进地图名6
batchmove ;开始从第一个步进地图移动到最后一个步进地图(这里是6)


把行会加入攻城列表

格式: ADDTOCASTLEWARLIST 城堡名称 行会名称(行会名称为*号时所有行会加入到攻城列表) 天数(几天后开始攻城，该参数可以为空，为空时按照引擎设置的天数)

[@main]
#ACT
ADDTOCASTLEWARLIST 沙巴克 1


把人物加入行会

格式: ADDGUILDMEMBER 行会名称 人物名称(人物名称为空时把自己加入到行会)

[@main]
#ACT
ADDGUILDMEMBER 行会名称


编组地图传送

GROUPMAPMOVE 地图号 X Y 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)

[@main]
#IF
#ACT
GROUPMAPMOVE 3 333 333 1 @GROUPMAPMOVE

[@GROUPMAPMOVE]
#IF
#ACT
SENDMSG 6 组队传送

相关命令：
编组地图随机传送：GROUPMOVE
检查是否为组长：ISGROUPMASTER


编组地图随机传送

GROUPMOVE 地图号 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)

[@main]
#IF
#ACT
GROUPMOVE 3 1 @GROUPMOVE

[@GROUPMOVE]
#IF
#ACT
SENDMSG 6 组队传送

相关命令：
编组地图传送：GROUPMAPMOVE
检查是否为组长：ISGROUPMASTER


变量数据传递MOVEX

MOVEX这个命令和MOV使用一样，不过在多级脚本使用中不一样

多级脚本触发，存在2个人物：

一个是执行脚本的人物，另外一个是触发这个脚本的人物，也就是说一个脚本是人物A执行的，但是这个脚本是由人物B触发后才开始运行的
看下面的例子:

[@main]
#ACT
MOV S1 神话
S1.MOVEX S2 <$USERNAME>
SENDMSG 6 S2使用的是神话这个人物的，<$USERNAME>这个使用的是，谁点击这个脚本，就调用的谁的
SENDMSG 6 这个脚本存在2个人，执行脚本的人物S1和点击触发脚本的人物

<$CURRRTARGETNAME>.movex2 n$致命传递 <$str(n$致命一击)>

将触发者的<$str(n$致命一击)> 赋值给<$CURRRTARGETNAME>的 n$致命传递


播放人物效果

格式: PlayEffect 资源名称 时间

时间：为 -1 时持续存在，大于0时按时间销毁，计时单位为毫秒

[@main]
#ACT
PLAYEFFECT 0 0 10 1 300


播放网络MP3

说明: 播放网络上的MP3文件,或者本地MP3文件.
格式: PlayMP3 http://www.d3dm2.com/123.mp3
注意: 如果是本地文件会自动搜索客户端Music目录中同名文件.

[@main]
#IF
#ACT
PlayMusic 100.MP3


播放音乐

格式: playsound 文件位置 循环次数 播放模式(0播放给自己,1播放给全服,2播放给同一地图,,4播放给同屏人物)

[@main]
#ACT
PLAYSOUND Wav\1.wav 1 0


穿人模式

功能: 改变当前人物的穿人,穿怪模式.
格式: THROUGHHUM 模式 时间(秒)
模式: [-1=恢复/0=穿人穿怪/1=穿怪/2=穿人]

#IF
#ACT
ThroughHum 1 60
SendMsg 5 60秒之内可随意穿怪.


创建文件

格式: CREATEFILE 文件名称

[@main]
#ACT
CREATEFILE ..\QuestDiary\名称列表.txt
#SAY
名称列表创建成功


从文件中随机取文本

功能：
从文件中随机取文本。

格式：
 GETRANDOMLINETEXT 文件 字符串变量

;==========================================
;示例脚本
[@Main]
#If
#Act
GETRANDOMLINETEXT ..\QuestDiary\装备列表.txt <$STR(S0)>
#Say
取回的文本是： <$STR(S0)>
;==========================================


从指定文件中删除字符串[!]

功能：
从指定文件中删除字符串和从指定文件中增加字符串。

格式：
 AddTextList 文件位置 字符串
DelTextList 文件位置 字符串

;==========================================
;增加字符串
[@Test老格式]
#IF
#ACT
AddTextList ..\TestList.txt 您的名字

[@Test新格式]
#IF
#ACT
AddTextList ..\TestList.txt 您的名字 您的性别
;==========================================

;==========================================
;删除字符串

[@Test老格式]
#IF
#ACT
DelTextList ..\TestList.txt 您的名字

[@Test1新格式]
#IF
#ACT
DelTextList ..\TestList.txt 您的名字 您的性别
;==========================================

新格式 老格式都可以使用


打开NPC大对话框[!]

格式: OPENMERCHANTBIGDLGWIL文件序号图片序号是否可以移动(0,1)显示位置(0=左上角,1=右上角,2=左下角,3=右下角,4=居中) 微调坐标X 微调坐标Y 是否显示关闭按钮(2,3为关闭，其他为不关闭) 关闭按钮坐标X 关闭按钮坐标Y

例：

[@main]
#ACT
OPENMERCHANTBIGDLG 3 607 0 1 1 1 1
;根据下图中的WIL序号，3表示的是prguse2.wzl，WIL序号的计算是从0开始的,从0开始数prguse2.wzl在第三位,
;如果要调用其他素材，如果WIL资料里没有，可以先添加WIL文件到WIL资源列表，然后修改脚本的WIL文件序号，就可以调用对应的文件。
;这个脚本调用的是prguse2.wzl素材里的607这个素材，为NPC的对话框

什么是WIL文件序号？

具体可以在，M2-查看-列表信息二


打开OK对话框

格式:OPENUPGRADEDLG 显示的名称 X坐标 Y坐标

例：
[@main]
#ACT
OPENUPGRADEDLG 装备升级(显示的名称)

;打开可以放物品的对话框，也就是装备修理或出售物品的那个对话框
OPENUPGRADEDLG 装备升级(显示的名称)

;收回OK框中的物品
TAKEDLGITEM

;返回OK框中的物品到包裹
RECLAIMITEM

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM

SetNewItemValue 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)

< P>

< P>

[@老版通用OK框1]
#if
#ACT
OPENUPGRADEDLG 装备 200 -200

[@老版通用OK框]
#if
#ACT
OPENUPGRADEDLG 装备

< P>


打开个人商店脚本命令

OpenShopDlg 类型(0所有商店列表 1我的商店列表)

[@main]
#ACT
OpenShopDlg 0


打开商铺脚本命令

OpenSndaShopDlg

[@main]
#ACT
OpenSndaShopDlg


打开自定义NPC对话框[!]

openBigDialogBox

格式

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7
openBigDialogBox | 图片名 | 显示位置 | 微调坐标X | 微调坐标Y | 显示关闭 | 关闭按钮坐标X | 关闭按钮坐标Y

参数2扩展

显示位置,1

扩展参数1代表全屏显示

示例

#act
openBigDialogBox JueSe_BeiJinTu 4,1 0 0 1 -100 -100

#say
<text:hello:0:0>


发送屏幕滚动信息

功能:

发送屏幕滚动信息

格式:

SENDMOVEMSG 信息类型代码(0全局发送，1发送给个人) 字体颜色(0-255) 背景颜色(0-255) Y坐标 滚动次数 信息内容 是否置顶（0，否；1，置顶层级）

[@测试]
#if
#ACT
MOV S1 这个是屏幕滚动信息坐标在100
SENDMOVEMSG 1 253 2551003<这个是屏幕滚动信息坐标在100/FCOLOR=250>{<$STR(S1)>/FCOLOR=253}{<$USERNAME>/FCOLOR=254}<这个是屏幕滚动信息坐标在100/FCOLOR=69>
SENDMOVEMSG 1 253 255 350 1 这个是屏幕滚动信息坐标在350


发送屏幕中间大字体信息

功能: 在专用登录器屏幕的中间显示公告.
格式: SendCenterMsg 前景色 背景色 消息文字 模式 显示时间 倒计时标签
模式: 0=发送给自己 1=发送所有人物 2=发送行会 3=发送国家 4=发送当前地图 5=替换模式
说明: 设置倒计时标签时可执行自定义脚本功能.

例子:
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0

例子:显示30秒.
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0 30

执行倒计时标签(注意:文字提示中必须包含%d):
[@main]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d发放新手奖励. 0 30 @GiveNewHumanItem

;需要放QFunction脚本中
[@GiveNewHumanItem]
#IF
#ACT
Give 金条 1
Give 裁决之杖 1
Give 圣战戒指 2
Give 圣战手镯 2
Give 圣战头盔 1
Give 圣战项链 1
Give 天魔神甲 1

例子:替换模式
替换模式只在有倒计时标签时有效.

;以下例子说明如何使倒计时从新开始.
[@main]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d离开本地图. 0 600 @ExitMap

;执行替换模式使时间从新开始
[@main1]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d离开本地图. 5 600 @ExitMap


发送文字信息

功能：
利用NPC发送信息。

格式：
 SENDMSG 信息类型代码 字体颜色(0-255) 背景颜色(0-255) %s信息内容%d

信息类型代码：
1、发送普通红色广播信息。
2、发送普通红色广播信息，并显示NPC名称。
3、发送普通红色广播信息，并人物NPC名称。
4、在NPC头顶，显示普通说话信息。
5、发送红色信息给人物
6、发送绿色信息给人物
7、发送蓝色信息给人物

%s 代表人物名称
%d 代表NPC名称

命令格式：
[@test]
#IF
#ACT
SENDMSG 0 %s信息内容%d
SENDMSG 1 %s信息内容%d
SENDMSG 2 %s信息内容%d
SENDMSG 3 %s信息内容%d
SENDMSG 4 %s信息内容%d
SENDMSG 5 %s信息内容%d
SENDMSG 6 %s信息内容%d
SENDMSG 7 %s信息内容%d

;以下是自定义颜色

SENDMSG 0 249 47 %s信息内容%d
SENDMSG 1 249 255 %s信息内容%d
SENDMSG 2 249 253 %s信息内容%d
SENDMSG 3 249 47 %s信息内容%d
SENDMSG 4 249 47 %s信息内容%d
SENDMSG 5 249 47 %s信息内容%d
SENDMSG 6 249 47 %s信息内容%d
SENDMSG 7 249 47 %s信息内容%d

==================================================


返回OK框中的物品

格式: RECLAIMITEM

;返回OK框中的物品到包裹

例：
[@main]
#ACT
RECLAIMITEM


复活人物

格式: REALIVE

[@main]
#ACT
REALIVE


改变人体颜色

格式: SETBODYCOLOR 颜色(0~255)255时清除颜色 改变时长(秒)

[@main]
#ACT
SETBODYCOLOR 253
H.SETBODYCOLOR 253


改变人物攻击模式

ChangeAttatckMode (0~7)

;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击 6-红名攻击 7-国家攻击


改变人物状态

格式: MAKEPOSION 类型(0-5,0和1是绿毒和红毒 5是麻痹 12冰冻 13蛛网 其他无效) 时间(秒) 威力

例：
[@main]
#ACT
MAKEPOSION 5 10 10
#SAY
你被麻痹了

[@main]
#ACT
MAKEPOSION 12 10
#SAY
你被冰冻了

[@main]
#ACT
MAKEPOSION 13 10
#SAY
你被蛛网缠绕


改变用户模式

changeModeEx

改变角色当前模式(加buff)

标签:命令定义|changeModeEx

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
changeModeEx | buff | 有效时长 | 附加值 | 附加值 | 附加值
说明:
  • 参数1：buff类型
    • 1：无敌
    • 2：隐身，移动失效，可在 ..\Mir200\Tejieconfig\Tejieconfig.txt 中配置是否对玩家也有效（ invisibeltoplayers=1，对玩家隐身有效； invisibeltoplayers=0，对玩家隐身无效）
    • 3：HP增加
    • 4：MP增加
    • 5：攻击力增加
    • 6：魔法力增加
    • 7：道术力增加
    • 8：攻击速度
    • 9：禁止攻击
    • 10：锁定自己
    • 11：禁锢自己，参数3为范围大小
    • 12：冰冻，参数3为分母基数，数值越小概率越高，1为最高，参数4为对目标造成的冰冻时长
    • 13：蛛网，参数3为分母基数，数值越小概率越高，1为最高，参数4为对目标造成的蛛网时长
    • 14：防麻痹
    • 15：防禁锢
    • 16：防冰冻
    • 17：防蛛网
    • 18：麻痹，参数3为分母基数，数值越小概率越高，1为最高，参数4为对目标造成的麻痹时长
    • 19：护身，需要在 ..\Mir200\Tejieconfig\Tejieconfig.txt 中配置 shieldNew=0 ，停用新伤害飘字模式
    • 20：吸血，参数3值越大，吸血几率越高（0-100），参数4为伤害吸血比例（0-100），如参数4=50，攻击造成1000伤害，则吸血500
    • 21：吸蓝，参数3值越大，吸蓝几率越高（0-100），参数4为伤害吸蓝比例（0-100），如参数4=50，攻击造成1000伤害，则吸蓝500
    • 23：复活，参数2为复活时恢复的血量（0-100），装备上带有复活效果时，先触发命令的复活，再触发装备的复活
    • 24：护身，参数3为防护伤害百分比，参数4为耗蓝的百分比
    • 25：反弹伤害减少，参数3为减少值
    • 26：怨念，参数2为怪物受到怨念的时长，参数3为可以攻击并挂上怨念的时长
    • 118：对战士增伤万分比：最终伤害*(1+增伤)
    • 119：对法师增伤万分比：最终伤害*(1+增伤)
    • 120：对道士增伤万分比：最终伤害*(1+增伤)
    • 121：受战士攻击减伤万分比：最终伤害*(1-增伤)
    • 122：受法师攻击减伤万分比：最终伤害*(1-增伤)
    • 123：受道士攻击减伤万分比：最终伤害*(1-增伤)
    • 124：受玩家攻击伤害上限万分比：最大生命*比例
    • 125：对怪物增伤万分比：最终伤害*(1+增伤)
    • 126：伤害万分比：伤害值=最终伤害x伤害比例
    • 127：怪物攻击降低万分比
    • 128：麻痹抵抗比例万分比：麻痹概率-麻痹抵抗
    • 129：蛛网抵抗比例万分比：蛛网概率-蛛网抵抗
    • 130：被玩家击杀爆装概率降低万分比：爆装概率*击杀者增加目标爆率*(1-抗暴装比)
    • 131：冰冻抵抗比例万分比：冰冻概率-冰冻抵抗
    • 132：暴击抵抗百分比：暴击概率=攻击方暴击概率-受击方暴击抵抗
    • 133：暴击额外增伤
    • 134：受玩家暴击伤害减免：暴击伤害保底等于普通伤害
    • 135：怪物攻击降低光环（万分比），多个光环存在时，参数3的值按加法计算，参数4为生效范围
    • 137：定身，参数3为分母基数，数值越小概率越高，1为最高，参数4为对目标造成的定身时长
    • 138：防定身
    • 139：瘫痪
    • 141：防瘫痪
  • 参数2：有效时长，单位为秒，除了复活buff，其它buff的时长等于0时为失效
  • 参数3：附加值
  • 参数4：附加值
  • 参数5：附加值
注意：
  • 可在 ..\Mir200\Tejieconfig\Tejieconfig.txt 中配置 changeModeExTimeReset ，设置多次施加buff时是否刷新buff的时间（ changeModeExTimeReset=1，刷新时间； changeModeExTimeReset=0，默认不刷新）

特戒引擎脚本示例：：

[@无敌]
#act
changeModeEx 1 10
sendmsg 6 无敌，10秒

[@隐身]
#act
changeModeEx 2 10
sendmsg 6 隐身，10秒

[@HP增加]
#act
changeModeEx 3 10 600
sendmsg 6 加血上限600，10秒

[@MP增加]
#act
changeModeEx 4 10 600
sendmsg 6 加蓝上限600，10秒

[@物攻增加]
#act
changeModeEx 5 10 500
sendmsg 6 加物攻上限500，10秒

[@魔攻增加]
#act
changeModeEx 6 10 500
sendmsg 6 加魔攻上限500，10秒

[@术攻增加]
#act
changeModeEx 7 10 500
sendmsg 6 加术攻上限500，10秒

[@攻速增加]
#act
changeModeEx 8 10 100
sendmsg 6 加攻速100，10秒

[@禁止]
#act
changeModeEx 9 10
sendmsg 6 禁止，10秒

[@锁定]
#act
changeModeEx 10 10
sendmsg 6 锁定，10秒

[@禁锢]
#act
changeModeEx 11 10 3
sendmsg 6 禁锢自己，10秒，范围3

[@冰冻]
#act
changeModeEx 12 10 2 5
sendmsg 6 冰冻，10秒，概率1/2，冰冻5秒

[@蛛网]
#act
changeModeEx 13 10 2 5
sendmsg 6 蛛网，10秒，概率1/2，蛛网5秒

[@防麻痹]
#act
changeModeEx 14 10
sendmsg 6 防麻痹，10秒

[@防禁锢]
#act
changeModeEx 15 10
sendmsg 6 防禁锢，10秒

[@防冰冻]
#act
changeModeEx 16 10
sendmsg 6 防冰冻，10秒

[@防蛛网]
#act
changeModeEx 17 10
sendmsg 6 防蛛网，10秒

[@麻痹]
#act
changeModeEx 18 10 2 5
sendmsg 6 麻痹，10秒，概率1/2，麻痹5秒

[@护体]
#act
changeModeEx 19 10
sendmsg 6 护体，10秒

[@吸血]
#act
changeModeEx 20 10 100 50
sendmsg 6 吸血，10秒，100%几率，造成伤害50%的吸血量

[@吸蓝]
#act
changeModeEx 21 10 100 50
sendmsg 6 吸蓝，10秒，100%几率，造成伤害50%的吸蓝量

[@复活]
#act
changeModeEx 23 50
sendmsg 6 复活，50%恢复血量

[@护身]
#ACT
changeModeEx 24 10 100 100
sendmsg 6 护身，10秒，100%伤害吸收，100%扣蓝

[@反伤减少]
#ACT
changeModeEx 25 10 99
sendmsg 6 反伤，10秒，反伤值减少99

[@怨念]
#ACT
changeModeEx 26 10 60
sendmsg 6 怨念，怪物怨念持续10秒，60秒内攻击怪物有效

[@战士增伤]
#ACT
changeModeEx 118 10 5000
sendmsg 6 对战士增伤，10秒，增加50%

[@法师增伤]
#ACT
changeModeEx 119 10 5000
sendmsg 6 对法师增伤，10秒，增加50%

[@道士增伤]
#ACT
changeModeEx 120 10 5000
sendmsg 6 对道士增伤，10秒，增加50%

[@战士减伤]
#ACT
changeModeEx 121 10 6000
sendmsg 6 受战士攻击减伤，10秒，减少60%

[@法师减伤]
#ACT
changeModeEx 122 10 6000
sendmsg 6 受法师攻击减伤，10秒，减少60%

[@道士减伤]
#ACT
changeModeEx 123 10 6000
sendmsg 6 受道士攻击减伤，10秒，减少60%

[@受玩家伤害上限]
#ACT
changeModeEx 124 10 3000
sendmsg 6 玩家伤害上限，10秒，最大HP*30%

[@怪物增伤]
#ACT
changeModeEx 125 10 5000
sendmsg 6 对怪物增伤，10秒，增加50%

[@伤害比例]
#ACT
changeModeEx 126 10 13000
sendmsg 6 改变伤害比例，10秒，最终伤害*130%

[@怪物减伤]
#ACT
m.changeModeEx 127 10 13000
sendmsg 6 受到怪物攻击减伤，10秒，减少30%

[@麻痹抵抗]
#ACT
changeModeEx 128 10 5000
sendmsg 6 麻痹抵抗，10秒，概率减少50%

[@蛛网抵抗]
#ACT
changeModeEx 129 10 5000
sendmsg 6 蛛网抵抗，10秒，概率减少50%

[@爆装抵抗]
#ACT
changeModeEx 130 10 5000
sendmsg 6 被玩家击杀爆装抵抗，10秒，概率减少50%

[@冰冻抵抗]
#ACT
changeModeEx 131 10 5000
sendmsg 6 冰冻抵抗，10秒，概率减少50%

[@暴击抵抗]
#ACT
changeModeEx 132 10 50
sendmsg 6 暴击抵抗，10秒，受到暴击概率减少50%

[@暴击增伤]
#ACT
changeModeEx 133 10 100
sendmsg 6 暴击增伤，10秒，暴击额外造成100点伤害

[@暴击减伤]
#ACT
changeModeEx 134 10 100
sendmsg 6 暴击减伤，10秒，暴击减免100点伤害

[@减攻光环]
#ACT
changeModeEx 135 60 1000 5 5000
sendmsg 6 减攻光环，60秒，降低攻击10%，范围5，减伤上限为50%，光环可叠加

[@定身]

#act

changeModeEx 137 10 2 5

sendmsg 6 10秒内有几率造成目标定身，概率1/2，目标定身5秒

[@防定身]

#act

changeModeEx 138 10

sendmsg 6 防定身，10秒


个人定时器

功能：
个人定时器。

格式：
 SETONTIMER 定时器索引(0-255) 定时间隔（单位为秒）
SETOFFTIMER 定时器索引(0-255) //停止定时器

;==========================================
设置定时器
[@Test]
#IF
#ACT
SetOnTimer 0 20

QManage.txt:
[@OnTimer0]
#ACT
SendMsg 5 你目前位于%m的(%x：%y)
;==========================================

;==========================================
停止定时器
[@Test]
#IF
#ACT
SetOffTimer 0
;==========================================


给予带绑定状态装备[!]

功能：
给予带绑定状态装备。主要方便设置不能配带的装备绑定状态

格式：

格式:CheckItemBind 装备位置(-1~16,-1时为OK框中物品)
GiveStateItem 物品名称 项目1 项目2 项目3 项目4 项目5 项目6 项目7(0为正常,1为绑定) 数量

;项目1--禁止扔，项目2--禁止交易，项目3--禁止存，项目4--禁止修，项目5--禁止出售,项目6--禁止爆出的装备,项目7--丢弃消失

[@给一个绑定的装备]
#ACT
GiveStateItem 木剑 1 0 0 0 0 0 0 1
SENDMSG 6 给你一个绑定木剑并且禁止扔


更改人物颜色

功能：
更改人物颜色。

格式：
CHANGENAMECOLOR 颜色代码(0-255)

;==========================================
;设置人物的名称颜色
[@changeexp0]
#IF
#ACT
CHANGENAMECOLOR 2
#SAY
你的颜色已改变。
;==========================================


更改头发类型

功能：
更改头发类型

格式：
;============================
[@ChangeHair]
#if
#act
HAIRSTYLE 0
#say
你的头发已更改
;============================


更换性别

功能：
更换性别。

格式：
 CHANGEGENDER 性別(男 0 女 1)

;==========================================
[@toman]
#IF
#ACT
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \

[@towoman]
#IF
#ACT
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \


关闭NPC大对话框

格式: CLOSEMERCHANTBIGDLG

[@main]
#ACT
CLOSEMERCHANTBIGDLG


关闭或显示脚本命令提示没有戴指定物品

SETSHOWITEMMSG (0关闭，1显示)

用来关闭或显示，有的脚本命令会提示“你身上没有戴指定物品！！！”


关闭提示 你身上没有戴指定物品

SETSHOWITEMMSG (0关闭，1显示)

关闭提示 你身上没有戴指定物品


关闭自定义NPC对话框

CloseBigDialogBox


过滤全服提示信息

功能：
过滤全服提示信息

格式：
FILTERGLOBALMSG 是否过滤(0不过滤，1过滤)

[@main]
#IF
#ACT
FILTERGLOBALMSG 1
SENDMSG 6 开启过滤全服提示信息，你不在接受如SENDMSG、GuildNoticeMsg等等脚本命令发送的全服提示信息。


行会地图传送

GUILDMAPMOVE 地图号 X Y 最低等级
只有行会掌门，才可以使用

[@guildmapmove]
#if
#act
GUILDMAPMOVE 3 330 330 0


行会地图随机传送

GUILDMOVE 地图号 最低等级
只有行会掌门，才可以使用

[@guildmove]
#if
#act
GUILDMOVE 3 0


行会建设相关

修改行会建筑度:
格式： GUILDBUILDPOINT 控制符（+-）数字

修改行会人气度:
格式： GUILDAURAEPOINT控制符（+-）数字

修改行会安定度:
格式： GUILDSTABILITYPOINT控制符（+-）数字

修改行会繁荣度:
格式：GUILDFLOURISHPOINT控制符（+-）数字

检测行会建筑度：
格式： CHECKGUILDBUILDPOINT 控制符（<>=）数字

检测行会行会人气度:
格式： CHECKGUILDAURAEPOINT 控制符（<>=）数字

检测行会安定度:
格式： CHECKGUILDSTABILITYPOINT 控制符（<>=）数字

检测行会繁荣度：
格式: CHECKGUILDFLOURISHPOINT 控制符（<>=）数字

变量：
<$GUILDBUILDPOINT> 行会建筑度
<$GUILDAURAEPOINT> 行会人气度
<$GUILDSTABILITYPOINT> 行会安定度
<$GUILDFLOURISHPOINT> 行会繁荣度


获取对面人物的名字

说明: 获取对面人物的名字
格式: GetOppositeHumName 变量

#IF
#ACT
GetOppositeHumName S0
SendMsg 5 你对面的人物是: <$STR(S0)>


获取文本字符

GetRandomText 文件路径 变量


加入国家

格式：JoinNational (国家编号 0~100 0表示从当前国家中删除，也就是退出该国家)

;==========================================
[@main]
#IF
CheckNational 0
#ACT
JoinNational 1
SENDMSG 6 你成功加入<$NATIONNAME>，当前国家总人数:<$NATIONPEOPLE>
#ELASEACT
MESSAGEBOX 你已经加入了<$NATIONNAME>，是否要注销国籍？ @yes

[@yes]
#ACT
JoinNational 0
SENDMSG 6 你成功注销国籍

;==========================================


加入会员人物及时间

加入会员人物及时间： ADDUSERDATE 会员.txt

相关命令：
CHECKUSERDATE 会员.txt < 30 p0 p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1

删除会员人物及时间： DELUSERDATE 会员.txt


假人自动练功[!]

功能: 假人自动练功

格式:AutoUseMagic 技能ID 间隔秒。(必须是学过的技能，在非挂机状态，没有攻击目标的情况下才能正常练功)

[@main]
#ACT
AutoUseMagic 0 10


假人自动锁定目标

[@假人自动锁定目标]
#ACT
DUMMYAUTOTARGET 1
;假人使用这个命令后，搜索到攻击目标后，会自动锁定该目标
;DUMMYAUTOTARGET 参数(0关闭自动锁定,1开启自动锁定)


拣物品触发[!]

功能: 挂机命令

格式:ISDUPMODE (0或空时检测所有对象，1只检测人物)

范例地址：挂机范例脚本


捡取物品关联命令检测操作

LINKPICKUPITEM脚本命令
功能：可以对捡取的物品进行关联，该命令只能在捡取触发里[@PickUpItemX]使用

[@PickUpItem0]
#IF
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚捡取的物品进行检测，或操作

;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253

;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1

;修改后的参数，刷新到客户端
SENDUPGRADEITEM


将人物行会名加入列表

功能：
将人物行会名加入列表

格式：
==========================
[@addguildList]
#if
#act
ADDGUILDLIST guildlist.txt
==========================


脚本控制人物等级

功能：
调整人物等级。

格式：
 CHANGELEVEL 控制符(=,+,-) 等级数(1-500)

;==========================================
;设置人物等级
[@changelevel0]
#IF
#ACT
CHANGELEVEL = 80
#SAY
你的等级已经为80级了。
;==========================================

;==========================================
;增加人物等级
[@changelevel1]
#IF
#ACT
CHANGELEVEL + 1
#SAY
你的等级已经升了1级。
;==========================================

;==========================================
;降人物等级
[@changelevel2]
#IF
#ACT
CHANGELEVEL - 1
#SAY
你的等级已经降了1级。
;==========================================


脚本命令刷怪

mongenex命令：
1.地图id
2.x坐标
3.y坐标
4.怪物名字
5.范围
6.数量
7.颜色
8.颜色
9.没有
10.没有
11.怪物视野
12.属性倍率
13.模型大小
14.掉落倍率
15.怪物归属
16.是否可以攻击同国家的玩家(0或空不可以,1可以)
17.不同国家怪物是否可以互相攻击(0或空不可以,1可以)

格式:

MonGenEx 地图文件名称 X Y 怪物名称 范围 数量 是否内功怪物(0否,1是) 名称颜色(0~255) 国家ID(属于哪个国家的怪物，没有可以为空) 同一个国家玩家是否可攻击怪怪物(0不可以,1可以)
最后2个参数是国家怪物设置，如果没有可以留空

[@main]
#if
#act
MonGenEx 3 330 330 白野猪 12 10 0 255


脚本调整人物PK点

功能：
调整人物PK点数。

格式：
 CHANGEPKPOINT 控制符(=,+,-) PK点数

;==========================================
;将人物的PK点数设置为指定点数，不能为负数
[@changepkpoint0]
#IF
#ACT
CHANGEPKPOINT = 0
#SAY
你的PK点数已经清除。
;==========================================

;==========================================
;将人物的PK点数加100点数，不能为负数
[@changepkpoint1]
#IF
#ACT
CHANGEPKPOINT + 100
#SAY
你的PK点数已经增加100点。

;==========================================

;==========================================
;将人物的PK点数减100点数，不能为负数，如果人物点数小于100则指定为0
[@changepkpoint2]
#IF
#ACT
CHANGEPKPOINT - 100
#SAY
你的PK点数已经减少100点。
;==========================================


脚本调整升级经验

功能：
调整人物经验点数。

格式：
 CHANGEEXP 参数1(=,+,-) 参数2(经验值) 参数3(为空或0时不增加聚灵珠经验 1时同时聚灵珠经验)

;==========================================
;将人物的经验点数设置为指定点数，不能为负数
[@changeexp0]
#IF
#ACT
CHANGEEXP = 20000
#SAY
你当前的经验点数为 20000。
;==========================================

;==========================================
;将人物的经验点数加1000点数，不能为负数
[@changeexp1]
#IF
#ACT
CHANGEEXP + 1000
#SAY
你的经验点数已经增加1000点。

;==========================================

;==========================================
;将人物的经验点数减1000点数，不能为负数，如果人物点数小于1000则指定为0
[@changeexp2]
#IF
#ACT
CHANGEEXP - 1000
#SAY
你的经验点数已经减少1000点。
;==========================================


禁止骑马

在骑马触发里使用

[@OnHorse]
#ACT
HORSERIDINGBAN
SENGMSG 6 禁止骑马


开启第四个连击技能的命令[!]

功能：开启第四个连击技能的命令
格式：无
说明：
例：
[@main]
#if
CHECKOPENLASTSKILL
#say
第四个连击技能已经开启
#elseact
OPENLASTSKILL


扩展GIVE命令

给物品到用户包裹

GIVE 物品名称 数量 极品属性(13个参数，可以参考UPGRADEITEMEX命令 属性位置的介绍，或自己实际测试看效果) 元素属性(11个参数,从暴击机率开始)

例：

GIVE 布衣(男) 1 100|100|100|100|100|100|100|100|100|100|100|100|100 100|100|100|100|100|100|100|100|100|100|100|100|100


扩展MessageBox

MessageBox 信息 @确定 @取消

[@main]
#if
#act
MessageBox 是否确认要删除 @确定 @取消

[@确定]
点击的确定

[@取消]
点击的取消

messageBox增加信息对齐参数：/*0或空居中，/*1左对齐，/*2右对齐

messagebox 信息内容 /*0

messagebox 信息内容 @1 @2 /*1

messagebox 信息内容 @1 @2 @3 @4 /*2


扩展MOVR使用方法

功能：
扩展MOVR使用方法。

格式：
 MOVR 变量 数值1 数值2

;==========================================
MOVR G10 100 ;随机生成100以内的随机数.
MOVR G10 10 100 ;随机生成10-100之间随机数
MOVR G10 100 5000 ;随机生成100-5000之间随机数
MOVR G10 1000 9999 ;随机生成1000-9999之间随机数
;==========================================


练习技能

功能：
脚本增加技能。

格式：
 ADDSKILL 技能名称

;==========================================
;增加技能
[@addskill]
#IF
#ACT
ADDSKILL 雷电术
#SAY
你已经练习雷电术了。
;==========================================

相关命令：
删除技能：DELSKILL
检查技能：CHECKSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL


屏幕震动

屏幕震动命令格式:
SCENEVIBRATION 模式(0~4，0仅自己，1在线所有人，2屏幕范围内人物，3.当前地图上所有人 4.指定地图上所有人) 震级(1~3) 次数 地图ID(模式等于4时，需要该参数)

[@main]
#IF
#ACT
SCENEVIBRATION 0 1 1
SENDMSG 6 你的屏幕开始震动

[@main]
#IF
#ACT
SCENEVIBRATION 1 1 1
SENDMSG 6 在线所有人的屏幕开始震动

[@main]
#IF
#ACT
SCENEVIBRATION 2 1 1
SENDMSG 6 当前屏幕范围内的所有人的屏幕开始震动

[@main]
#IF
#ACT
SCENEVIBRATION 3 1 1
SENDMSG 6 当前地图所有人的屏幕开始震动

[@main]
#IF
#ACT
SCENEVIBRATION 4 1 1 3
SENDMSG 6 土城所有人的屏幕开始震动


清除SendCenterMsg DelayGoto

[@main]
#act
CLEARDELAYGOTO
sendmsg 6 DELAYGOTO延迟时清除

[@main]
#act
CLEARDELAYGOTO 1
sendmsg 6 SendCenterMsg倒计时清除


清除地图物品

功能：
 清理地图上指定名字的物品.

格式：
 CLEARITEMMAP 地图 X Y 范围 物品名称 (清除地图物品，不带物品名称则清除所有)

说明：
 物品名字等于*时表示指定范围内的所有物品.

;清除盟重安全区内的回城卷
[@main]
#IF
#ACT
CLEARITEMMAP 3 330 330 10 回城卷
#SAY
盟重安全区内的回城卷都被清除了。

清除盟重安全区内所有物品
[@main]
#IF
#ACT
CLEARITEMMAP 3 330 330 10
#SAY
盟重安全区内的所有物品都被清除了。


清除地图中的怪物

功能：
用于清除指定地图里的怪物，人物的宝宝不在此范围以内，禁止清除怪物列表中的怪物不会被清除。
此功能一般用于动态刷怪方式，在有人的地图出现怪物，没人时地图上的怪物全部清除，以大大节约机器资源。

命令格式：
CLEARMAPMON 地图号

例子：

#ACT
CLEARMAPMON D717
#say
<返回/@main>


清除结婚信息

;============================
[@delMarry]
#if
DELMARRY
#say
你的结婚信息已清除
;============================


清除列表内容

脚本功能:
清除列表内容

命令格式:
CLEARNAMELIST namelist.txt

;==========================================
;清除列表
[@Clearnamelist]
#IF
#ACT
CLEARNAMELIST namelist.txt
#SAY
列表已被清除
;==========================================


清除人物的仓库密码

功能：
清除人物的仓库密码

格式：
 CLEARPASSWORD

;==========================================
;设置人物的名称颜色
[@clearpassword]
#IF
#ACT
CLEARPASSWORD
#SAY
你的仓库密码已清除。
;==========================================


清除人物转生

功能：
清除人物转生数据(即人物转生后恢复到未转生状态)

格式：
;==========================================
[@ClearRenewLevel]
#IF
#ACT
RestRenewLevel
;==========================================


清除延时移动

功能:
清除延时移动

格式:
BREAKTIMERECALL

============================

[@Test]
#IF
#ACT
BREAKTIMERECALL
#Say
延时移动已清除

===========================


取对面角色人物名

功能：
取对面角色人物名到变量

格式：
GETPOSENAME 变量名

功能：
================================
[@AddAccountList]
#IF#act
GETPOSENAME a1
#SAY
对面的人物名：<$STR(a1)>
================================


人物聊天文字变色

功能: 改变人物公聊时的文字信息颜色.
格式: ChangeHearMsgColor 时间(分钟) 颜色(0-255)

;人物说话信息蓝色显示
[@main]
#IF
#ACT
ChangeHearMsgColor 10 180


人物小退

[@小退]
#ACT
LOGOUT


杀死宝宝

功能：
将自己的宝宝全部杀死。

格式：

;==========================================
[@killslave]
#IF
#ACT
KILLSLAVE
#say
你的宝宝清理干净了。
;==========================================


杀死人物

功能：
杀死人物.

格式：
 CLEARPASSWORD

;==========================================
;杀死人物
KILL 0 人物死亡,不显示凶手信息
KILL 1 人物死亡不掉物品,不显示凶手信息
KILL 2 人物死亡,显示凶手信息为NPC
KILL 3 人物死亡不掉物品,显示凶手信息为NPC
;==========================================
[@KILL]
#IF
#ACT
KILL 2
;==========================================


删除非本职业的所有技能

功能：
清除人物非本职业的所有技能。

格式：
 DELNOJOBSKILL

;==========================================
;清除非本职业的所有技能
[@clearskill]
#IF
#ACT
DELNOJOBSKILL
#SAY
你的非法技能已经清除了。
;==========================================

相关命令：
练习技能：ADDSKILL
检查技能：CHECKSKILL
删除技能：DELSKILL
删除所有技能： CLEARSKILL


删除行会成员

功能：
删除行会成员。

格式：
 DelGuildMember 行会名称 人物名称

（删除掌门无效）
;==========================================
[@Test]
#if
#act
DelGuildMember 测试行会 <$USERNAME>
#say
你已经从[测试行会]中脱离出来
;==========================================


删除会员人物及时间

删除会员人物及时间： DELUSERDATE 会员.txt

相关命令：
CHECKUSERDATE 会员.txt < 30 p0 p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1
加入会员人物及时间： ADDUSERDATE 会员.txt


删除列表行会名

功能：
删除列表行会名

格式：
==========================
[@delguildList]
#if
#act
DELGUILDLIST guildlist.txt
==========================


删除人物IP在列表中

功能：
删除人物IP在列表中

功能：
================================
[@DelIPList]
#IF
#Act
DELIPLIST IPList.txt
================================


删除人物称号

DEPRIVETITLE 称号名称

DEPRIVETITLE ALL //删除所有称号


删除人物名在列表中

功能：
删除人物名在列表中

格式：
================================
[@DelNameList]
#IF
#Act
DELNAMELIST NameList.txt
================================


删除人物帐号在列表中

功能：
删除人物帐号在列表中

功能：
================================
[@DelAccountList]
#IF
#Act
DELACCOUNTLIST AccountList.txt
================================


删除所有技能

功能：
清除人物的所有技能。

格式：
 CLEARSKILL

;==========================================
;清除所有技能
[@clearskill]
#IF
#ACT
CLEARSKILL
#SAY
你的所有技能已经清除了。
;==========================================

相关命令：
练习技能：ADDSKILL
检查技能：CHECKSKILL
删除技能：DELSKILL
删除非本职业所有技能：DELNOJOBSKILL


删除一个NPC

格式: DELNPC NPC名字 地图文件名称(该参数可以为空，为空表示所有地图的)

[@删除所有地图的]
#IF
#ACT
DelNpc 测试

[@删除某个地图的]
#IF
#ACT
DelNpc 测试 3


删除指定技能

功能：
脚本删除指定技能。

格式：
 DELSKILL 技能名称

;==========================================
;删除技能
[@delskill]
#IF
#ACT
DELSKILL 雷电术
#SAY
你的雷电术已删除了。
;==========================================

相关命令：
练习技能：ADDSKILL
检查技能：CHECKSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL


设置地图的杀怪经验倍数

功能：
设置地图的杀怪经验倍数

格式：
 MAPKILLMONEXPRATE 地图文件名称(*号表示所有地图) 倍率
倍率 为杀怪经验倍数，倍数除以100为真正的倍率(200 为 2 倍经验，150 为1.5倍,0表示关闭地图的杀怪经验倍数)

;==========================================
[@MAPKILLMONEXPRATE]
#IF
#ACT
MAPKILLMONEXPRATE 0 1000
#SAY
您在比奇的杀怪经验倍数为 10倍
;==========================================

[@MAPKILLMONEXPRATE]
#IF
#ACT
MAPKILLMONEXPRATE * 1000
#SAY
所有地图杀怪经验倍数为 10倍
;==========================================


设置攻击力倍数[!]

功能：
设置攻击力倍数

格式：
POWERRATE 倍率 有效时间
倍率 为杀攻击力倍数，倍数除以100为真正的倍率(200为2倍攻击，150为1.5倍攻击)支持变量操作

;==========================================
[@POWERRATE]
#IF
#ACT
POWERRATE 1000 600
#SAY
您当前攻击力倍数为 10倍，有效时间 600秒。
;==========================================


设置人物当前模式

功能：
设置人物当前模式。（1管理模式、2无敌模式、3隐身模式）

格式：
CHANGEMODE 模式类型 开关（1为开，0为关）

;==========================================
[@test]
#IF
#ACT
CHANGEMODE 1 1
CHANGEMODE 2 1
CHANGEMODE 3 1
;==========================================


设置人物当前权限

功能：
设置人物当前权限（0-10）

格式：(提升到超级GM)

;==========================================
[@test]
#IF
#ACT
CHANGEPERMISSION 10
;==========================================


设置人物名称 称号

设置人物名称称号 M2-选项-参数设置-游戏选项(1)-开启称号。不能勾选，勾选了，这个脚本命令无效

SETRANKLEVELNAME 称号内容(必须包含一个%s)


设置杀怪经验倍数

功能：
设置杀怪经验倍数.(支持内功经验，经络经验倍数)

格式：
 KILLMONEXPRATE 倍率 有效时间
倍率 为杀怪经验倍数，倍数除以100为真正的倍率(200 为 2 倍经验，150 为1.5倍)

;==========================================
[@KILLMONEXPRATE]
#IF
#ACT
KILLMONEXPRATE 1000 600
#SAY
您当前杀怪经验倍数为 10倍，有效时间 600秒。
;==========================================


设置物品和人物绑定[!]

功能: 设置新的装备绑定功能.(专用登录器)
SetItemBind,设置物品和人物绑定 绑定后物品属性会显示“已绑定”
格式:SetItemBind 装备位置(-1~16,-1时为OK框中物品) 绑定(0-1)
说明:参数2 0=取消 1=绑定

例子: 绑定武器.

#IF
CheckGold 10000
#ACT
SetItemBind 1 1
Take 金币 10000

例子: 取消绑定

#IF
CheckGold 10000
CheckItemBind 1
#ACT
SetItemBind 1 0
Take 金币 10000
#ELSESAY
你没有10000金币,或者当前物品没绑定.


设置装备绑定状态[!]

功能：设置装备绑定状态。
格式：SetItemState 装备位置(-1~16,-1时为OK框中物品) 项目(0-6) 属性(0为正常,1为绑定)
项目: 0-禁止扔 1-禁止交易 2-禁止存 3-禁止修 4-禁止出售 5-禁止爆出 6-丢弃消失 7-禁止拍卖

[@衣服禁止扔]
#IF
CheckItemBind 0
#ACT
GOTO @禁止扔
#ELSEACT
SENDMSG 6 请先绑定

[@禁止扔]
#IF
CheckItemState 0 0
#ACT
SENDMSG 6 该装备已经设置过禁止扔
#ELSEACT
SetItemState 0 0 1
SENDMSG 6 该装备禁止扔


设置装备发光特效

格式: SETITEMEFFECT 位置(-1时是OK框中的装备, 0-16时是穿在身上的装备) 特效编号(0-65535,0为清除特效)

特效编号需要在M2里编辑好的

[@main]
#ACT
SETITEMEFFECT 0 0


收回OK框中的物品

格式: TAKEDLGITEM

例：
[@main]
#ACT
TAKEDLGITEM

例：
[@main]
#ACT
OPENUPGRADEDLG 装备升级(显示的名称)

;打开可以放物品的对话框，也就是装备修理或出售物品的那个对话框
OPENUPGRADEDLG 装备升级(显示的名称)

;收回OK框中的物品
TAKEDLGITEM

;返回OK框中的物品到包裹
RECLAIMITEM

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM

SetNewItemValue 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)


所有行会同时攻城

功能:所有行会在当晚同时攻城

AddAttackSabukAll 城堡号(0)

#IF
#SAY
所有行会将于今晚同时攻城!
#ACT
AddAttackSabukAll 0


特修装备

功能：
特修装备,在物品规则列表中限制物品的不会被修理

格式：
RepairAll
该命令是检测命令，会自动扣除金币。
如果无法修理：
1.金币不够
2.需要修理的物品设置不允许修理的物品规则
3.该NPC文件头没有加上允许修理的代码.例如修理衣服需要加上 +10 +11

ActRepairAll
该命令是操作命令，不会扣金币

;特修装备

[@Test]
#IF
RepairAll
#SAY
你的装备修好了.
#ELSESAY
你是不是没有钱啊.

#IF
#ACT
ACTREPAIRALL
#SAY
你的装备修好了.


踢除服务器挂机人物

功能：
踢除服务器所有挂机人物。

格式：
 KICKOFFLINE //踢除服务器所有挂机人物

;==========================================
例：
#IF
#ACT
KICKOFFLINE
#Say
挂机人员全体下线
;==========================================


踢除服务器所有人物

功能：
踢除服务器所有人物。

格式：
 KICKALLPLAY //踢除服务器所有在线人物

;==========================================
例：
#IF
#ACT
KICKALLPLAY
#Say
全体下线
;==========================================


踢人物下线

功能：
踢人物下线.

格式：
 KICK

;==========================================
[@KICK]
#IF
#ACT
SENDMSG 5 %s，非法登录游戏
 KICK
;==========================================


添加行会成员

功能：
添加行会成员。

格式：
 AddGuildMember 行会名称 人物名称

;==========================================
[@Test]
#if
#act
AddGuildMember 测试行会 <$USERNAME>
#say
你已经成功加入[测试行会]行会中
;==========================================


调整宝宝等级

功能: 直接调整人物宝宝的等级
格式: ChangeSlaveLevel 名字 操作符(+ = -) 等级(1-7)

例子: 把虎卫的等级调整到7级.
#IF
#ACT
ChangeSlaveLevel 虎卫 = 7


调整行会可以容纳最多成员

格式: CHANGEGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示调整自己所在的行会) 调整符(+,-,=) 数量
[@main]
#IF
CHANGEGUILDMEMBERMAXLIMITCOUNT = 100
#SAY
你的行会可以容纳100个成员


调整行会人数上限[!]

功能: 调整当前行会的人数上限.
说明: 只能由行会老大使用.每个行会会自动读取!Setup.txt中的行会人数限制,之后可以用此命令重
      新调整行会人数限制,也就是说调整后不受!Setup.txt中行会人数限制参数的限制.

格式: AddGuildMemberCount 操作符(+ - = ) 数量(0--1000)

#IF
CheckItem 金条 1
#ACT
Take 金条 1
AddGuildMemberCount + 5
#ELSESAY
你没有金条或者你不是行会老大.


调整技能等级(扩展)

功能：
脚本调整技能等级。

格式：
 SKILLLEVEL 魔法名称 调整符(+,-,=) 等级 是否调整强化技能(0或为空时为技能等级,1为强化技能等级)

;==========================================
[@skilllevel0]
#IF
#ACT
SKILLLEVEL 雷电术 = 3
#SAY
你的雷电术等级已经为3级。
;==========================================

;==========================================
;
[@skilllevel1]
#IF
#ACT
SKILLLEVEL 雷电术 + 1
#SAY
你的雷电术等级已经升了1级。
;==========================================

;==========================================
;
[@skilllevel2]
#IF
#ACT
SKILLLEVEL 雷电术 - 1
#SAY
你的雷电术等级已经降了1级。
;==========================================

[@skilllevel3]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重


调整技能点数[!]

功能：
脚本调整技能点数。

格式：
 CHANGETRANPOINT 控制符(+,-,=) 点数

;==========================================
[@CHANGETRANPOINT]
#IF
#ACT
CHANGETRANPOINT 雷电术 = 100
;==========================================


调整金刚石数量

功能：
调整金刚石和灵符数量。

格式：
 GAMEDIAMOND 控制符(=,+,-) 点数(0 到 2147483647)
GAMEGIRD 控制符(=,+,-) 点数(0 到 2147483647)

;==========================================
;将人物的金刚石设置为指定点数，不能为负数
#IF
#ACT
GAMEDIAMOND = 0
#SAY
你的金刚石数量为0
;==========================================

;==========================================
;将人物的灵符设置为指定点数，不能为负数

#IF
#ACT
GAMEGIRD = 0
#SAY
你的灵符数量为0

;==========================================


调整人物的HP或MP[!]

功能：
调整人物的HP或MP

格式：

HUMANHP（+ - =）数字

HUMANMP（+ - =）数字
=========================
[@HUMANHP0]
#IF
#ACT
HUMANHP + 100

[@HUMANHP1]
#IF
#ACT
HUMANHP - 100

[@HUMANHP2]
#IF
#ACT
HUMANHP = 100
=========================

[@HUMANMP0]
#IF
#ACT
HUMANMP + 100

[@HUMANMP1]
#IF
#ACT
HUMANMP - 100

[@HUMANMP2]
#IF
#ACT
HUMANMP = 100
=========================


调整人物的荣誉值[!]

#IF
CheckLevelEx > 50
#ACT
ChangeNationCredit + 100

—————————————————————两个命令自己测试

格式: GAMEGLORY (+,-,=) 值

[@main]
#ACT
GAMEGLORY + 5
#SAY
荣誉值+5


调整人物会员等级

功能：
调整人物会员等级。

格式：
 SETMEMBERLEVEL 控制符(=,+,-) 等级数(1-65535)

;==========================================
;设置人物会员等级
[@changememberlevel0]
#IF
#ACT
SETMEMBERLEVEL = 5
#SAY
你的会员等级为5。
;==========================================

;==========================================
;增加人物会员等级
[@changememberlevel1]
#IF
#ACT
SETMEMBERLEVEL + 1
#SAY
你的会员等级已经改变。
;==========================================

;==========================================
;减少人物会员等级
[@changememberlevel2]
#IF
#ACT
SETMEMBERLEVEL - 1
#SAY
你的会员等级已经改变。
;==========================================


调整人物会员类型

功能：
调整人物会员类型。

格式：
 SETMEMBERTYPE 控制符(=,+,-) 类型数(1-65535)

;==========================================
;设置人物会员类型
[@changemembertype0]
#IF
#ACT
SETMEMBERTYPE = 5
#SAY
你的会员类型为5。
;==========================================

;==========================================
;增加人物会员类型
[@changemembertype1]
#IF
#ACT
SETMEMBERTYPE + 1
#SAY
你的会员类型已经改变。
;==========================================

;==========================================
;减少人物会员类型
[@changemembertype2]
#IF
#ACT
SETMEMBERTYPE - 1
#SAY
你的会员类型已经改变。
;==========================================


调整人物属性

功能： 调整人物属性

格式: ChangeHumAbility 属性(1-20,30-40) 操作符(+ = -) 效果(1-65535) 时间秒
说明: 属性1-12分别对应人物 防御下限 防御上限 魔御下限 魔御上限 攻击下限 攻击上限 魔法下限 魔法上限 道术下限 道术上限 MaxHP MaxMP HP恢复 MP恢复 毒恢复 毒躲避 魔法躲避 准确 敏捷 幸运

30:真实伤害

31 攻击下限万分比

32 攻击上限万分比

33 魔法下限万分比

34 魔法上限万分比

35 道术下限万分比

36 道术上限万分比

37 物防下限万分比

38 物防下限万分比

39 魔防下限万分比

40 魔防上限万分比

注意: 整后的属性效果只在人物在线时有效.? 不带时间为在线一直有效

例子：

[@Test]
#IF
#ACT
ChangeHumAbility 2 + 10 60
#SAY
你的防御上限增加10点.60秒后恢复


调整人物游戏点数

功能：
调整人物游戏点。

格式：
 GAMEPOINT 控制符(=,+,-) 点数(1-100)< /FONT>

;==========================================
;设置人物游戏点
[@GAMEPOINT0]
#IF
#ACT
GAMEPOINT = 8
#SAY
你的游戏点已经为8了。
;==========================================

;==========================================
;增加人物游戏点
[@GAMEPOINT1]
#IF
#ACT
GAMEPOINT + 1
#SAY
你的游戏点已经加了1点。
;==========================================

;==========================================
;降人物游戏点
[@GAMEPOINT2]
#IF
#ACT
GAMEPOINT - 1
#SAY
你的游戏点已经降了1点。
;==========================================


调整声望点

功能：
调整人物声望点。

格式：
CREDITPOINT 控制符(=,+,-) 点数(1-100)< /FONT>

;==========================================
;设置人物声望点
[@CREDITPOINT0]
#IF
#ACT
CREDITPOINT = 8
#SAY
你的声望点已经为8了。
;==========================================

;==========================================
;增加人物声望点
[@CREDITPOINT1]
#IF
#ACT
CREDITPOINT + 1
#SAY
你的声望点已经加了1点。
;==========================================

;==========================================
;降人物声望点
[@CREDITPOINT2]
#IF
#ACT
CREDITPOINT - 1
#SAY
你的声望点已经降了1点。
;==========================================


调整属性点

功能：
调整人物属性点。

格式：
BONUSPOINT 控制符(=,+) 点数(0-1000)< /FONT>

;==========================================
;设置属性点
[@BONUSPOINT0]
#IF
#ACT
BONUSPOINT = 0
#SAY
你的属性点点已全部清0了。
;==========================================

;==========================================
;增加属性点
[@BONUSPOINT1]
#IF
#ACT
BONUSPOINT + 1
#SAY
你的属性点已经加了1点。
;==========================================

相关命令：
复位属性点数：RESTBONUSPOINT
检查属性点数：CHECKBONUSPOINT


调整物品名字颜色

功能:调整人物身上物品装备名字颜色(英雄M2)
格式:ChangeItemNameColor 物品位置(0-16，-1位OK框物品) 颜色(0-255)
说明:颜色=0时恢复默认颜色.

[@main]
#IF
#ACT
ChangeItemNameColor 1 253
#SAY
你装备名字的颜色变成紫色了.


调整物品元素属性

格式: SetNewItemValue 位置(-1时是OK框中的装备, 0-16时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)

属性(0-10)
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM


调整游戏速度

格式: ChangeSpeed 速度类型 速度值 有效时间(秒，该参数为空时表示不限制时间)
速度类型 1为 移动速度 2为攻击速度 3为魔法速度
速度值(-10和10之间 小于0为减速 等于0不变速)

[@main]
#ACT
CHANGESPEED 1 5
#SAY
移动速度增加


调整装备升级次数或星星数量[!]

功能: 调整装备升级次数或星星数量.

格式: ChangeItemUpgradeCount 物品位置(0~16,-1时为OK框物品) (+,-,=) 次数(0~255)

物品位置:

;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================

#IF
CheckItem 金条 1
#ACT
Take 金条 1
ChangeItemUpgradeCount 0 + 10
SendMsg 5 盔甲升级次数增加10次
#ELSESAY
你没有金条


通过脚本建立一个NPC 动态创建NPC

通过脚本命令建立一个NPC,服务器重启后消失.

格式: CreateNPC NPC名字 地图 坐标X(-1时随机坐标) 坐标Y(-1时随机坐标) 外观 脚本文件 脚本文件是否要加上地图名称(例如.设置为0时脚本文件必须带“-3”如:“传送员-3.txt” 设置为1时脚本文件不需要带“-3”如:“传送员.txt”这样的好处就是，你可以在任意地图地图创建NPC，只要一个脚本“传送员.txt”而不需要“传送员-0.txt、传送员-3.txt”等等好多NPC脚本) 存在时间（秒，0或空永久存在）

CreateNPC    NPC名字 地图 坐标X 坐标Y 外观 脚本文件 脚本文件是否要加上地图名称 存在时间 传递参数（通过变量s0可获取该参数的值）

注意: 脚本文件必须在Market_Def目录中.

例如:首先在Market_Def中建立一个叫测试-3.txt的脚本文件.
#IF
#ACT
CreateNPC 测试 3 330 330 8 测试-3 0 0
#SAY
通过脚本建立了一个NPC.

#IF
#ACT
CreateNPC 测试NPC 3 -1 -1 8 测试NPC 1 0
#SAY
通过脚本建立了一个NPC 随机坐标

[@创建npc]
#act
mov t$异兽 异兽<$USERNAME>
createNPC <$STR(t$异兽)> 3 80 49 1012 测试NPC 1 0 <$USERNAME>
创建NPC脚本：

[@main]
#if
equal s0 <$USERNAME>
#act
sendmsg 6 这是你的npc
#elseact
sendmsg 6 这不是你的npc


显示倒计时信息提示

功能:

显示倒计时信息提示

格式:

SENDDELAYMSG信息内容 时间(秒) 字体颜色 换地图是否删除 跳转字段

[@测试]
#if
#act
SENDDELAYMSG 你的礼物在%s后到达 300 255 0 @给礼物

[@给礼物]
#ACT
GIVE 布衣(男)

------------------------------------------
300秒倒计时结束后会执会当前脚本文件里的[@给礼物]段


显示验证码窗口

格式: SHOWGAMEVALIDATEDLG 模式(0自己 1当前地图 2全服人物) 自定义验证码(该参数可以为空，如果为空时，会自动生成验证码)

[@显示随机验证码窗口]
#ACT
SHOWGAMEVALIDATEDLG 0

[@显示自定义验证码窗口]
#ACT
SHOWGAMEVALIDATEDLG 0 123456
SENGMSG 6 验证码窗口会显示123456，不超过6个字符


新的装备改名

功能: 新的装备改名
格式: ChangeItemName 物品位置(0-16) 名字

物品位置:

;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================

#IF
#ACT
ChangeItemName 1 新名字


新游戏点[!]

检测命令 CHECKGAMEGOLDEX 检测符(<,>,=) 值
操作命令 GAMEGOLDEX 操作符(+,-,=) 值
显示变量 <$GAMEGOLDEX>


修改物品的附加属性值

功能： 修改物品的附加属性值

格式: CHANGEITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 + - =) 值

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

例子：

[@Test]
 #IF
CheckItemAddValue 0 0 > 1
#ACT
GETITEMADDVALUE 0 0 <$STR(M10)>
#SAY
你的盔甲附加了<$STR(M10)>点防御属性.


延时移动

功能:
延时移动

格式:
TIMERECALL 时间(分钟)

============================

[@Test]
#IF
#ACT
timerecall 60
map G012
give 回城卷 1
SENDMSG 0 [%s]使用了元宝练级卷.进入快速升级地图,1小时后会将您传回土城!

===========================


一键回收包裹物品[!]

一键回收包裹物品的脚本命令
格式：

takeBagItem

回收背包内指定物品

标签:命令定义|takeBagItem

格式

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8
takeBagItem | 物品名称 | 回收数量 | 获得元宝单价 | 获得金币单价 | 获得泡点值单价 | 获得经验单价 | 变量 | 聚灵珠经验

说明:

  • 参数1: 物品名称

  • 参数2: 回收数量

  • 参数3: 回收元宝单价(<$gameGold>)

  • 参数4: 回收金币单价(<$goldCount>)

  • 参数5: 获得泡点值(<$gamePoint>)

  • 参数6: 获得经验

  • 参数7: 变量，用于保存实际回收数量

  • 参数8: 经验是否存入聚灵珠
    • 0：存入
    • 1：不存
  • 参数9: 回收物品的颜色值(0-255，空或*回收所有颜色)

[@main]
#ACT
TakeBagItem 木剑|布衣(男)|布衣(女) 46 0 0 0 10000 N1 0
SENDMSG 6 成功回收<$STR(N1)>个木剑，布衣(男)，布衣(女)，价格为10000经验


移动到回城点

功能：
 移动到回城点

使用方法：

[@main]
#if
#act
GoHome
#say
你已经回城了


永久增加人物属性点

功能：
永久增加人物属性点。(支持英雄)

格式：
USEBONUSPOINT 属性位置（1-20） 控制符（+,-,=） 点数

1-攻击力 2-魔法力 3-道术力 4-防御力 5-魔防力 6-生命值 7-魔法值 8- 准确 9-躲避 10-防御下限 11-防御上限 12-魔御下限 13-魔御上限 14-吸收伤害 15-攻击力下限 16-攻击力上限 17-魔法下限 18-魔法上限 19-道术下限 20-道术上限

;==========================================
[@Main]
#ACT
USEBONUSPOINT 1 + 20
SENDMSG 7 攻击力增加20点.

[@Main]
#ACT
USEBONUSPOINT 2 + 20
SENDMSG 7 魔法力增加20点.

[@Main]
#ACT
USEBONUSPOINT 3 + 20
SENDMSG 7 道术力增加20点.

[@Main]
#ACT
USEBONUSPOINT 4 + 20
SENDMSG 7 防御力增加20点.

[@Main]
#ACT
USEBONUSPOINT 5 + 20
SENDMSG 7 魔防力增加20点.

[@Main]
#ACT
USEBONUSPOINT 6 + 20
SENDMSG 7 生命值上限增加20点

[@Main]
#ACT
USEBONUSPOINT 7 + 20
SENDMSG 7 魔法值上限增加20点.

[@Main]
#ACT
USEBONUSPOINT 8 + 20
SENDMSG 7 准确增加20点.

[@Main]
#ACT
USEBONUSPOINT 9 + 20
SENDMSG 7 躲避增加20点.
;==========================================


游戏币控制

功能：
调整人物游戏币及根据时间自动增减游戏币（可用来做会员时间用）。

格式：
GAMEGOLD 控制符(=,+,-) （1-100）

;==========================================
;设置人物游戏币
[@GAMEGOLD0]
#IF
#ACT
GAMEGOLD = 8
#SAY
你的游戏点已经为8了。
;==========================================

;==========================================
;增加人物游戏币
[@GAMEGOLD1]
#IF
#ACT
GAMEGOLD + 1
#SAY
你的游戏点已经加了1点。
;==========================================

;==========================================
;降人物游戏币
[@GAMEPOINT2]
#IF
#ACT
GAMEGOLD - 1
#SAY
你的游戏币已经降了1点。
;==========================================

功能：
设置是否自动增加游戏币。

格式：
AUTOADDGAMEGOLD 控制符(START,STOP)

;==========================================
;设置自动增加游戏币
[@AutoAddGAMEGOLD]
#IF
#ACT
PARAM1 1
PARAM2 10
AUTOADDGAMEGOLD START
#SAY
现进入自动增加游戏币模式，每10秒增加一个

;==========================================

;==========================================
;停止自动增加游戏点
[@AutoAddGAMEGOLD]
#IF
#ACT
AUTOADDGAMEGOLD STOP
#SAY
现退出自动增加游戏币模式

;==========================================

功能：
设置是否自动减少游戏币。

格式：
AUTOADDGAMEGOLD 控制符(START,STOP)

;==========================================
;设置自动增加游戏币
[@AutoAddGAMEGOLD]
#IF
#ACT
PARAM1 1
PARAM2 10
AUTOSUBGAMEGOLD START
#SAY
现进入自动增加游戏币模式，每10秒增加一个
;==========================================

;==========================================
;停止自动增加游戏点
[@AutoAddGAMEGOLD]
#IF
#ACT
AUTOSUBGAMEGOLD STOP
#SAY
现退出自动减少游戏币模式

;==========================================


在登陆器里浏览网页

功能：
浏览网页

格式：
WebBrowser 地址

;==========================================
[@WebBrowsertest]
#IF
#ACT
WebBrowser http://www.gameofmir.com
;==========================================


在地图上播放魔法效果[!]

格式: MAPEFFECT 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数(-1时表示不限制次数) 播放速度(毫秒) 播放效果(0普通 1特效) (该参数值范围0~5，0表示没有亮度，在关闭禁止免蜡时有效)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
MAPEFFECT 3 333 333 0 0 10 1 300 1 0


在地图上放物品[!]

格式: THROWITEM 地图名称 X坐标 Y坐标 范围 物品名称 数量|可拾取时间(秒)|物品存在时间（秒） 是否掉落提示(0不提示,1提示) 是否可以立即捡取(0不能立即捡取,1可以立即捡取)

格式

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8
throwItem | 地图名称 | X坐标 | Y坐标 | 范围 | 物品名称 | 数量|可拾取时间(秒)|物品存在时间（秒） | 是否掉落提示 | 是否可以立即捡取

数量|可拾取时间(秒)|物品存在时间(秒)

此参数缺省,则使用系统统一存在时间

[@main]
#IF
Random 100
#ACT
ThrowItem 3 330 330 10 回城卷 5|60


在屏幕上播放魔法效果

格式: SCREENEFFECT 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 播放效果(0=普通，1=魔法效果) 模式(0=自己，1=所有人)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
SCREENEFFECT 0 0 0 0 10 1 300 0


在线命令弹出菜单功能

功能：
玩家在线输入指定命令弹出菜单脚本功能

格式：
命令为command.ini内（命令名称随便定义）：MemberFunc=我是会员
输入@我是会员 命令后将运行登录脚本(Qmanage.txt)内[@Member]段内容脚本
具体脚本内容自己写。


在线泡经验

功能：
在线泡经验（直接得到经验）

格式：例：（等级30级以上，地图3安全区内每1秒种得到10个经验点）
==================================================
#IF
CheckLevelex > 30
#ACT
setautogetexp 1 10 1 3
命令 时间 经验 是否安全区（0为任何地方） 地图号（任何地图使用*号） 聚灵珠是否能获取经验(0=不可以 1=可以)
==================================================


增加会员时间[!]

功能：
增加会员时间 文件名称 天 时 分

例子：

[@Test]
#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 <$STR(S$1)> <$STR(N$1)> <$STR(N$2)> <$STR(N$3)>
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 0 0
SENDMSG 5 <$USERNAME>会员充值成功，增加30天0小时0分会员时间！
SENDMSG 6 你的会员到期时间是<$STR(S$1)>【剩余天数=<$STR(N$1)>】【剩余小时=<$STR(N$2)>】【剩余分钟=<$STR(N$3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253


增加人物IP在列表中

功能：
增加人物IP在列表中

功能：
================================
[@AddIPList]
#IF
#Act
ADDIPLIST IPList.txt
================================


增加人物称号

CONFERTITLE 称号名称(需要到物品数据库里添加，详见说明书称号系统) 是否设置为当前称号(1=设置为当前称号)


增加人物名在列表中

功能：
增加人物名在列表中

格式：
================================
[@AddNameList]
#IF
#Act
ADDNAMELIST NameList.txt
================================


增加人物帐号在列表中

功能：
增加人物帐号在列表中

功能：
================================
[@AddAccountList]
#IF
#Act
ADDACCOUNTLIST AccountList.txt
================================


增加限次使用物品的次数.
说明: 只对刚刚使用过的类型(StdItem=31 Source=1)或者(StdItem=2 Shape=1,3,5,9)的物品有效.

[@StdModeFunc10]
#IF
CheckLevelEx < 100
#ACT
ChangeLevel + 1
Break
#ELSESAY
小于100级才可以使用.
#ELSEACT
AddFunItemDura   ;持久增加1

[@StdModeFunc11]
#IF
CheckLevelEx < 100
#ACT
ChangeLevel + 1
Break
#ELSESAY
小于100级才可以使用.
#ELSEACT
AddFunItemDura 100 ;持久增加100


召唤指定怪物为宝宝

功能：
脚本召唤宝宝。

格式：
RECALLMOB 怪物名称 宝宝等级(最高为 7) 叛变时间(分钟) 是否自动变色（0、1）固定颜色（1-7） 缩放倍数（不填写默认为1） 属性倍率 是否无敌（默认0正常，1无敌模式）
攻击力受自动变色颜色不同而不同
固定颜色攻击力受指定颜色不同而不同

注：如设固定颜色，自动变色参数必须设置为0

;==========================================
;召唤最多5个七宝宝，30分钟后叛变,七彩变色
[@recallmob]
#IF
CHECKSLAVECOUNT < 5
#ACT
RECALLMOB 神兽 7 30 1
#SAY
好好看着自己的宝宝，不要乱咬人。
#ELSESAY
你已经有5个或以上的宝宝，现在不可以再召宝宝。
;==========================================

#if
#ACT
RECALLMOB 混沌圣虎 7 5 1 7 1 1 1


重新分配人物附加属性点
功能：
将人物附加的属性点复位到未分配状态；
格式：
#if
#act
RESTBONUSPOINT
#say
你的属性点已经重新分配；

相关命令：
检查属性点数：CHECKBONUSPOINT
调整属性点数：BONUSPOINT


转换职业

功能：
转换职业。

格式：
 CHANGEJOB 职业名称(Warrior,Wizard,Taoist)

;==========================================
;转职业为武士
[@changejob0]
#IF
#ACT
CHANGEJOB Warrior
#SAY
你的职业已经变成武士了。
;==========================================

;==========================================
;转职业为法师
[@changejob1]
#IF
#ACT
CHANGEJOB Wizard
#SAY
你的职业已经变成法师了。
;==========================================

;==========================================
;转职业为道士
[@changejob2]
#IF
#ACT
CHANGEJOB Taoist
#SAY
你的职业已经变成道士了。
;==========================================


装备名称自定义系统

功能：
装备名称自定义系统

格式：
例脚本：

(@@useitemname)
[@main]
请选择要改名的装备：(将要改名的装备戴身上)\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
◇◇◇『<盔　甲/@@useitemname0>』◇◇◇『<武　器/@@useitemname1>』◇◇◇\
◇◇◇『<项　链/@@useitemname3>』◇◇◇『<头　盔/@@useitemname4>』◇◇◇\
◇◇◇『<左手镯/@@useitemname5>』◇◇◇『<右手镯/@@useitemname6>』◇◇◇\
◇◇◇『<左戒指/@@useitemname8>』◇◇◇『<右戒指/@@useitemname7>』◇◇◇\
◇◇◇『<勋 章/@@useitemname2>』\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
〖<返回/@main>〗 〖<关闭/@exit>〗
[@@useitemname0]
#ACT
goto @ChangeName
[@@useitemname1]
#ACT
goto @ChangeName
[@@useitemname2]
#ACT
goto @ChangeName
[@@useitemname3]
#ACT
goto @ChangeName
[@@useitemname4]
#ACT
goto @ChangeName
[@@useitemname5]
#ACT
goto @ChangeName
[@@useitemname6]
#ACT
goto @ChangeName
[@@useitemname7]
#ACT
goto @ChangeName
[@@useitemname8]
#ACT
goto @ChangeName
[@@useitemname9]
#ACT
goto @ChangeName
[@@useitemname10]
#ACT
goto @ChangeName
[@@useitemname11]
#ACT
goto @ChangeName
[@@useitemname12]
#ACT
goto @ChangeName
[@ChangeName]
#if
checkgamegold > 0
#act
gamegold - 1
SETSCRIPTFLAG 1 1
sendmsg 7 改名成功！！！
Close
#elseact
sendmsg 7 没钱跑来做什么？


装备属性升级

装备升级

装备升级功能可以指定升级物品及属性，按指定机率得到结果。
需要升级的装备物品必须放在身上。

命令格式

UPGRADEITEMEX 物品位置(0-12) 属性位置(0-14) 成功机率(0-100) 点数机率(0-255) 是否破碎(0,1)

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

属性位置:
不同类型的物品属性位置不一样，以后补充这些资料，自行可以进行测试得到。

成功机率:
升级成功机率，数字越大机率越小。

点数机率:
升级成功后得到的点数，数值在 0 -255之间。

是否破碎:
升级失败后装备是否破碎，数值为0或1，1为失败后破碎。

属性位置详解

重要注意事项，请在使用本功能前务必详细阅读，否则将有可能带来严重后果
当所需要升级的项链、手镯、戒指、在DB数据库中因 StdMode值的不同，而升级
出来得到的结果也不同，所以使用者请按照以下属性变化列表进行详细设置！
其中涉及的体力恢复、魔法恢复、毒物躲避、中毒恢复、如升级成功“1”点属性，则表示为 10%

项链属性：
当StdMode值为19时：属性位置“0”升级出来表现为“魔法躲避”、属性位置“1”升级出来属性表现为“幸运”
当StdMode值为20时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当StdMode值为21时：属性位置“0”升级出来表现为“体力恢复”、属性位置“1”升级出来属性表现为“魔法恢复”

手镯属性：
当StdMode值为24时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当StdMode值为26时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”

戒指属性：
当StdMode值为22时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”
当StdMode值为23时：属性位置“0”升级出来表现为“毒物躲避”、属性位置“1”升级出来属性表现为“中毒恢复”

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久


自定义变量按变量值大小排序[!]

SortVarToList
功能：
自定义变量按变量值大小排序，并把排序后变量值对应的人物名存放到指定列表文件中(制作排行榜用)

格式：
SortVarToList 自定义变量名 自定义变量文件路径 排序后列表的保存路径 降序还是升序(0-1) 保存格式(0-1)为0时只保存人物名,为1时:人物名 变量值.

例子：

[@test2]
#if
#act
SortVarToList LJSQZS ..\QuestDiary\数据文件\Test.txt ..\QuestDiary\数据文件\排序的文件.txt 0 1
break


自定义变量功能

自定义变量数据类型

类型名称 | 类型说明
integer | 整数型
string | 字符串

自定义变量声明时,需要说明其数据类型
特戒引擎中,自定义变量声明已不再需要
在此列出来,只为兼容其它引擎,作说明用

脚本示例：

[@main]
#act
var integer human 个人捐款
var string human 个人密码

自定义变量作用域

名称 | 范围 | 使用说明
global | 全局 | 服务器重启不清除
guild | 行会 | 服务器重启清除
guild2 | 行会 | 服务器重启不清除
human | 私人 | 小退清0

脚本示例：

[@main]
#say
<text:变量赋值:50:50/@按钮1>
<text:变量读值:50:150/@按钮2>
;给变量赋值
[@按钮1]
#act
calcVar global 全服总捐款 = 999999
calcVar guild 行会总捐款 = 88888
calcVar guild2 行会总杀怪 = 77777
calcVar human 个人捐款 = 9527
sendMsg 6 赋值完毕
;读取变量值
;可尝试重启客户端后读取
;可尝试重启服务器后读取
[@按钮2]
#act
sendMsg 6 %s所在服务器全服总捐款:<$global(全服总捐款)>
;角色未加入行会,将输出空
sendMsg 6 %s所在行会总捐款数:<$guild(行会总捐款)>
;角色未加入行会,将输出空
sendMsg 6 %s所在行会总杀怪数:<$guild2(行会总杀怪)>
sendMsg 6 %s个人捐款:<$human(个人捐款)>

calcVar 增加变量类型标识，支持字符串加减

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
calcVar | 作用域 | 变量名 | =,+,- | 数值 | 类型标识

说明

增加参数5

当参数3为"+"或"-"时，

  • 参数5=0 表示整数加减
  • 参数5=1 表示字符串加减
  • 参数5缺省 表示整数加减

功能：
 自定义变量功能，不再受固定几个变量限制

使用方法：（loadvar时，需要在本地对应目录拥有同名txt文件，若无对应txt文件，则需要手动创建一个空文件）
三个步骤：
1、首先要声明变量
2、读取变量
3、保存变量
该变量支持增加、减少、脚本查看、检查大小等功能，该功能的开发突破了变量使用受限制，利用该变量可制作出超强功能脚本。
脚本样例：
=========================================
<声明变量/@newvarInteger> \
<查看变量/@viewvarInteger>\
<读取变量/@loadvarInteger> \
<保存变量/@savevarInteger> \
<增加变量/@calcvarinc> <检查变量是否大于5/@checklarage5>\
<减少变量/@calcvardec> <检查变量是否小于5/@checksmall5>\
<检查变量是否等于5/@checkequal5>
[@calcvarinc]
#IF
#ACT
CALCVAR HUMAN QQQQ + 5
goto @varcontrol
[@calcvardec]
#IF
#ACT
CALCVAR HUMAN QQQQ - 5
goto @varcontrol
[@checkequal5]
#IF
CHECKVAR HUMAN QQQQ = 5
#ACT
sendmsg 7 等于5
goto @varcontrol
#ELSEACT
sendmsg 7 不等于5
goto @varcontrol
[@checklarage5]
#IF
CHECKVAR HUMAN QQQQ > 5
#ACT
sendmsg 7 大于5
goto @varcontrol
#ELSEACT
sendmsg 7 小于5
goto @varcontrol
[@checksmall5]
#IF
CHECKVAR HUMAN QQQQ < 5
#ACT
sendmsg 7 小于5
goto @varcontrol
#ELSEACT
sendmsg 7 大于5
goto @varcontrol

[@decInteger]
#ACT
DEC QQQQ 1
sendmsg 7 <$HUMAN(QQQQ)>
goto @varcontrol
[@addInteger]
#ACT
INC QQQQ 1
sendmsg 7 <$HUMAN(QQQQ)>
goto @varcontrol
[@loadvarInteger]
#IF
#ACT
LOADVAR HUMAN QQQQ VarSave.txt
sendmsg 7 OK
GOTO @varcontrol

[@savevarInteger]
#IF
#ACT
SAVEVAR HUMAN QQQQ VarSave.txt
sendmsg 7 OK
GOTO @varcontrol
[@viewvarInteger]
#ACT
sendmsg 7 <$HUMAN(QQQQ)>
GOTO @varcontrol

[@newvarInteger]
#IF
#ACT
VAR Integer HUMAN QQQQ
sendmsg 7 OK
GOTO @varcontrol
[@viewvarString]
<$HUMAN(QQQS)>


自定义采集[!]

采集功能格式:
SHOWPROGRESSBARDLG 时间(秒) 触发字段 提示信息 有动作是否中断(0不中断,1中断) 中断触发字段

使用示例：
[@Main]
#ACT
SHOWPROGRESSBARDLG 5 @采集完成 正在采集,进度%d%... 1 @采集中断
Break

QF触发
[@采集完成]
#ACT
Give 回城卷 1
SendMsg 5 你采集一个回城卷
Break

[@采集中断]
#ACT
SendMsg 5 采集被中断
Break


自动穿取装备

功能：
自动穿取装备。

格式：
 穿装备 TakeOnItem 装备名称 位置(0-16)
脱装备 TakeOffItem 位置(0-16) 再次穿戴时间（秒）

;==========================================
物品位置:
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================

;==========================================
;穿装备
[@TakeOnItem]
#IF
#ACT
TakeOnItem 天魔神甲 0
#SAY
已经帮你穿上衣服了。
;==========================================

;==========================================
;脱装备
[@TakeOffItem]
#IF
#ACT
TakeOffItem 0 10
#SAY
已经帮你把衣服脱下来了。10秒后可以再次穿戴
;==========================================


自动穿装备和取装备

自动穿装备和取装备.新人出生就无需手动穿装备了.

例子:

;自动穿装备
AutoTakeOnItem 装备名称 位置(0-16)

;自动脱装备
AutoTakeOffItem 位置(0-16)

物品位置:
;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================


自动行走

功能：自动寻路
自动行走 AUTOGOTOXY 地图名称 X坐标 Y坐标

例子：

[@Test]
#IF
#ACT
AUTOGOTOXY 3 330 330


字符串替换

功能：
字符串替换

格式：
 ANSIREPLACETEXT 字符串变量 旧字符串 新字符串

;==========================================
;==========================================
;把www.gameofmir.com替换成www.qq.com
[@main]
#IF
#ACT
mov S1 www.gameofmir.com
ANSIREPLACETEXT <$STR(S1)> gameofmir qq
SENDMSG 6 <$STR(S1)>


增加附加伤害效果

RANGEHARM命令
格式： RANGEHARM 参数1 参数2 参数3 参数4 参数5 参数6。。。参数11
说明

参数1：X坐标
参数2：Y坐标
参数3：范围
参数4：伤害值
参数5：附加效果 0=无 1=击退 2=冻结 3=麻痹 4=吸血 5=吸蓝 6=真实伤害 7=石化 8= 冰冻 9=蛛网 10=红毒 11=绿毒 12=定身 13=瘫痪 14=防禁锢
参数6：附加属性值（时间值为毫秒） 分别对应 击退距离 冻结时间 麻痹时间 吸血值 吸蓝值 真实伤害值

参数7：附加属性值 毒伤害
参数8：是否检查防冻结/麻痹/石化/冰冻/蛛网/红毒/绿毒属性（0：直接设置状态；1：检查后设置状态）

参数9：目标（0或空：所有目标；1：仅人物；2：仅怪物）
参数10：特效资源名称 （0或空不播放特效）
参数11：是否物理属性攻击（0或空目标以魔御来抵御伤害，1物理属性则目标以防御来抵御伤害）

参数12：特效持续时间

参数13：是否考虑护身效果（0或空不考虑，1考虑）

例
RANGEHARM 333 333 8 100 1 5
当前地图坐标333 333 范围8之内所有可以攻击的目标都受到100点伤害，并且被击退5格
所有参数都支持变量 伤害和普通伤害一样 需要考虑目标的防御

RANGEHARMEX命令 支持伤害触发
格式： RANGEHARMEX 参数1 参数2 参数3 参数4 参数5 参数6。。。参数13
说明：

参数1：X坐标
参数2：Y坐标
参数3：范围
参数4：伤害值
参数5：附加效果 0=无 1=击退 2=冻结 3=麻痹 4=吸血 5=吸蓝 6=真实伤害 7=石化 8= 冰冻 9=蛛网 10=红毒 11=绿毒 12=定身 13=瘫痪 14=防禁锢
参数6：附加属性值 分别对应 击退距离 冻结时间 麻痹时间 吸血值 吸蓝值 真实伤害值

参数7：附加属性值 毒伤害
参数8：是否检查防冻结/麻痹/石化/冰冻/蛛网/红毒/绿毒属性（0：直接设置状态；1：检查后设置状态）
参数9：目标（0或空：所有目标；1：仅人物；2：仅怪物）
参数10：触发几率（仅对所有目标触发有效，值越小几率越高）
参数11：特效资源名称 （0或空不播放特效）
参数12：是否物理属性攻击（0或空目标以魔御来抵御伤害，1物理属性则目标以防御来抵御伤害）

参数13：特效持续时间

参数14：是否考虑护身效果（0或空不考虑，1考虑）


增加取随机值RandomEx

格式：Randomex 参数1 参数2

参数1为子，参数2为母，母是随机范围，当随机值小于或等于子值，就执行脚本

示例：

RandomEx 1 2 2分之1

RandomEx 4 5 5分之4


给角色发送邮件

sendEmails
给当前角色发送邮件

标签:命令定义|sendEmails

格式
命令名 | 参数1 | 参数2 | 参数3
sendEmails | 邮件标题 | 邮件正文 | 邮件附件
说明
  • 参数1: 邮件标题
  • 参数2: 邮件正文支持"\n"换行
  • 参数3: 附件设置格式
    • 格式:1 道具1名称,道具1数量|道具2名称,道具2数量|...
    • 格式:2 装备1唯一id,|装备2唯一id,

特戒引擎脚本示例：

示例1

[@main]
#act
sendEmails 充值奖励 充值100额外奖励\n充值100额外奖励 回城石,1|回城石,1

示例2

使用前提
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | canCtrlDrop=1

以下为QFunction-0.txt中的触发块
文件路径
..\Mir200\Envir\Market_Def\QFunction-0.txt

;--脚本控制身上物品掉落
[@dropUseItems]
#if
;--配置掉落再返回的条件
#act
;--此处为掉落再返回的逻辑
goto @返回道具
#elseAct
;--执行掉落处理
doDrop s0 s1 s2

[@返回道具]
#if
;--背包没满
#act
giveInsItem s1
#elseAct
sendEmails 保险掉落返还 保险掉落返还 s1,


怪物连爆命令

怪物死亡时触发多一次掉落

命令格式： CONTINUPISDROP 怪物名字

示例：

CONTINUPISDROP 帝皇瑞兽[万年魂兽]


自定义装备文字内容

格式：GetCustomItemText 装备位置 变量

格式：GetCustomItemTextColor 装备位置 变量(0~255)

例

[@InputInteger1]
#ACT
CHANGECUSTOMITEMTEXTCOLOR 0 N1
[@InputString1]
#ACT
CHANGECUSTOMITEMTEXT 0 S1

[@获取武器自定义装备文字内容：]
#IF
#ACT
GetCustomItemText 1 <$STR(S1)>
SENDMSG 6 武器自定义文字内容为<$STR(S1)>
[@获取武器自定义装备文字内容的颜色：]
#IF
#ACT
GetCustomItemTextColor 1 <$STR(N1)>
SENDMSG 6 武器自定义文字内容的颜色为<$STR(N1)>


背包自定义按钮

背包内自定义按钮功能

格式：SETITEMBAGBUTTONINFO 按钮编号 （1-5） 是否可见（0不可见，1可见） 坐标X 坐标Y 提示信息（按钮上文字） 宽度 高度
点击对应按钮可触发Qfunction-0 中对应的@块
@itemBagButtonClickX (X为按钮编号)

例如

#if
#act
SETITEMBAGBUTTONINFO 1 1 0 0 自定义一
SETITEMBAGBUTTONINFO 2 1 100 10 修天斗罗
SETITEMBAGBUTTONINFO 3 1 200 -50 测试按钮
SETITEMBAGBUTTONINFO 4 1 300 -200 自定义按钮
SETITEMBAGBUTTONINFO 5 1 500 -500 的说法是
Qfuntion配置：
[@ItemBagButtonClick1]
sendmsg 0 自定义按钮成功
[@ItemBagButtonClick2]
sendmsg 0 自定义按钮成功
[@ItemBagButtonClick3]
sendmsg 0 自定义按钮成功
[@ItemBagButtonClick4]
sendmsg 0 自定义按钮成功
[@ItemBagButtonClick5]
#CALL [\随身仓库\随身仓库NPC.txt] @随身仓库
break

新增PC端配置，参数与之前一致，移动端与PC端按钮坐标不同，需分别配置

PCSETITEMBAGBUTTONINFO 1 1 25 -390 仓库
PCSETITEMBAGBUTTONINFO 2 1 135 -390 回收
PCSETITEMBAGBUTTONINFO 3 1 245 -390 合成


获取背包内指定道具的数量

获取背包指定物品的数量
PGGetItemsNumber
参数1：物品名字
参数2：变量名，保存获取到的物品的数量
参数3：需要的数量，如果为空或者为0，则参数2返回背包物品的数量，大于0则判断离条件数量还差多少个，如果数量满足则返回0
实例
[@main]
#if
#act
PGGetItemsNumber 疗伤药 N0
SendMsg 6 你的背包共用疗伤药【<$STR(N0)>】个
#if
#act
PGGetItemsNumber 疗伤药 N0 10
#if
Equal N0 0
#act
SendMsg 6 你需要疗伤药10个，你的背包的疗伤药数量已经足够了
#elseact
SendMsg 6 你需要疗伤药10个，你目前还缺少【<$STR(N0)>】个


获取物品的字段值

获取物品指定字段值
格式：GetDBItemFieldValue 物品名称/IDX 字段名 变量

示范脚本：
[@循环]
#ACT
GetDBItemFieldValue 屠龙 idx <$STR(N1)>
GetDBItemFieldValue 屠龙 stdmode <$STR(N2)>
sendmsg 6 idx ：<$STR(N1)> ,stdmode:<$STR(N2)>


自动拾取宝宝

自动拾取宝宝功能

格式：RECALLJINFLING 名称 移动速度 捡取范围 捡取时间 捡取距离 跟随距离 持续时间 模型大小（0.1为0.1倍，2为2倍，1为正常大小） 是否显示精灵名称（0不显示，1显示 默认1）

收回召唤出的拾取精灵

格式：CALLBACKJINGLING 精灵名称


把人物属性叠加给宝宝

ChangeSlaveAbil("把人物的属性叠加给宝宝")
有4个参数
1.宝宝名字
2.0-攻击 1-防御
3.具体值（加百分之多少）
4.0-道术 1-魔法 2-物理
支持变量

ChangeSlaveAbil 稻草人 0 50 2

ChangeHumNewValue 4个参数
参数1：类型：
0:// 暴击几率增加
1:// 增加攻击伤害
2:// 物理伤害减少
3:// 魔法伤害减少
4:// 忽视目标防御
5:// 所有伤害反弹
6:// 增加目标暴率
7:// 人物HP增加
8:// 人物MP增加
参数2：增加多少暴击（倍数）
参数3：时间
参数4：暴击伤害加成

参数4可以为空
支持变量


播放动态图的命令

播放动态图的命令 (需要在tejieconfig内开启使用新的自定义OK框)

格式：<playflash:资源名称：坐标X：坐标Y：放大比例>


切割命令

功能：切割伤害

格式： PGDelMonHp 参数1 参数2 参数3 参数4
参数1 百分比或切割值
参数2 0：当前HP的百分比，1：以参数1的值切割，2：最大的HP的百分比
参数3 0：不判断嘲讽 1：嘲讽过的怪才切割
参数4 0：默认切割 ，1：切割角色 ，2：切割英雄 ，3：切割怪物

示例：

#IF
#Act
PGDelMonHp 99 2 1 3
SENDMSG 6 你触发了切割秒杀怪。

PGDelMonHpEx 范围内百分比切割(加强)
//参数1:百分比或切割值
//参数2:0:以当前HP的百分比 1:以参数1的值切割 2:以最大HP的百分比
//参数3:0:不判断嘲讽 1:判断嘲讽过的怪才切割
//参数4:0:以自身坐标 1:以攻击目标范围
//参数5:X坐标
//参数6:Y坐标
//参数7:范围
//参数8:0:都切割 1:本次切割只切割角色，2:本体切割只切割英雄，3:本次切割只切割怪物。
//参数9:是否显示飘血动画 0:关闭 1:开启
//参数10:比例分母, 参数2为0或2时 该参数有效
实例
[@main]
#if
#act
PGDelMonHpEx 11 2 0 0 <$X> <$Y> 1 3 1 1000
SendMsg 6 切割自身1格坐标范围的怪物1.1%HP


特效播放组

playEffectRole
参数1：特效组id
特效组id取自新加配置表.\scripts\Mir200\Envir\EffectRole.txt
参数2：特效组类型id
类型id填写大于1的数字，数字相同的类型id，其特效组会覆盖；不同类型id的特效组可以共存

参数3：特效播放

0-默认值，进出视野不同步，播放时视野外的其它玩家进入视野后不可见

1-进出视野时同步，播放时视野外的其它玩家进入视野后可见

配置表EffectRole.txt（编码格式需为ANSI）

说明：配置项存在时间(毫秒)，如果希望特效一直存在，填写-1
表示例：
;特效组id,特效名称,延迟时间(毫秒),存在时间(毫秒),X坐标,Y坐标,Z坐标
1 effect_zhenfa17 0 -1 0 -1 0
2 effect_zhenfa10 0 -1 0 -1 0
2 effect_zhenfa11 1000 -1 0 0 0

命令格式

playEffectRole 2 1 1

说明：从EffectRole.txt取出特效组id为2的全部特效按照参数配置播放，有其他玩家进入视野时同步该特效，如果角色身上已经有特效组类型id为1的特效存在则先清除


使用称号和取消使用称号触发

玩家改变使用称号或刚上线有使用到称号，触发：QFunction的
人物：[@TitleChanged_XX]
XX代表物品DB中的Shape
玩家取消使用称号时，触发：QFunction的
人物：[@Untitled_XX]
XX代表物品DB中的Shape
比如
[@TitleChanged_1]
#IF
#ACT
SENDMSG 6 伟大的【沙巴克城主】上线了


传送戒指

装备道具 shape=112时，穿戴物品可以使用传送功能

传送命令：

在聊天框内输入：@move X坐标 Y坐标 可以传送到当前地图的指定坐标

点击小地图位置、NPC列表内的NPC也可以传送到指定位置


宝箱功能

道具配置（宝箱需要设置为不可堆叠）
宝箱配置 stdmode = 31 shape = 15-24
例如 15=檀木宝箱 16=紫铜宝箱 17=白银宝箱 18=赤金宝箱 19-24 其他

钥匙配置 stdmode = 40 shape = 15-24

配置表字段

shape： stdmode=31时，15 - 24，为宝箱特殊功能，可以在M2-查看-列表信息二中编辑
need ：stdmode=31，shape = 15 - 24时，need为是否需要钥匙开启：默认为0不需要， 1需要
needlevel： stdmode=31，shape = 15 - 24时，need=1时，15 - 24，对应钥匙的shape，未填写或其他数值则认为不需要
Anicount ：stdmode=31，shape = 15 - 24时，字段值为0，开启转动抽取物品；字段值为100不通过转动，打开宝箱直接给物品
source ：stdmode=31，shape =15 - 24时，0 ：不触发[@GetBoxsItemX]脚本段，1 ：触发 默认为0

宝箱配置

道具配置完成后，在M2-查看-列表信息二中编辑宝箱内容
可得物品（必填）：用户转动宝箱在此列表中根据配置的获取几率抽取一个物品
中间一格（选填）：双击选择中间一格物品直接获得，不需要摇奖，物品从中间一格及可得物品内根据获取几率选取一件
不可得： 除1个可得物品和中间1格外，宝箱显示的其余物品在此列表中抽取
每个箱子中配置的物品不能少于9个，否则箱子无法打开
配置完成可以查看BOXITEM.TXT文件 M2修改后自动生成保存
宝箱物品支持分组，同组内物品按照权重选出一种物品放入宝箱
格式：宝箱名称 物品名称 数量 获取几率（1-255数字越大几率越大） 所属类型（1可能物品 2中间一格 3不可得） 道具所属组ID 道具组内权重

脚本命令

[@GetBoxsItemX]

宝箱增加获得物品时触发qfunction中的[@GetBoxsItemX]脚本段，其中X表示当前宝箱的Shape值
当前获得的物品名称放在人物的S0变量中，例如我们在物品数据中添加一个叫做经验500000的物品
打开檀木宝箱获得此物品时自动增加50W经验，
[@GetBoxsItem15]
#if
equal s0 经验500000
#act
Take 经验500000
ChangeExp + 500000
Break

OpenDragonBox
功能：使用脚本命令开宝箱
格式：OpenDragonBox 编号（15-24）
说明：宝箱具体设置M2\查看\列表信息二\宝箱列表

开宝箱
#if
checkgold 10000
#act
OpenDragonBox 15
Take 金币 10000
#elsesay
没钱还想开宝箱


修改宝宝属性

新增修改宝宝属性的命令ChangeSlaveAbility
功能：修改宝宝属性
ChangeSlaveAbility 参数1 参数值 宝宝名（为空表示所有宝宝）
参数1表示值：
0: 当前血量； 1: 最大血量； 2:当前魔法值； 3:最大魔法值； 4:最小防御力； 5:最大防御力； 6:最小物理攻击力； 7:最大物理攻击力； 8:魔法攻击力； 9:道术； 11:移动速度 12:属性有效时间（分钟，空或0表示不检测时间）

13：抗反伤值，每次受伤反伤伤害反弹都会减少对应参数值

// 重算宝宝属性，ChangeSlaveAbility后不会重算宝宝属性，必须调用本命令
RecalcSlaveAbility 宝宝名（为空表示所有宝宝）
;------------------------------------------------

例子：
[@Test]
#IF
#ACT
ChangeSlaveAbility 11 100
ChangeSlaveAbility 12 30
RecalcSlaveAbility
sendmsg 6 您的所有宝宝移动速度增加，有效时间30分钟！
break


时装柜

需要在tejieconfig内配置开启

;是否开启时装柜 0不开启，使用现有时装功能； 1开启 默认为0
openwardrobe=0

激活的时装属性会累加，已激活的时装不可脱下（除变性），不可替换

配置：

当stdmode=66.67.68.120.121.122.123时 根据anicount配置，相同数值为同一套装，有多件相同装备的anicount相同会造成显示错误

激活时装时触发 XX为anicount号
[@TakeOn17_XX] [@TakeOff17_XX]
[@TakeOn18_XX] [@TakeOff18_XX]
[@TakeOn121_XX] [@TakeOff121_XX]
[@TakeOn122_XX] [@TakeOff122_XX]
[@TakeOn123_XX] [@TakeOff123_XX]
[@TakeOn124_XX] [@TakeOff124_XX]


脚本开关复活麻痹护身

脚本开关复活戒指
PGSetRevival
//参数1：开关, 1：开，0：关
脚本开关麻痹戒指
PGSetParalysis
//参数1：开关, 1：开，0：关
注意：该功能小退恢复
脚本开关护身戒指
PGSetMagicShield
//参数1：开关, 1：开，0：关
注意：该功能小退恢复
实例:
[@main]
#if
#act
PGSetMagicShield 1
SendMsg 6 你已经拥有了护身戒指功能了
或者
PGSetMagicShield 0
SendMsg 6 你已经关闭了护身戒指功能了
[@main]
#if
#act
PGSetRevival 1
SendMsg 6 你已经拥有了复活戒指功能了
或者
PGSetRevival 0
SendMsg 6 你已经关闭了复活戒指功能了


设置伤害加成

设置攻击伤害加成
PGSetDamageAdd
设置魔法伤害加成
PGSetMagicDamageAdd
//参数1：伤害加成类型, 1：通用，2：人物，3：怪物
//参数2：加成值，该值是加成百分比
//参数3：持续时间，空或0为在线永久
注意：该值小退清空
实例：
[@main]
#if
#act
PGSetDamageAdd 2 50
SendMsg 6 你对人物的攻击伤害为150%
[@main]
#if
#act
PGSetMagicDamageAdd 3 50
SendMsg 6 你对怪物的魔法伤害为150%
PG3.42增加两个触发字段 伤害加成结束时触发
[@PGDAMAGEADDTIMEOUTX]
[@PGMAGDAMAGEADDTIMEOUTX]
注：X对应参数1的类型
注：只能用于qf触发文本
实例：
[@PGDAMAGEADDTIMEOUT2]
#act
sendmsg 6 你对人物的物理伤害加成结束
[@PGMAGDAMAGEADDTIMEOUT3]
#act
sendmsg 6 你对怪物魔法伤害加成结束


神秘人设置

SetMySteriousMan 参数1 参数2 参数3 参数4
参数1：是否显示神秘人（0：显示玩家名称；1，显示“神秘人”）
参数2：是否简装且装备不可查看[不填默认0，不显示简装，装备可查看；填写1，显示一套默认的装备（武器：20289； 斗笠：1020 ；布衣：男 20166，女20167），并且不可以查看当前装备]
参数3：是否隐藏血量显示（0-不隐藏血量；1-隐藏血量；包含人物头顶血量及选中显示血量）
参数4：设置宠物外显模型ID（战宠，不包含拾取精灵；缺省显示原模型）

  • 参数1=0，显示玩家名称
  • 参数1=1，显示“神秘人”
  • 参数1=2，
    角色职业为战士，无名武士
    角色职业为法师，无名法师
    角色职业为道士，无名道士


对话框文字坐标设置

<text:文字内容:X:Y:列宽:行间距:字号:文字是否描边（0-不描边；默认1-描边）/@触发>

<Text:测试下这段文字的显示|提示信息:10:20/@测试>
<Text:<$STR(S87)>{FCOLOR=250}|提示信息:10:20/@测试>
<Text:测试下这段文字的显示{FCOLOR=254}|提示信息:10:20{FCOLOR=254}/@测试>
<Text:测试下这段文字的显示{AUTOCOLOR=250,251,252,253,254}|提示信息:10:20/@测试>

<textex:文字1,文字2,文字3:颜色1,颜色2,颜色3:坐标x,坐标y:最大宽度,对齐方式:行间距:字号>

对齐方式：
默认左对齐
0 左对齐
1 居中对齐
2 右对齐

[@多颜色字]
#if
#act
mov s$text "我是一号 我是一号我是一号我是一号我是一号我是一号我是一号我是一号,我是二号,我是三号"
mov s$color 14,146,222

#if
#say
<textex:<$str(s$text)>:<$str(s$color)>:40,50:300:1.5:30>


调整角色速度

格式: ChangeSpeedex 速度类型 速度值 有效时间(秒，该参数为空时表示不限制时间)
速度类型 1为 移动速度 2为攻击速度 3为魔法速度

[@main]
#ACT
CHANGESPEEDEX 1 5
#SAY
移动速度增加


发送tips提示消息

sendtipsmsg 文字内容/SCOLOR=243（支持颜色设置）

sendtipsmsg 文字内容/FCOLOR=243


背包自定义按钮引导

背包自定义按钮引导：BAGBUTTONINTERFACEARROW 按钮序号(对应SETITEMBAGBUTTONINFO的背包编号，-1为关闭按钮) 位置（1上，2下，3左，4右） 提示文字 @跳转

支持背包道具格引导：bagButtonInterfaceArrow 引导对象 引导位置 提示文字 @跳转

  • 引导对象=-1,背包窗口关闭按钮
  • 引导对象=1,2,3...,背包自定义按钮
  • 引导对象=道具名称,背包中的某个道具
    有重名道具,则选择引导最后的那个
    没有相应道具,则没有引导箭头

[@ItemBagButtonClick2]
#if
#ACT
BAGBUTTONINTERFACEARROW 2 2 点击开始自动战斗！

[@引导测试]
#if
#ACT
MAININTERFACEARROW 1010 3 点击开始自动战斗！

[@道具引导]
#act
bagButtonInterfaceArrow 回城石 2 点这里 @关闭引导
[@关闭引导]
#act
bagButtonInterfaceArrow -1 3 点此关闭


假人读取穿戴装备

LoadPlayConfig 参数1 参数2 参数3

参数1：延迟穿戴时间（分钟，支持变量）

参数2：玩家战力排行榜名次（支持变量，不包含假人，参数指向的玩家不存在时，不读取数据，不穿戴该玩家装备）

参数3：读取类型[装备位号(如武器为1)，title(所有称号)，skill（所有技能）]

装备位号支持现有全部装备位，包含生肖，时装

例如：

LoadPlayConfig 60 1 title 获取当前榜1称号，60分钟后装备到假人身上

LoadPlayConfig 60 2 skill 获取当前榜2技能，60分钟后加到假人身上

LoadPlayConfig 60 3 1 获取当前榜2装备的武器，60分钟后穿到假人身上


PGchangeSP 命令

PGchangeSP
//参数1：特殊属性编号 0=神秘人 2=麻痹 3=防麻痹 4=复活 5=破复活 6=护身 7=防护身

10= 复活成功率(默认100,复活成功率0~100)
11= 麻痹几率(1~100,默认100,0也是100)
12= 防麻痹几率(1~100,默认100,0也是100)
13= 破复活几率(1~100,默认100,0也是100)
14=破护身几率(1~100,默认100,0也是100)
所有带几率的属性，如想其发挥作用,前者必须带有此属性效果,如装备带有相同属性的效果,尽量避免使用。
//参数2: 0=关闭 1=开启
//参数3: 持续时间 单位秒 参数0或空=无限制，参数大于0为时长，(参数1是10、11、12、13、14时,此参数3变为几率控制)
注意：该功能小退失效，当玩家身上装备拥有特殊属性装备时，优先生效装备上的特殊属性。如未拥有同类特殊属性，则可以使用此命令赋予。（套装属性增加的同类属性完全失效，可以通过套装触发来用脚本命令PGChangeSP添加特殊属性）
实例：
[@main]
#ACT
PGChangeSP 5 1 10
sendmsg 6 防复活特殊属性生效，持续10秒。
展开
14:43
#IF
CHECKCURRTARGETRACE = 0
CHECKTITLE 一九归一
#Act
PGChangeSP 5 1 2
PGChangeSP 13 1 10


OKPanelPlayEffect

OKPanelPlayEffect:参数1:参数2:参数3:参数4:参数5

参数1：特效名称
参数2：播放时长（单位毫秒，-1为循环播放）
参数3：X坐标（空或-1为中间位置，需要配置缩放倍数时不可为空）
参数4：Y坐标（空或-1为中间位置，需要配置缩放倍数时不可为空）
参数5：缩放倍数（不写默认为1倍）

tejieconfig配置：
;是否使用新自定义的OK框（开启后使用新的基于像素算法的OK框）(=1时开启，默认为不开启)
isUseCustomOKPanel=1

[@显示界面]

#Say
<OKPanelPlayEffect:guangzhu1125:72000>


checkallrecharge

checkallrecharge 控制符（<>=）数字

[@充值数等于18]
#IF
checkallrecharge = 18
#ACT
SENDMSG 6 你的充值金额正好18R.
#ELSEACT
SENDMSG 6 你的充值金额小于18R.或大于18R
Break

[@充值数大100]
#IF
checkallrecharge > 100
#ACT
SENDMSG 6 你的充值金额大于100R.
#ELSEACT
SENDMSG 6 你的充值金额小于100R.
Break

[@检测当前角色的充值总数]
#IF
checkallrecharge < 100
#ACT
SENDMSG 6 你的充值金额小于100R.
#ELSEACT
SENDMSG 6 你的充值金额大于100R.
Break


跨服货币

新增跨服货币变量，同版本内的相同账号下的所有角色可用：
<$CrossServerGold> 跨服元宝
<$CrossServerPoint> 跨服游戏点
<$CrossServerDiamond>跨服钻石

检测人物的货币：
checkCrossServerGold 控制符（>, <, =） 数量
checkCrossServerPoint 控制符（>, <, =） 数量
checkCrossServerDiamond 控制符（>, <, =） 数量

货币控制命令：
CrossServerGold 控制符（+，-，=） 数量
CrossServerPoint 控制符（+，-，=） 数量
CrossServerDiamond 控制符（+，-，=） 数量

删除当前角色命令：
delrole

例：

[@增加金币]
#act
CrossServerGold + 50000
[@增加游戏点]
#act
CrossServerPoint + 50000
[@增加钻石]
#act
CrossServerDiamond + 50000

[@减少钻石]
#act
CrossServerDiamond - 20000

[@查元宝]
#if
#act
<$CrossServerGold>
sendmsg 0 当前拥有<$CrossServerGold>元宝
[@查询游戏点]
#if
#act
<$CrossServerPoint>
sendmsg 0 当前拥有<$CrossServerPoint>游戏点
[@查询钻石]
#if
#act
<$CrossServerDiamond>
sendmsg 0 当前拥有<$CrossServerDiamond>钻石
[@检测跨服元宝]
#act
checkCrossServerGold > 1000
sendmsg 0 跨服元宝大于1000
#elseact
sendmsg 0 跨服元宝小于1000


检测幸运值

检测幸运值命令：checkluckypoint ； checkluckypointex

;数值为幸运值，幸运值 > 数值时为1 否则为0
checkluckypoint 数值

;检测人物的幸运值是否符合条件
checkluckypointex 控制符(>，<，=) 数值

[@检测人物的幸运值是否符合条件]
#IF
checkluckypointex = 7
#ACT
SENDMSG 6 你的幸运符合7.
#ELSEACT
SENDMSG 6 你的幸运值未达到要求，要求是7.
Break

[@数值为幸运值]
#IF
checkluckypoint 1
#ACT
SENDMSG 6 幸运值大于1.
#ELSEACT
SENDMSG 6 幸运值小于1
Break


读写配置项

ReadConfigFileItem

PGReadConfigFileItem
备注:此功能支持绝对路径

参数1：路径
参数2：sAppName （节点名）
参数3：sKeyName （配置项）
参数4：要保存到的变量名

实例：

[@main]
#if
#act
ReadConfigFileItem \QuestDiary\KEY.txt <$UserName> 内容 S3
SendMsg 0 你已经把配置文件KEY.txt中内容取出并保存到了S3变量

WriteConfigFileItem

PGWriteConfigFileItem

备注:此功能支持绝对路径

参数1：路径
参数2：sAppName （节点名）
参数3：sKeyName （配置项）
参数4：要写入的内容

实例：

[@main]
#if
#act
WriteConfigFileItem \QuestDiary\KEY.txt <$USERNAME> 内容 <$STR(S3)>
SENDMSG 6 你已经把你输入的内容写到配置文件中KEY.txt

注意：如果想读取本地上传的配置，配置文件拓展名需要改成： .txt.ConfigFileItem

文本格式为：

[节点名]

配置项1=XXXX

配置项2=XXXX

配置项中间不要有空行


CheckStoneCount

检测玩家身上所穿装备某个宝石的数量

CheckStoneCount 参数1 参数2 参数3

参数1：宝石名称
参数2：控制符（>,<,=）
参数3：数量

[@宝石检测]
#if
CheckStoneCount 刀锋之石·神化 > 2
#act
sendmsg 0 大于2
#elseact
sendmsg 0 小于2


宝宝攻击触发

宝宝物理攻击触发[@SlaveAttack]
宝宝魔法攻击触发[@SlaveMagicAttack]

宝宝受到物理攻击触发[@SlaveStruck]
宝宝受到魔法攻击触发[@SlaveMagicStruck]

增加魔法触发功能.自身技能触发. Q-Function.txt中[@SlaveMagTagFuncX]段,其中X表示要触发的魔法ID
增加魔法触发功能.对目标人物使用时自身触发. Q-Function.txt中[@SlaveMagTagFuncX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标人物技能触发. Q-Function.txt中[@SlaveMagSelfFuncX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标怪物技能触发. Q-Function.txt中[@SlaveMagMonFuncX] 段,其中X表示要触发的魔法ID

Q-Function.txt中配置

[@SlaveAttack]
#IF
#ACT
sendmsg 0 触发物理攻击

[@SlaveMagicAttack]
#IF
#ACT
sendmsg 0 触发魔法攻击

[@SlaveStruck]
#IF
#ACT
sendmsg 0 触发道术攻击

[@SlaveMagicStruck]
#IF
#ACT
sendmsg 0 受到魔法攻击

[@SlaveMagSelfFunc44]
#IF
#ACT
sendmsg 0 寒冰掌攻击

[@SlaveMagTagFunc37]
#IF
#ACT
sendmsg 0 群体雷电术攻击

[@SlaveMagTagFuncEx52]
#IF
#ACT
sendmsg 0 飓风破攻击

[@SlaveMagMonFunc1]
#IF
#ACT
sendmsg 0 受到火球术攻击


mongen.txt参数

mongen.txt

格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率(没支持) 名字颜色(0~255) 内功怪物(0,1)（未支持） 国家编号 同国家名玩家是否可攻击(0,1) 怪物视野 属性倍率 模型大小 掉落倍率（百分比） 怪物归属配置 怪物墓碑（0：不显示墓碑；1：显示墓碑）

怪物归属：

0或空：默认
1：首刀
2：最高伤害
3：共享归属

4：首刀且掉落物飞入背包 （注意：配置后，设置内不拾取的物品也会飞入背包，包满后会通过邮件发送，带附件的邮件到达数量上限便不再发送邮件）

例：

1xsly 135 77 双斧·牛魔王 500 50 1 0 251 1 1 1 1 1 1 100 1
1xsly 135 58 双锤·牛魔王 500 50 1 0 250 1 1 1 1 1 1 100 1
1xsly 81 26 大刀·牛魔王 500 50 1 0 254 1 1 1 1 1 1 100 1
1xsly 89 51 泽西之恶魔[BOSS] 500 20 2 0 249 1 1 1 1 1 1 100 2
1xsly 46 45 魔法之女巫[BOSS] 500 20 2 0 249 1 1 1 1 1 1 100 3


释放技能

通过命令释放的技能不会触发qf内的攻击触发@块

角色释放技能
ReleaseSkill 参数1 参数2 参数3 参数4 参数5 参数6
参数1：技能名称 （支持自定义技能）
参数2：目标（0：所有目标，1：仅人物，2：仅怪物）
参数3：附加伤害
参数4：附加伤害是否考虑防御（0不考虑，1考虑）
参数5：技能释放延迟时间（毫秒） 如：5000 则5秒后释放技能

参数6：技能等级

宝宝释放技能
slaveReleaseSkill 参数1 参数2 参数3 参数4 参数5
参数1：技能名称 （支持自定义技能）
参数2：目标（0：所有目标，1：仅人物，2：仅怪物）
参数3：附加伤害
参数4：附加伤害是否考虑防御（0不考虑，1考虑）
参数5：技能释放延迟时间（毫秒） 如：5000 则5秒后释放技能

例：

QFunction-0.txt配置：
[@Attack]
#act
ReleaseSkill 烈火剑法 1 100000 1 5000
sendmsg 6 触发烈火剑法100000伤害

[@slaveattack]
#act
slaveReleaseSkill 烈火剑法 0 100000 0 0
sendmsg 6 触发烈火剑法100000伤害


角色静止

人物
stopAction 参数1 参数2
参数1：停止时长（毫秒）
参数2：停止期间是否无敌（默认0，不无敌；1无敌）

宝宝（不对捡物精灵生效，切换地图时清除改状态）
效果同宝宝休息，但是在停止期间不会跟随人物传送
slaveStopAction 参数1 参数2

参数1：停止时长（毫秒）
参数2：停止期间是否无敌（默认0，不无敌；1无敌）

[@人物禁止]
#if
#act
stopAction 6000 1

[@人物禁止1]
#if
#act
stopAction 6000 0

[@宝宝禁止]
#if
#act
slaveStopAction 6000 1

[@宝宝禁止1]
#if
#act
slaveStopAction 6000 0


任务引导

功能：在任务栏弹出引导箭头，指向对应ID任务（手机端箭头方向向左 ，PC端箭头方向向右）
通过任务ID引导
MissonGuideArrow 任务ID 提示文字内容

[@任务栏弹出箭头]
#IF
#ACT
MissonGuideArrow 1001 箭头测试


国战相关命令

国家配置：
国家编号、名字 Envir\Nations\Nations.ini中的NationalNames1 -- NationalNames100是国家的名字,只有定义了国家名字之后加入国家才有效!
聊天频道 ;tejieconfig内配置是否显示国家频道，1显示，0不显示，默认不显示
nationchannel=0

国家变量：
国家编号：<$NATION>
国家名称：<$NATIONNAME>
国家人数：<$NATIONPEOPLE>
国家金币：<$NationGold>
建筑能力：<$NationBuilding>
军事能力：<$NationArm>
经济能力：<$NationEconomy>
政治能力：<$NationPolitics>
国家贡献：<$NationContribution>
地图数：<$NationMaps>
国王名称变量:<$NATIONKING>
指定编号国家信息（编号用X表示（1-100）） 国家名称：<$NationNameX>
国家人数：<$NationPeopleX>
国家金币：<$NationGoldX>
建筑能力：<$NationBuildingX>
军事能力：<$NationArmX>
经济能力：<$NationEconomyX>
政治能力：<$NationPoliticsX>
国家贡献：<$NationContributionX>
地图数：<$NationMapsX>
国王名称变量：<$NATIONKINGX>

国家相关命令：
检测是否加入国家 CheckNation 国家编号（如果是0，就表示没有加入国家）
加入国家 JoinNation 国家编号
检查是否国王 IsNationKing 国家编号 （为空表示所有国家）
退出国家 ExitNation
检查国家人数 CheckNationHumCount 控制符（>,<,=） 人数
成为国王 SetNationKing 国家编号
修改国家名称 SetNationName 国家编号 国家名字
检测国家名字是否被使用 CheckNationNameExists 国家名称
设置国家相应的变量值 SetNationValue 国家编号(0表示人物所在的国家，1-100指定国家） 编号(0-6) 操作符(+,-,=) 值
参数2的编号如下：
0:金币
1:建筑能力
2:军事能力
3:经济能力
4:政治能力
5:国家贡献
6:地图数

国家脚本刷怪设定 此命令支持怪物巡逻坐标攻击，设置多个指定坐标后，怪物会沿途巡逻(按照设定坐标行走到最后一个坐标停止)
格式:
MISSION 地图 x1|x2|x3...xn y1|y2|y3...yn (x和y的数量要一致）
PARAM1 刷新怪物座标X
PARAM2 刷新怪物座标Y
PARAM3 数量
PARAM4 范围
PARAM5 国家编号
PARAM6 是否攻击本国玩家(0,1)
PARAM7 不同国家怪物是否PK(0,1)
PARAM8 怪物名字颜色
PARAM9 是否允许本国玩家攻击(0,1)
MobPlace 怪物名称 目标名称(为空表示可攻击所有可攻击的对象，指定名字表示只攻击指定名称的可攻击对象)


扩展NPC脚本点击触发带参数
-----------------------------------扩展NPC脚本点击触发带参数------------------------------

///////////////////////////////////////////////////////////新增触发带参数

<@测试1/@测试(1,2,3)> <@测试2/@测试(2,3,4)>
[@测试]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 1,2,3
CHECKSCRIPTPARAM 2,3,4
#ACT
SENDMSG 6 <$SCRIPTPARAM1>,<$SCRIPTPARAM2>,<$SCRIPTPARAM3>
break
#ELSEACT
SENDMSG 6 非法的参数
break

[@main]
你想买点什么呢?\\
<麻痹戒指/@购物(20,麻痹戒指)> <重生戒指/@购物(20,重生戒指)>\
<护体戒指/@购物(20,护体戒指)> <魔道麻痹/@购物(20,魔道麻痹戒)>\
[@购物]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 20,麻痹戒指
CHECKSCRIPTPARAM 20,护体戒指
CHECKSCRIPTPARAM 20,重生戒指
CHECKSCRIPTPARAM 20,魔道麻痹戒
#ELSEACT
;-----------------------------------------------防止用抓包工具刷数据并且跳过了检测
SENDMSG 6 非法的参数
break
#IF
CHECKGAMEGOLD <$SCRIPTPARAM1>
#ACT
GAMEGOLD - <$SCRIPTPARAM1>
GIVE <$SCRIPTPARAM2> 1
#ELSESAY
对不起!你的元宝不够!

####################################################2019-08-28进行补充说明，防止个别人运用错误！！！！！下面为解说！！！！#########################################

[@main]
亲爱的<$USERNAME>\
你想买点什么呢?\\
<麻痹戒指/@购物(20,麻痹戒指)> <重生戒指/@购物(20,重生戒指)>\
<护体戒指/@购物(20,护体戒指)> <魔道麻痹/@购物(20,魔道麻痹戒)>\
[@购物]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 20,麻痹戒指
CHECKSCRIPTPARAM 20,护体戒指
CHECKSCRIPTPARAM 20,重生戒指
CHECKSCRIPTPARAM 20,魔道麻痹戒
#ELSEACT
;-----------------------------------------------防止用抓包工具刷数据并且跳过了检测
SENDMSG 6 非法的参数
break
#IF
CHECKGAMEGOLD <$SCRIPTPARAM1>
#ACT
GAMEGOLD - <$SCRIPTPARAM1>
GIVE <$SCRIPTPARAM2> 1
#ELSESAY
对不起!你的元宝不够!

------------------------------------**************************************但是一些GM会写成这样，然后来提交BUG*******************************-------------------------
**************************************************************************** 下面的写法会出问题:
<@测试1/@测试(封号1,100,封号1+)>
[@测试]
#ACT
;下面的脚本可能会触发跳转 @UnactiveTitle_XX @ActiveTitle_XX，而为了保证安全发生跳转到新的标签时会清掉参数值
;建议可能触发跳转之前，用变量先存起来
GameGold - <$SCRIPTPARAM2>
RecycFenghao <$SCRIPTPARAM1>
GiveFenghao <$SCRIPTPARAM3> 1
MessageBox <$SCRIPTPARAM1>,<$SCRIPTPARAM2>,<$SCRIPTPARAM3>


新增脚本命令:关联give物品LinkGiveItem

给物品触发

Give命令触发QF内的@块[@GiveItemX]

[@GiveitemX]

1.X为物品ID

2.通过脚本命令 give 给玩家物品时，触发qf里的[@GiveItemX]

脚本命令：LinkGiveItem

功能：可以对give的物品进行关联，该命令只能在捡取触发里[@GiveItemX]使用

[@GiveItem1]
#IF
#ACT
LinkGiveItem
;关联后就可以使用其他脚本命令对刚刚捡取的物品进行检测，或操作
;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253
;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
;修改后的参数，刷新到客户端
SENDUPGRADEITEM
[@给物]
#IF
#ACT
give 回城石 1
QFunction-0.txt配置：
[@Giveitem18]
#ACT
sendmsg 0 给与一个传送石
给任意物品触发 ： [@GiveItemEX] 触发器对装备类道具返回唯一id，存入变量s0 ，装备名称，存入变量s1

[@GiveItemEX]
#if
#ACT
Sendmsg 7 成功触发物品提示
break

[@测试GIVE]
#IF
#act
give 等级丹 10
sendmsg 6 等级丹 10！


系统调用的创建删除npc命令

CreateMapNPC NPC名字 地图 坐标X(-1时随机坐标) 坐标Y(-1时随机坐标) 外观 脚本文件 脚本文件是否要加上地图名称 存在时间（单位：秒；0：永久 ）

DelMapNpc NPC名字 地图名字（不写则删除所有CreateMapNPC创建的对应名字的npc）

RobotManage文档脚本

[@创建NPC-1]
#act
mov s0 创建npc测试
CreateMapNPC 测试 3 35 25 8 创建npc测试 1
sendmsg 6 创建npc了

[@创建NPC-2]
#act
mov s0 创建npc测试
CreateMapNPC 测试 3 38 25 8 创建npc测试 1
sendmsg 6 创建npc了

[@创建NPC-3]
#act
mov s0 创建npc测试
CreateMapNPC 测试 0 57 40 8 创建npc测试 1
sendmsg 6 创建npc了

[@删除NPC-1]
#act
DelMapNpc 测试 3
sendmsg 6 删除npc了

[@删除NPC-2]
#act
DelMapNpc 测试
sendmsg 6 删除npc了

AutoRunRobot定时执行文档脚本

#AutoRun NPC SEC 8 @创建NPC-1
#AutoRun NPC SEC 8 @创建NPC-2
#AutoRun NPC SEC 8 @创建NPC-3
#AutoRun NPC SEC 20 @删除NPC-1
#AutoRun NPC SEC 30 @删除NPC-2


拍卖行

拍卖行配置

tejieconfig增加拍卖行配置
;拍卖行交易货币设置,不配置默认为金币，货币最大值为21亿

[setAuctionHouseCurrency]

;货币名称 货币 最低上架价格
金币 <$GOLDCOUNT> 100
元宝 <$GAMEGOLD> 10
充值点 <$GAMEGIRD> 10

;标签配置
[setAuctionHouseTag]
一级标签 二级标签
全部 (默认显示不用配） 全部已上架物品
装备_类型标签名1#道具类型1，道具类型2| 类型标签名2#道具类型1，道具类型2
书籍_类型标签名1#道具类型1，道具类型2| 类型标签名2#道具类型1，道具类型2
材料_类型标签名1#道具类型1，道具类型2| 类型标签名2#道具类型1，道具类型2

例如
[setAuctionHouseTag]
装备_武器#5,6|衣服#10,11|头盔#15
书籍_卷轴#3
材料_药水#0|食物#1

;设置拍卖行vip等级和手续费率，可上架物品数量(不设置默认为等级0 手续费10 可上架物品数量1 上架时间120分钟)

[auctionvip]
;拍卖行vip等级（0-99） 手续费（百分比） 可上架物品数量 上架时间（分钟）
0 10 1 120
1 9 2 180

拍卖行相关命令

打开拍卖行页面命令：openAuctionHouse

设置拍卖行vip等级命令：

setauctionvip 等级 时长（单位：分，-1为永久）

设置等级后，立即生效，vip等级不会同时存在多个，手续费、可上架物品数量不会叠加


OKPanelPlayEffectEx

功能：在当前OK框播放特效
OKPanelPlayEffectEx 参数1 参数2 参数3 参数4 参数5
参数1：特效名称
参数2：播放时长（单位毫秒，-1为循环播放）
参数3：X坐标（空或-1为中间位置，需要配置缩放倍数时不可为空）
参数4：Y坐标（空或-1为中间位置，需要配置缩放倍数时不可为空）
参数5：缩放倍数（不写默认为1倍）

#IF
#SAY
<功能类型/@功能>
#act
break

[@功能]
#IF
#act
OKPanelPlayEffectEx guangzhu1213 3000 -1 -1 1


坐骑功能

坐骑

配置方法： stditems表

stdmode=28，Anicount≠0时：Value19字段配置模型ID （739：鲲 740：棕马 741：熊猫）

QF段触发：
@UPHORSE：上马触发

[@UPHORSE]
#if
#act
Sendmsg 7 您的坐骑成功被召唤！
break
-------------------------------------------------------
@DOWNHORSE：下马触发

[@DOWNHORSE]
#if
#act
Sendmsg 7 您的坐骑成功被收回！
break

tejieconfig配置 ;上/下马间隔时间配置（单位：秒，不配置无限制）
UpHorseCD=1
;受击下马几率（百分比，不配置为100%）
DownHorseRate=66


打开背包触发

 打开背包时触发qf内@块[OpenHumBag ]

QFunction-0.txt配置：
[@OpenHumBag]
#ACT
sendmsg 6 触发对应功能


打开网站

格式： OpenWebsite 网站地址

格式：PgOpenWebsite 网站地址 是否真正打开(1,真正打开，0不真正打开) 参数 参数存储变量（变量可不写）

[@打开网站]
#if
#act
OpenWebSite http://www.herom2.com

[@网站且传参]
#if
#act
PgOpenWebsite http://www.baidu.com 1 <$USERNAME> S31
SENDMSG 6 <$STR(S31)>

[@网站例子]
#IF
#ACT
PgOpenWebsite http://10.0.0.100:9000/zentao/my/ 1 我们 S32
sendmsg 0 <$STR(S32)>

[@打开网站无变量]
#IF
#ACT
PgOpenWebsite http://10.0.0.100:9000/zentao/my/ 1 我们
sendmsg 0 成功打开网站


检测是否已召唤拾取精灵

增加是否已经召唤拾取精灵的命令

checkSqjlStat

[@检测是否召唤拾取精灵]
#if
checkSqjlState
#ACT
SENDMSG 6 已经召唤
#ELSESAY
未能召唤出。


沙城相关命令

1.强制修改沙城归属

changeSabukLord 行会名称

2.强制马上开启/停止攻城(不受M2设置限制,随时开启/停止) 注意：强制开启后，需要再次触发该命令才会结束攻城活动

forcedWallconquestWar

[@强制修改沙城归属]
#IF
#act
changeSabukLord 行会测试
SENDMSG 6 沙巴克已归属阿斯顿公会。
#ELSESAY
未能成功执行该命令。

[@强制马上开启/停止攻城]
#IF
#act
forcedWallconquestWar
SENDMSG 6 攻城已经开启。
#ELSESAY
攻城已经停止。


获取当天充值总额

获取当天充值总额的命令

getDayRecharge

[@获取当日充值]
#act
getDayRecharge s$当日充值


获取boxitem堆叠物品数量

获取boxitem堆叠数量的命令： getBoxItemNum 参数一：boxitem序号 参数二：返回值

[@获取数量]
#if
#act
#say
<>\<>\
<> \
<放入可鉴定装备/scolor=150> → <ITEMBOX:0:13:10:0:-10:35:35:*:装备鉴定> <√开始鉴定/@jd>
[@jd]
#act
getBoxItemNum 1 param

sendmsg 0 <$STR(param)>个


获取指定npc坐标

获取指定npc坐标命令：getNpcPos 参数1:地图名称 参数2:NPC名称 参数3：返回值1（X坐标） 参数4：返回值2（Y坐标）

[@获取坐标]
#IF
#ACT
getNpcPos 3 生死八门 px py
sendmsg 0 <$str(px)>
sendmsg 0 <$str(py)>


合服次数

获取合服次数命令 （取合服次数的最大值）

getJoinCount 合服次数变量

检测合服次数命令

checkJoinCount 控制符(>,=,<) 次数

示例：

#SAY

<获取合服次数/@获取合服次数> <检测合服次数大小/@检测合服次数大小>\
[@获取合服次数]
#act
mov s$合服次数
getJoinCount s$合服次数
sendmsg 6 合服次数：<$str(s$合服次数)>

[@检测合服次数大小]
#if
checkjoincount > 1
#act
sendmsg 6 合服次数大于1
break
#if
checkjoincount = 1
#act
sendmsg 6 合服次数等于1
break
#if
checkjoincount < 1
#act
sendmsg 6 合服次数小于1
break


使用货币触发

使用货币时，触发qf内@块
[@COST_GAMEGLORY]
[@COST_GAMEDIAMOND]
[@COST_GOLDCOUNT]
[@COST_GAMEPOINT]
[@COST_GAMEGOLD]
[@COST_GAMEGIRD]
[@COST_CREDITPOINT]

使用货币触发qf内@块,返回货币消耗值
返回值存入变量M0

[@COST_GAMEGLORY]
sendMsg 6 获得GAMEGLORY<$STR(M0)>点

[@COST_GAMEDIAMOND]
sendMsg 6 获得GAMEDIAMOND<$STR(M0)>点

[@COST_GOLDCOUNT]
sendMsg 6 获得GOLDCOUNT<$STR(M0)>点

[@COST_GAMEPOINT]
sendMsg 6 获得GAMEPOINT<$STR(M0)>点

[@COST_GAMEGOLD]
sendMsg 6 获得GAMEGOLD<$STR(M0)>点

[@COST_GAMEGIRD]
sendMsg 6 获得GAMEGIRD<$STR(M0)>点

[@COST_CREDITPOINT]
sendMsg 6 获得CREDITPOINT<$STR(M0)>点

脚本命令QF中

[@COST_GOLDCOUNT]
;金币
#IF
#ACT
SendMsg 5 金币产生了消耗 获得GOLDCOUNT<$STR(M0)>点

[@COST_GAMEGOLD]
;元宝
#IF
#ACT
SendMsg 5 元宝产生了消耗 获得GAMEGOLD<$STR(M0)>点


永久增加人物元素属性

AddHumNewValue 属性（0-10） 操作符（+、-、=） 值（1-100）

参数一：

(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

[@加人物元素属性]

#act

AddHumNewValue 0 + 100
AddHumNewValue 1 + 100
AddHumNewValue 2 + 100
AddHumNewValue 3 + 100
AddHumNewValue 4 + 100
AddHumNewValue 5 + 100
AddHumNewValue 6 + 100
AddHumNewValue 7 + 100
AddHumNewValue 8 + 100
AddHumNewValue 9 + 100

[@减人物元素属性]

#act

AddHumNewValue 0 - 100
AddHumNewValue 1 - 100
AddHumNewValue 2 - 100
AddHumNewValue 3 - 100
AddHumNewValue 4 - 100
AddHumNewValue 5 - 100
AddHumNewValue 6 - 100
AddHumNewValue 7 - 100
AddHumNewValue 8 - 100
AddHumNewValue 9 - 100

[@等人物元素属性]

#act

AddHumNewValue 0 = 100
AddHumNewValue 1 = 100
AddHumNewValue 2 = 100
AddHumNewValue 3 = 100
AddHumNewValue 4 = 100
AddHumNewValue 5 = 100
AddHumNewValue 6 = 100
AddHumNewValue 7 = 100
AddHumNewValue 8 = 100
AddHumNewValue 9 = 100


自动寻路打开指定NPC面板

描述

自动寻路打开指定NPC面板 （重名的npc会寻找第一个）

新增命令
openNpcShowEx

格式

命令名 | 参数1 | 参数2 | 参数3 | 参数4
openNpcShowEx | 地图名 | NPC名称 | 传送范围下限 | 到NPC距离

说明

  • 参数1：寻路至哪张地图
  • 参数2：寻路至哪个NPC
  • 参数3：传送范围下限
    在此范围内执行寻路，可手动打断（点击地面）
    超出此范围执行传送，
    参数3=-1，表示同屏内
    执行该命令时，参数3是否大于主角当前位置到指定NPC的距离
    即同地图内，超出设定距离（参数3）直接传送，未超出设定距离寻路过去。
    • 大于，则主角寻路至NPC身边
    • 不大于，则主角直接传送至NPC身边
  • 参数4：主角寻路或传送至距NPC多远的位置

命令用例
openNpcShowEx shabake 城战管理员 -1 2

用例说明
如果主角距离沙巴克的城战管理员在同屏内，则寻路至城战管理员身边2格处，
否则直接传送至沙巴克的城战管理员身边2格处。
具体位置随机。


优先打指定打怪,支持多个怪物一起

新增命令

killMobAppoint

功能 ：
优先打指定区域中指定名称的怪,支持多个怪物一起。
指定区域中没有指定怪，则打其它的怪，
10秒后重新判断指定区域指定名称的怪

注：需要与MapMove命令组合使用

格式：

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6
killMobAppoint | 地图名 | 坐标X | 坐标Y | 范围 | 怪物名称1|怪物名称2.... | 0，关闭；1，开启

参数6

开启或关闭对指定怪的攻击,不停止挂机功能

修改命令

stopAutoPlayGame

停止挂机功能,且关闭对指定怪的攻击

脚本用例：

;例子
[@批量打指定怪物]
#IF
#ACT
MAPMOVE H007 162 173
KILLMOBAPPOINT H007 162 173 20 祖玛雕像|祖玛弓箭手|槭蛾 1
SENDMSG 6 你当前在幻境七层优先选择打祖玛雕像,祖玛弓箭手,槭蛾


怪物掉落展示

描述

  • 掉落展示处理
    屏幕上方的怪物血条后增加一个显示按钮，
    点击图示红框区域，展示预先配置的4-6种掉落物的图标，
    点击道具图标弹出对应的tips

  • 掉落数据配置
    怪物掉落文件中新增掉落物品展示块[display]
    掉落的物品配置在此块中

怪物掉落表：

[display]
山河图
仙缕神衣
九色仙鼎
红名清洗卷


装备数量相关命令

描述

checkEquipNum
检测指定装备的数量,包含装备位与背包

格式:
命令名 | 参数1 | 控制符 | 参数2
checkEquipNum | 装备名 | <、>、 = | 数量

用例:

checkEquipNum 倚天剑 = 2
checkEquipNum 屠龙刀 > 2

getEquipNum
返回指定装备的数量,包含装备位与背包

格式:
命令名 | 参数1 | 参数2
getEquipNum | 装备名 | 变量

用例:

getEquipNum 力量戒指 N$力量戒指数量

takeEquip

系统回收指定装备,包含装备位与背包

  • 未指定回收数量(参数2),回收装备位与背包全部指定装备
  • 指定回收数量(参数2),优先回收装备位装备
  • 设定回收数量(参数2)>装备位与背包格之和,则回收全部指定装备
格式:
命令名 | 参数1 | 参数2
takeEquip | 装备名 | 回收数量

用例:

takeEquip 虹膜项链 3


检测聚灵珠是否集满

checkExpBead

[@聚灵珠]
#if
checkExpBead
#act
sendmsg 0 聚灵珠充能满


改变物品外观

改变物品外观 ：支持 武器、衣服、时装武器、时装衣服 、头盔、斗笠、 面巾

changeitemshape 参数一：装备位置 参数二：shape值（-1表示初始状态） 参数三：look值（-1表示初始状态） 参数4:Value20(-1表示初始状态)

[@衣服外观]
#if
#act
changeitemshape 0 2086 300150
[@武器外观]
#if
#act
changeitemshape 1 20007 300135
[@时装外观]
#if
#act
changeitemshape 18 20073 300298


小地图备注显示

描述

小地图显示地图标识文字和标识了怪物墓碑的怪物名字

  • 小地图上显示有地图标记的描述信息
    新增文件
    .\Mir200\Envir\mapDesc.txt
    标记id | 地图名称 | 坐标x | 坐标y | 显示名称 | 文字颜色
    1 | shabake | 50 | 60 | 毒蛇山谷 | 222
  • 小地图上显示有怪物墓碑标记的怪物名称
    mongen.txt中配置了怪物墓碑的怪物,名称显示在小地图上
    怪物名称的颜色与mongen设定一致
  • 小地图上,上述两个标识,坐标点会有绿色小点显示

游戏内效果展示


OK框内即时刷新倒计时：
有单位转换：
时间倒计时(天数+小时+分钟+秒),每秒刷新
<timeTips:x:y:参数1{scolor=159}/@触发>
参数1:
代表秒的数字
可自动转化为 天数+小时+分钟+秒
不足一天显示 小时+分钟+秒
不足小时显示 分钟+秒
不足分钟显示 秒
倒计时结束,执行触发
没有单位转换：
每秒倒计时
<countDown:x:y:参数1{scolor=159}/@触发>
参数1:
代表秒的数字
倒计时结束,执行触发


跑马灯消息

SENDMOVEMSGEX 信息类型代码(0全局发送，1发送给个人) 字体颜色(0-255) 背景颜色(0-255) Y坐标 滚动次数 信息内容 是否置顶（0，否；1，置顶层级） 滚动播放时长 跑马灯编号(1 2 3)

[@发送跑马灯消息]

#act

SENDMOVEMSGEX 0 250 0 0 3 测试 1 10 1
SENDMOVEMSGEX 0 250 0 0 3 测试 1 5 2
SENDMOVEMSGEX 0 250 0 0 3 测试 1 3 3


强化等级（星星）套装属性

同样装备、不同强化等级的套装，会触发不同的套装属性

例如：

1星 圣战项链 + 1星 圣战头盔 触发1星套装属性

2星 圣战项链 + 1星 圣战头盔 触发1星套装属性

2星 圣战项链 + 2星 圣战头盔 触发2星套装属性

仅支持 1-9星

1.套装说明：需要相同的套装名称

2.套装物品：相同的配置

3.套装星级：强化等级达到时，触发套装属性


怨念

怨念定义
怨念效果：
降低怪物(BOSS)回血百分比。

新增系统变量：<$slowHot>，初始化为 0
新增命令：changeSlowHot (+-=) 数值 装备位置
装备位置=-1，为自定义 ok 框
装备位置=1-13，为指定位置装备
怪物回血：原怪物回血值 * (1-<$slowHot>) * 等级衰减效果

怨念等级：
? 对于不大于怨念等级的怪物，上述怨念效果百分百生效。
? 对于大于怨念等级的怪物，上述怨念效果按等级差衰减。

新增系统变量：<$slowHotLv>
新增命令：changeSlowHotLv 数值
等级衰减效果=<$slowHotLv>/怪物等级

例如：

怪物等级2，怨念等级1则衰减效果为50%

新增对怪 buff
changeModeEx 26 2
对怪施加了 2 秒怨念效果，2 秒内怪物回血受怨念影响。
原怪物回血值 * (1-<$slowHot>) * 等级衰减效果

[@怨念效果]
#if
#act
changeSlowHot + 50
changeSlowHotLv + 50
changeModeEx 26 3600
#say
60 秒内攻击目标，可以使目标怨念，怨念时长 3600 秒。


麻痹几率衰减

麻痹效果衰减

;配置了NumbRatio, changeMdeEx 18命令中的麻痹数值则无效

新增系统变量：<$numbRatio>，初始化为 0
新增命令：changeNumbRatio (+-=) 数值 装备位置
装备位置=-1，为自定义 ok 框
装备位置=1-13，为指定位置装备
麻痹公式：<$numbRatio> * 等级衰减效果

麻怪等级：
? 对于不大于麻怪等级的怪物，上述麻痹效果百分百生效。
? 对于大于麻怪等级的怪物，上述麻痹效果按等级差衰减。
新增系统变量：<$numbLv>
新增命令：changeNumbLv 数值
等级衰减效果= <$numbLv>/怪物等级

例如：

怪物等级=2 ， 麻痹等级=1，麻痹几率为80%， 则衰减效果为 0.8*1/2，即 40%几率麻痹目标

对怪施加 buff
changeModeEx 18 10 100 2
10 秒内攻击目标，可以使目标麻痹，麻痹机率：<$numbRatio> * 等级衰减效果，麻痹时长 2 秒。


获取怪物数量

getRangeMonCount
获得指定地图指定怪物的数量

格式：
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6
getRangeMonCount | 地图名 | X坐标 | Y坐标 | 范围 | 变量 | 怪物名称

说明：

  • 参数4=-1，表示全地图
  • 参数5为返回值
  • 参数6为检测的怪物名称
    参数6为-1，表示本图全部怪

脚本示例：

#act
getRangeMonCount 3 0 0 -1 n0 -1
sendMsg 6 盟重城当前有<$str(n0)>只怪。
getRangeMonCount 3 0 0 -1 n0 稻草人
sendMsg 6 盟重城当前有<$str(n0)>只稻草人。


设定指定道具的掉落系数

humanDropItem

命令名 | 参数1 | 参数2
humanDropItem | 道具名 | 百分比

  • 参数1：设定掉落系数的道具
  • 参数2：个人指定道具掉落系数
    指定道具最终掉率=怪物掉落文件设定值 X killMonBurstRate修正系数 X 个人指定道具掉落系数
    未使用此命令，个人指定道具掉落系数为1
  • 此命令变更数据会保存在数据库

globalDropItem

命令名 | 参数1 | 参数2
globalDropItem | 道具名 | 百分比

  • 参数1：设定掉落系数的道具
  • 参数2：全局指定道具掉落系数
    指定道具最终掉率=怪物掉落文件设定值 X killMonBurstRate修正系数 X 个人指定道具掉落系数 X 全局指定道具掉落系数
    未使用此命令，全局指定道具掉落系数为1
  • 此命令变更数据会保存在数据库

追加tejieconfig配置后的整体掉率公式备忘
指定道具最终掉率=原掉率 X 个人指定道具掉落系数 X 全局指定道具掉落系数 X 开服小时掉落系数 X 全服衰减系数 X 个人衰减系数

以上的最终值还受一个系数的影响：mongen.txt里的掉落倍率（原有的最终掉率*(这个值/100)）

[@指定掉落]
#if
#act
humanDropItem 技能书页 10000
globalDropItem 经验宝箱 10000
sendMsg 6 指定掉落开启


打开背包

新增 打开背包 命令
openHumBag

示例:

#act
openHumBag
sendMsg 6 你打开了角色的背包


隐藏主界面按钮

clsMainUI

用例:

[@对话框]
#act
openMerchantBigDLG shj_00862 4 -391 0 0 -7 -60

clsMainUI
#say
<这是一个对话框>


背包内可用道具绿点提示

Stditems表变更

可使用类道具(StdMode=31)，

need和needLevel字段新增定义

need | needlevel | 说明
0 | 指定等级 | 需要指定等级以上才可以戴上
4 | 指定转生等级 | 需要指定转生等级以上才可以戴上

tejieconfig配置：

;是否显示背包内可用道具绿点提示：0-不显示 1-显示
viewgreenpoint=1


怪物头顶特殊伤害飘字

playCutHurt

对怪切割时,用命令在怪物头顶播放掉血字
播放位置与原飘相同

格式：

命令名称 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7
playCutHurt | 模式 | 伤害求和 | 字符串 | 字号 | 掉血量 | 飘字颜色0-255 | 目标类型

说明：

  • 参数1
    • 0，切割万分比
    • 1，切割数值
  • 参数2，伤害求和
    • 0，不求和
    • 1，求和
  • 参数3，指定字符+%d
    • 参数2=0，%d代表切割伤害
    • 参数2=1，%d代表本次正常伤害与切割伤害之和
    • 参数2=1，不再单独播放本次正常伤害与切割伤害飘字
    • 字符串支持颜色设置
  • 参数4，本次飘字使用的字号
  • 参数5，本次飘字使用的字号
    • 模式0，掉血量是万分比整数值,即写10000表示100%
      附加掉血量=万分比(即参数2)*怪物总血量
    • 模式1，附加掉血量(即参数2)是整数值
  • 参数6，本次飘字使用颜色
  • 参数7，目标类型

    • 0，目标（怪物，玩家均生效）
    • 1，自己

1、参数2为不求和类型的本命令，都生效

2、参数2为求和类型的本命令，仅第一条命令生效

用例：

;qfunction.txt
[@Attack]
#act
playCutHurt 1 1 致命-%d 30 20000 254 0
sendMsg 6 切割数值求和

可用字：


绑定货币

现有7个货币,增加7个对应的绑定类型
扣钱命令增加两类
扣绑定的钱,优先扣绑定的钱

现有货币 <$GAMEGLORY>
现有货币 <$GAMEDIAMOND>
现有货币 <$GOLDCOUNT>
现有货币 <$GAMEPOINT>
现有货币 <$GAMEGOLD>
现有货币 <$GAMEGIRD>
现有货币 <$CREDITPOINT>

新增绑定货币 <$B_GAMEGLORY>
新增绑定货币 <$B_GAMEDIAMOND>
新增绑定货币 <$B_GOLDCOUNT>
新增绑定货币 <$B_GAMEPOINT>
新增绑定货币 <$B_GAMEGOLD>
新增绑定货币 <$B_GAMEGIRD>
新增绑定货币 <$B_CREDITPOINT>

现有非绑定货币增，减，赋值操作
原命令 GAMEGLORY (+ - =) 值
原命令 GAMEDIAMOND (+ - =) 值
原命令 GOLDCOUNT (+ - =) 值
原命令 GAMEPOINT (+ - =) 值
原命令 GAMEGOLD (+ - =) 值
原命令 GAMEGIRD (+ - =) 值
原命令 CREDITPOINT (+ - =) 值

新增对绑定货币增，减，赋值操作
新增命令 B_GAMEGLORY (+ - =) 值
新增命令 B_GAMEDIAMOND (+ - =) 值
新增命令 B_GOLDCOUNT (+ - =) 值
新增命令 B_GAMEPOINT (+ - =) 值
新增命令 B_GAMEGOLD (+ - =) 值
新增命令 B_GAMEGIRD (+ - =) 值
新增命令 B_CREDITPOINT (+ - =) 值

新增优先减绑定货币，绑定货币不足减非绑定货币
新增命令 A_GAMEGLORY 值
新增命令 A_GAMEDIAMOND 值
新增命令 A_GOLDCOUNT 值
新增命令 A_GAMEPOINT 值
新增命令 A_GAMEGOLD 值
新增命令 A_GAMEGIRD 值
新增命令 A_CREDITPOINT 值

现有货币检查命令
原命令 CHECKGAMEGLORY
原命令 CHECKGAMEDIAMOND
原命令 CHECKGOLDCOUNT
原命令 CHECKGAMEPOINT
原命令 CHECKGAMEGOLD
原命令 CHECKGAMEGIRD
原命令 CHECKCREDITPOINT

新增绑定货币数量检查
新增命令 CHECKB_GAMEGLORY
新增命令 CHECKB_GAMEDIAMOND
新增命令 CHECKB_GOLDCOUNT
新增命令 CHECKB_GAMEPOINT
新增命令 CHECKB_GAMEGOLD
新增命令 CHECKB_GAMEGIRD
新增命令 CHECKB_CREDITPOINT

新增混合货币数量检查
新增命令 CHECKA_GAMEGLORY
新增命令 CHECKA_GAMEDIAMOND
新增命令 CHECKA_GOLDCOUNT
新增命令 CHECKA_GAMEPOINT
新增命令 CHECKA_GAMEGOLD
新增命令 CHECKA_GAMEGIRD
新增命令 CHECKA_CREDITPOINT


怪物墓碑

mongen.txt新增字段可配置怪物死后是否出现墓碑，
墓碑出现在mongen配置的刷新点坐标,墓碑头顶显示复活倒计时,
配置了墓碑的怪物，死亡后地图上会有带复活倒计时的墓碑显示。


主动弹出自动使用框

描述

openUseWindow

格式:

命令名 | 参数1
openUseWindow | 可使用道具名称

说明:
给予可使用道具,并弹出快捷使用窗口
倒计时结束时自动使用
如道具被使用,则不再放入背包,
如道具未使用,背包中添加一个对应道具(背包满则发邮件).

举例:
openUseWindow 护体神盾

弹出下图快捷使用栏
显示道具名称与道具图标

  • 点击使用按钮,调用QF文件中的道具使用模块
    [@StdModeFuncX]
  • 点击关闭按钮,获得技能书放入背包

示意图:


重置指定日常任务ID的状态

clearTask 日常任务id

[@重置状态]
#if
#act
clearTask 1001


自定义进度条

格式 ：

<loadingBar:x:y:字号:字体颜色:底图:滚动图:滚动间隔:滚动进度/@跳转>

说明 ：

x | 进度条x偏移
y | 进度条y偏移
字号 | 进度条上显示百分比字号
字体颜色 | 进度条上文字颜色
底图 | 进度条的底板图片
滚动图 | 进度条的滚动图片
滚动间隔 | 多长时间滚动一次(毫秒)
滚动进度 | 单次滚动进度

举例:

滚动间隔=50(50毫秒前进一次)
滚动进度=20(每次前进1/20)

脚本示意 ：

openMerchantBigDLG common_dikuang_1_bg 4 0 0 1 0 0
#say
<loadingBar:x:y:字号:字体颜色:底图:滚动图:滚动间隔:滚动进度/@跳转>

[@跳转]
#act
sendMsg 6 进度加载结束

[@自定义loading]

#say
<text:努力加载中{scolor=248}:355:37>
<loadingBar:0:80:20:150:jingyantiao:jingyantiao_01:50:100/@load跳转>

[@load跳转]
#act
close

messageBox 加载完毕


创建行会时触发
[@crtGuild]

设置自动同意入会申请：

autoAdmApp 0（不设置默认0-关闭，1-开启）

脚本示例：

;qfuction-0.txt
[@crtGuild]
#act

autoAdmApp 1
sendMsg 6 <$time>
sendMsg 6 <$userName>创建了【<$guildName>】
sendMsg 6 行会自动同意入会申请


字符形式返回指定小数位的除法结果

新增命令

以字符形式返回指定小数位的除法结果
getFloat

格式：
命令名 | 参数1 | 参数2 | 参数3 | 参数4
getFloat | 被除数 | 除数 | 小数位 | 变量

说明：
参数3向下取整

脚本示例：

#act
getFloat 1250 100 2 S0
sendMsg 6 角色倍攻为<$str(s0)>


物品回收功能

回收配置 | GM编辑工具-查看-列表信息二-回收列表
 | 配置后Envir文件夹内自动生成recycleItem.txt
 | ;一级回收列表 二级回收列表 回收类型（1.货币；2.物品） 回收获得道具名称或货币ID 获得数量 是否默认回收
新增命令 | openRecycleItem
 | 使用后可呼出示意图中的快速回收窗口
 | doRecycleItem
 | 使用后，对背包中选中的道具，按设定的回收价格，执行回收操作。
 | doRecycleItem 回收%s，获得%s
 | 填写后面的信息时，聊天框发送回收信息，第一个%s固定为回收的道具，第二个%s固定为回收获得的收益
 | setautoRecycle 1
 | 设置为1，自动回收勾选框为选中状态，0为未选中状态 相关变量<$autoRecycle>
 | setautoRecycleEnable 1
 | 设置为1，自动回收按钮可点击，0为不可点击状态 相关变量<$autoRecycleEnable>
新增系统变量 | <$autoRecycle>
 | 自动回收勾选框未选中，<$autoRecycle>为 0
 | 自动回收勾选框已选中，<$autoRecycle>为 1
QF 新增触发块 | [@autoRecycle]
 | 点击自动回收勾选框时触发

完整示例：

;---------------qm设置背包自定义按钮

SETITEMBAGBUTTONINFO 2 1 400 -695 回收
PCSETITEMBAGBUTTONINFO 2 1 135 -390 回收

;--------------------qf内设置背包自定义按钮点击触发，打开回收界面
[@ItemBagButtonClick2]
#act
openRecycleItem

;------------------设置是否可点击勾选自动回收（用于设置自动回收权限，如首充、沙捐）
[@可点击自动回收]
#act
setautoRecycleEnable 1

[@不可点击自动回收]
#act
setautoRecycleEnable 0

;--------------------qf内设置自动回收按钮开启条件

[@autoRecycle]

#if
equal <$autoRecycleEnable> 0
#act
messagebox 未开启自动回收权限
break

#if
equal <$autoRecycleEnable> 1
#act
goto @switchAutoRecycle

[@switchAutoRecycle]
#if
equal <$autoRecycle> 0
#act
setautoRecycle 1
break

#if
equal <$autoRecycle> 1
#act
setautoRecycle 0
break

;------------------设置自动回收触发条件，以pickupitem为例

[@PickUpItemEx]
#if
equal <$autoRecycle> 1 ;自动回收勾选框为选中时，拾取物品执行回收
#act
doRecycleItem 回收%s，获得%s


显示指定进度的进度条

在对话框指定位置,
根据给定的进度值,
显示一个进度条.

#say
<progressBar:x:y:进度下限,进度上限:进度底图:进度滚动图>

进度值:0-100

示例：

[@progressBar]
#act
openMerchantBigDlg ok_di 4 0 0 1 0 0
#say
<panelsize:980:256>
<progressBar:0:0:50,200:jingyantiao:jingyantiao_01>


NPC商店

示例：

(@buy @sell @repair @s_repair @upgradenow @getbackupgnow)
%50
+5
+6

[@main]
欢迎光临. 感谢您到我们的铁匠铺.\ \
<买/@buy>武器\
<卖/@sell>武器\
<修理/@repair>武器\
<特殊修理/@s_repair>\
<开始武器升级/@upgrade>\
<取回武器/@getbackupgnow>\
<离 开/@exit>\
\
\
\

;---------------------------武器升级

[@upgrade]
#say
你像是想要升级你的武器。给我看你的武器，\
升级价格是<$UPGRADEWEAPONFEE>金币。修炼这个武器需要原料\
<黑铁矿/@Biron>，<饰品/@Etc>，<武器/@Weapon>和<金币/@Gold>。\
别的原料你可以使用你包内的物品。\
你想委托你的武器进入修炼系统吗？\ \
<确认修炼/@confirmupgrade>\ \
<取消/@main>\

[@Biron]
#say
你可以在矿山里采到黑铁矿石。如果你想修炼过程得到\
一个好得结果你最好拿给我更高纯度的黑铁矿。\
顺便请记得，在修炼期间如果没有足够数量的黑色铁矿，\
那怕你的矿石纯度再高修练的结果也可能不好。\ \
<返回/@upgrade>\

[@Etc]
#say
装饰品，项链，手镯当你的特殊技能融入了这种装饰物的时候，\
能够加强你的武器。如果你给我好原料我能给你好结果。\
如果你给我糟糕的装饰品那可能会失败，除非你有很好的运气。\ \
<返回/@upgrade>\

[@Weapon]
#say
只能对武器进行炼制。\
如果你想要升级武器请给我你携带的武器...\ \
<返回/@upgrade>\

[@Gold]
#say
修练武器的金子太少...\
你真的认为我的技术的价值就这么点数量的程度？\
这个价格我不能做这个工作。\ \
<返回/@upgrade>\

[@heardsing]
#say
如果你给我3万金子我会再考虑一下...\ \
<支付3万金币/@paythree>\ \
<退出/@main>\

[@paythree]
#say
不知名的杂草...\ \
<退出/@exit>\

[@confirmupgrade]
#say
给我看你给我的原料，修炼你的<$USERWEAPON>，我的视力不好，\
我想从你的包里取得更多的饰品和黑铁矿石。\
如果你有重要的物品，在你寄存在仓库后请回来。\ \
<请求修炼/@upgradenow>\ \
<在安排好以后再回来/@exit>\

[@upgradenow]
#act

[@getbackupgnow]
#act

[@upgradenow_ok]
#say
我会把它弄得像新的一样，\
所以请十分钟后再回来。\ \
<返回/@Main>\

[@upgradenow_ing]
#say
我们工作的规则是一个人只能进行一个项目。\
请下次再来...\ \
<返回/@Main>\

[@upgradenow_fail]
#say
材料不够。请你下次来的时候，\
准备好所有的矿石，武器和饰品。\
当然，我的工作才是最基本的...\ \
<返回/@Main>\

[@getbackupgnow_ok]
#say
就这样了，我尽我最大努力精炼了你的武器，
结果是否<成功/@Success>\
只有在你使用过一次后才知道，出去试试吧。\ \
<退出/@exit>\

[@Success]
#say
通过使用它，你可以体会到它精炼的好处。\
无论你的战斗对象是其他玩家还是怪物...\
你都会发现这个成果...\ \
<退出/@exit>\

[@getbackupgnow_ing]
#say
这个工作正忙着呢，请稍等片刻...\ \
<返回/@Main>\

[@getbackupgnow_fail]
#say
以前你是不是寄存了很多东西？\
如果你找我是为了取回你很久前寄存在这里的物品，\
那你还是回去吧，我可记不起来了。\
这也过去太长时间了...\ \
<返回/@Main>\ \

;---------------------买物品

[@buy]
#if
#act
npcShopArrow 记忆手镯 4 哦买噶买它！ @关闭页面
#say
您想买什么武器？\\\
<返 回/@main>\

[@关闭页面]
#act
close

[@buy_ok]
#say
购买成功！！！\

#act
;messagebox 购买成功\\\
<返 回/@main>\

[@buy_fail]
#say
购买失败\\\
<返 回/@main>\

[goods]
记忆戒指 10 10
记忆项链 10 10
记忆手镯 10 10
修复油 10 10

;-------------------------卖物品

[@sell]
#say
给我您要卖的武器.\\
<返回/@Main>\

[@sell_ok]
#say
出售成功\
<返回/@Main>\

[@sell_fail]
#say
我这里不要这东西\
<返回/@Main>\

;------------------------------修理物品

[@repair]
#say
请把要修理的东西放上去.\\
<返回/@Main>\

[@repair_ok]
#say
看起来你修好了，欢迎下次再来\
<返回/@Main>\

[@repair_fail1]
#say
金币不够，不能效劳
<返回/@Main>\

[@repair_fail2]
#say
这类装备我修不了\
<返回/@Main>\

[@repair_fail3]
#say
装备很好，用不着修\
<返回/@Main>\

;------------------------------特修

[@s_repair]
#say
请把要修理的东西放上去.\\
<返回/@Main>\

[@s_repair_ok]
#say
看起来你修好了，欢迎下次再来\
<返回/@Main>\

[@s_repair_fail1]
#say
金币不够，不能效劳\
<返回/@Main>\

[@s_repair_fail2]
#say
这类装备我修不了\
<返回/@Main>\

[@s_repair_fail3]
#say
装备很好，用不着修\
<返回/@Main>\


NPC商店引导

新增引导箭头命令
npcShopArrow
打开NPC商店时，
指定名称道具的购买按钮，出现引导箭头。

格式：
命令名 | 参数1 | 参数2 | 参数3 | 参数4
npcShopArrow | 引导对象 | 箭头方向 | 引导文本 | 跳转连接

说明：

  • 参数1：NPC商店出售的指定道具名称
  • 参数2：
    • 参数2=1，箭头方向上
    • 参数2=2，箭头方向下
    • 参数2=3，箭头方向左
    • 参数2=4，箭头方向右
  • 参数3：引导说明文字
  • 参数4：@跳转目标

会同时执行购买操作与跳转操作

脚本示例：

(@buy @sell )
[@显示界面]
#say
<欢迎光临. 感谢您到我们的铁匠铺.>\ \
<买/@buy> <卖/@sell>\ \
<离 开/@exit>\
[@buy]
<您想买些什么武器?>\ \ \
<返 回/@显示界面>
#if
#act
npcShopArrow ≮招摇链≯·南山 4 点击购买 @跳转目标

[@跳转目标]
#act
messageBox 引导完毕

[@buy_ok]
;<购买成功>\ \ \
;<返 回/@显示界面>

;------------------------------------
;--新手引导触发关闭购买成功及背包窗口
;------------------------------------
#if
#act
openMerchantBigDlg ok_di 0 0 0 1 0 0
#say
<img:zd_7_5:0:0:1:2.5>

#if
#act
close
;------------------------------------


行会相关命令

新增命令

获得指定行会人数 getGuildScale

格式：
命令名 | 参数1 | 参数2
getGuildScale | 行会名称 | 变量返回值

------------------------------------------------------------------------------------

新增命令

获得指定行会会长名称 getGuildMaster

格式：
命令名 | 参数1 | 参数2
getGuildMaster | 行会名称 | 变量返回值

------------------------------------------------------------------------------------

新增获取指定行会总战力命令

getGuildPower

格式：
命令名 | 参数1 | 参数2
getGuildPower | 行会名称 | 变量返回值

------------------------------------------------------------------------------------

新增命令
checkGuildName

检查指定字符串是否已创建过行会名称
已存在返回1
不存在返回0

格式：
命令名 | 参数1
checkGuildName | 指定字符串

说明：

示例：

#act
mov s$行会名称 天下第一

#if
checkGuildName <$str(s$行会名称)>
#act
sendMsg 6 <$str(s$行会名称)>已存在
#elseAct
sendMsg 6 <$str(s$行会名称)>不存在

------------------------------------------------------------------------------------

新增命令打开行会界面

openGuild

示例脚本：

#if
#act
openGuild

sendTipsMsg 你打开了行会界面

------------------------------------------------------------------------------------

新增命令解散行会

disband

示例脚本：

#if
isGuildMaster
#act
disband
sendTipsMsg 你解散了行会
#elseAct
sendTipsMsg 你不是会长


套装组

将不同套装通过套装组号关联，穿戴同组装备都可以触发套装效果

相关配置文件 | 套装描述文件：TzItemDescList.txt
 | 套装属性文件：GroupItemList.txt
 | 套装组文件：suititems.txt (手动配置或GM工具配置后自动生成)
配置套装 | GM编辑工具-查看-列表信息二-套装系统
 | 通过套装组和组内等级关联套装
 | 配置后Envir文件夹下会自动生成suititems.txt文件


九宫格对话框设置长宽

九宫格类对话框增加长宽设定支持：panelsize

<panelsize:长:宽>

以下例子设定对话框为400*300

#say

<panelsize:400:300>


主界面右上角自定义按钮红点提示

新增命令
redpointAddBtn
对于通过addButton添加的按钮，增加红点显示
按钮图片右上角作为锚点

格式：
命令名 | 参数1 | 参数2 | 参数3
redpointAddBtn | 按钮位置序号 | x偏移 | y偏移

-----------------------------------------------------------

新增命令
delRedpointAddBtn
删除上述红点

格式：
命令名 | 参数1
delRedpointAddBtn | 按钮位置序号

脚本示例：

[@自定义按钮加红点]
#if
checkLevelEx = 70
#act
redpointAddBtn 1 0 0

[@自定义按钮删红点]
#if
not checkLevelEx = 70
#act
delRedpointAddBtn 1


对话框指定按钮加红点提示

新增命令
redPointDlg
给对话框指定按钮加红点
如果是文字按钮(text)，以文字控件右上角为红点00点
如果是图片按钮(imgButton)，以图片控件右上角为红点00点

格式：
命令名 | 参数1 | 参数2 | 参数3
redPointDlg | 目标按钮 | x偏移 | y偏移

说明：

  • 参数1：目标按钮，通过“按钮文字/@跳转目标”识别
  • 参数2：相对锚点的x偏移
  • 参数3：相对锚点的y偏移

----------------------------------------------------------

新增命令
delRedPointDlg
删除对话框指定按钮的红点

格式：
命令名 | 参数1
delRedPointDlg | 目标按钮

说明：

  • 参数1：目标按钮，通过“按钮文字/@跳转目标”识别

脚本示例

[@对话框红点]
#say
<text:这是可以产生红点的按钮{scolor=248}:0:20>
<imgButton:kuaisuyouxi_anniu:80:100:按钮名称/@跳转目标>

#if

checkLevelEx = 70
#act
redPointDlg 按钮名称/@跳转目标 0 0

#elseAct

delRedPointDlg 按钮名称/@跳转目标

[@跳转目标]

#act

changeLevel = 71

messageBox 你升级到了71级

goto @对话框红点


对话框复选框

对话框新增复选框命令 checkbox

格式:
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6
checkbox | id | img1 | img2 | default | x | y
说明:
  • 参数1:checkboxId用于提交数据
  • 参数2:复选框未选中时的图片
  • 参数3:复选框已选中时的图片
  • 参数4:复选框默认是否选中,0未选中,1选中
    打开对话框,指定id复选框未赋值,则以上述参数处理
  • 复选框状态属于玩家角色私人变量

用例:

[@main]

#say

;状态下线保存
<checkbox:1:settings_markbg:settings_mark:<$str(u0)>:50:50/@勾选1>
<text:cb1:50:100>

;状态下线不保存
<checkbox:2:settings_markbg:settings_mark:<$str(s0)>:500:500/@勾选2>
<text:cb2:500:550>

#if
check [1] 0
#act
mov n$tmp 0
#elseAct
mov n$tmp 1

#if
#say
;状态下线保存
<checkbox:3:settings_markbg:settings_mark:<$str(n$tmp)>:50:500/@勾选3>
<text:cb3:50:550>

;状态下线保存
<checkbox:4:settings_markbg:settings_mark:<$human(个人开关4)>:500:50/@勾选4>
<text:cb4:500:100>

[@勾选1]
#if
#act
mov u0 <$checkbox1>
sendMsg 6 <$str(u0)>

[@勾选2]
#if
#act
mov s1 <$checkbox2>
sendMsg 6 <$str(s1)>

[@勾选3]
#if
#act
set [1] <$checkbox3>

[@勾选4]
#if
#act
calcVar human 个人开关4 = <$checkbox4>


提升按钮

菜单栏背景 <imgbg:图片名称:x坐标:y坐标>
菜单按钮内容 <popbutton:按钮图片:文字描述:按钮状态（0：隐藏，1：显示）/触发序号>
弹出菜单 popMenu 菜单内容
按钮状态都为0时，自动关闭提示按钮
按钮触发qf内@块：[@PopButtonClickX]

示例：

[@main]

#SAY
提升按钮脚本示例\

<装备强星/@装备强星> <清除装备强星/@清除装备强星>\
<合成提升/@合成提升> <清除合成提升/@清除合成提升>\
<血魔圣体/@血魔圣体> <清除血魔圣体/@清除血魔圣体>\
<金钢神体/@金钢神体> <清除金钢神体/@清除金钢神体>\
<免费赞助/@免费赞助> <清除免费赞助/@清除免费赞助>\

[@装备强星]
#act
mov n2001 1
goto @弹出提升按钮

[@合成提升]
#act
mov n2002 1
goto @弹出提升按钮

[@血魔圣体]
#act
mov n2003 1
goto @弹出提升按钮

[@金钢神体]
#act
mov n2004 1
goto @弹出提升按钮

[@免费赞助]
#act
mov n2005 1
goto @弹出提升按钮

[@清除装备强星]
#act
mov n2001 0
goto @弹出提升按钮

[@清除合成提升]
#act
mov n2002 0
goto @弹出提升按钮

[@清除血魔圣体]
#act
mov n2003 0
goto @弹出提升按钮

[@清除金钢神体]
#act
mov n2004 0
goto @弹出提升按钮

[@清除免费赞助]
#act
mov n2005 0
goto @弹出提升按钮

[@弹出提升按钮]
#act
;弹出菜单底板设定
mov S$弹出菜单 <imgBg:cq_50_1:0:0>
;弹出按钮设定
inc S$弹出菜单 <popButton:server_item_unselect:装备强星:<$STR(n2001)>/1>
inc S$弹出菜单 <popButton:server_item_unselect:合成提升:<$STR(n2002)>/2>
inc S$弹出菜单 <popButton:server_item_unselect:血魔圣体:<$STR(n2003)>/3>
inc S$弹出菜单 <popButton:server_item_unselect:金钢神体:<$STR(n2004)>/4>
inc S$弹出菜单 <popButton:server_item_unselect:免费赞助:<$STR(n2005)>/9999999>
popMenu S$弹出菜单

;----------------------------------qfuntion内触发对应@块

;
;[@PopButtonClick1]
;
;#act
;sendmsg 6 触发1
;mov n2001 0
;#call [\提升按钮.txt] @弹出提升按钮
;
;[@PopButtonClick2]
;
;#act
;sendmsg 6 触发2
;mov n2002 0
;#call [\提升按钮.txt] @弹出提升按钮
;
;[@PopButtonClick3]
;
;#act
;sendmsg 6 触发3
;mov n2003 0
;#call [\提升按钮.txt] @弹出提升按钮
;
;[@PopButtonClick4]
;
;#act
;sendmsg 6 触发4
;mov n2004 0
;#call [\提升按钮.txt] @弹出提升按钮
;
;[@PopButtonClick5]
;
;#act
;sendmsg 6 触发5
;mov n2005 0
;#call [\提升按钮.txt] @弹出提升按钮
;
;

;-----------------------------------qmanage定义了按钮状态
;mov n2001 0
;mov n2002 0
;mov n2003 0
;mov n2004 0
;mov n2005 0


拉取充值接口

 pullpay 参数一：充值标记id 参数二：充值方式（1.微信 2.支付宝）

;Tejieconfig 配置变更
;[charge]
;最后增加一列，表示是否在充值列表中隐藏
;0， 默认，表示不隐藏
;1， 表示隐藏

示例：

tejieconfig：

[charge]
10 5000 100000 500 yuanbao_6 0 0 500 5000金刚石|送100000元宝500积分 7 1

脚本：

[@main]

#act
mov n$支付宝 0
mov n$微信 0
mov n$支付方式 0

#SAY

<text:首充豪礼:50:50:120:1:30>\
\
\
\
\
\

<立即充值/@立即充值>\

[@立即充值]

#SAY

游戏商品 10元\
商品金额 ￥10.00元\
实际支付 ￥10.00元\

<text:支付宝:80:150:90:1:30>\
<text:微信:500:150:90:1:30>\
<checkbox:1:settings_markbg:settings_mark:<$str(n$支付宝)>:100:200/@支付宝>
<checkbox:2:settings_markbg:settings_mark:<$str(n$微信)>:500:200/@微信>
\
\
\
\
\
\
\

<确认支付/@确认支付>\

[@支付宝]
#act
mov n$支付宝 1
mov n$微信 0
mov n$支付方式 2
goto @立即充值

[@微信]
#act
mov n$支付宝 0
mov n$微信 1
mov n$支付方式 1
goto @立即充值

[@确认支付]

#if
not equal <$str(n$支付方式)> 0

#act

pullpay 7 <$str(n$支付方式)>

#elseact

sendtipsmsg 请选择支付方式


实时刷新time文本

当前时间,ok框中支持实时每秒刷新

<time:x坐标:y坐标:时间变量:颜色:是否显示年月日(0不显示，1显示)>
<time:x:y:<$time>:159:0>


PlayModelEx

功能: 在OK框中显示出3D模型、粒子特效
格式:< playmodelex:模型编号:X横向坐标:Y纵向坐标:UI缩放比例（不生效，不可空 ）:模型缩放比例:男女:武器:斗笠:翅膀:特效>
说明:模型编号可在资源编辑中查看(缩放比例1为正常大小)

注意：不要直接使用playmodelex代替playmodel，坐标计算方式不一样

男 = 0 女 = 1
[@main]
#IF
#SAY
<PlayModelex:2001:0:0:1:1:0:1001:0:0:0>


Itemshowex

itemshowex 显示装备动态图标 注意：仅支持有动态图标的道具

itemShowEx 物品id 物品数量 x y 底框 缩放系数

底框：

是否显示背景图片，（0不显示，1显示通用底框，2显示绿色底框，3显示蓝色底框，4显示紫色底框，5显示橙色底框，6红色底框）

示例：

<itemshowex:3:0:700:800:1:1>\


changeMonRenew

地图刷怪时间调整

针对mongen.txt(参数7)改变指定地图的刷怪间隔

changeMonRenew

格式：
命令名 | 参数1 | 参数2
changeMonRenew | 地图id | 变更系数百分比

说明：
参数1：指定地图id
参数2：原刷新参数的变更系数(百分比值)
注:脚本命令刷的怪不受影响

脚本示例：

;盟重城mongen刷怪参数*0.5
#act
changeMonRenew 3 50


New Item

取消所有行会攻城命令： CancelAttackSabukAll

#IF
#ACT
CancelAttackSabukAll

sendmsg 6 取消所有行会攻城资格


系统回收面板引导

新增引导箭头命令
recycleItemArrow
打开新版回收界面时，
指定一级回收列表的按钮，出现引导箭头。

格式：
命令名 | 参数1 | 参数2 | 参数3 | 参数4
recycleItemArrow | 引导对象 | 箭头方向 | 引导文本 | 跳转连接

说明：

  • 参数1：新版回收界面的一级回收列表名称， 及"自动回收"、"回收设置"、"快速回收"
  • 参数2：
    • 参数2=1，箭头方向上
    • 参数2=2，箭头方向下
    • 参数2=3，箭头方向左
    • 参数2=4，箭头方向右
  • 参数3：引导说明文字
  • 参数4：@跳转目标

会同时执行购买操作与跳转操作

脚本示例：

[@回收引导]
#if
#act
openRecycleItem
npcShopArrow 一星装备 4 点击勾选回收 @跳转目标

[@跳转目标]
#act
messagebox 引导完毕

[@快速回收]
#if
openRecycleItem
#act
recycleItemArrow 快速回收 3 点击勾选回收 @自动回收

[@自动回收]
#if
openRecycleItem
#act
recycleItemArrow 自动回收 4 点击勾选回收 @回收设置

[@回收设置]
#if
openRecycleItem
#act
recycleItemArrow 回收设置 4 点击勾选回收 @跳转目标


尸体采集

配置方式：

（1）配置怪物表

Monster.csv 增加一列 Butch 范围 0-32767

（2）配置怪物掉落表

怪物掉落表增加 [butch]

[butch] 下配置可挖掘的物品及几率 （使用#CHILD，RONDOM需大写）

例如：

1/1 金刚伏魔杵

[butch]

1/3 道具1

#CHILD 1/1 RANDOM
(
1/1 道具1

1/1 道具2
)

（3）tejieconfig增加配置：

;采集时间,采集尸体消失时间

butchTime=1000,3000

相关命令

1.尸体采集功能开启命令

setButchState 尸体采集功能开启状态（0-关闭，1-开启，默认开启）

2.尸体清理命令

clearMonCoprse 怪物实例ID

采集触发

q-function增加触发@块，返回值s0为道具名称，当前采集怪物实例ID:<s$monInstanceID>

[@butchX] X为monster表内butch值

例如：

[@butch666]
#if
equal s0
#act
sendmsg 6 啥也没挖到
#elseact
messagebox 获得道具<$str(s0)>


OK框内播放粒子特效

OK框内播放粒子特效 PlayParticleEffect

PlayParticleEffect:参数1:参数2:参数3:参数4:参数5

参数1：特效名称
参数2：播放时长（单位毫秒，-1为循环播放）
参数3：X坐标（空或-1为中间位置，需要配置缩放倍数时不可为空）
参数4：Y坐标（空或-1为中间位置，需要配置缩放倍数时不可为空）
参数5：缩放倍数（不写默认为1倍）

参数6：旋转角度

<PlayParticleEffect:effect_danhuan0:-1:100:300:1:45>


人物属性值增长绿字提示

[tjconfig]

配置项：

;是否浮动提示人物属性增加（1显示，0隐藏，默认隐藏）

attributeAddFloat=1

*脚本触发的属性项增加，需要显示提示的，要在脚本中进行标记

标记方式为，在@块的#Act部分，写入新命令attributeAddFloatRequest 直到该@块结束,增加的属性项都会提示

例如：
[@给人物加属性]
#IF
CHECKLEVELEX > 1
#Act
ChangeModeEx 5 10
attributeAddFloatRequest ;标记后的属性，会显示属性增加提示
ChangeModeEx 3 10000
ChangeModeEx 4 10000
#IF
CHECKLEVELEX > 100
#Act
ChangeModeEx 3 20000
ChangeModeEx 4 20000


万分比控制血量

addHpPerEx 运算符(+-=) 血量万分比

[@赋值]
#act
addHpPerEx = 5000
sendMsg 6 赋值血量万分之5000

[@减血]
#act
addHpPerEx - 3000
sendMsg 6 减血万分之3000

[@加血]
#act
addHpPerEx + 1000
sendMsg 6 加血万分之1000< /P>


货币id对应表
$GAMEGLORY | 12
$GAMEPOINT | 2
$GAMEGOLD | 0
$GAMEGIRD | 104
$CREDITPOINT | 7
$GAMEDIAMOND | 3
$GOLDCOUNT | 1
$B_GAMEGLORY | 13
$B_GAMEPOINT | 16
$B_GAMEGOLD | 17
$B_GAMEGIRD | 18
$B_CREDITPOINT | 19
$B_GAMEDIAMOND | 14
$B_GOLDCOUNT | 15


道具绿点提示

  • addGreenPoint
    tejieconfig中配置
    viewGreenPoint=0
    或未配置viewGreenPoint
    也可支持对指定道具添加绿点
  • delGreenPoint
    对使用addGreenPoint命令增加的绿点的道具
    可以取消绿点显示
    delGreenPoint 道具名称

示例：

[@main]
#say
<加绿点/@加绿点>\ \
<删绿点/@删绿点>

[@加绿点]
#act
addGreenPoint 回城石

[@删绿点]
#act
delGreenPoint 回城石


爆出背包物品触发

爆出背包物品触发qf内： [@scatterBagItems]

掉落包裹物品名称 <$SCATTERITEMNAME>
物品原拥有者名称 <$SCATTERITEMOWNERNAME>
物品所在地图中文名称 <$SCATTERITEMMAPNAME>
物品所在地图代码名称 <$SCATTERITEMMAPDESC>
物品所在地图坐标X <$SCATTERITEMX>
物品所在地图坐标Y <$SCATTERITEMY>


爆出身上物品触发

爆出身上物品触发qf内： [@dropUseItems]

掉落包裹物品名称 <$SCATTERITEMNAME>
物品原拥有者名称 <$SCATTERITEMOWNERNAME>
物品所在地图中文名称 <$SCATTERITEMMAPNAME>
物品所在地图代码名称 <$SCATTERITEMMAPDESC>
物品所在地图坐标X <$SCATTERITEMX>
物品所在地图坐标Y <$SCATTERITEMY>


自动采集尸体

挂机支持视野内自动采集尸体功能，单玩家生效，下线不保存
autoCorpseCollection 0 (0-关闭，默认；1-开启)

例如：

[@test3]
#act
autoCorpseCollection 1

[@test4]
#act
autoCorpseCollection 0


新增开始挂机命令

stAutoPlayGame

角色执行自动战斗操作

标签:命令定义|stAutoPlayGame

格式
命令名 | 参数1 | 参数2
stAutoPlayGame | 挂机范围 | 是否寻路
说明
  • 该命令可触发 ..\Mir200\Envir\Market_Def\QFunction-0.txt 中的 [@stAutoPlayGame]
  • 参数1: 挂机范围：以人物当前坐标为中心点，挂机范围为半径寻怪挂机
  • 参数2: 是否寻路：
    • 0-不寻路，始终在设置的挂机范围内寻怪挂机；
    • 1-寻路，当前范围内怪物清理完成后，寻找一个可到达的位置，到达指定位置后，再次以该位置为中心点，以挂机范围为半径寻怪
  • 参数1与参数2可缺省
  • 参数1与参数2配置生效前提如下
    tejieconfig
    [tjConfig]
    autoPlayGameMode=0或缺省

相关命令
startAutoPlayGame

特戒引擎脚本示例：

[@执行挂机]
#act
stAutoPlayGame

..\Mir200\Envir\Market_Def\QFunction-0.txt：
[@stAutoPlayGame]
#act
sendMsg 6 开始挂机


monsterdrop

新增杀怪新命令

monsterDrop

效果：执行后不在地图上显示怪物，直接击杀怪物，且掉落物飞入命令执行者的背包

说明：参数值需支持变量

参数1 怪物名字

参数2 怪物数量

实例：
monsterDrop 稻草人 10


在屏蔽中心播放特效

以屏幕中心为锚点播放特效

playScrEff

格式

playScrEff 特效资源名称 x,y 缩放系数 存在时间

示例：

[@播放特效]
#if
#act
playScrEff GuangZhu_Cheng 0,0 1 3000
sendMsg 6 播放特效


背包内增加/减少物品触发

1.QF内增加背包增加物品触发器： [@inbag]
;背包中增加物品
;s0道具名称 n0道具数量

2.QF内增加背包减少物品触发器： [@outbag]
;背包中增加物品
;s0道具名称 n0道具数量

示例：

[@inbag]
#if
#act
SendMsg 6 背包增加<$STR(s0)> <$STR(N0)>

;背包中减少物品
;s0道具名称 n0道具数量

[@outbag]
#if
#act
SendMsg 6 背包减少<$STR(s0)> <$STR(N0)>


技能名称文本配置

技能快捷键、技能配置界面，图标位置增加文本配置 （支持自定义技能）

可用于配置技能图标上方

路径：\Mir200\Envir\skillAbbr.txt

;magic表技能名称 快捷键显示文本 技能配置界面显示文本
;-1不显示文本


检测指定地图范围内，玩家所属行会数量

checkRangeGuildCount 地图名称 X坐标 Y坐标 范围 控制符（>,<,=） 数量


获取指定地图范围内，玩家所属行会数量及行会名称

getRangeGuildCount 地图名称 X坐标 Y坐标 范围 获取到的数量变量 获取到的行会名称变量（存在多个行会时，使用 "|" 做分割，如 行会一|行会二）


受击触发时，免疫本次伤害

命令 ： SuckDamage

受击触发时，执行则免疫本次伤害

脚本示例：
[@Struck]
#IF
RANDOM 6
#ACT
SuckDamage


清除指定目录下全部文件

clearPath

格式：
命令名 | 参数1
clearPath | 指定目录

clearPath ..\test\test\

清除以上目录下的全部文件


读取指定txt到指定变量

readTxt 文件路径 存储变量

[@指定变量]
#act
mov s$file \QuestDiary\数据文件\测试数据.txt
readTxt <$str(s$file)> s0
sendMsg 6 <$str(s0)>


检查数据库中文件是否存在

fileExist 文件路径

示例：

#if
fileExist \test\test9\test9.txt
#act
sendMsg 6 文件存在
#elseAct
sendMsg 6 文件不存在

实际查寻文件为
..\Mir200\Envir\test\test9\test9.txt


挂机时不将玩家角色作为目标

挂机时不将玩家角色作为目标 ： targetNoPlayer

命令示例

;QFunction-0.txt

[@StartAutoPlayGame]
#IF
CHECKMAPNAME 土城
#ACT
SENDMSG 6 当前地图禁止挂机
break

#IF
#ACT
StartAutoPlayGame

targetNoPlayer


是否是模拟器登陆

isSimulator 是否是模拟器登陆的检测命令

[@main]

#if
isSimulator

#act
sendmsg 6 是模拟器登陆
#elseact
sendmsg 6 不是模拟器登陆


清除指定文件

clearFile

格式：
命令名 | 参数1
clearFile | 指定文件路径

clearFile ..\test\test\test9.txt


跨天执行触发器

QM文件增加跨天执行块

[@dayChanged]

在线玩家 跨天时,会触发此模块

不在线玩家 第二天登录时会触发此模块


同一件装备不同职业穿戴增加的属性值不同，装备可根据职业配置属性

tejieconfig配置：

;是否支持同一件装备可根据职业配置属性（默认为0，不支持；1为支持，分职业属性读\Mir200\equipDiffJob.txt）
equipDiffJob=1

新增配置文件（战士读取stditems表内数据）
\Mir200\equipDiffJob.txt
;物品id 物品名 法师Ac 法师Ac2 法师Mac 法师Mac2 法师HP 法师MP 道士Ac 道士Ac2 道士Mac 道士Mac2 道士HP 道士MP


在小地图上显示NPC标记

小地图上显示NPC标记的命令： setNpcStat

setNpcStat 地图id npc的名字 字符串 颜色值 字符串 颜色值 图片资源 标识是否消失

说明：
参数1：地图id
参数2：npc的名字
参数3：字符串（场景中的NPC名称下方显示的字符串）
参数4：颜色值（场景中的NPC名称下方显示的字符串）
参数5：字符串（小地图对应的NPC，显示的字符串）
参数6：颜色值（小地图对应的NPC，显示的字符串）
参数7：图片资源，小地图上使用的NPC坐标点图片
参数8：-1为标识永久存在，填1以上的数时为标识存在的时间

[@地图展示]
#if
#act
setNpcStat 3 测试专用 测试专用111 254 测试专用222 253 wupin_hong -1


技能熟练度升级

tejieconfig配置

useskillproficient=1 (0或不写，为当前技能升级方式；1，使用技能熟练度升级技能)

magic表内配置：

NeedL1 ~ NeedL15 技能升到1级 需要玩家达到的人物等级

L1Train ~ L15Train 技能升到1级 需要的熟练度

MaxTrainLv 通过熟练度升级可以达到的最高等级

qf内新增触发器： [@updateskill]

触发器内可使用脚本变量：<$upgradeskillname> 学习/升级的技能名称


设置角色外显模型

setPlayerModel

设置角色模型展示（非对话框模型展示）

对话框模型展示参见
playModel
playModelEx
playUser

标签:命令定义|setPlayerModel

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
setPlayerModel | 角色名称 | 模型类型 | 模型id | 翅膀模型id
说明:

  • 参数1: 角色名称
  • 参数2:模型类型
    1.武器
    2.衣服
    4.斗笠
    5.头盔
    6.盾牌（只有角色界面模型，无外显模型）
    7.面巾
  • 参数3:模型id，参见 资源编辑器
    -1为取消设置，外显为当前角色穿戴的模型
  • 参数4:翅膀模型id，参数2为2时有效

特戒引擎脚本示例：

[@main]
#act
setPlayerModel <$userName> 1 20037

loginSetPlayerModel

角色登录时设置角色模型展示（非对话框模型展示）
需要在 QManage [@login触发器] 中使用

对话框模型展示参见
playModel
playModelEx
playUser

标签:命令定义|loginSetPlayerModel

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
loginSetPlayerModel | 角色名称 | 模型类型 | 模型id | 翅膀模型id
说明:

  • 参数1: 角色名称
  • 参数2:模型类型
    1.武器
    2.衣服
    4.斗笠
    5.头盔
    6.盾牌（只有角色界面模型，无外显模型）
    7.面巾
  • 参数3:模型id，参见 资源编辑器
    -1为取消设置，外显为当前角色穿戴的模型
  • 参数4:翅膀模型id，参数2为2时有效

特戒引擎脚本示例：

QManage 触发器中使用
[@login]
#act
loginSetPlayerModel <$userName> 1 20037


获取登陆渠道号

获取登陆渠道号命令： getChannel

getchannel 保存字符串

例如：

[@获取字符]

#act

mov s0

getchannel <$str(s0)>

sendmsg 6 登陆渠道号为： <$str(s0)>


保护设置

保护设置命令(玩家未勾选时生效)： setProtect

setProtect 保护类型 百分比 道具ID

保护类型：1 - 6

1,2：自动喝药 - 生命值低于指定百分比时自动使用

3,4：自动喝药 - 魔法值低于指定百分比时自动使用

5,6：自动传送 - 生命值低于指定 百分比时自动使用


改变怪物默认回血速度

改变全体怪物默认回血速度(对全体怪物实时生效)： setMonHot

格式：

setMonHot 回复间隔（秒） 回复最大血量万分比

示例：

[@设置怪物回血]

#act

setMonHot 30 2000

sendmsg 6 怪物每30秒 回复万分之2000的血量


收到私聊触发

QF内触发器：收到私聊消息,且未打开一对一聊天框时触发 [@prvtMsg]

返回变量s0,消息发出角色名称

[@prvtMsg]

#act

sendMsg 6 收到<$str(s0)>私聊消息


人物杀死怪物获得经验触发

QF内触发器：人物杀死怪物时获得经验触发 [@GetExp] ,获得经验变量 <$GetExp>

示例:

[@GetExp]

#act

sendmsg 6 你获得了<$GetExp>点经验


对话框增加关闭按钮及触发器

clsBtn

可在对话框pannel外面放置按钮,需要搭配clsMainUI使用，点击关闭按钮触发@块

关闭按钮锚点-右上角

<clsBtn:资源名称：X偏移坐标：Y偏移坐标/@触发块>

[@main]
#act
clsMainUI
openMerchantBigDlg ok_di 4 0 0 2 0 0
#say
<clsBtn:guanbi:50:50/@跳转标签>
[@跳转标签]
#act
close
sendTipsMsg 特戒提示关闭/scolor=222


设置指定技能的修改系数和附加伤害

setSkillPower

设置指定技能的修改系数和附加伤害

伤害公式：（造成伤害*基础系数+基础附加伤害）* 修改系数+修改系数的附加伤害
减伤公式：A打出的结算伤害*（100% - B减伤比%）- B减伤值）*（100%-B的Set减伤比%）- B的Set减伤值

标签:命令定义|setSkillPower

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8 | 参数9
setSkillPower | 技能id | 操作符（+，-，=） | 对人物伤害增加万分比 | 对人物伤害附加值 | 对怪物伤害增加万分比 | 对怪物伤害附加值 | 防御增加万分比 | 防御增加具体值 | 持续时间

pgSetSkillPower

设置指定技能的基础系数和附加伤害

伤害公式：（造成伤害*基础系数+基础附加伤害）* 修改系数+修改系数的附加伤害
减伤公式：A打出的结算伤害*（100% - B减伤比%）- B减伤值）*（100%-B的Set减伤比%）- B的Set减伤值

标签:命令定义|pgSetSkillPower

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8 | 参数9
pgSetSkillPower | 技能id | 操作符（+，-，=） | 对人物伤害增加万分比 | 对人物伤害附加值 | 对怪物伤害增加万分比 | 对怪物伤害附加值 | 防御增加万分比 | 防御增加具体值 | 持续时间

说明:

  • 参数1
    技能id
  • 参数2
    操作符（+，-，=）
    • +：增加相应数值
    • -：减小相应数值
    • =：赋值相应数值
  • 参数3
    对人物伤害增加万分比
  • 参数4
    对人物伤害附加值
  • 参数5
    对怪物伤害增加万分比
  • 参数6
    对怪物伤害附加值
  • 参数7
    防御增加万分比
  • 参数8
    防御增加具体值
  • 参数9
    持续时间，单位为秒
    • 持续时间 > 0：修改为临时的
    • 持续时间 <= 0：修改会保存数据库
注意：
  • 1.需要配合pgSetSkillPower设置基础系数时，修改系数不可设为0，否则最终伤害值是0
  • 2.SetSkillPower 和PGSetSkillPower 两个命令，每一个命令的数值都是有2套的， 数据库一套，临时的一套。取具体某一个数值的时候，数据库里的值是第一个操作数， 如果临时数据也有这个技能的数据，则操作符取临时的，临时的数值作为第二个操作数， 当操作符是=号的时候， 忽略库里的，直接取临时的数值。
  • 3.进行操作计算的时候，结果小于0按0算

脚本示例：

[@pg技能基础系数]
#ACT
pgSetSkillPower 23 = 10000 0 1000000 0 0 0 60
pgSetSkillPower 33 - 5000 0 500000 0 0 0 60

[@技能修改系数]
#act
SetSkillPower 23 = 10000 0 1000000 0 0 0 60


获取SetSkillPower设置的值

getSkillPower

获取SetSkillPower设置的值

标签:命令定义|getSkillPower

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8
getSkillPower | 技能id | 人物伤害百分比 | 人物伤害附加值 | 怪物伤害百分比 | 怪物伤害附加值 | 防御百分比 | 防御具体值 | 持续时间
说明:
  • 参数1
    技能id
  • 参数2
    人物伤害百分比
  • 参数3
    人物伤害附加值
  • 参数4
    怪物伤害百分比
  • 参数5
    怪物伤害附加值
  • 参数6
    防御百分比
  • 参数7
    防御具体值
  • 参数8
    持续时间，单位为秒

脚本示例：

[@获取技能参数]
#ACT
getSkillPower 33 s1 s2 s3 s4 s5 s6 s7
sendmsg 6 <$str(s1)>
sendmsg 6 <$str(s2)>
sendmsg 6 <$str(s3)>
sendmsg 6 <$str(s4)>
sendmsg 6 <$str(s5)>
sendmsg 6 <$str(s6)>
sendmsg 6 <$str(s7)>


自定义排行榜

标签:
排行|自定义|个人|角色|行会|

saveRankData

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7
saveRankData | 排序对象 | 排序属性 | 排序文件 | 排序规则 | 排序数量 | 排行榜表头属性 | 排行分类

说明:

  • 命令效果：对当前玩家角色，或角色所在行会的指定属性，与指定文件中的对应属性进行比较排序， 并将其它需要显示在排行榜上的信息一并存入文件
    • 保存文件为：Key 排名属性值 排名信息（供排行榜显示用）
  • 参数1：
    • <$userName>，当前玩家角色名，指定属性排序
    • <$guildName>，当前玩家所在行会名，指定属性排序
  • 参数2：要排序且保存的属性
  • 参数3：保存文件的路径
  • 参数4：
    • 参数值为0，升序排序
    • 参数值为1，降序排序
  • 参数5：排序保存的数据条数上限
  • 参数6：排行榜表头属性
    • 举例，$USERNAME|$LEVEL|$GUILDNAME|$human(个人捐款)
  • 参数7：排行分类
    • 参数值为1，个人
    • 参数值为2，行会

示例：

saveRankData <$userName> <$maxDc> <$str(s$filePath)> 1 10 <$str(s$rankInfo)> 1

getRank

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4
getRank | 查询对象 | 排序文件 | 返回值存储变量 | 排行分类

说明:

  • 命令效果：获取指定角色名或行会名，在指定排名文件中的排名
    • 查询指定角色名或行会名，在排序文件中的顺序，并返回结果
  • 参数1：查询对象
  • 参数2：排序文件路径
  • 参数3：返回排序值，未查询到返回 0，即未上榜
  • 参数4：排行分类
    • 参数值为1，个人
    • 参数值为2，行会

示例：

getRank <$userName> ..\test\test\test9.txt s$myRank 1
sendMsg 6 <$userName>:<$str(s$myRank)>

delRankData

清理排行榜文件中的指定对象数据

标签:命令定义|delRankData

格式
命令名 | 参数1 | 参数2 | 参数3
delRankData | 删除对象的id | 排行文件 | 排序规则
说明:

  • 参数1
    删除对象的id，在保存过排行数据的文件中查看
  • 参数2
    排行文件路径
  • 参数3
    排序规则，删除后刷新排行
    • 0：升序
    • 1：降序

脚本示例：

[@删除指定排行]
#act
mov s$删除对象 467601
mov s$排行文件路径 ..\test\test\test9.txt
delRankData <$str(s$删除对象)> <$str(s$排行文件路径)> 1

delRankData 467604 ..\test\test\test9.txt 1

..\test\test\test9.txt：
[GLOBAL]
;id = 玩家名称 排序属性 其它属性1|其它属性2|.. 序号 排序方式（0升序，1降序）
467601=玩家A 347 玩家A|行会A|347|225|11489 0 0
467604=玩家B 333 玩家B|暂无|333|212|5414 1 0
467603=玩家C 103 玩家C|行会B|103|232|16964 2 0

rankView

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8 | 参数9 | 参数10 | 参数11 | 参数12
rankView | 排行文件 | 排行名称 | 排行列表高度 | 排行列表各行宽度 | X偏移值 | Y偏移值 | 选中图片 | 间隔图片 | 单条高度 | 字号 | 文字颜色(选中,未选中) | 前三名图标

说明:

  • 命令效果：命令_ok 框类，以对话框左上角为锚点(0,0)，显示指定排名文件中的排名信息
  • 参数1：排行榜文件所在路径
  • 参数2：排行名称
  • 参数3：排名list在对话框中的高度
  • 参数4：排行列表各行宽度，用|分隔
  • 参数5：对话框中X偏移值
  • 参数6：对话框中Y偏移值
  • 参数7：选中框图片资源路径
  • 参数8：间隔图片资源路径
  • 参数9：排行列表的单条高度
  • 参数10：列表内容文字的字号大小
  • 参数11：列表内容文字的文字颜色，分为选中未选中两种状态，用逗号分隔
  • 参数12：前三名的排名图标的资源名，用逗号分隔

示例：

<rankView:<$str(s$filePath)>:等级排行:550:<$str(s$width)>:260:150:1:renwu_xhuanzhong01:nwtest_paihangbang_xinxifenge:100:30:149,158:rank_1,rank_2,rank_3/@actRank1>\

playUserModel

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
playUserModel | 角色昵称 | X偏移值 | Y偏移值 | UI缩放比例,旋转角度 | 模型缩放比例

说明:

  • 命令效果：命令_ok 框类，在对话框指定位置，播放指定昵称的角色模型
  • 参数1：角色昵称
  • 参数2和3：用于确定模型在对话框中的位置
  • 参数4：UI缩放比例,旋转角度（用逗号隔开）
  • 参数5：模型缩放比例，1不缩放

示例：

<playUserModel:<$str(s$currPlayer)>:1200:640:1,90:2>

viewPlayer

格式:

命令名 | 参数1
viewPlayer | 角色昵称

说明:

  • 命令效果：打开玩家角色信息窗口，默认选中装备分页
  • 参数1：角色昵称

示例：

viewPlayer <$str(s$currPlayer)>

getRankInfo

获取指定排行文件的排行对象的信息

标签:命令定义|getRankInfo

格式
命令名 | 参数1 | 参数2 | 参数3
getRankInfo | 排序文件 | 返回排名变量 | 返回玩家信息变量
说明

  • 参数1:排序文件的文件路径和文件名
  • 参数2:用于存储返回值的变量名，返回的是文件中存储的排名值，排名值之间用,分隔
  • 参数3:用于存储返回值的变量名，返回的是文件中存储的玩家信息，多条信息之间用,分隔
    • 玩家信息的内容在命令saveRankData的【参数6-排行榜表头属性】中定义
    • 注意：返回的玩家信息中不能包含,

特戒引擎脚本示例：

[@获取排行玩家信息]
#act
;从rank.txt中获取消费排名和消费玩家数据
getRankInfo ..\排名\rank.txt s$消费排名 s$消费玩家数据

pgExtractString , s$消费排名 N$消费排名返回值 N$消费排名分隔数

pgExtractString , s$消费玩家数据 S$消费玩家数据返回值 N$消费玩家数据分隔数


对话框自定义tab按钮、itemList和itemGrid

标签:
对话框|自定义|按钮|tab|列表|list|grid

btnItem

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8
btnItem | 选中状态图片资源名 | 未选中状态图片资源名 | listId | 文字颜色值 | 横竖排 | 文字偏移 | 文字文本 | 跳转连接

说明:

  • 命令效果：设置单个tab按钮的各种属性
  • 参数1：该tab按钮处于选中状态时显示的图片资源名，一般而言，选中状态的按钮和未选中状态相比会更醒目
    • 同一组tab按钮的图片需要保持尺寸大小一致
  • 参数3：listId，该按钮在btnList中的顺序id，id从1开始从小到大顺序排列，用于标识是否为当前选中的tab按钮
  • 参数4：按钮选中和未选中状态文字的颜色值，用逗号分隔
    • 颜色值，纯数字，范围0到255
  • 参数5：按钮文字的显示方式
    • 0-文字横排
    • 1-文字竖排

文字横/竖排效果

  • 参数6：按钮文字的偏移值，用逗号分隔
  • 参数7：按钮文字的内容
  • 参数8：点击按钮触发的@块

示例：

btnItem:anniu_zhengli_02:anniu_zhengli_01:1:254,150:0:0,0:周一活动/@周一活动

btnList

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7
btnList | 按钮列表内容 | 按钮列表名称 | list相对于对话框X偏移 | list相对于对话框Y偏移 | 纵横宽高 | 按钮字号 | 选中按钮id

说明:

  • 命令效果：定义一组tab按钮，并显示在对话框中
  • 参数1：按钮列表通过变量赋值方式实现
  • 参数2：区分同一个界面中不同的列表用
  • 参数3：列表相对于对话框的X偏移值
  • 参数4：列表相对于对话框的Y偏移值
  • 参数5：列表的显示方式与滑动设置
    • 参数填写为1,N或者1,N,1，表示列表为纵向滑动，N为滑动高度数字
    • 参数填写为0,N或0,N,1，表示列表为横向滑动，N为滑动宽度数字
    • 参数填写为1,N,0，表示列表纵向不滑动
    • 参数填写为0,N,0，表示列表横向不滑动
  • 参数6：按钮字号
  • 参数7：选中按钮的id，决定将该按钮列表中的第几个tab按钮显示成选中状态

示例：

<btnList:<$str(S$btnList0)>:会员和活动列表:-95:0:1,600:30:2>\

itemList

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6
itemList | list内容 | 列表名称，当前选中的单元序号 | list相对于对话框X偏移 | list相对于对话框Y偏移 | 纵横宽高 | 间距

说明:

  • 命令效果：定义一个内容列表，并显示在对话框中
    • itemlist前后必须加\做分隔符
  • 参数1： 列表通过变量赋值方式实现
  • 参数2： 区分同一个界面中不同的列表用，以及定义该列表当前选中的单元序号
  • 参数3：列表相对于对话框X偏移
  • 参数4：列表相对于对话框Y偏移
  • 参数5：列表的显示方式与滑动设置
    • 参数填写为1,N或者1,N,1，表示列表为纵向滑动，N为滑动高度数字
    • 参数填写为0,N或0,N,1，表示列表为横向滑动，N为滑动宽度数字
    • 参数填写为1,N,0，表示列表纵向不滑动
    • 参数填写为0,N,0，表示列表横向不滑动

item列表竖排效果

  • 参数6：列表之间的间距

示例：

\<itemList:<$str(s$itemList)>:itemListName:240:0:1,550:5>\

itemSize

格式:

命令名 | 参数1 | 参数2 | 参数3
itemSize | item的长度 | item的高度 | 单元序号

说明:

  • 命令效果：定义item列表的大小和在所属列表中的单元序号
  • 参数1：item列表的长度
  • 参数2：item列表的高度
  • 参数3：item列表的序号

示例：

move s$item0 (<itemSize:500:325:1>)

itemtoggle

格式:

命令名 | 参数1 | 参数2 | 参数3
itemtoggle | 选中状态图片资源名 | 未选中状态图片资源名 | 跳转连接

说明:

  • 命令效果：制作单独item时，设置选中/未选中状态的图片，以及选中后触发的@块
    • toggle命令固定写在itemsize命令之后
  • 参数1：选中状态的显示图片
  • 参数2：未选中状态的显示图片
  • 参数3：选中触发的@块

示例：

mov s$item1 (<itemsize:50:50>
inc s$item1 <itemtoggle:hefu:huodong/@周二活动>
inc s$item1 <text:特戒天魔降临{scolor=150}:30:40>)

panelSize

格式:

命令名 | 参数1 | 参数2
panelSize | 不裁剪区域的长度 | 不裁剪区域的高度

说明:

  • 命令效果：对itemList不要再进行区域裁剪

示例：

<panelsize:1300:650>

itemGrid

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7
itemGrid | itemGrid内容 | itemGridName,当前选中序号,是否可不选序号,可不选时是否亮 | 相对于对话框X偏移 | 相对于对话框Y偏移 | 纵横宽高 | 滑动方向,行列数,总高/宽度,是否可滑动 | 间隔

说明:

  • 命令效果：以格子的形式组织item，并显示在对话框中
  • 与itemList相比，itemGrid中的item显示尺寸一致，可以显示成多列
  • 参数1：itemGrid的内容通过变量赋值方式实现
  • 参数2：itemGridName,当前选中序号,是否可不选序号,可不选时是否亮
    • 是否可不选序号，0可不选,1必选一个
    • 可不选时是否亮，0不亮，1亮
  • 参数3、4：Grid整个格子区域相对于对话框的x、y偏移值，用于确定整个格子区域在界面上的位置
  • 参数5：单个item的尺寸，宽度和高度，用于决定每个格子的大小
  • 参数6：滑动方向,行列数,总高/宽度,是否可滑动
    • 滑动方向，1竖向，0横向
    • 行列数，由滑动方向决定，滑动方向1该值即为列数；滑动方向0该值即为行数
    • 总高/宽度，指整个格子区域的，由滑动方向决定，滑动方向1竖向，则该值为格子区域总高度；滑动方向0横向，则该值为格子区域总宽度
    • 是否可滑动，1可滑动，0不可滑动
  • 参数7：格子之间的间隔

示例：

;默认选中第4个,必选中1个,:x坐标:y坐标:单个item500x325,纵向滑动,两列,总高度650,可滑动:间隔0
<itemGrid:<$str(s$itemList)>:GridName,4,1,1:0:0:500,325:1,2,650,1:0>\

综合示例：

[@按钮列表]
#act
mov S$btnList (btnItem:anniu_zhengli_02:anniu_zhengli_01:1:254,150:0:0,0:青铜会员/@青铜会员)
inc S$btnList (btnItem:anniu_zhengli_02:anniu_zhengli_01:2:254,150:0:0,0:白银会员/@白银会员)
inc S$btnList (btnItem:anniu_zhengli_02:anniu_zhengli_01:3:254,150:0:0,0:黄金会员/@黄金会员)

[@main]
#act
goto @按钮列表
openMerchantBigDlg ok_di 0 0 0 1 0 0
goto @青铜会员

[@青铜会员]
#say
<btnList:<$str(S$btnList)>:0:0:1,600:30:1>
[@白银会员]
#say
<btnList:<$str(S$btnList)>:0:0:1,600:30:2>
[@黄金会员]
#say
<btnList:<$str(S$btnList)>:0:0:1,600:30:3>

btnlist效果

[@item初始化]
#act
mov s$item1 (<itemsize:500:325>
inc s$item1 <img:zd_7_5:0:0:1:2.5>
inc s$item1 <itemShow:101:0:350:80:1:0>
inc s$item1 <text:特戒天魔降临{scolor=150}:30:40>
inc s$item1 <text:奖励预览:340:40>
inc s$item1 <text:开启时间:30:100>
inc s$item1 <text:10~~~:~~~00-11~~~:~~~00:160:100>
inc s$item1 <text:开启条件:30:160>
inc s$item1 <text:60级:160:160>
inc s$item1 <text:击杀天外魔君,想要奖励就来找我{scolor=248}:30:240>)
mov s$item2 (<itemsize:500:325>
inc s$item2 <img:zd_7_5:0:0:1:2.5>
inc s$item2 <itemShow:101:0:350:80:1:0>
inc s$item2 <text:特戒双倍押标{scolor=150}:30:40>
inc s$item2 <text:奖励预览:340:40>
inc s$item2 <text:开启时间:30:100>
inc s$item2 <text:11~~~:~~~00-12~~~:~~~00:160:100>
inc s$item2 <text:开启条件:30:160>
inc s$item2 <text:好几转:160:160>
inc s$item2 <text:圣域双倍押镖,风险与利益共存{scolor=248}:30:240>)
mov s$itemList <$str(s$item1)>
inc s$itemList <$str(s$item2)>
[@main]
#act
goto @item初始化
openMerchantBigDlg ok_di 0 0 0 1 0 0
#say
<panelsize:700:600>\
;<itemList:list内容:x偏移:y偏移:(1纵向,0横向),(纵向高度,横向宽度):5>
<itemList:<$str(s$itemList)>:itemListName:0:0:1,550:5>\
;<itemList:<$str(s$itemList)>:itemListName:0:0:0,650:5>

itemlist效果


自定义主界面右下角功能按钮

标签:
红点|自定义|按钮|主界面|引导|

isUseCustomMainBtn

格式:

isUseCustomMainBtn=0
isUseCustomMainBtn=1

说明:

  • 特戒配置项，效果为版本是否启用自定义主界面右下角按钮
  • isUseCustomMainBtn=0时，主界面右下角按钮无法自定义
    非自定义的系统默认按钮情况见下图
  • isUseCustomMainBtn=1时，主界面右下角按钮需要自定义
  • 未配置时，即系统在[tjconfig]下未找到该配置时，默认配置值为0

示例：

文件路径：
.\scripts\Mir200\Tejieconfig\Tejieconfig.txt
配置模块：
[tjconfig]
配置项：
;是否启用自定义主界面右下角按钮（1开放，0不开放 默认不开放）
isUseCustomMainBtn=1

addMainUiRightBtn

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8 | 参数9
addMainUiRightBtn | 图片资源名 | 按钮排序id | 按钮功能id（含子功能id） | 按钮类型 | 按钮文本内容 | 按钮文本颜色 | 按钮文本字体大小 | 按钮文本微调坐标x | 微调坐标y

说明:

  • 效果：在主界面右下角添加一个按钮
    • 可添加多个按钮，从界面布局考虑，最多可添加12个按钮，超过显示会超出屏幕
  • 参数2:决定按钮的显示顺序，和主界面右上区域的自定义按钮的显示方式不同，参数2的数字是排序数字而非位置数字，参数2的数字越小对应的按钮显示越靠上靠右，效果见下图
  • 参数3:分为系统按钮和自定义按钮，与参数4配合使用
    • 系统按钮时，参数值和功能界面（子界面）的对应关系如下
      1,0 = 角色-装备
      1,1 = 角色-状态
      1,2 = 角色-属性
      1,3 = 角色-称号
      1,4 = 角色-技能
      1,5 = 角色-时装
      2 = 好友
      3 = 行会
      4 = 摆摊
      5 = 排行
      6 = 邮件
      7,1 = 设置-基本设置
      7,2 = 设置-战斗设置
      7,3 = 设置-保护设置
      7,4 = 设置-挂机设置
      7,5 = 设置-账号设置
      7,6 = 设置-BUG与建议
      8 = 商城
    • 注意：系统按钮，属于一个功能界面的子界面，在主界面右下角功能按钮中只能同时存在一个，添加多个无法同时显示。
    • 自定义按钮时，和命令addbutton共用按钮ID，点击触发的脚本位于
      .\scripts\Mir200\Envir\Market_Def\QFunction-0.txt
      [@ButtonClickX]，X为参数3的值
  • 参数4:1-系统，2-自定义，与参数3配合使用

示例：

[@添加按钮]
#act
addMainUiRightBtn lt_jineng_bth 1 1,4 1
addMainUiRightBtn lt_haoyou_bth 2 2 1
addMainUiRightBtn lt_bangpai_bth 3 3 1
addMainUiRightBtn lt_baitan_bth 4 4 1
addMainUiRightBtn lt_paihang_bth 5 5 1
addMainUiRightBtn lt_youjian_bth 6 6 1
addMainUiRightBtn lt_shezhi_bth 7 7,3 1
addMainUiRightBtn shangcheng 8 8 1
addMainUiRightBtn shangma 9 40 2

delMainUiRightBtn

格式:

命令名 | 参数1 | 参数2
delMainUiRightBtn | 按钮功能id | 按钮类型

说明:

  • 效果：删除主界面右下角的一个指定的按钮
  • 参数1:分为系统按钮和自定义按钮，与参数2配合使用
    • 系统按钮时，参数值和功能界面的对应关系如下
1 =  角色（包括全部子界面）
2 = 好友
3 = 行会
4 =
    摆摊
5 = 排行
6 = 邮件
7 = 设置（包括全部子界面）
8 = 商城
    • 自定义按钮时，点击触发的脚本位于
      .\scripts\Mir200\Envir\Market_Def\QFunction-0.txt
      [@ButtonClickX]，X为参数1的值
  • 参数2:1-系统，2-自定义，与参数1配合使用

示例：

[@删除按钮]
#act
delMainUiRightBtn 1 1

删除技能按钮前

删除技能按钮后

redpointMainUiRightBtn

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
redpointMainUiRightBtn | 按钮功能id | 按钮类型 | 红点操作 | X偏移值 | Y偏移值

说明:

  • 效果：添加/删除主界面右下角的一个指定按钮的红点提示
  • 参数1:分为系统按钮和自定义按钮，与参数2配合使用
    • 系统按钮时，参数值和功能界面的对应关系如下
1 =  角色（包括全部子界面）
2 = 好友
3 = 行会
4 =
    摆摊
5 = 排行
6 = 邮件
7 = 设置（包括全部子界面）
8 = 商城
    • 自定义按钮时，点击触发的脚本位于
      .\scripts\Mir200\Envir\Market_Def\QFunction-0.txt
      [@ButtonClickX]，X为参数1的值
  • 参数2:1-系统，2-自定义，与参数1配合使用
  • 参数3:0-删除红点提示，1-添加红点提示
  • 参数4和5:微调红点和对应按钮的相对位置

示例：

[@添加红点]
#act
redpointMainUiRightBtn 2 1 1 -10 -10

[@删除红点]
#act
redpointMainUiRightBtn 2 1 0

红点提示效果

guideMainUiRightBtn

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
guideMainUiRightBtn | 按钮功能id | 按钮类型 | 引导操作 | 引导文字 | 箭头位置

说明:

  • 效果：添加/删除主界面右下角的一个指定按钮的引导提示
  • 参数1:分为系统按钮和自定义按钮，与参数2配合使用
    • 系统按钮时，参数值和功能界面的对应关系如下
1 =  角色（包括全部子界面）
2 = 好友
3 = 行会
4 =
    摆摊
5 = 排行
6 = 邮件
7 = 设置（包括全部子界面）
8 = 商城
    • 自定义按钮时，点击触发的脚本位于
      .\scripts\Mir200\Envir\Market_Def\QFunction-0.txt
      [@ButtonClickX]，X为参数1的值
  • 参数2:1-系统，2-自定义，与参数1配合使用
  • 参数3:0-删除引导提示，1-添加引导提示
  • 参数5:
    1-箭头在按钮上方，向下指
    2-箭头在按钮下方，向上指
    3-箭头在按钮左边，向右指
    4-箭头在按钮右边，向左指

示例：

[@添加引导]
#act
guideMainUiRightBtn 2 1 1 点这里 3

[@删除引导]
#act
guideMainUiRightBtn 2 1 0

引导提示效果

完整示例?

文件路径：
.\scripts\Mir200\Tejieconfig\Tejieconfig.txt
配置模块：
[tjconfig]
配置项：
;是否启用自定义主界面右下角按钮（1开放，0不开放 默认不开放）
isUseCustomMainBtn=1

[@添加一个操作界面]
#act
#say
<>\\
<添加按钮/@添加按钮> <删除按钮/@删除按钮> <>\\
<>\\
<>\\
<添加红点/@添加红点> <删除红点/@删除红点> <>\\
<>\\
<>\\
<添加引导/@添加引导> <删除引导/@删除引导> <>\\
<>\\

[@添加按钮]
#act
addMainUiRightBtn lt_jineng_bth 1 1,4 1
addMainUiRightBtn lt_haoyou_bth 2 2 1
addMainUiRightBtn lt_bangpai_bth 3 3 1
addMainUiRightBtn lt_baitan_bth 4 4 1
addMainUiRightBtn lt_paihang_bth 5 5 1
addMainUiRightBtn lt_youjian_bth 6 6 1
addMainUiRightBtn lt_shezhi_bth 7 7,3 1
addMainUiRightBtn shangcheng 8 8 1
addMainUiRightBtn shangma 9 40 2

[@删除按钮]
#act
delMainUiRightBtn 1 1

[@添加红点]
#act
redpointMainUiRightBtn 2 1 1 -10 -10

[@删除红点]
#act
redpointMainUiRightBtn 2 1 0

[@添加引导]
#act
guideMainUiRightBtn 2 1 1 点这里 3

[@删除引导]
#act
guideMainUiRightBtn 2 1 0


神佑首饰盒

标签:模块示例|神佑首饰盒

模块说明
神佑首饰盒是一系列的装备位，首饰盒开启后可以穿戴对应的装备

相关配置
一、数据表
..\Mud2\DB\StdItems.CSV
表字段Stdmode决定该装备是否可穿戴到神佑首饰盒
字段值与装备格的对应关系：
72-神佑首饰1
73-神佑首饰2
74-神佑首饰3
75-神佑首饰4
76-神佑首饰5
77-神佑首饰6

二、装备位
神佑首饰盒拥有六个装备位，装备位编号51-56
装备位编号与装备格的对应关系：
51-神佑首饰1
52-神佑首饰2
53-神佑首饰3
54-神佑首饰4
55-神佑首饰5
56-神佑首饰6

特戒引擎脚本示例：

;..\Mir200\Envir\QuestDiary\神佑首饰盒\神佑首饰盒.txt
[@main]
#say
<显示首饰盒按钮/@显示首饰盒按钮> \ \
<锁住首饰盒按钮/@锁住首饰盒按钮> \ \
<隐藏首饰盒按钮/@隐藏首饰盒按钮> \ \

;在界面上显示首饰盒按钮
[@显示首饰盒按钮]
#act
activationCasket
messageBox 首饰盒入口在角色装备界面，点击首饰盒按钮可解锁

;将首饰盒按钮重新上锁，不常用
[@锁住首饰盒按钮]
#say
<关闭首饰盒/@确定关闭首饰盒> \ \
<取消/@exit>\

[@确定关闭首饰盒]
#act
setSndacasket 0
messageBox 首饰盒成功上锁

;隐藏界面上的首饰盒按钮，不常用
[@隐藏首饰盒按钮]
#say
必须在首饰盒显示或关闭的状态下才能使用 \ \
<隐藏首饰盒/@确定隐藏首饰盒> \ \
<取消/@exit>\

[@确定隐藏首饰盒]
#act
closeSndacasket
messageBox 首饰盒按钮成功隐藏

;..\Mir200\Envir\Market_Def\QFunction-0.txt
;解锁神佑首饰盒按钮
[@openSndacasket]
#say
<解锁首饰盒/@确定解锁首饰盒> \ \
<取消/@exit>\

[@确定解锁首饰盒]
#if
#act
setSndacasket 1
messageBox 首饰盒成功解锁

;穿装备触发，神佑首饰盒装备的装备位置是51-56
[@TakeOn51]
#act
messageBox 穿戴神佑盒装备51成功

;脱装备触发，神佑首饰盒装备的装备位置是51-56
[@TakeOff51]
#act
messageBox 脱掉神佑盒装备51成功


设置子对话框(二级对话框)

<childDlg:

设置子对话框(二级对话框)

标签:命令定义|dlg_childDlg

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7
childDlg | 子对话框内容 | 子对话框名称 | 背景图资源名称 | 显示位置 | x偏移 | y偏移 | 关闭跳转标签
说明
  • 参数1：子对话框内容
    • 包含在"()"内
    • 以<itemSize:>定义开头
      举例
      mov s$子对话框 (<itemSize:400:520>
      inc s$子对话框 <text:子对话框1{scolor=150}:100:40>
      inc s$子对话框 )
  • 参数2：子对话框名称
  • 参数3：背景图资源名称,参见资源编辑器
  • 参数4：子对话框在主对话框中的位置
    • 0 左上
    • 1 右上
    • 2 左下
    • 3 右下
    • 4 居中
  • 参数5：相对于参数4的x偏移
  • 参数6：相对于参数4的偏移
  • 参数7：关闭子对话框后的跳转标签
    点击子对话框外部任意处,
    可关闭子对话框
    跳转至参数7标记的标签

特戒引擎脚本示例：

[@main]
#act
openMerchantBigDlg ok_di 4 0 0 1 0 0
#say
<panelSize:1000:800>\
<text:主对话框:50:50>
<text:打开子对话框1:50:150/@childDlg1>
<text:打开子对话框2:50:200/@childDlg2>

#if
equal s$子界面 1
#say
<childDlg:<$str(s$myContainer)>:子对话框1名子:ok_di:4:0:0/@close>

#if
equal s$子界面 2
#say
<childDlg:<$str(s$myContainer1)>:子对话框2名子:ok_di:4:0:0/@close>

[@iniChildDlg]
#act
mov s$myContainer (<itemSize:400:520>
inc s$myContainer <text:子对话框1{scolor=150}:100:40>
inc s$myContainer )

#act
mov s$myContainer1 (<itemSize:600:600>
inc s$myContainer1 <text:子对话框2{scolor=150}:100:40>)

[@childDlg1]
#act
mov s$子界面 1
goto @iniChildDlg
goto @main

[@childDlg2]
#act
mov s$子界面 2
goto @iniChildDlg
goto @main

[@close]
#act
mov s$子界面 0
goto @main


设置风琴列表样式

<accordionList:
设置风琴列表样式

标签:命令定义|accordionList

格式 命令名 参数1 参数2 参数3 参数4 参数5 参数6
accordionList 风琴列表内容 内部按钮样式 列表名称 x坐标,y坐标 列表高度,是否滑动 外部按钮样式
说明
参数1: 风琴列表内容，由一组 风琴列表外部按钮 组合构成
举例
mov s$风琴列表 (acdBtn:<acdItem:1:内部文字1_1/@按钮1_1><acdItem:2:内部文字1_2/@按钮1_2><acdItem:3:内部文字1_3/@按钮1_3>:1:外部文字1/@按钮1)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字2_1/@按钮2_1><acdItem:2:内部文字2_2/@按钮2_2><acdItem:3:内部文字2_3/@按钮2_3>:1:外部文字2/@按钮2)
参数2: 内部按钮样式
参数2.1: 按钮文字x坐标,按钮文字y坐标
参数2.2: 按钮选中图片,按钮未选中图片
参数2.3: 按钮文字大小,选中字色,未选中字色
参数2.4: 选中索引
举例
mov s$内部按钮样式 2,3:huishouwupin_xuanzhongkuang,denglu_liebiao_weixuanzhong:30,168,232:1
参数3: 列表名称
参数4: x坐标,y坐标
风琴列表在自定义对话框中的坐标
参数5: 列表高度,是否滑动(1可滑动;0不可滑动)
参数6: 外部按钮样式
参数6.1: 按钮文字x坐标,按钮文字y坐标
参数6.2: 按钮选中图片,按钮未选中图片
参数6.3: 按钮文字大小,选中字色,未选中字色
参数6.4: 选中索引
举例
mov s$外部按钮样式 0,0:lc_shijieliaotian_xuanzhong,lc_shijieliaotian_weixuanzhong:35,24,128:1
#say命令中出现 <accordionList: 命令时，#say中<>模块必须以“\”结尾
参见以下脚本示例

特戒引擎脚本示例：
使用前提1
请开启配置开关"isUseCustomOKPanel" 配置文件 ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 [tjconfig]
配置项 isUseCustomOkPanel=1
使用前提2
请配置补丁资源"lc",即找到以下配置项,加入 lc 配置文件 ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 [tjconfig]
配置项 patch=aa,bb,lc

--------------------------------------------------------------------------------

示例1
[@main]
#act
goto @按钮列表初始化
goto @外部按钮样式
goto @内部按钮样式
mov n$按钮1选中 0
goto @按钮1
goto @显示界面

[@按钮列表初始化]
#act
mov s$风琴列表 (acdBtn:<acdItem:1:内部文字1_1/@按钮1_1><acdItem:2:内部文字1_2/@按钮1_2>:1:外部文字1/@按钮1)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字2_1/@按钮2_1><acdItem:2:内部文字2_2/@按钮2_2>:2:外部文字2/@按钮2)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字3_1/@按钮3_1><acdItem:2:内部文字3_2/@按钮3_2>:3:外部文字3/@按钮3)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字4_1/@按钮4_1><acdItem:2:内部文字4_2/@按钮4_2>:4:外部文字4/@按钮4)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字5_1/@按钮5_1><acdItem:2:内部文字5_2/@按钮5_2>:5:外部文字5/@按钮5)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字6_1/@按钮6_1><acdItem:2:内部文字6_2/@按钮6_2>:6:外部文字6/@按钮6)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字7_1/@按钮7_1><acdItem:2:内部文字7_2/@按钮7_2>:7:外部文字7/@按钮7)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字8_1/@按钮8_1><acdItem:2:内部文字8_2/@按钮8_2>:8:外部文字8/@按钮8)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字9_1/@按钮9_1><acdItem:2:内部文字9_2/@按钮9_2>:9:外部文字9/@按钮9)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字10_1/@按钮10_1><acdItem:2:内部文字10_2/@按钮10_2>:10:外部文字10/@按钮10)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字11_1/@按钮11_1><acdItem:2:内部文字11_2/@按钮11_2>:11:外部文字11/@按钮11)
inc s$风琴列表 (acdBtn:<acdItem:1:内部文字12_1/@按钮12_1><acdItem:2:内部文字12_2/@按钮12_2>:12:外部文字12/@按钮12)

[@外部按钮样式]
#act
;--按钮文本偏移x,按钮文本偏移y:选中图片名,未选中图片名:按钮文字大小,选中字色,未选中字色:选中索引--
mov s$外部按钮样式 0,0:lc_shijieliaotian_xuanzhong,lc_shijieliaotian_weixuanzhong:35,24,128:1

[@内部按钮样式]
#act
;--按钮文本偏移x,按钮文本偏移y:选中图片名,未选中图片名:按钮文字大小,选中字色,未选中字色:选中索引--
mov s$内部按钮样式 2,3:huishouwupin_xuanzhongkuang,denglu_liebiao_weixuanzhong:30,168,232:1

[@内容刷新]
#act
mov s$item (
inc s$item <itemSize:905:325:1>
inc s$item <text:<$str(s$测试内容)>:0:0>
inc s$item )
mov s$itemList <$str(s$item)>
refreshItem 刷新内容 1 s$item 0

[@显示界面]
#act
openMerchantBigDlg ok_di 4 0 0 1 0 0
#say
<panelsize:1200:900>\
<accordionList:<$str(s$风琴列表)>:<$str(s$内部按钮样式)>:手风琴列表:0,0:800,1:<$str(s$外部按钮样式)>>\
<itemList:<$str(s$itemList)>:刷新内容,1:225:10:1,835,0:5>\

[@按钮1]
#act
mov n$外部按钮 1
goto @内部按钮

[@按钮2]
#act
mov n$外部按钮 2
goto @内部按钮

[@内部按钮]
#if
equal <$str(n$按钮<$str(n$外部按钮)>选中)> 0
#act
goto @按钮<$str(n$外部按钮)>_1
#elseAct
mov s$内部选中 <$str(n$按钮<$str(n$外部按钮)>选中)>
goto @按钮<$str(n$外部按钮)>_<$str(s$内部选中)>

[@按钮1_1]
#act
mov n$按钮1选中 1
mov s$测试内容 按钮1_1专属内容
goto @内容刷新

[@按钮1_2]
#act
mov n$按钮1选中 2
mov s$测试内容 按钮1_2专属内容
goto @内容刷新

[@按钮2_1]
#act
mov n$按钮2选中 1
mov s$测试内容 按钮2_1专属内容
goto @内容刷新

[@按钮2_2]
#act
mov n$按钮2选中 2
mov s$测试内容 按钮2_2专属内容
goto @内容刷新

--------------------------------------------------------------------------------

示例2
通过读表，设定风琴列表按钮。

使用前提
将附件中的配置文件放入以下目录
..\Mir200\Envir\QuestDiary\数据文件\

[@main]
#act
goto @风琴列表内容
mov n$按钮1选中 0
goto @按钮1
goto @显示界面

[@内容刷新]
#act
mov s$item (
inc s$item <itemSize:905:325:1>
inc s$item <text:<$str(s$测试内容)>:0:0>
inc s$item )
mov s$itemList <$str(s$item)>
refreshItem 刷新内容 1 s$item 0

[@显示界面]
#act
openMerchantBigDlg ok_di 4 0 0 1 0 0
#say
<panelsize:1200:900>\
<accordionList:<$str(s$风琴列表)>:<$str(s$内部按钮样式)>:手风琴列表:0,0:800,1:<$str(s$外部按钮样式)>>\
<itemList:<$str(s$itemList)>:刷新内容,1:225:10:1,835,0:5>\

[@按钮1]
#act
mov n$外部按钮 1
goto @内部按钮

[@按钮2]
#act
mov n$外部按钮 2
goto @内部按钮

[@内部按钮]
#if
equal <$str(n$按钮<$str(n$外部按钮)>选中)> 0
#act
goto @按钮<$str(n$外部按钮)>_1
#elseAct
mov s$内部选中 <$str(n$按钮<$str(n$外部按钮)>选中)>
goto @按钮<$str(n$外部按钮)>_<$str(s$内部选中)>

[@按钮1_1]
#act
mov n$按钮<$str(n$外部按钮)>选中 1
mov s$测试内容 按钮1_1专属内容
goto @内容刷新

[@按钮1_2]
#act
mov n$按钮<$str(n$外部按钮)>选中 2
mov s$测试内容 按钮1_2专属内容
goto @内容刷新

[@按钮2_1]
#act
mov n$按钮<$str(n$外部按钮)>选中 1
mov s$测试内容 按钮2_1专属内容
goto @内容刷新

[@按钮2_2]
#act
mov n$按钮<$str(n$外部按钮)>选中 2
mov s$测试内容 按钮2_2专属内容
goto @内容刷新

;--风琴按钮样式布局--

[@风琴列表内容]
#act
mov s$风琴列表
tbl_load g风琴按钮1 \数据文件\风琴按钮1.csv
tbl_load g风琴按钮2 \数据文件\风琴按钮2.csv

#if tbl g风琴按钮1 s$关键字
#act
mov s$外部按钮id <$str(s$关键字)>
mov s$外部按钮名 <$tbl(g风琴按钮1,s$关键字,按钮名)>
mov s$外部按钮序号 <$tbl(g风琴按钮1,s$关键字,序号)>
mov n$子数量 <$tbl(g风琴按钮1,s$关键字,子数量)>
mov n0 1
mov s$内部按钮
goto @内部按钮赋值

#if
#act
;--输出风琴按钮列表信息--
goto @外部按钮样式
goto @内部按钮样式

[@内部按钮赋值]
#if loop n$子数量
#act
mov s$子关键字 <$str(s$外部按钮id)>_<$str(n0)>
mov s$内部按钮id <$str(s$子关键字)>
mov s$内部按钮名 <$tbl(g风琴按钮2,s$子关键字,按钮名)>
mov s$内部按钮序号 <$tbl(g风琴按钮2,s$子关键字,序号)>
inc s$内部按钮 <acdItem:<$str(s$内部按钮序号)>:<$str(s$内部按钮名)>/@<$str(s$内部按钮id)>>
inc n0 1

#if
#act
mov s$外部按钮 (acdBtn:<$str(s$内部按钮)>:<$str(s$外部按钮序号)>:<$str(s$外部按钮名)>/@<$str(s$外部按钮id)>)
inc s$风琴列表 <$str(s$外部按钮)>

[@外部按钮样式]
#act
;--按钮文本偏移x,按钮文本偏移y:选中图片名,未选中图片名:按钮文字大小,选中字色,未选中字色:选中索引--
mov s$外部按钮样式 0,0:lc_shijieliaotian_xuanzhong,lc_shijieliaotian_weixuanzhong:35,24,128:1

[@内部按钮样式]
#act
;--按钮文本偏移x,按钮文本偏移y:选中图片名,未选中图片名:按钮文字大小,选中字色,未选中字色:选中索引--
mov s$内部按钮样式 2,3:huishouwupin_xuanzhongkuang,denglu_liebiao_weixuanzhong:30,168,232:1


获取pgExtractString命令拆分后的指定顺序字符串

getListValue
获取pgExtractString命令拆分后的指定顺序字符串

标签:命令定义|getListValue

格式
命令名 | 参数1 | 参数2 | 参数3
getListValue | pgExtractString拆分返回字符串 | 取拆分后第几个 | 结果保存变量
说明
  • 参数1
    pgExtractString拆分返回字符串
  • 参数2
    取拆分后第几个字符串
  • 参数3
    保存结果的返回变量

脚本示例：

[@main]
#act
mov s0 特戒|版本39|发布日期20220305
pgextractString | s0 s$拆分值 n0
getListValue s$拆分值 1 s$返回结果
sendMsg 6 拆分第1值是:<$str(s$返回结果)>
sendMsg 6 拆分数量<$str(n0)>


检测指定itemBox中有无物品

chkItemBoxNull

检测指定itemBox中有无物品

标签:命令定义|chkItemBoxNull

格式
命令名 | 参数1
chkItemBoxNull | itemBox编号
说明:
  • 参数1
    itemBox编号（0-7）

特戒引擎脚本示例：

[@main]
#say
<itemBox:0:0:0:0:0:40:40:*:tips>
<itemBox:1:0:0:200:0:40:40:*:tips>

#if
chkItemBoxNull 0
#act
sendMsg 6 0号itemBox有道具
#elseAct
sendMsg 6 0号itemBox无道具


脚本设置checkBox选中状态

setCheckBox
脚本设置checkBox选中状态

标签:命令定义|setCheckBox

格式
命令名 | 参数1 | 参数2
setCheckBox | 指定checkBox | 0不选,1勾选
说明

  • 参数1: 指定checkBox
    举例
    checkBox0
    checkBox1
    ......
  • 参数2: 是否勾选
    • 0不选
    • 1勾选
  • 参考: 对话框相关命令的用法
    <checkBox:

脚本示例：

[@main]
#if
not checkLevelEx > 59
#act
mov n$勾选0 0

#if
#say
<checkbox:0:settings_markbg:settings_mark:<$str(n$勾选0)>:50:50/@勾选0>
<text:勾选框:120:50>

[@勾选0]
#if
equal <$str(n$勾选0)> 0
checkLevelEx > 59
#act
mov n$勾选0 1
setCheckBox checkBox0 <$str(n$勾选0)>
sendTipsMsg 特戒提示:角色等级小于60就不能勾选了/sColor=150
goto @main
break

#if
equal <$str(n$勾选0)> 1
checkLevelEx > 59
#act
mov n$勾选0 0
setCheckBox checkBox0 <$str(n$勾选0)>
sendTipsMsg 特戒提示:角色等级小于60就不能勾选了/sColor=150
goto @main
break

#if
not checkLevelEx > 59
#act
mov n$勾选0 0
setCheckBox checkBox0 <$str(n$勾选0)>
sendTipsMsg 特戒提示:角色等级请达到60/sColor=150
goto @main
break


新版押镖（角色跟随镖车移动）

新版押镖

标签:
押镖|运镖|镖车|宝宝|宠物

autoEscort

格式:

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8 | 参数9 | 参数10 | 参数11 | 参数12 | 参数13 | 参数14 | 参数15
autoEscort | 宠物名 | 宠物寻路速度 | 主人与宠物的最大距离 | 宠物存活时长(秒) | NPC | NPC距离 | 跳转链接 | 召唤坐标x | 召唤坐标y | 是否可被攻击 | 距离内光圈特效 | 距离外光圈特效 | 光圈缩放比例 | 路点1x,路点2x,…,路点Nx | 路点1y,路点2y,…,路点Ny

说明:

  • 命令效果：召唤宠物，宠物自动寻路到本地图指定的npc处，并自动触发@块
  • 参数1：执行自动寻路的宠物名字，该宠物作为镖车类宠物处理
  • 参数2：宠物寻路时的移动速度，需支持小数
  • 参数3：主人与宠物的最大距离，超出该距离，宠物会暂停自动寻路，待主人重新回到最大距离之内重启寻路距离未超出时，以宠物为圆心，最大距离为半径显示绿圈；超出时显示红圈
  • 参数4：宠物存活时长（秒），超出后宠物消失
  • 参数5：寻路至本地图的哪个NPC
  • 参数6：宠物与该NPC距离小于多少时停止自动寻路，并自动执行指定的@块
  • 参数7：跳转链接，自动执行文件QFunction-0.txt里的块（不要带）
  • 参数8、9：镖车被召出的坐标x值和y值
  • 参数10：镖车是否可被攻击，0否，1是，默认为0
  • 参数11：人和镖车距离内时，镖车的光圈特效资源名
  • 参数12：人和镖车距离超出时，镖车的光圈特效资源名
  • 参数13：镖车光圈特效的缩放比例，1为原大小
  • 参数14：路线中间路点的坐标x，多个路点x值用逗号分隔
  • 参数15：路线中间路点的坐标y，多个路点y值用逗号分隔，参数14和参数15同时为0表示无中间路点

示例：

autoEscort 高级镖车 1 5 18 神石锻造 3 提交高级镖车 266 104 1 guangzhu1144 guangzhu1146 4 0 0
;召唤高级镖车自动寻路至本地图的 npc“神石锻造”附近，自动执行QFunction-0.txt 中的@提交高级镖车

fellowSlave

格式:

命令名 | 参数1 | 参数2
fellowSlave | 宠物名 | 跟随宠物时的最小距离

说明:

  • 命令效果：主人跟随宠物，且始终保持一定的距离
  • 参数1：跟随宠物的名字
  • 参数2：主人跟随宠物时的最小距离。超出该距离时，主人向宠物靠近；达到该距离时，主人停止移动

示例：

fellowSlave 高级镖车 3
;主人跟随自己的高级镖车，过程中始终保持3个单位的距离

stopFellowSlave

格式:

命令名
stopFellowSlave

说明:

  • 命令效果：停止主人自动跟随宠物

示例：

stopFellowSlave
;停止主人自动跟随宠物

checkEscort

格式:

命令名
checkEscort

说明:

  • 命令效果：检测镖车是否存在，存在则通过

示例：

not checkEscort
;如果当前未拥有镖车则通过

checkBiao

格式:

命令名
checkBiao

说明:

  • 命令效果：检测镖车是否处于移动状态，移动中则通过

示例：

#IF
checkBiao
#ACT
mov S$镖车状态 镖车状态：移动中...


主界面左侧边栏添加自定义对话框内容

addDlg

主界面左侧边栏添加自定义对话框内容

标签:命令定义|addDlg

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
addDlg | 侧边对话框编号 | 展示内容 | 平台类型 | 标签页图片组 | 创建或刷新
说明

  • 参数1: 侧边对话框编号
    支持多个左侧边栏自定义对话框
  • 参数2: 展示内容，同一id的左侧边栏自定义对话框,支持两个独立标签页
    格式如下:
    dlg:上方标签页内容文本dlg:下方标签页内容文本
  • 参数3: 平台类型
    • 1 手机
    • 2 PC
  • 参数4: 标签页图片组,格式如下
    标签页1按钮未选中图片,标签页1按钮选中图片,标签页2按钮未选中图片,标签页2按钮选中图片
  • 参数5: 创建或刷新
    • 0 创建新的侧边栏对话框
    • 1 刷新已存在的侧边栏对话框

delDlg

删除主界面左侧边栏自定义对话框

标签:命令定义|delDlg

格式
命令名 | 参数1
delDlg | 左侧边栏对话框编号

特戒引擎脚本示例：

使用前提1
请开启配置开关"isUseCustomOKPanel"
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | isUseCustomOkPanel=1
使用前提2
请配置补丁资源"lc",即找到以下配置项,加入 lc
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | patch=aa,bb,lc

[@main]
#act
mov s$dlgUpIni
inc s$dlgUpIni <text:魔神个人页面{fcolor=251}:50:20>
inc s$dlgUpIni <img:settings_jiantou_you:0:4:1:1>
inc s$dlgUpIni <img:settings_jiantou_zuo:220:4:1:1>
inc s$dlgUpIni <text:点击行会页签试试吧{fcolor=103}:12:175>
inc s$dlgUpIni <text:特戒引擎持续更新中{fcolor=103}:12:275>
inc s$dlgUpIni <img:lc_xiaofei_shuzi_dadao:360:125:1:1:0.7/@行会魔神介绍>
inc s$dlgUpIni <text:介绍{fcolor=103}:375:185:50:1:20>
inc s$dlgUpIni <img:lc_xiaofei_shuzi_changtai:360:220:1:1/@退出行会魔神>
inc s$dlgUpIni <text:退出{fcolor=103}:375:275:50:1:20>

mov s$dlgDownIni
inc s$dlgDownIni <text:魔神行会页面{fcolor=251}:50:20>
inc s$dlgDownIni <img:settings_jiantou_you:0:4:1:1>
inc s$dlgDownIni <img:settings_jiantou_zuo:220:4:1:1>
inc s$dlgDownIni <text:查看介绍时间刷新{fcolor=103}:40:90>
inc s$dlgDownIni <text:~~~<$time>~~~{fcolor=222}:20:130>
inc s$dlgDownIni <text:点击个人页签试试{fcolor=103}:40:175>
inc s$dlgDownIni <text:特戒引擎服务至上{fcolor=103}:40:275>
inc s$dlgDownIni <img:lc_xiaofei_shuzi_dadao:360:125:1:1:0.7/@行会魔神介绍>
inc s$dlgDownIni <text:介绍{fcolor=103}:375:185:50:1:20>
inc s$dlgDownIni <img:lc_xiaofei_shuzi_changtai:360:220:1:1/@退出行会魔神>
inc s$dlgDownIni <text:退出{fcolor=103}:375:275:50:1:20>

mov s$setPic main_task_geren_02,main_task_geren_01,main_task_hanghui_02,main_task_hanghui_01

;--对话框id 对话框内容(以dlg:分割) 平台类型(1:手机 2:PC) 按钮图片组(未选中1,选中1,未选中2,选中2) 创建或刷新(0:创建 1:刷新)--
addDlg 1 dlg:<$str(s$dlgUpIni)>dlg:<$str(s$dlgDownIni)> 1 <$str(s$setPic)> 0

[@行会魔神介绍]
#say
<text:行会魔神介绍:0:0>
<img:lc_quxiaogenbiao:50:60:1:0.65>

#act
mov s$dlgUpRefresh
inc s$dlgUpRefresh <text:魔神行会页面{fcolor=251}:50:20>
inc s$dlgUpRefresh <img:settings_jiantou_you:0:4:1:1>
inc s$dlgUpRefresh <img:settings_jiantou_zuo:220:4:1:1>
inc s$dlgUpRefresh <text:查看介绍时间刷新{fcolor=103}:40:90>
inc s$dlgUpRefresh <text:~~~<$time>~~~{fcolor=222}:20:130>
inc s$dlgUpRefresh <text:点击个人页签试试{fcolor=103}:40:175>
inc s$dlgUpRefresh <text:特戒引擎服务至上{fcolor=103}:40:275>
inc s$dlgUpRefresh <img:lc_xiaofei_shuzi_dadao:360:125:1:1:0.7/@行会魔神介绍>
inc s$dlgUpRefresh <text:介绍{fcolor=103}:375:185:50:1:20>
inc s$dlgUpRefresh <img:lc_xiaofei_shuzi_changtai:360:220:1:1/@退出行会魔神>
inc s$dlgUpRefresh <text:退出{fcolor=103}:375:275:50:1:20>

addDlg 1 dlg:<$str(s$dlgUpIni)>dlg:<$str(s$dlgUpRefresh)> 1 <$str(s$setPic)> 1

[@退出行会魔神]
#act
delDlg 1


采集玩法

采集

标签:模块示例|采集

模块说明
人物靠近可采集资源时，屏幕中间会出现采集按钮
点击采集按钮，进度条走完可获得采集奖励，采集资源消失（怪物被杀死）
采集过程中，人物移动或被攻击将中断采集

相关配置
可采集资源通过在地图刷新怪物实现
..\Mir200\Envir\MonGen.txt

  • 第18个参数
    • 2-可采集怪(带墓碑效果，采集完有墓碑)
    • 3-可采集怪(无墓碑效果，采集完没有墓碑)

采集奖励通过配置怪物掉落，配合采集时杀死怪物的命令nearKillMon实现
..\Mir200\Envir\MonItems\

特戒引擎脚本示例：

;..\scripts\Mir200\Envir\QuestDiary\采集\采集.txt
[@main]
#if
;检测人物附近有没有可采集物
checkRangeMonCountEX 神龙山庄 高级神物 <$X> <$Y> 3 > 0
#act
mov S$采集怪物名字 高级神物
goto @采集按钮显示
break

#if
;检测人物附近有没有可采集物
checkRangeMonCountEX 神龙山庄 低级神物 <$X> <$Y> 3 > 0
#act
mov S$采集怪物名字 低级神物
goto @采集按钮显示
break
#elseact
goto @采集按钮隐藏

[@采集按钮显示]
#if
check [3007] 0
#act
set [3007] 1
goto @采集中

[@采集按钮隐藏]
#if
check [3007] 1
#act
set [3007] 0
delMainCenterBtn 采集中按钮

[@采集中]
#if
;检测人物体力值是否满足采集消耗
large U80 14
#act
addMainCenterBtn 采集中按钮 2 lc_wajue,lc_caiji_jishi2,5000,采集中 0,-100 可采集 250 32 0,-183 lc_wajue_di <$X>,<$Y>,7,1 采集中,采集进度条走完
#elseact
addMainCenterBtn 采集中按钮 1 lc_wajue 0,-100 可采集 250 32 0,-183 lc_wajue_di 0,0,0,1 体力不足

[@体力不足]
#if
#act
sendTipsMSG 体力不足：15

[@采集进度条走完]
#if
#act
delMainCenterBtn 采集中按钮
;杀死采集资源怪并获取掉落
nearKillMon 3 <$str(S$采集怪物名字)> 1
dec U80 15
sendTipsMSG 采集成功
#call [\采集\采集.txt] @神龙山庄侧边栏
#elseact
sendTipsMSG 采集失败

;QFunction-0.txt的触发器会调用这里
[@采集失败]
#if
check [3007] 1
#act
set [3007] 0
delMainCenterBtn 采集中按钮

;位于采集地图时任务侧边栏的显示
[@神龙山庄侧边栏]
#if
#act
mov U3036 1

#if
#act
mov N3015 0
getRangeMonCount 神龙山庄 90 88 500 N3007 神魔矿工首领
getRangeMonCount 神龙山庄 90 88 500 N3008 神魔骑兵首领
getRangeMonCount 神龙山庄 90 88 500 N3009 神魔刀兵首领
getRangeMonCount 神龙山庄 90 88 500 N3010 神魔力士首领
inc N3015 N3007
inc N3015 N3008
inc N3015 N3009
inc N3015 N3010
getRangeMonCount 神龙山庄 90 88 500 N3011 低级神物
getRangeMonCount 神龙山庄 90 88 500 N3012 高级神物
mov N3016 0
getRangeMonCount 神龙山庄 90 88 500 N3013 魔神半兽人
getRangeMonCount 神龙山庄 90 88 500 N3014 魔神兽人
inc N3016 N3013
inc N3016 N3014

#if
isOnMap 神龙山庄
#act
mov s$sideInfo3
inc s$sideInfo3 <text:当前体力剩余：<$str(U80)>{fcolor=250}:10:0>
inc s$sideInfo3 <text:山庄魔神消耗：30{fcolor=161}:10:40>
inc s$sideInfo3 <text:山庄首领消耗：5{fcolor=161}:10:80>
inc s$sideInfo3 <text:山庄圣物消耗：15{scolor=161}:10:120>
inc s$sideInfo3 <text:魔神剩余数量：<$str(N3016)>{scolor=251}:10:160>
inc s$sideInfo3 <text:首领剩余数量：<$str(N3015)>{scolor=251}:10:200>
inc s$sideInfo3 <text:高级神物数量：<$str(N3012)>{scolor=251}:10:240>
inc s$sideInfo3 <text:低级神物数量：<$str(N3011)>{scolor=161}:10:280>

mov s$sideInfo4
inc s$sideInfo4 <text:当前体力剩余：<$str(U80)>{fcolor=250}:0:0:150:10:16>
inc s$sideInfo4 <text:山庄魔神消耗：30{fcolor=161}:0:30:150:10:16>
inc s$sideInfo4 <text:山庄首领消耗：5{fcolor=161}:0:60:150:10:16>
inc s$sideInfo4 <text:山庄圣物消耗：15{scolor=161}:0:90:150:10:16>
inc s$sideInfo4 <text:魔神剩余数量：<$str(N3016)>{scolor=251}:0:120:150:10:16>
inc s$sideInfo4 <text:首领剩余数量：<$str(N3015)>{scolor=251}:0:150:150:10:16>
inc s$sideInfo4 <text:高级神物数量：<$str(N3012)>{scolor=251}:0:180:150:10:16>
inc s$sideInfo4 <text:低级神物数量：<$str(N3011)>{scolor=161}:0:210:150:10:16>

mov s$setPic main_task_geren_02,main_task_geren_01,main_task_hanghui_02,main_task_hanghui_01

#if
isOnMap 神龙山庄
#act
;手机端处理
addDlg 1 dlg:<$str(s$sideInfo3)>dlg: 1 <$str(s$setPic)> 0
;pc端处理
addDlg 1 dlg:<$str(s$sideInfo4)>dlg: 2 <$str(s$setPic)> 0

;..\Mir200\Envir\Market_Def\QFunction-0.txt
;被法术攻击时触发
[@MagicStruck]
;打断采集进度条，采集失败
#if
isOnMap 神龙山庄
#act
#call [\采集\采集.txt] @采集失败

;被攻击时触发
[@Struck]
;打断采集进度条，采集失败
#if
isOnMap 神龙山庄
#act
#call [\采集\采集.txt] @采集失败

;跑触发
[@run]
;打断采集进度条，采集失败
#if
isOnMap 神龙山庄
#act
#call [\采集\采集.txt] @采集失败

;走触发
[@walk]
;打断采集进度条，采集失败
#if
isOnMap 神龙山庄
#act
#call [\采集\采集.txt] @采集失败


直接击杀玩家周边一定范围内的指定怪物

nearKillMon

直接击杀玩家周边一定范围内的指定怪物

标签:命令定义|nearKillMon

格式
命令名 | 参数1 | 参数2 | 参数3
nearKillMon | 范围 | 怪物名称 | 击杀数量
说明:
  • 参数1
    以玩家为中心点，参数值为半径的圆形区域
  • 参数2
    怪物名称，支持变量
  • 参数3
    杀死怪物的数量（1-255）

脚本示例：

[@范围杀怪]
#act
nearKillMon 10 通天神树 2


OK框装备位

stdmode 124-143 对应装备位 60-83

装备位 60-83

OK框装备格子 将指定装备位的装备显示在OK框
<equipField:装备位序号（60-83）:格子底图:X:Y>

OK框装备格子功能同角色界面装备格子，可以穿脱装备，可以显示装备信息

脚本变量装备名： <$equipField60> - <$equipField83>

穿戴/脱下触发： [@takeon60] - [@takeon83]
[@takeoff60] - [@takeoff83]


屏幕中间位置添加/删除自定义按钮

addMainCenterBtn

屏幕中间位置添加自定义按钮

标签:命令定义|addMainCenterBtn

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8 | 参数9 | 参数10 | 参数11
addMainCenterBtn | 按钮名称 | 按钮类型 | 按钮图片 | 按钮坐标 | 按钮文字 | 文字颜色 | 字号 | 文字坐标 | 文字背景图片名称 | 导航坐标及光圈设置 | 跳转方法
说明:
  • 参数1: 按钮名称
  • 参数2: 按钮类型
    • 1：普通类型
    • 2：loading类型
    • 3：导航类型
  • 参数3: 按钮图片，为loading类型时，loading前后允许使用不同按钮图片
    • 格式：按钮图片,loading图片,loading时间(毫秒),loading开始后的按钮文字
  • 参数4: 按钮坐标
    • 格式：x,y
  • 参数5: 按钮文字
  • 参数6: 字色，颜色编码id[0-255]
  • 参数7: 字号
  • 参数8: 文字坐标
  • 参数9: 文字背景图片名称
  • 参数10: 导航坐标及终点光圈设置，只有类型为3时有用
    • 格式：x,y,光圈的半径,是否隐藏光圈（0：不隐藏，1：隐藏）
  • 参数11: 跳转方法，可多个跳转，用于不同阶段的执行操作， 不加@
    • 参数2=2：类型2的按钮触发3个跳转链接，点击按钮触发第1个指定块，进度条走完触发第2个指定块，离开光圈范围触发第3个指定@块，特别注意参数格式为@1,@2|@3

delMainCenterBtn

删除addMainCenterBrn命令添加的指定按钮

标签:命令定义|delMainCenterBtn

格式
命令名 | 参数1
delMainCenterBtn | 按钮名称
说明:
  • 参数1
    按钮名称

脚本示例：

[@删除按钮]
#act
delMainCenterBtn 点击寻找按钮
delMainCenterBtn 寻路中按钮
delMainCenterBtn 挖掘按钮

特戒引擎脚本示例：

[@数值定义]
#act
MOV S$宝藏地图名 土城
MOV N$宝藏坐标x 80
MOV N$宝藏坐标y 53
goto @判断地图

[@判断地图]
#if
not isOnMap <$str(S$宝藏地图名)>
#ACT
;添加普通可点击按钮
addMainCenterBtn 点击寻找按钮 1 lc_dianjixunzhao 0,-100 点击寻找 151 24 0,-170 lc_ditu_mc_di 0,0,0,0 点击寻找
#elseact
goto @寻路中

[@点击寻找]
#ACT
mapmove <$str(S$宝藏地图名)>
delaygoto 300 @自动寻路
;删除按钮，并添加新的导航类型按钮
delMainCenterBtn 点击寻找按钮
;触发执行方法“寻路中”，到达目标点后执行方法“到达终点”
addMainCenterBtn 寻路中按钮 3 lc_xunluzhizhen 0,-100 寻路中 250 32 0,-183 lc_ditu_mc_di <$str(N$宝藏坐标x)>,<$str(N$宝藏坐标y)>,5,1 寻路中,到达终点

[@自动寻路]
#ACT
autogotoxy 土城 <$str(N$宝藏坐标x)> <$str(N$宝藏坐标y)>

[@寻路中]
#act
delMainCenterBtn 点击寻找按钮
addMainCenterBtn 寻路中按钮 3 lc_xunluzhizhen 0,-100 寻路中 250 32 0,-183 lc_ditu_mc_di <$str(N$宝藏坐标x)>,<$str(N$宝藏坐标y)>,5,1 寻路中,到达终点
autogotoxy 土城 <$str(N$宝藏坐标x)> <$str(N$宝藏坐标y)>

[@到达终点]
#ACT
delMainCenterBtn 寻路中按钮
;添加loading类型按钮，使用多张按钮图片，设置loading前、loading中和loading后的样式。触发时执行“到达终点”，loading完成后执行“进度条走完”，离开光圈执行“离开终点”
addMainCenterBtn 挖掘按钮 2 lc_wajue,lc_caiji_jishi2,5000,挖掘中 0,-100 挖掘宝藏 250 32 0,-183 lc_wajue_di <$str(N$宝藏坐标x)>,<$str(N$宝藏坐标y)>,5,0 到达终点,进度条走完|离开终点

[@进度条走完]
#ACT
sendmsg 6 进度条走完
delMainCenterBtn 挖掘按钮

[@离开终点]
#act
delMainCenterBtn 挖掘按钮
addMainCenterBtn 寻路中按钮 3 lc_xunluzhizhen 0,-100 寻路中 250 32 0,-183 lc_ditu_mc_di <$str(N$宝藏坐标x)>,<$str(N$宝藏坐标y)>,5,1 寻路中,到达终点


装备回收针对不同货币类型,设置回收时获得货币的倍率

setRecMoneyRate

装备回收针对不同货币类型,设置回收时获得货币的倍率

回收物品和单价根据GM编辑工具配置的recycleitem.txt执行

标签:命令定义|setRecMoneyRate

格式
命令名 | 参数1 | 参数2
setRecMoneyRate | 货币类型id | 回收获得倍率
说明:
  • 参数1
    货币类型id
    货币 | id
    $GAMEGLORY | 12
    $GAMEPOINT | 2
    $GAMEGOLD | 0
    $GAMEGIRD | 104
    $CREDITPOINT | 7
    $GAMEDIAMOND | 3
    $GOLDCOUNT | 1
    $B_GAMEGLORY | 13
    $B_GAMEPOINT | 16
    $B_GAMEGOLD | 17
    $B_GAMEGOLD | 18
    $B_CREDITPOINT | 19
    $B_GAMEDIAMOND | 14
    $B_GOLDCOUNT | 15
  • 参数2
    回收货币倍率

脚本示例：

[@GameGold回收倍率]
#ACT
setRecMoneyRate 0 0.8
sendMsg 6 GameGold回收倍率0.8倍

[@GamePoint回收倍率]
#ACT
setRecMoneyRate 2 0.5
sendMsg 6 GamePoint回收倍率0.5倍

[@GameGird回收倍率]
#ACT
setRecMoneyRate 104 2
sendMsg 6 GameGird回收倍率2倍

recycleItem.txt中设置的回收道具及单价：
回收测试1 芙蓉石 1 0 2000 0
回收测试1 百病消 1 2 100 0
回收测试1 麻布 1 104 500 0

回收结果：
百病消：回收单价100 GamePoint，倍率0.5，回收数量10，获得500

芙蓉石：单价2000 GameGold，倍率0.8，回收数量5，获得8000

麻布：单价500 GameGird，倍率2，回收数量100，获得100000


获取指定排行文件的排行对象列表

getRankList

获取指定排行文件的排行对象列表

标签:命令定义|getRankList

格式
命令名 | 参数1 | 参数2 | 参数3
getRankList | 排行文件 | 变量 | 排行类型
说明:
  • 参数1
    排行文件的路径
  • 参数2
    变量，用于保存获取的列表
  • 参数3
    排行类型
    • 1：玩家排行
    • 2：行会排行

脚本示例：

[@获取排行列表]
#act
getRankList ..\test\test\test9.txt s$rankList玩家 1
sendMsg 6 玩家列表：<$str(s$rankList玩家)>

getRankList ..\test\test\行会排名.txt s$rankList行会 2
sendMsg 6 行会列表：<$str(s$rankList行会)>

..\test\test\test9.txt：
[GLOBAL]
;id = 玩家名称 排序属性 其它属性1|其它属性2|.. 序号 排序方式（0升序，1降序）
467601=玩家A 347 玩家A|行会A|347|225|11489 0 0
467604=玩家B 333 玩家B|暂无|333|212|5414 1 0
467603=玩家C 103 玩家C|行会B|103|232|16964 2 0

..\test\test\行会排名.txt：
[GLOBAL]
17902=行会A 347 玩家A|行会A|347|225|11489 0 0
17901=行会B 103 玩家C|行会B|103|232|16964 1 0


设置指定技能的攻击距离

setSkillAttDist

设置指定技能的攻击距离

标签:命令定义|setSkillAttDist

格式
命令名 | 参数1 | 参数2
setSkillAttDist | 技能名称 | 设定距离

说明
  • 参数1: 技能名称
  • 参数2: 设定距离，支持小数，距离1为近身。

特戒引擎脚本示例：

[@main]
#act
mov s$设定距离 1.5
setSkillAttDist 半月弯刀 s$设定距离
sendMsg 6 设置半月弯刀距离为<$str(s$设定距离)>


脚本循环模式

loop

对满足指定条件时，循环执行最大次数
条件不满足,则退出当前if或or循环

标签:命令定义|loop

格式
命令名 | 参数1
loop | 最大循环次数
说明
  • 参数1
    最大循环次数[0,2000]
    0 表示不执行
    支持变量,

    示例1
    mov n0 200
    #if loop n0

    示例2
    mov n0 200
    #or loop n0

特戒引擎脚本示例：

[@main]
#if
#act
mov n1 0
mov n2 1
mov n3 200

#if loop n3
;--if判断条件
small n2 101
#act
inc n1 n2
inc n2 1

#if
#act
sendMsg 6 <$str(n1)>

[@main]
#if
#act
mov n1 0
mov n2 1
mov n3 200

#or loop n3
;--or判断条件
small n2 101
#act
inc n1 n2
inc n2 1

#if
#act
sendMsg 6 <$str(n1)>


装备tips指定位置加入文本：addItemTips

addItemTips

装备tips指定位置加入文本

标签:命令定义|addItemTips

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
addItemTips | 装备位id | 文本内容 | tips段 | 段前或后 | 字色
说明
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见 装备位id说明
    • -1
      当前打开的自定义道具栏中的道具
  • 参数2: 文本内容，-1表示删除当前文本内容
  • 参数3: tips段位置
  • 参数4: 参数3段位置前或后
    • 0 位置前
    • 1 位置后
  • 参数5: 颜色编码id[0-255]

特戒引擎脚本示例：

[@main]
#if
equal <$weapon>
#act
messageBox 请装备武器后测试
#elseSay
<添加武器tips描述/@添加> \ \
<清除武器tips描述/@清除>

[@添加]
#act
mov s$tips 已投保(1/5)
addItemTips 1 s$tips 0 1 254
openSysUi 1 0
messageBox 添加武器tips内容完毕

[@清除]
#act
mov s$tips
addItemTips 1 s$tips 0 1 254
openSysUi 1 0
messageBox 清除武器tips内容完毕

tips段示意
tips段示意 ?


装备图标附加小图标

setAttachIco

装备图标附加小图标

标签:命令定义|setAttachIco

格式
命令名 | 参数1 | 参数2 | 参数3
setAttachIco | 装备位id | 图标资源 | 图标位置
说明
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见 装备位id说明
    • -1
      当前打开的自定义道具栏中的道具
  • 参数2: 附属图标资源id，参见 资源编辑器
    • -1 删除附属图标
  • 参数3: 附属图标在道具图标上的显示位置
    • 1 左上
    • 2 右上
    • 3 左下
    • 4 右下

特戒引擎脚本示例：

[@main]
#if
equal <$weapon>
#act
messageBox 请装备武器后测试
#elseSay
<添加武器附加图标/@添加> \ \
<清除武器附加图标/@清除>

[@添加]
#act
setAttachIco 1 0000114 2
openSysUi 1 0
messageBox 添加武器附加图标完毕

[@清除]
#act
setAttachIco 1 -1 2
openSysUi 1 0
messageBox 清除武器附加图标完毕


返回指定唯一id装备到背包

giveInsItem

返回指定唯一id装备到背包

标签:命令定义|giveInsItem

格式
命令名 | 参数1
giveInsItem | 装备唯一id
说明:
  • 参数1: 装备唯一id
  • 此命令使用前提
    开启以下配置，
    配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
    配置节点 | [tjconfig]
    配置项 | canCtrlDrop=1
    在以下触发器中可获得doDrop的3个参数
    [@scatterBagItems]
    [@dropUseItems]

特戒引擎脚本示例：

使用前提
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | canCtrlDrop=1

以下为QFunction-0.txt中的触发块
文件路径
..\Mir200\Envir\Market_Def\QFunction-0.txt

;--脚本控制身上物品掉落
[@dropUseItems]
#if
;--配置掉落再返回的条件
#act
;--此处为掉落再返回的逻辑
goto @返回道具
#elseAct
;--执行掉落处理
doDrop s0 s1 s2

[@返回道具]
#if
;--背包没满
#act
giveInsItem s1
#elseAct
sendEmails 保险掉落返还 保险掉落返还 s1,


脚本控制角色死亡掉落

doDrop

脚本控制角色死亡掉落

标签:命令定义|doDrop

格式
命令名 | 参数1 | 参数2 | 参数3
doDrop | 装备唯一id | 道具名称 | 掉落数量
说明:
  • 参数1: 掉落物为装备时，此参数为唯一id
  • 参数2: 掉落物道具名称
  • 参数3: 掉落数量
  • 此命令使用前提
    开启以下配置，
    配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
    配置节点 | [tjconfig]
    配置项 | canCtrlDrop=1
    在以下触发器中可获得doDrop的3个参数
    [@scatterBagItems]
    [@dropUseItems]

特戒引擎脚本示例：

使用前提
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | canCtrlDrop=1

以下为QFunction-0.txt中的触发块
文件路径
..\Mir200\Envir\Market_Def\QFunction-0.txt

;--脚本控制背包物品掉落
[@scatterBagItems]
#if
;--配置不执行掉落的条件
#act
;--此处为不执行掉落的逻辑
#elseAct
;--执行掉落处理
doDrop s0 s1 s2

;--脚本控制身上物品掉落
[@dropUseItems]
#if
;--配置掉落再返回的条件
#act
;--此处为掉落再返回的逻辑
goto @返回道具
#elseAct
;--执行掉落处理
doDrop s0 s1 s2

[@返回道具]
#if
;--背包没满
#act
giveInsItem s1
#elseAct
sendEmails 保险掉落返还 保险掉落返还 s1,


主界面指定按钮附近生成气泡对话框

addBtnBubble

主界面指定按钮附近生成气泡对话框

标签:命令定义|addBtnBubble

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
addBtnBubble | 对话框内容 | 按钮id | 锚点位置 | 偏移标 | 平台类型
说明
  • 参数1: 对话框内容，由自定义对话框命令组构成的字符串
    参见以下脚本示例
  • 参数2: 主界面按钮id，目前只有1，代表背包
  • 参数3: 锚点位置
    0 左上
    1 右上
    2 左下
    3 右下
    4 居中
  • 参数4: 相对锚点偏移量
    格式:x,y
  • 参数5: 平台类型
    0 手机
    1 PC

delBtnBubble

删除addBtnBubble生成的气泡对话框

标签:命令定义|delBtnBubble

格式
命令名 | 参数1 | 参数2
delBtnBubble | 按钮id | 平台类型
说明

  • 参数1: 主界面按钮id，目前只有1，代表背包
  • 参数2: 平台类型
    0 手机
    1 PC

特戒引擎脚本示例：

使用前提
请开启配置开关"isUseCustomOKPanel"
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | isUseCustomOkPanel=1

[@main]
#say
<添加气泡/@添加气泡>\ \
<删除气泡/@删除气泡>

[@添加气泡]
#act
mov s$bubble
inc s$bubble <img:tip:-80:-20:1:2>
inc s$bubble <img:guideArrow:30:-60:1:0.8>
inc s$bubble <text:背包已满{fcolor=251}:-50:0>
inc s$bubble <text:清理背包{fcolor=222}:-50:50/@删除气泡>

addBtnBubble <$str(s$bubble)> 1 4 -50,-100 0

[@删除气泡]
#act
openHumBag
delBtnBubble 1 0


根据约定的ID向对应UI添加自定义内容

addUiDlg

根据约定的ID向对应UI添加自定义内容

标签:命令定义|addUiDlg

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
addUiDlg | 内容id | 界面id | 显示内容 | 坐标(x,y) | 平台
说明

  • 参数1: 可以向指定系统界面添加多条内容,以此id区别
  • 参数2: 系统界面id设定
  • 参数3: 需要显示的内容,支持文字、图片、图标、特效
    参见自定义对话框命令
  • 参数4: 自定义内容在指定系统UI中的显示位置
  • 参数5: 平台设定
    • 0 手机
    • 1 PC

delUiDlg

根据约定的ID向对应UI添加自定义内容

标签:命令定义|delUiDlg

格式
命令名 | 参数1 | 参数2 | 参数3
delUiDlg | 内容id | 界面id | 平台
说明

  • 参数1: 可以向指定系统界面添加多条内容,以此id区别
  • 参数2: 系统界面id设定
    界面主id与界面子id","分隔
    对于没有界面子id的ui,可缺省界面子id项
  • 参数3: 平台设定
    • 0 手机
    • 1 PC

脚本示例：

[@main]
<text:添加自定义UI:50:100/@添加自定义UI>
<text:删除自定义UI:50:200/@删除自定义UI>

[@添加自定义UI]

#act
mov s$name1 <text:充值更多优惠，上top166.com{fcolor=251}:0:0>
mov s$name2 <text:反馈更多问题，上top166.com{fcolor=251}:0:0>
mov s$name3 <text:玩游戏，上top166.com{fcolor=251}:0:0>
;充值
addUiDlg 1 13 <$str(s$name1)> 580,-880 0
;BUG建议
addUiDlg 1 7,6 <$str(s$name2)> 409,-605 0
;账号
addUiDlg 1 7,5 <$str(s$name3)> 409,-489 0

;充值
addUiDlg 1 13 <$str(s$name1)> 580,-880 1
;BUG建议
addUiDlg 1 7,6 <$str(s$name2)> 409,-605 1
;账号
addUiDlg 1 7,5 <$str(s$name3)> 409,-489 1

[@删除自定义UI]
#act
delUiDlg 1 13 0
delUiDlg 1 7,5 0
delUiDlg 1 7,6 0

delUiDlg 1 13 1
delUiDlg 1 7,5 1
delUiDlg 1 7,6 1

系统界面id设定

界面主id | 界面子id | 界面名称
1 | 0 | 装备
1 | 状态
2 | 属性
3 | 称号
4 | 技能
5 | 时装
2 | 好友
3 | 行会列表
0 | 行会信息
1 | 行会成员
2 | 行会日志
3 | 创建行会
4 | 摆摊
5 | 排行
6 | 邮件
7 | 1 | 基本设置
2 | 战斗设置
3 | 保护设置
4 | 挂机设置
5 | 账号设置
6 | BUG与建议
8 | 商城
9 | 合成
10 | 背包
11 | 1 | 快捷组队
2 | 创建组队
3 | 组队申请列表
4 | 邀请组队
13 | 充值
14 | 聊天
15 | 小地图
16 | 拍卖行
17 | 技能设置
18 | 仓库

27（主界面） | 1 | 屏幕左上
2 | 屏幕中上
3 | 屏幕右上
4 | 屏幕左中
5 | 屏幕正中
6 | 屏幕右中
7 | 屏幕左下
8 | 屏幕中下
9 | 屏幕右下


打开指定id的系统界面

openSysUi
根据约定的ID打开对应UI

标签:命令定义|openSysUi

格式
命令名 | 参数1 | 参数2
openSysUi | 界面主id | 界面子id
说明
  • 参数1: 参见系统界面id设定系列界面主id
  • 参数2: 参见系统界面id设定系列界面子id
    对于没有界面子id的ui,参数2缺省

脚本示例：

[@main]
#say
<text:请输入要打开的界面:20:10/@@inPutString1>
<text:1角色:20:100>
<text:2好友:20:150>
<text:3行会:20:200>
<text:4摆摊:20:250>
<text:5排行:20:300>
<text:6邮件:20:350>
<text:7设置:20:400>
<text:8商城:20:450>
<text:9合成:20:500>
<text:10背包:200:100>
<text:11组队:200:150>
<text:13充值:200:200>
<text:14聊天:200:250>
<text:15小地图:200:300>
<text:16拍卖行:200:350>
<text:17技能设置:200:400>
<text:18仓库:200:450>
<text:打开的界面5秒后会关闭:20:600>

[@inPutString1]
#act
openSysUi <$str(s1)> 1
delaygoto 5000 @关闭

[@关闭]
#if
#act
closeSystemUi 1
closeSystemUi 2
;closeSystemUi 3
closeSystemUi 4
closeSystemUi 5
closeSystemUi 6
closeSystemUi 7
closeSystemUi 8
closeSystemUi 9
closeSystemUi 10
closeSystemUi 11
closeSystemUi 13
closeSystemUi 14
closeSystemUi 15
closeSystemUi 16
closeSystemUi 17
closeSystemUi 18

系统界面id设定

界面主id | 界面子id | 界面名称
1 | 0 | 装备
1 | 状态
2 | 属性
3 | 称号
4 | 技能
5 | 时装
2 | 好友
3 | 行会列表
0 | 行会信息
1 | 行会成员
2 | 行会日志
3 | 创建行会
4 | 摆摊
5 | 排行
6 | 邮件
7 | 1 | 基本设置
2 | 战斗设置
3 | 保护设置
4 | 挂机设置
5 | 账号设置
6 | BUG与建议
8 | 商城
9 | 合成
10 | 背包
11 | 1 | 快捷组队
2 | 创建组队
3 | 组队申请列表
4 | 邀请组队
13 | 充值
14 | 聊天
15 | 小地图
16 | 拍卖行
17 | 技能设置
18 | 仓库


主界面添加或删除一个消息提示按钮

setMsgBtn

主界面添加或删除一个消息提示按钮

标签:命令定义|setMsgBtn

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
setMsgBtn | 消息按钮id | 添加删除标识 | 按钮图片 | @跳转标签
说明
  • 参数1: 消息按钮id(1,2,3,最多3个)
  • 参数2: 添加删除标识
    • 1 添加按钮
    • 0 删除按钮
  • 参数3: 添加按钮的图片资源
    参见资源管理器
  • 参数4: @跳转标签

特戒引擎脚本示例：

以下示例请配置补丁资源"lc"
即,找到以下配置项,加入 lc
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | patch=aa,cc,lc

[@main]
#act
setMsgBtn 1 1 lc_shuoming @跳转标签1
setMsgBtn 2 1 lc_shuoming @跳转标签2
setMsgBtn 3 1 lc_shuoming @跳转标签3

[@跳转标签1]
#say
<text:你点击了1号消息按钮/@关闭消息1提示>

[@跳转标签2]
#say
<text:你点击了2号消息按钮/@关闭消息2提示>

[@跳转标签3]
#say
<text:你点击了3号消息按钮/@关闭消息3提示>

[@关闭消息1提示]
#act
setMsgBtn 1 0
close

[@关闭消息2提示]
#act
setMsgBtn 2 0
close

[@关闭消息3提示]
#act
setMsgBtn 3 0
close


设置是否外显时装

setShowFashion (仅供假人使用)

设置是否勾选-->角色-->时装分页-->外显时装
此命令用来控制假人是否显示时装

标签:命令定义|setShowFashion

格式
命令名 | 参数1
setShowFashion | 勾选标记
说明:
  • 参数1: 勾选标记，0为不勾选，1为勾选。


设置多排图标单元组列表

<iconGrid:
设置多排图标单元组列表
支持以下自定义对话框图标组件
itemShow
itemShowEx
itemShowNum

标签:命令定义|dlg_iconGrid

格式

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7
iconGrid | 列表内容 | 列表名称,当前选中序号,是否可不选,可不选时是否亮 | X坐标 | Y坐标 | 单元宽高 | 滑动方向,行列数,总高(宽)度,是否可滑动 | 单元间隔

说明
  • 参数1: 列表内容，每个列表由多个单元构成，每个单元包含在“()”当中。
    包含以下三个组件
    • itemIndex
    • itemToggle
    • itemShow
  • 参数2: 列表名称,当前选中序号,是否可不选,都不选时是否亮
    • 列表名称 区别对话框中存在的多个同类列表
    • 当前选中序号 打开对话框时选中的是哪个单元
    • 是否可不选 （0 必须选1个，1 可都不选）
    • 都不选时是否亮 （0 都不选时当前选中序号不亮，1 都不选时当前选中序号亮）
  • 参数3: 列表在自定义对话框中的X坐标
  • 参数4: 列表在自定义对话框中的Y坐标
  • 参数5: 每个单元的宽高
  • 参数6: 滑动方向,行列数,总高(宽)度,是否可滑动
    • 滑动方向 (1 纵向滑动，0 横向滑动)
    • 行列数 (纵向滑动时为列数，横向滑动时为行数)
    • 总高(宽)度 (纵向滑动时为总高度，横向滑动时为总宽度)
    • 是否可滑动 (1 可滑动，0 不可滑动)
  • #say命令中出现 <iconGrid: 命令时，#say中<>模块必须以“\”结尾
    参见以下脚本示例

特戒引擎脚本示例：

使用前提1
请开启配置开关"isUseCustomOKPanel"
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | isUseCustomOkPanel=1
使用前提2
请配置补丁资源"lc",即找到以下配置项,加入 lc
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | patch=aa,bb,lc

[@main]
#if
#act
mov s$内丹列表

inc s$内丹列表 (<itemIndex:1>
inc s$内丹列表 <itemToggle:lc_kaibaoxiang_3:lc_qitianwupindikuang/@选中内丹(1)>
inc s$内丹列表 <itemShow:11:0:34:30:0>)

inc s$内丹列表 (<itemIndex:2>
inc s$内丹列表 <itemToggle:lc_kaibaoxiang_3:lc_qitianwupindikuang/@选中内丹(2)>
inc s$内丹列表 <itemShow:12:0:34:30:0>)

inc s$内丹列表 (<itemIndex:3>
inc s$内丹列表 <itemToggle:lc_kaibaoxiang_3:lc_qitianwupindikuang/@选中内丹(3)>
inc s$内丹列表 <itemShow:13:0:34:30:0>)

inc s$内丹列表 (<itemIndex:4>
inc s$内丹列表 <itemToggle:lc_kaibaoxiang_3:lc_qitianwupindikuang/@选中内丹(4)>
inc s$内丹列表 <itemShow:14:0:34:30:0>)

inc s$内丹列表 (<itemIndex:5>
inc s$内丹列表 <itemToggle:lc_kaibaoxiang_3:lc_qitianwupindikuang/@选中内丹(5)>
inc s$内丹列表 <itemShow:15:0:34:30:0>)

#say
<panelSize:1440:900>\
<iconGrid:<$str(s$内丹列表)>:内丹列表,1,1,1:50:70:120,120:1,4,685,1:20>\

[@选中内丹]
#act
;--状态=0 未选中; 状态=1 未选中
;--print命令在控制台输出文件内容
print 格子<$str(s0)> 状态<$str(s1)>


修改物品的附加属性：tjChgItemValue

tjChgItemValue

修改物品的附加属性

标签:命令定义|tjChgItemValue

格式
命令名 | 参数1 | 参数2
tjChgItemValue | 装备位 | 属性修改公式
说明
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见 装备位id说明
    • -1
      当前打开的自定义道具栏中的道具
      当前拾取道具
  • 参数2: 属性修改公式，支持同时修改多个属性，不同属性间以“,”分隔
    举例
    ;--以下效果为属性1加200，属性15赋值100，属性17减1000
    tjChgItemValue -1 1+200,15=100,17-1000
  • 属性id说明
    属性id | 中文说明 | 英文说明
    1 | 攻击上限 | Dc2
    2 | 魔法上限 | Mc2
    3 | 道术上限 | Sc2
    4 | 物防上限 | Ac2
    5 | 魔防上限 | Mac2
    6 | 幸运
    7 | 诅咒
    8 | 攻速
    9 | 准确
    10 | 敏捷
    11 | 魔法躲避百分比
    12 | 毒物躲避百分比
    13 | 中毒恢复百分比
    14 | 体力恢复百分比
    15 | 魔法恢复百分比
    16 | HP上限
    17 | MP上限
  • 相关命令
    changeItemAddValue
    upgradeItemEx
  • 相关触发器
    [@giveitemX]
    [@giveItemEx]

特戒引擎脚本示例：

[@main]
#say
<itemBox:0:-1:-1:50:50:-1:-1:*:hello>
<修改属性/@修改属性>

[@修改属性]
#if
chkItemBoxNull 0
#act
tjChgItemValue -1 1+1000,2+1000,3=1000
updateBoxItem 0
messageBox 属性修改完毕
#elseAct
messageBox 请先放入装备


装备tips指定位置加入文本，支持换行与多字色

addItemTipsEx

装备tips指定位置加入文本，支持换行与多字色

标签:命令定义|addItemTipsEx

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
addItemTipsEx | 装备位id | 文本内容 | tips段 | 段前或后
说明
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见 装备位id说明
    • -1
      当前打开的自定义道具栏中的道具
      当前获得的道具(比如拾取)
  • 参数2: 文本内容
    参考itemDescList.txt解析规则
    举例
    mov s$tip
    inc s$tip \-
    inc s$tip \246/[隐藏属性]：/249/单件触发
    inc s$tip \246/[隐藏属性]：/229/人物生命值+2%
    inc s$tip \-
    inc s$tip \246/[物品类别]：/254/制式衣服
    inc s$tip \246/[物品品阶]：/250/一阶
    inc s$tip \-
    inc s$tip \253/⌒三千大世界·谁主沉浮路⌒

    显示效果
  • 参数3: tips段位置
  • 参数4: 参数3段位置前或后
    • 0 位置前
    • 1 位置后
  • tips段位置

特戒引擎脚本示例：

[@main]
#if
not equal <$weapon>
#act
mov s$tip
inc s$tip \-
inc s$tip \246/[隐藏属性]：/249/单件触发
inc s$tip \246/[隐藏属性]：/229/人物生命值+2%
inc s$tip \-
inc s$tip \246/[物品类别]：/254/制式衣服
inc s$tip \246/[物品品阶]：/250/一阶
inc s$tip \-
inc s$tip \253/⌒三千大世界·谁主沉浮路⌒
addItemTipsEx 1 s$tip 0 1
messageBox 身上武器tips已变更,请查看tips
#elseAct
messageBox 请穿戴武器后测试


给指定装备添加扩展属性

setItemExValue

给指定装备添加扩展属性

标签:命令定义|setItemExValue

格式
命令名 | 参数1 | 参数2 | 参数3
setItemExValue | 装备位id | 扩展属性id | 字符串值
说明
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见 装备位id说明
    • -1
      当前打开的自定义道具栏中的道具
      当前获得的道具(比如拾取)
  • 参数2: 扩展属性id，[1-10]
  • 参数3: 上述扩展属性id，对应保存的字符串值
  • 该装备赋值的扩展属性,会保存在服务器

特戒引擎脚本示例：

[@main]
#if
equal <$weapon>
#act
messageBox 请穿戴武器后测试
break

#if
#act
mov s0 1|2|3
setItemExValue 1 1 <$str(s0)>

;--;--获取指定装备位,指定扩展属性--
getItemExValue 1 1 s0
print 该装备扩展属性1效果列表--><$str(s0)>

;--;--遍历效果值--
#if array <$str(s0)> s$效果id
#act
;--;--控制台输出3次结果--
print 该装备扩展属性1-->效果<$str(s$效果id)>

;--;--检测是否包含指定效果值--
#if
array_in <$str(s0)> 1
#act
print 该装备包含效果1
#elseAct
print 该装备不包含效果1


获取指定装备扩展属性

getItemExValue

获取指定装备扩展属性

标签:命令定义|getItemExValue

格式
命令名 | 参数1 | 参数2 | 参数3
getItemExValue | 装备位id | 扩展属性id | 返回变量
说明
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见 装备位id说明
    • -1
      当前打开的自定义道具栏中的道具
      当前获得的道具(比如拾取)
  • 参数2: 扩展属性id，[1-10]
  • 参数3: 返回字符串变量

特戒引擎脚本示例：

[@main]
#if
equal <$weapon>
#act
messageBox 请穿戴武器后测试
break

#if
#act
mov s0 1|2|3
setItemExValue 1 1 <$str(s0)>

;--获取指定装备位,指定扩展属性--
getItemExValue 1 1 s0
print 该装备扩展属性1效果列表--><$str(s0)>

;--遍历效果值--
#if array <$str(s0)> s$效果id
#act
;--控制台输出3次结果--
print 该装备扩展属性1-->效果<$str(s$效果id)>

;--检测是否包含指定效果值--
#if
array_in <$str(s0)> 1
#act
print 该装备包含效果1
#elseAct
print 该装备不包含效果1


游戏加载时文字信息展示

loadingTxt

游戏加载时文字信息展示

必须配置在以下位置
..\Mir200\Envir\MapQuest_Def\QManage.txt
[@Login]

标签:命令定义|loadingTxt

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7
loadingTxt | 文本内容 | 文本颜色 | x坐标 | y坐标 | 文本宽度 | 对齐方式 | 字号
说明
  • 参数1: 文本内容，不同颜色字以","分隔
    举例
    文字1,文字2,文字3
  • 参数2: 文本颜色,多颜色以","分隔
    举例
    颜色1,颜色2,颜色3
  • 参数3: x坐标(锚点为文本框中心点,00点为加载条中心点)
  • 参数4: y坐标(锚点为文本框中心点,00点为加载条中心点)
  • 参数5: 文本宽度
  • 参数6: 对齐方式
    • 0 左对齐
    • 1 居中对齐
    • 2 右对齐
    • 对齐方式缺省时,为左对齐
  • 参数7: 文本块中文字字号，缺省为20

特戒引擎脚本示例：

;..\Mir200\Envir\MapQuest_Def\QManage.txt

[@Login]
#act
loadingTxt 添加官方QQ群:,463853799,领取福利礼包 254,253,254 0 40 1000 1 30


获取指定角色的模型信息

playUser

获取指定角色的模型信息，支持跨服
该命令与 playModel 或 playModelEx 组合使用

标签:命令定义|playUser

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8
playUser | 角色名称 | 所在服务器 | 返回模型id变量 | 返回性别id变量 | 返回武器id变量 | 返回斗笠id变量 | 返回翅膀id变量 | 跳转标签
说明
  • 参数1: 要获取模型信息的角色名称
  • 参数2: 角色所在服务器
  • 参数3: 返回模型id变量
  • 参数4: 返回性别id变量
  • 参数5: 返回武器id变量
  • 参数6: 返回斗笠id变量
  • 参数7: 返回翅膀id变量
  • 参数8: 跳转标签,返回值在跳转标签@块中被赋值
  • 对于翅膀道具，身上装备位请保留唯一位置给翅膀。即不支持多装备位同时放置翅膀。
  • 跨服玩家信息获取，会有2分钟的信息时差。
  • 更多用法，参见 跨服排行榜

特戒引擎脚本示例：

[@main]
#act
playUser <$userName> <$server> s$模型id s$性别 s$武器id s$斗笠id s$翅膀id @getUserInfo

[@getUserInfo]
#say
<playModel:<$str(s$模型id)>:-150:150:8:1.3,5:<$str(s$性别)>:<$str(s$武器id)>:<$str(s$斗笠id)>:<$str(s$翅膀id)>:0>
<playModelEx:<$str(s$模型id)>:200:150:8:1.3,5:<$str(s$性别)>:<$str(s$武器id)>:<$str(s$斗笠id)>:<$str(s$翅膀id)>:0>


查看玩家信息面板

viewPlayerEx

查看玩家信息面板

标签:命令定义|viewPlayerEx

格式
命令名 | 参数1 | 参数2
viewPlayerEx | 角色名称 | 服务器id
说明
  • 参数1: 待查看信息的角色名称
  • 参数2: 角色所在服务器信息

特戒引擎脚本示例：

[@main]
#act
viewPlayerEx <$userName> <$server>


自定义技能图标

【配置文件】

新建配置文件：customSkillIcon.txt
路径： \Mir200\Envir\customSkillIcon.txt

未配置自定义图标的技能，使用默认技能图标

配置文件格式：
;技能名称 图标名称（支持使用补丁,下毒术，群体下毒术需配置2个技能图标）

神之开天 LeiBaoTianZhu
下毒术 LeLingLeiFa,LeiBaoTianZhu


在客户端增加BUFF图标显示

setClientBuff

游戏窗口左上角添加buff图标

标签:命令定义|setClientBuff

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
setClientBuff | 无效参数 | buffId | 图标资源 | 显示时长 | tips文字
说明
  • 参数1: 无效参数，填写-1
  • 参数2: buffId
  • 参数3: 图标资源，参见 资源编辑器
  • 参数4: 显示时长，会有倒计时，单元秒；-1表示永久，不再出现倒计时
  • 参数5: tips文字
    • “\”表示换行
    • “\颜色编码id/”表示本行颜色，首行为“颜色编码id/”

特戒引擎脚本示例：

[@main]
#act
openMerchantBigDlg ok_di 4 0 0 1 0 0
#say
<加buff图标1/@加buff1>\ \
<加buff图标2/@加buff2>\ \
<删buff图标1/@删buff1>\ \
<删buff图标2/@删buff2>\ \

[@加buff1]
#act
setClientBuff -1 1 0000025 -1 254/[隐藏属性]：\70/单件触发

[@加buff2]
#act
setClientBuff -1 2 0000026 20 buff2\文字备注

[@删buff1]
#act
closeClientBuff 1

[@删buff2]
#act
closeClientBuff 2


Merchant.txt详解

MerChant.txt 支持npc变色设定

字段1 | 字段2 | 字段3 | 字段4 | 字段5 | 字段6 | 字段7 | 字段8 | 字段9 | 字段10 | 字段11 | 字段12
脚本名称 | 地图名称 | X坐标 | Y坐标 | NPC名称 | 标志 | 形象 | 是否属于沙巴克 | 是否允许移动 | 移动间隔 | 变色模式 | 变色间隔(毫秒)|颜色编码,颜色编码...
已有 | 已有 | 已有 | 已有 | 已有 | 无用 | 已有 | 无用 | 无用 | 无用 | 字段11 | 字段12

新加字段11

变色模式 = 3 npc名字变色

新加字段12

变色间隔毫秒|颜色编码,颜色编码...

举例

土城\1加群礼包 3 106.06 66.14 〈·公众号礼包·〉 0 600375 0 0 0 3 1000|254,250

土城\1加群礼包2 3 106.06 66.14 〈·公众号礼包2·〉 0 600375 0 0 0 3 0|254


合服触发

新增全局触发器 合服触发

触发器所在文件

RobotManage.txt

[@serverMerge]

#act

mov a$合服标记 <$time>发生了一次合服事件！


获取指定地图、指定怪物的复活时间

[新增命令] 获取指定地图 指定怪物的复活时间

getReviveTime 地图编号 怪物名称 返回变量

返回变量: 自定义字符串，单位秒

多个怪的复活时间以"|"分隔

举例

12340000|254645600

复活时间从怪物尸体消失开始

怪物模型存在时,复活时间返回0

示例脚本

[@main]

#act

getReviveTime 3 新手Boss s$新手Boss复活时间

sendMsg 6 新手Boss复活时间:<$str(s$新手Boss复活时间)>


自定义对话框中设置一个文字输入框

<input:

标签:命令定义|dlg_input

定义
自定义对话框中设置一个文字输入框
参数之间以":"为分割符

使用前提
配置Tejieconfig.txt
开启对应开关
  • 文件位置
    ..\Mir200\Tejieconfig\Tejieconfig.txt
  • 对应开关
    [tjconfig]
    ;(=1时开启，=0时关闭，缺省时关闭)
    isUseCustomOKPanel=1

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8 | 参数9 | 参数10 | 参数11
input | 编号 | 类型 | 提醒文本 | 提醒文本字色 | 宽度 | 高度 | 输入文本字色 | 字号 | 字数限制 | X坐标 | Y坐标
说明
  • 参数1 : 输入框ID 存在多个输入框时,用于作出区别
  • 参数2 : 输入类型 0任意文本 1数字 2密码
  • 参数3 : 输入框空着时提醒文本
  • 参数4 : 空着时提醒文本颜色
  • 参数5 : 输入框宽度
  • 参数6 : 输入框高度
  • 参数7 : 输入文本颜色
  • 参数8 : 文本字号
  • 参数9 : 字数限制(默认0不限制)
  • 参数10 : x坐标
  • 参数11 : y坐标
  • 固定[@submitInput]为提交触发器
  • 固定[@endInputX]为结束输入触发器,X代表输入框id
  • 上述触发器触发时,
    输入框中的内容将保存在对应序号的s变量

脚本示例：

[@main]
#act
;输入框显示值赋初值
mov s$显示值 1000
goto @界面显示

[@界面显示]
#say
<img:huatiao01:70:40:1:1>
<input:1:0:<$str(s$显示值)>:241:220:40:28:30:0:80:50/@endInput1>
<text:加一:0:50/@加1按钮>
<text:减一:310:50/@减1按钮>

<text:提交:150:500/@submitInput>

[@endInput1]
;触发编辑结束,如未写内容,会返回一个空字符
#if
not equal s1
#act
mov s$显示值 <$str(s1)>
sendMsg 6 编辑后显示值<$str(s$显示值)>

[@submitInput]
;触发提交时,如input未编辑过,会返回一个空格
#if
equal " " <$str(s1)>
#act
sendMsg 6 输入的是<$str(s$显示值)>
#elseAct
sendMsg 6 输入的是<$str(s1)>

[@加1按钮]
#if
#act
mov n$显示值数字化 <$str(s$显示值)>
inc n$显示值数字化 1
mov s$显示值 <$str(n$显示值数字化)>
goto @界面显示

[@减1按钮]
#if
#act
mov n$显示值数字化 <$str(s$显示值)>
inc n$显示值数字化 -1
mov s$显示值 <$str(n$显示值数字化)>
goto @界面显示


放大装备位武器或翅膀外显

zoom

缩放指定装备位的武器或翅膀模型外显

标签:命令定义>zoom>缩放

格式
命令名 | 参数1 | 参数2
zoom | 装备位id | 缩放倍率
说明
  • 参数1: 装备位id
    • 0，装备位衣服上的翅膀
    • 1，装备位武器
    • 17，装备位时装衣服上的翅膀
    • 18，装备位武器

参数2: 缩放倍率基准为100，表示1比1，101表示放大1%，99表示缩小1%

相关命令
zoomEx

特戒引擎脚本示例：

[@main]
#if
equal u$初次打开放大 0
#act
mov u$初次打开放大 1
mov u$武器基数 100
mov u$翅膀基数 100
mov u$装扮武器基数 100
mov u$装扮翅膀基数 100

#if
#say
<放大武器/@放大武器>< ><缩小武器/@缩小武器>< ><当前系数:<$str(u$武器基数)>>\ \
<放大翅膀/@放大翅膀>< ><缩小翅膀/@缩小翅膀>< ><当前系数:<$str(u$翅膀基数)>>\ \
<------------------------------------->\ \
<显示装扮武器/@显示装扮武器>< ><取消装扮武器/@取消装扮武器>\ \
<显示装扮翅膀/@显示装扮翅膀>< ><取消装扮翅膀/@取消装扮翅膀>\ \
<------------------------------------->\ \
<放大装扮武器/@放大装扮武器>< ><缩小装扮武器/@缩小装扮武器>< ><当前系数:<$str(u$装扮武器基数)>>\ \
<放大装扮翅膀/@放大装扮翅膀>< ><缩小装扮翅膀/@缩小装扮翅膀>< ><当前系数:<$str(u$装扮翅膀基数)>>\ \

[@显示装扮武器]
#act
setPlayerModel <$userName> 1 20037

[@取消装扮武器]
#act
setPlayerModel <$userName> 1 -1

[@显示装扮翅膀]
#act
setPlayerModel <$userName> 2 20089 2038

[@取消装扮翅膀]
#act
setPlayerModel <$userName> 2 -1 -1

[@放大武器]
#act
goto @取消装扮武器
inc u$武器基数 10
sendMsg 6 武器<$str(u$武器基数)>
zoom 1 u$武器基数
goto @main

[@缩小武器]
#act
goto @取消装扮武器
dec u$武器基数 10
sendMsg 6 武器<$str(u$武器基数)>
zoom 1 u$武器基数
goto @main

[@放大翅膀]
#act
goto @取消装扮翅膀
inc u$翅膀基数 10
sendMsg 6 翅膀<$str(u$翅膀基数)>
zoom 0 u$翅膀基数
goto @main

[@缩小翅膀]
#act
goto @取消装扮翅膀
dec u$翅膀基数 10
sendMsg 6 翅膀<$str(u$翅膀基数)>
zoom 0 u$翅膀基数
goto @main

[@放大装扮武器]
#act
goto @显示装扮武器
inc u$装扮武器基数 10
sendMsg 6 装扮武器<$str(u$装扮武器基数)>
zoomEx 1 u$装扮武器基数
goto @main

[@缩小装扮武器]
#act
goto @显示装扮武器
dec u$装扮武器基数 10
sendMsg 6 装扮武器<$str(u$装扮武器基数)>
zoomEx 1 u$装扮武器基数
goto @main

[@放大装扮翅膀]
#act
goto @显示装扮翅膀
inc u$装扮翅膀基数 10
sendMsg 6 装扮翅膀<$str(u$装扮翅膀基数)>
zoomEx 2 u$装扮翅膀基数
goto @main

[@缩小装扮翅膀]
#act
goto @显示装扮翅膀
dec u$装扮翅膀基数 10
sendMsg 6 装扮翅膀<$str(u$装扮翅膀基数)>
zoomEx 2 u$装扮翅膀基数
goto @main


放大SetPlayerModel命令设置的武器或翅膀外显

zoomEx

缩放setPlayerModel命令设置的武器或翅膀模型外显

标签:命令定义>zoomEx>缩放

格式
命令名 | 参数1 | 参数2
zoom | 类型id | 缩放倍率
说明
  • 参数1: 类型id
    • 1，setPlayerModel命令设置的武器
    • 2，setPlayerModel命令设置的翅膀

参数2: 缩放倍率基准为100，表示1比1，101表示放大1%，99表示缩小1%

相关命令
zoom
setPlayerModel

特戒引擎脚本示例：

[@main]
#if
equal u$初次打开放大 0
#act
mov u$初次打开放大 1
mov u$武器基数 100
mov u$翅膀基数 100
mov u$装扮武器基数 100
mov u$装扮翅膀基数 100

#if
#say
<放大武器/@放大武器>< ><缩小武器/@缩小武器>< ><当前系数:<$str(u$武器基数)>>\ \
<放大翅膀/@放大翅膀>< ><缩小翅膀/@缩小翅膀>< ><当前系数:<$str(u$翅膀基数)>>\ \
<------------------------------------->\ \
<显示装扮武器/@显示装扮武器>< ><取消装扮武器/@取消装扮武器>\ \
<显示装扮翅膀/@显示装扮翅膀>< ><取消装扮翅膀/@取消装扮翅膀>\ \
<------------------------------------->\ \
<放大装扮武器/@放大装扮武器>< ><缩小装扮武器/@缩小装扮武器>< ><当前系数:<$str(u$装扮武器基数)>>\ \
<放大装扮翅膀/@放大装扮翅膀>< ><缩小装扮翅膀/@缩小装扮翅膀>< ><当前系数:<$str(u$装扮翅膀基数)>>\ \

[@显示装扮武器]
#act
setPlayerModel <$userName> 1 20037

[@取消装扮武器]
#act
setPlayerModel <$userName> 1 -1

[@显示装扮翅膀]
#act
setPlayerModel <$userName> 2 20089 2038

[@取消装扮翅膀]
#act
setPlayerModel <$userName> 2 -1 -1

[@放大武器]
#act
goto @取消装扮武器
inc u$武器基数 10
sendMsg 6 武器<$str(u$武器基数)>
zoom 1 u$武器基数
goto @main

[@缩小武器]
#act
goto @取消装扮武器
dec u$武器基数 10
sendMsg 6 武器<$str(u$武器基数)>
zoom 1 u$武器基数
goto @main

[@放大翅膀]
#act
goto @取消装扮翅膀
inc u$翅膀基数 10
sendMsg 6 翅膀<$str(u$翅膀基数)>
zoom 0 u$翅膀基数
goto @main

[@缩小翅膀]
#act
goto @取消装扮翅膀
dec u$翅膀基数 10
sendMsg 6 翅膀<$str(u$翅膀基数)>
zoom 0 u$翅膀基数
goto @main

[@放大装扮武器]
#act
goto @显示装扮武器
inc u$装扮武器基数 10
sendMsg 6 装扮武器<$str(u$装扮武器基数)>
zoomEx 1 u$装扮武器基数
goto @main

[@缩小装扮武器]
#act
goto @显示装扮武器
dec u$装扮武器基数 10
sendMsg 6 装扮武器<$str(u$装扮武器基数)>
zoomEx 1 u$装扮武器基数
goto @main

[@放大装扮翅膀]
#act
goto @显示装扮翅膀
inc u$装扮翅膀基数 10
sendMsg 6 装扮翅膀<$str(u$装扮翅膀基数)>
zoomEx 2 u$装扮翅膀基数
goto @main

[@缩小装扮翅膀]
#act
goto @显示装扮翅膀
dec u$装扮翅膀基数 10
sendMsg 6 装扮翅膀<$str(u$装扮翅膀基数)>
zoomEx 2 u$装扮翅膀基数
goto @main


道具图标右下角添加自定义文本

在道具图标右下角添加自定义文本的配置文件：equipStage.txt

文件路径：..\Mir200\Envir\equipStage.txt

;物品Name 图标右下角文本内容 文字颜色

井月刀 1阶 151

饮血剑 11阶 224

無极道杖 99阶 249


面巾

stditems配置 stdmode=50

装备位号 26

装备触发 [@takeon26]
[@takeoff26]

对应脚本变量 <$FTOWER>

tejieconfig配置装备框是否显示 ;是否开启面巾装备位
openequip26=1

tejieconfig配置装备框显示位置 （必配，位置可自调）
[EquipmenField]

26 90,20 Beibao_mianjin

[EquipmenFieldPC]

26 100,-167 Beibao_mianjin


设置自动拾取范围

测试用例

说明：

测试道具需在挂机拾取列表中

[@main]
<扔/@扔>\ \
<设置拾取范围2/@范围2>\ \
<设置拾取范围0/@范围0>\ \

[@扔]
#act
throwItem <$map> <$x> <$y> 2 黑铁 2|10|30 1 1

[@范围2]
#act
setPickupRange 2
sendMsg 6 设定拾取范围为2

[@范围0]
#act
setPickupRange 0
sendMsg 6 设定拾取范围为0


重置宝宝属性

重置宝宝属性的命令resetSlaveAbility
功能：重置宝宝属性，例如：宝宝基础攻击为100，命令设置攻击为200，则宝宝攻击重置后为200（命令changeSlaveAbility，得到的结果为300）
resetSlaveAbility 参数1 参数值 宝宝名（为空表示所有宝宝）
参数1表示值：
0: 当前血量； 1: 最大血量； 2:当前魔法值； 3:最大魔法值； 4:最小防御力； 5:最大防御力； 6:最小物理攻击力； 7:最大物理攻击力； 8:魔法攻击力； 9:道术； 11:移动速度 12:属性有效时间（分钟，空或0表示不检测时间）
13：抗反伤值，每次受伤反伤伤害反弹都会减少对应参数值
// 重算宝宝属性后不会立即重算宝宝属性，必须调用本命令
RecalcSlaveAbility 宝宝名（为空表示所有宝宝）

新增gm命令

summInfo 宠物名字 s$宠物信息


判断是否是PC端

[新增命令]

是否是pc端 isPc

用例

#if

isPc

#act

sendMsg 6 是pc端

#elseAct

sendMsg 6 非pc端


通用穿戴/脱下触发器

QF增加触发器

穿戴任意物品触发： [@takeon]

脱下任意物品触发：[@takeoff]

相关变量：

当前操作装备位置: <$CurItemPos>
当前操作装备数据库名: <$CurItemName>
当前操作装备改名后名称: <$G_CurItemName>
当前操作装备唯一ID: <$CurItemMakeIndex>

示例：

[@takeon]
#ACT
SENDMSG 6 人物穿装备，位置<$CurItemPos>，物品<$CurItemName>(<$G_CurItemName>)，ID<$CurItemMakeIndex>
[@TakeOff]
#ACT
SENDMSG 6 人物脱装备，位置<$CurItemPos>，物品<$CurItemName>(<$G_CurItemName>)，ID<$CurItemMakeIndex>


跨服功能：

1.后台管理工具-运营管理-跨服服务器管理添加跨服服务器

跨服区名称：跨服服务器标识，方便查看

区内拥有的服务器：填写服务器ID

通区跨服：【gm平台】后台管理工具-->运营管理-->游戏版本列表-->通区跨服设置|通区跨服

2.跨服设置

跨服服务器的名字变量：目前支持1-10 <$CrossServerName1>...<$CrossServerName10>
地图参数：CrossServerMap（0,1,0,0,0）
;是否可以交易
;是否可以扔东西
;死亡是否掉落
;是否可以摆摊
;是否可以跨服组队（退出跨服地图自动离队）

跨服地图配置：mapinfo.txt
[跨服地图|sxb_0607_67 跨服地图] CrossServerMap(0,1,0,0,0)

示例：

[@main]

#act
mov s$跨服一服
mov s$跨服二服
mov s$跨服三服
mov s$跨服四服

#if
not equal <$CrossServerName1>
#act
mov s$跨服一服 <$CrossServerName1>{FCOLOR=250}
#elseact
mov s$跨服一服 未连接到次元裂缝{FCOLOR=146}

#if
not equal <$CrossServerName2>
#act
mov s$跨服二服 <$CrossServerName2>{FCOLOR=250}
#elseact
mov s$跨服二服 未连接到次元裂缝{FCOLOR=146}

#if
not equal <$CrossServerName3>
#act
mov s$跨服三服 <$CrossServerName3>{FCOLOR=250}
#elseact
mov s$跨服三服 未连接到次元裂缝{FCOLOR=146}

#if
not equal <$CrossServerName4>
#act
mov s$跨服四服 <$CrossServerName4>{FCOLOR=250}
#elseact
mov s$跨服四服 未连接到次元裂缝{FCOLOR=146}

#if
#act
OPENMERCHANTBIGDLG shj2_map 5 0 0 1 0 0

#say
\ \

<text:<$str(s$跨服一服)>:365:313> \ \

<text:<$str(s$跨服二服)>:365:751> \ \

<text:<$str(s$跨服三服)>:1285:313> \ \

<text:<$str(s$跨服四服)>:1285:751> \ \

<text:进入跨服地图:786:608/@进入跨服地图> \ \

<OKPanelPlayEffect:guangzhu1253:-1:716:363:1>

[@进入跨服地图]

#act
mapmove 跨服地图

3.检测是否是本服玩家命令 isInServer

检测是否是本服玩家
对于跨服地图,
主服玩家会判定为本服玩家
从服玩家会判定为非本服玩家

#if
isInServer
#act
sendMsg 6 在当前服务器
#elseAct
sendMsg 6 不在当前服务

跨服相关逻辑处理时
如果需要存盘,要检测是否本服玩家
比如排行榜
避免数据跨服混乱

4.玩家角色是否在跨服地图：isOnCrossServerMap

#if

isOnCrossServerMap

#act

sendmsg 6 在跨服地图

#elseact

sendmsg 6 不在跨服地图


跨服攻城

相关配置

地图配置说明

标签:|跨服攻城战地图|城堡地图

说明

  • 在文件 ..\Envir\MapInfo.txt 中将城堡地图配置为跨服地图(地图属性CrossServerMap(0,0,0,0,0))
  • 打开该城堡对应的配置文件，将[Defense]下的CastlePlaceMap配置好，例如CastlePlaceMap=0151（0151为该地图的地图id）
    • 0号城堡的配置文件 ..\Mir200\Castle\0\SabukW.txt
    • 1号城堡的配置文件 ..\Mir200\Castle\1\SabukW.txt
    • 2号城堡的配置文件 ..\Mir200\Castle\2\SabukW.txt
  • 将该城堡设为跨服城堡，方法为编辑该城堡对应的配置文件
    [Setup]
    ;是否跨服攻城战（0不是，1是，默认值0）
    crossServer=1

城堡号配置说明

标签:|城堡号

说明

  • 目前支持0、1、2号共3个城堡
  • 每个城堡使用单独的配置文件
    • 0号城堡的配置文件 ..\Mir200\Castle\0\SabukW.txt
    • 1号城堡的配置文件 ..\Mir200\Castle\1\SabukW.txt
    • 2号城堡的配置文件 ..\Mir200\Castle\2\SabukW.txt

时间配置说明

标签:|跨服攻城战时间|攻城战时间

说明

  • 支持使用工具配置本服所有城堡统一的相关时间
    • 配置路径TejiePlatform.exe>选项>参数设置>时间控制
  • 支持使用配置文件给各个城堡配置不同的相关时间（默认值为工具中的统一配置）
    • 每个城堡使用单独的配置文件
      • 0号城堡的配置文件 ..\Mir200\Castle\0\SabukW.txt
      • 1号城堡的配置文件 ..\Mir200\Castle\1\SabukW.txt
      • 2号城堡的配置文件 ..\Mir200\Castle\2\SabukW.txt
    • 配置项，[Setup]下
      申请攻城天数（单位天） | 暂不支持单独配置
      攻城时长（单位天） | castleWarTime
      攻城开始时间（每天整点，24小时制） | startCastleWarTime
      禁止占领时间（单位分钟） | getCastleTime
      攻城结束提示（单位分钟） | 暂不支持单独配置

相关变量

<$guildName>

获取人物所属行会名称

标签:变量定义|<$guildName>

格式
变量名
<$guildName>

说明

  • 位于非跨服地图时，返回行会名称
  • 位于跨服地图时，主服角色返回行会名称，非主服角色返回行会名称_服务器ID
    • 同一跨服服务器组中，服务器ID最小的服务器为主服

<$ownerguild>系列

返回占领0号城堡的行会名称 | <$ownerguild>
返回占领0号城堡的行会名称 | <$ownerguild_0>
返回占领1号城堡的行会名称 | <$ownerguild_1>
返回占领2号城堡的行会名称 | <$ownerguild_2>

<$lord>系列

返回0号城堡城主的名字 | <$lord>
返回0号城堡城主的名字 | <$lord_0>
返回1号城堡城主的名字 | <$lord_1>
返回2号城堡城主的名字 | <$lord_2>


对话框播放指定玩家模型

<player:x:y:玩家昵称:缩放系数>

参数1: 对话框中x偏移

参数2: 对话框中y偏移

参数3: 玩家昵称

参数4: 缩放系数，支持小数1.1或0.9


定义itemBox显示资源

对话框命令 itemBoxRes 定义itemBox显示资源

<itemBoxRes:

标签:命令定义|dlg_itemBoxRes
标签:>dlg_itemBoxRes

定义
设置指定id自定义道具栏的图片资源

格式
命令名 | 参数1 | 参数2
itemBoxRes | 道具栏编号 | 图片资源名称

说明

  • 参数1: 道具栏编号，非负整数，对话框中有多个itemBox时，以示区别
  • 参数2: 图片资源名称，指定编号道具栏要使用的图片资源

示例：

[@main]

#if

#say

<itemBoxRes:0:35>

<ITEMBOX:0:2:117:300:200:76:76:*>\ \


套装属性克隆

;-----------------------------------------变量

;指定ok框中物品的套装编号
;<$BOXITEM[X].suitID>

;-----------------------------------------命令

;获取指定物品的套装ID
;getSuitID 装备位(-1为OK框) 套装ID变量

;克隆指定道具的套装属性
;cloneSuitId 装备位(-1为OK框) 套装编号(-1为删除克隆套装及描述信息) 克隆的套装道具名称 套装描述(缺省则使用克隆装备的套装描述)

;获取指定套装的克隆信息
;getCloneSuitInfo 装备位(-1为OK框) 克隆的套装ID(没有克隆返回空) 克隆的道具名称变量(没有克隆返回空)

[@main]

#if

#say

<text:要克隆套装属性的装备:70:50>

<ITEMBOX:0:2:117:100:100:76:76:*>\

<text:被克隆套装属性的装备:520:50>

<ITEMBOX:1:2:117:550:100:76:76:*>\

\ \ \ \ \ \ \ \ \ \ \
<text:克隆套装描述及属性:250:250/@克隆套装描述及属性> \ \

<text:删除克隆套装属性及描述:250:350/@删除克隆套装属性及描述> \ \

<text:要拆分的装备:70:500>

<ITEMBOX:2:2:117:100:550:76:76:*>\

<text:拆分:120:660/@拆分> \ \

[@拆分]

#act

SetUpgradeItem 2

getCloneSuitInfo -1 s$克隆的套装ID s$克隆的道具名称
cloneSuitId -1 -1

give <$str(s$克隆的道具名称)> 1

ReturnBoxItem 2

[@克隆套装描述及属性]

#act

SetUpgradeItem 0
;克隆指定道具的套装属性
;cloneSuitId 装备位（-1为OK框） n$套装编号（-1为删除克隆套装信息） 克隆的套装道具名称 套装描述（缺省则使用克隆装备的套装描述）
cloneSuitId -1 <$BOXITEM[1].GroupID> <$BOXITEM[1].NAME>

[@删除克隆套装属性及描述]

#act
SetUpgradeItem 0
cloneSuitId -1 -1


通用触发器

新增触发器,将原有分组,统一返回变量

触发器 | 触发事件 | 返回值0
[@stdModeFunc] | 点击任意stdModeFuncX触发 | 返回点击id
[@buttonClick] | 点击任意buttonClickX触发 | 返回点击id
[@takeOn] | 点击任意takeOnX触发 | 返回点击id
[@takeOff] | 点击任意takeOffX触发 | 返回点击id
[@task] | 点击任意taskX触发 | 返回点击id
[@itemBagButtonClick] | 点击任意itemBagButtonClickX触发 | 返回点击id
[@storageOpenFail] | 点击任意storageOpenFail触发 | 返回点击id
[@bagOpenFail] | 点击任意bagOpenFailX触发 | 返回点击id
[@pMove] | 点击任意pMoveX触发 | 返回点击id
[@groupItemOn] | 点击任意groupItemOnX触发 | 返回点击id
[@magSelfFunc] | 点击任意magSelfFuncX触发 | 返回点击id
[@canInputItemList] | 点击任意canInputItemListX触发 | 返回点击id
[@canPutoffItemList] | 点击任意canPutoffItemListX触发 | 返回点击id


@OnKillMob

功能: 杀死怪物时触发
说明: 对应地图参数中需要加入ONKILLMON才可生效!

[@OnKillMob]
#IF
CheckKillMonName 白野猪
#SAY
你杀死一头白野猪!


宝宝立即叛变

功能: 指定宝宝立即叛变的脚本命令
格式: GetCallMob 宝宝名字

#act
GETCALLMOB 神兽
#say
你的神兽已经叛变


不允许宝石升级

功能: 当前宝石升级装备失败
格式: SetUpgradeFail
说明: 此命令只能在QFunction中的@ItemUpgrade下执行.

[@ItemUpgrade]
#IF
CheckGold 5000
#ACT
Take 金币 5000
#ELSESAY
升级装备需要5000金币.
#ELSEACT
SetUpgradeFail
Break


查看动态地图链接点

说明: 查看使用AddMapRoute设置的动态链接点.
格式: GetMapRouteInfo 链接标示 查看方式(0-1) 坐标X 坐标Y

例子: 查看地图链接点
[@ViewRoute]
#IF
#ACT
;查看链接坐标,参数2等于0查看连接地图,等于1查看待连接地图.
GetMapRouteInfo 1 0 A0 G0 G1
GetMapRouteInfo 1 1 A1 G2 G3
SendMsg 5 [地图<$STR(A0)>坐标:<$STR(G0)>:<$STR(G1)>]->[地图<$STR(A1)>坐标:<$STR(G2)>:<$STR(G3)>]


拆解物品

功能: 可简单实现物品拆解,升级,回收等功能.
格式: OpenItemBoxEx 标号(1-1000) 是否回收(0,1) 提示信息
说明: 标号代表要执行的脚本编号,提示信息是登录器显示的简单提示.
放入的物品名字保存在人物的S0变量中.
放入的物品的持久放在人物的N0变量中.
注意: 脚本文件头必须加入@ReclaimItem
N0中保存的持久1000=游戏中1点持久,20000=20点持久.

相关检测脚本命令:EQUAL?CheckTextList
例如:实现装备拆解功能.

(@ReclaimItem )
[@main]
是否要把圣战戒指拆解为3个力量戒指.\
是否要把天尊戒指拆解为3个泰坦戒指.\
是否要把法神戒指拆解为3个紫碧螺戒指.\
<开始拆解/@拆解_戒指>

[@拆解_戒指]
#IF
#ACT
OpenItemBoxEx 1 1 拆解戒指类物品

Q-Function.txt中脚本:
[@GetBoxItem1]
#IF
EQUAL S0 圣战戒指
#ACT
Give?力量戒指 3
Break

#IF
EQUAL S0 天尊戒指
#ACT
Give?泰坦戒指 3
Break

#IF
EQUAL S0 法神戒指
#ACT
Give?紫碧螺 3
#ELSEACT
ReclaimItem
#ELSESAY
请放入<圣战戒指> <天尊戒指> <法神戒指>


创建目录

功能: 创建新目录.
格式: ForceDirectories 目录

#IF
#ACT
ForceDirectories \QuestDiary\新目录\


打开网站地址

功能: 游戏中打开网站.
格式: OpenWebSite 网站

#IF
#ACT
OpenWebSite http://www.herom2.com


地图动态链接点

功能: 给地图增加动态链接点.
说明: 此功能需要两个脚本命令配套使用才可生效.
      AddMapRoute用于添加一个地图链接点,SetMapRoute配合设置一个地图链接点.
格式: AddMapRoute 动态链接标示(1-65535) 连接地图 坐标X 坐标Y
格式: SetMapRoute 动态链接标示(1-65535) 待连接地图 坐标X 坐标Y

例子: 链接地图3和地图5的特定坐标, 地图 3 335 330 地图 5 658 463
[@AddRoute]
#IF
#ACT
AddMapRoute 1 3 335 330
SetMapRoute 1 5 658 463


动态修改地图名字

功能: 动态修改地图显示名字.
格式: ChangeMapDesc 新名字 是否保存(0,1)
说明: 直接修改MapInfo.txt中对应地图的显示名字.

例子: 修改盟重省的名字,并且保存.
#IF
#ACT
ChangeMapDesc 新盟重 1


读取文本内容到变量[!]

功能: 读取文本文件中的内容到变量中.

格式:GetListString 文件路径 行号(行号从0开始) 变量1 变量2
说明: 变量2可以不需要,当读取变量2时文本单行的内容必须是以下格式:
人物1:10
人物2:20

例子:
[@main]
#IF
#ACT
GetListString ..\QuestDiary\测试.txt 5 A10 N10


改变宝宝名字颜色

功能: 改变人物宝宝名字颜色.
格式: ChangeSlaveNameColor 宝宝名字 颜色(0-255)


改变人物的模式

改变人物当前模式(无敌,隐身,生命,魔法,攻击力,道术力,魔法力,攻击速度,禁止攻击)

格式: ChangeModeEx 模式(1-10)  时间(1-65535)  附加值(1-65535)
说明: 1=无敌 2=隐身 3=HP  4=MP  5=攻击力 6=魔法力 7=道术力 8=攻击速度 9=禁止攻击 10=锁定
       第三个参数无敌,隐身,禁止攻击时没有使用.

#IF
#ACT
ChangeModeEx 1 60
#SAY
给你1分钟的无敌时间,好好利用哦!

#IF
#ACT
ChangeModeEx 5 60 20
#SAY
60秒之内攻击力增加20点.


改变物品的持久

功能: 修改指定位置装备的当前最大持久.
格式: ChangeItemDura 装备位置(0-12) 操作符(+,-,=) 持久(0-65000) 当前持久大于最大持久时是否改变当前支持(0-1)

#IF
#ACT
ChangeItemDura 0 - 1000
#SAY
你的物品最大持久降低1点.


改变指定行会的掌门人

改变行会掌门人

[@changeguildmaster]
#IF
#ACT
ChangeGuildMaster 华山派
#SAY
贡献,你现在是华山派掌门人了.


给字符串增加空格

功能： 给字符串在前面或者后面增加指定个数的空格.

格式: SetStringBlank 变量(S,A) 长度(1-100) 格式(0, 1)?
说明: 可支持人物S变量或者全局A变量,格式0=前面,1=后面
注意: 第二个参数长度是指增加空格后整个字符串的长度,例如字符gameofmir引擎长度是13,
如果第二个参数设置1 那么实际增加7个空格.
注意: 英文字母和数字占用1个字节(长度),汉字占用2个字节(长度).

例子：

[@Test]
#IF
#ACT
MOV S10 gameofmir引擎
SetStringBlank <$STR(S10)> 20 0
SendMsg 5 <$STR(S10)>

MOV S10 gameofmir引擎
SetStringBlank <$STR(S10)> 20 1
SendMsg 5 <$STR(S10)>


关闭大对话框模式

功能: 关闭大对话框模式. (专用登录器)
格式: CloseBigDialogBox

#IF
#ACT
CloseBigDialogBox


恢复发言

恢复人物发言.

#IF
CheckLevelEx > 1
#ACT
ENABLESENDSAY


获取玩家名字

功能:
取得玩家名字.

格式:
GetUserName 0-99之间的数字,或者范围是0-99之间的数值型变量.
如下将玩家名字放入S10中

#IF
#ACT
GetUserName S10


建立新行会

增加一个新的行会.可以指定某人成为该行会掌门(必须在线)

说明: 第二个参数等于Self时掌门是自己.否则是在线玩家.

[@AddGuild]
#IF
#ACT
AddGuild 华山派 Self


建立一个文本文件

在指定位置建立一个文本文件.

注意:文件保存在 \Envir目录中.

#IF
#ACT
CreateFile ..\QuestDiary\NewFile.txt
#SAY
在Envir\QuestDiary目录中建立了一个文件.


排序人物自定义变量[!]

功能: 排序人物自定义变量.
格式: SortHumVarToListEx 变量名 变量路径 排序模式(0,1) 保存路径 保存模式(0,1)
说明: 排序模式 0=升序,1=降序

升序排序人物变量QQQQ:
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试A.txt 0

升序排序人物变量QQQQ,不保存人物变量:
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试A.txt 1


排序在线人物自定义变量[!]

功能: 排序在线人物自定义变量.
格式: SortHumVarToLisL) 变量名 保存路径 排序模式(0,1) 名字路径
说明: 排序模式 0=升序,1=降序
      名字路径在排序后只保存人物名字不保存人物变量.
注意: 此脚本命令只排序在线人物的变量

升序排序人物变量QQQQ:
[@main]
#IF
#ACT
SortHumVarToList QQQQ ..\QuestDiary\测试.txt 0

升序排序人物变量QQQQ,单独保存人物名字:
[@main]
#IF
#ACT
SortHumVarToList QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试1.txt


强制攻击模式

功能: 强制人物的攻击模式
格式: SetHumAttackMode 攻击模式(0-7) 时间(秒)
说明: 0=全体模式 1=和平模式

例子: 强制人物和平模式
#IF
CheckPkPoint 2
#ACT
SetHumAttackMode 1 3600


清除宝石升级属性

功能: 清除使用宝石升级的装备属性.
格式: ClearStoneUpgrade 位置(0-14)
注意: 此命令不区分极品和普通装备,清除时所有属性都将消失.

例子:
[@main]
#IF
#ACT
ClearStoneUpgrade 0


取得随机字符串

功能: 从文件中随机获取一行字符串
格式: GetRandomText 文件路径 变量(S0--S99) 指定行(0-10000)
说明: 没有指定行时随机取某一行的字符串.

例如:随机取一行字符串到S10中.
[@Main]
#IF
#ACT
GetRandomText ..\QuestDiary\测试.txt S10
SendMsg 5 取出的字符串是:<$STR(S10)>

例如:取特定行的字符串.
[@Main]
#IF
#ACT
GetRandomText ..\QuestDiary\测试.txt S10 5
SendMsg 5 取出的字符串是:<$STR(S10)>


取下人物身上装备

把人物身上装备放入背包中.

格式: TakeEx (0-16)

#IF
#ACT
TakeEx 1


取装备名字

取指定位置的装备名字
格式: GetUserItemName 位置(0-12) S变量(0-99)
说明: S变量是人物私有变量(0-99)

例子: 把武器的名字放如S10变量中

#IF
#ACT
GetUserItemName 1 10
SendMsg 5 武器的名字: <$STR(S10)>


取字符串在列表中的位置

功能: 取字符串在列表中的下标.
格式: GetStringPos 路径 字符串
说明: 返回值放在人物的N0变量中,如果值=9999999说明没有找到.
其他: 返回值可以通过EQUAL做条件检测

[@main]
#IF
#ACT
GetStringPos ..\QuestDiary\测试.txt 管理员
SendMsg 5 字符串在列表中的位置:<$STR(N0)>


杀死地图中的怪物

功能: 随机杀死地图中的怪物.
格式: RandomKillMon 地图 怪物名字 数量(1-255) 掉落物品(0掉落,1不掉落)
说明: 地图=Self时表示当前地图.

例子:
[@main]
#IF
#ACT
RandomKillMon Self 稻草人 5


杀死人物的宝宝

说明:把自己的宝宝杀死.
格式:KillCallMob 名字 数量 方式(0杀死会触发脚本 1直接消失不会触发脚本)

#IF
#ACT
KILLCALLMOB 神兽
#SAY
你的神兽已经死亡.

#IF
#ACT
KILLCALLMOB 白野猪 2


删除地图动态链接点

功能: 删除使用AddMapRoute设置的地图链接点.
格式: DelMapRoute 动态链接标示(1-65535)

例子: 删除链接表示等于1的链接点.
#IF
#ACT
DelMapRoute 1


设置人物伤害吸收

说明:设置人物可吸收收到的攻击伤害.

格式: SetSuckDamage 操作符(+ - =) 总吸收直(1-2000000000) 吸收比例(1-1000) 成功率(1-100)
      吸收比例 1=0.1% 500=50% 1000=100%

例子: 设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%
#IF
CheckGold 10000
#ACT
SetSuckDamage + 1000 200 95
Take 金币 10000

特别说明:当人物设置伤害吸收后,收到攻击后会按照一定比例减少受到的伤害.
例如:当前拥有5000点伤害吸收,每次吸收20%,成功率100%.当前攻击受到100点伤害,那么本次攻击实际受到的伤害是80点.当前伤害吸收剩余4980点,此状态直到伤害吸收等于0时恢复,下线可保存装备.


设置人物商铺购买价格比例

功能: 设置人物商铺购买物品的价格比例.
格式: SetShopItemPriceRate 比例(1-100)
注意: 人物下线后状态消失.
其他: 列表信息中可设置单个物品是否允许打折购买.

例如:大于100级人物商铺购买物品的价格比例是90%,人物上线时在登录脚本设置价格比例即可.

[@Login]
#IF
CheckLevelEx > 99
#ACT
SetShopItemPriceRate 90


设置装备发光

功能: 设置装备发光
说明: 衣服,武器和头盔不支持次功能.
适用: 英雄M2
格式: SetItemsLight 位置(0-12) 值(1=发光效果1 2=发光效果2 0=不发光).
其他: 选择效果点击 M2\选项\功能设置\内挂控制

发光效果1:
#IF
#ACT
SetItemsLight 3 1

发光效果2:
#IF
#ACT
SetItemsLight 3 2

取消发光:
#IF
#ACT
SetItemsLight 3 0


随机验证码

随机输入验证码

[@Main]
#If
CheckLevelEx > 0
#Act
SetRandomNo
#Say
<输入验证码/@@CheckNo>:<$RANDOMNO>

[@@CheckNo]
#If
CheckRandomNo
#SAY
输入正确.
#ELSESAY
输入不正确.


特修身上装备

在物品规则列表中限制物品的不会被修理

#IF
RepairAll
#SAY
你的装备修好了.
#ELSESAY
你是不是没有钱啊.


写入指定文本文件

功能: 把字符串写入到指定的文本文件中,可以指定写入行.
格式: AddTextListEx 路径 字符串 行(0-65535)

#IF
#ACT
AddTextListEx ..\TestList.txt <$USERNAME> 0


延时执行脚本

延时执行指定的脚本.

DelayCall S Label (S单位毫秒, Label是需要跳转的脚本段)

#IF
#ACT
DelayCall 5000 @Kick

[@Kick]
#IF
#ACT
Kick


移动怪物到新坐标

功能: 移动指定坐标的怪物到新的位置.
格式: MoveMonToPos 怪物 地图 老坐标X 老坐标Y 新坐标X 新坐标Y

例子:
#IF
CheckRangeMonCountEx K004 51 43 魔王弓箭手 > 0
#ACT
MoveMonToPos 魔王弓箭手 K004 51 43 48 47


移动某地图全部人物到另外一个地图

把某个地图中的玩家全部移动到另外一个地图.

#IF
#ACT
MoveMapPlay 0 3 333 333
#SAY
地图0中的人物已经全部移动到地图3中.


召唤自己的分身

例子:召唤自己的分身帮助自己作战3个小时.

#IF
#ACT
RecallSelf 3


自定义颜色文字发送

功能说明: 发送自定义颜色的文字信息.

格式: GuildNoticeMsg 255 233 发送自定义颜色的文字信息. Self

参数一是前景颜色,参数二是背景颜色,参数三是要发送的文字信息,参数四等于'Self'时只发送给自己, 等于'Group'时发送给组队, 等于'National'时发送给自己国家的人(使用于国战), 等于'Map'时发送到当前地图中的人物.如果省略参数四表示全服发送.

支持的参数: %s(玩家名字) %d(NPC名字) %m(地图名字) %x%y(坐标)
  <$KILLER>杀死人物的名字 <$MONKILLER>杀死怪物的名字


自动穿戴装备

   功能:自动穿背包中的装备

  装备位置:
  衣服        = 0;
  武器        = 1;
  蜡烛        = 2;
  项链        = 3;
  头盔        = 4;
  左手镯      = 5;
  右手镯      = 6;
  左戒指      = 7;
  右戒指      = 8;
  护符        = 9;
  腰带        = 10;
  鞋子        = 11;
  宝石        = 12;

  #IF
  CheckLevelEx > 1
  #ACT
  Give 怒斩 1
  AutoTakeOnItem 怒斩 1


检测被自己杀死宝宝的名字

检测被自己杀死的宝宝的名字.
注意:此命令只检测直属宝宝,例如道士英雄召唤的神兽不属于直属宝宝.

#IF
CheckKillSlaveName 白野猪
#SAY
你把对方的宝宝<白野猪>杀死了.


检测本月的天数

功能: 检测是否是本月的第几天.
格式: DAYOFMONTH 天数(1-31) 天数(1-31)
说明: 第二个参数可省略.

例子: 检测是否本月的前7天
[@main]
#IF
DAYOFMONTH 1 10
#SAY
本月10号之前.

例子: 检测是否是本月的第一天
[@main]
#IF
DAYOFMONTH 1
#SAY
今天是1号,新的一个月又开始了.


检测当前宝石升级装备的名字

功能: 检测当前通过宝石升级装备的名字
格式: CheckUpgradeItemName 位置(0-1) 名字
说明: 位置0=升级装备的名字 1=左边一格宝石的名字
注意: 此命令只能在QFunction中的@ItemUpgarde下执行.

[@ItemUpgrade]
#IF
CheckGold 5000
CheckUpgradeItemName 0 裁决之杖
#ACT
Take 金币 5000
#ELSESAY
只能升级裁决之杖,或者你没有5000金币.
#ELSEACT
SetUpgradeFail
Break


检测人物的攻击模式

说明: 检测人物的攻击模式
格式: CheckAttackMode 模式(0-7)

#IF
CheckAttackMode 0
#SAY
全体攻击模式

#IF
CheckAttackMode 1
#SAY
和平攻击模式


检测人物是否挂机

功能:检测人物是否是离线挂机
格式:CheckOffline


检测物品持久

功能:检测人物身上物品持久.
格式:CheckItemDura 位置(0-12) 操作法(> = <) 持久(1-65000) 模式(0,1)
说明:默认模式=0表示检测物品持久下限,模式=1时检测物品持久上限.

例子:检测物品持久下限
[@Main]
#IF
CheckItemDura 1 > 30000 0
#SAY
武器持久下限大于30.

例子:检测物品持久上限
[@Main]
#IF
CheckItemDura 1 > 30000 1
#SAY
武器持久上限大于30.


检测物品纯度

功能: 检测背包中物品的纯度(持久,品质).
格式: CheckMine 物品名称 数量(1-45) 纯度(1-65)

例子: 检测背包中是否有5个纯度20的黑铁矿石,并且回收.
[@main]
#IF
CheckMine 黑铁矿石 5 20
#ACT
TakeMine 黑铁矿石 5 20
#SAY
背包中有5个纯度20的黑铁矿石.
#ELSESAY
没有.


检测月份

功能: 检测现在是几月
格式: MONTHOFYEAR 月份(1-12) 月份(1-12)
说明: 第二个参数可省略.

例子: 检测是否7月--8月
[@main]
#IF
MONTHOFYEAR 7 8
#SAY
暑假期间大家玩的开心点.

例子: 检测是否1月
[@main]
#IF
MONTHOFYEAR 1
#SAY
新的一年开始了.


检测装备的附加属性总和[!]

功能: 检测装备的附加属性总和(武器的诅咒不在计算范围之内).
格式: 格式: CheckItemAddValueEx 位置(0-15) 操作符(> = <) 附加值(0-65000) 新属性(0,1)
说明: 第四个参数只在英雄M2下有效,1时计算附加的致命一击等属性.

例子:
#IF
CheckItemAddValueEx 1 > 5 1
#SAY
武器的附加属性大于5点.


检测装备名字颜色

功能: 检测装备名字的颜色(英雄M2).
格式: CheckItemNameColor 位置(0-13) 颜色(0-255)

例子: 检测武器颜色是否是紫色.
[@main]
#IF
CheckItemNameColor 1 253
#SAY
武器名字紫色显示.


检测字符串长度命令

功能：

检测字符串长度命令

格式：

CheckStringlength 字符串 操作符(<,>,=) 位数

说明：一个汉字位数为2, "》"也为2个字符

[@test]
#IF
CheckStringlength D3dm2 > 3
#SAY
D3dm2大于3个字符
#ELSESAY
D3dm2小于3个字符


检查宝宝数量

功能：
    可以检查玩家所带宠物的数量。

格式：
CHECKSLAVECOUNT  控制符  <.=.>  数量< FONT>

;==========================================
;检查宝宝数量是否为指定数量
[@checkslavecount0]
#IF
#ACT
  CHECKSLAVECOUNT = 5
#SAY
你的宝宝数量为5个。
#ELSESAY
你的宝宝数量不为5个。
;==========================================

;==========================================
;检查宝宝数量是否为大于数量
[@checkslavecount1]
#IF
#ACT
  CHECKSLAVECOUNT > 5
#SAY
你的宝宝数量超过5个。
#ELSESAY
你的宝宝数量不超过5个。
;==========================================

;==========================================
;检查宝宝数量是否为小于数量
[@checkslavecount2]
#IF
#ACT
  CHECKSLAVECOUNT < 5
#SAY
你的宝宝数量小于5个。
#ELSESAY
你的宝宝数量不小于5个。
;==========================================


检查宝宝最高等级

脚本功能:
检查宝宝的等级。

命令格式:
CHECKSLAVELEVEL 控制符(=,>,<)  等级数(7)< /FONT>

;==========================================
;检查宝宝的等级是否等于指定级别
[@checklevel0]
#IF
  CHECKSLAVELEVEL = 5
#SAY
宝宝的等级等于5级。
#ELSESAY
宝宝的等级不等于5级。
;==========================================

;==========================================
;检查宝宝的等级是否大于指定级别
[@checklevel1]
#IF
  CHECKSLAVELEVEL > 5
#SAY
宝宝的等级大于5级。
#ELSESAY
宝宝的等级不大于5级。
;==========================================

;==========================================
;检查宝宝的等级是否小于指定级别
[@checkposelevel2]
#IF
  CHECKSLAVELEVEL < 5
#SAY
宝宝的等级小于5级。
#ELSESAY
宝宝的等级不小于5级。
;==========================================


检查地图中的人物是否属于同一个行会

检查当前地图中的人物是否属于同一行会

格式: MapHumIsSameGuild 是否忽略没有加人行会的人物(0-1)

#IF
MapHumIsSameGuild 1
#SAY
当前地图中的人物属于同一个行会,不包涵没有加入行会的人物.


检查人物被踢次数.

#IF
CheckNumOfKick 3
#SAY
你已经被踢下线至少3次了.


检查人物杀死怪物的名字

功能:检查人物杀死怪物的名字
格式:CheckKillMonName 名字 是否清除(0,1)
说明:是否清除参数可以不需要默认0,为了避免杀死某个怪物可重复执行脚本是设置1.

[@main]
#IF
CheckKillMonName 白野猪
#SAY
你把白野猪干掉了!

;检测后立即清除人物内置变量.

[@main]
#IF
CheckKillMonName 白野猪 1
#SAY
你把白野猪干掉了!


检查人物是否在指定范围内

功能: 检测人物是否在指定范围之内
格式: CheckHumInRange 地图 坐标X 坐标Y 范围(0 -- 500)
说明: 地图=Self时表示当前地图.

例子: 检测人物是否在盟重安全区.
#IF
CheckHumInRange 3 330 330 5
#SAY
你在盟重安全区发呆呢..


检查人物所在地图是否允许使用记忆,夫妻,师徒传送

#IF
CheckRecall 人物名字
#SAY
当前地图不允许被传送.


检查是被人物还是怪物杀死的

检查是被怪物还是人物杀死的.

#IF
KillByHum
#ACT
SendMsg 5 玩家 <$KILLER> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$MONKILLER> 在%m 把你干死了!


检查一个范围内怪物数[!]

功能：
    可以检查一个坐标范围内怪物数量。

格式：
CheckRangeMonCount 地图号 X坐标 Y坐标 范围 控制符(=,>,<) 数量

;==========================================
[@Main]
#IF
  CheckRangeMonCount 3 330 330 10 < 100
#SAY
地图3的X330Y330十的范围内怪物少于100只
#ELSESAY
地图3的X330Y330十的范围内怪物多于100只
;==========================================


检查在线最高属性人物

检查在线最高攻击,魔法,道术,防御,PK值

#if
IsHigh L
#say
你的级别是全服最高的
#act
break

#if
IsHigh P
#say
你的PK值是全服最高的
#act
break

#if
IsHigh D
#say
你的攻击是全服最高的
#act
break

#if
IsHigh M
#say
你的魔力是全服最高的
#act
break

#if
IsHigh S
#say
你的道术是全服最高的
#act
break


检查正在穿身上装备的名字[!]

检查正在穿身上装备的名字.

格式: CheckTakeOnItem 物品名字

#IF
CheckTakeOnItem 布衣(男)
#SAY
你正在穿布衣！


检查正在攻击中的怪物名字

说明: 检查正在被自己攻击的怪物的名字.
注意: 地图参数中加入 HITMON(@XXX)

Q-Function0.txt中

[@XXX]
#IF
CHECKHITMONNAME 白野猪
#SAY
你正在攻击白野猪


检查正在脱身上装备的名字[!]

检查正在脱身上装备的名字.

格式: CheckTakeOffItem 物品名字

#IF
CheckTakeOffItem 布衣(男)
#SAY
你的布衣是不是该扔掉了?


检查指定城堡是否在攻城[!]

#if
checkcastlewar 2
#say
第三个城堡正在攻城
#elsesay
第三个城堡没有攻城


检查指定范围内人物数量

功能: 检测指定范围内人物数量
格式: 格式: CheckRangeHumCount 地图 坐标X 坐标Y 范围 操作符(>= <) 数量
说明: 地图=Self时表示当前地图 坐标=0时表示当前坐标

例子: 检测盟重省安全区的人物数量
#IF
CheckRangeHumCount 3 330 330 10 > 100
#SAY
盟重土城当前人数超过100.


检查指定人物背包空格数量

检测指定人物背包空格数量

#IF
CheckHumBag <$STR(S$1)> > 5
#SAY
<$STR(S$1)>的背包有5个以上的空格.


检查装备升级次数 或 星星数量

功能: 用来检测通过宝石升级装备的次数. 或 星星数量
格式: CheckItemupgradeCount 方式(0,1) 位置(0-12) 操作符(> = <) 次数(0-255)
说明: 方式=0时检测正在升级的装备,方式=1时检测人物身上的装备.

例子: 检测武器是否已经升级10次.
#IF
CheckItemUpgradeCount 1 1 > 10
#SAY
你的武器已经升级了10次以上.


检查自己和宝宝之间的距离[!]

功能: 检测自己和宝宝之间的距离
格式: CheckSlaveInRange 名字 距离
说明: 此命令的主要作用是配合128类型的宝宝使用(可模仿押镖任务).

#IF
CheckSlaveInRange 月灵 5
#SAY
你的月灵在身边
#ELSESAY
你的月灵宝宝跑哪里去了?


摆摊触发脚本

注意：以下功能是仿HeroM2摆摊功能。如果你使用的是个人商店，请查看个人商店部分

打开摆摊窗口之前首先执行Q-Function中的@StartMyShop脚本段.

脚本命令ForbidMyShop用于中断摆摊.

例子:以下脚本放在Q-Function中.

[@StartMyShop]
#if
ISDUPMODE
#say
请找一个空位置，不能与别人站在一起。
#ACT
ForbidMyShop
BREAK

#IF
NOT INSAFEZONE
#SAY
需要在安全区使用摆摊功能！
#ACT
ForbidMyShop
BREAK

#IF
NOT IsOnMap 3
#SAY
需要在盟重使用摆摊功能.
#ACT
ForbidMyShop
BREAK

#IF
CheckLevelEx < 40
#SAY
需要40级才可以使用摆摊功能！
#ACT
ForbidMyShop


购买商铺物品时触发

功能说明: 人物通过商铺购买物品成功时触发.
使用方法: Q-Function.txt中@BuyShopItem脚本段,
购买的物品名字放在人物的S0变量中,物品价格放在M0中.总价放在M1中，货币类型放在M2

[@BuyShopItem]
#IF
#ACT
SendMsg 5 %s通过商铺购买了<$STR(S0)>,价格是:<$STR(M0)> 总价格是:<$STR(M1)>，货币类型是:<$STR(M2)>

货币id对应表
$GAMEGLORY | 12
$GAMEPOINT | 2
$GAMEGOLD | 0
$GAMEGIRD | 104
$CREDITPOINT | 7
$GAMEDIAMOND | 3
$GOLDCOUNT | 1
$B_GAMEGLORY | 13
$B_GAMEPOINT | 16
$B_GAMEGOLD | 17
$B_GAMEGOLD | 18
$B_CREDITPOINT | 19
$B_GAMEDIAMOND | 14
$B_GOLDCOUNT | 15


技能触发脚本功能

增加魔法触发功能.自身技能触发. Q-Function.txt中[@MagSelfFuncX]段,其中X表示要触发的魔法ID
增加魔法触发功能.对目标人物使用时自身触发. Q-Function.txt中[@MagTagFuncX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标人物技能触发. Q-Function.txt中[@MagTagFuncExX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标怪物技能触发. Q-Function.txt中[@MagMonFuncX] 段,其中X表示要触发的魔法ID

例子:使用治愈术时触发脚本

[@MagSelfFunc2]
#ACT
SendMsg 5 自己加血
[@MagTagFunc2]
#ACT
SendMsg 5 给别人加血
[@MagMonFunc2]
#ACT
SendMsg 5 给怪物加血.


宝石升级系统[!]

说明:1.打开人物背包点右下脚的升级按钮进行升级.也可使用OpenUpgradeDialog命令打开界面.
     3.放好物品点升级时先执行Q-Function中的@ItemUpgrade脚本段.

例如:升级装备需要5000金币,此脚本放入Q-Function.txt中.

[@ItemUpgrade]
#IF
CheckGold 5000
#ACT
Take 金币 5000
#ELSESAY
升级装备需要5000金币.
#ELSEACT
SetUpgradeFail
Break

--------------------------------------------------------------------------------------------------------------

升级宝石StdMode=55,56,57,58,59

宝石类型1:

StdMode=55(升级指定类型的装备)
Shape=(指定升级哪种类型的装备,此处添写和要升级类型的StdMode一样的值即可,例如武器设定为5)
AniCount=(指定可以升级加几以下的装备,例如:设定为10,那么该宝石可以升级次数小于10次的装备)
DuraMax=(指定宝石升级装备的成功机率,例如:设定为20既为20%成功机率)
Need=(升级失败后可执行的操作,如果该值等于1-100时,则失败后把装备副加属性全部清零.如果该等于101-200时,则失败后装备消失.等于201-300时,升级失败后装备当前属性不变.)
NeedLevel=(指定宝石升级范围,等于0时不限制,例如:该宝石只允许升级+5到+10之间的装备,那么Need=5*65535+10,计算规则=低限*65535+上限)
Ac,Ac2,Mac,Mac2,Dc,Dc2,Mc,Mc2,Sc,SC2=(指定该宝石升级成功后给装备加的属性，设定方法跟设置装备属性一样，不同的装备设置也不一样)

宝石类型2:
StdMode=57(升级符合类型的装备)
Source=(等于1)
Shape=(等于0升级符合类型的装备,指定类型时填写待升级装备的StdMode值)
区别:其他设置方法参照宝石类型1
注意:此类宝石只增加防御和魔御.
AC2,MAC2=(升级装备的防御,魔御,必须是可增加防御和魔御的装备才可以升级,例如:衣服,手镯等)

宝石类型3:
StdMode=57(升级符合类型的装备)
Source=(等于2)
Shape=(等于0升级符合类型的装备,指定类型时填写待升级装备的StdMode值)
区别:其他设置方法参照宝石类型1
注意:此类宝石只增加攻击,道术和魔法.
DC2,MC2,SC2=(升级装备的攻击,魔法等,必须是可增加攻击和魔法等属性的装备才可以升级,例如:武器,项链等)

宝石类型4:
StdMode=58(随成升级装备属性)
Shape=(0表示所有类型,指定类型时填写待升级装备的StdMode值)
AniCount=(升级点数)
区别:其他设置参照宝石类型1,此类宝石升级时随机增加装备属性,例如:AniCount等于5时,那么随机增加装备5点属性.
注意:升级失败后如果Need小于100那么随机清除某项或者多项附加属性.

宝石类型5:
StdMode=59(增加升级成功率)
Shape=(0表示所有类型,指定类型时填写待升级装备的StdMode值)
DuraMax=(提高成功机率,例如:设定5即为提高5%的机率)

以下是最新更新后的部分新特性:

1.55,56,57,58这几种类型宝石失败后默认不会降低装备升级的星星数.如果升级失败时需要降低装备的星星数那么设置物品的Reserved字段,0时不降,大于0时设置几就降几点.
例如宝石的Reserved=2 装备的星星数=3 升级失败后星星就会减去2，剩下1个星星

2.58类型的升级宝石Weight=1时随机升级所以属性,Weight=2时只随机升级攻击,魔法,道术.


毒素武器[!]

使用方法:\Envir\UserData\PoisonWeapon.txt

格式: 武器名称 成功几率 减HP值 基本时间 扩展时间
成功率100以下时设置多少就是多少的成功率例如:80就是80%的成功率50就是50%的成功率
扩展时间是一个随即值,假如设置为10那么它的值就是1-10之间的值. 持续时间=基本时间+扩展时间所产生的随机值
例如:木剑 90 10 10 5


行会成员人数

功能: 检测行会成员人数

格式:
CheckGuildMemberCount 控制符  <.=.>  数量

#IF
CheckGuildMemberCount  > 100
#SAY
行会成员大于100人.


检测当前目标类型

格式: CHECKCURRTARGETRACE 控制符(=,>,<) 数据库Race值

该命令只有在死亡触发和攻击触发中使用

[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#SAY
当前是人物
BREAK

#IF
CHECKCURRTARGETRACE = 1
#SAY
当前是英雄
BREAK

#IF
CHECKCURRTARGETRACE = 60
#SAY
当前是人形怪
BREAK


检测地图范围怪物数量[!]

格式: CHECKRANGEMONCOUNTEX 地图名称 怪物名称 X坐标 Y坐标 范围 控制符(=,>,<) 数量
[@main]
#IF
CHECKRANGEMONCOUNTEX 3 333 333 10 > 100
#SAY
大于100个怪物


检测地图假人数量[!]

CHECKMAPDUMMYCOUNT,检测地图假人数量
格式:检测地图假人数量 地图 （< > =）

例子:

[@main]
#IF
CHECKMAPDUMMYCOUNT 3 > 10
#SAY
地图3假人数量大于10个


检测地图相同怪物数量[!]

格式: CheckMapSameMonCount 地图名称 怪物名称 控制符(<,>,=) 数量 是否忽略怪物名称后面的数字(0=检测数字,1=不检测数字)

[@Main]
#IF
CheckMapSameMonCount 3 稻草人 > 10
#SAY
土城的稻草人大于10个


检测地图坐标是否可以到达

功能：
检测地图坐标是否可以到达

格式：
CHECKMAPMOVE 地图名 X坐标 Y坐标

==============================================
[@测试]
#IF
CHECKMAPMOVE 3 333 333
#SAY
盟重省333 333能够到达
#ELSESAY
该坐标不能到达
============================================


检测行会可以容纳多少成员

格式: CHECKGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示检测自己所在的行会) 检测符(<,>,=) 数量
[@main]
#IF
CHECKGUILDMEMBERMAXLIMITCOUNT 行会名称 > 100
#SAY
你的行会可以容纳成员数大于100个


检测会员剩余时间

格式: 检测会员剩余时间 文件名称 过期是否删除(0不删除 1删除) 变量1(到期时间 字符变量) 变量2(剩余天数 数字变量) 变量3(剩余小时 数字变量) 变量4(剩余分钟 数字变量)

例子:?

#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 <$STR(S$1)> <$STR(N$1)> <$STR(N$2)><$STR(N$3)>
#ACT
SENDMSG 6 你的会员到期时间是<$STR(S1)>【剩余天数=<$STR(N$1)>】【剩余小时=<$STR(N$2)>】【剩余分钟=<$STR(N$3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253

删除会员还是使用原来的老命令DELNAMEDATELIST


检测技能修炼点数[!]

功能：
检测技能修炼点数。

格式：
CHECKTRANPOINT 技能名称 检测符(>,<,=) 点数

;==========================================
[@CHECKTRANPOINT]
#IF
CHECKTRANPOINT 雷电术 = 100
#SAY
你的技能雷电术修炼点数等于100。
;==========================================


检测加入国家

格式: CheckNational (国家编号 0~100)

[@main]
#IF
CheckNational 0
#SAY
你还没有加入国家
BREAK

#IF
CheckNational 1
#SAY
你已经加入国家，国家编号1
BREAK


检测人物PK值

功能：
检测人物PK值。

格式：
 CHECKPKPOINTEX 控制符(=,>,<) 数量

;==========================================
[@Main]
#IF
CHECKPKPOINTEX > 100
#SAY
PK值大于 100
#ELSESAY
PK值小于 100
;==========================================


检测人物宝宝名字[!]

功能：

检测人物宝宝名字

格式：

;==========================================
[@main]
#IF
CHECKSLAVENAME GameOfMir
#ACT
SENDMSG 5 提示:你的宝宝叫GameOfMir
#ELSEACT
SENDMSG 5 提示:你的宝宝不叫GameOfMir
;==========================================


检测人物的伤害吸收

说明: 检测人物的伤害

格式: CheckSuckDamage 操作符(> = <) 数量(1-2000000000)

#IF
CheckSuckDamage > 1000
#SAY
SendMsg 5 你当前拥有的伤害吸收大于1000点.


检测人物荣誉

格式: CHECKGAMEGLORY (<,>,=) 值

[@Main]
#IF
CHECKGAMEGLORY = 100
#SAY
荣誉等于100

_________________________________________是两个命令自己测试把

检查人物的荣誉值

#IF
CheckNationCredit > 100
#SAY
你的荣誉值大于100点.


检测人物是否佩带指定物品

功能:
检测当前人物是否佩带指定物品

格式:
CHECKITEMW 物品名 数量

============================

[@TEST]
#IF
CHECKITEMW 力量戒指 1
#elsesay
你身上没有力量戒指\ \
#elseact
break

============================

[@TEST1]
#IF
COMPARETEXT <$DRESS> 布衣(男)
#elsesay
你身上没有布衣(男)\ \
#elseact
break


检测人物是否在线

checkonline

例子:

[@main]
#IF
checkonline
#SAY
在线

[@main]
#IF
H.checkonline
#SAY
你的英雄在线

[@main]
#IF
gameofmir.checkonline
#SAY
gameofmir在线

[@main]
#IF
S1.checkonline
#SAY
<$STR(S1)>在线


检测人物是否重叠

格式: IsDupMode 模式(0检测所有对象(包括人物、怪物、NPC)，1只检测是否有人物)

[@Main]
#IF
IsDupMode 1
#SAY
不要和其他人站在一起

[@Main]
#IF
IsDupMode 0
#SAY
不要和其他人或怪物站在一起


检测人物元素属性

格式: CHECKNEWITEMVALUE 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 检测符(>,<,=) 值(1-100)

(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%
[@main]
#IF
CHECKNEWITEMVALUE 0 0 > 10
#SAY
暴击几率大于10%


检测人物在线时长[!]

功能：
可以检查人物在线时间长度。

格式：
ONLINELONGMIN (> < =) 支持变量操作
;==========================================
#if
ONLINELONGMIN > 10
#say
在线时间大于 10分钟
;==========================================


检测杀人者是人物还是怪物

功能：
人物是被怪物杀死还是玩家杀死 死亡触发

格式：

;==========================================
[@PlayDie]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK


检测是不是在摆摊

格式: CHECKSHOPSTALLSTATUS

[@main]
#IF
CHECKSHOPSTALLSTATUS
#SAY
正在摆摊
#ELSE
没有摆摊


检测是否进入攻城的范围

格式: CHECKCASTLEWARAREA 城堡名称

[@Main]
#IF
CHECKCASTLEWARAREA 沙巴克
#SAY
你已经进入进入攻城的范围


检测是否正在攻城

格式: CHECKUNDERWAR 城堡名称

[@Main]
#IF
CHECKUNDERWAR 沙巴克
#SAY
沙巴克正在攻击战


检测物品的附加属性值

功能： 获取物品的附加属性值

格式: 格式: CHECKITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 < > =) 值 保存变量

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

例子:?
#IF
CheckItemAddValue 0 0 > 1
#ACT
GETITEMADDVALUE 0 0 <$STR(M10)>
#SAY
你的盔甲附加了<$STR(M10)>点防御属性.


检测在安全区

INSAFEZONE


检测指定范围内的人物数量

CheckRangeHumCount 地图名称 X Y 范围 (<,>,=) 数量


检测组队人数[!]

功能：
可以检查人物组队人数。

格式：
CHECKGROUPMEMBERCOUNT (<,>,=) 数量
;==========================================
#if
CHECKGROUPMEMBERCOUNT > 10
#say
组队人数大于10个人
;==========================================


检查城堡占领天数

功能：
 检查沙巴克占领天数

格式：
================================
#if
CASTLECHANGEDAY > 7
#say
你已经占领沙城7天以上.
================================


检查城堡战争天数

功能：
可以检查上次攻城到现在的天数。

格式：
 CASTLEWARAY 控制符(<=>) 天数
;==========================================
[@Main]
#IF
CASTLEWARAY > 3
#SAY
上次攻城到现在超过三天
#ELSESAY
上次攻城到现在未够三天
;==========================================


检查城门状态

功能：
可以检查沙城门状态。

格式：
;==========================================
#if
CHECKCASTLEDOOR 损坏
#say
城门损坏

#if
CHECKCASTLEDOOR 开启
#say
城门开启

#if
CHECKCASTLEDOOR 关闭
#say
城门关闭
;==========================================


检查当前所在地图的名字

功能：
检查当前所在地图的名字

格式：CHECKMAPNAME 地图名称
;==========================================
#if

CHECKMAPNAME 3

#say

你当前在地图3上\ \

<退出/@exit>

#elsesay

你当前不在地图3上\ \

<退出/@exit>

;==========================================


检查登录帐号与IP是否匹配

功能：
可以检查登录帐号与IP是否匹配。

格式：
CHECKACCOUNTIPLIST AccountIPList.txt

;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKACCOUNTIPLIST AccountIPList.txt
#SAY
您的登录帐号与指定IP匹配。
#ELSESAY
您的登录帐号与指定IP不匹配。
;==========================================

列表文件格式:
此文件们于目录：Mir200\Envir\

AccountIPList.txt

;==========================================
;登录帐号 IP
lintest 192.168.1.123
lintest1 192.168.1.124
;==========================================


检查地图怪物数量

功能：
可以检查一个地图内的怪物数量。

格式：
CheckMonMap 地图号 数量

;==========================================
[@Main]
#IF
CheckMonMap 3 30
#SAY
地图3的内怪物多于100只
#ELSESAY
地图3的怪物少于100只
;==========================================


检查对面人物的等级

功能：
 可以检查对面人物的等级（不要求面对面）。

格式：
CHECKPOSELEVEL 控制符(=,>,<) 等级数(1 - 65535)

;==========================================
;检查对面人物的等级是否等于指定级别
[@checkposelevel0]
#IF
CHECKPOSELEVEL = 50
#SAY
您对面人物的等级等于50级。
#ELSESAY
您对面人物的等级不等于50级。
;==========================================

;==========================================
;检查对面人物的等级是否大于指定级别
[@checkposelevel1]
#IF
CHECKPOSELEVEL > 50
#SAY
您对面人物的等级大于50级。
#ELSESAY
您对面人物的等级不大于50级。
;==========================================

;==========================================
;检查对面人物的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKPOSELEVEL < 50
#SAY
您对面人物的等级小于50级。
#ELSESAY
您对面人物的等级不小于50级。
;==========================================


检查对面人物的性别

功能：
 可以检查对面人物的性别（不要求面对面）。

格式：
CHECKPOSEGENDER 性别(MAN,男,WOMAN,女)

;==========================================
;检查对面人物是否为男的
[@checkposegender0]
#IF
CHECKPOSEGENDER MAN
#SAY
你对面的人物是男的。
#ELSESAY
你对面的人物不是男的。
;==========================================

;检查对面人物是否为女的
[@checkposegender1]
#IF
CHECKPOSEGENDER WOMAN
#SAY
你对面的人物是女的。
#ELSESAY
你对面的人物不是女的。
;==========================================


检查对面人物站的位置

功能：
 可以检查对面人物站的位置性别（要求面对面）。

格式：
CHECKPOSEDIR 控制符(1,2)

;==========================================
;检查对面人物是否面对面
[@checkposedir0]
#IF
CHECKPOSEDIR
#SAY
你二个站的位置正确。
#ELSESAY
你二个站的位置不正确。
;==========================================

;==========================================
;检查对面人物是否面对面，而且要求二个人相同性别
[@checkposelevel0]
#IF
CHECKPOSEDIR 1
#SAY
你二个站的位置及性别一样。
#ELSESAY
你二个站的位置不正确或性别不一样。
;==========================================

;==========================================
;检查对面人物是否面对面，而且要求二个人不同性别
[@checkposelevel0]
#IF
CHECKPOSEDIR 2
#SAY
你二个站的位置及性别不一样。
#ELSESAY
你二个站的位置不正确或性别一样。
;==========================================


检查国家人物总数.

格式: CheckNationHumCount 操作符(< = >) 人数

#IF
CheckNationHumCount > 100
#SAY
当前国家大于100人.


检查行会名称

功能：
 检查行会名称

格式：
================================
#if
CHECKOFGUILD 行会名称
#say
行会正确
================================


检查行会是否在列表中

功能：
检查行会是否在列表中

格式：
================================
[@checkGuild]
#IF
CHECKGUILDLIST GuildList.txt
#SAY
列表中有行会。
#ELSESAY
列表中没有行会。
================================


检查会员时间

相关命令：
CHECKUSERDATE 会员.txt < 30 p0 p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1

加入会员人物及时间： ADDUSERDATE 会员.txt
删除会员人物及时间： DELUSERDATE 会员.txt


检查金刚石数量

功能：
 检查金刚石数量。

格式：
 CHECKGAMEDIAMOND 控制符(<、>、 =) 点数

GAMEDIAMOND (+,-,=) 值
<$GAMEDIAMOND>

;==========================================
#IF
CHECKGAMEDIAMOND> 50
#SAY
你的金刚石超过50点
#ELSESAY
你的金刚石少于50点
;==========================================

功能：
 检查灵符数量。

格式：
 CHECKGAMEGIRD 控制符(<、>、 =) 点数

GAMEGIRD (+,-,=) 值
<$GAMEGIRD>

;==========================================
#IF
CHECKGAMEGIRD > 50
#SAY
你的灵符超过50点
#ELSESAY
你的灵符少于50点
;==========================================

功能：
 检查荣誉数量。

格式：
 CHECKGAMEGLORY 控制符(<、>、 =) 点数

GAMEGLORY (+,-,=) 值
<$GAMEGLORY>

;==========================================
#IF
CHECKGAMEGLORY > 50
#SAY
你的荣誉超过50点
#ELSESAY
你的荣誉少于50点
;==========================================


检查人物HP值

功能：
用来检查人物HP值的上限及下限值

命令格式：
 CHECKHP 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限

======================
#if
CHECKHP > 29 < 41
#say
你的HP值大于30-40
======================


检查人物MP值

功能：
 用来检查人物MP值的上限及下限值

命令格式：
 CHECKMP 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限

==========================
#if
CHECKMP > 29 < 41
#say
你的MP值大于30-40
==========================


检查人物背包空格数

功能：
检查人物背包空格数

命令：
 CheckBagSize 数量

=======================
[@checkbagsize]
#if
CHECKBAGSIZE 5
#say
身上有5个空格
#elsesay
身上的空格不够。
=======================


检查人物称号的数量

功能：
 检查人物称号的数量

格式：
 CHECKFENGHAOCOUNT 操作符(<,>,=) 数量(0-30)

[@main]
#IF
CHECKFENGHAOCOUNT > 9
#SAY
你已经有了10个称号


检查人物当前经验值

功能：
 检查玩家当前经验值。

格式：
CHECKEXP 控制符(=,>,<) 经验值(1 - 4000000000)< /FONT>

;==========================================
;检查人物的经验值是否等于指定值
[@checkexp2]
#IF
CHECKEXP = 5000
#SAY
您的经验值等于5000。
#ELSESAY
您的经验值不等于5000。
;==========================================

;==========================================
;检查人物的经验值是否大于指定值
[@checkexp2]
#IF
CHECKEXP > 5000
#SAY
您的经验值大于5000级。
#ELSESAY
您的经验值不大于5000。
;==========================================

;==========================================
;检查人物的经验值是否小于指定值
[@checkexp2]
#IF
CHECKEXP < 5000
#SAY
您的经验值小于5000级。
#ELSESAY
您的经验值不小于5000。
;==========================================


检查人物道术

功能：
 用来检查人物道术的上限及下限值

命令格式：
 CHECKSC 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限

================
#if
CHECKSC > 29 < 41
#say
你的道术大于30-40
================


检查人物的会员等级

功能：
 可以检查人物的会员等级。

格式：
CHECKMEMBERLEVEL 类型(1-65535) 控制符(=,>,<) 等级数(1 - 65535)

;==========================================
;检查人物的会员等级是否为指定等级
[@checkmemberlevel0]
#IF
CHECKMEMBERLEVEL 2 = 5
#SAY
您的会员等级为5。
#ELSESAY
您的会员等级不为5。
;==========================================

;==========================================
;检查人物的会员等级是否大于指定等级
[@checkmemberlevel1]
#IF
CHECKMEMBERLEVEL 2 > 5
#SAY
您的会员等级大于5。
#ELSESAY
您的会员等级不大于5。
;==========================================

;==========================================
;检查人物的会员等级是否小于指定等级
[@checkmemberlevel1]
#IF
CHECKMEMBERLEVEL 2 < 5
#SAY
您的会员等级小于5。
#ELSESAY
您的会员等级不小于5。
;==========================================


检查人物的会员类型

功能：
可以检查人物的会员类型。

格式：
CHECKMEMBERTYPE 控制符(=,>,<) 类型数(1 - 65535)

;==========================================
;检查人物的会员类型是否为指定类型
[@checkmember0]
#IF
CHECKMEMBERTYPE = 5
#SAY
您的会员类型为5。
#ELSESAY
您的会员类型不为5。
;==========================================

;==========================================
;检查人物的会员类型是否大于指定类型
[@checkmember1]
#IF
CHECKMEMBERTYPE > 5
#SAY
您的会员类型大于5。
#ELSESAY
您的会员类型不大于5。
;==========================================

;==========================================
;检查人物的会员类型是否小于指定类型
[@checkmember1]
#IF
CHECKMEMBERTYPE < 5
#SAY
您的会员类型小于5。
#ELSESAY
您的会员类型不小于5。
;==========================================


检查人物的游戏点数

功能：
 用于配合泡点功能，检查当前人物身上有多少点数。

格式：
 CHECKGAMEPOINT 控制符(<、>、 =) 点数

;==========================================
#IF
CHECKGAMEPOINT > 50
#SAY
你的游戏点超过50点
#ELSESAY
你的游戏点少于50点
;==========================================

功能：
 检查当前人物身上有多少游戏币。

格式：
 CHECKGAMEGOLD 控制符(<、>、 =) 点数

;==========================================
#IF
CHECKGAMEGOLD > 50
#SAY
你的游戏币超过50点
#ELSESAY
你的游戏币少于50点
;==========================================


检查人物的转生等级

功能：
 检查人物的转生等级

命令格式:
 CHECKRENEWLEVEL 控制符(=,>,<) 转生等级数(1 - 255)

;==========================================
;检查人物的转生等级是否等于指定级别
[@checklevel0]
#IF
CHECKRENEWLEVEL = 5
#SAY
您的转生等级等于5级。
#ELSESAY
您的转生等级不等于5级。
;==========================================

;==========================================
;检查人物的转生等级是否大于指定级别
[@checklevel1]
#IF
CHECKRENEWLEVEL > 5
#SAY
您的转生等级大于5级。
#ELSESAY
您的转生等级不大于5级。
;==========================================

;==========================================
;检查人物的转生等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKRENEWLEVEL < 5
#SAY
您的转生等级小于5级。
#ELSESAY
您的转生等级不小于5级。
;==========================================


检查人物登录IP

功能：
检查人物登录IP.

格式：
 CHECKIPLIST 会员.txt

;==========================================
;按IP检查
[@checkiplist0]
#IF
CHECKIPLIST IP会员.txt
#SAY
你是会员
#ELSESAY
你不是会员
;==========================================


检查人物登录帐号

功能：
检查人物登录帐号.

格式：
 CHECKACCOUNTLIST 帐号.txt

;==========================================
;按登录帐号检查
[@checkaccountlist0]
#IF
CHECKACCOUNTLIST 帐号.txt
#SAY
你是会员
#ELSESAY
你不是会员
;==========================================


检查人物等级（改进）

功能：
可以更为方便地检查玩家等级。

格式：
CHECKLEVELEX 控制符(=,>,<) 等级数(1 - 65535)

;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKLEVELEX = 50
#SAY
您的等级等于50级。
#ELSESAY
您的等级不等于50级。
;==========================================

;==========================================
;检查人物的等级是否大于指定级别
[@checklevel1]
#IF
CHECKLEVELEX > 50
#SAY
您的等级大于50级。
#ELSESAY
您的等级不大于50级。
;==========================================

;==========================================
;检查人物的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKLEVELEX < 50
#SAY
您的等级小于50级。
#ELSESAY
您的等级不小于50级。
;==========================================


检查人物附加属性点数

功能：
检查人物附加属性点数

格式：
CHECKBONUSPOINT 控制符(=,>,<) 点数

相关命令：
复位属性点数：RESTBONUSPOINT
调整属性点数：BONUSPOINT


检查人物攻击力

功能：
用来检查人物攻击力的上限及下限值

命令格式：
 CHECKDC 控制符(<、>、 =) 攻击下限 控制符(<、>、 =) 攻击上限

====================
#IF
CHECKDC > 29 < 41
#say
你的攻击力大于30-40
====================


检查人物技能(扩展)

检查人物技能

功能：
检查人物技能

格式：
CHECKSKILL 技能名称 检测符(<,>,=) 等级 是否检测强化技能(0或为空时为技能等级,1为强化技能等级)

例：
[@main]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重

相关命令：
练习技能：ADDSKILL
删除技能：DELSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL


检查人物名称是否与IP匹配

功能：
可以检查登录帐号与IP是否匹配。

格式：
CHECKNAMEIPLIST NameIPList.txt

;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKNAMEIPLIST NameIPList.txt
#SAY
您的登录帐号与指定IP匹配。
#ELSESAY
您的登录帐号与指定IP不匹配。
;==========================================

列表文件格式:
此文件们于目录：Mir200\Envir\

NameIPList.txt

;==========================================
;人物名称 IP
GM001 192.168.1.123
GM002 192.168.1.124
;==========================================


检查人物魔法力

功能：
用来检查人物魔法力的上限及下限值

命令格式：
 CHECKMC 控制符(<、>、 =) 攻击下限 控制符(<、>、 =) 攻击上限

======================
#if
CHECKMC > 29 < 41
#say
你的魔法力大于30-40
======================


检查人物身上指定位置是否戴物品

功能：
检查人物身上指定位置是否戴物品

命令：
 CHECKUSEITEM 物品位置(0-12)

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

[@checkUseItem]
#if
CHECKUSEITEM 0
#say
你身上穿了衣服。
#elsesay
你还没穿衣服呢。


检查人物身上装备类型

功能：
用来检查人物身上戴物品类型，因为不同类型物品的附加属性值位置不一样，在升级装备物品性时用来控制指定属性值。
命令格式：
 CHECKITEMTYPE 物品位置 物品类型

物品位置：
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

物品类型：
5 武器
6 武器
10 衣服
11 衣服
15 头盔
19 项链
20 项链
21 项链
22 戒指
23 戒指
24 手镯
25 护身符
26 手镯
28 马牌
29 天使
30 照明物
52 鞋子
53 宝石
54 腰带


检查人物声望点

功能：
检查人物声望点

命令格式:
CHECKCREDITPOINT 控制符(=,>,<) 声望点数(1 - 255)< /FONT>

;==========================================
;检查声望点是否等于指定点数
[@CHECKCREDITPOINT0]
#IF
CHECKCREDITPOINT = 50
#SAY
您声望点等于50级。
#ELSESAY
您声望点不等于50级。
;==========================================

;==========================================
;检查声望点是否大于指定点数
[@CHECKCREDITPOINT1]
#IF
CHECKCREDITPOINT > 50
#SAY
您声望点大于50级。
#ELSESAY
您声望点不大于50级。
;==========================================

;==========================================
;检查声望点是否小于指定点数
[@CHECKCREDITPOINT2]
#IF
CHECKCREDITPOINT < 50
#SAY
您声望点小于50级。
#ELSESAY
您声望点不小于50级。
;==========================================


检查人物是否付费

#if
CHECKPAYMENT 2
#say


检查人物是否加入行会

功能：
可以检查玩家是否加入行会。

格式：
============================
#IF
HAVEGUILD
#SAY
你已经加入了行会！
#ELSESAY
你没加入行会！
============================


检查人物是否为管理员

功能：
检查人物是否为管理员

格式：
;==========================================
;检查人物是否为系统管理员
[@IsSysOp]
#IF
ISADMIN
#SAY
你是系统管理员。
#ELSESAY
你不是系统管理员。
;==========================================


检查人物是否为行会掌门人

功能：
可以检查玩家是否为行会老大。

格式：
============================
#IF
ISGUILDMASTER
#SAY
你是行会老大！
#ELSESAY
你不是行会老大！
============================


检查人物是否为沙城成员

功能：
可以检查玩家是否为沙城成员。

格式：
============================
#IF
ISCASTLEGUILD
#SAY
你是沙城成员！
#ELSESAY
你不是沙城成员！
============================


检查人物是否为沙城城主

功能：
可以检查玩家是否为沙城老大。

格式：
============================
#IF
ISCASTLEMASTER
#SAY
你是沙城老大！
#ELSESAY
你不是沙城老大！
============================


检查人物是否为新人

功能：
可以检查玩家是否为新人（即刚注册进入游戏的人，退出后再进就不是新人了）。

格式：
============================
#IF
ISNEWHUMAN
#SAY
你是新人！
#ELSESAY
你不是新人！
============================


检查人物是否学习了某项魔法

#IF
CheckMagicName 烈火剑法
#SAY
你已经学会了烈火剑法.


检查人物是否在攻城区域[!]

功能: 检查人物是否在攻城区域
格式: CheckInWarArea

#IF
CheckInWarArea
#SAY
在攻城区域.


检查人物在列表中的位置

功能：
检查人物在列表中的位置。

格式：
 CHECKNAMELISTPOSITION List.txt (> < = ) 10 P0

;==========================================
;
[@checkpostion0]
#IF
CHECKNAMELISTPOSITION AccountIPList.txt < 10 P0
#SAY
您在前10名，当前排名为<$STR(P0)>。
#ELSESAY
您不在前10名，当前排名为<$STR(P0)>。。
;==========================================


检查是否存在某个称号

功能：
 检查是否存在某个称号

格式：
 CHECKTITLE 称号名称

[@main]
#IF
CHECKTITLE 称号一
#SAY
你已经有了“称号一”的称号


检查是否为组长

功能：
检查人物是否为编组的组长
格式：
ISGROUPMASTER
[@checkgroup]

#if
ISGROUPMASTER
#say
你是组长
#elsesay
你不是组长

相关命令：
编组地图传送：GROUPMAPMOVE
编组地图随机传送：GROUPMOVE


检查是否在某地图

ISONMAP 地图名称


检查一个地图内人数

功能：
可以检查一个地图内的人物数量。

格式：
CheckMapHumenCount地图号 ('<' '>' '=')数量

;==========================================
[@Main]
#if
CheckMapHumanCount 3 < 100
#say
地图3内人数小于100人
#elsesay
地图3内人数多于100人

;==========================================


检查装备绑定状态[!]

功能：检查装备绑定状态
格式：CheckItemState 装备位置(-1~13,-1时为OK框中物品) 项目(0-6)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出 6 丢弃消失

[@衣服禁止扔]
#IF
CheckItemBind 0
#ACT
GOTO @禁止扔
#ELSEACT
SENDMSG 6 请先绑定

[@禁止扔]
#IF
CheckItemState 0 0
#ACT
SENDMSG 6 该装备已经设置过禁止扔
#ELSEACT
SetItemState 0 0 1
SENDMSG 6 该装备禁止扔


检查字符串是否在指定文件中 包含检测 [!]

检查字符串是否在指定文件中 包含检测 检测的字符串不需要完全相同，文件里的字符包含检测的字符，就会成功

[@CheckContainsTextList]
#IF
CheckContainsTextList ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)>
#SAY
列表里的某一行字符包含<$STR(S2)>
#ELSESAY
列表里的某一行字符包含<$STR(S2)>

[@CheckContainsTextListEx]
#IF
CheckContainsTextListEx ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)>
#SAY
<$STR(S2)>包含列表里某一行字符
#ELSESAY
<$STR(S2)>不包含列表里某一行字符

CheckContainsTextList 和 CheckContainsTextListEx 区别

CheckContainsTextList 列表文件里保存的是完整的字符。检测列表里的某一行字符是否包含检测的关键字

CheckContainsTextListEx 列表文件里保存的是关键字。检测字符是否包含列表里的某一行关键字


检查字符串是否在指定文件中[!]

[@旧格式_不区分大小写]
#IF
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S$2)>
#SAY
<$STR(S$2)>在列表中
#ELSESAY
<$STR(S$2)>不在列表中

[@新格式_区分大小写]
#IF
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S$2)> <$STR(S$3)>
#SAY
卡号密码正确
#ELSESAY
卡号密码错误

S$2和S$3的值在“10元卡号.txt”文本中以空格分开


脚本检测命令取反 NOT [!]
格式:NOT 命令 > 50 //检测人物物品算不大于50

例子:

[@main]
#IF
NOT CHECKGAMEGOLD > 50 //检测人物元宝算不大于50
#ACT
SENDMSG 5 你身上的元宝不大于50

[@main_1]
#IF
NOT CHECKLEVELEX > 80 //检测人物等级不大于80级
#ACT
SENDMSG 5 你的等级不大于80级

[@main_2]
#IF
NOT EQUAL P0 5 //检测变量P0是否不等于5
#ACT
SENDMSG 5 <$STR(P0)>变量不等于5

[@main_3]
#IF
NOT H.CHECKLEVELEX > 80 //检测英雄等级不大于80级
#ACT
SENDMSG 5 你的英雄等级不大于80级


新物品绑定检测[!]

CheckItemBind,检测物品是否已经绑定
格式:CheckItemBind 装备位置(-1~13,-1时为OK框中物品)

例子:

[@衣服绑定]
#IF
CheckItemBind 0
#ACT
SENDMSG 6 该装备已经绑定过了
#ELSEACT
SetItemBind 0 1
SENDMSG 6 绑定完成


字符串比较处理

功能：
字符串比较处理。

格式：
CheckContainsText 字符 字符串检查 //检查字符串是否包涵在另外一个字符串中.
CompareText 字符 字符 // 比较两个字符串是否一样

;==========================================
检查字符串是否包涵在另外一个字符串中
[@Test]
#IF
CheckContainsText www.gameofmir.com gameofmir.com
#Say
包涵
#elsesay
不包涵
;==========================================

;==========================================
比较两个字符串是否一样，不区分大小写
[@Test]
#IF
CompareText www.gameofmir.com www.gameofmir.com
#Say
一样
#elsesay
不一样
;==========================================


DEC对字符型变量操作命令[!]

DEC对字符型变量操作命令。
MOV命令做了一些改进。

[@Main]
#ACT
MOV S1 GameOfMir引擎M2
MOV S2 GameOfMir引擎M2
DEC S1 GameOfMir引擎 ;删除S1中的“GameOfMir引擎”字符串

decex

支持对程序变量（如U变量、D变量）操作，例如：decex u<$str(n$变量值)> 123


查看人物私聊信息

此功能可以实时侦听指定人物的私聊信息，将指定人物发送及接收的私聊信息发送到自己。

命令格式：
@ViewWhisper 人物名称

重复输入取消侦听私听信息。


程序变量说明[!]

P0-P99 (私人变量，数字型) 打开对话框重置为0。
D0-D99 (私人变量，数字型) 下线不保存.摇筛子变量.
M0-M99 (私人变量，数字型) 下线不保存.切换地图清空.
N0-N99 (私人变量，数字型) 下线不保存.小退归0.
S0-S99 (私人变量，字符型) 下线不保存.小退清空.
I0-I99 (全局变量，数字型) 下线不保存.小退归0.
G0-G499 (全局变量，数字型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
A0-A499 (全局变量，字符型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
U0-U49 (私人变量，数字型) 可保存。（存放在人物数据库Mir.db里面）
T0-T49 (私人变量，字符型) 可保存。（存放在人物数据库Mir.db里面）

注意： 自定义变量名称不要以P、D、M、N、S、I、G、A开头

【变量属性】

P(0-9)

『属性说明』：该变量只对当前对话NPC内有效果。如果中途点其他NPC或者对话产生close、关闭时所有P变量均归0。该变量取值范围：（0-？）根据M2最大值不同
『用法』：该变量没有NPC间传递性作为临时变量多重复使用效果十分好。而且因为脚本命令有对该变量进行加/减/赋值/随机取值等运算，他和goto的配合可以使脚本中出现仿for循环的效果。并且因为他不传递的性质其
随机取值也能与RANDOM媲美。

D(0-9)

『属性说明』：该变量在人物不下线时对全局NPC通用传递。该变量取值范围：同P变量
『用法』：既有像[0-？]变量一样的人物属性私有变量的效果又有像P变量一样的运算功能！唯一不足就是下线 后该变量会被清空。可是如果配合上[000]变量或者namelist变量的记录性。实在是功能强大的个人隐私属性！

G(0-499)

『属性说明』：该变量不属于人物属性范围，对于全服务器内该变量唯一并且全局NPC通用传递。该变量取值范围：同P变量
『用法』：这个变量是唯一的一个不属于任何人物而属于服务器的变量，该变量通过任何人的运算均产生效果。而且不保存在任何人的属性中。（存放在Mir200/GlobalVal.ini文件里面）

A(0-499)

『属性说明』：该变量不属于人物属性范围，对于全服务器内该变量唯一并且全局NPC通用传递。该变量取值范围：同D变量
『用法』：这个变量是唯一的一个不属于任何人物而属于服务器的变量，该变量通过任何人的运算均产生效果。而且不保存在任何人的属性中。（存放在Mir200/GlobalVal.ini文件里面）


脚本命令详解[!]

===========================================================

脚本命令详解
====================********************************========================

[@段] ;段用英文或数字表示

goto @段 ;跳转到指定段，开始执行相当于B中的goto语句

#say 语句 ;语句设定为字符，不用加任何定界符

#act 执行命令 ;符合3.0规定的任何系统已定义命令

give 物品 数量 ;给多少东西,除了物器数据库中有的物品，还有金币，

take 物品 数量 ;同上，只是与上面相反，一个是给东西，一个是收回东西

map 地图名 ;移动到这个地图的随机坐标，地图名为地图的数字人码

mapmove 地图名 坐标A 坐标B ;同上，只是指定了坐标

monclear 地图名 ;清除这个地图上刷的怪物

MonGen 怪物名称 数量 时间 ;刷怪物，与刷怪角本用法相同

TimeRecall 数值 ;数值为分钟，定义进入某地的时间限制。

BreakTimeRecall ;中断上面那个语句设定的时间

hairstyle 数值 ;改变头发类型

haircolor 红值 绿值 蓝值 ;值域为0 ~ 255 设定头发颜色

close ; 关闭对话框

======================****************************========================
---------------------- 程 序 中 的 变 量 与 常 量 ------------------------
======================****************************========================

变量 ;变量用字母表示，在程序中可以赋任何数据 名称只限于P0-P9,D0-D9
mov 变量 数值 ;给变量赋值

inc 变量 数值 ;让变量自动加指定数值到变量，相当于程序中的x=x+n

sum 变量A 变量B ;变量求和不要与int混淆,需要下面的组合语名才能实现

MOV 变量X 0 ;变量X，初值。

sum 变量A 变量B ;X=A+B

sum 变量C ;X=X+C 最后在程序中得到的是X值，实际X=A+B+C

;如果只写中间一句是无意义的，只能导致错误

movr 变量 数值 ;定义随机变量，变量值为 “0 到 数值”

random 数值 ;当数值=随机数时则为1否则为0

<$STR(变量)> ;显示变量时用，可以将变量值显示在游戏里，用在 #say后面。

=========================*******************************========================
------------------------- 程 序 中 的 逻 辑 判 断 语 句 ------------------------
=========================*******************************========================

[n] ;n为1-1024正整数，是逻辑变量，有0值和1值，初始0值

#IF
条件--执行
#elsesay 或者 #elseact
否定--执行 ;相当于程序中的条件判断

SET [n] 1 ;设置逻辑变量为真

--------------------关于reset命令的详解------------------------------------

reset [XXX] 7 意思是将从XXX开始的7个变量回复到原始值0

比如：reset [100] 7 就是把100 101 102 103 104 105 106 107这7个变量赋值为0。

它等同与：set [100] 0

set [101] 0

set [102] 0

set [103] 0

set [104] 0

set [105] 0

set [106] 0

--------------------------------------------------------

Check [n] 1 ;测试逻辑变量是否为真，可以测试是否已经完成了任务

small 变量 数值 ;如果“变量 < 数值”则为1否则为0

large 变量 数值 ;如果“变量 > 数值”则为1否则为0

equal 变量 数值 ;如果“变量 = 数据”则为1否则为0

checkjob Warr(Wizard、Taos) ;测试职业 成功为1否则为0

checkgold 数值 ;拥有金币数>=数值为1否则为0

checklevel 数值 ;人物等级>=数值为1否则为0

checkitem 物品 数值 ;测试拥用物品的数量

genderman ;测试性别为男，如果为男则为1否则为0

checkbaggage ;测试背包是否已满，满时为1否则为0

checkpkpoint 数值 ;数值为PK值，PK值数>值时为1否则为0

checkluckypoint 数值 ;同上，只是测的是幸运值

checkmonmap 地图名 数值 ;同上，只是测的是怪物数量

checkduraeva 物品名 数值 ;同上，只是测试有品质的物品的品质

checkhum 地图名 数值 ;同上，测试这个地图的人数

checkitemw 物品 检测身上所带的物品

takew 物品 直接从身上回收物品

checkmagic 技能名称 检测已经修炼的技能

脚本大全 [喜欢脚本的来]
商用NPC开头解释(部分,补足请补足)
%100 代表买东西是原价格还是双倍价格
+40 买肉
+1 卖肉
+43 武器有关(修)
+15 头盔
+10 买衣服
+11 修衣服
+26 修手镯类
+0 买各种药水
+42 卖各种药水
+30 蜡烛等.
+25 特殊水
+3 买卷轴,书类
+4 卖书类
+19 项链
+20 项链
+21 项链
+22 买戒指
+23 卖戒指
+24 买手镯
+26 卖手镯
+5 修炼武器或买武器
+6 修炼武器或卖武器
================================

checkjob (Warr, Wizard, Taos) ;测试职业
checkgold (金币数) ;测试金币
checklevel (等级) ;测试等级
checkitem (物品名) (数量) ;测试物品及数量
give gold (金币数) ;给钱
give (物品名) (数量) ;给物及数量
take gold (金币数) ;拿走钱
take (物品名) (数量) ;拿走物及数量
checkpkpoint (pk值) ;测试PK值
checkluckypoint (幸运值) ;幸运值正值为好,负值为差
checkduraeva (物品名) (数值) ;一般测试矿物等物品的品质
checkhum (地图名) (数值) ;测试这个地图的人数
checkmonmap (地图名) (数值) ;测试这个地图的怪物数
map (地图名) ;移动到这个地图
mapmove (地图名) (坐标A) (坐标B) ;移动到这个地图指定坐标
monclear 地图清除
close 关闭对话框
TimeRecall (设定时间值) ;分钟,一般指进入地图时间限制
BreakTimeRecall ;中断设定时间
ExchangeMap (地图名) ;与指定地图里的人交换位置
daytime sunset ;一天时间
checkbaggage ;测试背包满没
small (变量) (数值) ;测试变量是不是小于指定数值
large (变量) (数值) ;测试变量是不是大于指定数值
equal (变量) (数值) ;测试变量是不是等于指定数值
mov (变量) (数值) ;让变量等于指定数值
sum (变量A) (变量B) ;A+B 注意,如果还要家第3个数直接换行写sum (变量C)
注:关于SUM的详解
首先有MOV (变量X) 0 ;(变量X)清0
sum (变量A) (变量B) ;X=A+B
sum (变量C) ;X=X+C
movr (变量) (数值) ;随机把指定数值以下的数(正数)给变量
inc (变量) (数值) ;让变量自动加指定数值到变量

;----------------------------------------------------------------------------------
playdice (骰子数) @xxx ;玩骰子,跳转到标签[@xxx]
; 整一个骰子来摇； 变量D0是第一个骰子最后的点数，D1是第2个骰子，顺序往后
; 如果没有给初始值（初值为0），则骰子最后没有点数即看不到
#act
; 1个骰子摇
mov D0 3
playdice 1 @XXX
; 3个骰子摇
mov D0 1
mov D1 3
mov D2 5
playdice 3 @XXX
;----------------------------------------------------------------------------------

random (随机数) ;一般用在#IF语句中作为触发#IF机率,有时随机数=并列#IF语句数用 于随机多项选择,例如: #IF RANDOM 3 #SAY() #ELSEACT
Check [条件数] 1 ;测试[条件数]触发与否 1(触发)
SET [条件数] 1 ;设置[条件数]触发
Monclear 地图 清理这个地图！
Param1 地图 地图名
Param2 横坐标 坐标
Param3 纵坐标 坐标
MonGen 怪物名称 数量 时间
TimeRecall 时间 时间限制

二。脚本变量：
<$USERNAME> 当前用户名
<$GUILDWARFEE>行会战金币数
<$LORD>沙巴克行会头名
<$OWNERGUILD>沙巴克行会名
<$UPGRADEWEAPONFEE>升级武器价格
<$USERWEAPON> 放在对话框里的武器名字
<$STR(变量)> 把变量转换为字符型 random (随机数) ;一般用在#IF语句中作为触发#IF机率,有时随机数=并列
#IF语句数用 于随机多项选择,例如: #IF RANDOM 3 #SAY() #ELSEACT


关于国战

Envir\Nations\Nations.ini中的NationalNames1 -- NationalNames100是国家的名字,只有定义了国家名字之后加入国家才有效!

Nations.ini

[Names]
NationalNames1=
NationalNames2=
NationalNames3=
NationalNames4=
NationalNames5=
NationalNames6=
NationalNames7=
NationalNames8=
NationalNames9=
NationalNames10=
NationalNames11=
NationalNames12=
NationalNames13=
NationalNames14=
NationalNames15=
NationalNames16=
NationalNames17=
NationalNames18=
NationalNames19=
NationalNames20=
NationalNames21=
NationalNames22=
NationalNames23=
NationalNames24=
NationalNames25=
NationalNames26=
NationalNames27=
NationalNames28=
NationalNames29=
NationalNames30=
NationalNames31=
NationalNames32=
NationalNames33=
NationalNames34=
NationalNames35=
NationalNames36=
NationalNames37=
NationalNames38=
NationalNames39=
NationalNames40=
NationalNames41=
NationalNames42=
NationalNames43=
NationalNames44=
NationalNames45=
NationalNames46=
NationalNames47=
NationalNames48=
NationalNames49=
NationalNames50=
NationalNames51=
NationalNames52=
NationalNames53=
NationalNames54=
NationalNames55=
NationalNames56=
NationalNames57=
NationalNames58=
NationalNames59=
NationalNames60=
NationalNames61=
NationalNames62=
NationalNames63=
NationalNames64=
NationalNames65=
NationalNames66=
NationalNames67=
NationalNames68=
NationalNames69=
NationalNames70=
NationalNames71=
NationalNames72=
NationalNames73=
NationalNames74=
NationalNames75=
NationalNames76=
NationalNames77=
NationalNames78=
NationalNames79=
NationalNames80=
NationalNames81=
NationalNames82=
NationalNames83=
NationalNames84=
NationalNames85=
NationalNames86=
NationalNames87=
NationalNames88=
NationalNames89=
NationalNames90=
NationalNames91=
NationalNames92=
NationalNames93=
NationalNames94=
NationalNames95=
NationalNames96=
NationalNames97=
NationalNames98=
NationalNames99=
NationalNames100=


脚本变量大全[!]

脚本变量

人物信息

变量名称 | 说明
<$USERNAME> | 人物名称
<$GUILDNAME> | 行会名称
<$RANKNAME> | 行会职位名称
<$LEVEL> | 等级
<$HP> | 生命值
<$AC> | 防御力
<$MAXAC> | 最高防御力
<$MAC> | 魔法防御力
<$MAXMAC> | 最高魔法防御力
<$DC> | 物理攻击力
<$MAXDC> | 最高物理攻击力
<$MC> | 魔法力
<$MAXMC> | 最高魔法力
<$SC> | 道术
<$MAXSC> | 最高道术
<$EXP> | 当前经验值
<$MAXEXP> | 升级经验值
<$MAXHP> | HP上限
<$MAXMP> | MP上限
<$DIR> | 方向
<$PKPOINT> | PK点数
<$CREDITPOINT> | 声望点数
<$GOLDCOUNT> | 金币数量
<$GAMEGOLD> | 游戏币数
<$GAMEPOINT> | 游戏点数
<$HW> | 腕力
<$MAXHW> | 最高腕力
<$BW> | 背包重量
<$MAXBW> | 最高背包重量
<$WW> | 负重力
<$MAXWW> | 最高负重
<$HUNGER> | 饥饿程度
<$LOGINTIME> | 登录时间
<$LOGINLONG> | 登录时长
<$speed> | 主角当前的移动速度
<$DRESS> | 衣服
<$WEAPON> | 武器
<$RIGHTHAND> | 蜡烛
<$HELMET> | 头盔
<$NECKLACE> | 项链
<$RING_R> | 右戒指
<$RING_L> | 左戒指
<$ARMRING_R> | 右手镯
<$ARMRING_L> | 左手镯
<$BUJUK> | 护身符
<$BELT> | 腰带
<$BOOTS> | 鞋子
<$CHARM> | 宝石
<$HAT> | 斗笠
<$DRUM> | 军鼓
<$HORSE> | 马牌
<$SHIELD> | 盾牌
<$SDRESS> | 时装衣服
<$SWEAPON> | 时装武器
<$SUCKDAMAGE> | 伤害吸收值 脚本命令USEBONUSPOINT增加的，该值保存人物数据库里，下线不消失
<$SUCKDAMAGEPOINT> | 伤害吸收值 脚本命令SETSUCKDAMAGE增加的，下线消失
<$G_DRESS> | 衣服 改名名称
<$G_WEAPON> | 武器 改名名称
<$G_RIGHTHAND> | 蜡烛 改名名称
<$G_HELMET> | 头盔 改名名称
<$G_NECKLACE> | 项链 改名名称
<$G_RING_R> | 右戒指 改名名称
<$G_RING_L> | 左戒指 改名名称
<$G_ARMRING_R> | 右手镯 改名名称
<$G_ARMRING_L> | 左手镯 改名名称
<$G_BUJUK> | 护身符 改名名称
<$G_BELT> | 腰带 改名名称
<$G_BOOTS> | 鞋子 改名名称
<$G_CHARM> | 宝石 改名名称
<$G_HAT> | 斗笠 改名名称
<$G_DRUM> | 军鼓 改名名称
<$G_HORSE> | 马牌 改名名称
<$G_SHIELD> | 盾牌 改名名称
<$G_SDRESS> | 时装衣服 改名名称
<$G_SWEAPON> | 时装武器 改名名称
<$CASTLENAME> | 沙城名称
<$GAMEDIAMOND> | 金刚石
<$GAMEGIRD> | 灵符
<$MAP> | 当前地图代码
<$RELEVEL> | 显示转生等级
<$STATSERVERTIME> | 显示M2启动时间
<$RUNDATETIME> | 开区间隔时间
<$KILLER> | 杀人者变量
<$RANDOMNO> | 随机值变量
<$X> | 人物X坐标
<$Y> | 人物Y坐标
<$USERALLNAME> | 人物完整名称
<$GAMEGLORY> | 人物荣誉值
<$MapTitle> | 取地图名称
<$GetExp> | 人物当前获得经验变量
<$CASTLEGAMEGOLD> | 显示沙城税收的元宝值
<$USERID> | 人物登录帐号
<$KILLMONNAME> | 人物杀死的怪物名称
<$KILLMONX> <$KILLMONY> | 人物杀死怪物的坐标
<$HIT> | 准确
<$SPD> | 敏捷
<$HITSPD> | 攻速
<$weekday> | 当前周几 1-7 对应周一至周日
<$YEAR> | 当前年份
<$MONTH> | 当前月份
<$DAY> | 当前日期
<$HOUR> | 当前小时
<$MINUTE> | 当前分钟
<$SECOND> | 当前秒
<$TEAM0>..<$TEAMX> | 用于显示组队成员,<$TEAM0>代表队长,成员从<$TEAM1>开始
<$STNAME> | 师徒名称变量
<$KILLMONEXPRATE> | 杀怪经验倍数
<$KILLMONEXPRATETIME> | 杀怪经验倍数时长
<$GAMEGOLDEX> | 新游戏点数
<$REVIVALTIME> | 复活间隔变量
<$POWERRATE> | 复当前攻击力倍数
<$POWERRATETIME> | 当前攻击力倍数剩余时间
<$GROUPMEMBERCOUNT> | 当前组队人数
<$X> | 人物当前坐标X
<$Y> | 人物当前坐标Y
<$VALUE1>..<$VALUE11> | 人物元素的属性值的常量共11个。1到11
<$SCREENWIDTH> | 分辨率 宽
<$SCREENHEIGHT> | 分辨率 高
<$PASSWORD> | 注册账号时用户输入的密码
<$BIRTHDAT> | 注册账号时用户输入的生日
<$QUIZ1> | 注册账号时用户输入的问题1
<$ANSWER1> | 注册账号时用户输入的答案1
<$QUIZ2> | 注册账号时用户输入的问题2
<$ANSWER2> | 注册账号时用户输入的答案2
<$EMAIL> | 注册账号时用户输入的邮箱
<$PHONE> | 注册账号时用户输入的电话
<$MOBILEPHONE> | 注册账号时用户输入的手机
<$ACCOUNTUSERNAME> | 注册账号时用户输入的用户名
<$CURRTEMNAME> | 当前物品名称 指人物掉落或捡取的
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落或捡取的
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落或捡取的
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落或捡取的
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落或捡取的
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落或捡取的
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落或捡取的
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落或捡取的
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落或捡取的
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落或捡取的
<$CURRHERONAME> | 当前召唤出来的英雄名称，如果没有召唤英雄，该值为空
<$HERONAME> | 英雄名称。如果没有创建过英雄，该值为空
<$DEPUTYHERONAME> | 副将英雄名称。如果没有创建过副将英雄，该值为空
<$ServerName> | 服务器名字
<$PKPOWER> | 当前攻击造成的伤害

<$ATTACKMONSTER_MAXHP>

当前锁定怪物总血量

<$GODBLESSITEM1>~ <$GODBLESSITEM12>

生肖盒道具名称（对应1-12个位置）

<$ALLRECHARGE>

角色在当前服务器的充值总额

<$FriendsCount>

角色好友数

<$job>

(0：战士；1：法师；2：道士)

<$gender>

(0:男；1：女)

英雄信息

变量名称 | 说明
<$H.USERNAME> | 人物名称
<$H.LEVEL> | 等级
<$H.HP> | 生命值
<$H.AC> | 防御力
<$H.MAXAC> | 最高防御力
<$H.MAC> | 魔法防御力
<$H.MAXMAC> | 最高魔法防御力
<$H.DC> | 物理攻击力
<$H.MAXDC> | 最高物理攻击力
<$H.MC> | 魔法力
<$H.MAXMC> | 最高魔法力
<$H.SC> | 道术
<$H.MAXSC> | 最高道术
<$H.EXP> | 当前经验值
<$H.MAXEXP> | 升级经验值
<$H.MAXHP> | HP上限
<$H.MAXMP> | MP上限
<$H.DIR> | 方向
<$H.PKPOINT> | PK点数
<$H.HW> | 腕力
<$H.MAXHW> | 最高腕力
<$H.BW> | 背包重量
<$H.MAXBW> | 最高背包重量
<$H.WW> | 负重力
<$H.MAXWW> | 最高负重
<$H.HUNGER> | 饥饿程度
<$H.SUCKDAMAGE> | 伤害吸收值 脚本命令H.USEBONUSPOINT增加的，该值保存英雄数据库里，下线不消失
<$H.SUCKDAMAGEPOINT> | 伤害吸收值 脚本命令H.SETSUCKDAMAGE或SETHEROSUCKDAMAGE增加的，下线消失
<$H.DRESS> | 衣服 英雄
<$H.WEAPON> | 武器 英雄
<$H.RIGHTHAND> | 蜡烛 英雄
<$H.HELMET> | 头盔 英雄
<$H.NECKLACE> | 项链 英雄
<$H.RING_R> | 右戒指 英雄
<$H.RING_L> | 左戒指 英雄
<$H.ARMRING_R> | 右手镯 英雄
<$H.ARMRING_L> | 左手镯 英雄
<$H.BUJUK> | 护身符 英雄
<$H.BELT> | 腰带 英雄
<$H.BOOTS> | 鞋子 英雄
<$H.CHARM> | 宝石 英雄
<$H.HAT> | 斗笠 英雄
<$H.DRUM> | 军鼓 英雄
<$H.HORSE> | 马牌 英雄
<$H.SHIELD> | 盾牌 英雄
<$H.SDRESS> | 时装衣服 英雄
<$H.SWEAPON> | 时装武器 英雄
<$H.G_DRESS> | 衣服 改名名称 英雄
<$H.G_WEAPON> | 武器 改名名称 英雄
<$H.G_RIGHTHAND> | 蜡烛 改名名称 英雄
<$H.G_HELMET> | 头盔 改名名称 英雄
<$H.G_NECKLACE> | 项链 改名名称 英雄
<$H.G_RING_R> | 右戒指 改名名称 英雄
<$H.G_RING_L> | 左戒指 改名名称 英雄
<$H.G_ARMRING_R> | 右手镯 改名名称 英雄
<$H.G_ARMRING_L> | 左手镯 改名名称 英雄
<$H.G_BUJUK> | 护身符 改名名称 英雄
<$H.G_BELT> | 腰带 改名名称 英雄
<$H.G_BOOTS> | 鞋子 改名名称 英雄
<$H.G_CHARM> | 宝石 改名名称 英雄
<$H.G_HAT> | 斗笠 改名名称 英雄
<$H.G_DRUM> | 军鼓 改名名称 英雄
<$H.G_HORSE> | 马牌 改名名称 英雄
<$H.G_SHIELD> | 盾牌 改名名称 英雄
<$H.G_SDRESS> | 时装衣服 改名名称 英雄
<$H.G_SWEAPON> | 时装武器 改名名称 英雄
<$H.MAP> | 当前地图代码
<$H.RELEVEL> | 显示转生等级
<$H.X> | 人物X坐标
<$H.Y> | 人物Y坐标
<$H.USERALLNAME> | 人物完整名称
<$H.MapTitle> | 取地图名称
<$HeroGetExp> | 英雄当前获得经验变量
<$H.HIT> | 准确
<$H.SPD> | 敏捷
<$H.HITSPD> | 攻速
<$HEROGENDER> | 英雄性别
<$HEROJOB> | 英雄职业
<$HEROLEVEL> | 英雄级别
<$HERONAME> | 英雄名字
<$HMapTitle> | 英雄地图名字
<$HMAP> | 英雄地图编号
<$HX> | 英雄前坐标X
<$HY> | 英雄前坐标Y

天地结晶变量

变量名称 | 说明
<$GETCRYSTALEXP> | 天地结晶可提取的经验
<$GETCRYSTALNGEXP> | 天地结晶可提取的内功经验
<$CRYSTALEXP> | 天地结晶当前的经验
<$CRYSTALNGEXP> | 天地结晶当前的内功经验
<$CRYSTALLEVEL> | 天地结晶等级

人物内力变量

变量名称 | 说明
<$NH> | 内力
<$MAXNH> | 内力上限
<$NGEXP> | 内功经验
<$NGMAXEXP> | 内功升级经验
<$NGLEVEL> | 内功等级

英雄内力变量

变量名称 | 说明
<$H.NH> | 英雄内力
<$H.MAXNH> | 英雄内力上限
<$H.NGEXP> | 英雄内功经验
<$H.NGMAXEXP> | 英雄内功升级经验
<$H.NGLEVEL> | 英雄内功等级
 | 所有英雄的变量都是在人物的变量 前面加“H.” 例如：<$H.MAXHP> <$H.MAXMP>
<$H.VALUE1>..<$H.VALUE11> | 英雄元素的属性值的常量共11个。1到11

连击变量

变量名称 | 说明
<$NGLEVEL> | 内功等级
<$HEROPULSEXP> | 英雄经络经验
<$GETNGEXP> | 当前得到的内功经验
<$HEROGETNGEXP> | 英雄当前得到的内功经验

国家变量

变量名称 | 说明
<$NATIONNAME> | 国家名称
<$NATIONPEOPLE> | 国家人数

服务器信息

变量名称 | 说 明
<$SERVERNAME> | 服务器名字
<$SERVERIP> | 服务器IP地址
<$WEBSITE> | 游戏网址
<$BBSSITE> | 论坛网址
<$CLIENTDOWNLOAD> | 客户端程序下载地址
<$QQ> | 联系QQ号
<$PHONE> | 联系电话号码
<$BANKACCOUNT0> | 银行帐号信息
<$BANKACCOUNT1> | 银行帐号信息
<$BANKACCOUNT2> | 银行帐号信息
<$BANKACCOUNT3> | 银行帐号信息
<$BANKACCOUNT4> | 银行帐号信息
<$BANKACCOUNT5> | 银行帐号信息
<$BANKACCOUNT6> | 银行帐号信息
<$BANKACCOUNT7> | 银行帐号信息
<$BANKACCOUNT8> | 银行帐号信息
<$BANKACCOUNT9> | 银行帐号信息
<$GAMEGOLDNAME> | 游戏币名称
<$USERCOUNT> | 在线人数
<$DATETIME> | 当前日期时间
<$GAMEGOLDNAME> | 游戏币名称
<$HIGHLEVELINFO> | 最高等人物信息
<$HIGHPKINFO> | 最高PK点数人物信息
<$HIGHDCINFO> | 最高攻击力人物信息
<$HIGHMCINFO> | 最高魔法力人物信息
<$HIGHSCINFO> | 最高道术人物信息

<$timestamp>

时间戳变量

<$server>

服务器ID

宝宝变量

<$S.X> | 宝宝X坐标
<$S.Y> | 宝宝Y坐标

<$slaveAttackPower>

宝宝当前攻击造成的伤害变量


设置显示名称格式

一、显示名称设置方法

1、相关配置

配置文件：String.ini

以下为相关配置内容：

CastleGuildName=%guildname[%castlename(%rankname)]
NoCastleGuildName=%guildname(%rankname)
WarrReNewName=%chrname\*<圣>*
WizardReNewName=%chrname\*<神>*
TaosReNewName=%chrname\*<尊>*
ManDearName=%s的老公
WoManDearName=%s的老婆
MasterName=%s的师父
NoMasterName=%s的徒弟
HumanShowName=%chrname\%guildname\%dearname\%mastername

CastleGuildName 沙城成员显示行会格式
NoCastleGuildName 普通已加入行会人员显示行会格式

%guildname 行会名称
%castlename 城堡名称
%rankname 职位名称

WarrReNewName 武士转生后名称显示
WizardReNewName 法师转生后名称显示
TaosReNewName 道士转生后名称显示

%chrname 人物名称

ManDearName 结婚后男的显示名称
WoManDearName 结婚后女的显示名称

MasterName 师父显示名称
NoMasterName 徒弟显示名称

HumanShowName 显示完整名称格式

游戏中显示出来的名称是根据以上格式组合出来的，大家可以根据自己的要求，自行调行组合及格式。


物品绑定人物[!]

功能：
物品绑定人物

绑定类型:
帐号，角色名，IP

命令格式:
@BindUseItem 人物名称 物品类型 绑定类型
例：@BindUseItem 人物名称 武器 帐号
此时将指定的人物及其身上的武器绑定在该人的帐号上
========================================================

物品类型:
衣服，武器，照明物，项链，头盔，左手镯，右手镯，左戒指，右戒指，物品
腰带，鞋子，宝石

BindUseItem
显示绑定物品到人物信息

ShowUseItemInfo
显示人物身上带装备信息


物品位置[!]

物品位置:

;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
;==========================================


新增GM命令[!]

新增部分游戏相关命令

注：以下命令在(M2目录中)Command.ini文件中均可自由更改命令名称.

传送相关命令
@recall | 将人物召唤到自己身边
@Regoto | 传送到对方身边
@Ting | 将对方随机传送
@SuperTing | 将指定范围内人物随机传送
@Mapmove | 将指定地图所有人物传送到指定地图
@Move | 移动到指定地图
@PositionMove | 移动到指定地图座标
人物控制相关命令
@GameMaster | 进入/退出管理员模式
@Observer | 进入/退出隐身模式
@Superman | 进入/退出无敌模式
@Level | 调整自己的等级
@Kick | 将指定的人物踢下线
@Kill | 将指定的人物杀死
@Realive | 将死亡的人物复活
@Setpermission | 设置人物的游戏权限，可将普通人物提升为GM
@Info | 显示人物详细信息
@MobLevel | 显示身边所有怪物或人物信息
@FreePK | 清除指定人物的PK点
@PKpoint | 显示指定人物的PK点
@IncPkPoint | 增加指定人物的PK点
@AdjustLevel | 调整他人级别
@AdjustExp | 调整他人经验
怪物控制相关命令
@Mob | 在身边放置一个指定的怪物
@RecallMob | 召唤一个怪物为宝宝
@Mission | 设置怪物集中点(用于开展怪物攻城)
@MobPlace | 放置怪物，怪物向集中点集中，大刀守卫不攻击怪物(用于开展怪物攻城)
聊天信息相关命令
@DisableSendMsg | 将指定人物加入禁言列表，人物发信息只能自己看到别人看不到
@EnableSendMsg | 将指定人物从禁言列表中删除
@DisableSendMsgList | 显示禁言列表中的人物名称
@ViewWhisper | 查看指定人物的私聊信息
@MobNpc | 制造一个NPC（可不用重启M2做增加NPC制作脚本）；
@DelNpc | 删除NPC
重新加载设置相关命令
@ReloadAdmin | 重新加载管理员列表
@ReloadNpc | 重新加载NPC脚本
@ReloadMonItems | 重新加载怪物爆物品列表
@ReloadLineNotice | 重新加载游戏公告
@ReloadManage | 重新加载登录脚本
@ReloadItemDB | 重新加载物品数据库
@ReloadMagicDB | 重新加载魔法数据库(暂时无效)
@ReloadMonsterDB | 重新加载怪物数据库
@ReloadRobotManage | 重新加载游戏登录文本
物品控制相关命令
@make | 制造指定的物品
@SuperMake | 调整给指定物品属性值
@BindUseItem | 物品绑定人物信息
@GiveMine 数量 纯度 | 给指定纯度的矿石.
仓库、登录密码相关命令
@CLEARPASSWORD | GM专用命令
人物分配点数控制相关命令
@BonusPoint | 增加人物属性点
@DelBonusPoint | 删除人物属性点(删除所有已分配及未分配的属性点)
@RestBonusPoint | 将人物属性点复位(已分配的复位到未分配的点数)
地图控制相关命令
@SetMapMode | 设置地图模式
@Map | 查看当前所在地图相关信息
游戏点、币相关命令
@GameGold | 调整人物游戏币数量
@GamePoint | 调整人物游戏点数量(泡点数量)
@CREDITPOINT | 调整人物声望点(1-255)
@DelGold | 减少人物金币
@AddGold | 增加人物金币
其他相关命令
@Showflag | 显示标识
@showopen | 显示打开
@showunit | 显示单位
@setflag | 设置标识
@setopen | 设置打开
@setunit | 设置单位
@Reconnection | 更换网关的命令
行会相关命令
@AddGuild | 添加一个行会
@DelGuild | 删除一个行会
@SabukWallGold | 更改沙城所属性行会
@ForcedWallconquest | 强行开始或结果攻城战
@SabukWallGold | 查看沙城金币数

操控角色命令

Backstep 功能：后退一步


用户游戏命令详解

用户游戏相关命令

注：以下命令在(M2目录中)Command.ini文件中均可自由更改命令名称.

相关命令
@Date | 显示当前服务器上的日期时间
@禁止私聊 |
@禁止群聊 |
@禁止交易 |
@加入行会 |
@退出行会 |
@禁止行会聊天 |
@允许行会联盟 |
@联盟 |
@取消联盟 |
@允许天地合一 |
@天地合一 |
@仓库解锁 |
@仓库开锁 |
@设置仓库密码 |
@修改仓库密码 |
@Rest |
@传送 | 传送物品移动命令
@Dear | 夫妻查询位置
@Master | 师徒查询位置
@DearRecall | 夫妻传送
@MasterRecall | 师徒传送
@AllowDearRecall | 允许夫妻传送
@AllowMasterRecall | 允许师徒传送
@GuildRecall | 行会合一
@AllowGuildRecall | @允许天地合一
@AttackMode | 调整攻击模式
仓库、登录密码相关命令
@SetPassword | 设置仓库密码
@Chgpassword | 修改仓库密码
@UnLock | 打开密码锁
@UnLockStorage | 仓库解锁
@Lock | 仓库加锁


人物状态说明

 人物状态说明：
冰冻 麻痹效果+不可传送
蛛网 无法跑步，只能走动（没有动作前先用减速，状态持续时，速度为跑步速度的一半）
定身 无法跑动、走动、可以攻击施法
禁锢 释放一个类似困魔咒的光圈，敌对人物或怪物只能在圈子里移动、攻击，所有传送失效，不能小退，禁锢范围大小可配置
瘫痪 无法攻击、施法、跑动、走动，被攻击立即解除瘫痪状态


GOTOLABEL触发[!]

GOTOLABEL 模式(0,1,2,3) 触发字段 范围(模式等于3时有效)

模式=0 小组成员触发
模式=1 行会成员触发
模式=2 当前地图的人物触发
模式=3 以自己坐标为中心指定范围人物触发

[@main]
#IF
#ACT
GOTOLABEL 0 @小组成员触发
GOTOLABEL 1 @行会成员触发
GOTOLABEL 2 @当前地图的人物触发
GOTOLABEL 3 @指定范围人物触发 12

--------------------------------------------------------------------------------------------------

GOTOLABELEX 模式(0组队,1行会) X Y 范围 在什么脚本里触发(0=QF脚本,1=当前NPC脚本) 触发字段

[@main]
#IF
#ACT
GOTOLABELEX 0 <$X> <$Y> 10 0 @aaa


M2启动后触发

QManage.txt中增加一个新的脚本段[@Startup],此脚本段只在M2启动后执行一次.


包裹按钮自定义按钮触发

共5个按钮

在脚本QFunction-0.txt里触发
[@ItemBagButtonClickX] X范围在1-5

[@ItemBagButtonClick1]

[@ItemBagButtonClick2]

[@ItemBagButtonClick3]

[@ItemBagButtonClick4]

[@ItemBagButtonClick5]

可以使用脚本命令SETITEMBAGBUTTONINFO来动态调整按钮的位置，或是否显示某个按钮。

命令格式 SETITEMBAGBUTTONINFO 按钮编号(1~5) 是否可见(0不可见,1可见) 坐标X 坐标Y 提示信息

使用方法：

首先启动登陆器配置器

点击界面UI编辑-界面编辑-OK

然后找到包裹的窗口，鼠标点一下包裹窗口，右边的窗口会有名称，DItemBag_，在这个下面找到 DItemBagButton1 DItemBagButton2 DItemBagButton3 DItemBagButton4 DItemBagButton5
这5个按钮点击会分别触发QF的[@ItemBagButtonClickX]，默认是隐藏的，不显示的，并且没有素材显示，需要设置素材。
鼠标选择其中一个按钮，比如点击DItemBagButton1，然后在左边的窗口，双击图片，就可以设置素材了(具体可以到我们官方网站看视频教程，UI编辑的视频)
在左边的窗口基本属性里-是否可见设置成True。就可以显示按钮，这一步可以省略。可以使用脚本命令SETITEMBAGBUTTONINFO设置。


初始化行会触发

只能用于行会自定义变量的申请

在登陆脚本QManage.txt里触发
[@LoadGuild]
#IF
#ACT
VAR Integer GUILD QQQQ


带上物品时触发[!]

功能: 带上物品时触发 位置0-18

[@TakeOn0] 0----18

[@TakeOn]
#IF
CheckLevelEx > 0
#SAY
穿上衣服真漂亮！!


地图事件触发

地图事件配置详解 必须在M2-选项-功能设置-基本设置-启用地图事件触发勾上才有效

Mir200\Envir\MapEvent.txt 配置

;触发标识
; 格式:
; 标识:值
;
; 标识:(-1 - 800) -1 代表不检查标识
; 值: (0 - 1)
;
;

;触发条件

; 格式:
; 代码:物品:组队;
; 代码:
; 0:无效
; 1:扔物品
; 2:捡物品
; 3:挖矿
; 4:走路(不支持物品条件)
; 5:跑步(不支持物品条件)
; 6:爆物品

; 物品:(物品名称 - *) * 代表不需要物品
; 组队:(0 - 1) 0为不需要组队，1为必须组队才触发(暂时不支持)

;触发机率
; 数字越大，机率越低
; 范围:(0 - 999999) 0 的机率为100%

;事件类型
; 格式
; 代码:内容

; 代码:(现在只支持脚本事件)
; 0:无效
; 1:调用脚本(调用QFunction-0.txt中的内容)
;注意事项
;
; 在相同地图座标，不支持相同触发标识及条件(触发条件中的物品名称除外)，如果有相同的设置，只有最后一个设置有效

;地图号 座标X 座标Y 范围 触发标识 触发条件 触发机率 事件类型
;和翎风不同的我们这里增加一个范围,如果范围的值是0 那么必须在这个坐标上才能触发，否则只要进入这个坐标的范围就会触发
;坐标为-1时不检测坐标

3 333 333 0 -1:1 1:回城卷:0 2 1:@MapEventDropItem
3 333 333 0 -1:1 2:回城卷:0 2 1:@MapEventPickUpItem
3 338 331 0 -1:1 3:*:0 2 1:@MapEventMine
3 330 330 0 -1:1 4:*:0 2 1:@MapEventWalk
3 331 335 0 -1:1 5:*:0 2 1:@MapEventRun
3 -1 -1 0 -1:0 6:*:0 0 1:@爆物品

QFunction脚本
[@爆物品]
#ACT
;这里的%s表示的爆出的物品名称 %x爆出的物品X坐标 %y爆出的物品Y坐标.
SENDMSG 0 【地图:%m】【物品:%s】【坐标(%x:%y】 255 253
;也可以这样
SENDMSG 0 【地图:%m】【物品:<$SCATTERITEMNAME>】【坐标(<$SCATTERITEMX>:<$SCATTERITEMY>】 255 253


定时触发[!]

定时触发 DelayCall 时间毫秒 触发字段


复活时触发[!]

功能: 复活时触发.
说明: QF脚本触发

[@Revival]
#IF
#ACT
SendMsg 5 你复活了继续折腾把！


个人商店和人物摆摊

该触发是引擎默认的个人商店摆摊触发，不是仿HeroM2摆摊触发。仿HeroM2摆摊相关触发完全兼容HeroM2,可以查看兼容HeroM2部分

点击开始摆摊或停止摆摊将触发 QFunction-0 [@ShopStall] 地图参数 ALLOWUSEMYSHOP 允许摆摊(必需先设置摆摊限制在指定地图才会生效)

[@ShopStall]
#IF
INSAFEZONE
;检测在安全区
#ELSEACT
MESSAGEBOX 需要在安全区才能摆摊
BREAK

#IF
CHECKSHOPSTALLSTATUS
;检测是不是在摆摊
#ACT
MESSAGEBOX 你是否确认要停止摆摊 @停止摆摊
#ELSEACT
MESSAGEBOX 你是否确认要开始摆摊 @确定开始

[@确定开始]
#if
ISDUPMODE
#say
请找一个空位置，不能与别人站在一起。
#ACT
BREAK

#if
#ACT
SHOPSTALL
;使用SHOPSTALL命令，如果正在摆摊就会停止摆摊，如果没有摆摊就会开始摆摊

[停止摆摊]
#if
#ACT
SHOPSTALL
;使用SHOPSTALL命令，如果正在摆摊就会停止摆摊，如果没有摆摊就会开始摆摊

============================================================================================================

点击我的商店，如果还没有创建将触发[@QueryMyShopFail]

[@QueryMyShopFail]
#ACT
MESSAGEBOX 你还没有个人商店，是否创建你的个人商店？\\点击确定创建个人商店。 @创建个人商店 @取消

[@创建个人商店]
亲爱的玩家你好。这里可以申请开店。\
你可以把你的物品放到你的店铺里出售，\
游戏中的玩家可以查询到你要出售的物品。\
也可以把不用的物品放到店铺的仓库里。\
点击客户端中“店”就可以进入到你的店铺中,\
也可以查询其他用户的店铺和物品，\
可以很方便的把仓库物品和出售的物品相互转移。\
还可以进行摆摊操作。\

<我要开店(点击输入你喜欢的店铺名称)/@@InputString1>\

[@InputString1]
#IF
CHECKMYSHOP
#ACT
MESSAGEBOX 你已经有店铺了
BREAK

#IF
CHECKSHOPNAME <$STR(S$1)>
#ACT
MESSAGEBOX <$STR(S$1)>店铺名称已经存在，请重新选择一个
BREAK

#IF
#ACT
CREATEMYSHOP <$STR(S$1)>

[@CreateMyShopOK]
#SAY
你的店铺创建成功

[@CreateMyShopFail]
#SAY
你的店铺创建失败


攻击触发

QFunction-0

;所有触发只有攻击到怪物才会触发，有些魔法不会触发，如魔法盾
;======================魔法攻击触发==========================
[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@MagicAttack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

;======================物理攻击触发==========================
[@Struck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@Attack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

[@attack]

说明
攻击玩家或怪物时触发

相关命令
currrTargetName

标签:|currrTargetName>currrTargetName

;攻击模块中,被攻击者执行指定脚本

示例：
[@attack]
#act
currrTargetName #call [\path\scriptName.txt] @跳转标签
currrTargetName goto @跳转标签

[@struck]

说明
玩家被攻击时触发

相关命令
currrTargetName

标签:|currrTargetName>currrTargetName

;被攻击模块中,攻击者执行指定脚本

[@struck]
#act
currrTargetName #call [\path\scriptName.txt] @跳转标签
currrTargetName goto @跳转标签


拣物品触发 捡取物品触发[!]

功能: 拣物品触发 捡取物品触发

@PickUpItemX X是物品数据库中对应的IDX

[@PickUpItem0]
#IF
#SAY
某某某捡到了一个<$CURRTEMNAME>

;----------------物品拾取后，进背包前触发，可在此触发器内修改物品属性

[@prepickupitem]

#act
CHANGECUSTOMITEMPROGRESSBAR -1 0 0 1
CHANGECUSTOMITEMPROGRESSBAR -1 1 0 1
CHANGECUSTOMITEMPROGRESSBAR -1 0 1 特戒
CHANGECUSTOMITEMPROGRESSBAR -1 1 1 引擎
CHANGECUSTOMITEMPROGRESSBARVALUE -1 0 1 = 100
CHANGECUSTOMITEMPROGRESSBARVALUE -1 0 0 = 100
CHANGECUSTOMITEMPROGRESSBARVALUE -1 1 1 = 100
CHANGECUSTOMITEMPROGRESSBARVALUE -1 1 0 = 50
CHANGECUSTOMITEMTEXT -1 自定义属性
CHANGECUSTOMITEMABIL -1 1 1 1
CHANGECUSTOMITEMABIL -1 2 1 2
CHANGECUSTOMITEMABIL -1 3 1 3
CHANGECUSTOMITEMVALUE -1 1 = 100
CHANGECUSTOMITEMVALUE -1 2 = 100
CHANGECUSTOMITEMVALUE -1 3 = 100
SetNewItemValue -1 0 + 100
sendMsg 6 进背包前触发！

;------------物品拾取进背包后触发，在此处修改物品属性，不会即时刷新

[@PickUpItemEx]
#IF
#SAY
某某某捡到了一个<$CURRTEMNAME>

捡取物品的相关常量

<$CURRTEMNAME> | 当前物品名称 指人物掉落或捡取的
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落或捡取的
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落或捡取的
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落或捡取的
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落或捡取的
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落或捡取的
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落或捡取的
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落或捡取的
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落或捡取的
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落或捡取的
<$CURRTEMMAKEINDEX> | 当前物品MakeIndex序列号


界面帮助按钮触发

功能： 界面帮助按钮触发

格式:

QFunction-0.txt
[@Help]
#SAY
Help


骑马触发

QFunction-0

[@OnHorse]
#SAT
骑马

[@OffHorse]
#SAT
下马


取下身上物品时触发[!]

功能: 取下身上物品时触发,位置0-18

[@TakeOff0] 0----18

[@TakeOff]
#IF
CheckLevelEx > 0
#SAY
不穿衣服小心感冒!


人物大退触发

[@PlayOffLine] 人物大退触发


人物当前获得经验触发

@GetExp

例如:
[@GetExp]
#if
#act
SENDMSG 5 ：人物本次获取经验为:<$GetExp>
break


人物升级触发

脚本文件位于: X:\GameOfmir\Mir200\Envir\Market_Def\QFunction-0.txt

;此脚为功能脚本，用于实现各种与脚本有关的功能

;人物升级触发
[@PlayLevelUp]
#ACT
MessageBox 升级


人物死亡时触发[!]

功能: 人物死亡时触发

[@PlayDie]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK


人物小退触发

[@PlayReconnection] 人物小退触发


扔物品触发[!]

功能: 扔物品触发

@DropItemX X是物品数据库中对应的IDX

[@DropItem0]
#IF
#SAY
某某某扔了一个<$CURRTEMNAME>

扔物品的相关常量

<$CURRTEMNAME> | 当前物品名称 指人物掉落或捡取的
<$G_CURRTEMNAME> | 当前物品改名名称 指人物掉落或捡取的
<$CURRTEMSTDMODE> | 当前物品DB字段StdMode值 指人物掉落或捡取的
<$CURRTEMSHAPE> | 当前物品DB字段Shape值 指人物掉落或捡取的
<$CURRTEMANICOUNT> | 当前物品DB字段AniCount值 指人物掉落或捡取的
<$CURRTEMLOOKS> | 当前物品DB字段Looks值 指人物掉落或捡取的
<$CURRTEMDURA> | 当前物品当前持久值 指人物掉落或捡取的
<$CURRTEMDURAMAX> | 当前物品最大值 指人物掉落或捡取的
<$CURRTEMINDEX> | 当前物品DB字段Idx值 指人物掉落或捡取的
<$CURRTEMCOLOR> | 当前物品DB字段Color值 指人物掉落或捡取的


杀死怪物时触发

功能: 杀死怪物时触发
说明: 对应地图参数中需要加入ONKILLMON才可生效!
[@OnKillMob]
#IF
CheckKillMonName 白野猪
#SAY
你杀死一头白野猪!


杀死人物宝宝时触发[!]

功能: 杀死人物宝宝时触发

[@KillSlave]
#IF
CheckKillSlaveName 月灵
#ACT
SendMsg 5 你把对方的月灵宝宝杀死了.


杀死人物触发

@KillPlay

;杀人触发
[@KillPlay]
#ACT
MessageBox 你杀人了


套装触发

@GroupItem

例如：

[@GroupItem0]
#IF
#ACT
SENDMSG 0 圣战套装隐藏属性被激发:攻击上限增加5点!

[@GroupItem1]
#IF
#ACT
SENDMSG 0 法神套装隐藏属性被激发:魔法上限增加5点!

[@GroupItem2]
#IF
#ACT
SENDMSG 0 天尊套装隐藏属性被激发:道术上限增加5点!

套装生效触发[@GroupItemOnX],套装失效触发[@GroupItemOffX],英雄对应[@HeroGroupItemOnX],[@HeroGroupItemOffX] X表示套装编号

套装编号在M2-查看-列表信息二-套装系统-套装编号


外挂触发[!]

QFunction-0脚本里[@UsePlugin]字段

[@UsePlugin]
#ACT
ChangeModeEx 10 10
SENDMSG 6 使用外挂，锁定10秒


物品触发脚本功能

功能：
双击物品可以自动触发指定脚本功能；

使用方法：
1、物品数据库设置1：STDMODE字段设置为：31
2、物品数据库设置2：AniCount字段设置为：X
X为指字数字触发脚本（1-999）
3、\Mir200\Envir\market_def\QFunction-0.txt下设置
[@StdModeFuncX]
#IF
#ACT
sendmsg 7 触发成功！！！
===================================
注：其中X为物品数据库设置2中的X


占领沙巴克触发

功能: 占领沙巴克触发

QFunction-0

[@GetCastleX] X表示城堡编号

[@GetCastle0]
#IF
#SAY
沙巴克已经被占领


指定人物触发字段[!]

指定人物触发字段 HCALL 人物名称 触发字段


装备持久消失时触发

功能: 装备持久消失时触发,位置0-18

[@ItemDamage1]
#IF
#ACT
SendMsg 5 你的武器已经损坏.


装备升级触发[!]

执行脚本功能.升级成功时执行@UpgradeOKX,升级失败时执行@UpgradeFailX,
属性被清除时执行@UpgradeClearX,其中X代表装备位置,例如:衣服=0,武器=1


走路和跑步触发

QFunction-0

[@Run]
#SAT
你在跑步

[@Walk]
#SAT
你在走路


组队时触发

功能: 创建小组时触发.
说明: 队员的名字放在队长S0变量中.
[@GroupCreate]
#IF
#ACT
SendMsg 5 <$STR(S0)>加入了组队.
<$STR(S$0)>.SendMsg 5 你加入了组队.

;在组队前触发
[@StartGroup]
#IF
CheckLevelEx < 25
#ACT
CreateGroupFail
SendMsg 5 25级之后才可以组队.

功能: 离开队伍时触发.
说明: 被删除的队员名字放在队长的S0变量中.
[@LeaveGroup]
#IF
#ACT
SendMsg 5 你退出了组队.

功能: 删除小组成员时触发.
说明: 被删除的队员名字放在队长的S0变量中.
[@GroupDelMember]
#IF
#ACT
<$STR(S0)>.SendMsg 5 你被队长踢出了组队!

功能: 添加小组成员时触发.
说明: 队员名字放在队长的S0变量中.
[@GroupAddMember]
#IF
#ACT
SendMsg 5 <$STR(S0)>加入了队伍.
<$STR(S$0)>.SendMsg 5 你加入了队伍.

功能: 组队杀死怪物时触发.
[@GroupKillMon]
#IF
#ACT
SendMsg 5 组队杀怪.


创建副将英雄脚本

;@@BuHero 是创建和删除副将英雄的标志

;以下是酒馆_辰星的脚本

(@@BuHero @PlayDrink )
[@main]
魔法不单是华丽的攻击，更需要在战斗中感受它的使用技巧。现\
在是时间让年轻的卧龙英雄们去体会战斗中的艰辛了。如果能在修\
行中遇到值追随一生的伙伴，对他们来说也许就更有意义！\ \
<召唤卧龙英雄/@召唤卧龙英雄>\
<寄存领回英雄/@寄领英雄> \
<主将副将英雄培养/@主副英雄培养> \
<我不想再带领卧龙英雄/@不带英雄>\

[@召唤卧龙英雄]
<我想找卧龙英雄做为我的历练伙伴/@领取卧龙英雄>\ \
<返回/@main>

[@寄领英雄]
<我想找您帮个忙，我想寄放英雄/@寄放英雄>\
<我想领回英雄/@领回英雄> \ \
<返回/@main>

[@主副英雄培养]
#if
CheckHeroAutoPractice
#say
看来你的副将英雄正在进行自我修炼....\ \
<我要停止副将英雄的自我修炼/@停止自我修炼>\ \
<查看副将英雄修炼时间/@查看修炼时间>
#elsesay
随着我们多年以来对英雄的训练，我们发现了一种新的培养方式和\
战斗方式。新的培养方式能够让同一英雄以三职业不同状态出战。\
新的战斗方式能够让你在战斗中召唤第二个英雄替换英雄进行战斗，\
从而对战局产生变化。\
当然，要想实现这一切的前提是必须对你的卧龙英雄和白日门英雄\
进行评定，选出主将和副将，才能够进行新的培养方式。\
<主将副将英雄评定/@主副将评定> <副将英雄自我修炼/@自我修炼> <英雄的历史/@英雄历史>\
<主将副将英雄指南/@英雄指南>\
<返回/@main>

[@停止自我修炼]
#if
#ACT
StopHeroAutoPractice
Close

[@StopHeroAuto]
#if
#ACT
give 金创药 1
Close

[@查看修炼时间]
你的副将英雄本次的修炼时间为:<$HEROAUTOTIME>秒\
<返回/@主副英雄培养>

[@主副将评定]
#if
#act
ASSESSMENTHERO

[@自我修炼]
#if
CheckDeputyHero
;检测当前在线的是卧龙英雄
#say
请注意：副将英雄的等级上限为主将英雄当前等级减三，副将\
英雄的内功等级上限为主将英雄当前内功等级减三。一旦副将\
英雄的等级或内功等级达到上限，自动修炼将不能获得相应的\
经验或内功经验。\
当且仅当副将英雄自动修炼满2小时，且在酒馆英雄NPC处终止\
训练时，将有几率带回训练过程中拾取的物品。\ \
<副将英雄自动修炼/@自动修炼>
#elsesay
请先召唤出你的副将英雄吧......\

[@自动修炼]
#if
#ACT
OpenHeroAutoPractice
Close

[@领回英雄]
<$USERNAME>,想和你的英雄一起闯荡玛珐大陆吗？\ \
<是的，我是来接他走的/@GetHero>\ \
<不了，还要托你照顾一段时间/@exit>\

[@GetHero]
#if
#act
GetHero

[~PlayDrink_Already]
#if
#act
#Say
嗯......真是香醇的美酒,令我心情舒畅。\<寄放英雄/@SaveHero>

[~PlayDrink_Already_NotHero]
#if
#act
#Say
你没喝多吧？你身边空无一人，还说要把英雄\托付我？\

[~PlayDrink_Already_HeroBegin]
#if
#act
#Say
你没喝多吧？你身边空无一人，还说要把英雄\托付我？\<重新寄放英雄/@SaveHero>

[@领取卧龙英雄]
#if
HAVHERO TRUE
#say
你已经有卧龙英雄了,还想再领取?\
#elsesay
<$USERNAME>，休息一下吧。不要忽视声明中的美好。\
如同杯中的美酒一般，一起喝吗？\
   \
<没有问题，我这里有上好的美酒/@请喝酒>\
   \
<我不会喝酒……/@exit>\

[@请喝酒]
#if
HAVHERO
#say
你精力有限,只能带领一位英雄在玛法大陆历练。\
如果你想再带领一位英雄,可以先将身边的英雄安顿在我们这里\
#elsesay
好！好！快拿酒来，让小二倒进六个坛中。\
每个坛里的酒有多有少，喝多喝少就看运气。\
我们就来拿这六坛酒来斗一斗！\ \
<好的，来吧/@斗酒规则>\

[@斗酒规则]
#if
#act
Mov M0 1
#say
<斗酒规则提示>：双方猜拳胜者，将有权选择桌面上的一坛酒，\
让双方的任一个人饮下，并会根据其酒精浓度，在酒量槽中相应显示。\
在桌面上的全部饮完后，\
且在双方均未喝醉（不超过酒槽内红线）的情况下，\
如果玩家酒槽内酒值不超过NPC酒值，便可赢得斗酒。\
<操作提示>：在选择出拳型后，点击出拳按钮，\
双方将出猜拳胜负，如果赢了，\
请单击桌面上的任一坛酒，并指定双方任一人喝下。\
<我明白了,摆酒吧/@PlayDrink>\

[@PlayDrink]
请把酒放上去

[~PlayDrink_Game]
#if
#act
OPENPLAYDRINK 2 晨星 DRINK
PLAYDRINKMSG 1 <$USERNAME>，酒之道也可以算作我修行的一部\分，让我看看你的表现吧。
PLAYDRINKMSG 2 嘿嘿……我可不会比你先醉倒，保管陪\你喝爽了！

[~PlayDrink_Self_Loss]
#if
#act
PLAYDRINKMSG 1 这点酒量，我怎么放心让我的弟子\跟随你啊！
PLAYDRINKMSG 2 惭愧惭愧，我一定努力!\<招幕英雄/@CrHero>

[~PlayDrink_SelfToNpc]
#if
#act
PLAYDRINKMSG 1 好！
PLAYDRINKMSG 2 就这坛了！请前辈来喝!

[~PlayDrink_SelfToSelf]
#if
#act
PLAYDRINKMSG 1 ……
PLAYDRINKMSG 2 就这坛了！我自己喝！

[~PlayDrink_NpcToSelf]
#if
#act
PLAYDRINKMSG 1 就这坛了！你来喝吧！
PLAYDRINKMSG 2 谢谢前辈！

[~PlayDrink_NpcToNpc]
#if
#act
PLAYDRINKMSG 1 就这坛了！我来喝！
PLAYDRINKMSG 2 前辈尽管喝！

[~PlayDrink_Dogfall]
#if
#act
PLAYDRINKMSG 1 那再来一局吧。
PLAYDRINKMSG 2 来就来！

[~PlayDrink_NpcWil]
#if
#act
PLAYDRINKMSG 1 嗯，不错，那我选了。
PLAYDRINKMSG 2 真倒霉，我就不信赢不了你。

[~PlayDrink_PlayWil]
#if
#act
PLAYDRINKMSG 1 <$USERNAME>，你选吧。
PLAYDRINKMSG 2 哈哈哈，还是我厉害吧~\选哪一坛好呢？

[~PlayDrink_Self_Drunk]
#if
#act
PLAYDRINKMSG 1 看你这么努力，英雄我就交给你了\！
PLAYDRINKMSG 2 惭愧惭愧，我一定努力!\<招幕英雄/@CrHero>

[~PlayDrink_Npc_Drunk]
#if
#act
PLAYDRINKMSG 1 呃,看来令天我是有点喝多了……！
PLAYDRINKMSG 2 啊……前辈,您别醉呀……\<招幕英雄/@CrHero>

[@CloseDrink]
#if
#act
CLOSEDRINK

[~PlayDrink_Npc_Loss]
#if
equal M0 1
#act
PLAYDRINKMSG 1 好久没有这种感觉了,酒意可谓"点到\即止",看来你也深明其理啦.！
PLAYDRINKMSG 2 呵呵,这次陪前辈喝酒,前辈已经喝得\尽兴,不知可否帮我个忙?\<招幕英雄/@CrHero>!
#elseact
PLAYDRINKMSG 1 好久没有这种感觉了,酒意可谓"点到\即止",看来你也深明其理啦.！
PLAYDRINKMSG 2 呵呵,这次陪前辈喝酒,前辈已经喝得\尽兴,不知可否帮我个忙?\<删除英雄/@DelMyHero>!

[@CrHero]
#if
#act
CLOSEDRINK
#say
恩……好酒啊，既然你请我喝酒了。\
请先给您的卧龙英雄取个名字吧。\
<英雄起名/@@buHero>\

[@@buHero]
你要带一个男法师还是法师士卧龙英雄呢？\
<卧龙男法师英雄/@CREATEHERO_TAOS_MAN>\
<卧龙女法师英雄/@CREATEHERO_TAOS_WOM>\
\

[@CREATEHERO_TAOS_MAN]
#ACT
CREATEHERO 1 0 TRUE
[@CREATEHERO_TAOS_WOM]
#ACT
CREATEHERO 1 1 TRUE
//返回消息

[@HAVHERO]
您已经有英雄了。\ \
<噢，也许是我记错了/@exit>

[@SetHeroName]
请先给您的卧龙英雄取个名字吧。\ \
<关闭/@exit>

[@寄放英雄]
<$USERNAME>，休息一下吧。不要忽视声明中的美好。\
如同杯中的美酒一般，一起喝吗？\
   \
<没有问题，我这里有上好的美酒/@Drink>\
   \
<我不会喝酒……/@exit>\

[@Drink]
#if
#act
OPENPLAYDRINK 2 辰星
PLAYDRINKMSG 1 酒意需要品味，生命的动人之处常会在不经意\之间显现。我们在小酌中慢慢体会\吧。
PLAYDRINKMSG 2 小提示：请将包裹栏中的酒放至酒碟上。

[~PlayDrink_Ok]
#if
#act
PLAYDRINKMSG 1 天道自然，在自然之中追寻平衡本百易事，但\这酒令我有了一些顿悟。\<寄放英雄/@SaveHero>

[@SaveHero]
#if
#act
SAVEHERO

[@NoSaveHero2]
还是不要寄放了吧，让你的主将英雄同你一起战斗吧......

[@NoSaveHero3]
还是不要寄放了吧，让你的副将英雄同你一起战斗吧......

[~PlayDrink_HeroOk]
#if
#act
CLOSEDRINK

[~PlayDrink_NotHero]
#if
#act
CLOSEDRINK
PLAYDRINKMSG 1 你没喝多吧？你身边空无一人，还说要把英雄\托付我？\

[~PlayDrink_HeroBegin]
#if
#act
PLAYDRINKMSG 1 你你没喝多吧？你身边空无一人，还说要把英雄\托付我？\<重新寄放英雄/@SaveHero>

[@不带英雄]
你想把你的伙伴送回卧龙山庄？\
你要知道，修行结束回到卧龙山庄的子弟,\
不可能再次像现在这样随你一同探索玛法大陆了。\
你真的想这样么？你要是决定了，我们就来斗上一盘酒!\
待我喝好了，我就帮你的伙伴送回山庄。\
<是的，拜托你了/@是的> \
   \
<我还想与我的伙伴一起继续战斗/@exit>\

[@是的]
好！好！快拿酒来，让小二倒进六个酒坛中。\
没个酒坛中的酒有多有少，喝多喝少就看运气了。\
我们就拿这六个酒坛中的酒来斗一斗！\ \
<好的，来吧/@DJSM>\

[@DJSM]
#if
#act
Mov M0 2
#say
<斗酒规则提示>：双方猜拳胜者，将有权选择桌面上的一坛酒，\
让双方的任一个人饮下，并会根据其酒精浓度，在酒量槽中相应显示。\
在桌面上的全部饮完后，\
且在双方均未喝醉（不超过酒槽内红线）的情况下，\
如果玩家酒槽内酒值不超过NPC酒值，便可赢得斗酒。\
<操作提示>：在选择出拳型后，点击出拳按钮，\
双方将出猜拳胜负，如果赢了，\
请单击桌面上的任一坛酒，并指定双方任一人喝下。\
<我明白了/@PlayDrink>\

[@DelMyHero]
#ACT
DELETEHERO
[@NotHAVHERO]
你没有英雄。\ \
<噢，也许是我记错了/@exit>
[@LogOutHeroFirst]
请将英雄设置下线！在来找我吧！\
     \
<好的/@exit>
[@NotDelHero]
评定主副将英雄后，不能进行删除英雄！\
     \
<好的/@exit>

[@DeleteHeroOK]
既然你请我喝酒了，那我就答应你的要求。\
我会尽快把你的英雄送回山庄的\\
<那谢谢你了/@exit>

[@英雄历史]
玛法大陆上有两个重要的势力，白日门和卧龙山庄。\
在这两个地方，勇士们都能够召唤到英雄来协助自已。\
每一个势力最多只能领取一个英雄。一直以来，勇士们只能率领一\
名英雄征战玛法。另一名的英雄被寄存在酒馆外的翔天等人处。\
勇士们通过苍月岛仓库里的神秘人找到英雄地的长老，在他那里召\
唤<白日门英雄/fcolor=249>，通过酒馆外的翔天等人处召唤<卧龙英雄/fcolor=249>。\
现在，当你同时拥有两个英雄后，可以在酒馆外的翔天等人接受\
<新的英雄培养/fcolor=249>。新英雄时代即将来临！\
<返回/@主副英雄培养>

[@英雄指南]
《主将副将英雄指南》\ \
1、<如何将卧龙英雄、白日门英雄评定为主将英雄、副将英雄？/@如何评定>\
2、<主将、副将英雄有何特色？/@有何特色>\
3、<副将英雄的操作与训练。/@如何操作>\
4、<什么时候是复仇模式?/@复仇模式>\ \
<返回/@主副英雄培养>

[@如何评定]
必须首先拥有白日门英雄和卧龙英雄，才能够对其进行评定，成为\
主将英雄和副将英雄。白日门英雄可以通过苍月岛的仓库内神秘人获\
得。卧龙英雄，可以通过酒馆外的翔天等人处召唤。拥有两名英雄名，\
将其寄放在酒馆外的翔天等人处，即可使其参与英雄评定，\
从而决定主将英雄和副将英雄的人选。\
<请注意：一旦评定成功，将不可更改，且英雄无法删除！/fcolor=249>\ \
<我知道了/@英雄指南>

[@有何特色]
一旦成功评定主将英雄和副将英雄，两个英雄将可轮流召唤出战。\
主将英雄的实力决定了副将英雄成长的空间。只有当主将英雄的等级、\
内功等级比副将英雄高3级，副将英雄才能分别获得经验、内功经验。\
副将英雄可以战、法、道的不同形态出战。主将英雄累积的经验、\
内功经验等，在召唤出副将英雄时，能够直接向副将英雄传功。\ \
<我知道了/@英雄指南>

[@如何操作]
在英雄包裹按键右侧新增副将英雄的召唤按钮，也可在F12辅助\
工具中，设置召唤的快捷键。成功评定出主将英雄和副将英雄后，\
必须在酒馆外的翔天等人处参与副将英雄的初次训练后，\
才能开始副将英雄的自我修炼。初次训练过程中获得的经验奖励\
与副将英雄的等级相关，等级越高，获得的经验奖励越多。\
副将英雄的自我修炼可根据不同的修炼地图和强度，选择适合的\
修炼方式 。小退或下线将不计入修炼时间。\ \
<我知道了/@英雄指南>

[@复仇模式]
当主将英雄死亡时，开始1分钟复仇倒计时。在倒计时时间内，\
成功召唤出副将英雄，则副将英雄进入到复仇状态，\
其基础属性将获得大幅提升，提升效果持续3分钟。\ \
<我知道了/@英雄指南>


创建主将英雄脚本

;@@CreateHero 是创建和删除主将英雄的标志

(@@CreateHero)

[@main]
创建英雄：<英雄取名/@@CreateHero>\ \
删除英雄：<删除英雄/@DelMyHero>\ \
<退出/@exit>

[@CreateHero]
//CREATEHERO 职业 性别 请创建英雄：\ \

<男战士/@CREATEHERO_WARR_MAN> <女战士/@CREATEHERO_WARR_WOM>\
<男法师/@CREATEHERO_WIZA_MAN> <女法师/@CREATEHERO_WIZA_WOM>\
<男道士/@CREATEHERO_TAOS_MAN> <女道士/@CREATEHERO_TAOS_WOM>\ \

<关闭/@exit>

[@CREATEHERO_WARR_MAN]
#ACT
CREATEHERO 0 0
[@CREATEHERO_WARR_WOM]
#ACT
CREATEHERO 0 1
[@CREATEHERO_WIZA_MAN]
#ACT
CREATEHERO 1 0
[@CREATEHERO_WIZA_WOM]
#ACT
CREATEHERO 1 1
[@CREATEHERO_TAOS_MAN]
#ACT
CREATEHERO 2 0
[@CREATEHERO_TAOS_WOM]
#ACT
CREATEHERO 2 1

//返回消息
[@CreateingHero]
系统正在接受申请，请稍候……\ \
<关闭/@exit>

[@HaveHero]
您已经有英雄了。\ \
<关闭/@exit>

[@HeroNameFilter]
英雄名字存在非法字符。\ \
<关闭/@exit>

[@SetHeroName]
请先给您的英雄取名字。\ \
<关闭/@exit>

;;--------------------删除英雄触发------------------

[@DelMyHero]
#ACT
DELETEHERO
//返回消息

[@NotHaveHero]
你没有英雄。\ \

<关闭/@exit>
[@LogOutHeroFirst]
请将英雄设置下线！\ \

<关闭/@exit>
[@DeleteHeroOK]
删除英雄成功。\ \
<关闭/@exit>

;---------------------QF脚本触发--------------------

[@CreateHeroOK]
英雄创建成功。\ \
<关闭/@exit>

[@HeroNameExists]
英雄名称已经存在了，请重新换一个名称。\ \
<关闭/@exit>

[@HeroOverChrCount]
英雄的数量超出限制。\ \
<关闭/@exit>

[@CreateHeroFail]
英雄创建失败。\ \
<关闭/@exit>

[@CreateHeroFailEx]
英雄创建失败。\ \
<关闭/@exit>

[@HeroNameFilter]
英雄名字存在非法字符。\ \
<关闭/@exit>

;--------------------------------

[@DeleteHeroOK]
英雄删除成功。\ \
<关闭/@exit>

[@DeleteHeroFail]
英雄删除失败。\ \
<关闭/@exit>


检测英雄的PK值

#IF
CheckHeroPkPoint > 100
#SAY
英雄的PK值大于100点.


检测英雄的伤害吸收

说明: 检测英雄的伤害

格式: CheckHeroSuckDamage 操作符(> = <) 数量(1-2000000000)

#IF
CheckHeroSuckDamage > 1000
#SAY
SendMsg 5 你的英雄当前拥有的伤害吸收大于1000点.


检测英雄的忠诚度

功能: 检测英雄当前的忠诚度
格式: CheckHeroLoyal 操作符(< = >) 数值(0 -- 100)

例子:
#IF
CheckHeroOnline
CheckHeroLoyal > 50
#ACT
SendMsg 5 您的英雄忠诚度大于50%.


检测英雄登录器荣誉
格式: CheckHumCreditEx 操作符(> = <) 数值(1-65535)

#IF
CheckHumCreditEx < 10
#ACT
ChangeHumCreditEx = 10


检测英雄职业.

CheckHeroJob 职业(0,1,2)

#IF
CheckHeroOnline
CheckHeroJob 2
#SAY
你英雄的职业是道士
#ELSESAY
你的英雄没有在线.


检查是否有英雄

检查人物是否有英雄

#IF
CheckHaveHero
#SAY
你已经有英雄了.
#ELSESAY
你还没有英雄.


检查英雄等级

检查英雄当前等级.

格式: CheckHerolevel 操作符(> = <) 级别(1-65535)

#IF
CheckHerolevel = 50
#SAY
你的英雄已经50级了


清除英雄所有技能
注意:如果清除后英雄技能依然显示存在,那么请更新最新登录器.

#IF
#ACT
ClearHeroAllSkill


设置英雄伤害吸收

说明:设置英雄可吸收收到的攻击伤害.

格式: SetHeroSuckDamage 操作符(+ - =) 总吸收直(1-2000000) 吸收比例(1-1000) 成功率(1-100)
      吸收比例 1=0.1% 500=50% 1000=100%

例子: 设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%
#IF
CheckGold 10000

#ACT
SetHeroSuckDamage + 1000 200 95
Take 金币 10000

特别说明:查看SetSuckDamage


收回人物的英雄

功能: 收回人物的英雄.
格式: TakeHero

[@main]
#IF
CheckHeroOnline
#ACT
TakeHero


调整英雄的PK值[!]

调整英雄PK值

#IF
CheckHeroOnline
#ACT
ChangeHeroPkPoint + 100
#SAY
你英雄的PK值增加100点.


调整英雄的忠诚度

格式: ChangeHeroLoyal 操作符(+ - =) 数值(0 -- 10000)
注意: 第二个参数+1那么英雄增加0.01点忠诚+100那么英雄增加1点忠诚

例子: 增加英雄1点忠诚
#IF
H.CHECKONLINE
#ACT
ChangeHeroLoyal + 100
SendMsg 5 您的英雄忠诚度增加[1]

功能: 检测英雄当前的忠诚度
格式: CheckHeroLoyal 操作符(< = >) 数值(0 -- 100)

例子:
#IF
H.CHECKONLINE
CheckHeroLoyal > 50
#ACT
SendMsg 5 您的英雄忠诚度大于50%.


调整英雄等级[!]

调整人物英雄等级.

ChangeHeroLevel 操作符(+ - =) 级别(1-65535)

#IF
CheckHeroOnline
#ACT
ChangeHeroLevel = 50
#SAY
你的英雄50级了.


调整英雄职业[!]

格式: ChangeHeroJob 职业(0,1,2)

#IF
CheckHeroOnline
#ACT
ChangeHeroJob 2
#SAY
你英雄现在的职业是道士.


英雄当前获得经验触发

@HeroGetExp

例如:
[@HeroGetExp]
#if
#act
SENDMSG 5 ：英雄本次获取经验为:<$HeroGetExp>
break


英雄登录器荣誉

英雄登录器专用荣誉
格式: ChangeHumCreditEx 操作符(+ - =) 数值(1-65535)

#IF
#ACT
ChangeHumCreditEx + 10


英雄上线触发

英雄上线触发 @HeroLogin 注意这个触发是由主人执行的所以对英雄的操作请在前面加H

QManage.txt里的配置脚本

[@HeroLogin]
#if
H.CHECKNAMELIST ..\QuestDiary\数据文件\英雄名单.txt
#act
H.DELSKILL 破魂斩
H.DELSKILL 劈星斩
H.DELSKILL 雷霆一击
H.DELSKILL 噬魂沼泽
H.DELSKILL 末日审判
H.DELSKILL 火龙气焰
H.delnamelist ..\QuestDiary\数据文件\英雄名单.txt
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 恶魔长袍(男) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(男) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 恶魔长袍(女) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(女) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 战神盔甲(男) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(男) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 战神盔甲(女) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(女) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 幽灵战衣(男) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(男) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 幽灵战衣(女) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(女) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break


英雄升级触发

英雄升级触发 @HeroLevelUp 这个触发也是由主人执行的所以对英雄的操作请在前面加H

例如:

[@HeroLevelUp]
#IF
#ACT
H.give 金条 2
break


NewopUI.Pak文件说明[!]

NewopUI.pak文件为登录器必备补丁，如果没有登录器无法正常启动。
可以使用我们提供的专用WIL编辑器打开编辑。该文件格式支持密码功能。
NewopUI.pak文件密码为空或者输入gameofmir

00108~00163 个人商店相关图片
00180~00193 仿HeroM2摆摊相关图片
00210~00225 黑夜白天功能相关的图片
00732~0748 配置器选择连击版，登录窗口图片

01370~01375是1024界面相关图片(配置器的 显示1024的界面 不勾选就不会使用这些图片)

血条
00170 血条背景
00171 人物血条
00172 高亮血条
00173 内功血条
00174 NPC血条
00175 怪物血条
00176 大刀、弓箭手血条

雷达
00240 自己
00241 其他人
00242 我的英雄
00243 NPC
00244 怪物
00245 大刀、弓箭手

00470~00475 是1.76和1.85登录界面

以上如果有不使用的功能，可以用编辑器把相关图片删除，减小登录器的大小。删除图片时，编辑器选择用空图片代替不是删除


NPC标签备注功能[!]

功能：
NPC标签备注功能

格式：

[@main]
<GOM引擎官方网站|253#GOM引擎官方网站：^254#www.gameofmir.com>\
<GOM引擎官方网站|249#GOM引擎官方网站：^250#www.gameofmir.com/@打开>\
<Img:210:3:0:0|254#GOM引擎官方网站：^253#www.gameofmir.com>\


NPC彩色字体设置[!]

功能：NPC彩色字体设置
格式：无
说明：无
例：

变量字符颜色{<$USERNAME>/FCOLOR=254}\
变量字符自动变色{<$USERNAME>/AUTOCOLOR=254,251,168,191,250,70,245,249,253}\

<字体颜色/FCOLOR=69>\
<自动变色/AUTOCOLOR=254,251,168,191,250,70,245,249,253>\

<可以触发字段颜色{FCOLOR=250}/@跳转1>\
<可以触发自动变色{AUTOCOLOR=254,251,168,191,250,70,245,249,253}/@跳转2>\


NPC自动变色[!]

;脚本名称 地图名称 X坐标 Y坐标 NPC名称 标志 形象 是否属于沙 是否移动 移动间隔 是否允许变色 变色速度（秒）
;--------------------------------------------------------------------------------------------


补丁读取规则[!]

功能：补丁读取规则
格式：Resources目录
说明：以读取Prguse.wil为例， 先读取Resources\Data\Prguse.pak, 如果Resources\Data\Prguse.pak不存在,读取Data\Prguse.wil, 如果Data\Prguse.wil不存在,读取Data\Prguse.wzl。

例:
优先读取Resources\Data\Hum.pak 如果这个文件不存在，则读取Data\Hum.wil。
优先读取Resources\Map\0.map 如果这个文件不存在，则读取Map\0.map。
优先读取Resources\Wav\0.wav 如果这个文件不存在，则读取Wav\0.wav。

增加支持 Resources\Data\ItemDesc.Dat(物品备注) 2013-02-20更新后的备注在m2--列表二里直接修改
增加支持 Resources\Data\TZItemDesc.Dat(套装备注)
增加支持 Resources\Data\SkillDesc.Dat(技能备注)
增加支持 Resources\Data\MapDesc.Dat(外传的小地图备注)
增加支持 Resources\Data\MapDesc1.Dat(小地图备注)

增加Items1.wil DnItems1.wil StateItem1.wil 数据库Looks起始编号10000开始

改进小地图扩展mmap10.wil从10001开始

增加扩展Npc10.wil Npc代码从1000

增加支持:
武器和衣服时可按照一件武器一个.wil文件的方式配置.
武器放在目录的\Graphics\Weapon\
衣服放在\Graphics\Human\下.
物品数据库中单个武器和衣服的Shape值从1000开始算起.
单个武器和衣服素材的文件名必须和物品数据库中的Shape值一样,
例如:数据库中设置Shape=1000,那么单个武器或者素材的文件就是1000.wil,如果Shape=1001那么文件名就是1001.wil


称号系统

增加称号：

第一步：首先选择称号的图库。在M2里设置(选项-功能设置-其他控制-称号素材读取设置)，素材的排列规则可以参考盛大的ui1.wzl里面的，从690~739都是称号的图片，每个称号需要5个图片，第一个图片是外观显示的，第二三是界面显示的，第四五是称号激活显示用的

第二步：在物品数据库里增加称号

-------------------------------------------------------------------------------------------

称号功能，增加减少称号物品DB时，请注意Shape的连续性

StdMode 70或71
Name 称号的名称，该名称外观是否显示，由Reserved字段控制
Shape 称号编号，触发用的
Color 颜色 0~255
Reserved 显示DB中的名字（有部分图自带了名字，不显示DB的名字可以写上1)
Anicount 大于0时，无需设置为当前称号，属性就可以叠加到人物。等于0时，需要设置为当前称号，该称号的属性才会叠加到人物
Looks 称号图片的开始位置
其他就等同于装备属性

玩家改变使用称号或刚上线有使用到称号，触发：QFunction的
人物：[@TitleChanged_XX]
XX代表物品DB中的Shape

玩家取消使用称号时，触发：QFunction的
人物：[@Untitled_XX]
XX代表物品DB中的Shape

比如
[@TitleChanged_1]
#IF
#ACT
伟大的【沙巴克城主】上线了

-------------------------------------------------------------------------------------------

第三步：使用脚本命令增加人物称号

称号对应NPC命令:

检测人物是否有某个称号
CHECKTITLE 称号名称(也就是在物品数据库增加的那个称号物品名称)

增加人物称号
CONFERTITLE 称号名称(也就是在物品数据库增加的那个称号物品名称)

删除人物称号
DEPRIVETITLE 称号名称(也就是在物品数据库增加的那个称号物品名称)

[@增加称号]
#IF
CHECKFENGHAOCOUNT > 29
#ACT
SENDMSG 6 已经有了所有称号
BREAK

#IF
NOT CHECKTITLE 巅峰战神 //检测没有有这个称号
#ACT
CONFERTITLE 巅峰战神 //授予称号
#ELSEACT
SENDMSG 6 已经有了该称号

[@删除称号]
#IF
CHECKTITLE 巅峰战神
#ACT
DEPRIVETITLE 巅峰战神 //删除称号
;DEPRIVETITLE ALL //删除所有称号

功能：检查玩家所有称号的数量
格式：CHECKFENGHAOCOUNT 操作符(<,>,=) 数量(0-30)

称号改变属性及时刷新
称号物品DuraMax=0时，称号可以无限时间使用
赋予新称号，将标注为未使用状态，激活称号后才开始计时

-------------------------------------------------------------------------------------------

称号最多支持30个

-------------------------------------------------------------------------------------------

以下数据是按照盛大ui1.wzl里面的称号做的数据

573;称号一;70;0;20;0;0;0;690;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;251;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
574;称号二;70;0;20;0;0;0;695;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;252;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
575;称号三;70;0;20;0;0;0;700;48;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;253;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
576;称号四;70;0;20;0;0;0;705;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;251;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
577;称号五;70;0;20;0;0;0;710;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
578;称号六;70;0;20;0;0;0;715;0;4;5;2;3;0;1;0;0;0;0;1;40;35000;5;249;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
579;称号七;70;;0;20;0;0;720;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;250;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
580;称号八;70;;0;20;0;0;725;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;252;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
581;称号九;70;;0;20;0;0;730;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
582;称号十;70;;0;20;0;0;735;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
583;称号十一;70;;0;20;0;0;1240;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
584;称号十二;70;;0;20;0;0;1245;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
585;称号十三;70;;0;20;0;0;1250;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
586;称号十四;70;;0;20;0;0;1255;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
587;称号十五;70;;0;20;0;0;1260;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
588;称号十六;70;;0;20;0;1;1265;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
589;称号十七;70;;0;20;0;0;1270;0;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;
590;称号十八;70;;0;20;0;1;1275;1;4;5;5;2;3;0;1;0;0;0;0;1;40;35000;5;255;0;0;;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0


登录点安全区[!]

功能：登录点安全区
格式：无
说明：配置文件 D:\MirServer\Mir200\Envir\StartPoint.txt
例：

文件格式：

;地图号 | 座标X | 座标Y | 禁止说话 | 大小范围 | 光环类型 | PKZONE | PKFIRE
0 | 289 | 618 | 0 | 10 | 4 | 0 | 0
0 | 650 | 631 | 0 | 10 | 4 | 0 | 0
0 | 334 | 266 | 0 | 10 | 4 | 0 | 0
2 | 503 | 483 | 0 | 10 | 4 | 0 | 0
3 | 330 | 330 | 0 | 10 | 4 | 0 | 0

地图号：安全区所在地图
座标X：安全区所在地图座标X
座标Y：安全区所在地图座标Y
禁止说话：安全区内是否禁止说话(此功能未完成)
大小范围：安全区范围大小(此功能未完成)
光环类型：安全区边界显示类型 1是僵尸钻的洞 3是石块 4是困魔光 5是火墙 6是祖码教主裂开的石头 7,8,9三种火墙效果
PKZONE：安全区是否为PK比赛区域(此功能未完成)
PKFIRE：安全区PK区域边界显示类型(此功能未完成)


地图参数表

地图参数标志 | 说明
CHECKQUEST | 进入本地图执行任务脚本 格式：CHECKQUEST(Q001) 说明： Q001 代表脚本名。
NEEDSET_ON | 进入本地图需要人物指定标志为打开状态 格式：NEEDSET_ON(001) 说明：001 代表人物标志
NEEDSET_OFF | 进入本地图需要人物指定标志为关闭状态 格式：NEEDSET_OFF(001) 说明：001 代表人物标志
MUSIC | 进入入本地图播放音乐 格式：MUSIC(Wav\bg.mp3) 或者 MUSIC(Wav\sellect-loop2.wav)代表客户端Wav目录下的sellect-loop2.wav文件
EXPRATE | 进入本地图后杀怪经验倍数 格式：EXPRATE(100) 说明：100代表经验倍数，除以100后为实际倍数。
PKWINLEVEL | 进入本地图后可以PK升级 格式：PKWINLEVEL(1) 说明：1代表升多少级；
PKWINEXP | 进入本地图后可以PK得经验 格式：PKWINEXP(1000) 说明：1000代表得多少经验；
PKLOSTLEVEL | 进入本地图后可以PK死亡掉等级 格式：PKLOSTLEVEL(1) 说明：1代表掉多少等级；
PKLOSTEXP | 进入本地图后可以PK死亡掉经验 格式：PKLOSTEXPP(1000) 说明：1000代表掉多少经验；
DECHP | 进入本地图后自动减HP 格式：DECHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCHP | 进入本地图后自动加HP 格式：INCHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次加多少点；
DECGAMEGOLD | 进入本地图后自动减游戏币 格式：DECGAMEGOLD(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCGAMEGOLD | 进入本地图后自动加游戏币 格式：INCGAMEGOLD(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；
INCGAMEPOINT | 进入本地图后自动加游戏点 格式：INCGAMEPOINT(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；(用于游戏泡点功能)
RUNMON | 允许穿怪
RUNHUMAN | 允许穿人
NORUNMON | 禁止穿怪
NORUNHUMAN | 禁止穿人
NEEDHOLE | 进入需要洞
NORECALL | 禁止记忆召唤
NOGUILDRECALL | 禁止行会召唤
NODEARRECALL | 禁止夫妻召唤
NOMasterRECALL | 禁止师徒传送
NORANDOMMOVE | 禁止使用瞬息移动
NODRUG | 禁止吃药
MINE | 可以挖矿
NODEAL | 禁止交易
NOPOSITIONMOVE | 禁止定座标移动
NORECONNECT | 进游戏时退出本地图 格式:NORECONNECT(3) 说明：3 代表地图号盟重
QUIZ | 禁止喊话
ALLOWUSEMYSHOP | 允许摆摊，该参数只对个人商店的摆摊有效，对仿Hero摆摊的无效(必需先设置摆摊限制在指定地图才会生效)
NOTALLOWUSEITEMS | 禁止使用物品 说明：NOALLOWUSEITEMS(回城卷|强效金创药)
NOTALLOWUSEMAGIC | 禁止使用技能 说明：NOTALLOWUSEMAGIC(火墙|彻地钉)
NOHEROPROTECT | 为禁止英雄守护
THUNDER | 例:THUNDER(10) 此地图有闪电效果,击中减hp为10
LAVA | 例:LAVA(10) 此地图地上冒岩浆,击中减HP为10
FLAME | FLAME(45:82:50|43:84:50)参数说明:x坐标：y坐标：伤害 可以为多坐标以|分隔
HORSE | 允许骑马
MISSION | 不允许使用任何物品和技能，并且宝宝在该地图会自动消失，不能攻击
NOMANNOMON | 智能刷怪 无效
NOCALLHERO | 禁止召唤英雄，已召唤英雄将自动消失
NIGHT | 该参数与M2内挂设置配合使用，当M2设置免蜡烛时凡是地图带NIGHT开启天气效果，M2取消免蜡烛时不带该参数的地图天启天气效果
NEEDLEVELTIME | 没到指定等级时不让进入，发送string.ini里的NeedLevelToXYErrorMsg提示可以自行修改
DECEXPRATETIME(值) | 每秒减双倍经验时间,如值小于1时，则默认为1
NGEXPRATE(数值) | 内功经验倍数(100代表经验倍数，除以100后为实际倍数)
PULSEXPRATE(数值) | 经络经验倍数(100代表经验倍数，除以100后为实际倍数)
DARK | 黑暗效果 如果同时存在 DAY以DAY参数效果为准
DAY | 白天效果 如果同时存在DARK以DAY参数效果为准
SAYLEVEL(等级) | 可限制当前地图人物说话等级.
DELDROPITEM | 人物(英雄)死亡后掉落的身上物品立即消失(不掉落在地图中).
REVIVAL(X:N) | 当前地图人物可复活的次数,X表示复活次数,N表示人物在当前地图已经复活次数的自动清零间隔(最小30秒).具体表示:每经过指定秒人物在当前地图复活过的次数自动减1.
NODROPUSEITEMS | 当前地图人物死亡不掉落身上的物品
NOSAFEPOSITIONMOVE | 禁止在当前地图安全区中使用传送戒指
NOALLOWUSEITEMS | 不允许使用物品NOALLOWUSEITEMS(回城卷,随机传送卷)
ONKILLMON | 杀死怪物时触发,对应地图参数中需要加入ONKILLMON才可生效!
HITMON(触发字段) | 攻击怪物触发。例:HITMON(@攻击) 攻击怪物会触发QF脚本的[@攻击]字段
FIGHT | 杀人不加PK值 死亡不掉装备
FIGHT2 | 杀人不加PK值 死亡掉装备
FIGHT3(是否掉装备) | 行会战地图 进入该地图名字颜色会变色，杀人不加PK。格式:FIGHT3(0) 死亡不掉装备 格式:FIGHT3(1) 死亡掉装备
FIGHT4 | 挑战地图 杀人不加PK 死亡不掉装备
SAFE | 安全地图
WEATHER1 | 天气效果1 读取Effect_SE.wzl
WEATHER2 | 天气效果2 读取Effect_SE.wzl
WEATHER3 | 天气效果3 读取Effect_SE.wzl


点击小地图自动寻路[!]

增加点击小地图自动寻路功能(可以在M2关闭或开启该功能，使用小地图按键或M键打开)

寻路QF触发
[@FindPathBegin] 开始
[@FindPathStop] 中断
[@FindPathEnd] 到达


叠加功能[!]

功能：多个物品放到一格
格式：无
说明：物品重叠功能不能使用在拥有持久、属性、品质、纯度等物品上。StdMode等于 0, 2, 3, 40, 41, 42
例：

物品重叠功能，StdItem.DB 中OverLap=1或2 表示可以重叠 0不叠加。DuraMax字段表示可以叠加的数量 必须大于1.例如：DuraMax=100表示可以叠加100个
OverLap=1 重量=重叠数量*单物品重量/10
OverLap=2 重量=重叠数量*单物品重量

收回物品 take 1 数字自己看着办喽

检测多少个 查看持久即可


顶戴花翎功能[!]

功能：顶戴花翎功能
格式：SetIcon 位置(0-9) 图片名称 是否只有自己看见（0=所有人都可以看见 1=仅仅自己可以看见） 微调上下偏移（正数往上，负数往下）
说明：图片名称在资源编辑中的：可调用UI资源中查看
例：

--------------------------------------------------------------------------

NPC顶戴花翎:
MerChant.txt中的NPC
盟重土城/流浪汉 3 346 334 流浪汉 0 3 0

流浪汉的顶戴花翎会读取 Envir\NpcIcons\盟重土城\流浪汉-3.txt

Envir\NpcIcons\盟重土城\流浪汉-3.txt 格式如下:
;图片名称
;最多不超过十行
图片名称

图片名称

--------------------------------------------------------------------------

怪物顶戴花翎:
白野猪的顶戴花翎会读取 Envir\MonIcons\白野猪.txt

Envir\MonIcons\白野猪.txt 格式如下和NPC的顶戴花翎格式是一样的:
;图片名称
;最多不超过十行
图片名称

--------------------------------------------------------------------------
人物顶戴花翎:
[@main]
#ACT
SETICON 0 tittle_1 0
SETICON 1 tittle_1 0
SETICON 2 tittle_1 0
SETICON 2 tittle_1 0

;如果要清除，WIL文件序号设置为-1即可
[@main]
SETICON 0 -1
SETICON 1 -1
SETICON 2 -1


动态创建镜像地图

动态创建一个镜像地图

ADDMIRRORMAP
格式：AddMirrorMap A B C D E F
功能：动态创建一个镜像地图
说明：创建成功后，人物D99变量返回1，否则返回0
A，原地图编号，在地图配置文件中存在的地图！
B，新地图编号，临时使用的地图编号，就和镜像地图功能一样！
C，新地图名，这里指客户端显示的名字
D，该地图存在的有效时长(秒)，时间到后，此地图将自动回收，并且将地图上的人传送至E参数设置的地图
E，人物退出时返回的地图编号
F, 小地图编号

DelMirrorMap
格式：DelMirrorMap 地图名
功能：删除动态创建的镜像地图

MirrorMapTime
格式：MirrorMapTime 地图名 时间（单位：秒）
功能：设置/获取镜像地图的时间
说明：如果时间不写，则表示获取当前地图的剩余时间，时间返回在D99变量
如果获取地图失败或不是镜像地图，则D99返回-1

CheckMirrorMap
格式：CheckMirrorMap 地图名
功能：检测镜像地图是否已经创建

addMirrorMap

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
addMirrorMap | 原地图编号 | 新地图编号 | 新地图名称 | 存在时长 | 退出返回地图编号

参数4:存在时长
填写-1,表示永久存在,写入数据库,
服务器重启后仍旧存在
可通过delMirrorMap命令删除

脚本示例：

#act
addMirrorMap xyczyt1c guild01 行会魔神 -1 3


斗笠功能设置[!]

斗笠相关数据

功能：斗笠相关数据

StdMode = 16
Anicount 0戴上后显示头盔的内观 1戴上后不显示头盔的内观
Shape 0~7 Hair2
Shape 8~9 Hair3 目前Hair3只有2个斗笠，如果增加，Shape值依次增加就可以支持
Source 0时显示神秘人,Source=1时不显示神秘人 带斗笠后的"神秘人"效果对管理员无效.

神秘人显示可以在M2中设置-功能设置-其他设置

563;斗笠一;16;0;1;0;0;0;1188;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
564;斗笠二;16;1;1;0;0;0;1587;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
565;斗笠三;16;2;1;0;0;0;2080;6000;0;0;0;0;0;1;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
566;斗笠四;16;3;1;0;0;0;2081;6000;0;0;0;0;0;0;0;1;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
567;斗笠五;16;4;1;0;0;0;2422;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
568;斗笠六;16;5;1;0;0;0;2522;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
569;斗笠七;16;6;1;0;0;0;2768;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
570;斗笠八;16;7;1;0;0;0;3356;6000;0;1;0;0;0;1;0;0;0;0;0;44;10000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
571;斗笠九;16;8;1;0;0;0;3890;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;
572;斗笠十;16;9;1;0;0;0;4266;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;255;0;;;;;;;;;;;;;;;;;;;;;;;

物品位置:

0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌


多级脚本使用[!]

功能：多级脚本使用
格式：无
说明：本功能的实现突破执行脚本的唯一性，使脚本的使用更加灵活多变，使用方法为 任意人物名称.任意脚本命令。以下所使用的翎风网络名称等全部支持变量操作

H. 表示是英雄

O. 表示是主人

M. 表示是怪物

P. 表示是对面的角色

例：

例如：
#if
翎风网络.Check [100] 1
check [100] 1
#act
翎风网络的变量值100为1
你自己的变量值100也为1

下面列举几种常用的使用方法，以下方法同样可以用在#ACT命令中

例如
#if
翎风网络.CheckLevel 51
CheckLevel 51
#act
翎风网络.GameGold + 10
GameGold + 10
#say
翎风网络的等级在50级以上，给予10元宝奖励
你的等级也在50级以上，给予10元宝奖励

上面脚本，如果翎风网络不在线，M2会提示出错，但脚本会继续执行并跳过该句做为无效检测处理
当做为无效检测处理后，只要D3dm2等级和自己的等级在50级以上，既执行#say和#act段，
并且，翎风网络.GameGold + 10 该句也无法执行，被跳过，继续执行下面的
所以在使用多级的时候请注意脚本的使用

#if
H.CheckLevelEx > 1
#say
你的英雄大于1级

#if
P.CheckLevelEx > 1
#say
你的对面的角色大于1级

;怪物操作，一般用在攻击触发里
#if
#act
M.HumanHP + 100


怪物名称颜色自定义功能[!]

增加怪物名称颜色自定义功能

MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1)
说明：最后一个参数为0时表示同国家玩家不能攻击该怪物，为1时在非国家攻击模式下可以攻击该怪物


怪物伤害封顶[!]

增加怪物伤害封顶，封顶数值等于怪物BD中的MP数值，若DB中怪物MP值=0则不计算伤害封顶


怪物属性扩展[!]

增加怪物属性扩展：Envir\MonSpAbilList.txt

格式：怪物名 忽视防御(0~100) 增加伤害(0~255) 伤害反弹(0~100) 物伤减少(0~100) 魔伤减少(0~100) 麻痹-几率-时间(0~1 0~10 0~10) 防麻痹(0~1) 防全毒(0~1) 防火墙(0~1) 防诱惑(0~1) 破复活(0~1) 破护身(0~1) 反伤数值（0~21E）


怪物说话配置[!]

功能：怪物说话配置
格式：无
说明：配置文件位置Mir200\Envir\MonSayMsg.txt
例：

;状态(0为杀人，1为被攻击，2为死亡，3为刚刷出来) 刚刷出来发的文字为广播文字全服务器都可以看到。
;机率(数字越大，说话机率越小)
;颜色(0为红色，1为绿色，2为蓝色，3为白色) 白色文字，显示在怪物头顶上所有旁边的人都可以看到，其它颜色则显示在人物聊到框中只有对应的人物可以看到。

;状态 机率 颜色 怪物名称 文字内容

1 30 0 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 1 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 2 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 3 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 4 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 稻草人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 森林雪人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 半兽人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 半兽战士 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 0 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 0 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 1 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 2 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 3 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 4 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标

2 30 1 鹿 %s不要打我，%d我挂了！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 0 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 1 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 2 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 3 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 4 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标

3 1 4 白野猪0 %s老猪来也%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标


怪物探索设置说明[!]

功能：怪物探索设置说明
格式：无
说明：在Mir200\Envir\MonUseItems里添加对应怪物名称的两个文件(xxxx.txt xxxx-item.txt格式和人形怪的配置差不多)
例：

狂热火蜥蜴.txt
[INFO]
;挖取身上装备收费模式(0金币，1元宝，2金刚石，3灵符)
ButchChargeClass=0
;挖取身上装备每次收费点数
ButchChargeCount=1
;未挖到物品是否减灵符 1=是，0=否
ButchNotItemDelGold=0
狂热火蜥蜴-Item.txt
1/5 龙牙
1/50 凰天魔衣
1/50 天龙圣剑
1/50 银星勋章(法)


火龙神殿[!]

NPC相关命令：
功能：关闭客户端'!'图标显示
格式：CLOSEMSGWINDOWS

格式：MESSAGEBOX 消息内容 QF触发段 QF触发段
例： MESSAGEBOX 使用10元宝，便可在当前地图内原位\置复活？ @确认 @取消
说明：在客户端显示一个提示框，点确定时，触发QFunction-0.txt的 @确认 代码
点取消时，触发QFunction-0.txt的 @取消 代码

物品ID
774;火龙凭证;41;0;1;0;0;0;269;0;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;;0;

MonGen.txt
;地图名：火龙殿
D2083 82 44 火龙教主 0 1 30
D2083 65 48 恶魔蝙蝠 10 10 30
D2083 81 62 恶魔蝙蝠 10 10 30
D2083 66 62 恶魔蝙蝠 10 10 30
D2083 51 75 恶魔蝙蝠 10 10 30

火龙守护兽设置说明

;名称 地图 x y dir(0-1) 攻击坐标x 攻击坐标Y(可以为多个以|分隔)
;----------------------------------
火龙守护兽 D2083 51,67 1 77,50|74,50|83,50|80,53|86,53|74,41|71,41|71,44|71,47
火龙守护兽 D2083 48,70 1 81,44|81,47|78,44|75,44|84,47|78,41|75,41|81,50|84,50
火龙守护兽 D2083 45,73 1 81,44|84,47|78,41|85,50|75,41|76,51|79,54|73,48
火龙守护兽 D2083 61,78 0 79,48|79,51|76,48|78,53|75,50|76,45|82,51|81,44|84,47|78,41
火龙守护兽 D2083 58,81 0 79,48|82,51|85,54|76,45|71,40|82,48|79,45|76,42|85,51|73,42
火龙守护兽 D2083 55,84 0 80,48|77,48|80,45|77,51|74,51|74,54|71,54|71,57

(怪物血量以及一些其他配置请自行修改)

灵魂收割者;81;19;240;100;1;1000;20000;20000;0;12;12;280;300;0;0;17;15;900;1;0;2000;
蓝影刀客;81;19;241;100;1;1000;20000;20000;0;12;12;280;300;0;0;17;15;900;1;0;2000;
恶魔蝙蝠;127;19;80;999;0;1000;2000;400;0;1000;1000;40;45;0;0;17;15;900;1;0;2000;
火龙魔兽;128;93;800;999;1;1000;30000;18000;0;30;30;60;150;0;0;17;15;900;1;0;3000;
火龙守护兽;129;94;802;999;1;1000;0;18000;0;30;30;40;45;0;0;17;15;900;1;0;2000;


机器码使用说明[!]

<$MACHINEID> 机器码，和登录的角色无关，只要是该机器登录的角色，这个机器码就一样。
<$USERMACHINEID> 该机器当前登录的角色的机器码。不同的角色名称或不同的机器登录生成的机器码不一样。

配合以下命令可以限制角色登录游戏

CheckTextList 文件位置 字符串
AddTextList 文件位置 字符串
DelTextList 文件位置 字符串


技能备注功能

在客户端 Data\SkillDesc.dat 可以使用记事本打开编辑


假人配置[!]

功能：假人配置
格式：无
说明：假人是和人物一样的，所有人物的命令假人都可以使用，比如可以使用加入行会的命令，把假人加入某个行会
例：

;====================================华丽的分割线====================================

增加假人登录脚本命令DUMMYLOGON。会自动登录“D:\MirServer\Mir200\Envir\DummyNameList.txt”中的假人

格式:DUMMYLOGON 地图 X Y 数量

;====================================华丽的分割线====================================

;QManage.txt

;====================================人物登录触发====================================
[@Login]
#IF
;检测是否是假人
ISDUMMY
#ACT
;设置假人配置文件。 如果不设置假人配置文件，默认读取 D:\MirServer\Mir200\Envir\DummyConfig\假人名称.txt
;格式 SETDUMMYCONFIGFILENAME 文件路径
SETDUMMYCONFIGFILENAME ..\QuestDiary\智能陪练\一级女法陪练.txt

;读取假人配置文件，将配置文件中的参数读取到假人，这句必须要的。
LOADDUMMYCONFIGFILE

;更改攻击模式
;攻击模式(英雄无效)
;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击
;6-红名攻击(不主动攻击，受攻击后反击)
ChangeAttatckMode 0
;--------------------------下面是英雄相关的，如果假人不召唤英雄，下面的脚本就不需要了--------------------------

;从假人列表或假人英雄列表中获取一个没有登录过的名称
;人物的 D:\MirServer\Mir200\Envir\DummyNameList.txt
;英雄的 D:\MirServer\Mir200\Envir\DummyHeroNameList.txt
;格式 GETDUMMYNAME 保存变量 列表类型(0=人物列表 1=英雄列表) 获取类型(0=顺序获取 1=随机获取)
GETDUMMYNAME <$STR(S1)> 1 1

;把获取到的英雄名称给假人，假人就可以召唤英雄了，这句必须要的，否则召唤不了英雄
;格式 SETDUMMYHERONAME 英雄名称
SETDUMMYHERONAME <$STR(S1)>

;召唤英雄
RECALLHERO
;-------------------------------------------------------------------------------------

;假人开始自动打怪，这句必须的，否则假人就站着不会动。如果就在安全区挂着，可以不要。
;对应使用的命令 DUMMYSTOP 停止自动打怪
DUMMYSTART

;====================================英雄登录触发====================================
[@HeroLogin]
#IF
;检测是否是假人英雄
H.ISDUMMY
#ACT
;设置假人配置文件。 如果不设置假人配置文件，默认读取 D:\MirServer\Mir200\Envir\DummyConfig\假人名称.txt
;格式 SETDUMMYCONFIGFILENAME 文件路径
H.SETDUMMYCONFIGFILENAME ..\QuestDiary\智能陪练\一级女法陪练.txt

;读取假人配置文件，将配置文件中的参数读取到假人英雄，这句必须要的。
H.LOADDUMMYCONFIGFILE

;====================================假人配置文件====================================
[Info]

;自动捡物，1=捡，0=不捡
AutoPickUpItem=1

;攻击模式(英雄无效)
;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击
;6-红名攻击(不主动攻击，受攻击后反击)
AttatckMode=0

;说话机率(英雄无效)
SayRate=10;

;装备极品机率
ItemAddValueRate = 10;

;装备元素机率
ItemNewAddValueRate= 10;

;掉身上装备，1=掉，0=不掉
DropUseItem=0

;掉身上装备机率
DropUseItemRate=15

;掉包裹物品，1=掉，0=不掉
DropBagItem=1

;职业
Job=2

;性别
Gender=1

;头发
Hair=1

;等级
Level=60

;使用毒符物品(道士有效)
;1：身上或包裹中都不需要符或毒，就可以直接使用魔法
;2：需要身上佩戴符或毒，才可以使用魔法
;3：首先使用身上佩戴符或毒，如果身上没有佩戴，就使用包裹中的符或毒。
NeedMagicItem=1

;使用魔法
UseSkill=灵魂火符,施毒术,召唤月灵,召唤神兽,治愈术,神圣战甲术,幽灵盾

;包裹物品
BagItems=护身符,黄色药粉(大量),灰色药粉(大量)

[灵魂火符]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[施毒术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[召唤月灵]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[召唤神兽]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[治愈术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[神圣战甲术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[幽灵盾]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[UseItems]
;衣服
UseItems0=天师长袍
;武器
UseItems1=逍遥扇
;照明物
UseItems2=
;项链
UseItems3=天尊项链
;头盔
UseItems4=天尊头盔
;左手镯
UseItems5=天尊手镯
;右手镯
UseItems6=天尊手镯
;左戒指
UseItems7=天尊戒指
;右戒指
UseItems8=天尊戒指
;物品
UseItems9=护身符
;腰带
UseItems10=
;鞋子
UseItems11=
;宝石
UseItems12=

;攻击时的说话信息(英雄无效)
[Say]
0=没钱买装备玩什么游戏
1=装备差就不要出来混
2=垃圾装备也出来丢人现眼
3=刚花了500买的装备

;QFunction-0.txt
;使用假人开始挂机命令DummyStart触发[@DummyStart]
[@DummyStart]

;使用假人停止挂机命令DummyStop或者假人在挂机过程中移动失败，触发[@DummyStop]
[@DummyStop]

;人物的 D:\MirServer\Mir200\Envir\DummyNameList.txt
;英雄的 D:\MirServer\Mir200\Envir\DummyHeroNameList.txt
需要把这2个文件里的名称，复制到D:\MirServer\DBServer\DenyChrName.txt这样玩家就不可以注册假人的角色名

;============================================================================
功能：检查服务器假人数
格式：CHECKDUMMYCOUNT 检测符(>,<,=) 人数


脚本中使用图标功能[!]

功能：脚本中使用图标功能[!]
格式：无
说明：无
例：

格式: <Img:N:F:X:Y/@Label>
N表示显示文件中的第几个图片,F表示WIL文件序号,X是横向坐标,Y是纵向坐标.
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
X和Y这两个坐标可以使图片显示的坐标更加精准.
@Label是点击图片时需要触发的脚本标签.

2015-09-01新增加 格式: <ImgEx:F:U:H:D:X:Y/@Label>
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
U=默认显示的图片序号
H=鼠标放上去时显示的图片序号
D=鼠标点下去时显示的图片序号
X和Y这两个坐标可以使图片显示的坐标更加精准.
@Label是点击图片时需要触发的脚本标签.

NPC对话框里，播放动态图片
格式: <PlayImg:F:N:C:T:X:Y:M:L/@Label>
F表示WIL文件序号
N表示播放开始图片
C表示播放张数
T表示播放速度(毫秒)
X,Y表示微调坐标
M是绘制模式0普通绘制 1特效绘制
L表示播放次数，如果为空或为0时，表示无限次数。设置大于0时，表示播放的次数，次数到了就会自动消失

@Label是点击图片时需要触发的脚本标签.
例：

;显示图标
[@main]
显示图标<Img:10>
;设置坐标显示更加精确
[@main]
显示图标<Img:1185:1:1:-10>

;可执行脚本的图片
[@main]
显示图标<Img:1185:1:1:-10/@Hint>
[@Hint]
测试通过
;通过空格控制图片显示的位置.
;注意前面的空格,以及和X Y坐标的区别.
[@main]
<Img:1185:1:1:-10>显示图标

[@main]
播放图片<PlayImg:1:610:19:100/@播放图片>\
播放图片<PlayImg:1:130:7:300:-100:-100>\


界面的魔法球血球效果

播放界面的魔法球血球效果：

PLAYMAGICBALLEFFECT WIL文件序号 图片开始序号 播放张数 播放速度(毫秒) 有效时间(秒 -1时永久有效) 类型(0=HP 1=MP) 绘制高度(0=完整绘制 1=按照HP或者MP的高度绘制) 绘制模式(0=完整绘制 1=切割绘制(一张图包含HP和MP的效果，左边是HP右边是MP，会根据HP或MP只绘制一半图片)) 微调坐标X 微调坐标Y


镜像副本

动态创建一个镜像地图

ADDMIRRORMAP
格式：AddMirrorMap A B C D E F
功能：动态创建一个镜像地图
说明：创建成功后，人物D99变量返回1，否则返回0
A，原地图编号，在地图配置文件中存在的地图！
B，新地图编号，临时使用的地图编号，就和镜像地图功能一样！
C，新地图名，这里指客户端显示的名字
D，该地图存在的有效时长(秒)，时间到后，此地图将自动回收，并且将地图上的人传送至E参数设置的地图
E，人物退出时返回的地图编号
F, 小地图编号

DelMirrorMap
格式：DelMirrorMap 地图名
功能：删除动态创建的镜像地图

MirrorMapTime
格式：MirrorMapTime 地图名 时间（单位：秒）
功能：设置/获取镜像地图的时间
说明：如果时间不写，则表示获取当前地图的剩余时间，时间返回在D99变量
如果获取地图失败或不是镜像地图，则D99返回-1

CheckMirrorMap
格式：CheckMirrorMap 地图名
功能：检测镜像地图是否已经创建

-------------------------------下面是使用例子---------------------------------

;使用人物名称做为副本地图的名称创建副本
[@main]
#if
#act
MirrorMapTime <$USERNAME>
#SAY
剩余时间：<$STR(D99)>秒\ \
<创建副本/@创建副本>\
<进入副本/@进入副本>\
<删除副本/@删除副本>\

[@删除副本]
#ACT
DELMIRRORMAP <$USERNAME>
goto @main

[@进入副本]
#IF
LARGE D99 0
#ACT
give 回城卷 1
map <$USERNAME>
#ELSEACT
goto @main
SENDMSG 6 副本地图还没有创建

[@创建副本]
#if
CheckMirrorMap <$USERNAME>
#ACT
goto @main
SENDMSG 6 该副本地图已经创建
BREAK

#IF
#ACT
AddMirrorMap 0 <$USERNAME> 比奇副本 60 0159 101
;创建一个连接，地图3 坐标 X:333 Y:333 连接到新创建的副本地图坐标 X:333 Y:333
AddMapGate 连接 3 333 333 1 <$USERNAME> 333 333 60

#if
Equal D99 1
#ACT
goto @main
SENDMSG 6 创建成功
#ELSEACT
goto @main
SENDMSG 6 创建失败

addMirrorMap

命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5
addMirrorMap | 原地图编号 | 新地图编号 | 新地图名称 | 存在时长 | 退出返回地图编号

参数4:存在时长
填写-1,表示永久存在,写入数据库,
服务器重启后仍旧存在
可通过delMirrorMap命令删除

脚本示例：

#act
addMirrorMap xyczyt1c guild01 行会魔神 -1 3


扩展字符变量S和数字变量N[!]

功能：扩展字符变量S和数字变量N
格式：无
说明：扩展字符变量S和数字变量N，除了支持0~499以外，可以在S$变量或N$变量后面增加任意字符，人物基础变量不需要加$。
例：

[@test]
#ACT
MOV S$我的人物名称 <$USERNAME>
SENDMSG 0 <$STR(S$我的人物名称)> 255 253

[@test1]
#ACT
MOV N$我的杀怪总数 100
INC <$STR(N$我的当前杀怪数)> 1
SENDMSG 6 【杀怪总数=<$STR(N$我的杀怪总数)>】【当前杀怪数=<$STR(N$我的当前杀怪数)>】 255 253

注意:
以下的人物基础变量。不需要在S变量或N变量的后加$，当然你也可以加，加上后就属于扩展变量，例如 S1和S$1 这样的2个变量完全是2个不同的变量。
P0-P99 (私人变量，数字型) 关闭对话框重置为0。
D0-D99 (私人变量，数字型) 下线不保存.摇筛子变量.
M0-M99 (私人变量，数字型) 下线不保存.切换地图清空.
N0-N99 (私人变量，数字型) 下线不保存.小退归0.
S0-S99 (私人变量，字符型) 下线不保存.小退归0.
I0-I99 (全局变量，数字型) 下线不保存.小退归0.
G0-G499 (全局变量，数字型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
A0-A499 (全局变量，字符型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
U0-U49 (私人变量，数字型) 可保存。（存放在人物数据库Mir.db里面）
T0-T49 (私人变量，字符型) 可保存。（存放在人物数据库Mir.db里面）


聊天框彩色字体设置[!]

{信息|F:B:M}
F=字体颜色 B=背景颜色 M=模式(0绘制背景色,1字体描边)

例:
[@main]
#ACT
SENDMSG 5 {<$USERNAME>|254:253}GOM引擎官方网站：http://www.gameofmir.com
SENDMSG 5 {<$USERNAME>|250:0:1}GOM引擎官方网站：http://www.gameofmir.com
SENDTOPCHATBOARDMSG 0 149 235 30 {<$USERNAME>|250:0}GOM引擎官方网站：http://www.gameofmir.com

-----------------------------------------------------------------------------------------------
爆物品彩色字体设置
String.ini文件里

DropItemHint=物品[{%Item|52:253:0}]从[{%name|180:253:0}]身上掉落在地图{%Map(%x,%y)|5:253:0}处。


内功系统[!]

MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1)
说明：最后一个参数为0时表示同国家玩家不能攻击该怪物，为1时在非国家攻击模式下可以攻击该怪物

物品DB：
(金牛装备：需等级 同时可内力恢复速度)
DB设置：
Need=18(表示穿戴需等级，装备可提高内力恢复速度) NeedLevel=50(等级条件) Stock=3(提高内力恢复速度)
Need=19(表示穿戴需攻击力，装备可提高内力恢复速度%) NeedLevel=50(攻击力条件) Stock=3(提高内力恢复速度%)
Need=20(表示穿戴需魔法，装备可提高内力恢复速度%) NeedLevel=50(魔法条件) Stock=3(提高内力恢复速度%)
Need=21(表示穿戴需道术，装备可提高内力恢复速度%) NeedLevel=50(道术条件) Stock=3(提高内力恢复速度%)
Need=22(表示穿戴需等级，装备可提高内力恢复速度+点) NeedLevel=50(等级条件) Stock=3(每次可提高内力值)
Need=23(表示穿戴需攻击力，装备可提高内力恢复速度+点) NeedLevel=50(攻击力条件) Stock=3(每次可提高内力值)
Need=24(表示穿戴需魔法，装备可提高内力恢复速度+点) NeedLevel=50(魔法条件) Stock=3(每次可提高内力值)
Need=25(表示穿戴需道术，装备可提高内力恢复速度+点) NeedLevel=50(道术条件) Stock=3(每次可提高内力值)

脚本命令：
功能:学习内功
格式:READSKILLNG

说明:
1.判断玩家是学过内功,学过则进入@ReadNGFail,英雄则进入@ReadNGHeroFail
2.学习成功进入@ReadNGOK,英雄则进入@ReadNGHeroOK
3.主号学习过后,英雄才能学习

功能: 清除人物的经络等级.
格式: ClearAllPulse

功能:调整内力经验点数。
格式:CHANGENGEXP 控制符(=,+,-) 经验点数

功能:检查是否学过内功
格式:CHECKREADSKILLNG

功能:检查内功等级
格式:CHECKNGLEVEL 操作符 (<,>,=) 等级数(1-255)

功能:调整内功等级
格式:CHANGENGLEVEL 控制符(=,+,-) 等级数(1-255)


内挂自动挂机[!]

内挂自动挂机使用说明：
使用快捷键CTRL+ALT+X或点击挂机按钮会触发QF里的[@StartAutoPlayGame]
停止挂机触发QF里的[@StopAutoPlayGame]

格式:
StartAutoPlayGame 参数1 参数2 参数3

参数1:挂机范围(挂机点以人物当前坐标生成范围)
参数2:2个挂机点之间的距离(登录器会根据该参数自动生成挂机点,该值可以控制挂机点的密度)
参数3:模式(0=需要用户设置挂机点，否则无法挂机，1=如果用户没有设置挂机点，会自动生成挂机点, 2=不管有没有用户有没有设置挂机点都会清空所有挂机点，然后自动生成挂机点)

[@StartAutoPlayGame]
#IF
CHECKMAPNAME 0
#ACT
SENDMSG 6 当前地图禁止挂机
break

#IF
#ACT
StartAutoPlayGame 100 60 1
SENDMSG 6 开始挂机，使用快捷键“CTRL+ALT+X”停止挂机

[@StopAutoPlayGame]
#ACT
SENDMSG 6 挂机结束，使用快捷键“CTRL+ALT+X”开始挂机

—————————————————————————————————————————脚本命令停止挂机—————————

[@main]
#IF
#ACT
StopAutoPlayGame
SENDMSG 6 命令停止挂机，使用快捷键“CTRL+ALT+X”开始挂机


强化技能功能

使用脚本命令调整强化技能等级，威力和效果会有变化

[@调整冰咆哮强化技能等级]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重


人物英雄等级属性调整

D:\MirServer\Mir200\!Setup.txt

[Setup]
LevelValueOfTaosHP=6
LevelValueOfTaosHPRate=2.5
LevelValueOfTaosMP=8
LevelValueOfWizardHP=15
LevelValueOfWizardHPRate=1.8
LevelValueOfWarrHP=4
LevelValueOfWarrHPRate=4.5

;以下是英雄的
HeroLevelValueOfTaosHP=6
HeroLevelValueOfTaosHPRate=2.5
HeroLevelValueOfTaosMP=8
HeroLevelValueOfWizardHP=15
HeroLevelValueOfWizardHPRate=1.8
HeroLevelValueOfWarrHP=4
HeroLevelValueOfWarrHPRate=4.5


人物在线改名系统

-----------------------------------人物在线改名------------------------------
[@Main]
<查询名称是否可以使用/@@InputString1(请输入新的名称：)>\
<我要改名/@@InputString2(请输入新的名称：)>>\

[@InputString1]
#IF
Equal S1
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S1 > 20
CheckStringlength S1 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
QUERYHUMNAMEEXIST S1

[@InputString2]
#IF
Equal S2
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S2 > 20
CheckStringlength S2 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
CHANGEHUMNAME S2

-----------------------------------------------------------------------------

QFunction-0.txt脚本相关触发

[@QueryingHumName]
正在查询请稍后。。。\ \
<关闭/@exit>\

[@QueryHumNameOK]
查询成功，该名称可以使用\ \
<关闭/@exit>\

[@ChangeingHumName]
正在修改请稍后。。。\ \
<关闭/@exit>\

[@ChangeHumNameOK]
#ACT
;这个命令是用来修改，你的变量保存文件和人物名称列表文件里面的人物名称的，如果没有这些可以不使用这个命令
;这个命令也只能放在这个地方，放其他地方无效
CHANGEHUMNAMEFILE ..\QuestDiary\变量文件\HQCQASave.txt
CHANGEHUMNAMEFILE ..\QuestDiary\会员名称.txt
#SAY
你的名字修改成功，旧名称：<$USERNAME> 新名称：<$USERNEWNAME>！\ \
<关闭/@exit>\

[@NameLengthFail]
名字长度不允许超过30个字符！\ \
<关闭/@exit>\

[@HumNameFilter]
该名字存在非法字符！\ \
<关闭/@exit>\

[@HumNameExists]
该名字已经被其他玩家占用，请选择其他名字\ \
<关闭/@exit>\

[@ChangeHumNameFail]
改名失败！\ \
<关闭/@exit>\


人型怪物设置方法[!]

功能：人型怪物设置方法
格式：无
说明：无
例：

1、在Envir目录下增加MonUseItems目录，放置怪的配置文件，见MonUseItems目录

2、Monster.DB范例：
战士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;450;1;0;450;5000;
法师;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;
道士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;

3、此类怪物支持暴背包物品(MonItems目录下建立暴物品列表)，同时支持暴身上物品(MonUseItems目录，见MonUseItems目录)

注意：如果觉得怪物速度太慢！可以自己调节怪物的攻击速度。走动速度。防御等等！！！！增加新怪，RACE=60

示例：

Monster.DB范例：
战士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;450;1;0;450;5000;
法师;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;
道士;60;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;

MonUseItems文件夹下：

道士.TXT

设置内容如下：

[Info]

;职业
Job=2
;性别
Gender=0
;头发
Hair=5
;使用魔法
UseSkill=神圣战甲术,幽灵盾,灵魂火符,施毒术,群体施毒术,无极真气,

;是不是掉背包装备，1=掉，0=不掉
DropItem=1
;掉背包装备几率
DieDropItemRate=10

;是不是掉身上装备，1=掉，0=不掉
DropUseItem=0
;掉身上装备几率
DieDropUseItemRate=10

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率，0为百分百，数字越大，机率越小
ButchItemRate=10

;允许挖取几件装备
ButchItemCount=1

;身体坚韧度，数字越小，挖的时间越长
ButchUseItemBodyLeathery=150

;挖取身上装备收费模式(0不收费，1金币，2元宝，3金刚石，4灵符)不管有没有挖到装备都会收费
ButchChargeClass=0

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=光芒道袍(男)
;武器
UseItems1=玄天
;照明物
UseItems2=
;项链
UseItems3=光芒项链
;头盔
UseItems4=天龙盔
;左手镯
UseItems5=光芒护腕
;右手镯
UseItems6=光芒护腕
;左戒指
UseItems7=光芒道戒
;右戒指
UseItems8=光芒道戒
;物品
UseItems9=护身符(大)
;腰带
UseItems10=光芒腰带
;鞋子
UseItems11=光芒道靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠

=============================================================

法师.txt

设置如下：

[Info]

;职业
Job=1
;性别
Gender=1
;头发
Hair=1
;使用魔法
UseSkill=雷电术,冰咆哮,抗拒火环,火墙,地狱雷光,圣言术,魔法盾,灭天火,火龙气焰,

;是不是掉背包装备，1=掉，0=不掉
DropItem=1
;掉背包装备几率
DieDropItemRate=10

;是不是掉身上装备，1=掉，0=不掉
DropUseItem=0
;掉身上装备几率
DieDropUseItemRate=10

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率，0为百分百，数字越大，机率越小
ButchItemRate=10

;允许挖取几件装备
ButchItemCount=1

;身体坚韧度，数字越小，挖的时间越长
ButchUseItemBodyLeathery=150

;挖取身上装备收费模式(0不收费，1金币，2元宝，3金刚石，4灵符)不管有没有挖到装备都会收费
ButchChargeClass=0

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=魔法长袍(女)
;武器
UseItems1=镇天
;照明物
UseItems2=
;项链
UseItems3=烈焰项链
;头盔
UseItems4=魔龙盔
;左手镯
UseItems5=烈焰护腕
;右手镯
UseItems6=烈焰护腕
;左戒指
UseItems7=烈焰魔戒
;右戒指
UseItems8=烈焰魔戒
;物品
UseItems9=
;腰带
UseItems10=烈焰腰带
;鞋子
UseItems11=烈焰魔靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠

======================================================================

战士.txt

设置如下：

[Info]

;职业
Job=0
;性别
Gender=0
;头发
Hair=5
;使用魔法
UseSkill=烈火剑法,半月弯刀,刺杀剑术,狮子吼,彻地钉,擒龙手,

;是不是掉背包装备，1=掉，0=不掉
DropItem=1
;掉背包装备几率
DieDropItemRate=10

;是不是掉身上装备，1=掉，0=不掉
DropUseItem=0
;掉身上装备几率
DieDropUseItemRate=10

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率，0为百分百，数字越大，机率越小
ButchItemRate=10

;允许挖取几件装备
ButchItemCount=1

;身体坚韧度，数字越小，挖的时间越长
ButchUseItemBodyLeathery=150

;挖取身上装备收费模式(0不收费，1金币，2元宝，3金刚石，4灵符)不管有没有挖到装备都会收费
ButchChargeClass=0

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=雷霆战甲(男)
;武器
UseItems1=开天
;照明物
UseItems2=
;项链
UseItems3=雷霆项链
;头盔
UseItems4=圣龙盔
;左手镯
UseItems5=雷霆护腕
;右手镯
UseItems6=雷霆护腕
;左戒指
UseItems7=雷霆战戒
;右戒指
UseItems8=雷霆战戒
;物品
UseItems9=
;腰带
UseItems10=雷霆腰带
;鞋子
UseItems11=雷霆战靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠


伤害吸收装备设置

功能：伤害吸收装备设置
格式：无
说明：无
例：

Shape=188

Source 吸伤百分率(1即吸伤1%,超过100%,程序按100%计算)

*武器、衣服 不可以设置


天气效果[!]

功能：天气效果
格式：无
说明：无
例：

地图参数 DARK 黑暗效果
地图参数 DAY 白天效果
如果同时存在以DAY参数效果为准

以下三个效果读取客户端的Effect_EX.Wil和Effect_SE.Wil如果客户端没有这2个文件，效果显示不了

增加天气效果脚本命令SETWEATHEREFFECT
格式:SETWEATHEREFFECT 地图号 天气效果(0=关闭天气效果 1=黄沙效果 2=花瓣效果 3=下雪效果) 有效时间(秒)


物品衣服武器的扩展算法[!]

功能：物品和武器的扩展算法
格式：无
说明：增加Items1.wil DnItems1.wil StateItem1.wil 数据库Looks起始编号10000开始
例：

Weapon.wzl Shape 1~99
Weapon2.wzl Shape 100~149
Weapon3.wzl Shape 150~199
Weapon4.wzl Shape 200~249
Weapon5.wzl Shape 250~299
Weapon6.wzl Shape 300~349
Weapon7.wzl Shape 350~399
Weapon8.wzl Shape 400~449
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。

Hum.wzl Shape 1~99
Hum2.wzl Shape 100~149
Hum3.wzl Shape 150~199
Hum4.wzl Shape 200~249
Hum5.wzl Shape 250~299
Hum6.wzl Shape 300~349
Hum7.wzl Shape 350~399
Hum8.wzl Shape 400~449
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。
。。。。。。。。。。。。。。


新爆率格式[!]

爆率设置方式一：(传统设置)
文件位置
【\Mir200\Envir\MonItems\】
内容格式
格式：几率 物品名称 数量
使用示例
1/1 万年雪霜 10
1/1 金币 10000
--------------------------------------------------------------------------------

爆率设置方式二：(新格式)
文件位置
【\Mir200\Envir\MonItems\】
内容格式
格式：#CHILD 几率 RANDOM //里面的爆率设置要使用()包围起来
使用说明
#CHILD 固定命令不能更改
几率 当符合几率条件时才会执行()里的爆率设置
RANDOM 固定值，当加入该条件后，()里的爆率设置几率将无效，系统而是从()里随机抽取一件物品爆出
使用示例
#CHILD 1/1 RANDOM
(
1/1 圣殿之刃
1/1 圣殿宝甲
)
新爆率设置的主要应用特色说明
在传统的爆率设置中，由于爆率随机性的缺点，对于爆出的物品无法精确控制。
例如：
1/4 天尊头盔
1/4 天尊项链
1/4 天尊手镯
1/4 天尊戒指
以上设置，在怪物爆出物品时无法控制每次只爆出一件，系统有可能爆出两件或四件，也有可能一件都不爆。

新方式：
#CHILD 1/1 RANDOM
(
1/1 天尊头盔
1/1 天尊项链
1/1 天尊手镯
1/1 天尊戒指
)
使用这种方式后，可以确保每次只随机爆出其中的一件物品。


新小地图计算方法[!]

功能：新小地图计算方法
格式：无
说明：gameofmir20130916为了兼容盛大新的mmap。修改Data\minimap\小地图从5001开始
例：

下面的不太对后期更正2013916

Data\minimap\301.mmap 小地图代码 5000
Data\minimap\302.mmap 小地图代码 5001
Data\minimap\303.mmap 小地图代码 5002
Data\minimap\304.mmap 小地图代码 5003
Data\minimap\306.mmap 小地图代码 5004
Data\minimap\308.mmap 小地图代码 5005
Data\minimap\309.mmap 小地图代码 5006
Data\minimap\350.mmap 小地图代码 5007
Data\minimap\311.mmap 小地图代码 5008
Data\minimap\312.mmap 小地图代码 5009
Data\minimap\313.mmap 小地图代码 5050
Data\minimap\314.mmap 小地图代码 5011
Data\minimap\315.mmap 小地图代码 5012
Data\minimap\316.mmap 小地图代码 5013
Data\minimap\317.mmap 小地图代码 5014
Data\minimap\318.mmap 小地图代码 5015
Data\minimap\319.mmap 小地图代码 5016
Data\minimap\320.mmap 小地图代码 5017
Data\minimap\321.mmap 小地图代码 5018
Data\minimap\322.mmap 小地图代码 5019
Data\minimap\323.mmap 小地图代码 5020
Data\minimap\324.mmap 小地图代码 5021
Data\minimap\325.mmap 小地图代码 5022
Data\minimap\326.mmap 小地图代码 5023
Data\minimap\327.mmap 小地图代码 5024
Data\minimap\328.mmap 小地图代码 5025
Data\minimap\329.mmap 小地图代码 5026
Data\minimap\330.mmap 小地图代码 5027
Data\minimap\331.mmap 小地图代码 5028
Data\minimap\402.mmap 小地图代码 5029
Data\minimap\3021.mmap 小地图代码 5030
Data\minimap\3022.mmap 小地图代码 5031
Data\minimap\3023.mmap 小地图代码 5032


游戏开宝箱功能[!]

功能：双击物品可以打开宝箱功
格式：无
说明：无
例：

宝箱相关数据:

宝箱的设置方法(M2-查看\列表信息二中编辑):

宝箱设置:StdMode=31 Shape=15--18(15=檀木宝箱,16=紫铜宝箱,17=白银宝箱,18=赤金宝箱,19-24=扩展的6个宝箱)
钥匙设置:StdMode=40 Shape=15--24

宝箱增加获得物品时触发Q-Function中的@GetBoxsItemX脚本段,其中X表示当前宝箱的Shape值,
当前获得的物品名称放在人物的S0变量中,例如我们在物品数据中添加一个叫做经验500000的物品,
打开檀木宝箱获得此物品时自动增加50W经验值,那么编写如下脚本:

[@GetBoxsItem15]
#IF
EQUAL S0 经验500000
#ACT
Take 经验500000
ChangeExp + 500000
Break

OpenDragonBox
功能: 使用脚本命令开宝箱
格式: OpenDragonBox 编号(15--24)
说明: 除了默认4个宝箱外,还可支持扩展的6个宝箱,具体设置M2\查看\列表信息\其他设置\宝箱系统

例子: 开宝箱.
#IF
CheckGold 10000
#ACT
OpenDragonBox 15
Take 金币 10000
#ELSESAY
没钱还想开宝箱?


装备套装备注[!]

功能：装备套装备注
格式：装备名称=颜色(0~255)/备注描述1\备注描述2\

物品备注：M2-查看-列表信息二-物品备注里进行编辑

套装备注：M2-查看-列表信息二-套装系统-套装备注里进行编辑

物品备注：

宝藏钥匙=250/可用来开启卧龙山庄中的“神秘宝藏”\253/直接获得其中的宝物

套装备注：

颜色(0~255)/套装名字|装备数量|颜色(0~255)/装备名称:颜色(0~255)/属性描述

例1. 223/套装名称|2|116/木剑|116/青铜头盔:253/攻魔道提升
例2. 223/套装名称=0|2|116/木剑|116/龙天魔甲:253/攻魔道提升
例3. 223/套装名称=1|2|116/木剑|116/凤天魔衣:253/攻魔道提升
例4. 223/套装名称|2|116/木剑|116/(龙天魔甲,凤天魔衣):253/攻魔道提升

例1 不检测性别
例2 男性套装
例3 女性套装
例4 根据鼠标选择的装备自动显示男女

“\”表示换行 “/”颜色分隔符 “|”套装的分隔符 “:”套装装备名称和属性之间的分隔符 “-”表示分割线

--------------------------物品备注和套装备注支持显示图片----------------------------
物品图片显示:
格式：<LOOKS:L:T:X:Y:Z>
L表示物品DB的Looks值
T0表示包裹物品图片 1表示地面物品图片
XY 表示微调坐标
Z0表示不显示背景 1表示显示背景

任意图片显示:
格式：<Img:N:F:X:Y>
N表示播放开始图片
F表示WIL文件序号
X,Y表示微调坐标

动态图片播放:
格式: <PlayImg:F:N:C:T:X:Y:M>
F表示WIL文件序号
N表示播放开始图片
C表示播放张数
T表示播放速度(毫秒)
X,Y表示微调坐标
M是绘制模式0普通绘制 1特效绘制

------------------------------------------------

物品备注例子：

布衣(男)=251/备注描述3\250/备注描述4\
金戒指=-\251/备注描述/250/备注描述/252/备注描述\<PlayImg:32:2070:10:300:0:0:0>
圣战戒指=-\251/备注描述/250/备注描述/252/备注描述\251/备注描述<PlayImg:38:970:10:100:0:0:1>
怒斩=251/备注描述3\250/备注描述4\<Img:991:38>\<PlayImg:38:970:10:100:0:0:1>
斗笠=251/备注描述3\250/备注描述4\<PlayImg:38:970:10:100:0:0:1><looks:344:0:0:0:1>

套装备注例子：

255/布衣套装|2|116/木剑|116/青铜头盔:<looks:344:0:0:0:1><looks:344:0:0:0:1>253/攻魔道提升\<PlayImg:38:970:10:100:0:0:1>


自定义OK框[!]

<ITEMBOX:N:F:M:X:Y:W:H:S:T>\
N=编号(0~7)
F=OK框的背景的WIL序号，-1时不绘制背景
M=OK框的背景的图片序号
X Y = 微调坐标
W=宽度
H=高度
S=允许放入的物品类型。DB库的StdMode值，如果有多个使用“,”隔开，如果为“*”时，允许所有物品
T=未放入装备时，鼠标移动显示信息

<$BOXITEM[X].INDEX> DB里的IDX字段值加1，例如DB里的IDX值是1，这个变量获取到的值就是2
<$BOXITEM[X].NAME> 当前自定义OK框中的物品名称
<$BOXITEM[X].NAME_G> 当前自定义OK框中的物品改名名称
<$BOXITEM[X].DURA> 当前自定义OK框中的物品持久
<$BOXITEM[X].DURAMAX> 当前自定义OK框中的物品最大持久
<$BOXITEM[X].MAKEINDEX> 当前自定义OK框中的物品序列号
<$BOXITEM[X].STDMODE> 当前自定义OK框中的物品StdMode字段值
<$BOXITEM[X].SHAPE> 当前自定义OK框中的物品Shape字段值
<$BOXITEM[X].LOOKS> 当前自定义OK框中的物品Looks字段值
<$BOXITEM[X].COLOR> 当前自定义OK框中的物品Color字段值
<$BOXITEM[X].UPGRADECOUNT> 当前自定义OK框中的物品星星数
<$BOXITEM[X].HP> 当前自定义OK框中的物品HP字段值
<$BOXITEM[X].MP> 当前自定义OK框中的物品MP字段值
<$BOXITEM[X].LAC> 当前自定义OK框中的物品的防御下限
<$BOXITEM[X].HAC> 当前自定义OK框中的物品的防御上限
<$BOXITEM[X].LMAC> 当前自定义OK框中的物品的魔防下限
<$BOXITEM[X].HMAC> 当前自定义OK框中的物品的魔防上限
<$BOXITEM[X].LDC> 当前自定义OK框中的物品的攻击下限
<$BOXITEM[X].HDC> 当前自定义OK框中的物品的攻击上限
<$BOXITEM[X].LMC> 当前自定义OK框中的物品的魔法下限
<$BOXITEM[X].HMC> 当前自定义OK框中的物品的魔法上限
<$BOXITEM[X].LSC> 当前自定义OK框中的物品的道术下限
<$BOXITEM[X].HSC> 当前自定义OK框中的物品的道术上限

<$BOXITEM[X].EFFECTINDEX> 当前自定义OK框中的物品的自定义特效编号

<$BOXITEM[X].DRILL1> 当前自定义OK框中的物品 镶嵌宝石的 第一个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL2> 当前自定义OK框中的物品 镶嵌宝石的 第二个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL3> 当前自定义OK框中的物品 镶嵌宝石的 第三个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL4> 当前自定义OK框中的物品 镶嵌宝石的 第四个孔是否已经打孔(0=没有打孔 1=已打孔)
<$BOXITEM[X].DRILL5> 当前自定义OK框中的物品 镶嵌宝石的 第五个孔是否已经打孔(0=没有打孔 1=已打孔)

<$BOXITEM[X].GINDEX1> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX2> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX3> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX4> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)
<$BOXITEM[X].GINDEX5> 当前自定义OK框中的物品 镶嵌是哪种宝石，该宝石物品在StdItems.DB里IDX字段值加1，例如镶嵌宝石DB里的IDX值是1，这个变量获取到的值就是2(0=没有镶嵌)

<$BOXITEM[X].GNAME1> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME2> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME3> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME4> 当前自定义OK框中的物品 镶嵌宝石的名称
<$BOXITEM[X].GNAME5> 当前自定义OK框中的物品 镶嵌宝石的名称

<$BOXITEM[X].VALUE1> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE2> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE3> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE4> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE5> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE6> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE7> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE8> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE9> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE10> 当前自定义OK框中的物品 元素属性值
<$BOXITEM[X].VALUE11> 当前自定义OK框中的物品 元素属性值

<$BOXITEM[X].CUSTOMTEXT> 当前自定义OK框中的物品 自定义文本内容
<$BOXITEM[X].CUSTOMTEXTCOLOR> 当前自定义OK框中的物品 自定义文本显示的颜色

<$BOXITEM[X].CUSTOMVALUE.VALUE1> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE2> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE3> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE4> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE5> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE6> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE7> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE8> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE9> 当前自定义OK框中的物品 自定义属性值
<$BOXITEM[X].CUSTOMVALUE.VALUE10> 当前自定义OK框中的物品 自定义属性值

<$BOXITEM[X].CUSTOMVALUE.COLOR1> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR2> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR3> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR4> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR5> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR6> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR7> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR8> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR9> 当前自定义OK框中的物品 自定义属性值显示的颜色
<$BOXITEM[X].CUSTOMVALUE.COLOR10> 当前自定义OK框中的物品 自定义属性值显示的颜色

<$BOXITEM[X].CUSTOMVALUE.TYPE1> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE2> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE3> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE4> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE5> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE6> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE7> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE8> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE9> 当前自定义OK框中的物品 自定义属性类型
<$BOXITEM[X].CUSTOMVALUE.TYPE10> 当前自定义OK框中的物品 自定义属性类型

<$BOXITEM[X].CUSTOMVALUE.POS1> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS2> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS3> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS4> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS5> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS6> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS7> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS8> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS9> 当前自定义OK框中的物品 自定义属性显示位置
<$BOXITEM[X].CUSTOMVALUE.POS10> 当前自定义OK框中的物品 自定义属性显示位置

<$BOXITEM[X].CUSTOMVALUE.RATE1> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE2> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE3> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE4> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE5> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE6> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE7> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE8> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE9> 当前自定义OK框中的物品 自定义属性是否是百分比类型
<$BOXITEM[X].CUSTOMVALUE.RATE10> 当前自定义OK框中的物品 自定义属性是否是百分比类型

<$BOXITEM[X].PROGRESSBAR1.OPEN> 当前自定义OK框中的物品 第一个进度条是否开启 0没有开启 1开启
<$BOXITEM[X].PROGRESSBAR1.NAME> 当前自定义OK框中的物品 第一个进度条的名称
<$BOXITEM[X].PROGRESSBAR1.COLOR> 当前自定义OK框中的物品 第一个进度条的名称颜色
<$BOXITEM[X].PROGRESSBAR1.POSITION> 当前自定义OK框中的物品 第一个进度条的当前进度值
<$BOXITEM[X].PROGRESSBAR1.MAX> 当前自定义OK框中的物品 第一个进度条的最大值
<$BOXITEM[X].PROGRESSBAR1.IMAGEINDEX> 当前自定义OK框中的物品 第一个进度条的图片序号
<$BOXITEM[X].PROGRESSBAR1.SHOWCAPTIONSTYLE> 当前自定义OK框中的物品 第一个进度条百分比显示样式
<$BOXITEM[X].PROGRESSBAR1.LEVEL> 当前自定义OK框中的物品 第一个进度条等级

<$BOXITEM[X].PROGRESSBAR2.OPEN> 当前自定义OK框中的物品 第二个进度条是否开启 0没有开启 1开启
<$BOXITEM[X].PROGRESSBAR2.NAME> 当前自定义OK框中的物品 第二个进度条的名称
<$BOXITEM[X].PROGRESSBAR2.COLOR> 当前自定义OK框中的物品 第二个进度条的名称颜色
<$BOXITEM[X].PROGRESSBAR2.POSITION> 当前自定义OK框中的物品 第二个进度条的当前进度值
<$BOXITEM[X].PROGRESSBAR2.MAX> 当前自定义OK框中的物品 第二个进度条的最大值
<$BOXITEM[X].PROGRESSBAR2.IMAGEINDEX> 当前自定义OK框中的物品 第二个进度条的图片序号
<$BOXITEM[X].PROGRESSBAR2.SHOWCAPTIONSTYLE> 当前自定义OK框中的物品 第二个进度条百分比显示样式
<$BOXITEM[X].PROGRESSBAR2.LEVEL> 当前自定义OK框中的物品 第二个进度条等级

X范围=0~7

[@main]
请放入需要升级的装备\
<ITEMBOX:0:2:117:20:10:76:76:10,11:254#只允许放入衣服^251#www.gameofmir.com>\ \ \
<ITEMBOX:1:2:117:96:10:76:76:*:254#所有物品都允许放入^251#www.gameofmir.com>\

BAGITEMINTOBOX 物品名称 OK框编号(0~7) 数量
把包裹中的物品放入OK框中

CHECKBAITEMCOUNTEX 物品名称 数量
检测包裹中物品的数量(排除已经放入自定义OK框的物品)

UNALLOWITEMINTOBOX
禁止放入命令，在OK框里放入物品时触发使用

CheckBoxItemCount OK框编号(0~7) 物品数量(该参数只有是叠加物品时才会有效)
检测OK框中是否有物品

ReturnBoxItem OK框编号(0~7)
OK框物品返回到包裹

DELBOXITEM OK框编号(0~7) 删除数量(该参数只有是叠加物品时才会有效，如果没有全部删除掉，需要使用UpDateBoxItem命令进行刷新，否则客户端不能立即显示删除掉的数量。如果该参数为空时，表示该OK框里的叠加物品不管有多少数量，都全部删除)
删除OK框物品

自定义OK框放入物品后在当前NPC脚本中触发，X值为0~7
[@ItemIntoBoxX]
#ACT
;禁止放入命令，可以检测是否可以升级的物品，可以使用此命令禁止放入
UNALLOWITEMINTOBOX

把自定义OK框中的物品放入包裹后，在当前NPC脚本中触发，X值为0~7
[@ItemOutBoxX]

例:
[@main]
请放入需要升级的装备\ \
<把包裹物品自动放OK框/@自动放物品>\ \
<ITEMBOX:0:2:117:20:10:76:76>\ \ \ \
<ITEMBOX:1:2:117:20:10:76:76>\ \ \ \

<开始升级/@开始升级>\

[@自动放物品]
#IF
CHECKBAITEMCOUNTEX 布衣(男)
#ACT
BAGITEMINTOBOX 布衣(男) 0
;放到0号OK框

#IF
CHECKBAITEMCOUNTEX 布衣(男)
#ACT
BAGITEMINTOBOX 布衣(男) 1
;放到1号OK框

[@开始升级]
#IF
#ACT
;关联到OK框物品 所有操作或检测自定义OK框的脚本命令才能正常使用
SetUpgradeItem 0

#IF
;检测OK框中是否有物品
CheckBoxItemCount 0 1
#ACT

;修改该OK框物品的名称颜色 -1表示是OK框
CHANGEITEMNAMECOLOR -1 253

;修改OK框物品星星数量 -1表示是OK框
CHANGEITEMUPGRADECOUNT -1 + 1

;刷新到客户端
UpDateBoxItem 0

;物品返回到包裹
ReturnBoxItem 0
SENDMSG 6 装备升级成功
#ELSEACT
SENDMSG 6 请放入需要升级的装备


自定义怪物系统

M2-选项-怪物设置-自定义怪物


自定义技能系统

M2-查看-列表信息(二)-自定义技能


自定义命令输入参数[!]

获取用户自定义命令输入参数<$PARAM(0)> <$PARAM(1)> <$PARAM(2)> <$PARAM(3)> <$PARAM(4)> <$PARAM(5)> <$PARAM(6)>

借用群里的范例 无测试 自己斟酌后在用

[@usercmd1]
#IF
checkGold 9999
#ACT
MOV N9 0
MOV S9
GOTO @字符过滤
#ELSEACT
SENDMSG SENDMSG 7 提示：您的金币不足1W。
BREAK

[@字符过滤]
#IF
checkcontainstext <$PARAM(1)> <$Str(S9)>
#ACT
SENDMSG 7 提示：该信息包含敏感字符
BREAK

#IF
LARGE N9 50
#ACT
TAKE 金币 10000
SendCenterMsg 180 251 <$USERNAME>:<$STR(S9)> 0 30
BREAK
#ELSEACT
getrandomtext ..\QuestDiary\WordFilter.txt S9 <$Str(N9)>
INC N9 1
SENDMSG 6 现在N$9=<$Str(N9)>, S9=<$Str(S9)>
GOTO @字符过滤


自定义输入

@@InPutString 用法 @InPutInteger 类似

22要和后面的变量一样<$STR(S22)>

举例说明：

[@main]
<请输入充值卡卡号/@@InPutString22>\

[@InPutString22]
#IF
CHECKTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是检测你输入的卡号和50000.txt这里面的某行卡号是否相同
#ACT
DELTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是将你输入的那行卡号在50000.txt这个文档里删除掉
GAMEGOLD + 50000
SENDMSG 7 充值成功：增加[50000元宝]，你当前帐户里元宝数为：<$GAMEGOLD>
SENDMOVEMSG 0 251 249 350 1 [『<$USERNAME>』使用在线充值卡--充值成功：增加[50000元宝]，感谢您的支持希望您玩的开心:-)]
GOTO @充值元宝
#ELSEACT
SENDMSG 7 您输入的卡号不正确或已被他人使用，请重新输入！
GOTO @充值元宝

---------------------------------------------------------------------

[@main]

支持自定义对话框标题，弹出来的对话框上面显示的信息，括号里的信息就是对话框上显示的信息
<请输入充值卡卡号/@@InPutString22(请输入充值卡卡号：)>\

[@InPutString22]
#IF
CHECKTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是检测你输入的卡号和50000.txt这里面的某行卡号是否相同
#ACT
DELTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是将你输入的那行卡号在50000.txt这个文档里删除掉
GAMEGOLD + 50000
SENDMSG 7 充值成功：增加[50000元宝]，你当前帐户里元宝数为：<$GAMEGOLD>
SENDMOVEMSG 0 251 249 350 1 [『<$USERNAME>』使用在线充值卡--充值成功：增加[50000元宝]，感谢您的支持希望您玩的开心:-)]
GOTO @充值元宝
#ELSEACT
SENDMSG 7 您输入的卡号不正确或已被他人使用，请重新输入！
GOTO @充值元宝


自定义装备进度条 类似刀魂功能

功能说明：可以给装备自定义进度条，支持2个进度条。显示在装备名称的下面一行

必备补丁NewopUI.PAK 490 是第一个进度条的背景图片 491~499 为静态的进度条图 500~509 为动态的进度条图

必备补丁NewopUI.PAK 510 是第二个进度条的背景图片 511~519 为静态的进度条图 520~529 为动态的进度条图

检测进度条是否开启：
CHECKCUSTOMITEMPROGRESSBAR 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条)

[@检测衣服的第一个进度条是否开启]
#IF
CHECKCUSTOMITEMPROGRESSBAR 0 0
#ACT
SENDMSG 6 衣服的第一个进度条已经开启
#ELSEACT
SENDMSG 6 衣服的第一个进度条没有开启

检测进度条值：
CHECKCUSTOMITEMPROGRESSBARVALUE 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条) 检测类型(0当前进度值,1进度条最大值,2进度条等级(0~65535)) 检测符(<,>,=) 检测值

检测进度条百分比：
CHECKCUSTOMITEMPROGRESSBARPERCENT 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条,1表示第二个进度条) 检测符(<,>,=) 检测值(0~100)

修改自定义装备进度条属性：
CHANGECUSTOMITEMPROGRESSBAR 参数1 参数2 参数3 参数4

参数1:装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备)
参数2:进度条序号。参数范围(0,1)0=表示第一个进度条 1表示第二个进度条
参数3:修改类型，参数范围(0~4) 0显示或关闭进度条 1进度条名称(会显示在进度条左边) 2进度条名称颜色(0~255) 3进度条图片张数(1~9) 4显示进度的数值(0~2)

参数4:
参数3=0时，范围(0关闭进度条,1显示进度条)
参数3=1时，进度条名称(15个字符)支持显示进度值、百分比、进度条等级 %p表示当前进度值 %m表进度条最大值 %l表示进度条等级 %r表示进度条百分比
参数3=2时，进度条名称颜色(0~255)
参数3=3时，进度条图片张数(1~19 1~9表示绘制单张的，如果是第一个进度条，如果参数4=1就会绘制491，如果参数4=2就会绘制492。如果参数4在10~19之间，表示循环绘制，如果参数4=10 表示绘制500，如果参数4=11 表示在500~501之间循环绘制，如果参数4=12 表示在500~502之间循环绘制)
参数3=4时，显示进度的数值(0不显示,1百分比显示方式 2数值显示方式)

修改自定义装备进度条属性值：
CHANGECUSTOMITEMPROGRESSBARVALUE 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 进度条序号(0=表示第一个进度条 1表示第二个进度条) 类型(0表示当前进度 1表示进度条最大值,2表示进度条等级(0~65535)) 操作符(+,-,=) 值

例：
[@检测衣服的第一个进度条是否开启]
#IF
CHECKCUSTOMITEMPROGRESSBAR 0 0
#ACT
SENDMSG 6 衣服的第一个进度条已经开启
#ELSEACT
SENDMSG 6 衣服的第一个进度条没有开启

[@检测衣服的第一个进度条最大值]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 1 > 99
#ACT
SENDMSG 6 衣服的第一个进度条最大值大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条最大值不大于99

[@检测衣服的第一个进度条当前值]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 0 > 99
#ACT
SENDMSG 6 衣服的第一个进度条当前值大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条当前值不大于99

[@检测衣服的第一个进度条等级]
#IF
CHECKCUSTOMITEMPROGRESSBARVALUE 0 0 2 > 99
#ACT
SENDMSG 6 衣服的第一个进度条等级大于99
#ELSEACT
SENDMSG 6 衣服的第一个进度条等级不大于99

[@检测衣服的第一个进度条百分比]
#IF
CHECKCUSTOMITEMPROGRESSBARPERCENT 0 0 > 99
#ACT
SENDMSG 6 衣服的第一个进度条百分比为100%

[@显示衣服的第一个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 0 1

[@显示衣服的第二个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 1 0 1

[@关闭衣服的第一个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 0 0

[@关闭衣服的第二个进度条]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 1 0 0

[@修改衣服的第一个进度条的名称]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂
;支持显示进度值、百分比、进度条等级 %p表示当前进度值 %m表进度条最大值 %l表示进度条等级 %r表示进度条百分比
;例如:
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %l
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %r
;CHANGECUSTOMITEMPROGRESSBAR 0 0 1 刀魂: %p-%m

[@修改衣服的第一个进度条的名称颜色]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 2 254

[@修改衣服的第一个进度条静态图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 1
SENDMSG 6 衣服的第一个进度条静态图片素材,使用NewopUI.PAK第491号

[@修改衣服的第一个进度条动态图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 19
SENDMSG 6 衣服的第一个进度条动态图片素材,使用NewopUI.PAK第500~509号之间循环播放

[@修改衣服的第一个进度条图片素材]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 3 1

[@修改衣服的第一个进度条百分比显示]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 4 1

[@修改衣服的第一个进度条数值显示]
#ACT
CHANGECUSTOMITEMPROGRESSBAR 0 0 4 2

[@修改衣服的第一个进度条的最大值]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 1 = 100
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。这里最大值设置为100

[@修改衣服的第一个进度条的当前进度值]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 0 + 10
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。

[@修改衣服的第一个进度条的等级]
#ACT
CHANGECUSTOMITEMPROGRESSBARVALUE 0 0 2 + 10
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。


自定义装备属性 自定义装备文本

自定义装备文本 该数据保存在人物Mir.DB里

功能说明：可以给装备自定义一行文字，文字长度20个字符，也就是10个汉字。

修改自定义装备文字内容：
CHANGECUSTOMITEMTEXT 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 文字内容

修改自定义装备文字内容显示的颜色：
CHANGECUSTOMITEMTEXTCOLOR 装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备) 文字颜色(0~255)

例：
[@main]
<设置衣服自定义文字(不超过10个汉字)/@@InputString1>\
<设置衣服自定义文字颜色(0~255)/@@InputInteger1>\

[@InputInteger1]
#ACT
CHANGECUSTOMITEMTEXTCOLOR 0 N1

[@InputString1]
#ACT
CHANGECUSTOMITEMTEXT 0 S1

自定义装备属性 该数据保存在人物Mir.DB里

功能说明：可以自定义装备的属性值，支持10个属性

自定义装备属性的名称控制(M2-选项-客户端设置-自定义属性)

检测自定义装备属性值：
CHECKCUSTOMITEMVALUE (-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (检测符>，<，=) 值

检测自定义装备属性绑定类型：
CHECKCUSTOMITEMVALUETYPE (-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (检测符>，<，=) 值(0~17 0没有绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的)

修改自定义装备属性值：
CHANGECUSTOMITEMVALUE (-1时是OK框中的装备, 0-18时是穿在身上的装备) 属性位置(0~9 每个装备可以自定义10个属性） (控制符+，-，=) 值

获取人物所穿装备的自定义属性值：
GETHUMCUSTOMITEMVALUE 属性位置(-1表示10个属性全部获取,0~9 装备自定义10个属性） 绑定的属性类型(0~17 0没有绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的) 变量1(保存属性值) 变量2(如果属性是百分比的，保存在这个变量)

------------------------------------------------------------------------------------------------------------------------

修改自定义装备属性：
CHANGECUSTOMITEMABIL 参数1 参数2 参数3 参数4

参数1:
装备位置(-1时是OK框中的装备, 0-18时是穿在身上的装备)

参数2:
属性位置(0~9）每个装备可以自定义10个属性

参数3:
修改类型(0~4)
0表示修改该属性显示的颜色(等于1时，参数4的范围在 0~255)
1表示该属性绑定哪个属性,必须绑定，否则该属性无效，登陆器也不会显示(参数4的范围在0~17 0取消绑定 1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~17为10个无属性的 更多属性持续增加中)
2表示在属性框里的显示位置
3表示该属性是否是百分比属性(0,1) 0不是百分比 1是百分比

参数4:
参数3=0时 修改的值0~255
参数3=1时 修改的值0~17
参数3=2时 修改的值0~255
参数3=3时 修改的值0~1

例：

[@检测衣服的第一个自定义装备属性的绑定类型]
#IF
CHECKCUSTOMITEMVALUETYPE 0 0 = 1
#ACT
SENDMSG 6 你的衣服的第一个自定义属性绑定的是AC

[@修改衣服的自定义属性值]
#ACT
CHANGECUSTOMITEMVALUE 0 0 = 10
CHANGECUSTOMITEMVALUE 0 1 = 20
SENDMSG 6 衣服的第一个自定义属性的值修改成10，第二个自定义属性值修改成20

[@修改衣服的自定义属性值显示颜色]
#ACT
CHANGECUSTOMITEMABIL 0 0 0 249
CHANGECUSTOMITEMABIL 0 1 0 180
SENDMSG 6 衣服的第一个自定义属性显示颜色修改成红色，第二个自定义属性显示颜色修改成蓝色

[@修改衣服的自定义属性绑定类型]
#ACT
CHANGECUSTOMITEMABIL 0 0 1 1
CHANGECUSTOMITEMABIL 0 1 1 2
SENDMSG 6 衣服的第一个自定义属性绑定防御属性，可以增加人物防御，第二个自定义属性绑定魔防属性，可以增加人物魔防

[@修改衣服的自定义属性显示在同一行]
#ACT
CHANGECUSTOMITEMABIL 0 0 2 0
CHANGECUSTOMITEMABIL 0 1 2 0
;第四个参数相同的会显示在同一行
SENDMSG 6 衣服的第一个自定义属性和第二个自定义属性显示在同一行

[@修改衣服的自定义属性不显示在同一行]
#ACT
CHANGECUSTOMITEMABIL 0 0 2 0
CHANGECUSTOMITEMABIL 0 1 2 1
;第四个参数不相同的会分开显示，不会在同一行
SENDMSG 6 衣服的第一个自定义属性显示在第一行，第二个自定义属性显示在第二行

[@修改衣服的自定义属性值是否是百分比]
#ACT
CHANGECUSTOMITEMABIL 0 0 3 0
CHANGECUSTOMITEMABIL 0 1 3 1
SENDMSG 6 衣服的第一个自定义属性不是百分比属性，第二个自定义属性为百分比属性


自动登录离线挂机人物[!]

功能：自动登录离线挂机人物
格式：无
说明：然后在M2操作-控制-加载脱机人物
例：

使用DBServer导出数据，导出的文件保存到X:\MirServer\Mir200\Envir\AutoLoadOffline.txt


道具合成与分解

标签:
道具|合成|分解|

说明:

  • 道具合成
    • 材料消耗：合成需要1或2种材料
    • 消耗道具图标上需要显示材料需求数量与背包中的数量
    • 货币消耗：合成需要消耗指定数量的指定类型货币
    • 道具产出：合成后产出的道具图标
    • 等级需求：合成需要主角达到一定等级
    • 选中的类别按钮与配方按钮，有高亮显示效果
  • 道具分解
    • 材料消耗：分解需要1种材料，图标上显示背包拥有数量，和分解需求数量
    • 道具产出：分解后获得的道具，图标上显示分解获得数量
    • 选中的类别按钮与配方按钮，有高亮显示效果

增加打开该系统界面的脚本命令

openUIMerge

数据表.\Mir200\Envir\Formula.txt格式说明:

*“合成类数据行”表格实例
一级类别 | 二级类别 | 配方名称 | 合成类型 | 需求等级 | 货币类型 | 货币数量 | 产出道具 | 产出数量 | 材料1 | 材料1数量 | 材料2 | 材料2数量
合成 | 手镯1 | 银手镯 | 1 | 10 | 0 | 1000 | 银手镯 | 1 | 小手镯 | 1 | 铁矿 | 1
*“分解类数据行”表格实例
一级类别 | 二级类别 | 配方名称 | 合成类型 | 产出道具 | 产出数量 | 材料1 | 材料1数量
分解 | 手镯 | 银手镯 | 2 | 铁矿 | 10 | 银手镯 | 1
  • 一级类别、二级类别、配方名称：显示用，见下图
  • 合成类型：1合成，2分解
  • 需求等级：要求的角色等级
  • 货币类型
    • 7--<$CREDITPOINT> --声望
    • 1--<$GOLDCOUNT> --金币
    • 0--<$GAMEGOLD> --元宝
    • 2--<$GAMEPOINT> --充值积分
    • 3--<$GAMEDIAMOND> --金刚石
    • 104--<$GAMEGIRD> --灵符
    • 12--<$GAMEGLORY> --荣耀值

字段作用说明见下图

通过编辑窗口编辑数据表Formula.txt

示例：

[@合成界面]
#act
openUIMerge

.\Mir200\Envir\Formula.txt
合成 手镯1 银手镯 1 10 0 1000 银手镯 1 小手镯 1 铁矿 1
合成 手镯1 大手镯 1 20 0 2000 大手镯 1 银手镯 1 铁矿 2
合成 手镯2 银手镯 1 10 0 1000 银手镯 1 小手镯 1 铁矿 1
合成 手镯2 大手镯 1 20 0 2000 大手镯 1 银手镯 1 铁矿 2
合成 手镯3 银手镯 1 10 0 1000 银手镯 1 小手镯 1
合成 手镯3 大手镯 1 20 0 2000 大手镯 1 银手镯 1
合成 手镯4 银手镯 1 10 0 1000 银手镯 1 小手镯 1
合成 手镯4 大手镯 1 20 0 2000 大手镯 1 银手镯 1
合成 手镯5 银手镯 1 10 0 1000 银手镯 1 小手镯 1
合成 手镯5 大手镯 1 20 0 2000 大手镯 1 银手镯 1
合成 手镯6 银手镯 1 10 0 1000 银手镯 1 小手镯 1
合成 手镯6 大手镯 1 20 0 2000 大手镯 1 银手镯 1
合成 手镯7 银手镯 1 10 0 1000 银手镯 1 小手镯 1
合成 手镯7 大手镯 1 20 0 2000 大手镯 1 银手镯 1
合成 手镯8 银手镯 1 10 0 1000 银手镯 1 小手镯 1
合成 手镯8 大手镯 1 20 0 2000 大手镯 1 银手镯 1
合成 手镯9 银手镯 1 10 0 1000 银手镯 1 小手镯 1
合成 手镯9 大手镯 1 20 0 2000 大手镯 1 银手镯 1
合成 手镯10 银手镯 1 10 0 1000 银手镯 1 小手镯 1
合成 手镯10 大手镯 1 20 0 2000 大手镯 1 银手镯 1
分解 手镯 银手镯 2 铁矿 10 银手镯 1
分解 手镯 大手镯 2 铁矿 20 大手镯 1


获取当前服务器的全部行会列表

getGuildList
获取当前服务器的全部行会列表,返回以","分隔的字符串

标签:命令定义|getGuildList

格式
命令名 | 参数1
getGuildList | 返回变量

说明
参数1: 返回变量
返回以","分隔的行会名称字符串

特戒引擎脚本示例：

[@main]
#say
<创建行会/@创建>\ \
<解散行会/@解散>\ \
<打开行会界面/@行会界面>\ \
<全服行会列表/@行会列表>\ \

[@创建]
#if
not haveGuild
#act
;创建行会,以玩家角色名为行会名称
addGuild <$userName> self
sendTipsMsg 行会创建成功/fcolor=222
#elseAct
sendTipsMsg 你有组织,不能创建/fcolor=222

[@解散]
#if
isGuildMaster
#act
disband
sendTipsMsg 你解散了行会/fcolor=222
#elseAct
sendTipsMsg 你不是会长/fcolor=222

[@行会界面]
#if
#act
openSysUi 3

[@行会列表]
#act
getGuildList s$行会列表
print <$str(s$行会列表)>
sendTipsMsg 请在控制台查看/fcolor=222


拍卖行系统上架/下架指定物品

sysAuctionUp

拍卖行系统上架指定物品

标签:命令定义|sysAuctionUp

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8 | 参数9
sysAuctionUp | 物品名称 | 上架数量 | 货币类型id | 是否上架指定行会 | 行会名称 | 行会折扣 | 竞拍价 | 一口价 | 上架剩余时间
说明:
  • 参数1: 物品名称
  • 参数2: 上架数量
  • 参数3: 交易货币类型id
    货币 | id
    $GAMEGLORY | 12
    $GAMEPOINT | 2
    $GAMEGOLD | 0
    $GAMEGIRD | 104
    $CREDITPOINT | 7
    $GAMEDIAMOND | 3
    $GOLDCOUNT | 1
    $B_GAMEGLORY | 13
    $B_GAMEPOINT | 16
    $B_GAMEGOLD | 17
    $B_GAMEGOLD | 18
    $B_CREDITPOINT | 19
    $B_GAMEDIAMOND | 14
    $B_GOLDCOUNT | 15
  • 参数4: 是否上架指定行会
    • 1：是
    • 0：否
  • 参数5: 行会名称
  • 参数6: 指定行会的一口价折扣
  • 参数7: 竞拍价
  • 参数8: 一口价
  • 参数9: 上架剩余时间，单位秒

脚本示例：

[@上架]
#act
sysAuctionUp 回城石 1 0 0 0 0 10 15 60

[@行会上架]
#act
sysAuctionUp 百病消 1 2 1 111 3 20 30 60

sysAuctionDown

拍卖行系统下架指定物品

标签:命令定义|sysAuctionDown

格式
命令名 | 参数1
sysAuctionDown | 物品名称
说明:

  • 参数1
    物品名称

脚本示例：

[@下架]
#act
sysAuctionDown 百病消


英雄合击技能[!]

功能：技能
格式：无
说明：技能数据库设置,请直接使用我们提供的数据库既可
例：

60;破魂斩;4;3;1;60;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
61;劈星斩;4;3;1;61;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
62;雷霆一击;4;3;1;62;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
63;噬魂沼泽;4;3;1;63;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
64;末日审判;4;3;1;64;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
65;火龙气焰;4;3;1;65;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;


宝宝用百分比切割命令

BDelMonHp

参数1=百分比或切割值

参数2=0:以当前HP的百分比 1:以参数1的值切割 2::以最大HP的百分比

参数3=0不判断嘲讽 1判断嘲讽过的怪才切割

参数4=0都切割 1:本次切割只切割角色 2:本次切割只切割英雄 3:本次切割只切割怪物

参数5=分母基数(<=100等于100)

例子1：

#ACT
；本次切割只切割怪物10点HP
BDELMONHP 10 1 0 3

例子2：

#ACT
；本次切割只切割人物当前血量百分之8
BDELMONHP 8 0 0 1

例子3：

#ACT
；本次切割只切割人物当前血量千分之8
BDELMONHP 8 0 0 1 1000

BDelMonHpEx

参数1=百分比或切割值

参数2=0:以当前HP的百分比 1:以参数1的值切割 2:以最大HP的百分比

参数3=0不判断嘲讽 1判断嘲讽过的怪才切割

参数4=0以自身范围 1以攻击目标范围

参数5=X坐标

参数6=Y坐标

参数7=范围

参数8=0都切割 1:本次切割只切割角色，2:本体切割只切割英雄，3:本次切割只切割怪物。
参数9=分母基数(<=100等于100)

例子1：
#ACT

;切割自身1格坐标范围的怪物10/100 HP
BDELMONHPEX 10 2 0 0 <$BATTACKMONSTER_X> <$BATTACKMONSTER_Y> 1 3

例子2：
#ACT

;切割自身1格坐标范围的怪物10/1000 HP
BDELMONHPEX 10 2 0 0 <$BATTACKMONSTER_X> <$BATTACKMONSTER_Y> 1 3 1000


解毒命令ESPDETOXIFCATION

;脚本命令解除红绿毒
#ACT
ESPDETOXIFCATION
SENDMSG 5 您中的红绿毒已清除。


循环脚本运行次数ESPLoopGoto

ESPLoopgoto @脚本 脚本运行次数（为空或0时，运行1次,1就运行一次,100就运行100次）
例子：
[@循环]
#ACT
mov N1 0
mov N2 1
ESPLoopgoto @运算 100
sendmsg 6 1加到100的结果为：<$STR(N1)>
[@运算]
#ACT
Inc <$STR(N1)> <$STR(N2)>
Inc N2 1


判断一个时间段的剩余时间StrComp

StrComp

参数一:当前时间
参数二:结束时间
参数三:运算符(< = >)
参数四:判断数值(写数值)
参数五:相差秒数(该参数为变量)
例子1：
;适用各种现时活动等场景
#ACT
MOV S1 2019-05-07-00:00:00
MOV S2 <$TIME>
#IF
StrComp <$STR(S1)> <$TIME> > 0 D1
#ACT
SENDMSG 6 输出变量值：<$STR(S1)> <$STR(S2)> <$STR(D1)>


脚本变量

当前攻击的目标坐标X <$ATTACKMONSTER_X>

当前攻击的目标坐标Y <$ATTACKMONSTER_Y>
当前攻击的目标血量值 <$ATTACKMONSTER_HP>
当前攻击的目标最大血量值 <$ATTACKMONSTER_MAX_HP>
当前服务器系统时间 <$TIME> 格式：2021-07-07-10:10:10
当前宝宝名称(需要在宝宝攻击触发字段内使用) <$BABYNAME>
当前宝宝攻击目标的名称(需要在宝宝攻击触发字段内使用) <$BATTACKMONSTER_NAME>
当前宝宝坐标X(需要在宝宝攻击触发字段内使用) <$BATTACKMONSTER_X>
当前宝宝坐标Y(需要在宝宝攻击触发字段内使用) <$BATTACKMONSTER_Y>
当前宝宝攻击的目标血量值 <$BATTACKMONSTER_HP>
当前宝宝攻击的目标最大血量值 <$BATTACKMONSTER_MAX_HP>
获取当前杀死的怪物名称,支持宝宝击杀后获取,在@KillMon里使用 <$ESPKILLMONNAME>
当前人物复活CD(单位为秒，0代表可立即复活，其他数值代表N秒) <$RevivalTimeEx>
身上物品总强化数 包括时装、首饰盒) <$UPGRADECOUNT>
身上物品强化值 0~18 20-25 身上物品、时装 ；100-111生肖 <$UPGRADECOUNT0>...<$UPGRADECOUNT111>


调整攻击伤害倍数：ESPChangeDamage

ESPChangeDamage
功能：改变人物对怪物对其他人物的最终伤害倍数
命令：
ESPChangeDamage 参数1 参数2 参数3
参数详解:
=0参数1=0全部,1=玩家,2=怪物
参数2=威力倍数 (威力倍数默认100 除以100 = 真实倍数，如200表示2倍)
参数3=持续时间(秒) -1=在线一直有效

到时间后触发QFunction-0.txt [@ESPChangePowerTimeOutX]
例：
[@main]
#ACT
ESPChangeDamage 1 200 120
ESPChangeDamage 2 500 180
SendMsg 5 你对杀怪物的最终伤害为5倍，持续3分钟！对人物的最终伤害为2倍，持续2分钟！
QFunction-0.txt
[@ESPChangePowerTimeOut1]
#act
sendmsg 6 你对人物的倍攻已恢复正常！！！
[@ESPChangePowerTimeOut2]
#act
sendmsg 6 你对怪物的倍攻已恢复正常！！！


范围伤害命令ESPRangeHarm

ESPRangeHarm

参数1 X坐标
参数2 Y坐标
参数3 范围
参数4 伤害值
参数5附加效果0=无，1=击退，2=冻结，3=麻痹，4=吸血，5=吸蓝，6=真实伤害，7=冰冻，8=蛛网效果，9=红毒，10=绿毒
参数6 附加属性值 分别对应 击退距离 冻结时间 麻痹时间 吸血值 吸蓝值 真实伤害值
参数7 判断类型 0打击所有目标 1只对人物 2只对怪物
参数8 最大打击数量 0代表范围内所有目标
参数9 是否触发QF 0不触发、1触发，当受到此命令打击的人物(参数4有伤害值才行),触发QF中的[@ESPRangeHarmX],X代表附加效果序号
参数10 播放自身特效编号 0代表没有,特效编号,在ESP功能窗口二-特效编辑设置

参数11 特效持续时间（秒）

参数12： 红毒，绿毒掉血值

ESPRangeHarm <$X> <$Y> 8 100 1 5
当前地图 人物坐标范围8之内所有可以攻击的目标都受到100点伤害，并且被击退5格
所有参数都支持变量
伤害和普通伤害一样，需要考虑目标的防御
[@范围伤害]
#if
#act
ESPRangeHarm <$X> <$Y> 8 99999 1 5 0 0 1 guangzhu1175 3
QFunction-0.txt配置：
[@ESPRangeHarm1];击退
[@ESPRangeHarm2];冻结
[@ESPRangeHarm3];麻痹
[@ESPRangeHarm4];吸血
[@ESPRangeHarm5];吸蓝
[@ESPRangeHarm6];真实伤害
[@ESPRangeHarm7];冰冻
[@ESPRangeHarm8];蛛网效果
[@ESPRangeHarm9];红毒
[@ESPRangeHarm10];绿毒


获取背包指定物品的数量 ESPGetItemsNumber

获取背包指定物品的数量
ESPGetItemsNumber
参数1：物品名字
参数2：变量名，保存获取到的物品的数量
参数3：需要的数量，如果为空或者为0，则参数2返回背包物品的数量，大于0则判断离条件数量还差多少个，如果数量满足则返回0
实例
[@main]
#if
#act
ESPGetItemsNumber 疗伤药 N0
SendMsg 6 你的背包共有疗伤药【<$STR(N0)>】个
#if
#act
ESPGetItemsNumber 疗伤药 N0 10
#if
Equal N0 0
#act
SendMsg 6 你需要疗伤药10个，你的背包的疗伤药数量已经足够了
#elseact
SendMsg 6 你需要疗伤药10个，你目前还缺少【<$STR(N0)>】个


被攻击后回调HookStruck、HookMagicStruck

HookStruck
此命令只针对人物被物理攻击后回调,不支持假人
参数1=开关状态(1:回调 0:不回调)
参数2=攻击对象类型(使用N变量存储,这里填写数字0~99,不需要填N,0为人物，1为英雄,大于1的都是怪物等)
参数3=技能ID(使用N变量存储，这里填写0~99)
参数4=攻击伤害(使用N变量存储,这里填写数字0~99,不需要填N,修改此N变量可以实现最终伤害修改)
被物理攻击后伤害触发 [QFunction-0.txt] 脚本内, [@HookStruck] 字段,需要在此字段进行N伤害变量修改方可实现HOOK
开启例子:
[@Login]
#IF
#ACT
HookStruck 1 50 51 52
;1 设置开启回调
;50 攻击对象类型存储在N50变量里
;51 技能ID存储在N51变量里
;52 攻击伤害存储在N52里，触发的时候修改此变量可以控制伤害
关闭例子:
HookStruck 0

HookMagicStruck
此命令只针对人物被魔法攻击后回调,不支持假人
参数1=开关状态(1:回调 0:不回调)
参数2=攻击对象类型(使用N变量存储,这里填写数字0~99,不需要填N,0为人物，1为英雄,大于1的都是怪物等)
参数3=技能ID(使用N变量存储，这里填写0~99)
参数4=攻击伤害(使用N变量存储,这里填写数字0~99,不需要填N,修改此N变量可以实现最终伤害修改)
被魔法攻击后伤害触发 [QFunction-0.txt] 脚本内, [@HookMagicStruck] 字段,需要在此字段进行N伤害变量修改方可实现HOOK
开启例子:
[@Login]
#IF
#ACT
HookMagicStruck 1 50 51 52
;1 设置开启回调
;50 攻击对象类型存储在N50变量里
;51 技能ID存储在N51变量里
;52 攻击伤害存储在N52里，触发的时候修改此变量可以控制伤害
关闭例子:
HookMagicStruck 0
[@开启]
#if
#act
HookStruck 1 50 51 52
[@关闭]
#if
#act
HookStruck 0

QFunction-0.txt配置

[@HookStruck]
#IF
#ACT
sendmsg 6 攻击对象类型<$STR(N50)>
sendmsg 6 技能ID<$STR(N51)>
sendmsg 6 技能伤害<$STR(N52)>


根据物品Idx获取物品数据库字段参数值：PGGetDBIdxItemFieldValue

根据物品Idx获取物品数据库字段参数值
PGGetDBIdxItemFieldValue
参数1：物品Idx
参数2：字段名
参数3：变量名，用户保存获取到的参数值
实例
[@main]
#if
#act
PGGetDBItemFieldValue 屠龙 Idx N0
PGGetDBIdxItemFieldValue Idx Weight N1
SendMsg 6 屠龙的IDX是【<$STR(N0)>】，他的重量是【<$STR(N1)>】点


根据物品名获取物品数据库字段参数值：PGGetDBItemFieldValue

根据物品名获取物品数据库字段参数值
PGGetDBItemFieldValue
参数1：物品名
参数2：字段名
参数3：变量名，用户保存获取到的参数值
实例
[@main]
#if
#act
PGGetDBItemFieldValue 屠龙 Weight N0
SendMsg 6 屠龙的重量是【<$STR(N0)>】点


杀死怪物时触发qf

功能：杀死怪物时，触发QF脚本 检测人物数据后决定是否爆出物品
命令：ESPALLOWDROP 参数1
参数1： 0=不允许掉落物品 1=允许掉落物品 不调用命令,默认不允许
常量：<$DROPITEMNAME> 杀死怪物正在爆出的物品名称
触发：在爆率中装备名字后面加|@触发字段 如：1/10 开天|@爆开天触发检测
例子：
怪物爆率文件：D:\Mirserver_GOM32\Mir200\Envir\MonItems\黑野猪教主.txt
爆率内容：
1/2 比奇传送石
1/2 万年雪霜
1/10 圣战戒指
1/10 法神戒指
1/10 天尊戒指
1/50 怒斩
1/50 逍遥扇
1/50 龙牙
1/100 屠龙|@爆稀有装备检测
1/100 嗜魂法杖|@爆稀有装备检测
1/100 命运之刃|@爆稀有装备检测
QF中脚本例子：
;检测是否为指定的物品名称
[@爆稀有装备检测]
#if
#OR
equal <$DROPITEMNAME> 屠龙
equal <$DROPITEMNAME> 嗜魂法杖
equal <$DROPITEMNAME> 命运之刃
#act
goto @爆出稀有装备条件检测
break
[@爆出稀有装备条件检测]
#if
checkgamegold < 10000
#act
;元宝小于1W，设置不允许爆出物品
ESPALLOWDROP 0
break
#elseact
;元宝大于1W，设置允许爆出物品
ESPALLOWDROP 1
支持 #CHILD 1/1 RANDOM 爆率写法


动态调整特殊状态：ChangeSP

ChangeSP
参数1：特殊属性编号 0=神秘人 1=传送 2=麻痹 3=防麻痹 4=复活 5=破复活 6=护身 7=防护身 8=技巧 9= 探测
10= 复活成功率(默认100,复活成功率0~100)
11= 麻痹几率(1~100,默认100,0也是100)
12= 防麻痹几率(1~100,默认100,0也是100)
13= 破复活几率(1~100,默认100,0也是100)
14=破护身几率(1~100,默认100,0也是100)
所有带几率的属性，如想其发挥作用,前者必须带有此属性效果,如装备带有相同属性的效果,尽量避免使用。
参数2: 0=关闭 1=开启
参数3: 持续时间 单位秒 参数0或空=无限制，参数大于0为时长，(参数1是10、11、12、13、14时,此参数3变为几率控制)
注意事项：此命令下线失效，有特殊属性的装备并不会冲突,也不会因为冲突导致失效,但应注意使用逻辑，不支持假人！！！！
场景1:带复活戒指的人物且开启了复活属性10秒，十秒复活到达后，带有复活戒指情况下，是会继续复活的，两者是不冲突
场景2:带复活戒指的人物且开启了复活属性10秒，十秒未到达前,卸掉了复活戒指，此时复活属性依然有效，除非你关闭了。
复活成功率:在原复活基础下进行判断，满足原基础复活条件下，进行几率判断，几率不满足的取消复活。
注:关闭指定属性编号,效果会立即取消，如关闭神秘人属性就会立即取消神秘人效果。
多次调用同一个属性编号，参数取最后调用，如前者设置了1000秒防复活，后者设置了10秒防复活，最终生效时间取后者(10秒，持续时间设置为0时效率最优且一直生效)。
此命令充分分析了引擎运行机制，采用最优方案进行贴合设计，效率和设计快捷性达到最完美。
到时间后触发QFunction-0.txt [@ChangeSPTimeOutX] X代表属性编号,不提供参数1的10、11、12、13、14模式的触发
=================================================================================================
赋予玩家复活成功几率(前者必须有复活属性,无时间控制,无时间到期反馈)
#ACT
ChangeSP 10 1 50
sendmsg 6 您的复活成功率更改为百分之50
赋予玩家防复活属性
#ACT
ChangeSP 5 1 10
sendmsg 6 防复活特殊属性生效，持续10秒。
QFunction-0.txt 任意位置添加
[@ChangeSPTimeOut5]
#act
sendmsg 6 防复活属性失效！！！


怪物鞭尸命令ESPMonItems

使用例子:
在QF里的[@onKillMob]使用
[@onKillMob]
#ACT
ESPMonItems
;让刚刚杀死的怪物，再次触发爆率
SENDMSG 6 ESP鞭尸触发！


全屏吸怪命令MoveMonsters

MoveMonsters
参数1：中心X
参数2：中心Y
参数3：影响范围(0-999)
参数4：目标类型(0=怪物 1=人物 2=怪物+人物)
参数5：最大吸取数量(0=不限制数量)
参数6：判断怪物等级(0=不判断，其他数值的话。怪物等级小于等于参数6吸取)
参数7：判断是否嘲讽状态（0=不判断 1=静止的怪才吸取, 避免吸取其他玩家的怪）
例子1
[@attack]
#IF
#ACT
MoveMonsters <$X> <$Y> 20 0 0 0 0
sendmsg 6 范围20的所有怪物都吸过来了
例子2
[@attack]
#IF
#ACT
MoveMonsters <$X> <$Y> 20 0 0 0 1
sendmsg 6 范围20的所有怪物都吸过来了,不包括活跃的怪物


切割命令DelMonHp、DelMonHpEx

DelMonHp
参数1=百分比或切割值
参数2=0:以当前HP的百分比 1:以参数1的值切割
2::以最大HP的百分比
参数3=0不判断嘲讽 1判断嘲讽过的怪才切割
参数4=0都切割 1:本次切割只切割角色 2:本次切割只切割英雄
3:本次切割只切割怪物
参数5=分母基数(<=100等于100)

例子1：
#ACT
；本次切割只切割怪物10点HP
DELMONHP 10 1 0 3
例子2：
#ACT
；本次切割只切割人物当前血量百分之8
DELMONHP 8 0 0 1
例子3：
#ACT
；本次切割只切割人物当前血量千分之8
DELMONHP 8 0 0 1 1000
DelMonHpEx
参数1=百分比或切割值
参数2=0:以当前HP的百分比 1:以参数1的值切割 2:以最大HP的百分比
参数3=0不判断嘲讽 1判断嘲讽过的怪才切割
参数4=0以自身范围 1以攻击目标范围
参数5=X坐标
参数6=Y坐标
参数7=范围
参数8=0都切割 1:本次切割只切割角色，2:本体切割只切割英雄，3:本次切割只切割怪物。
参数9=分母基数(<=100等于100)

例子1：
#ACT
;切割自身1格坐标范围的怪物10/100 HP
DELMONHPEX 10 2 0 0 <$X> <$Y> 1 3
例子2：
#ACT
;切割自身1格坐标范围的怪物10/1000 HP
DELMONHPEX 10 2 0 0 <$X> <$Y> 1 3 1000


获取背包内指定道具的数量命令：PGGetItemsNumber

获取背包指定物品的数量
PGGetItemsNumber
参数1：物品名字
参数2：变量名，保存获取到的物品的数量
参数3：需要的数量，如果为空或者为0，则参数2返回背包物品的数量，大于0则判断离条件数量还差多少个，如果数量满足则返回0
实例
[@main]
#if
#act
PGGetItemsNumber 疗伤药 N0
SendMsg 6 你的背包共用疗伤药【<$STR(N0)>】个
#if
#act
PGGetItemsNumber 疗伤药 N0 10
#if
Equal N0 0
#act
SendMsg 6 你需要疗伤药10个，你的背包的疗伤药数量已经足够了
#elseact
SendMsg 6 你需要疗伤药10个，你目前还缺少【<$STR(N0)>】个


获取指定人物的指定变量值信息：PGGetHumVar

PGGetHumVar
参数1：玩家名称
参数2：变量名称
参数3：保存到变量名称
实例：
[@main]
你想知道对方防御力是多少吗,并且不让他知道
请确保对方在线\ <请输入对方名字/@@InPutString2>
对方名字：<$STR(S3)> \
[@InPutString2]
#IF
#ACT
GetHumVar S3 <$MAXAC> S4
SENDMSG 6 你已成功取得对方防御力为<$STR(S4)>


脚本开关神秘人PGSetMySteriousMan

脚本开关神秘人
PGSetMySteriousMan
//参数1：开关, 1：开，0：关
注意：该功能小退恢复
实例
[@main]
#if
#act
PGSetMySteriousMan 1
SendMsg 0 你已经变成神秘人了
或者
PGSetMySteriousMan 0
SendMsg 0 你已经不是神秘人了


脚本整理背包PGQueryBag

脚本整理背包
PGQueryBag
实例
[@main]
#if
#act
PGQueryBag
SendMsg 0 你的背包已经整理好了


取随机值：PGRandomEx

PGRandomEx
参数1：随机分子
参数2：随机分母
例子：
[@main]
#if
PGRANDOMEX 17 1000
#say
千分之17的几率


血量控制检测：PGCheckHpPer、PGCheckMpPer、PGAddHpPer、PGAddMpPer

比例检测HP
PGCheckHpPer
参数1：> < =
参数2：百分比值
参数3：分母，如果该参数省略则默认按照百分比算
实例
[@main]
#if
PGCheckHpPer > 50
#act
SendMsg 6 你的血量大于50%
#elseact
SendMsg 6 你的血量不大于50%
#if
PGCheckHpPer > 50 300
#act
SendMsg 6 你的血量大于300分之50
#elseact
SendMsg 6 你的血量不大于300分之50

比例检测MP
PGCheckMpPer
参数1：> < =
参数2：百分比值
参数3：分母，如果该参数省略则默认按照百分比算
实例
[@main]
#if
PGCheckMpPer > 50
#act
SendMsg 6 你的蓝量大于50%
#elseact
SendMsg 6 你的蓝量不大于50%
#if
PGCheckMpPer > 50 300
#act
SendMsg 6 你的蓝量大于300分之50
#elseact
SendMsg 6 你的蓝量不大于300分之50

比例调整HP
PGAddHpPer
参数1：+ - =
参数2：百分比值
参数3：是否按照当前血量计算，1是0否
参数4：分母，如果该参数省略则默认按照百分比算
参数5：是否显示飘血动画，该参数只有在参数1 为－时生效 1是0否
实例
[@main]
#if
#act
PGAddHpPer + 10 1
SendMsg 6 已经帮你增加了你当前血量的10%
#if
#act
PGAddHpPer + 7 1 150
SendMsg 6 已经帮你增加了你当前血量的150分之7
半月切割脚本如下：
[@Attack]
#if
#act
M.PGAddHpPer - 1 0 10 1
SendMsg 6 你对怪物造成了了你最大血量的10%的伤害
比例调整MP
PGAddMpPer
参数1：+ - =
参数2：百分比值
参数3：是否按照当前蓝量计算，1是0否
参数4：分母，如果该参数省略则默认按照百分比算
实例
[@main]
#if
#act
PGAddMpPer + 10 1
SendMsg 6 已经帮你增加了你当前蓝量的10%
#if
#act
PGAddMpPer + 10
SendMsg 6 已经帮你增加了你最大蓝量的10%
#if
#act
PGAddMpPer + 10 1 150
SendMsg 6 已经帮你增加了你当前蓝量的150分之10


全屏吸怪PGMoveMonsters

范围吸怪
PGMoveMonsters
参数1:坐标X
参数2:坐标Y
参数3:范围
参数4:目标类型(0=怪物，1=人物，2=怪物+人物)
参数5:最大吸取数量(0=不限制)
参数6:判断怪物等级(0=不判断)

实例
[@main]
#if
#act
PGMoveMonsters <$X> <$Y> 5 0 0 0
SendMsg 0 你已经将你范围5格之类的所有怪物都吸到身边来了！


分割数字到变量：PGSplitNumber

分割数字到变量
PGSplitNumber
参数1=要分割的数字
参数2=分割后保存的变量,保存的变量格式为 变量_标记
参数3=分割后获得的数字总数保存的变量名
实例
[@main]
#if
#act
PGSplitNumber 1024520 N$分割数字 N0
SendMsg 6 <$STR(N$分割数字_1)>的值为1
SendMsg 6 <$STR(N$分割数字_2)>的值为0
SendMsg 6 <$STR(N$分割数字_3)>的值为2
SendMsg 6 <$STR(N$分割数字_4)>的值为4
SendMsg 6 <$STR(N$分割数字_5)>的值为5
SendMsg 6 <$STR(N$分割数字_6)>的值为2
SendMsg 6 <$STR(N$分割数字_7)>的值为0
SendMsg 6 一共分割获得7个数字


分割字符串：PGExtractString

分割字符串
PGExtractString
参数1：分隔符
参数2：待分割的内容
参数3：变量名，用于保存分割后的内容，内容保存在变量名_1、变量名_2、依次类推
，注意此变量只能使用扩展变量
参数4：变量名，用于保存分割得到的数量
实例
[@main]
#if
#act
PGExtractString | 测试文本1|测试文本2 S$测试变量 N0
SendMsg 0 你将文本分割了，并将分割后的内容保存在变量【S$测试变量_1】和【S$测试变量_2】中，他们的值分别是<$STR(S$测试变量_1)>和<$STR(S$测试变量_2)>，分割后共获得了【<$STR(N0)>】个内容


宝宝攻击触发

宝宝魔法攻击触发
[@PGSLAVEMAGICATTACK]

宝宝魔法受击触发
[@PGSLAVEMAGICSTRUCK]

宝宝死亡触发
[@PGSLAVEDIE]

宝宝物理攻击触发
[@PGSLAVEATTACK]

宝宝物理受击触发
[@PGSLAVESTRUCK]


怪物掉落物品时触发

新增一个QF触发，当怪物掉落物品时触发
此触发配合扩展爆率可以实现精准控制产出
[@PGDropItem]
该触发可以使用常量
<$PGDROPMONSTER> //代表爆出物品的怪物名字
<$PGDROPITEM> //代表爆出的物品名字

怪物掉落物品时触发[@pgdropitem]

支持对物品设定指定光柱,名称,字符串

[@pgdropitem]

#act

setDropBeam 光柱资源id

setDropName 掉落物名称

setDropStr s$掉落物信息

[@pickUpItemEX]

getDropStr s$掉落物信息

示例：

QF配置：

;掉落触发

[@PGDropItem]
#IF
#act
setDropBeam guangzhu1122
setDropName 雪莲精
setDropStr s$掉落物信息

;拾取触发

[@PickUpItemEx]
#IF
#ACT
getDropStr s$掉落物信息
sendmsg 6 <$str(s$掉落物信息)>


嘲讽范围内的怪物
PGDoTaunt
参数1：最大范围
参数2：最小范围
参数3：怪物等级，留空则可以嘲讽所以级别怪物
实例
[@main]
#if
#act
PGDoTaunt 5 0 100
SendMsg 6 嘲讽范围5格内的等级低于100级的怪物向你攻击
嘲讽范围内的怪物（加强）
PGDoTauntEx
参数1=最大范围
参数2=最小范围
参数3=怪物等级，写0则可嘲讽所有级别怪物
参数4=单次嘲讽数量，0表示不限制数量
参数5=1:秒血 2:冻结 3:麻痹 4:红毒 5:绿毒
参数6=参数5为1:秒血时表示秒血的百分比，参数5为其它则是对目标的伤害值
参数7=伤害时长（秒）
实例
[@main]
#if
#act
PGDoTauntEx 7 1 0 5 1 5 0
SendMsg 6 嘲讽范围7格内最多5只怪物并切割了他们5%的HP


脚本变量

<$PGPKPOWER> 当前攻击造成的伤害，该变量只可用于QF脚本
<$PGDROPMONSTER> 掉落物品的怪物名称，该变量只可用于QF脚本
<$PGDROPITEM> 掉落的物品名称，该变量只可用于QF脚本
<$PGTARGETNAME> 当前攻击对象名称
<$PGTARGETHP> 当前攻击对象血量
<$PGTARGETMAXHP> 当前攻击对象最大血量
<$PGTARGETX> 当前攻击对象X坐标
<$PGTARGETY> 当前攻击对象Y坐标
<$PGSNDAITEMBOX1>...<$PGSNDAITEMBOX12> 首饰盒1物品名称...首饰盒12物品名称
<$PGG_SNDAITEMBOX1>...<$PGG_SNDAITEMBOX12> 首饰盒1物品改名名称...首饰盒12物品改名名称
<$PGDROPMONSTER> 代表爆出物品的怪物名字
<$PGDROPITEM> 代表爆出的物品名字


PG读写配置项

PGReadConfigFileItem
备注:此功能支持绝对路径

参数1：路径
参数2：sAppName （节点名）
参数3：sKeyName （配置项）
参数4：要保存到的变量名

实例：

[@main]
#if
#act
PGReadConfigFileItem \QuestDiary\KEY.txt <$UserName> 内容 S3
SendMsg 0 你已经把配置文件KEY.txt中内容取出并保存到了S3变量

PGWriteConfigFileItem

备注:此功能支持绝对路径

参数1：路径
参数2：sAppName （节点名）
参数3：sKeyName （配置项）
参数4：要写入的内容

实例：

[@main]
#if
#act
PGWriteConfigFileItem \QuestDiary\KEY.txt <$USERNAME> 内容 <$STR(S3)>
SENDMSG 6 你已经把你输入的内容写到配置文件中KEY.txt


装备改造

模块说明
  • 根据条件,筛选出装备列表
  • 自定义对话框指定位置，生成上述装备列表
  • 点击装备列表某个单元,
    • 选中单元对应装备放入自定义装备位1
    • 改造后的装备会出现在自定义装备位2
    • 改造后 自定义装备属性 效果会显示在装备tips中，替换原有自定义装备属性

相关命令
设置装备列表模板 | setModule
将指定实例化装备，放入指定itemBox | putinBox
根据筛选条件，取出装备列表 | getEquipList
取出装备列表中第1件装备的实例化id | getEquipListFirst
设置装备自定义属性tips显示名称 | changeCustomItemText
设置装备自定义属性tips显示属性文本 | changeCustomItemabil
设置装备自定义属性数值 | changeCustomItemValue
装备列表模板定义项 | <itemInsId:
装备列表模板定义项 | <itemBoxEx:
自定义对话框中显示装备列表的属性配置 | <equipList:
预览装备tips中自定义装备属性文本设定 | <tipsPreview:

注意事项
#say命令中出现以下命令时，
<temList:
<itemGrid:
<equipList:
#say中<>模块必须以“\”结尾
参见以下脚本示例

特戒引擎脚本示例：

使用前提1
请开启配置开关"isUseCustomOKPanel"
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | isUseCustomOkPanel=1
使用前提2
请配置补丁资源"lc",即找到以下配置项,加入 lc
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | patch=aa,bb,lc
使用前提3
配置装备类型名称与显示序号
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [upGradeItem]

配置举例
[upGradeItem]
5 1 武器
10 2 衣服[男]
11 3 衣服[女]
15 4 头盔
19 5 项链
26 6 手镯
22 7 戒指
64 8 腰带
62 9 鞋子

[@main]
;--设置装备列表模板,可配置部件坐标信息.--
#act
mov s$module (<itemSize:400:150:index>
inc s$module <itemToggle:huishouwupin_xuanzhongkuang:denglu_liebiao_weixuanzhong/@装备列表点击> ;--定义装备列表单元选中与未选中图片--
inc s$module <itemInsId:instanceId> ;--道具实例id:程序项,无须定义--
inc s$module <itemBoxEx:itemId:instanceId:sourceType:equipplace:20:20:wupinkuang:looks:effectname:animation> ;--定义道具图标在装备列表单元中的坐标--
inc s$module <text:itemName{scolor=168}:140:30> ;--定义道具名称在装备列表单元中的文本属性--
inc s$module <text:itemType{scolor=25}:160:90>) ;--定义道具部位名称在装备列表单元中的文本属性--
setModule s$module

;--设定"身上"与"背包"切换按钮--
mov s$切换按钮 (
inc s$切换按钮 <itemIndex:1>
inc s$切换按钮 <itemToggle:lc_shijieliaotian_xuanzhong:lc_shijieliaotian_weixuanzhong/@身背切换(1)>
inc s$切换按钮 <text:身上装备{scolor=150}:75:50>
inc s$切换按钮 )

inc s$切换按钮 (
inc s$切换按钮 <itemIndex:2>
inc s$切换按钮 <itemToggle:lc_shijieliaotian_xuanzhong:lc_shijieliaotian_weixuanzhong/@身背切换(2)>
inc s$切换按钮 <text:背包装备{scolor=150}:75:50>
inc s$切换按钮 )

mov s$激活列表 1
goto @获取装备列表

[@获取装备列表]
#act
getEquipList 1 <$str(s$激活列表)> s$装备列表
getEquipListFirst s$装备列表
goto @右侧刷新
goto @显示界面
goto @装备列表点击

;-----------------------------------------------------------------------------
;--右侧改造界面显示数据处理--
;--此处为固定显示示例，真实应用请根据业务实例做相应改造--
;--参考装备自定义属性相关命令--
;-----------------------------------------------------------------------------
[@右侧刷新]
#if
equal <$boxItem[0].name>
#act
mov s$改造属性1 [改造属性]+0
#elseAct
mov s$改造属性1 <$boxItem[0].customText>

#if
#act
mov s$改造属性2 [改造属性]+23

mov s$item1 (<itemsize:500:325>
inc s$item1 <text:<$str(s$改造属性1)>:45:10>
inc s$item1 <text:<$str(s$改造属性2)>:275:10>
inc s$item1 <text:生命值：0:50:100>
inc s$item1 "<text:魔 防：0-0:50:150>"
inc s$item1 "<text:防 御：0-0:50:200>)"

mov s$itemList <$str(s$item1)>

;--定义预览tips显示块--
;--原始装备tips内容中自定义属性，替换为以下文本内容--
mov s$改造属性2 [改造属性]+23
mov s$item2 (<itemsize:500:325>
inc s$item2 <tipsPreview:1:<$str(s$改造属性2)>>
inc s$item2 <text:生命值：49342{scolor=250}:200:100>
inc s$item2 "<text:魔 防：444-1035{scolor=250}:200:150>"
inc s$item2 "<text:防 御：1147-2677{scolor=250}:200:200>)"

mov s$itemList2 <$str(s$item2)>

refreshItem 当前属性 1 s$item1 0
refreshItem 预览属性 1 s$item2 0

[@装备列表点击]
#if
not equal <$str(s$装备列表)>
#act
;--putinBox 物品唯一id itemBox编号 位置类型(1身上,2背包)--
putinBox <$str(s0)> 0 <$str(s$激活列表)>
putinBox <$str(s0)> 1 <$str(s$激活列表)>
goto @右侧刷新
#elseAct
returnBoxItem 0
returnBoxItem 1

[@显示界面]
#act
openMerchantBigDlg lc_chuangti 4 0 0 1 0 0
#say
<panelsize:700:600>\
<itemGrid:<$str(s$切换按钮)>:切换按钮,<$str(s$激活列表)>,0,1:10:70:220,85:1,2,90,0:1>\
<equipList:<$str(s$装备列表)>:身上装备改造,1:20:160:1,715,1:0> \

<itemBox:0:-100001:0:780:120:50:50:*:251>\
<itemBox:1:-100001:0:1000:120:50:50:*:251>\
<imgButton:lc_anniu01:750:720:装备改造/@装备改造>\

#if
not equal <$str(s$装备列表)>
#say
<itemList:<$str(s$itemList2)>:预览属性:800:200:1,300,0:5>\
<itemList:<$str(s$itemList)>:当前属性:700:200:1,310,0:5>\
#elseSay
<text:没有可改造装备:840:300>

[@身背切换]
#if
not equal s$激活列表 <$scriptParam1>
#act
mov s$激活列表 <$scriptParam1>
goto @获取装备列表

;-----------------------------------------------------------------------------
;--改造逻辑处理--
;--只支持changeCustomItem系列命令--
;--此处为固定显示示例，真实应用请根据业务实例做相应改造--
;-----------------------------------------------------------------------------
[@装备改造]
#act
changeCustomItemText -1 [改造属性]+1

changeCustomItemabil -1 0 1 1
changeCustomItemabil -1 1 1 2
changeCustomItemabil -1 5 1 6

changeCustomItemabil -1 0 0 255
changeCustomItemabil -1 1 0 255
changeCustomItemabil -1 5 0 255

changeCustomItemValue -1 0 = 10
changeCustomItemValue -1 1 = 10
changeCustomItemValue -1 5 = 100

goto @装备列表点击 ;--刷新box中的道具tips--


设置装备列表模板

setModule
设置装备列表模板

标签:命令定义|setModule

格式
命令名 | 参数1
setModule | 模板数据

说明
参数1: 模板数据

特戒引擎脚本示例：

使用前提1
请开启配置开关"isUseCustomOKPanel"
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | isUseCustomOkPanel=1
使用前提2
请配置补丁资源"lc",即找到以下配置项,加入 lc
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | patch=aa,bb,lc

[@UI数据初始]
#act
;--设置装备列表模板
mov s$module (<itemSize:400:150:index> ;定义装备列表单元宽高
inc s$module <itemToggle:huishouwupin_xuanzhongkuang:denglu_liebiao_weixuanzhong/@装备列表点击> ;定义装备列表单元选中与未选中图片
inc s$module <itemInsId:instanceId> ;道具实例id:程序项,无须定义
inc s$module <itemBoxEx:itemId:instanceId:sourceType:equipplace:20:20:wupinkuang:looks:effectname:animation> ;定义装备图标在装备列表单元中的坐标
inc s$module <text:itemName{scolor=168}:140:30> ;定义装备名称在装备列表单元中的文本属性
inc s$module <text:itemType{scolor=25}:160:90>) ;定义装备部位名称在装备列表单元中的文本属性
setModule s$module


将指定实例化装备，放入指定itemBox

putinBox
将指定实例化装备，放入指定itemBox

标签:命令定义|putinBox

格式
命令名 | 参数1 | 参数2 | 参数3
putinBox | 装备唯一id | itemBox编号 | 列表来源

说明
参数1: 装备唯一id，通过点击装备列表返回值获得

参数2: 自定义对话框中的itemBox编号

参数3: 列表来源
  • 1 身上的装备
  • 2 背包的装备


根据筛选条件，取出装备列表

getEquipList
根据筛选条件，取出装备列表

标签:命令定义|getEquipList

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6
getEquipList | 筛选类型 | 列表来源 | 装备列表返回变量 | 备选装备列表 | 指定装备类型 | 要过滤装备唯一id串
说明
  • 参数1: 筛选类型
    • 类型=1，选出全部类型装备
    • 类型=2，选出强过星的装备
      以下命令获取的星
      changeItemUpgradeCount
    • 类型=3，选出带有自定义属性(改造属性)的装备
      以下命令获得的属性
      changeCustomItemValue
    • 类型=4，选出没有自定义属性(改造属性)的装备
    • 类型=5，选出没有额外属性的装备
      参见 额外属性配置
    • 类型=6，选出有任意可转移属性的装备列表
    • 类型=7，选出有额外属性的装备
    • 类型=8，选出克隆过套装属性的装备
    • 类型=9，选出克隆过套装属性的装备
    • 类型=10，选出有极品属性的装备
      以下命令获得的属性
      changeItemAddValue upgradeItemEx tjChgItemValue
    • 类型=11，选出没有极品属性的装备
  • 参数2: 列表来源
    • 1 身上的装备
    • 2 背包的装备
  • 参数3: 装备列表返回变量
  • 参数4: 备选装备列表
    以“,”分隔的装备名称字符串，以此列表为筛选基准（缺省或-1表示全部装备）
    最后一个装备名也要加上“,”
  • 参数5: 指定装备stdMode类型，参见 StdItems
  • 参数6: 要过滤装备唯一id串，以“,”分隔的装备唯一id字符串
    标记在参数6中的装备，不会出现在列表中
  • 命令使用前提
    配置装备类型名称与显示序号
    配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
    配置节点 | [upGradeItem]
    配置举例
    [upGradeItem]
    5 1 武器
    10 2 衣服[男]
    11 3 衣服[女]
    15 4 头盔
    19 5 项链
    26 6 手镯
    22 7 戒指
    64 8 腰带
    62 9 鞋子
    120 10 时装格子1
    121 11 时装格子2
    122 12 时装格子3
    123 13 时装格子4
    124-147 14-37 隐藏装备1-24


取出装备列表中第1件装备的实例化id

getEquipListFirst
取出装备列表中第1件装备的实例化id

标签:命令定义|getEquipListFirst

格式
命令名 | 参数1
getEquipListFirst | 筛选出的装备列表变量
说明

  • 参数1: 通过 getEquipList 命令，筛选出的装备列表变量
  • 返回列表中的第1件装备唯一id，存入变量s0


装备列表模板组件，无需定义

itemInsId
装备列表模板组件，无需定义

标签:命令定义|dlg_itemInsId

格式
命令名 | 参数1
itemInsI | instanceId

参见装备列表模板设置命令 setModule


定义道具图标在装备列表单元中的坐标

itemBoxEx
定义道具图标在装备列表单元中的坐标

标签:命令定义|dlg_itemBoxEx

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6 | 参数7 | 参数8 | 参数9 | 参数10
itemBoxEx | itemId | instanceId | sourceType | equipplace | x坐标 | y坐标 | wupinkuang | looks | effectname | animation
说明
  • 参数5: 定义道具图标在装备列表单元中的x坐标
  • 参数6: 定义道具图标在装备列表单元中的6坐标
  • 其它参数无需定义

参见装备列表模板设置命令 setModule


自定义对话框中显示装备列表的属性配置

equipList
自定义对话框中显示装备列表的属性配置

标签:命令定义|dlg_equipList

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
equipList | 列表内容 | 列表名称,选中单元 | 滑动方向,列表大小,可否滑动 | 列表间隔
说明
  • 参数1: 列表内容
  • 参数2: 列表名称,选中单元
    • 列表名称 区别对话框中存在的多个同类列表
    • 当前选中序号 打开对话框时选中的是哪个列表单元
  • 参数3: 滑动方向,列表大小,可否滑动
    • 滑动方向 1 纵向，0 横向
    • 列表大小 纵向滑动时为列表高度，横向滑动时为列表宽度
    • 可否滑动 1 可滑动，0 不可滑动
  • 参数4: 列表间隔


预览装备tips中自定义装备属性文本设定

tipsPreview
自定义对话框中显示装备列表的属性配置

标签:命令定义|dlg_tipsPreview

格式
命令名 | 参数1 | 参数2
tipsPreview | itemBoxId | 装备自定义属性标题
说明
  • 参数1: 要在自定义对话框中，哪个itemBoxId内预览装备自定义属性
  • 参数2: 预览装备tips时，装备自定义属性显示的标题文本


装备属性转移

标签:模块示例|装备属性转移

模块说明
  • 根据条件,筛选出装备列表
  • 自定义对话框指定位置，生成上述装备列表
  • 点击装备列表某个单元
    • 选中单元放入原始装备栏
    • 装备列表中对应装备消失
  • 再次点击装备列表某个单元
    • 选中单元放入目标装备栏
    • 装备列表中对应装备消失
    • 继承预览栏显示目标装备
  • 选中要转移的属性，继承预览栏中道具tips会出现相应内容
  • 点击原始装备栏的道具图标，会重置原始装备栏、目标装备栏、继承预览栏
  • 点击目标装备栏的道具图标，会重置目标装备栏、继承预览栏

相关命令
设置装备列表模板 | setModule
将指定实例化装备，放入指定itemBox | putinBox
根据筛选条件，取出装备列表 | getEquipList
检测是否有可转移的指定属性 | checkTransAtt
生成属性转移预览道具tips | putinBoxPreview
转移指定装备的指定属性 | transAtt
装备列表模板定义项 | <itemInsId:
装备列表模板定义项 | <itemBoxEx:
自定义对话框中显示装备列表的属性配置 | <equipList:
设定itemBoxId预览装备属性转移tips | <tipsMergePreview:

注意事项
#say命令中出现以下命令时，
<temList:
<itemGrid:
<equipList:
#say中<>模块必须以“\”结尾
参见以下脚本示例

特戒引擎脚本示例：

使用前提1
请开启配置开关"isUseCustomOKPanel"
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | isUseCustomOkPanel=1
使用前提2
请配置补丁资源"lc",即找到以下配置项,加入 lc
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | patch=aa,bb,lc
使用前提3
配置装备类型名称与显示序号
配置文件 | ..\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [upGradeItem]

配置举例
[upGradeItem]
5 1 武器
10 2 衣服[男]
11 3 衣服[女]
15 4 头盔
19 5 项链
26 6 手镯
22 7 戒指
64 8 腰带
62 9 鞋子

[@main]
#act
;--设置装备列表模板--
mov s$module (<itemSize:400:150:index>
inc s$module <itemToggle:lc_alpha0:denglu_liebiao_weixuanzhong/@装备列表点击> ;--定义装备列表单元选中与未选中图片--
inc s$module <itemInsId:instanceId> ;--道具实例id:程序项,无须定义--
inc s$module <itemboxex:itemId:instanceId:sourceType:equipplace:20:20:wupinkuang:looks:effectname:animation> ;--定义道具图标在装备列表单元中的坐标--
inc s$module <text:itemname{scolor=168}:140:30> ;--定义道具名称在装备列表单元中的文本属性--
inc s$module <text:itemType{scolor=25}:160:90>) ;--定义道具部位名称在装备列表单元中的文本属性--
setModule s$module

;--设定"身上"与"背包"切换按钮--
mov s$切换按钮 (
inc s$切换按钮 <itemIndex:1>
inc s$切换按钮 <itemToggle:lc_shijieliaotian_xuanzhong:lc_shijieliaotian_weixuanzhong/@身背切换(1)>
inc s$切换按钮 <text:身上装备{scolor=150}:75:50>
inc s$切换按钮 )
inc s$切换按钮 (
inc s$切换按钮 <itemIndex:2>
inc s$切换按钮 <itemToggle:lc_shijieliaotian_xuanzhong:lc_shijieliaotian_weixuanzhong/@身背切换(2)>
inc s$切换按钮 <text:背包装备{scolor=150}:75:50>
inc s$切换按钮 )

mov s$激活列表 1 ;--设定初始选中"身上"页签--

goto @勾选重置
goto @获取装备列表
goto @刷新非文字
goto @刷新文字
goto @显示界面

[@勾选重置]
#act
mov n$颜色1 255
mov n$颜色2 255
mov n$颜色3 255

mov n$勾选1预制 0
mov n$勾选2预制 0

[@身背切换]
#if
not equal s$激活列表 <$scriptParam1>
#act
mov s$激活列表 <$scriptParam1>
goto @获取装备列表
goto @刷新非文字
goto @刷新文字
goto @显示界面

[@获取装备列表]
#if
equal <$boxItem[0].name>
#act
getEquipList 1 <$str(s$激活列表)> s$装备列表 -1 -1 -1 ;--原始装备列表--

#if
not equal <$boxItem[0].name>
equal <$boxItem[1].name>
#act
getEquipList 1 <$str(s$激活列表)> s$装备列表 -1 <$str(s$原始类别)> <$str(s$原始insId)>, ;--目标装备列表(过滤原始装备)--

#if
not equal <$boxItem[0].name>
not equal <$boxItem[1].name>
#act
getEquipList 1 <$str(s$激活列表)> s$装备列表 -1 <$str(s$原始类别)> <$str(s$原始insId)>,<$str(s$目标insId)>, ;--其它装备列表(过滤原始和目标装备)--

[@刷新非文字]
#act
mov s$item1 (<itemsize:500:325>
inc s$item1 <itemBox:0:-100001:0:80:0:50:50:*:251> ;--原始装备--
inc s$item1 <img:lc_alpha0:80:0:1:1/@清空box0>
inc s$item1 <imgButton:lc_anniu01:200:670:属性转移/@属性转移>
inc s$item1 <text:原始装备:75:110>
inc s$item1 <itemBox:1:-100001:0:300:0:50:50:*:251> ;--目标装备--
inc s$item1 <img:lc_alpha0:300:0:1:1/@清空box1>
inc s$item1 <itemBox:2:-100001:0:205:200:50:50:*:251> ;--预览装备--
inc s$item1 <checkBox:1:settings_markbg:settings_mark:<$str(n$勾选1预制)>:50:400/@勾选1>
inc s$item1 <checkBox:2:settings_markbg:settings_mark:<$str(n$勾选2预制)>:50:475/@勾选2>
inc s$item1 <tipsMergePreview:2>
inc s$item1 <text:目标装备:285:110>
inc s$item1 <text:继承预览:200:300>)
mov s$itemList <$str(s$item1)>

[@刷新文字]
;--此处文字为示意固定值，请根据真实情况补充文字取值逻辑--
#act
mov s$item2 (<itemsize:500:325>
inc s$item2 <itemToggle:pic:pic>
inc s$item2 "<text:[改造属性]+10 消耗9999{scolor=<$str(n$颜色1)>}:120:400>"
inc s$item2 "<text:[额外属性] 消耗9999{scolor=<$str(n$颜色2)>}:120:475>)"
mov s$itemList2 <$str(s$item2)>

[@显示界面]
#act
openMerchantBigDlg lc_chuangti 4 0 0 1 0 0
#say
<panelsize:700:600>\
<itemGrid:<$str(s$切换按钮)>:切换按钮,<$str(s$激活列表)>,0,1:10:70:220,85:1,2,90,0:1>\
<equipList:<$str(s$装备列表)>:身上装备强星,1:20:160:1,715,1:0> \
<itemList:<$str(s$itemList2)>:刷新文字:700:100:1,750,0:5>\
<itemList:<$str(s$itemList)>:刷新非文字:700:100:1,750,0:5>\

#if
equal <$str(s$装备列表)>
#say
<text:没有可转移的装备{scolor=159}:100:300>

[@装备列表点击]
;--放置目标装备--
#if
not equal <$boxItem[0].name>
equal <$boxItem[1].name>
#act
mov s$目标insId <$str(s0)>
mov s$预览激活 <$str(s$激活列表)>
putinBox <$str(s$目标insId)> 1 <$str(s$激活列表)>
goto @获取装备列表
goto @刷新非文字
goto @显示界面
goto @目标放置预览框

;--放置原始装备--
#if
equal <$boxItem[0].name>
#act
mov s$原始insId <$str(s0)>
putinBox <$str(s$原始insId)> 0 <$str(s$激活列表)>
mov s$原始类别 <$boxItem[0].stdMode>
goto @获取装备列表
goto @刷新非文字
goto @显示界面

[@清空box0]
#act
returnboxItem 0
goto @勾选重置
goto @刷新文字
goto @清空box1

[@清空box1]
#act
returnboxItem 1
returnboxItem 2
goto @获取装备列表
goto @刷新非文字
goto @显示界面

;--------------------------------------------------------------------------
;--勾选处理--
;--------------------------------------------------------------------------
[@转移属性检测]
#if
equal <$boxItem[0].name> ;--原始装备栏为空时，无转移勾选可用--
#act
mov n$可用 0
break

#if
#act
mov n$chkVar <$str(n$勾选idx)> ;--勾选idx=1，检测类型2是否可用；勾选idx=2，检测类型3是否可用；--
inc n$chkVar 1

#if
checkTransAtt <$str(s$原始insId)> <$str(n$chkVar)>
#act
mov n$可用 1
#elseAct
mov n$可用 0

[@勾选1]
#act
mov n$勾选idx 1
goto @勾选逻辑

[@勾选2]
#act
mov n$勾选idx 2
goto @勾选逻辑

[@勾选逻辑]
#act
goto @转移属性检测

#if
equal <$str(n$可用)> 0
#act
messageBox 没有可转移的改造属性
setCheckBox checkBox<$str(n$勾选idx)> 0
mov n$勾选<$str(n$勾选idx)>预制 0
goto @刷新非文字
goto @显示界面
#elseAct
mov s$勾选状态 <$checkbox<$str(n$勾选idx)>>
goto @字色刷新

[@字色刷新]
#if
equal <$str(s$勾选状态)> 1
#act
mov n$颜色<$str(n$勾选idx)> 250
mov n$勾选<$str(n$勾选idx)>预制 1

#if
equal <$str(s$勾选状态)> 0
#act
mov n$颜色<$str(n$勾选idx)> 255
mov n$勾选<$str(n$勾选idx)>预制 0

#if
#act
goto @刷新文字
refreshItem 刷新文字 1 <$str(s$item2)> 0
goto @目标放置预览框

[@目标放置预览框]
#if
not equal <$boxItem[1].name>
#act
putinBox <$str(s$目标insId)> 2 <$str(s$预览激活)>
putinBoxPreview 0,<$str(n$勾选1预制)>,<$str(n$勾选2预制)> 0 1

;--------------------------------------------------------------------------
;--执行属性转移操作，请自行补充花费处理逻辑--
;--------------------------------------------------------------------------
[@属性转移]
#if
equal <$str(n$勾选1预制)> 0
equal <$str(n$勾选2预制)> 0
#act
messageBox 未选择任何可转移的属性

#if
#act
transAtt 0,<$str(n$勾选1预制)>,<$str(n$勾选2预制)> 0 1


检测指定装备是否存在指定类型的可转移属性

checkTransAtt
检测指定装备是否存在指定类型的可转移属性

标签:命令定义|checkTransAtt

格式
命令名 | 参数1 | 参数2
checkTransAtt | 装备唯一id | 可转移属性类型

说明
  • 参数1: 装备唯一id
    通过点击自定义对话框中的<equipList:命令获得
  • 参数2: 可转移属性类型
    • 1 极品属性转移(changeItemAddValue命令影响的属性)
    • 2 改造属性转移(changeCustomItemValue命令影响的属性)
    • 3 额外属性转移(通过额外属性配置获得的属性)


自定义对话框中有tipsMergePreview标记的itemBox，生成道具tips中的属性转移预览

putinBoxPreview
自定义对话框中有tipsMergePreview标记的itemBox，生成道具tips中的属性转移预览

标签:命令定义|putinBoxPreview

格式
命令名 | 参数1 | 参数2 | 参数3
putinBoxPreview | 转移类型标记 | 原始itemBoxId | 目标itemBoxId

说明
  • 参数1: 转移类型标记
    格式如下
    是否转移类型1,是否转移类型2,是否转移类型3
    目前有3个可转移属性类型
    • 1 极品属性转移(changeItemAddValue命令影响的属性)
    • 2 改造属性转移(changeCustomItemValue命令影响的属性)
    • 3 额外属性转移(通过额外属性配置获得的属性)
    • 4 套装属性克隆
  • 参数2: 原始itemBoxId
    从该装备栏装备中转移属性出去
  • 参数3: 目标itemBoxId
    该装备栏装备接受转移的属性
  • 命令举例:
    ;--预览栏tips显示额外属性转移效果
    putinBoxPreview 0,0,1 0 1
    ;--预览栏tips显示改造及额外属性转移效果
    putinBoxPreview 0,1,1 0 1


转移原始装备栏指定可转移属性，至目标装备栏对应装备

transAtt

转移原始装备栏指定可转移属性，至目标装备栏对应装备

标签:命令定义|transAtt

格式
命令名 | 参数1 | 参数2 | 参数3
transAtt | 转移类型标记 | 原始itemBoxId | 目标itemBoxId

说明
  • 参数1: 转移类型标记
    格式如下
    是否转移类型1,是否转移类型2,是否转移类型3,是否转移类型4
    目前有4个可转移属性类型
    • 1 极品属性转移(changeItemAddValue命令影响的属性)
    • 2 改造属性转移(changeCustomItemValue命令影响的属性)
    • 3 额外属性转移(通过额外属性配置获得的属性)
    • 4 装备星数 参见 changeItemUpgradeCount getItemStarNum
  • 参数2: 原始itemBoxId
    从该装备栏装备中转移属性出去
  • 参数3: 目标itemBoxId
    该装备栏装备接受转移的属性
  • 命令举例:
    ;--目标装备栏接受额外属性转移
    transAtt 0,0,1 0 1
    ;--目标装备栏接受改造及额外属性转移
    transAtt 0,1,1 0 1


定义装备属性转移预览itemBoxId

tipsMergePreview
定义装备属性转移预览itemBoxId
在哪个itemBox生成预览属性转移tips

标签:命令定义|dlg_tipsMergePreview

格式
命令名 | 参数1
tipsMergePreview | itemBoxId


道具筛选框组件

模块说明
呼出一个道具筛选框，可自定义行列数
可定义哪些道具出现在筛选框中
点击组件中的按钮，返回选中道具名称列表，以“,”分隔

相关命令
getcanInputItemList
setcanInputItem
getAllInputItem

相关qfunction触发器
[@canInputItemList]
点击筛选框单元格时，单元处于可勾选状态时触发

[@canPutoffItemList]
点击筛选框单元格时，单元处于可取消勾选状态时触发

特戒引擎脚本示例：

[@main]
#act
mov n$打开筛选 1
;--配置置筛选框面板--
;panel:坐标x,坐标y:行,列:边长:选中图(对勾),未选中图(单元格底板):底板:间隔:面板宽,面板高:筛选列表x偏移,筛选列表y偏移
mov s$panel panel:0,0:5,2:100:settings_mark,settings_markbg:ok_di:10:650,400:0,0

;--配置置筛选框按钮--
;--button:坐标x,坐标y:图片:文字,颜色,字号
mov s$button button:160,-130:anniu_hui_4zi:放入,250,30

;--创建道具筛选框--
;getcanInputItemList 类型(0背包 1身上) 获取的最大数量 面板数据 按钮数据 筛选物品列表id,id,id, qf触发器
mov s$tmp 3,4,5,6,7,2001,
getcanInputItemList 0 10 <$str(s$panel)> <$str(s$button)> <$str(s$tmp)> %{color:green}放入

;--..\Mir200\Envir\Market_Def\QFunction-0.txt--
[@canInputItemList]
#act
setcanInputItem n0 1
print 勾选了<$str(n0)>
%nbsp;
[@canPutoffItemList]
#if
equal n$打开筛选 1
#act
setcanInputItem n0 0
print 取消了<$str(n0)>

[@放入]
#act
mov n$打开筛选 0
getAllInputItem s0
messagebox 勾选道具列表:\\<$str(s0)>


设置筛选列表，从背包中获取指定id的对应物品

getCanInputItemList

设置筛选列表，从背包中获取指定id的对应物品

标签:命令定义|getCanInputItemList

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4 | 参数5 | 参数6
getCanInputItemList | 获取对象类型 | 筛选栏最大数量 | 面板数据 | 按钮数据 | 筛选的物品id | QF触发器
说明:
  • 参数1: 获取对象类型
    • 1：装备栏
    • 0：背包
  • 参数2: 筛选栏格子的最大数量
  • 参数3: 面板相关数据，格式如下：
    panel:坐标x,坐标y:行,列:边长:选中图(对勾),未选中图(单元格底板):底板:间隔:面板宽,面板高:筛选列表x偏移,筛选列表y偏移
    举例
    mov s$panel panel:0,0:5,2:100:settings_mark,settings_markbg:ok_di:10:650,400:50,-50
  • 参数4: 按钮相关数据，格式如下：
    button:坐标x,坐标y:图片:文字,颜色,字号
    举例
    mov s$button button:160,-130:anniu_hui_4zi:放入,250,30
  • 参数5: 筛选物品idx，多个idx用逗号隔开，参见 StdItems
  • 参数6: 自定义Qfunction触发器，不用加@


设置筛选框的选中状态

setCanInputItem

点击格子时触发QF中的触发器[@canInputItemList]或[@canPutoffItemList]
通过本命令设置筛选框的选中状态。

标签:命令定义|setCanInputItem

格式
命令名 | 参数1 | 参数2
setCanInputItem | 筛选栏序号 | 勾选状态
说明:
  • 参数1: 筛选栏序号
  • 参数2: 勾选状态
    • 1：勾选
    • 0：未勾选


返回所有勾选的物品的名称，用逗号分隔并存入变量中

getAllInputItem

点击道具筛选框组件上的按钮时，触发qfunction中的按钮自定义触发器。
在触发器中使用本命令，返回所有勾选的物品的名称，用逗号分隔并存入变量中。

标签:命令定义|getAllInputItem

格式
命令名 | 参数1
getAllInputItem | 返回变量
说明:
  • 参数1
    变量，用于保存勾选的物品名称列表，用逗号分隔。


自定义装备属性

命令描述 | 命令名称
赋值指定装备位,自定义装备属性的文本标题 | changeCustomItemText
获取指定装备位,自定义装备属性的文本标题 | getCustomItemText
赋值指定装备位,自定义装备属性的文本标题颜色 | changeCustomItemTextColor
获取指定装备位,自定义装备属性的文本标题颜色 | getCustomItemTextColor
指定自定义装备属性，绑定指定显示属性 | changeCustomItemAbil
设定自定义装备属性数值 | changeCustomItemValue
获取指定装备位装备的,指定id自定义装备属性值 | getCustomItemValue
检测指定装备位,自定义装备属性数值,是否满足条件 | checkCustomItemValue
检测指定装备位,自定义装备属性绑定显示id,是否满足条件 | checkCustomItemValueType
获取角色身上自定义装备属性数值之和 | getHumCustomItemValue


设定自定义装备属性标题文本

changeCustomItemText
设定自定义装备属性标题文本

标签:命令定义|changeCustomItemText

格式
命令名 | 参数1 | 参数2
changeCustomItemText | 装备位id | 标题文本字符串
说明:
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见装备位id说明装备位置
    • -1
      当前打开的自定义道具栏中的道具
      当前拾取道具
  • 参数2: 设定的标题文本字符串

特戒引擎脚本示例：

[@main]
#if
equal <$dress>
#act
messageBox 特戒提示:请穿上衣服再来测试!
break

#if
#say
<自定义装备属性测试>\ \
<装备位:衣服>\ \

<赋值属性文本标题/@@inputString0>\ \
<获取属性文本标题/@获取文字>\ \

<赋值属性文本标题颜色/@@inputInteger0>\ \
<获取属性文本标题颜色/@标题颜色>\ \

<打开角色界面,看下衣服tips/@角色界面>\ \
<绑定显示属性且赋值/@属性赋值>\ \

[@inputString0]
#act
changeCustomItemText 0 s0
;print命令在控制台输出文件内容
print 赋值为<$str(s0)>

[@获取文字]
#act
getCustomItemText 0 s0
print s0

[@inputInteger0]
#or
small n0 0
large n0 255
#act
sendMsg 6 请输入[0-255]颜色编码
break

#if
#act
changeCustomItemTextColor 0 n0
sendMsg 6 自定义装备属性文本标题颜色赋值完毕

[@标题颜色]
#act
getCustomItemTextColor 0 n0
print 文本标题颜色id:<$str(n0)>

[@角色界面]
#act
openSysUi 1 0

[@属性赋值]
#act
;衣服栏 属性0 绑定maxDc(显示id3)
changeCustomItemAbil 0 0 1 3
changeCustomItemValue 0 0 = 222222

;衣服栏 属性1 绑定显示id8
changeCustomItemAbil 0 1 1 8
changeCustomItemValue 0 1 = 11111

sendMsg 6 自定义装备属性赋值完毕


获取自定义装备属性标题文本

getCustomItemText
获取自定义装备属性标题文本

标签:命令定义|getCustomItemText

格式
命令名 | 参数1 | 参数2
getCustomItemText | 装备位id | 返回值变量
说明
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见 装备位id说明
    • -1
      当前打开的自定义道具栏中的道具
      当前拾取道具
  • 参数2: 标题文本字符串返回值变量

特戒引擎脚本示例：

[@main]
#if
equal <$dress>
#act
messageBox 特戒提示:请穿上衣服再来测试!
break

#if
#say
<自定义装备属性测试>\ \
<装备位:衣服>\ \

<赋值属性文本标题/@@inputString0>\ \
<获取属性文本标题/@获取文字>\ \

<赋值属性文本标题颜色/@@inputInteger0>\ \
<获取属性文本标题颜色/@标题颜色>\ \

<打开角色界面,看下衣服tips/@角色界面>\ \
<绑定显示属性且赋值/@属性赋值>\ \

[@inputString0]
#act
changeCustomItemText 0 s0
;print命令在控制台输出文件内容
print 赋值为<$str(s0)>

[@获取文字]
#act
getCustomItemText 0 s0
print s0

[@inputInteger0]
#or
small n0 0
large n0 255
#act
sendMsg 6 请输入[0-255]颜色编码
break

#if
#act
changeCustomItemTextColor 0 n0
sendMsg 6 自定义装备属性文本标题颜色赋值完毕

[@标题颜色]
#act
getCustomItemTextColor 0 n0
print 文本标题颜色id:<$str(n0)>

[@角色界面]
#act
openSysUi 1 0

[@属性赋值]
#act
;衣服栏 属性0 绑定maxDc(显示id3)
changeCustomItemAbil 0 0 1 3
changeCustomItemValue 0 0 = 222222

;衣服栏 属性1 绑定显示id8
changeCustomItemAbil 0 1 1 8
changeCustomItemValue 0 1 = 11111

sendMsg 6 自定义装备属性赋值完毕


设定自定义装备属性标题文本颜色

changeCustomItemTextColor
设定自定义装备属性标题文本颜色

标签:命令定义|changeCustomItemTextColor

格式
命令名 | 参数1 | 参数2
changeCustomItemTextColor | 装备位id | 颜色编码id
说明:
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见装备位id说明装备位置
    • -1
      当前打开的自定义道具栏中的道具
      当前拾取道具
  • 参数2: 颜色编码id[0-255]

特戒引擎脚本示例：

[@main]
#if
equal <$dress>
#act
messageBox 特戒提示:请穿上衣服再来测试!
break

#if
#say
<自定义装备属性测试>\ \
<装备位:衣服>\ \

<赋值属性文本标题/@@inputString0>\ \
<获取属性文本标题/@获取文字>\ \

<赋值属性文本标题颜色/@@inputInteger0>\ \
<获取属性文本标题颜色/@@标题颜色>\ \

<打开角色界面,看下衣服tips/@角色界面>\ \
<绑定显示属性且赋值/@属性赋值>\ \

[@inputString0]
#act
changeCustomItemText 0 s0
;print命令在控制台输出文件内容
print 赋值为<$str(s0)>

[@获取文字]
#act
getCustomItemText 0 s0
print s0

[@inputInteger0]
#or
small n0 0
large n0 255
#act
sendMsg 6 请输入[0-255]颜色编码
break

#if
#act
changeCustomItemTextColor 0 n0
sendMsg 6 自定义装备属性文本标题颜色赋值完毕

[@标题颜色]
#act
getCustomItemTextColor 0 n0
print 文本标题颜色id:<$str(n0)>

[@角色界面]
#act
openSysUi 1 0

[@属性赋值]
#act
;衣服栏 属性0 绑定maxDc(显示id3)
changeCustomItemAbil 0 0 1 3
changeCustomItemValue 0 0 = 222222

;衣服栏 属性1 绑定显示id8
changeCustomItemAbil 0 1 1 8
changeCustomItemValue 0 1 = 11111

sendMsg 6 自定义装备属性赋值完毕


获取自定义装备属性标题文本颜色

getCustomItemTextColor
获取自定义装备属性标题文本颜色

标签:命令定义|getCustomItemTextColor

格式
命令名 | 参数1 | 参数2
getCustomItemTextColor | 装备位id | 颜色编码id
说明:
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见装备位id说明装备位置
    • -1
      当前打开的自定义道具栏中的道具
      当前拾取道具
  • 参数2: 颜色编码id[0-255]

特戒引擎脚本示例：

[@main]
#if
equal <$dress>
#act
messageBox 特戒提示:请穿上衣服再来测试!
break

#if
#say
<自定义装备属性测试>\ \
<装备位:衣服>\ \

<赋值属性文本标题/@@inputString0>\ \
<获取属性文本标题/@获取文字>\ \

<赋值属性文本标题颜色/@@inputInteger0>\ \
<获取属性文本标题颜色/@@标题颜色>\ \

<打开角色界面,看下衣服tips/@角色界面>\ \
<绑定显示属性且赋值/@属性赋值>\ \

[@inputString0]
#act
changeCustomItemText 0 s0
;print命令在控制台输出文件内容
print 赋值为<$str(s0)>

[@获取文字]
#act
getCustomItemText 0 s0
print s0

[@inputInteger0]
#or
small n0 0
large n0 255
#act
sendMsg 6 请输入[0-255]颜色编码
break

#if
#act
changeCustomItemTextColor 0 n0
sendMsg 6 自定义装备属性文本标题颜色赋值完毕

[@标题颜色]
#act
getCustomItemTextColor 0 n0
print 文本标题颜色id:<$str(n0)>

[@角色界面]
#act
openSysUi 1 0

[@属性赋值]
#act
;衣服栏 属性0 绑定maxDc(显示id3)
changeCustomItemAbil 0 0 1 3
changeCustomItemValue 0 0 = 222222

;衣服栏 属性1 绑定显示id8
changeCustomItemAbil 0 1 1 8
changeCustomItemValue 0 1 = 11111

sendMsg 6 自定义装备属性赋值完毕


指定自定义装备属性,绑定指定显示属性

changeCustomItemAbil

指定自定义装备属性,绑定指定显示属性

标签:命令定义|changeCustomItemAbil

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
changeCustomItemAbil | 装备位Id | 自定义装备属性id | 绑定类型1 | 绑定类型2
说明
  • 参数1:装备位Id
    • 0-16 参见装备位id说明装备位置
    • -1:自定义属性编号
      • 当前打开的自定义道具栏中的道具
      • 当前拾取道具
  • 参数2: 自定义装备属性id
    每件装备可设定10个自定义属性
    编号从0到9
  • 参数3=0
    参数4 : 表示属性显示颜色id
  • 参数3=1
    参数4 : 表示绑定显示属性id
  • 参数3=2
    参数4 : 表示属性框中显示位置
  • 参数3=3
    参数4 : 表示是常规数值还是百分比数值

特戒引擎脚本示例：

示例1

[@main]
#act
;--武器栏 属性1 绑定 maxDc
changeCustomItemAbil 1 1 1 3
changeCustomItemValue 1 1 = 222222

示例2
使用前提
请开启配置开关"useMinCustomItemValue"
配置文件 | .\Mir200\Tejieconfig\Tejieconfig.txt
配置节点 | [tjconfig]
配置项 | useMinCustomItemValue=1

[@main]
#act
;--武器栏 属性1 绑定 dc
;--攻击上限配置
changeCustomItemAbil 1 1 1 3
changeCustomItemValue 1 1 = 222222
;--武器栏 属性1 绑定 maxDc
;--攻击下限配置
changeCustomItemAbil 1 2 1 20
changeCustomItemValue 1 2 = 111

游戏效果 | 配置信息

显示属性说明

显示属性文本编辑工具
tejiePlatform_选项_客户端设置_自定义属性

绑定显示属性id
  • 角色基础属性上限
    1 | 2 | 3 | 4 | 5 | 6 | 7
    maxAc | maxMac | maxDc | maxMc | maxSc | maxHp | maxMp
  • 角色基础属性下限
    ..\Mir200\Tejieconfig\Tejieconfig.txt
    添加启用下限显示配置项
    配置项 [tjconfig]
    配置内容 useMinCustomItemValue=1
    18 | 19 | 20 | 21 | 22
    ac | mac | dc | mc | sc
  • 装备自定义属性
    8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17
    无属性显示1 | 无属性显示2 | 无属性显示3 | 无属性显示4 | 无属性显示5 | 无属性显示6 | 无属性显示7 | 无属性显示8 | 无属性显示9 | 无属性显示10


设定自定义装备属性数值

changeCustomItemValue
设定自定义装备属性数值

标签:命令定义|changeCustomItemValue

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
changeCustomItemValue | 装备位id | 自定义属性编号 | 操作符(+,-,=) | 操作值
说明
  • 参数1
    装备栏Id
    • 0-16 参见装备位id说明装备位置
    • -1:自定义属性编号
      • 当前打开的自定义道具栏中的道具
      • 当前拾取道具
  • 参数2
    每件装备可设定10个自定义属性
    编号从0到9
  • 参数3
    对自定义属性的数值进行操作
    可以进行+,-,=操作
  • 参数4
    对自定义属性的数值操作的具体数值

脚本示例：

[@main]
#if
not equal <$dress>
#act
;--装备栏0(衣服)对应装备:自定义属性0赋值9527;自定义属性1赋值1024
changeCustomItemValue 0 0 = 9527
changeCustomItemValue 0 1 = 1024

mov n1 0
mov n2 0
;--获取装备栏0(衣服)对应装备,自定义属性0常规数值与百分比数值
getCustomItemValue 0 0 n1 n2
sendMsg 6 自定义属性0的常规数值:<$str(n1)>
sendMsg 6 自定义属性0的百分比数值:<$str(n2)>

mov n1 0
mov n2 0
;--获取装备栏0(衣服)对应装备,自定义属性1常规数值与百分比数值
getCustomItemValue 0 1 n1 n2
sendMsg 6 自定义属性1的常规数值:<$str(n1)>
sendMsg 6 自定义属性1的百分比数值:<$str(n2)>

#elseAct
sendMsg 6 角色穿上衣服再测试!


获取指定装备位装备的指定id自定义装备属性值

getCustomItemValue
获取指定装备位装备的指定id自定义装备属性值

标签:命令定义|getCustomItemValue

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
getCustomItemValue | 装备位id | 自定义装备属性id | 返回值1 | 返回值2
说明
  • 参数1: 装备位Id
    • 0-16 参见装备栏id说明装备位置
    • -1:自定义属性编号
      • 当前打开的自定义道具栏中的道具
      • 当前拾取道具
  • 参数2: 每件装备可设定10个自定义装备属性id(编号从0到9)
  • 参数3: 返回值1
    存储指定id自定义装备属性常规数值
  • 参数4: 返回值2
    存储指定id自定义装备属性百分比数值

脚本示例：

[@main]
#if
equal <$dress>
sendMsg 6 角色穿上衣服再测试!

#if
#act
;--装备栏0(衣服)对应装备:自定义属性0赋值9527;自定义属性1赋值1024
changeCustomItemValue 0 0 = 9527
changeCustomItemValue 0 1 = 1024

mov n1 0
mov n2 0
;--获取装备栏0(衣服)对应装备,自定义属性0常规数值与百分比数值
getCustomItemValue 0 0 n1 n2
sendMsg 6 自定义属性0的常规数值:<$str(n1)>
sendMsg 6 自定义属性0的百分比数值:<$str(n2)>

mov n1 0
mov n2 0
;--获取装备栏0(衣服)对应装备,自定义属性1常规数值与百分比数值
getCustomItemValue 0 1 n1 n2
sendMsg 6 自定义属性1的常规数值:<$str(n1)>
sendMsg 6 自定义属性1的百分比数值:<$str(n2)>


检测指定装备位,自定义装备属性数值,是否满足条件

checkCustomItemValue
检测指定装备位,自定义装备属性数值,是否满足条件

标签:命令定义|checkCustomItemValue

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
checkCustomItemValue | 装备位id | 自定义装备属性id | 比较符 | 比较值
说明
  • 参数1: 装备位Id
    • 0-16 参见装备栏id说明装备位置
    • -1:自定义属性编号
      • 当前打开的自定义道具栏中的道具
      • 当前拾取道具
  • 参数2: 每件装备可设定10个自定义装备属性id(编号从0到9)
  • 参数3: 比较符(> < =)
  • 参数4: 比较值

脚本示例：

[@main]
#if
equal <$dress>
#act
messageBox 特戒提示:请穿上衣服再来测试!
break

#if
#say
<自定义装备属性测试>\ \
<装备位:衣服>\ \

<绑定显示属性且赋值/@属性赋值>\ \
<打开角色界面,看下衣服tips/@角色界面>\ \

<检测自定义装备属性值/@检测属性值>\ \
<检测自定义装备属性绑定显示id/@检测显示id>\ \

[@角色界面]
#act
openSysUi 1 0

[@属性赋值]
#act
;衣服栏 属性0 绑定maxDc(显示id3)
changeCustomItemAbil 0 0 1 3
changeCustomItemValue 0 0 = 222222

;衣服栏 属性1 绑定显示id8
changeCustomItemAbil 0 1 1 8
changeCustomItemValue 0 1 = 11111

sendMsg 6 自定义装备属性赋值完毕

[@检测属性值]
#if
checkCustomItemValue 0 0 > 200000
#act
sendMsg 6 装备位衣服的自定义属性0,大于200000

#if
checkCustomItemValue 0 1 = 11111
#act
sendMsg 6 装备位衣服的自定义属性1,等于11111

[@检测显示id]
#if
checkCustomItemValueType 0 0 = 3
#act
sendMsg 6 装备位衣服的自定义属性0,绑定了显示id3

#if
checkCustomItemValueType 0 1 > 3
#act
sendMsg 6 装备位衣服的自定义属性0,绑定了大于3的显示id


检测指定装备位,自定义装备属性绑定显示id,是否满足条件

checkCustomItemValueType
检测指定装备位,自定义装备属性数值,是否满足条件

标签:命令定义|checkCustomItemValueType

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
checkCustomItemValueType | 装备位id | 自定义装备属性id | 比较符 | 待比较绑定显示id
说明
  • 参数1: 装备位Id
    • 0-16 参见装备栏id说明 装备位置
    • -1:自定义属性编号
      • 当前打开的自定义道具栏中的道具
      • 当前拾取道具
  • 参数2: 每件装备可设定10个自定义装备属性id(编号从0到9)
  • 参数3: 比较符(> < =)
  • 参数4: 待比较绑定显示id,参见 绑定显示id说明

脚本示例：

[@main]
#if
equal <$dress>
#act
messageBox 特戒提示:请穿上衣服再来测试!
break

#if
#say
<自定义装备属性测试>\ \
<装备位:衣服>\ \

<绑定显示属性且赋值/@属性赋值>\ \
<打开角色界面,看下衣服tips/@角色界面>\ \

<检测自定义装备属性值/@检测属性值>\ \
<检测自定义装备属性绑定显示id/@检测显示id>\ \

[@角色界面]
#act
openSysUi 1 0

[@属性赋值]
#act
;衣服栏 属性0 绑定maxDc(显示id3)
changeCustomItemAbil 0 0 1 3
changeCustomItemValue 0 0 = 222222

;衣服栏 属性1 绑定显示id8
changeCustomItemAbil 0 1 1 8
changeCustomItemValue 0 1 = 11111

sendMsg 6 自定义装备属性赋值完毕

[@检测属性值]
#if
checkCustomItemValue 0 0 > 200000
#act
sendMsg 6 装备位衣服的自定义属性0,大于200000

#if
checkCustomItemValue 0 1 = 11111
#act
sendMsg 6 装备位衣服的自定义属性1,等于11111

[@检测显示id]
#if
checkCustomItemValueType 0 0 = 3
#act
sendMsg 6 装备位衣服的自定义属性0,绑定了显示id3

#if
checkCustomItemValueType 0 1 > 3
#act
sendMsg 6 装备位衣服的自定义属性0,绑定了大于3的显示id


获取角色身上,绑定了相同显示属性id的,某指定id自定义装备属性之和.

getHumCustomItemValue
获取角色身上,绑定了相同显示属性id的,某指定id自定义装备属性之和.

举例
获取自定义装备属性0之和,且都绑定了显示属性id1

标签:命令定义|getHumCustomItemValue

格式
命令名 | 参数1 | 参数2 | 参数3 | 参数4
getHumCustomItemValue | 自定义属性id | 绑定显示属性id | 返回变量1 | 返回变量2
说明
  • 参数1: 指定的自定义装备属性id(0-9)
    每件装备可设定10个自定义装备属性,id从0到9
  • 参数2: 绑定显示属性id(0-17)
    指定id的自定义装备属性,通过changeCustomItemAbil命令绑定了哪个显示属性id
    0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
    无绑定 | 绑定AC | 绑定MAC | 绑定DC | 绑定MC | 绑定SC | 绑定MaxHp | 绑定MaxMp
    8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17
    无属性显示1 | 无属性显示2 | 无属性显示3 | 无属性显示4 | 无属性显示5 | 无属性显示6 | 无属性显示7 | 无属性显示8 | 无属性显示9 | 无属性显示10
  • 参数3: 返回角色身上指定id,自定义装备属性的常规数值和,这些装备均绑定了参数2
    举例
    角色穿的衣服上自定义属性0(绑定了显示属性id1),常规数值为10
    角色穿的武器上自定义属性0(绑定了显示属性id1),常规数值为20
    角色身上没有其它设定了自定义属性0的装备
    获取绑定了显示属性id1的自定义属性0时,参数3返回30
  • 参数4: 返回角色身上指定id,自定义装备属性的百分比数值和,这些装备均绑定了参数2
    举例
    角色穿的项链上自定义属性1(绑定了显示属性id2),百分比数值为5
    角色穿的腰带上自定义属性1(绑定了显示属性id2),百分比数值为15
    角色身上没有其它设定了自定义属性1的装备
    获取绑定了显示属性id2的自定义属性1时,参数4返回20

特戒引擎脚本示例：

[@main]
#or
equal <$dress>
equal <$weapon>
#act
sendMsg 6 角色穿戴衣服与武器后再测试!
break

#if
#act

;--装备栏0(衣服) 自定义属性0 绑定显示属性id8
changeCustomItemAbil 0 0 1 8
;--装备栏0(衣服)对应装备:自定义属性0赋值9527
changeCustomItemValue 0 0 = 9527

;--装备栏1(武器) 自定义属性1 绑定显示属性id8
changeCustomItemAbil 1 0 1 8
;--装备栏1(武器)对应装备:自定义属性0赋值1
changeCustomItemValue 1 0 = 1

;--装备栏0(衣服) 自定义属性1 绑定显示属性id9
changeCustomItemAbil 0 1 1 9
;--装备栏0(衣服)对应装备:自定义属性1赋值1024
changeCustomItemValue 0 1 = 1024

mov n1 0
mov n2 0
;--自定义属性id(-1表示10个属性全部获取,0~9装备自定义10个属性） 绑定显示属性id 变量1 变量2
getHumCustomItemValue 0 8 n1 n2
sendMsg 6 自定义属性0的常规数值:<$str(n1)>
sendMsg 6 自定义属性0的百分比数值:<$str(n2)>

mov n1 0
mov n2 0
;--自定义属性id(-1表示10个属性全部获取,0~9装备自定义10个属性） 绑定显示属性id 变量1 变量2
getHumCustomItemValue 1 9 n1 n2
sendMsg 6 自定义属性1的常规数值:<$str(n1)>
sendMsg 6 自定义属性1的百分比数值:<$str(n2)>


装备额外属性

额外属性配置
给指定装备配置额外属性
属性效果会出现在该装备tips中
该属性可转移给其它装备
getItemEff命令可检测装备栏中的额外属性id，可根据此id编写脚本软件，实现属性效果

标签:文件定义|额外属性配置

文件路径
..\Mir200\Envir\额外属性配置.txt

文件字段说明
1 | 2 | 3
道具名 | 额外属性id | 额外属性效果描述
说明
  • 字段1: 配置额外属性的道具名称
  • 字段2: 本条额外属性的id
  • 字段3: 本条额外属性的tips效果描述
    • 格式举例
      \146/[额外属性]\146/防御+8%\146/附加闪现效果
      说明
      “\颜色编码id/文本内容” 换行并定义文字颜色
相关命令
获取指定唯一id装备的额外属性id | getExtraAtt
删除指定唯一id装备的额外属性 | delExtraAtt
获取指定装备位置id的额外属性效果id | getItemEff
检测指定装备,是否有指定id的额外属性 | checkItemEff
选出有额外属性的装备 | getEquipList
检测是否有可转移的指定属性 | checkTransAtt
生成属性转移预览道具tips | putinBoxPreview
转移指定装备的指定属性 | transAtt

特戒引擎文件示例：

文件路径: ..\Mir200\Envir\额外属性配置.txt

新手·剑 1 \146/[额外属性]\146/防御+8%,魔防+8%
新手·甲 2 \146/[额外属性]\146/生命上限+2%\146/附加闪现效果


获取指定唯一id装备的额外属性id

getExtraAtt
获取指定唯一id装备的额外属性id

标签:命令定义|getExtraAtt

格式
命令名 | 参数1 | 参数2
getExtraAtt | 装备唯一id | 返回变量

说明
  • 参数1: 装备唯一id，通过 setModule 命令设置 itemToggle 触发跳转获取
    参见 装备列表 [@装备列表点击]
  • 参数2: 返回变量，存储获得的额外属性id
    没有额外属性,返回-1


删除指定唯一id装备的额外属性

delExtraAtt
删除指定唯一id装备的额外属性

标签:命令定义|delExtraAtt

格式
命令名 | 参数1
delExtraAtt | 装备唯一id

说明
  • 参数1: 装备唯一id，通过 setModule 命令设置 itemToggle 触发跳转获取
    参见 装备列表 [@装备列表点击]


获取指定装备位id的额外属性效果id

getItemEff

获取指定装备位id的额外属性效果id

标签:命令定义|getItemEff

格式
命令名 | 参数1 | 参数2
getItemEff | 装备位id | 返回变量

说明
  • 参数1: 装备位id,参见 装备位id说明
    • 命令支持的装备位id
      • 0-16，24，25，26 （角色装备）
      • 17，18，20-23 （时装装备）
      • 30-41 （生肖装备）
      • 51-56 （神佑首饰盒装备）
      • 60-83 （ok框用装备位）
  • 参数2: 返回变量，存储返回的额外属性id
    没有额外属性,返回-1

特戒引擎脚本示例：

[@main]
#act
;--获取身上武器额外属性1id--
getItemEff 1 n1

#if
equal n1 -1
#act
;print命令在控制台输出文件内容
print 身上武器_额外属性_检测结果-->无
#elseAct
print 身上武器_额外属性_检测结果-->额外属性_<$str(n1)>


检测指定id装备位中的装备,是否有指定id的额外属性

checkItemEff
检测指定id装备位中的装备,是否有指定id的额外属性

标签:命令定义|checkItemEff

格式
命令名 | 参数1 | 参数2
checkItemEff | 装备位id | 检测值

说明
  • 参数1: 装备位id
    • 0-16 指定id装备位中的道具
      参见装备位id说明装备位置
  • 参数2: 检测是否有检测值对应的额外属性id

特戒引擎脚本示例：

[@main]
#if
;--检测身上武器是否有额外属性1--
checkItemEff 1 1
#act
;print命令在控制台输出文件内容
print 身上武器_额外属性1_检测结果-->有
#elseAct
print 身上武器_额外属性1_检测结果-->无